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Overview

This presentation is focusing on producing the specific output files used by
contractors for Automated Machine Guidance (AMG); specifically the geometrics
files, CAD files, existing and proposed features, and the surface model files.

Topics Covered Include:
¢ What will be q red.

¢ How to generate required files.
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Session Objectives

» What information is required for AMG operators? - Basic requirements for AMG
operations.

» How models are prepared and exported to AMG operators — Examine how Alignment
data, Proposed, Existing and Finished graded surfaces are exported to LandXML.
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What information is required for AMG operators?

¢ Contract Plans

v Multiple DGN\DWG Files — See CPCH for names and content. A PDF of
the Contract Plans is to be Signed and Sealed using Digital Signature.

¢ Existing Planimetrics (2D and 3D)
v TOPORD.DGN - 2D & 3D existing topography
v DREXRD.DGN - 2D & 3D existing drainage
v UTEXRD.DGN — 2D & 3D existing utilities

o 3D Existing Surface(s)
v GDTMRD.DGN - 3D existing surfaces triangles
v LandXML of the existing (Ground) surface
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What information is required for AMG operators?

+ Alignments

v ALGNRD.DGN\DWG - 2D file of Alignments and stationing and LandXML file of the
alignment data.

¢ 2D Proposed Planimetrics
v DSGNRD. DGN\DWG - 2D proposed roadway design
v DRPRRD. DGN\DWG - 2D proposed drainage design
v" PDPLRD. DGN\DWG - 2D proposed pond design

¢ 3D Proposed Surface(s)

v' AMGMRD. DGN\DWG — 3D proposed roadway model top surface (3D break lines can be
together or in separate files).

v" LandXML of the Proposed (Top) surface.

¢ 3D Proposed Break Lines
v' AMGMRD. DGN\DWG - 3D proposed roadway break lines
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File Location and Naming

+ Alignments\Profiles

¢ Planimetrics
v' Existing
v Proposed

¢ Surfaces

¢ Break Lines
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3D DELIVERABLES SUPPORTING AMG FOR 3D PROJECTS

File Name

(put in .\3DDeliverables)

Description

Alignments and Profiles

AMG-ALGNXX.xml

All alignments extracted from the .\Roadway\ALGNRD file

AMG-ALGNXX.xml

All Profiles extracted from the .\Roadway\DSPFRD or
.\\Roadway\CORRRD file

2D Proposed Planimetrics Design

AMG-2DSGNXX.dwg/dgn

2D proposed Roadway design extracted from the .\Roadway\DSGNRD
file

AMG-2DRPRXX.dwg/dgn

2D proposed Drainage design extracted from the .\Roadway\DRPRRD
file

AMG-2PDPLXX.dwg/dgn

2D proposed Pond design extracted from the .\Roadway\PDPLRD file

2D Existing Survey (Note these are being considered to merge into one survey file)

AMG-2TOPOXX.dwg/dgn

2D proposed existing Topography extracted from the .\Survey\TOPORD
file

AMG-2DREXXX.dwg/dgn

2D proposed existing Drainage extracted from the .\Survey\DREXRD
file

AMG-2UTEXXX.dwg/dgn

2D proposed existing Utilities extracted from the .\Survey\UTEXRD file

3D Existing Survey Surface

AMG-3SURFACEEXXX.xml

3D existing terrain to be exported from the \Survey\GDTMRD file

3D Proposed Surface

AMG-3SURFACEPRXX.xml

3D proposed finish terrain to be exported from the .\Roadway\AMGMRD
file

3D Proposed Break Lines

AMG-3DSGNXX.dwg/dgn

3D proposed Roadway design extracted from the .\Roadway\DSGNRD
file




Exporting Alignments

You can export alignments and profiles directly from the elements in the DGN
file.

¢ Open the ALGNRDxx.DGN

¢ Select, and hove
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Exporting Alignments

+ In the Bentley Civil Report Browser select the “AlignmentsToLandXML.xsl”

report.

File Tools Help

|C:\F‘rog|am Data"Bentley Civil\Report Browser'8.11.9%en"

(=3 CivilGeometry

----- )

----- A HorizontalAlgnmentArea xs|

----- @ Horizontal AlignmentCheck Integrity xsl
----- .B Horizontal AlignmentControlLine Data Table xsl
----- .B Horizontal AlignmentCurve Data Table xsl
----- .g Horizontal Alignment Interval XYZ xs|

----- Af] HorizontalAlgnmentLength xs!

----- @ Horizontal Alignment Review xs|

----- @ Horizontal Alignment ReviewASC sl

----- éﬂ Horizontal Alignment ReviewMNDOR xsl
----- @ Horizontal Alignment ReviewWith P | xsl
----- .g Horizontal Alignment Station Equations xsl
----- .B Horizontal And Vertical Alignment Review xs|
----- .g HorizontalElements Table xsl

----- .g HorizontalElements Table Simplified xsl
----- Af] HorizontalElements XY Z xsl

----- Af] SettingOut Table xs|

----- Aj] SettingOut TableDeflection xs!

----- Af] Traverse xsl

----- Af] TraverseCurveASCI|xsl

----- A TraverseCurveASCI2xsl

----- A TraverseCurveASClI3xsl

----- Af] TraverseEditASCIlxs!

----- Af] TraverseFoints xs!

----- A3 Vertical lianmentCheck Intearity xs!
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<?xml version="1.0" encoding="iso-8859-1" 2>
<Land¥ML xmlns="http://www.landxml.org/schema/LandXML-1.1" xmlns:xs
<Units>
<Imperial arealUnit="acre" linearUnit="USSurveyFoot"™ wolumeUnit="cuk
</Units>
<Alignments>
<Alignment name="RAMPF" length="1395.361103908" state="proposed" st
<CoordGeom name="RAMPF" state="proposed":>
<Curve rot="cw" crvIype="arc" radias="250.000000000" length="584,23
<Start code="BPC":>

592917.915084000 21559408.233007000 163.6504E87000
</Start>
<Center code="CC">

5926658.556293850 2159390.339047820 145.905219926

</Center>

<End code="PCC">

5892482 .769382000 2159557.620927000 138.945794524

</End>

</Curve>

<Curve rot="cw" crvIype="arc" radius="250.000017000" length="584.23
<5tart code="FCC">

592482.769392000 2155557.620927000 138.945794524

</Start>

<Center code="CC">

592668.506306483 2159390.339036450 138.945794524
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Exporting Alignments

¢ Select “File > Save As” and navigate to the 3DDeliverables directory.

v' Choose “Text File(.txt)” as the “Save as type”. (rename extensions later)
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File Tools Help

|C:\ng|amData\Bentley\Q\ril\Hepo Save As

=

{3 CivilGeometry

Af] AlignmentsTolandXMLxs|
A HorizontalAlignment Area xs| Iz
Horizortal AlignmentCheck Int -iy
Horizontal AlignmentCortrol Lin Recent Flaces
Horizontal AlignmentCurve Datj

Horizontal Alignment Interval X !
Horizontal Alignment Length xs Desktop
Horizontal lignment Review I
Horizontal Alignment ReviewAd _,::_,J
Horizortal Alignment ReviewN| LiErcln'.es
Horizontal Alignment Review Wi

Horizortal Alignment StationEq| | L&L
Horizontal AndVertical Aignmed oo
HorizortalElements Table xs| Computer
HorizontalElements Table Simp Q
HorizontalElementsXYZ xsl h
SettingOut Table xsl
SettingOut Table Deflection sl
Traverse xs|
TraverseCurve ASCI| xs
TraverseCurve ASCII2 xsl
TraverseCurve ASClI3xsl
TraverseEditASCI| xsl

Savein: | ) 3DDeliverables

MName

| | AMG-ALGNOO-RampF et

5

cf B~
Date modified
6/5/2014 10:18 AM

4| n

Type
Text Docu

File name: |AMG-ALGNDD—RampF.bd

Save as type: IText File: {* et}

BndXML-1.1" xmlns:xs

oot" volumeUnit="cuk

state="proposed" st

DO00" length="584.23

0o

000" length="584.23

24

TraversePoints xsl
Wertical AianmentCheckintearitv sl
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2D Proposed Planimetrics

Use MicroStation’s “Save As” command to save copies of the proposed design
files into the 3DDeliverables directory with AMG-2 names in DGN and DWG
formats.

¢ AMG-2DSGNRDxx.DGN, AMG-2DSGNRDxx.DWG
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¢ AMG-2DSGNRDxx.DGN, AMG-2DSGNRDxx.DWG

NOTE: These steps can also be used for 2D existing survey
fles TOPORD, DREXRD, UTEXRD
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2D Proposed Planimetrics

First you need to dumb down the data.
1. In the View Attributes, turn off “Construction”
2. Place a Fence around all elements in the design file

3. Inthe Key-in window type “ff=tempdsgnrdxx.dgn”
v DataPoint to accept




H Save As - Che\Projects\Gore_Designiroadway'

2D Proposed Planimetrics i odow

Name Date modified Type

L

’;"-} . eng_data 6/3/2014 2:32 AM File folder
Recent PI | projdbs 6/2/2014 932 AM  File folder

m | rdldbs 6/3/2014438PM  File folder

4. Open the tempdsgnrdxx.dgn o
design file =

5.  Select “File > Save As” from
the MicroStation menu N

6. Choose DWG as the “Save as
typ e " File name: AMG-2DSGNRDO0.DGN

- Save
Saveastype: | AutodeskiR) DWG Fies (“cwg) ~| [ cenca |

7. Key in the filename & Click

DWG/DXF Units

Save.

Power GEOPAK requires that the file units be accurately specified in order for "True" scaling to be
calculated correctly when werking with cells and reference filesIt is not possible to infer the units

8_ Se I eCt th e U n ItS S u rvey Feet & ;glrliozl:veir?:\:(eiaz;r?:)(F file: "C:\e\Projects\Gore_Design'roadwaytAMG-2D5GNRDOD.DGN" for the

CI ICk O K . The "Design Center Units” option has been selected, but Design Center units are not specified in
this file.

9. Copy file to 3DDeliverables
d i re Cto ry [] Do not display again (Use this setting for all DWG/DXF files of this type)
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Exporting 3D Break Lines

1. Open the DSGNRDxx.DGN file.
v" Display 2D and 3D views (F9)

2. In 2D, Select and hover over the corridor
handle then select Properties from the
Context menu

3. Choose the Design Stage “4 Final —
Lines Only”
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Exporting 3D Break Lines

4. Turn off subsurface levels
5. Fence elements in 3D view

6. In the Key-in window type
“fi=temp3dsgnrdxx.dgn”

v DataPoint to accept

T

Dy B (ViewDisplay ]
l{-ﬁD:lMLevev@v

=8 DSGNRDO0.dgn, Default-3D
v ALGNRDOO.dgn, Defautt-30

Ll L

Narme Used ™

ep DE_d i}

{55hapelndep07_dp

[m] »
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Exporting 3D Break Lines

7. Open the temp3dsgnrdxx.dgn
design file

s. Select “File > Save As” from
the MicroStation menu

9. Choose DWG as the “Save as
typell

10. Key in the filename & Click
Save.

11. Select the Units Survey Feet &
click OK.

12. Copy file to 3DDeliverables
directory.
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H Save As - C\e\Projects\Gore_Designiroadway

Savein: roadway - @7 mE
T Name ’ Date modified Type
"'wb‘ eng_data 6/3/2014 9:32 AM File folder
Recent Places projdbs 6/3/20149:32 AM  File folder
! rddbs 6/3/2014 438 PM  Filefolder
[ AMG-3DSGNRD00.dwg 6/5/2014 514PM  AutoCAD Drawing
Desktop [ tempdsgnrdog.dwg 6/5/2014 4:48 PM AutoCAD Drawing
Libraries
LY
Computer
=,
w
Network

4 n | b

File name: temp3dsgnrd00.dwg -
Saveastype: || Autodesk(R) DWG Fies (*dwg) ~| Cancel

Options

-

DWG/DXF Units

Power GEOPAK requires that the file units be accurately specified in order for "True" scaling to be
calculated correctly when werking with cells and reference filesIt is not possible to infer the units
for the DWG or DXF file: "C\e\Projects\ Gore_Design\roadway\AMG-2DSGNRDO0.DGN" for the
following reason:

The "Design Center Units” option has been selected, but Design Center units are not specified in
this file,

Units:

[] Do not display again (Use this setting for all DWG/DXF files of this type)
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Exporting Proposed Surface

1. Open the DSGNRDxx.DGN file.
v" Display 2D and 3D views (F9)

2. In 2D, Select and hover over the corridor
handle then select Properties from the
Context menu

3. Choose the Design Stage “4 Final —
Lines Only”

2014 |

sign Training

o



Tasks - 0 ¥

Exporting Proposed Surface —— =
S TRRTE T UR d § o
4. Create a new AMGMRDxx.DGN file %J’ 85

5. Open AMGMRDxx.DGN file 5 ceneacaamery v
6. Reference the TEMP3DSGNRDxx.DGN File S

s o S
I (S AT AR
Sl d W

255
te From Elements

7. Select all elements

8. Click “Create From Elements” on the “Civil Tools > Eﬁé,i_iﬁi%%
Terrain Model” task menu. Y =TS

ug Visualization

ﬁ Corridor Modeling A4
2 3D Geometry w
2 cCivil cells v
M Survey e}
\;' Drawing w

b

A4

m4/IJ|! H Animation
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Exporting Proposed Surface

9. Set the following in the Create Terrain Model dialog:

- Feature Type: Break Line
- Edge Method: None
- Feature Definition: DTMProposed

10. DataPoint through prompts to accept settings.

A Surface is created
v' external triangles must be trimmed

() Create Terrain Mod...l = LX)

Feature Type Break Line E|
Edge Method Mona E|

Feature A
Feature Definition  DimProposed E|
MName DTMPr
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Exporting Proposed Surface

11. Turn off the level “DTM” in the 2D view

11. Click “Change Feature Type” on the “Civil Tools >
Terrain Model” task menu.

12. Set the Feature Type to Boundary

1) Change Feature Type = X
Terrain Model ’ vl
Feature Type Boundary El
Change only in Selected Terrain
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Tasks

[ Civil Tools

Bl L7 .0 .

~ Analysis & Reporting
iy Genera | Geometry
<. Horizontal Geometry
BB vertical Geometry

# Terrain Model ==

ao %%@%@%
£ ;7/5 < E% -

R & i [F] 0 ST
il corridor Modeling

& 3D Geometry

2 civil cells

A Survey

N Drawin g

49 Visualization

B Animation

Chanoe Feature Type
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Exporting Proposed Surface

13. When prompted to “Locate Terrain Linear Features”
select the cut and fill lines defining the external limits
of the surface.
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Exporting Proposed Surface

15. Select and hover over the surface then select
“Export Terrain Model > GEOPAK TIN".

16. When prompted key in the filename “AMG-

3SURFACEPRxXxx.TIN” and click Save.

- esrmr =

Nam: Date modified Type

eng_data 6/6/2014 245 PM File folder

projdbs 6/6/2014 2:46 PM File folder

rddbs 6/6/2014 2:46 PM File folder

36984 TIN.tin 6/20/2013 8:07 AM TIN File

DTMPr.tin 6/6/2014 4:56 PM TIN File

Finish.tin 7/10/2013 10:09 AM TIN File

GRTesttin 10/29/2013 10:30 AM TIN File

1-95 NB.tin 7/5/2013 10:31 AM TIN File
< »
File AMG-3SURFACEPROD.TIN A Save
Save as type: =tin V‘ ‘ Cancel ‘
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Exporting Proposed Surface

17. From the GEOPAK DTM Toolbox select “Utilities DT“;WNT“TA Mﬁ,f‘
> Export LandXML” —— oy
18.  On the DTM Export LandXML dialog enter: EAE CD“AS
- TIN File: AMG-3SURFACEPRXxx.TIN = R
- English Unit: US Survey Feet JL: R
- LandXML File:AMG-3SURFACEPRxx.TIN = Open es ToolBox

[ Bt DTM Export LanaXML =)
19. Click EXpOI‘t TIN File: | AMG-3SURFACEPR00.TIN Q
Project Name:
: Description:
20. Copy AMG-BSUR_FACEPRXX files to ot Ut
3DDeliverables dlreCtOFy LandXML File: | AMG-3SURFACEPROO.xml Q
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Exporting Existing Surface

1. Open the GDTMRDxx.DGN file.

2. Select and hover over the existing surface then
select “Export Terrain Model > GEOPAK TIN”.

i Lap-et
= GEOPAK TIN

#3 InRoads DTM

Savein roadway v GFEEr 'E’] .E]
= Name = Date moditied lype
~ erg_data 6/6/2014 245 PM File folder
Recent Places projdbs 6/6/2014 246 PM File folder
. rddbs 6/6/2014 246 PM File folder
—_— 36984_TIN tin 6/20/2013 8:07 AM TIN File
Desklop AMG-3SURFACEPROD.TIN 6/7/2014 221 PM TIN File
= DTMPr.tin 6/6/2014 456 PM TIN File
a Finishtin 7/10/2013 10:09 AM TIN File
Libraries GRIestun 10/29/2013 1130 AM 1IN Hle
A 1-95 NB.tin 77512013 10:31 AM 1IN Hie
CompLter |
e 3
“w

Network

4 1 [
/' File name: AMG-35URFACEEX00.TIN| - e
m__4/ S— Save as type *in V‘ ‘ Cancel |
)esign Trm:g;:ng‘ -

o



Exporting Existing Surface

4. From the GEOPAK DTM Toolbox select “Utilities DT“;WNT“TA Mﬁ,f‘
> Export LandXML” —— oy
5. Onthe DTM Export LandXML dialog enter: EAE CD“AS
- TIN File: AMG-3SURFACEEXxx.TIN = R
- English Unit: US Survey Feet JL: R
- LandXML File:AMG-3SURFACEEXxx.TIN = Open es ToolBox

[ M DTM Export LanaXML o S |
6. Click EXpOI‘t TIN File: | AMG-3SURFACEPR00.TIN Q
Project Name:
: Description:
7. Copy AMG-3SURFACEEXXxx files to e
3DDeliverables dlreCtOFy LandXML File: | AMG-3SURFACEPROO.xml Q
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Native Design and Survey Files

¢ Copy the native (DGN) proposed design and survey files to the
3DDeliverables directory.

¢ Rename them, placing the “AMG-" prefix before the file name.




Contact Information

Jimmie Prow

CADD Applications Support Coordinator
Phone no: (850) 414-4863

Toll Free no: (866) 374-3368 extension 4863

Florida Department of Transportation
Engineering / CADD Systems Office
605 Suwannee Street, Mail Station 69
Tallahassee, Florida 32399-0450

email ecso.support@dot.state.fl.us
immie.prow@dot.state.fl.us

web:  http://www.dot.state.fl.us/ecso
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