
 

 

 

 

 

 

 

 

Florida Department of Transportation 

Trns•Port CES 

Release 5.6a 

Job Estimator's Guide 
 

 

 

 

 

 

 

 

 

 

 

 
 
PREPARED BY: 
CAPSTONE ENGINEERING ASSOCIATES 
 
APRIL 2006 



Table of Contents 

Introduction................................................................................................................................... 4 

Managing Jobs in Trns•port CES ............................................................................................... 5 
Checking Jobs In and Out .......................................................................................................... 6 

The Jobs List Window........................................................................................................... 6 
Checking Jobs Out ................................................................................................................ 7 

Projects ............................................................................................................................. 7 
Proposals........................................................................................................................... 8 

Checking Jobs in ................................................................................................................... 9 
Projects ............................................................................................................................. 9 
Proposals........................................................................................................................... 9 

Deleting a Job...................................................................................................................... 10 
Estimating the Job.................................................................................................................... 10 

Opening the Job................................................................................................................... 10 
Working with the Jobs Tabbed Folder ................................................................................ 10 

The General Tab – Page 1 .............................................................................................. 10 
The General Tab – Page 2 .............................................................................................. 11 
The Items Tab................................................................................................................. 11 

The Grid Format.................................................................................................................. 13 
The Tree Format.................................................................................................................. 13 
Importing Default Tasks...................................................................................................... 14 

First Run ......................................................................................................................... 14 
Missing Unit Prices ........................................................................................................ 16 

Item Pricing.............................................................................................................................. 19 
Adding and Changing Item Tasks ....................................................................................... 19 

Bid-based Prices ............................................................................................................. 20 
Adding a Bid-based Price .......................................................................................... 20 
Regression Analysis................................................................................................... 22 
Averages .................................................................................................................... 23 

Reference Prices ............................................................................................................. 24 
Recalculating Item Values.............................................................................................. 25 

Deleting Item Tasks ............................................................................................................ 25 
Active and Inactive Tasks ................................................................................................... 26 

Scatter Diagrams ...................................................................................................................... 26 
Profile Name ....................................................................................................................... 27 
Factors ................................................................................................................................. 27 
Model Options..................................................................................................................... 27 
Viewing the data.................................................................................................................. 27 

Enlarging the graph ........................................................................................................ 30 
Alternate Items ............................................................................................................... 31 

Importing Job Items from a CES Snapshot ......................................................................... 32 
Saving Data ......................................................................................................................... 35 
Restoring Job Reference Prices........................................................................................... 35 

Trns•port CES User Guide Release 5.6a                                                                               Page 2 of 43 



Managing Snapshots ................................................................................................................ 37 
Adding a Snapshot .............................................................................................................. 38 
Deleting a Snapshot............................................................................................................. 38 
Viewing a Snapshot of a Job still in CES............................................................................ 39 
Listing Snapshots ................................................................................................................ 41 
Comparing Snapshots.......................................................................................................... 42 
Comparing Global Snapshots.............................................................................................. 42 

Trns•port CES User Guide Release 5.6a                                                                               Page 3 of 43 



Introduction 

This User Guide describes the procedures involved in establishing and maintaining projects in 
the Trns•port Cost Estimation System (CES).  It is intended for Estimators in the Department 
who are involved in the development of project and contract Cost Estimates.  They may be 
prepared at various times in the life cycle of a project or contract. 

Three elements control the security of Department data in the CES database.  These are the 
granting of access to individuals into CES, the granting of particular authority within the system, 
and the assignment of each user to an Access Control Group. 

The State Estimates Office Security Coordinator or The Trns•port Coordinator will assist with 
security access issues and questions. 

Just as PES created headers in the formulation of projects and proposals, CES will create a Job 
header.  A Job is the entity that holds the list of all proposal or project information.  A Trns•port 
project from PES is a group of pay Items with their associated quantities and other physical and 
financial information.  It is "checked out" from PES to CES as a Job and will show on the list 
under the Jobs List window.  While it is "checked out" from PES, it will be locked in the PES 
module to avoid the chance of data changes while the Job is under the control of an estimator. 

Data fields on Trns•port screens are either required or optional.  A required field may be required 
by either Trns•port system requirements or Department procedure.  Throughout this guide, 
required field names will be in bold italics.  Field names of optional fields will be in italics.   

Because there are hundreds of active projects in the Department at any given time, the use of the 
Control Group field is very important.  Through its use, projects and proposals can, in effect, be 
sub-sets to individuals or groups of individuals for simplifying screen lists as well as for security 
protection of data.  See Appendix A for a discussion on the structure of Control Group.   

For questions relating to logging in the Trns•port modules, filtering data, and printing with Citrix 
Metaframe, and generating reports, see the applicable sections of the PES Reference Manual for 
Production Projects and Proposals. 

Reference is made to the Trns•port Proposal and Estimating System (PES) and to the Trns•port 
Letting and Award System (LAS) where the estimator will have a role to perform in concert with 
the Contracts Administration Offices. 

 

System Security 

Trns•port software includes several levels of security.  Each Trns•port module has a list of users 
(identified by user ID) who may access the module.   

Each major process or program in Trns•port CES, PES, and LAS is accessible only to users with 
privileges to access that process or program.  Each user has a set of process privileges. 

 

Trns•port CES User Guide Release 5.6a                                                                               Page 4 of 43 



Managing Jobs in Trns•port CES 

Trns•port CES has extensive project building capabilities that permit users to create projects and 
do many functions that are also available to PES users.  The Department has restricted the 
functions of CES to estimating.  In general, all functions associated with creating or modifying 
the scopes of projects or proposals are to be done only in PES.  The security tokens for these 
types of actions have been removed from the appropriate roles in CES. 

Projects.  Projects may be processed through CES several times over their development life.  
They may be re-estimated for work program purposes or at any other time if there is a change to 
the project scope. 

Proposals.  When a proposal is being made ready for advertisement, and after all related projects 
have been attached, the final job should be estimated in CES.  To move the proposal and projects 
to the estimator and CES: 

 Change the proposal and all related project Control Groups to one that is accessible to the 
District Estimator.  Once the Control Group in PES has been changed, the estimator may 
take control of the Job and proceed with the estimate. 

 From within CES, the estimator will "check out" the appropriate proposal.  During the 
time that the Job is "checked out" the proposal and all associated projects in PES are 
locked.  No one may access them from within PES.  This is to ensure that Jobs do not 
become duplicated in the database. 

 The estimator performs all necessary tasks associated with estimating the Job. 

 When all work is complete, the estimator will reverse the process and perform a "check 
in" of the Job to PES.  At this point the locks on the proposal and projects are removed. 

 The Job will then reside only in PES except for the "Snapshot" of the estimate that will 
remain in CES.  The proposal and projects retain a control group under the control of the 
District Estimator. 

 

The steps to pricing a Job are: 

 "Check Out" a Proposal from PES. 

 Click a Job from the Jobs List Window. 

 Open the Job in Change mode. 

 Review the General Tab pages one and two and make necessary changes. 

 Open the Items Tab and work with Item tasks.  This tab has a Grid View and a Tree 
View.  Both views will be used extensively. 

 Add or change Item tasks. 

 Close the Job and save the work. 

 "Check In" the Job to PES. 
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Checking Jobs In and Out 

CES is a temporary repository for proposal and project records, the normal location is PES.  
Since it is temporary, they are checked out of PES for the period it is necessary to perform an 
estimate.  During the time they are 
checked out, the proposals and projects 
may not be accessed by others who may 
wish to make scope changes, but they are 
available in a "view" mode.  Snapshots 
are created frequently as a job is 
processed trough CES and are stored in 
CES.  Any snapshot may be accessed for 
alter review or comparison.  This scr
in PES illustrates all locks in effect at the 
time the screen was o

een 

pened. 

 

The Jobs List Window 
Work performed in Trns•port CES will be accomplished through the Jobs List window.  This 
window lists all the Jobs in CES that match your Control Group.  You can view and create new 
Job Snapshots from the Jobs List window.  You cannot change quantities or make other scope 
changes to the Job. 

To access the Jobs List window:  

• Click the Jobs       icon,  

Or  

• Click File > Open Job List from 
the Menu Bar.   

 

The Jobs List window will open as seen 
here. 

Filter and sort               the window as you 
would any list window.   

• Click the desired proposal. 

• Click OK.   

If the project you need is not in the Jobs 
List Window, you will have to check it out from PES. 

Note that in the box containing the check out option, other options are "grayed out."   
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Checking Jobs Out  
 

Projects 
During the time that a project is checked out, that project is locked in PES so that no interactive 
or batch processes can modify the proposal’s data.  The corresponding CES Job is also locked 
with the exception of Item and task level cost estimation activities.  While you can modify Item 
task information in CES, you will not be able to add or delete Items nor will you be able to 
change Item quantities.  This is done to ensure proposal integrity when the estimated Job is 
returned to PES. 

To bring a Project into CES:   

• Click File > Import > Check Out 
PES Project from the Menu Bar.   

Or 

• Click the Check Out Project 
icon.  

A P je

•  the project to be checked 

e 
 

 USERID, has checked 
out

•  the window and select 

 be used 

in the Jobs List window.  The original PES project number 
will display in the Project column. 

 

 

ro cts List window will open.   

Click
out.  

• Click OK. 

If you choose a project that has the sam
number as a Job that already exists in
CES, a Project Locked window will 
display similar to this one.  This window 
indicates who, by

 the project.   

Click OK to close
another project. 

The PES Project header information will
to create the CES Job header.  Job Item 
information will be created from the Project Item 
records.  Job category records will be created from the project category records.  Once done, 
CES will list the newly created Job 

Trns•port CES User Guide Release 5.6a                                                                               Page 7 of 43 



Proposals
CES will also create a Job by importing 
information from a PES proposal.  To do 
this:  

• Click File > Import > Check out 
PES Proposal from the Menu 
Bar.   

• heck Out Proposal 
       icon.  

CES displays a Proposals List window. 

• 
croll to the 

posal to import. 

• Click OK.   

eady exists in CES, a Proposal 
already locked lay.   

• Select a different proposal. 

er already in 
use

• window and select 

d 

e Proposal column.  Access 
the new Job information just as you would any other Job in CES. 

Or 

Click the C

 

Type the Proposal ID into the 
Contract Id field or s
proposal you want. 

• Click the pro

 

If you choose a proposal that has the same 
number as a Job that alr

 window will disp

• Click OK. 

 

You may also choose a job numb
, but not locked as seen here. 

Click OK to close the 
another Job number. 

The PES proposal header information will be 
used to create the CES Job header.  Job Item 
information will be created from the Proposal Item records.  Job category records will be create
from the project category records.  Once done, CES will list the newly created Job in the Jobs 
List window.  The original PES proposal number will display in th
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Checking Jobs in 
 

Projects 
When the estimate is complete, return it to 
PES. 

• Click the appropriate Job (project).   

• Click File > Export > Check In 
Project from the Menu Bar.  

Or 

• Click the Check In Project 
       icon.  

The Items will be returned to PES for 
assigning to the Project Item Unit Price fields.   

 

Price Locked Flag.  For any Project Items that are marked Yes, this screen will appear for each 
item when the project is exported back to PES.  It 
will appear whether or not the Item Price has been 
changed in CES.   

• Click Yes to accept each one individually or 
Yes to All to accept all at once. 

 

Proposals 
When the estimate is complete, return it to 
PES by: 

• Click the appropriate Job 
(proposal).   

• Click File > Export > Check In 
Proposal from the Menu Bar.   

Or 

• Click the Check In Proposal 
       icon.  

The unit prices will be passed to PES for 
assigning to the Proposal Item Unit Price 
field.  
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Deleting a Job 

CES has the capability to delete Jobs.  That authority has been limited to the Trns•port 
Coordinator in that the need to delete should be rare.  Contact the Trns•port Coordinator for 
assistance. 

 

Estimating the Job 

Opening the Job 
From the Jobs List window, 

• DblClick the row. 

Or 

• Rclick the Job.   

• Click Change.   

If you want to view this Job 

• Rclick the row.   

• Click Job.   

While in View mode, you may switch to the edit Change mode. 

• Click Edit > Change from the Menu Bar,  

Or 

• Click the Change        icon.  

You cannot switch back to View mode from Change mode.  If you switch to Change mode, you 
can edit the fields as necessary to create the Job estimate.   
 

Working with the Jobs Tabbed Folder 

The General Tab – Page 1 
Most fields on this screen are 
blue.  They were populated in 
PES and may not be changed in 
CES.  Review this page to 
insure you are in the correct Job 
and that all information is 
correct.  From this screen you 
will also load the Library to be 
used for the cost history for this 
Job by clicking on the down 
arrow in the Item History field. 
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• Fill the following fields: 

Base Date   The field will default to the current date.  This date is the point from which 
inflation will be calculated. 

Urban/Rural  Season   Estimated By   Item History  

The libraries will appear as seen here.  Currently 
there are libraries for awarded contracts for six 
months, 18 months, and three years.  Additionally 
there are libraries for six months, 18 months, and 
three year for all bids received.  The libraries are 
updated about once per month, about 10 to 14 
days after each Central Office letting .  Choose 
the Library you wish. 

• Click it. 

• Click OK.   

 

The General Tab – Page 2 
There are no fields requiring change on 
this page. 

 

 

 

 

• Click the Items Tab to work with 
the Items on the Job. 

The Items Tab  
Open the Items Tab (the Items are 
in the Grid format) which is very 
similar to the Worksheet display in 
PES.   

       Tree Format Icon  

The Grid view will be used for 
locating and sorting item rows.  
Unit Prices may be updated in the 
grid view. 

To switch from the Grid format to 
the Tree format, 

• Click the Tree       icon. 
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Here is the Items Tab in Tree 
format.  On the left side of the 
screen is the list of Items, and on 
the right is detail at Item level as 
well as Task Level.  The Items list 
shows plus "+" signs in front of 
each Item, indicating that they are 
expandable. 

 

 

 

 

 

              Grid Format Icon        
 

See the Grid Format        icon at 
the right of the screen.  You may 
toggle between the two views as 
you price the Job. 

This shows the same item list in 
expanded view.  On the left, all 
items have been expanded to show 
the tasks associated with each 
Item.  On the right the detail 
information is also altered.   

 Note.  Unit price changes 
may only be made at the 
task level.   

 

 

To see this view from the Menu Bar: 

• Click View > Expand All. 
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The Grid Format 
In the Grid view the Units column was 
highlighted by clicking the label Units in 
the green band.  Dblclick any column title 
and the column will sort.  In this case, the 
units are sorted alphabetically.  Note that 
some items appear to be duplicated.  This 
example is a strung job, and some of the 
Items were set to not combine, so that 
they will be bid, and priced, individually.  
Check your job to see that all items are 
marked to Combine with Like Items 
where appropriate.  If these flags have to 
be changed, check the job into PES and 
make the necessary changes in the 
projects. 

 

The Tree Format 
The first time an Item is opened after 
checking out the proposal all of the task 
types will be "R" for Reference Price.  
This graphic illustrates the Add and 
Insert Icons for Bid-based Prices.  In this 
approach, you will add or insert one Item 
at a time.  To add more task types you can 
Add or Insert other types from the tool bar 
Icons.  Trns•port provides seven task 
types that are:  

Add Icons 
Insert Icons 

 B   Bid-based Price 

 C   New Cost Sheet 

 CI   Item Cost Sheet 

 CS   Standard Cost Sheet 

 R   Reference Price 

 RH   Historical Price 

 T   Task Group 

Of this group of seven, The Department is using two at this time.  These are B and R.  The Bid-
based Price tasks will use data from the cost Library you selected at the General Tab.  Be sure 
to select the Library that is best suited to the Job.   
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Importing Default Tasks 

First Run 
As you begin pricing a Job, you may import default tasks that are based on specific Library bid 
history.  This process can replace all of the Reference Prices for the tasks that you select.   

Begin in the General Tab – 
Page 1 of the Job. 

• Enter Season that 
corresponds to the 
Letting Date. 

• Enter your ID in the 
Estimated By field. 

• Enter Rural/Urban. 

• Enter Item History. 
Click the Bid-based 
Library for the time 
period and range by 
clicking the arrow at the Item Bid History Library field.   

 

On completing these fields at the General Tab,  

• Click the Items Tab 
icon.  

Begin with the Item list in Grid 
format. 

You may want to import 
default Items for all Items th
are NOT lump su

at 
m: 

• Sort the worksheet on 
the Unit of Measure.  
Do this by 
"DblClicking" the label 
Unit in the green bar.   
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The worksheet will appear similar 
to this one. 

• Click the rows for which 
you wish to import default 
values to highlight them. 

In this example 

• DblClick the Units label. 

The Units column will be sorted. 

 

 

 

• Click Edit > Select All 
from the Menu bar.   

All the rows will be highlighted 

• Scroll down to the rows 
where LS units appear.   

• With the CTRL key 
depressed, click each LS 
row. 

Each of the LS rows will be 
deselected as seen here.  Scroll up 
and down to verify the list of 
selected Items.  By holding down 
the CTRL key and clicking, any 
row can be individually selected or 
de-selected. 

 

When the selected list is correct, 
from the Menu Bar: 

• Click Edit > Bring in 
Default Tasks. 
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The warning window will appear.   

• Click Yes.   

A second window will appear to give you choices 
on how to show the default items.   

• Click a Radio Button. 

In this example the third radio button is selected 
so that the default prices being imported will be 
the primary price and the reference prices will be 
available for comparison.   

• Click OK. 

As the import proceeds, you will see activity on the screen. 

 

Missing Unit Prices 
You may find that the library used for the 
first run of importing default prices 
includes some Items that did not have 
prices.  To find these: 

• DblClick the label Unit Price in 
the green bar.   

Items having no unit prices will sort to the 
top of the list.  In this example, the library 
contained values for all but 18 items. 

 

 

• Highlight all unpriced rows by 
holding down the <CTRL> key 
and Clicking the rows. 

 

 

Trns•port CES User Guide Release 5.6a                                                                               Page 16 of 43 



 

• From the menu bar Click Edit . Set 
Selected Bid-Bases Library 

 

 

 

 

 

This selection window will open. 

• Click the Down Arrow 

 

 

The Bid Histories Library window will open 

• Highlight a different library, in this 
example the 18 MOS AWD library will be 
chosen. 

• Click OK. 

 

• Click OK. 

 

 

In this run eight prices were found 
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• Highlight all remaining unpriced 
rows by holding down the 
<CTRL> key and Clicking the 
rows. 

 

As discussed above bring in another 
library of longer duration. 

 

In this case the 3 YEAR AWD library was chosen 

 

 
Two more items are priced, leaving eight 
to be priced by other means.   

One means to pricing the remaining items 
is to us the reference price initially 
imported from PES.  Do this by toggling 
the active and inactive tasks.  Another 
technique is to find the price on a similar 
item. 

 

When the import finishes:  

• Click the Tree icon. 

• Click View > Expand 
All from the Menu Bar. 

In this example you see an item 
where the Bid based price is the 
active task and the information 
is displayed in blue in the upper 
part of the screen. 

Compare it to the Reference 
Price information below it. 
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If you toggle the two tasks to 
reverse which is active, the 
screen will look like this. 

The Reference Price task data 
is now in the upper portion of 
the screen and the Bid data 
below it. 

w. 

 

Item Pricing 

Trns•port CES has numerous features to provide estimates for Items.  These range from 
equipment and crew labor costs to formulae, cost sheets, and task groups.  At present the 
Department practice is limited to two types of tasks at the Item level.  These are Bid-based 
Prices, which come from Bid History Libraries, and Reference Prices, which come from the 
individual pricing actions of Department estimators.  

The purpose of Tasks as elements of Items is to draw into the worksheet prices with varying 
criteria to allow the estimator to choose the most appropriate unit price for the Item.  The 
remainder of this section will show how to add or delete tasks at the Item.   

 

Adding and Changing Item Tasks 
Click the Job you want to work with in 
the Jobs List windo

• Open the Job in Change mode.   

• Click the Items Tab. 

• Click the Tree icon.   

This screen will appear.  From this point, 
the view can be changed to Expand all 
Items to view the full set of tasks, or 
individual Items can be expanded as 
desired.   
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This shows the Tree View fully 
expanded, with the Bid-Based Prices 
active, and the Reference Prices inactive. 

 

 

 

 

 

 

This shows a Job with only three tasks 
expanded.  Individual tasks may be 
expanded by clicking the "+" sign in the 
box at the left of the Item row or 
collapsed expanded by clicking the "-" 
sign in the box at the left of the Item row. 

 

 

 

Bid-based Prices 
CES draws information from the libraries 
listed in the Item Bid History Library field 
when calculating Bid-based Prices. 

 

Adding a Bid-based Price 
To add a Bid-based Price for an Item, 
from Tree View 

• Click the Item to edit.   

• Click Edit > Add > Bid-based 
Price from the Menu Bar.   

A new task row appears for this item. 

• Click the Down Arrow at the 
Library Name field  
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The Item Bid History Libraries will appear as 
seen here. 

• Click the Library to use for this new task. 

• Click OK. 

The Bid-based Price history will be imported.   

 

The left pane of the Items Tab will alter 
to display the new Bid-based Price at the 
end of the list of tasks for the selected 
Item.  (To place the Bid-based Price 
elsewhere in the list, highlight the task 
above which to place the Bid-based Price, 
and select Insert instead of Add.)  The 
right pane will display a data entry and 
display area for the Bid-based Price.   

The following fields can be edited in the 
data entry area: 

 

 Task ID This identifier must differ from any other task IDs for the selected Item. 

 Comment  A user-entered brief comment about the Bid-based Price. 

 Item Code  The Item on which the Bid-based Price is founded.  When the Item Code 
field is blank, the price is based on the Item selected in the left pane of the Items Tab.  If 
there is another Item on which the Bid-based Price should be based, enter that Item 
number in this field.  To select an alternative item from the Library associated to the Job 
click the Library Name button.  If a particular Library is named for this task it will show 
in the Library Name field and appear on the heading of the pop up menu.  If no Library is 
named for the task, then the Library associated with the Job on the General tab will be 
used.  To pick from the Master Item List, outside of Library results, click the down arrow. 

 Library Name  The Item bid history Library that CES uses to arrive at the Bid-based 
Price.  When this field is blank, CES uses the Library specified in the Library Name field 
on the General Tab.  If there is another Library on which the Bid-based Price should be 
made, enter that Library name in this field by clicking on a selection from the down arrow 
menu.   
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Regression Analysis 
To open a regression analysis, click the 
View Bid-based Graphs and 
Information icon.  It looks like a sine 
wave, and is to the right of the "+/-" icon. 

 

This shows a regression analysis on which 
a Bid-based Price is made.  In this 
example two models appear in 
the lower part of the screen.  
Click between them to see 
price/quantity sensitivity for 
each available model.   

Note that, in this example, CES 
chose Model 3 and selected a 
price of $52.76928 per unit for 
the 3081.0000 units of the item. 

 

 

 

 

When CES uses regression 
analysis to price an Item, you 
can access a graphical view of 
the regression information by 
choosing Bid-based 
Information from the View 
menu.  CES displays a Bid 
History Analysis window that 
interactively displays prices 
and quantities along the curve.   

To do this, place the cursor on 
the red curve and click the left 
mouse button.  The price and 
quantity values at the point 
chosen will display at the right   

Hold the left mouse button down while tracing the curve and the price and quantity values will 
display at the right in blue as the cursor moves.   

Trns•port CES User Guide Release 5.6a                                                                               Page 22 of 43 



Use the horizontal scroll bar at the bottom of the window to view specific information about the 
regression.  In the Grid below, the model number is an identifier given to the groupings of 
components used to determine the Bid-based Price.  These groupings can range from different 
seasons combined with terrain, or terrain combined with the work type, or simply the location of 
the work.  Some of the determinants of the price are listed in the Grid.  CES assigns the highest 
model number to what it deems the most compatible grouping. 

 

Averages 
To see price averages 
information for the analysis, 
click the Averages Tab.  The 
averages information for an 
Item displays, even if CES does 
not have the information 
necessary to perform a 
regression analysis for an Item, 
it will still attempt to produce a 
price for that Item based on 
averages.  Click the red line 
and the values will appear on 
the right.  In this example t
average price is $49.00311 for 
all quantities in the low and 
high ranges, and $45.30710 for quantities in the middle range. 

he 

Use the horizontal scroll bar at the bottom of the window to view specific information.  Similar 
to the Regressions Tab, the grid at the bottom of the regression display shows the different 
factors that influence the price and lists them by different model numbers.  When you decide on 
the model number of the regression or the average you wish to use: 

• Click the model you wish to use.   

• Click OK to exit the graphic window. 

• Click SAVE, or Click File > Save from the Menu Bar to save the work. 
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Reference Prices 
A Reference Price is a price used as the 
basis for estimating the cost of an Item.  
Reference Prices can be entered directly, 
or they can be imported from a Snapshot.  
They are the prices used when a Job is 
first "checked out" or they can be derived 
from formulas or other sources.  At 
present, Department practice will include 
those prices brought in from PES, and 
prices directly entered by estimators.   

To add a Reference Price for an Item, you 
must be in the Tree view.  In the left pane of the Tree view,  

• Click the Item to edit.  You can add a Reference Price by clicking on the Add Reference 
Price icon.  It is the yellow cube with the label "R."   

Or 

• Click Edit > Add > Reference 
Price > New Price from the Menu 
Bar.  

 

 

 

 

 

If you choose Historical Price in the last 
menu choice you will insert a new task 
the states that a historical Price could not 
be found.  This feature is not present
available in Florida DOT.  Once the new 
task is entered, go to the entry area in the 
right panel and manually enter a Price and 
a Comment as appropriate.   

ly 
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Recalculating Item Values 
CES does not automatically recalculate all 
the costs for a Job each time a change is 
made to the Job.  Instead, it recalculates 
only the Job element that changed and its 
associated higher-level entities.   

CES offers a menu option that 
recalculates all the costs related to an 
Item.  This menu item is available from
either the Grid view or the Tree view of 

 

e 
 

ill be highlighted.  Go the 
Me  B

 one Item at a time.  The recalculate feature 
 also available from the right mouse button menu. 

he 
s.   

To e

• the 

• nu, 
.   

A D e

•  
 YES CES 

will delete the selected task. 

the Items Tab. 

When in the Grid View, begin by 
selecting the row or rows of Item 
information to include.  To choose mor
than one row at a time, hold down the CTRL key, while selecting rows.  To include several rows
that are adjacent to each other, select the first Item and then hold down the SHIFT key as you 
select the last Item row to be included.  All the Items to be included w

nu ar: 

• Click Edit > Recalculate Item Values.   

In the Tree view you can only recalculate the values
is

 

Deleting Item Tasks 
You must be in the Tree view of t
Items Tab to delete Item task

del te a Bid-based Price: 

Click the Bid-based Price in 
left pane of the Items Tab.  

From the Mouse button me
Click Delete Bid-based

el te window will open.   

Click YES to confirm the deletion or NO to
cancel the action.  If you click
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Off/On icon Active and Inactive Tasks 

As Bid-based or Reference tasks are 
added to a Job, they are initially made 
Active.  In this condition, they will 
contribute to the total cost of an Item and 
the Job.   

For the final pricing of a Job, only one 
task per Item should be Active.   

When it is determined that an Item task is 
not desired for the Job being estimated, it 
can easily be eliminated from the task 
calculations by marking it Inactive.  In the 
Tree view: 

• Click the task to be made Inactive.   

• Click the right mouse button and Click Toggle Active/Inactive.   

Or 

• Click the Off/On        icon. 

A red X will display over the selected Item task indicating that it is now inactive and the costs 
for the task will not be included in calculations for the Item or the Job.   

To make an inactive task active again: 

• Click the task. 

• Click Toggle Active/Inactive from the right mouse button menu.  The selected element 
will no longer display an X and will once again be included in Job estimate.   

 

Scatter Diagrams 

A new CES feature is the ability to examine a 
regression curve in greater detail.  The estimator 
may vary several factors to achieve a better unit 
price for a particular item in a circumstance. 

To open a scatter diagram, highlight a bid based 
price on the tree diagram for the Item you want to 
examine. 

• Click File > Services from the Menu bar. 
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• Click Job Item Bid History 

• Click OK. 

 

 

A diagram of points with a curve fit through them will 
open. 

 

Profile Name 
The header on the page provides the Pay 
Item Number and Description as well as 
the Library from which the data points 
came.  In this illustration the profile name is ALL6MON.  Recall that the name of the CES library 
for this item was 6 Months All DSS/LAS.  While the names are different they are sufficiently 
similar to know the data content and they are the identical data set.  The ALL6MON is the name 
used in the DSS which is the primary source for CES profiles. 

 

Factors 
The next block indicates specific factors 
that are not influencing the data. 

 

 

Model Options 
The next block indicates item quantity, 
price, date, model, and plot type. 

 

Viewing the data 
The scatter diagram contains a 
wealth of information.  It will 
open defaulting to an Area and a 
Work Type.  In this example the 
Area is 01 and the Work Type is 
03, with a wide choice of vari
to change.  The ◊ indicates the 
point on the curve representing
selected cost of $791.28 for the 
contract quantity of 22.996 units 
of the Pay Item

ables 

 the 

. 
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Note that the circles are all open, 
red or green, and either bold or not 
bold.  The bold circles are those 
points from the active Work Type 
(X3) and the active Area (01).  
The red circles are those that fall 
out of “range” and may be 
removed from the graph by 
removing the X in the Outliers box 
as seen here.  While all of the 
points on the graph are shown, 
only Area 01 and Work Type X3 
are contributing to the curve seen 
here.  Note in this enlargement 
that a shadow regression curve is present.  This shad
curve represents the effect of all points (less outliers) 
and may be activated by clicking the window Model 
and selecting Not Parameterized. 

ow 

ta 

 

This view is Not Parameterized.  
Note that the unit price is now 
$730.83, represented by the ◊.  
Also note that all data circles are 
filled circles. 

 

 

 

 

 

Additional detail is available for 
each data point.  In this view, 
the curser is placed over the da
point jut above and to the right 
of the ◊.  Note that when the 
curser hovers over a point a 
window opens that provides 
details about the particular point. 

 

Trns•port CES User Guide Release 5.6a                                                                               Page 28 of 43 



Another navigational feature is to 
click the box Highlight County.  A 
county list opens representing the 
data points on the screen 

 

 

 

 

 

 
Place your cursor over a county 
and a red dot appears at the county 
name and the data points from that 
county are turned red in the plot.  
In this example Osceola County 
has four points in the plot. 

 

 

 

 

 

In a similar manner place an X in 
the Highlight Season box and see 
which data points are included by 
season of letting.  I this example 
the summer data points are shown. 

 

 

 

 

Observe the rectangle labeled “Area”.  It presently 
shows Area 01 and a unit price of $792.25.   

Move your cursor over the other points and notice their 
values.  The left most point is lowest price.  In this 
example it is Area 09 at a unit price of $519.13. 
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Enlarging the graph 
Place your cursor at a spot where you 
want to see more detail and  

• Click Zoom In from the right 
mouse button menu. 

 

 

 

The enlargement will appear like 
this one. 

To return to the original view, 

• Click Original View from 
the right mouse button 
menu. 

After your review of the bid 
history, you opt to use $740.00 as 
the unit price for this item. 

• Close the Scatter Diagram 

 

Return to the Item List window. 

• Insert a new reference price task. 

• Enter a unit price of $740.00 

• Toggle the Bid Based price task to 
off. 

Proceed to price other items. 
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Alternate Items 
In another Job, which is a project estimate 
as opposed to a proposal estimate, after 
trials with Libraries, three Items remain 
without prices.  The first Item to try will 
be the Inlet.  Look for a similar Item, 
under a different Item Number. 

• Click the Inlet Item in the Grid 
View. 

• Click the Tree View icon. 

 

 

 

 

In the Job task detail for the Inlet Item 
select a value in the Item Code field.  
Click the down arrow which will take you 
to the Master Item List.  

 

 

 

 

Using the Filter 

From this Item List,  

• Click Filter. 

See Appendix B for searches like this one, 
using an advanced filter that is named and 
saved will save a great deal of time.   

The Filter will appear.  In this example: 

• For Column, Click Description. 

• For Operator, Click Contains. 

• For Value, enter INLET in capital letters.  
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For now: 

• Click the 0425 1714 inlet. 

• Click OK.   

 

 

The information on the selected Item will 
be entered and can be seen here.  For other 
Items in your Job that still lack a unit 
price, continue in this manner until all 
Items have a Bid-based Price.   

Continue until all items are satisfactorily 
priced and the        symbol is removed 
from the General Tab page 1. 

 

Importing Job Items from a CES Snapshot 
You can import Job Items into a CES Job 
from earlier Snapshots taken of that Job.  
You may do this for any Snapshot in your 
Control Group. 

• Click the Job into which the 
Snapshot will be placed.   

• Click File > Import > Job 
Information from CES Snapshot 
from the Menu Bar. 

 

CES displays a Snapshots List window.   

• Click the particular Snapshot. 

• Click OK.   

Take great care if the Snapshot detail selected is 
for a different Job Number than the one 
Highlighted on the Jobs List window. 
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You will have the choice of importing the 
Job header information, replacing the 
current Job Items with the Items in the 
Snapshot, or importing the tasks of the 
Snapshot Items into the matching Job 
Items.  These are the default settings. 

If the check mark option is selected, CES 
imports header information along with the 
Snapshot Item task information.  For most 
situations this should not be done, as it 
will lead to changing of critical fields in 
the Job Header.   

• Click the check mark to turn off this choice. 

The three radio buttons provide options 
on how the Job information should b
imported. 

e 

• If the first radio button is selected, 
CES does not bring in any Item 
information. 

• The second radio button is grayed 
out and not available. 

• When the third option is selected, 
the three buttons below it will be 
activated. 

CES matches up the Items in the Snapshot 
to those in the Job, but instead of 
replacing all Items, it only replaces the 
tasks of the Items that are also in the 
Snapshot.  This is done if you want to use 
earlier tasks, but want to keep the same 
Items, for example, to use a previous 
version of a Job.  Once you've chosen an 
option. 

• Click OK. 

CES displays the Snapshot Items to 
Import Tasks Window.   

In this example some Items are selected and some are not.  The SELECT ALL button was selected 
first and then some Items were deselected.  Decide which Items to include in the import by 
selecting them in the Include checkbox.   
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If you want to select all the Items,  

• Click SELECT ALL.   

You may also choose the Category and Item Alt Code boxes for matching purposes.  Once you 
have decided which Items to include, 

• Click OK. 

• From the Grid View of the Job, click the Tree icon.   

When the load is completed, the 
results display on the status bar.  In 
this example, eight job items received tasks.   

The tree view will appear as seen here.  
See the Tasks associated with the Items of 
a particular Job.  In this example, most 
Items have either one or two tasks per 
Item. 

 

 

 

 

This shows the Job after a Snapshot was 
merged into it.  The three choices in the 
radio buttons give the estimator the ability 
to approach the estimate with varied 
sources of information. 

It is recommended that as soon as a Job is 
"checked out" from PES that an 
immediate Snapshot be made to record 
the original conditions.  This gives t
estimator a way to restore the proposal (or 
project) to its condition when it was 
received from project staff or a District 
Estimator should problems occur in the preparation of the estimate. 

he 
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Saving Data 
Review the General Tab once more.  
Verify that the Estimated Cost is 
reasonable.  Review the base library on 
which the estimate was based and other 
information on the tab. 

When it is complete save the record.  
There are three ways to save the data.   

From the Menu Bar,  

• Click File > Save.   

Or 

• Click the Save        icon on the toolbar. 

Or 

• Click the X to close the window. 

After you Click SAVE, you will receive a query message. 

• Click Yes. 

 
Restoring Job Reference Prices 
If you decide you want to update an 
estimate by restoring prices contained in 
an earlier snapshot,   

• Click the Job to be updated. 

• From the Menu Bar, Click File > 
Import > Job Information from 
CES Snapshot. 

• Click a snapshot source. 

At the screen as seen here, 

• Click the check mark to turn off 
the Header choice 

• Click the Import Task Radio Button to activate the buttons below it.   

• Click the bottom Radio Button. 

With this selection, the Header will be unaltered and all Reference Prices from PES will be 
imported as the active Tasks.  Other tasks on the job will be inactive. 
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The screen appears as seen here   

• Click SELECT ALL. 

• Click OK.   

 

 

 

 

 

 

 

The Jobs List window will 
reappear.   

Note the status bar comment of 
Load Completed and the 
number of tasks altered.  

• Open the Job in Change 
Mode. 

• Click the Items Tab. 

• Click the Tree icon. 

• Click View > Expand All from the Menu Bar. 

In this example, we saw in the 
load complete statement that 
there were many tasks that 
were unaltered.  We also saw 
that at the end of the merge 
process, the estimate for the Job 
was 171 million dolla
mismatching that occurred 
allowed for two active tasks on 
numerous items.  See the result 
after making inactive all but 
one task per Item.  While it 
seems easy to recall a snapshot and activate those prices, time may have caused the Job to be 
altered, and the snapshot may no longer be a satisfactory representative of the job as it has 
changed. 

rs.  The 
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Before saving the Job at the end of 
pricing, remember that only one task for 
each Item may be active.  If more than 
one is active, their cumulative value will
be the value placed in the final estimate
You will also occasionally encounter 
difficulties with you data that will cause 
you to not be able to save your work.  
This shows an error message indicating that no changes were saved to the database.  From the 
message you see that the problem appears to be with Item 0710__6.  You may have to close the 
Job and reopen it to clear the error causing task if it cannot be found. 

 
.  

ng 

in" to PES). 

 

Managing Snapshots 

A Snapshot is a complete picture of a Job 
at a given time.  It is like freezing the 
information in a Job and keeping it 
available for use, even if the information 
in that Job later changes.  Looking at a 
Job Snapshot is similar to being in View 
mode but without the option of switchi
to Change mode.  You can choose to 
create a Snapshot, and Snapshots may 
also occur automatically at prescribed 
times (for instance, when a Job is being 
"checked 

To work with Snapshots: 

• Click the Job from the Jobs List window. 

• Click View > Snapshots from the Menu Bar.   

Snapshots are also available from the right mouse button menu.   

CES displays the Snapshot List Window 
seen here.  This window lists all the 
Snapshots that currently exist for the 
selected Job along with information about 
each Snapshot such as creator of the 
Snapshot, the Snapshot ID number, and 
the description of the Snapshot. 

 

 

Trns•port CES User Guide Release 5.6a                                                                               Page 37 of 43 



Adding a Snapshot 
To add a Snapshot, while in the Snapshot 
List Window: 

• Click Add from the right mouse 
button menu.   

 

 

 

 

 

 

The Snapshot Description window will appear. 

• Enter a description of the snapshot. 

• Click OK or click CANCEL to cancel the 
action.   

If you click OK CES once again displays the 
Snapshot List window, which now includes the 
newly added Snapshot. 

 

Deleting a Snapshot 
To delete a Snapshot, begin by selecting the Snapshot from the Snapshot List window.  To select 
more then one Snapshot at a time, hold down the CTRL key as you select the Snapshots.  To 
select multiple Snapshots that are adjacent to each other, select the first Snapshot, and then hold 
down the SHIFT key as you select the last Snapshot.   

To select all the Snapshots in the list 
window at once,  

• Click Select All from the Edit 
menu. 

Once the Snapshot(s) is selected: 

• Click Delete from the right mouse 
button menu.   
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Two Delete Warning windows will display listing 
the tables that will be affected by the deletion.  
You will need to confirm the deletion several 
times before CES will delete the data from the 
database.  The window title bar lists the number 
of deletes required.  The first Delete Warning 
window is shown here. 

 

The second Delete Warning Window will appear.  

 

 

 

 

If you click YES in each of the Delete Warning 
windows, CES will then display a final window 
to confirm the deletion.  To delete the Snapshot 
currently listed,  

• Click YES.  If you chose multiple 
Snapshots to delete at once. 

• Click YES TO ALL to delete them simultaneously,  

• Click NO to cancel the deletion of the Snapshot currently listed and move on to the 
Confirm Delete window for the next Snapshot.   

• Click CANCEL to cancel the deletion of the remaining selected Snapshots. 

 

Viewing a Snapshot of a Job still in CES 
To view a Snapshot for a job that remains 
in the Job List Window. 

• Click the job 

• Click Snapshot from the right 
mouse button menu. 
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Jobs Returned to PES 

To view a snapshot from a job that has been returned to PES. 

• From the Menu Bar, Click Utilities > System Management > Global Snapshot List. 

The Global Snapshot List window will appear.  Use the scroll bar, sorting or filtering features if 
necessary to find a Job: 

• Click the job you want to 
see. 

• Double-click it, or Click 
View > Snapshot from 
the Menu Bar, or Click 
Snapshot from the right 
mouse button menu.   

 

 
 

CES displays a tabbed folder 
window in which you can view but not 
modify the Snapshot information. 

 

The Snapshot will open.  The General 
Tab of the Job Snapshot window displays 
the same information about the Snapshot 
as the Snapshot List window.   

 

 

The Job Tab opens on Page 1 of the Job 
General Tab.  See Page 2 by clicking on 
the appropriate Radio Button. 
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The Grid View of the Snapshot is seen 
here. 

 

 

 

 

 

 
The Expanded Tree view can be seen. 

 

 

 

 

 
Listing Snapshots 
To produce a listing of Snapshot 
information,  

• Begin by selecting the Snapshot or 
Snapshots for which to produce a 
listing in the Snapshot List 
window.   

• Click Run Process from the File 
or right mouse button menu.   

 

 

CES displays a Processes window.   

• Click List Job Snapshots. 

• Click OK to submit the process   

When it appears,  

• Click Submit on the Confirm process Window.   

Shortly after that,  

• Click OK on Confirmation window. 
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See "Running a Process" below for more information about Processes. 

 

Comparing Snapshots 
You may compare two snapshots to see 
changes in quantity and price over time.  

• From the Job List window, Click a 
Job. 

• From the Right Mouse Button 
Menu Click Snapshots. 

• Click the two snapshots to be 
compared. 

• Click Run Process from the right 
mouse button menu.   

CES displays a Processes window.   

• Click Snapshot to Snapshot 
Comparison. 

• Click OK to submit the process to print the report.   

When it appears,  

• Click Submit on the Confirm process 
Submission Window.   

Shortly after that,  

• Click OK on the Confirmation 
window when it appears. 

 

Comparing Global Snapshots 
After projects and proposals are checked 
in to PES, there is one more source of 
seeing snapshot information. 

• From the Menu Bar, Click Utilities 
> System Management > Global 
Snapshots. 
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The Global Snapshot List window will 
open.  

 

 

 

 

 

Scroll to the desired project or proposal.  
In this case T3001. 

• Click one snapshot. 

• Press the <CTRL> key and Click 
the second snapshot of interest. 

• Rclick the blue band. 

• Click Run Process. 

 

• Click Global Snapshots to Snapshot 
Comparison. 

• Click OK. 

• Click Submit. 

• Acknowledge the remaining process messages. 

 

Open the report and it will be 
similar to the one seen here.  
The items in each snapshot will 
be listed and a comparison 
column at the right will show 
the item by item variances.  A 
job total variance will also 
appear at the bottom of the 
report. 
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