
CAiCE Release Notes – Visual Transportation 10,  SP5 
 
 
Resolved Incidents 
 

Command/Item Description  

Custom Line Styles Custom line style scales were incorrect for both sheet composer and Export to 
Screen Graphics (Defect 651256) 

Custom Line Styles Only the first custom linestyle found in the drawing would be used in the DGN 

Drafting => Store/Edit Extended Text 
Elements 

 

When the user clicks the Store button in the Store Edit Extended Text dialog 
the Font Attributes for Color changes to -521 and the Font changes to a value 
of -15. (Defect 597786) 

Drafting => Store/Edit Extended Text 
Elements 

 

When text is placed either by the Power Tool Place button or the Digitize All 
button the following error is displayed Rotation:  “Error in Input- Please 
Correct”. (Defect 598654) 

Drafting => Store/Edit Extended Text 
Elements 

Using the System Category to build a macro to display a Point Name, Lat, and 
Long only displays the name when previewed or stored. (Defect 598660) 
 

DTM=>DTM Database Manager In DTM Manager doing when performing a crossing breakline check, the report 
will list the breaklines by number and a corresponding chain. The chain that is 
listed is not the same as the breakline number that is reported. (Defect 
575278) 
 

DTM=>Edit=>DTM Points If you snap to a point and then click the 'Digitize' button, then right click to 
cancel the digitize operation, the X and Y coordinate values are replaced with 
0.0000. (Defect 580087) 

DTM=>Save DTM points and 
Breaklines to SRV 

The command doesn't replace the previous 'last command' used for the right-
click popup menu.(Defect 588281) 

DTM=>Save DTM Points and 
Breaklines to SRV 

The point numbering is not incremented for the first non-chain point in the SRV 
file. (Defect 599712) 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V7/V8 DGN File 

Contours with a text height of 0 are labeled in V7, V8 MicroStation. (Defect 
597579) 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V7/V8 DGN File 

The Text Height to Width ratio used in the export to DGN was being calculated 
incorrectly 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V8 DGN File 

The “Save Screen Graphics to DGN File” dialog does not remember the 
previous inputs values. 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 

The customer needs the ability to map the degree symbol character ID in 



Graphics to V8 DGN File CAiCE to the equivalent character ID in MicroStation. (Defect 655764)  

File=>Export Translators=>To 
SDR/Leitz=>Profiles 

 

The command does not recognize the LA value for asymmetrical vertical 
curves.  It only reads LB and assumes the curve is symmetrical. (Defect 
574560, WisDOT HD HD179138)  

File=>Import Translators=>From 
Intergraph/MicroStation=>V8 CEL File 
to Cell Library 

CAiCE crashes when converting a V8 cell file to a  CAiCE cell library.  

(Defect 653492) 

File=>Import Translators=>From 
Intergraph/MicroStation=>V8 DGN File 
to Geometry Elements 

Imported text from v8 DGN (Geometry Text) is large if it is more than 1 line of 
text. (Defect 574962) 

File=>Import Translators=>From 
Intergraph/MicroStation=>V8 DGN File 
to Geometry Elements 

The Use Individual Cell Names is not functioning when importing from a V8 
DGN file. (Defect 597752) 

File=>Import Translators=>From 
Intergraph/MicroStation=>V8 DGN File 
to Geometry Elements 

A V7 DGN translation table does not work when importing V8 DGN files. 
(Defect 597753) 

File=>Import Translators=>From 
Intergraph/MicroStation=>V8 DGN File 
to Geometry Elements 

When loading a translation table file and copying a row without first loading the 
DGN display an error message. (Defect 606153) 

File=>Print Composed Sheets Colors defined in the CAiCE color table with RGB = {255,255,255} still appear 
white in the print composed sheets preview, except for color 0, which is 
inverted to black (Defect 1017710, 572892) 

File=>Print Composed Sheets When exporting a sheet to MicroStation V8, the file is not stored in the Project 
Directory by default. (Defect 594887) 

Files=>Flexible File Format=>Read When reading in a point file that has descriptions with spaces Flex File reads. 
only the first word.(Defect 598938) 

Files=>Import Translators=>From 
SDMs=>V3.4 Alignment File 

When an 3.4 SDMS ALI file is created in a directory other then the project 
directory the superelevation (.SPL) file is not created for the alignment being 
exported. (Defect,597580) 

Files=>Project=>Reset Revised the “Reset project' message to read.  

"Resetting the project removes all elements from the project database. The 
UNDO operation does NOT apply to this command. Are you sure that you want 
to continue?""" (Defect 602031)  

 

Geometry => Curves => Store => 
Concentric 

After the new curve is stored the name in the New Curve field reverts to the 
name of the curve that is in the Current Curve box. (Defect 599906) 

Geometry=>Geometry Chain=>Copy 
Offset Parallel Chain 

Stationing problem along the offset chain - the spiral length of the original SCS 
is carried over onto the offset SCS and even though the spirals are obviously 
different lengths, the graphical stationing and reports incorrectly show the 
spiral as the same length as the original. (Defect 597767)  



Geometry=>Geometry Chains=>Insert 
Station Equations 

The Insert Station Equations command does not use the Prefix and Feature 
Code for inserted points, or curves. (Defect 597568)   

 

Geometry=>Geometry 
Chains=>Store/Edit 

The description field gets deleted if a chain point is snapped to using the At 
field in the dialog and the point is updated. (Defect 577059) 

 

Geometry=>Geometry 
Chains=>Store/Edit 

If you use the picker control for the Point List and chose Insert a Gap, the 
entire object list string is replaced with ",,". (Defect 600170) 

Geometry=>Points=>Delete When using the SnapW option to collect the list of points to be deleted, the 
data written to the project's _undo.kcm file does not include the description.  
(Defect 579971) 

Geometry=>Points=>Locate at Station-
Offsets 

The command doesn't support ASCII Station List Files. (Defect 597864) 

Geometry=>Profiles=>Smoothed 
Profiles 

Help file doesn't match the command for Smoothed Profile. (Defect 602188) 

Geometry=>Survey Chains=>Break 

Geometry=>Survey Chains=>Join 

Snap to a chain and it disappears from the screen.(Defect 646584) 

LandXML Toolbox DTM triangles are being incorrectly exported as breaklines instead of faces 
and breaklines are stored as survey chains instead of breaklines. (Defect 
597582) 

LandXML Toolbox The LandXML read defaults to overwrite rather than to rename/use next 
available. (Defect 598712) 

Macro => Save Design  The dialog box title for the Macro => Save Design command displays "Save 
the entire design as a serious of template applied at each cross section 
station..." (Defect 599909) 

Macro=>Run Template; Macro=>Run 
Design 

When running a template or design (vrs) where the profile or horizontal 
alignment specified in the VRD/VRS is not correct for the EAR file in use, you 
will still get the message PGL not found, but it will also runs the template and 
insert fragments at the first station using the current PGL settings.  (Defect 
597564) 

MicroStation V8 with CADLinks CADLinks w/ v8 is not drawing alignments correctly. (Defect 594604) 

MicroStation V8 with CADLinks Shape objects were not being exported to DGN using the Sheet Composer 
(Defect 651253) 

Project Manager=>Project=>Delete 

 

After importing a segment, deleting the project, recreate the project and then 
re-importing the segments the point list for the survey chain gets messed up.  
However, if you close CAiCE after deleting the project and then come back in 
and recreate the project and import the segments, the importation works fine.  
(Defect 599922) 



Project Manager=>Segment=>Import When importing an SDMS CAL file, if the total number of characters added to 
the point description buffer exceeds 79, CAiCE will crash. (Defect 600895) 

Settings=>Load Settings From 

 

The curve display settings are not being loaded when the command is used. 
(Defect 571362) 

Sheet Composer Sheet Composer is not exporting the correct colors when using the “ByLevel” 
option (Defect 655766) 

Sheet Composer Custom line styles are being exported to DGN using the Sheet Composer and 
the Export Screen Graphic command using the “ByLevel” option 

Snap Procedure Hitting the F3/F4 button during a snap procedure displays an unused dialogs. 
(Defect 607097) 

StationList Picker Control This picker control includes a 'from database' option that inserts a point name 
into the textbox portion of the control.  Instead of just inserting the name of the 
point, the point should be checked against the active alignment and a station 
value should be placed in the control.(Defect 579301) 

Survey Data Editor Unable to start OBM Editor if Office 2003 is installed. (Defect 583832) 

Tools => Database Explorer Can not read a KCM file that has Read-only attributes. (Defect 597856) 

Tools=>Database Explorer Problem writing out a KCM file (Defect 598241) 

Tools=>Edit Feature Table The level field in the feature table currently allows 4 characters.  With unlimited 
levels now supported in MicroStation v8, this field needs to be expanded to 
support up to 10 characters." (Defect 596003) 

VBA Objects The KcSelectionList object didn’t have any code implemented to handle a 
kcProfile object in VBA. (Defect 638119) 

VBA Objects Application.kcupdategraphics method doesn't work for x-section screen. 
(Defect 603423) 

VBA Objects The Loadini and Saveini VBA methods to not seem to work. (Defect 590663) 

View=>CAiCE (.CDG) Background File When the CDG buffer is too small terrain profiles won't view. (Defect 605725) 

View=>Geometry Chains Geometry Chains are drawn incorrectly when patterning with cells. (Defect 
603000) 

View=>geometry=>Curves When viewing curve with very small delta angle the curve gets displayed as a 
circle and not a small arc. (Defect 1043574) 

View=>Geometry=>Lines 

 

Viewing geometry lines doesn't utilize the 'within window' option. (Defect 
564842, 981020) 

View=>MicroStation V7 (DGN) 
Background File/ 

View=>MicroStation V8 (DGN) 
Background File 

When the Use Current Settings for Attributes option  is turned on and the color 
set to 15  the graphics is displayed in a completely different color. (Defect 
597577) 
 
 



View=>MicroStation V8 (.DGN) 
Background File 

There is no option to “Use Current Settings for Attributes” when viewing a V8 
DGN file (Defect 597882) 

View=>X-Sections=>On X-Section 
Sheets 

Box mislabeled on dialog for viewing cross sections.  The Origin text field is 
labeled "Origin X,Y Position", but actually interprets the entry as N, E or Y,X. 
(Defect 599910) 

X-Section=>Edit/View X-Section: 

Edit=>Surface=>Fill Gaps 

Problem resolving closed areas and filling gaps in an EAR file. (Defect 591191) 

 

X-Section=>Edit/View X-Section: 

Edit=>Surface=>Copy Surface to 
Other Station  

Invoking this command does nothing  (Defect 597574) 
 
 

X-Sections=> Store X-Section from 
Scanlines and DTM 

The incorrect station is inserted into EAR file  (Defect 604663) 

 

X-Sections=>Add Utilities to X-
Sections=>To EAR File 

When utilities are added to the EAR file and plotted on cross-section sheets, 
extra lines show up from utility points on one section to utility points on the 
next. (Defect 597862) 

X-Sections=>Store from Station-Offset-
Elevation File 

When the reference alignment has over lap station equation the SOE file 
cannot be imported. (Defect 597603) 

 

X-Sections=>X-Section 
Reports=>Endarea Volumes 

The earthwork volumes are incorrect when the stations are within 0.01 of each 
other. (Defect 602569) 

 
 
New Functionality 
 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V8 DGN File 

Implemented a new function in the export to v8 routine that allows you to re-
map text characters by their ASCII codes.  This allows you to keep the degree 
symbol set to char 176 in the CAiCE application, but export it to char 94 in 
MicroStation so that it will display properly in the MicroStation font.   

This feature allows an infinite number of characters to be mapped for 
substitution.  A new table was added to %kctables%\dgn\v8 that contains the 
character mapping data.  If the table is missing, the mapping function is 
skipped over, so the changes will be completely transparent to most users. 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V8 DGN File 

Implemented a new silent export function to the MicroSServer library that 
allows a programmer to silently export a v8 DGN file from their own macros by 
including the library as a reference. This function is completely transparent to 
the end user. All settings are passed to the function as parameters, so the 
interface for the macro developer is nice and clean. 

File=>Export Translators=>To 
Intergraph/MicroStation=>Screen 
Graphics to V8 DGN File 

Added debugging code at various points in the MicroSServer.lib and 
CADLinksv8_1.mvba libraries that produce extra error messages, create log 
files, etc. 



   

To activate the log file error reporting in export screen graphics to v8 or convert 
v8 CEL to CCL, double click on the dialog and select the ‘log file’ debug mode.  

LandXML Toolbox Implemented a new silent export function for the LandXML library.  This 
function allows the macro developer to specify all selection settings and pass 
them to the LandXML export routine as parameters of the new function.  All 
structures used as parameters are exposed as public types.   

LandXML Toolbox Implemented a new silent import function that is a slight variation on the 
existing silent export function in the LandXML library. In this function, you get 
to specify the XML filename.  ALL data is read into the project database from 
the XML file. 

X-Sections=>Edit/View X-Sections: 

Edit=>Utility Point=>Delete 

A new command was added to the x-section editor 



 
Changes to Command Behavior (MicroStation V8 interface): 
 

• DebugMode options have been added to the following commands: 
o File=>Export Translators=>To Intergraph/MicroStation=>Screen Graphics to v8 

DGN File 
o File=>Import Translators=>From Intergraph/MicroStation=>V8 CEL File to Cell 

Library 
 

To activate the Debug Mode, double click on the command’s form outside of any of 
the controls on the form (i.e. on a blank area of the form).  A dialog box that prompts 
you to set the debug mode options will come up.  You have the option of sending 
messages to a log file, sending them to the screen via message box pop-ups, or you 
can turn the debug mode off.   
 

• File=>Import Translators=>From Intergraph/MicroStation=>V8 CEL File to Cell 
Library 

 
Two dummy seed files have been added to the %CAICE%\MDL folder – one for 
English units projects and one for metric.  When launching the MicroStation server to 
convert the cell library, the appropriate file is opened as the active application prior to 
performing the conversion.  This resolved an issue on certain machines where 
MicroStation would crash in server mode during the cell file conversion. 
 

• V8 DGN File Creation (all methods):  DGNCharIDMap.tbl 
 

A character mapping table has been added to the %KCTABLES%\DGN\V8 directory 
(DGNCharIDMap.tbl).  This table, if present and not empty, will allow the end 
user/CAD standards manager to substitute certain characters for other characters 
when exporting text to a v8 DGN.  For example, if you are using char id 176 as the 
degree symbol in CAiCE, but your font in MicroStation requires you to use character 
94 for this symbol; you can add a line to the table to cause CAiCE to substitute 
character 94 for every instance of character 176 when writing out the DGN file.  The 
character codes correspond to the ASCII character set.  Valid ID numbers range from 
0 to 255.  DO NOT specify a value outside of this range.  Also note that there is no 
provision in the code to prevent you from substituting non-printing or special 
characters.  Please refer to the Microsoft VBA documentation accessible through the 
VBA Editor for the ASCII character set. 

 
• File=>Export Translators=>To Intergraph/MicroStation=>Screen Graphics to v8 

DGN File 
 

The Text Width/Height ratio behavior was modified so that the text width would be 
calculated by multiplying the specified ratio by the text height specified for the 
element in CAiCE.  The old behavior had this relationship backwards…the text height 
value was being assigned to the width and the height was being calculated as the 
ratio times the width. 

 



 
KCLandXML.lib Changes - VBA 
 
New Features Specification: 
 
'data types: 
 
Public Type SelectionCriteriaType 
    ImportMe As Boolean 
    Objects As String 
    Features As String 
    Segments As String 
    Zones As String 
    OptionsFeatureObjects As Boolean 
    OptionsGroundObjects As Boolean 
    OptionsSectionObjects As Boolean 
    OptionsUsersObjects As Boolean 
End Type 
 
 
Public Type AlignmentCriteriaType 
    ImportMe As Boolean   'only checked at array idx = 0 
    AlignmentName As String  'one object name only 
    Super As Boolean 
    TerrainProfile As String  'single FULLY QUALIFIED filename 
    DesignProfile As String  'one object name only 
    XSectionList As String 'comma delineated list of filenames (files located in 

CAiCE 'project directory => no path should be specified)   
example:   '"CL1.EAR,CL1FIN.EAR,...".  EAR File must 
be based on 'the alignment specified for this record. 

End Type 
 
 
Public Type DTMCriteriaType 
    ImportMe As Boolean 
    DTMList As String      'comma separated list 
End Type 
 
 
' public variables: 
 
Public NullSelectionCriteria As SelectionCriteriaType 
Public NullAlignmentCriteria(0) As AlignmentCriteriaType 
Public NullDTMCriteria As DTMCriteriaType 
 
 
'public functions: 
 
Public Function SilentWriter(PointSelectionCriteria As SelectionCriteriaType, 
SChainSelectionCriteria As SelectionCriteriaType, DTMCriteria As DTMCriteriaType, 
ParcelSelectionCriteria As SelectionCriteriaType, AlignmentCriteria() As AlignmentCriteriaType, 
FormatOnSeparateLines As Boolean, XMLFileName As String) As Long 
 
Public Function SilentReader(XMLFile As String) As Boolean 
 



 
Notes: 
 
Public data types:  
 

• SelectionCriteriaType This is used to populate the members of a 
KcSelectionSet internally.  Create one for each object 
category you want to import except alignments and 
DTM's (i.e. if you want to import points and parcels, you 
would instantiate two variables of this type).  Also make 
sure you set the .ImportMe field value to 'True'. 

• AlignmentCriteriaType This is used to store the alignment selection criteria info.  
You will have to declare an array of this type to pass to 
the SilentWriter function.  If you have only one alignment 
to export, you still must use an array:  
 
Dim AlignCriteria As AlignmentCriteriaType  
 
The .ImportMe field is only checked for the first array 
element (idx = 0). 

 
• DTMCriteriaType This is used to store the list of DTM's you want to import.  

You must set the .ImportMe value to 'True'. 
 
 
Public Variables: 
 

• NullSelectionCriteria This variable is provided so that you do not need to 
waste time or memory creating local variables as 
placeholders for object categories you do not wish to 
export.  Simply pass this variable to the SilentWriter 
function for each category you do not wish to import.  
This variable will not work for the alignment or DTM 
categories. 

• NullAlignmentCriteria This is a single element array created for the same 
reason as the NullSelectionCriteria variable, only for the 
'Alignment' category. 

• NullDTMCriteria This variable was created for the same reason as the 
NullSelectionCriteria variable, only for the 'DTM' 
category. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Public Functions: 
 

• SilentWriter This function will allow you to export selected elements 
from your CAiCE database to LandXML.  The input 
parameters simulate the settings available in the 
LandXML Writer macro, including the selection criteria. 

 
 
Parameter:    Data Type:  Notes: 
PointSelectionCriteria  SelectionCriteriaType Use similar to KcSelectionSet  
        object.  The ‘ImportMe' field  
        should be set to a value of 
         'True' to cause the selection set  
        to be recognized. 
 
SChainSelectionCriteria  SelectionCriteriaType Use similar to KcSelectionSet  

        object.  The ‘.ImportMe' field  
        should be set to a value of 

 'True' to cause the selection set  
  to be recognized. 

 
DTMCriteria    DTMCriteriaType The '.DTMList" field should  

        contain a comma separated list  
        of VALID DTM surface names.   
        No spaces or punctuation  

 are allowed.  Do not use a  
  leading or trailing comma. 

 The '.ImportMe' field should be  
  set to a value of 'True' to cause  
  the selection set to be   
  recognized. 

 
ParcelSelectionCriteria  SelectionCriteriaType Use similar to KcSelectionSet  

        object.  The‘.ImportMe' field  
        should be set to a value of 

 'True' to cause the selection set  
  to be recognized. 

 
AlignmentCriteria()   AlignmentCriteriaType You must pass an array variable 

        of the correct data type to this  
        parameter.  Each array element  
        should contain the entire  
        selection criteria for one and  
        only one alignment.   

 
 In addition to the alignment  
 name, you may specify a single  

  terrain profile (fully qualified  
  filename), a single design  
  profile, and a comma separated  
  list of EAR files.  EAR files  
  should be located in the project  
  directory.  Do not specify a path  

 for these files. The list is  
  comma separated with no  
  leading or trailing commas or  



  spaces (spaces in the filename  
  are OK). The alignment   
  specified must match the  

 alignment used to create the 
 EAR file.  
 
 The '.ImportMe' field should be 
 set to a value of 'True' to cause 
 the selection set to be 
 recognized. 
 

FormatOnSeparateLines  Boolean  This parameter directly   
        corresponds with a  

 checkbox on the KcLandXML  
  Writer macro main form. 

 
XMLFileName   String   This is the file you want to write  

        to.  It should be a fully qualified  
        filename. 
 

Return Value:   Long   Returns the value of the  
        err.number object. Returns 0 for 
        successful execution. 
 
 

• SilentReader This function currently imports ALL valid data from the 
specified LandXML file. 

 
 
Parameter:   Data Type:  Notes: 
XMLFile   String   File to import.  Must be fully qualified  

filename. 
Return Value:  Boolean  Always returns True. 

 
 
 
 
 
Examples: 
 
 
 
Private Sub testalign() 
    Dim AlignmentData(1) As AlignmentCriteriaType 
    With AlignmentData(0) 
        .AlignmentName = "CL1" 
        .DesignProfile = "CL1" 
        .TerrainProfile = "C:\support\kcdata\SR22\CL1.PF$" 
        .XSectionList = "CL1.EAR,CL1FIN.EAR" 
        .Super = True 
        .ImportMe = True 
    End With 
     
    With AlignmentData(1) 
        .AlignmentName = "KC1" 
        '.ImportMe = True 



    End With 
     
    MsgBox CStr(SilentWriter(NullSelectionCriteria, NullSelectionCriteria, NullDTMCriteria, 
NullSelectionCriteria, AlignmentData, False, "TestAlign.xml")) 
     
End Sub 
 
Private Sub TestDTM() 
    Dim DTMCriteria As DTMCriteriaType 
    DTMCriteria.ImportMe = True 
    DTMCriteria.DTMList = "EXIST,TEST" 
    MsgBox CStr(SilentWriter(NullSelectionCriteria, NullSelectionCriteria, DTMCriteria, 
NullSelectionCriteria, NullAlignmentCriteria, False, "TestDTM.xml"))  
 
End Sub 
 
Private Sub TestParcels() 
    Dim ParcelCriteria As SelectionCriteriaType 
    With ParcelCriteria 
        .ImportMe = True 
        .Features = ALL 
        .Objects = "KC1" 
        .Segments = ALL 
        .Zones = ALL 
    End With 
     
    MsgBox CStr(SilentWriter(NullSelectionCriteria, NullSelectionCriteria, NullDTMCriteria, 
ParcelCriteria, NullAlignmentCriteria, False, "TestParcels.xml")) 
     
End Sub 
 
Private Sub TestReader() 
    MsgBox CStr(SilentReader("C:\support\kcdata\sr22\testalign.xml")) 
End Sub 
 
MicrosServer.lib Changes - VBA 
 
 
New Features Specification: 
 
'public functions: 
Public Function ExportScrnGraphicsToV8DGN(SeedFile As String, CellFile As String, DGNFile 

As String, LineStyleScale As String, TextRatio As String, Optional SetColorByLevel As 
Boolean = False, Optional SetLineStyleByLevel As Boolean = False, Optional 
SetLineWeightByLevel As Boolean = False, Optional UseUserDefinedStyle As Boolean = 
True) As Long 

 
 
Notes: 
 
Public data types:  
 

• NONE 
 
 



Public Variables: 
 

• NONE 
 
Public Functions: 
 

• ExportScrnGraphicsToV8DGN:  
This function will allow you to export screen graphics to 
a MicroStation v8 DGN file from a VBA macro without 
having to bring up the command dialog.  All options 
given in the dialog are made available to the macro 
programmer as parameters in the function specification. 
 

Parameter:   Data Type:  Notes: 
SeedFile   String   Seed file used to create the output DGN 
       file.  
CellFile   String   Cell file used to create the output DGN  

       file. 
DGNFile   String   The DGN file to create. 
LineStyleScale  String   Linestyle scale used for custom   

       linestyles in the DGN.  This is a string  
       value, however, it must be able to be  
       converted to a numeric value (i.e.  
       numbers and “.” only). 

TextRatio   String   This ration is used to calculate the  
       WIDTHof the text in the DGN as a  
       function of the height specified in  
       CAiCE. 
SetColorByLevel  Boolean  Optional.  Default value = FALSE.  

Overrides current graphics object color  
setting and forces ALL elements to be  
created with ByLevel color in the DGN 

 file.  
SetLineStyleByLevel Boolean  Optional.  Default value = FALSE.  

Overrides current graphics object color  
setting and forces ALL elements to be  
created with ByLevel color in the DGN 

 file.  
 

SetLineWeightByLevel Boolean  Optional.  Default value = FALSE.  
Overrides current graphics object color  
setting and forces ALL elements to be  
created with ByLevel color in the DGN 

 file.  
UseUserDefinedStyle Boolean  Optional.  Default value = TRUE.   

       Currently ignored in this command,  
       however, the intention is to enable  
       custom linestyles.   

Custom linestyles are always used if set 
 up properly in CAiCE and pre-defined in  

MicroStation. 
 

 
 
Return Value:  Long   Returns the value of the err.number  

       object. 



Returns 0 for successful execution.  
Returns -1 if for some reason it is 
unable to write data to one of the 
internal CAiCE variables. 

 
 
 
 
 


