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I n t r o d u c t i o n

Autodesk Subassembly composer
Autodesk subassembly composer for AutoCAD Civil3D provides an interface for composing and modifying complex subassemblies, without the need for programming. It is available in the Autodesk Subscription Center. Without the need to be an expert in programming, users can create custom subassemblies to meet their specific needs that can be used again and again once they are imported in Civil3D, making corridors have endless possibilities.Before installing subassembly composer, AutoCAD Civil3D 2012 must be installed on the machine. In order to create subassemblies and as reviewed in the document, either Civil3D or Subassembly composer are required. 
To use a subassembly created with subassembly composer, users must either have subassembly composer downloaded on their machines or the Autodesk Subassembly Composer Support Pack for AutoCAD Civil3D must be downloaded. The subassembly in composer is saved as a pkt file, whenever the file is opened in AutoCAD Civil3D, the pkt is automatically converted to its latest version.
Subassembly composer consists of five individual windows: Tool Box, Flowchart, Preview, Properties and Settings and Parameters. Each of these windows may be moved around independently using the docking controls . At any time, the default position can be regained by going to View> Restore Default Layout.
[image: ]
The Toolbox window is the storage location for elements available for constructing the subassembly. This window will provide all elements used to build the flowchart. There are five sections: Geometry, Advanced Geometry, Auxiliary, Workflow and Miscellaneous. To use any of these elements, simply click on the desired element and drag and drop it over into the Flowchart window.
The Flowchart window is used to build and organize the subassembly logic and elements. A flowchart could be a simple straight line of logic or it can be a complex tree of branching decisions either way always beginning at the Start element. If there is a problem with the subassembly a small red circle with an exclamation point will be displayed in the upper right hand corner of this panel.
The Preview window allows users to view your current geometry. There are two preview modes: 
· Roadway Model which shows the subassembly built using any target surfaces, target elevations, and/or target offsets; and 
·  Layout Mode which shows the subassembly built using only the input parameters (no targets). 

At the bottom of this panel are two checkboxes for Codes which are shown in brackets [] and Comments which are shown in parentheses (). If any Codes or Comments were entered in the properties for the points, links, or shapes then this information will be listed next to the applicable geometry.
The properties window is the input location of the parameters that define each geometry element.
The Settings and Parameters window consists of five tabs that define the subassembly: Packet Settings, Input/Output parameters, Target parameters, Superelevation, and Event Viewer.
Typical workflow
The typical workflow for creating a subassembly is broken into six steps:

1. Create a Project 
2. Specify subassembly parameters 
3. Add geometry elements 
4. Modify geometry elements 
5. Preview Geometry 
6. Save the project and import into AutoCAD Civil 3D.

[image: ]









C  h a p t e r  
2
SUBASSEMBLY COMPOSER








F i x e d                           S u b a s s e m b l y 

Fixed Geometry Subassembly Creation
1.-  Grab the Point from the Geometry Toolbox and drop it under the Start Icon on the Flowchart window
		[image: ]
Notice and review the Properties window automatically updated upon the point creation:
		[image: ]
The Point is automatically assigned a Point Number, P1, the From Point is set to Origin. Notice and review the Preview window with the point created
		 [image: ]
2.-  Grab the Point from the Geometry toolbox and drop it under the point previously created, P1. Notice that the new point P2, is automatically assigned and a Link is automatically created:
		[image: ]
3.- Under the Properties window, under the Point Geometry Type, change the Type to Slope and Delta X. Under Point Geometry Properties, select From Point P1, Slope of -2% and Delta X, 10
	[image: ]
4.- On the Preview window, select the Fit to Screen button to visualize the Point and Link created based on the geometry parameters previously created:
				[image: ]
5.- Grab the Point from the Geometry toolbox and drop it under the point previously created, P2. Notice that the new point P3, is automatically assigned and a Link is automatically created:
		[image: ]
6.- Under the Properties Window, verify that the Type under Point Geometry Type is set to Delta X and Delta Y. Under Point Geometry Properties, select From Point P2, type in 0 for Delta X and -1 for Delta Y:
	[image: ]
7.- Select the Fit to Screen button. The Link and Point are created:
			 [image: ] 
8.- Grab the Point from the Geometry toolbox and drop it under the point previously created, P3. Notice that the new point P4, is automatically assigned and a Link is automatically created:
		[image: ]
9.- Under the Properties Window, verify that the Type under Point Geometry Type is set to Delta X and Delta Y. Under Point Geometry Properties, select From Point P1, type in 0 for Delta X and -1 for Delta Y:
	[image: ]
10.- The Preview window is automatically updated:
		[image: ]
11.- Grab the Link from the Geometry toolbox and drop it under the point previously created, P4. Notice that the new link, L4, is automatically assigned and a Link is automatically created:
		[image: ]
12.- Under the Properties window, change the Link Position. Select Start Point P3, and End Point, P4:
[image: ]




13.-  The Preview window is updated:
		[image: ]
The geometry so far is made out of Links and Points. 
14.- In order to create a shape, grab the Shape from the Geometry toolbox and drop it under the link previously created, L4. Notice that the new shape, S1 is automatically created:
		[image: ]
15.- Under the Properties window, on the component, Links, select the green cube icon located on the right side:
[image: ]
16.- Place a data point anywhere on the rectangle made by points and links on the Preview window. A new Shape, S1 is automatically created:
	[image: ]
So far, the shape, links and points are static. They are defined by a geometry established under the Properties window.
Nothing, at this point, is targeting anything. We will make point P2 be defined by a slope and distance as defined previously or this point may also be targeting an offset alignment.
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T a r g e t s




Targets
Targets are defined under the Target Parameters window on the Target Parameters Tab 
		[image: ]
Targets can be set to Surfaces, Elevations or Offsets.
Continue working on the same file.
1.- Create an Offset target by clicking on the italic Create Parameter line. Change the Name to OffsetAlignment and the Type to Offset:
		[image: ]
Leave the Preview Value at its default value. Notice also the change on the Preview Window.
2.- Click on the P2&L1 rectangle on the Flowchart window:
		[image: ]
3.- On the Properties window, change the Offset Target (overrides Delta X) to OffsetAlignment (This target was created previously and available for Selection):
[image: ]
If the OffsetAlignment exists, it will overwrite the Delta X value.
4.- In order to test the behavior, notice the Preview window the arrow with the OffsetAlignment name. It depicts the target recently created and available for testing. The geometry is shrunk since the OffsetAlignment preview value is 0:
				[image: ]
5.- Select the OffsetAlignment arrow. It should turn yellow and drag it to the right. Release the selection.  Notice that the Preview value under the Target Parameters changes and the shape geometry is updated: 
			[image: ]
Point P2 is now being controlled by an Offset Alignment.
6.- Select the Create parameter line under Target Parameters, rename TargetParameter2 to Elevation, set the Type to Elevation and the value to  -1
			[image: ]
7.- Select the P2&L1 rectangle from the Flowchart window. Change the Offset Target to OffsetAlignment and the Elevation Target to Elevation. 
	[image: ]
8.- On the Preview window, select  and drag the OffsetAlignment and Elevation arrows and review the behavior of the shape and link:
			[image: ]
If these targets are defined in the Corridor in Civil3D, the width and slope of the link will be controlled by an alignment and Elevation Targets.
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I n p u t  /  O u t p u t  P a r a m e t e r s

Input/Output Parameters
Input and Output Parameters are values that can be defined once the assembly is imported into full blown Civil3D.
They are defined under the Input/Output tab on the bottom right window of Subassembly composer:
			[image: ]
If now, the width of the shape is to be controlled not by a target parameter, but by an input/output parameter, they must be defined on this window.
Continue working on the same file.
1.- Click on the Create parameter line under the Input/Output Parameters tab. Select Parameter2 and rename it to Width, set the type to Double and the Default Value to 12.
				[image: ]
2.- Highlight the P2&L1 rectangle from the Flowchart window and under Point Geometry Properties, revert the Offset Target (overrides Delta X) to None,  Elevation target to None, leave -2% for the Slope and write Width for Delta X:
			[image: ]
Notice the Preview window automatically updated.
3.- Change the Default Value for the width parameter under the Input/Ouput Parameters window to 5.00. The preview window is automatically updated for the width. 
			[image: ]
4.- Click on the Create parameter line under the Input/Output Parameters tab. Select Parameter3 and rename it to Thickness, set the type to Double and the Default Value to 1.
			[image: ]
5.- Highlight the P3&L2 rectangle from the Flowchart window and under Point Geometry Properties, change the Delta Y from -1 to –thickness:
		[image: ]
6.- Highlight the P4&L3 rectangle from the Flowchart window and under Point Geometry Properties, change the Delta Y from -1 to –thickness:
		[image: ]
7.- On the lower right window Input/Output Parameters window, change the Thickness parameter to 3. The preview window automatically updates. Revert the value to 1.
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C o d e s

Codes
Point, Link and Shape Codes can be assigned directly in Subassembly Composer by typing any name under the Point, Link or Shape Code. Code names must be in quotes.
Continue working on the same file.
1.- Highlight the P2&L1 rectangle on the Flowchart window. Under the Properties window, type in “EOP” under Point Codes:
		[image: ]
2.- On the Preview window, turn on the Codes box at the lower left corner of the window. Notice that P2 has the EOP Point Code name on brackets.
			[image: ]
3.- If multiple point codes are to be assigned to one point, names have to be separated by a comma. On the properties window for point P2, under Point Codes, type in a coma next to “EOP” and type in “ETW”. Point P2 has two point codes assigned to it.
		[image: ]
4.- Scroll down on the Properties window, and under Link, type in “Top” for the Codes:
		[image: ]
5.- Select the L4 rectangle from the Flowchart window and on the Properties window, type in “Datum” under Link Codes:
		[image: ]
6.- Select the S1 rectangle from the Flowchart window and on the Properties window, type in “Asphalt” under Shape Codes:
	[image: ]
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C u t  a n d  F i l l         C o m p o s e r

Cut & Fill Conditions
Cut and Fill conditions can be modeled in subassembly composer. In order to do so, a surface target must be defined under Target Parameters and an auxiliary point must be created from the last decision point with a zero Delta X from the last decision point and a Delta Y on the target surface.
The conditions to be modeled are the following for both Cut and Fill:
				[image: ]
				[image: ]

1.- On the Target Parameters window, click on the Create parameter line. Rename TargetParameter3 to EG, change the Type to Surface and type in a Preview Value of -1.
				[image: ]
2.- Drag an Auxiliary Point from the Auxiliary section on the Toolbox and drop it on the Flowchart window:
			[image: ]
3.- On the Properties window, under Point Geometry Type, the Type should be set to Delta X on Surface. Under Point Geometry Properties, select From Point P2 and Surface Target, EG: 
		[image: ]
4.- Select and drag the EG target surface on the Preview window. The Auxiliary Point, AP1, is automatically updated:
					[image: ] 
5.- Drag the Decision marker from the Workflow section under Toolbox and drop it on the Flowchart window:
			[image: ]
6.- On the Properties window, under Condition, type in P2.Y > AP1.Y  
This condition rule will be true if point P2 is above the existing ground point, AP1 (Fill Condition)
		[image: ]
7.- Drag a point from the Geometry section on the Toolbox and place it on the left side of the decision marker on the Flowchart window:
		[image: ]
8.- On the Properties window, under From Point, select P2, type in a slope of -2:1, select the Surface Target to EG, turn on the Add Link to From Point box:
		[image: ]
9.- The fill slope segment is placed when the condition value is true as seen in the Preview window:
			[image: ]
10.- Drag a Point from the Geometry section under Toolbox and place it on the Flowchart window:
		[image: ]
11.- The point is automatically added to the previous point. Grab the arrow attached to the new point rectangle attached to the previous rectangle and attach it to the right side of the Decision symbol so that it is placed at the False condition:
			[image: ]

12.- On the Properties window, select the Type to Slope and Delta X,  under From Point, select P2, type in a slope of -2:1 and type in 2 for Delta X:
		[image: ]
13.- Drag a point from the Geometry section and drop it under the previously created point and link on the workflow window:
		[image: ]
14.- On the properties window, under Point Geometry Type, select the Type to be Delta X and Delta Y. Under Point Geometry Properties, select From Point, P6 and type in a Delta X of 3 and a Delta Y of 0:
	[image: ]
15.- Drag a point from the Geometry section and drop it under the previously created point and link on the workflow window:
		[image: ]
16.- On the Properties window, select Slope to Surface for the Point Geometry Type. Under From Point, select P7, type in a slope of 2:1 and select the Surface Target to EG:
	[image: ]
17.- In order to test the False condition, move the EG target surface on the Preview window to a cut condition and verify the behavior of the subassembly:
			[image: ]
18.- In order to have all the Cut & Fill slopes for links and points open for prompting when placed in the drawing, they will be created as Input/Output parameters.
On the Target Parameters window, click on the Create parameter line. Rename TargetParameter4 to CutSlope, change the Type to Slope and type in  a Default Value of 2:1

		[image: ]
19.- On the Target Parameters window, click on the Create parameter line. Rename TargetParameter5 to FillSlope, change the Type to Slope and type in a Default Value of -2:1
		[image: ]
20.- Highlight the P5 & L5 rectangle on the Flowchart window and under the Properties window, type in FillSlope for the Slope value:
		[image: ]
21.- Highlight the P8& L8 rectangle on the Flowchart window and under the Properties window, type in CutSlope for the Slope value:
		[image: ]
22.- Change the Cut and Fill Slope Default Values on the Input/Output Parameters window and review the automatic updates on the preview window.
23.- Highlight the P5 & L5 rectangle in the Flowchart window and assign the “Top” link code to the current link:
				[image: ]
24.- Repeat the same process of assigning the “Top” code to the L6, L7 and L8 links.
25.- On the Input/Output Parameters window, set the Default Value on the Side parameter to Right:
				[image: ]
26.- On the Lower Right window, select the Packet Settings tab and under Subassembly Name, type SimpleLane (No spaces are accepted for names):
		[image: ]
27.- Save the Packet file by selecting File at the top left corner of Subassembly Composer and then selecting Save As.  Name it SimpleLane.pkt and place it in the current working directory:
				[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML3570dc7.PNG]
28.- Close subassembly composer (File > Exit)
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I m p o r t i n g   p k t   f i l e s  i n  C i v i l 3 D

Importing and Modeling with Packet files from Subassembly composer in Civil3D
1.- Open the drawing Sac.dwg in Civil3D located on the working directory
2.- The file contains an existing surface, a design horizontal alignment and a profile design.
3.- On the Home tab of the ribbon, under the Palettes section, select the Tool Palettes command:
			[image: ]
4.- The current Civil Subassemblies tool palette appears:
					[image: ]
5.- Right click on the gray right side area of the tool palette (Tool Palettes – Civil Imperial Subassemblies) and select the Import Subassemblies option:
				[image: ]
6.- On the Import Subassemblies dialog box, select the SimpleLane.pkt file created using Subassembly Composer. Select Import to: Tool Palette, Basic. The subassembly created in Subassembly Composer will be placed on the Basic tab on the current Tool Palette:
				[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML1792bd.PNG]
7.- Scroll down on the Basic tab subassemblies. The subassembly SimpleLane will be placed at the bottom of the list:
					[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML19e0fc.PNG]
8.- On the Home tab of the Ribbon, select Assembly, Create Assembly, name it SimpleLane and after selecting OK,  place the Assembly marker anywhere in the drawing: 
					[image: ]

					[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML1cbce8.PNG]
9.- Select the SimpleLane subassembly. Notice by scrolling down on the Advanced properties that the side, Width, Thickness, Cut and Fill Slopes are ready to be overwritten by the user:
					[image: ]
					[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML234a2a.PNG]
10.- Change the Side to Right, and the Width to 12.00’. Verify that the CutSlope is 1:1 and that the FillSlope value is -2:1. Select the marker and place the subassembly:
					[image: ]
11.- Change the Side to Left, identify the marker to complete the Assembly:
			[image: ]
12.- Select the Escape key to exit out of the Subassembly properties dialog box and Close the Tool Palettes containing all available subassemblies.
13.- On the Home tab of the ribbon, select Corridor > Create Corridor. When prompted to select a baseline alignment, right click and select cl. When prompted to select a profile, right click and select cl for the design profile and when prompted to select an assembly, right click and select the SimpleLane assembly created in the previous steps (SimpleLane).
		[image: ]
14.- On the Create Corridor dialog box, change the Start Station to 0+20.00, select the Set all Targets option and under Surfaces, select the EG target surface for both the right and left sides of the assembly. Notice the that the Width or Offset Targets and the Slope or Elevation Targets are available since these targets were defined and are now available from Subassembly Composer:
				[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML301380.PNG]
			[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML31781c.PNG]
15.- Select OK to dismiss the Target Mapping and select OK to run the Corridor. The corridor is modeled:
			[image: ]
14.- On the Toolspace, Prospector tab, expand the Corridors, find the Corridor created, right click on it and select Cross Section Editor:

				[image: ]
15.- Review the Sections by selecting the forward or backwards arrows at the Ribbon under Station Selection. The assembly behavior is exactly what was created in Subassembly Composer. Select the Close X mark on the ribbon to exit the Corridor Section Editor upon completion.
[image: ]
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E d i t i n g  p k t           f i l e s / M o d e l               U p d a t e 

Making changes to the packet file and updating the model in Civil 3D
Now that everything has been modeled, let us now suppose that a fill ditch must be added if the fill height is less than 3 feet:
[image: ]
1.- Open Subassembly Composer. Select File > Open and open the SimpleLane.pkt file previously created under the working directory.
2.- Scroll down on the flowchart window to the Decision symbol. The left side (True) currently holds the geometry for the fill situation.

		[image: ]
3.- Delete the P5 & L5 rectangle by selecting it and pressing the delete key on the keyboard.

			[image: ]
4.- Select the decision symbol from the Workflow section on the Toolbox and place it on the left side:
			[image: ]
5.- Select the line currently connecting the P8 & L8 rectangle to the decision symbol and move one of the ends so that it connects properly to the main decision symbol:
		[image: ]
If the workflow instructions do not fit, the lower right corner symbol of the drawing allows the window to be resized.
6.- Click on the new Decision symbol and under the Properties window, type under condition P2.Y – AP1.Y < 3  
This condition will test true if the fill height is less than 3:
		[image: ]
7.- Drag and drop a Point from the Geometry section of the Toolbox. On the Properties window, under Point Geometry Properties, select From Point P2, type in a Slope of -50% a Delta X of 8 and turn on under Link, Add Link to From Point
		[image: ]
8.- In order to test the behavior, move the EG line  close to P2 on the Preview window and verify that the segment is placed. 
			[image: ]
9.- Drag and drop a Point from the Geometry section of the Toolbox and place it under the previously created point:
			[image: ]
10.- On the Properties window, under Point Geometry Type, set the Type to Delta X and Delta Y. Select From Point P9 and type in a Delta X of 3. Verify the ditch on the Preview window. 
	[image: ]
11.- Drag and drop a Point from the Geometry section on the Toolbox under the point and link previously created. On the Properties window, under Point Geometry Type, select Slope to Surface. Under Point Geometry Properties, select From Point P10 and type in CutSlope for Slope. Set the Surface Target to EG.
[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML3c73536.PNG]
12.- Finally, a Point and Link must be added when the Fill height is greater than 3 feet.  Drag and drop a point:
			[image: ]
13.- Select the line connecting the Point and Link and add it to the decision symbol on its False Condition:
			[image: ]
14.- On the Properties window, under Type, select Slope to Surface. Under Point Geometry Properties, select From Point P2, type in FillSlope for the Slope value and select the Surface Target to EG. Move down EG on the Preview window and verify proper behavior.
[image: ]
15.- Highlight the new links and under the Properties window, type in under Link Codes “Top”. Repeat it for L6, L7, L8, L9,  L10, L11 and L12
		[image: ]
16.- On the bottom right corner window, select the Packet Settings tab, type under Subassembly Name, SimpleLaneDitchFill
		[image: ]
17.- Save the pkt file with the new changes by selecting File > Save As. Save it under the working directory and call it SimpleLaneDitchFill.pkt




18.- Go back to Civil3D. In Civil3D, under the Home tab, select Assembly > Create Assembly, call it SimpleLaneFillDitch and select OK. Data point anywhere on the file to place the marker.
				[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML4d0fb96.PNG]
19.- On the Ribbon, select the Insert tab and select Import, select Import Subassemblies (another alternate method to importing the pkt file):
			[image: ]
20.- Select the SimpleLaneDitchFill pkt file located under the working directory and select OK. The subassembly is ready for placement on the imported Tool Palette.
			[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML4d4bbf7.PNG]



21.- The subassembly is displayed on the Tool Palette:
					[image: ]
22.- Select the SimpleLaneDitchFill subassembly and place it on both sides of the marker.
			[image: ]
23.- Select the active Corridor from the Prospector tab under Corridors, right click on it and select Rebuild Automatic. Right click on it again, and select Cross Section Editor.
					[image: ]
24.- On the Ribbon, under Station Selection, select the forward arrow and move on to station 0+20.00
			[image: ]
[image: ]
25.- Move now to station 0+50.00. Under the Corridor Editor Tools, select Change Assembly
			[image: ]
26.- Select SimpleLaneFillDitch and select OK
			[image: C:\Users\herrere\AppData\Local\Temp\SNAGHTML4ddc116.PNG]
27.- Upon selecting OK, notice how the Corridor gets automatically rebuilt and all sections are automatically updated:
[image: ]













C  h a p t e r  
9
SUBASSEMBLY COMPOSER










A p p e n d i x  A

	Class Name
	Function Name
	Description

	P1 (AP1)
…
P1000(AP1000)
	X
	X is relative to Origin Point of Subassembly

	
	Y
	Y is relative to Origin Point of Subassembly

	
	Offset
	Offset is relative to Baseline

	
	Elevation
	Elevation is relative to 0.0 height

	
	DistanceTo(point)
	Get the distance to another point

	
	SlopeTo(point)
	Get the slope to another point

	L1(AL1)
…
L1000(AL1000)
	Slope
	Link slope

	
	Length
	Absolute length, always be positive

	
	Xlength
	Length in horizontal direction, always be positive

	
	Ylength
	Length in vertical direction, always be positive

	
	StartPoint
	Get the start point of the link

	
	EndPoint
	Get the end point of the link

	
	MaxY
	Finds the max Y elevation from the points of the link

	
	MinY
	Finds the min Y elevation from the points of the link

	
	MaxInterceptY(slope)
	Lay a line at a slope on all the points on the link to determine the highest intercept at the start of the links. 

	
	MinInterceptY(slope)
	Lay a line at a slope on all the points on the link to determine the lowest intercept at the start of the links. 

	
	LinearRegressionSlope
	Do a linear regression on the points in the link to find the best fit slope between all of them. 

	
	LinearRegressionInterceptY
	find the Y value of the linear regression line (at the start point of the link). 

	SE
	HasLeftLI
	return true if has left lane inside SE

	
	HasLeftLO
	return true if has left lane outside SE

	
	HasLeftSI
	return true if has left shouder inside SE

	
	HasLeftSO
	return true if has left shouder inside SE

	
	HasRightLI
	return true if has right lane inside SE

	
	HasRightLO
	return true if has right lane outside SE

	
	HasRightSI
	return true if has right shouder inside SE

	
	HasRightSO
	return true if has right shouder inside SE

	
	LeftLI
	return left lane inside SE

	
	LeftLO
	return left lane outside SE

	
	LeftSI
	return left shouder inside SE

	
	LeftSO
	return left shouder inside SE

	
	RightLI
	return right lane inside SE

	
	RightLO
	return right lane outside SE

	
	RightSI
	return right shouder inside SE

	
	RightSO
	return right shouder inside SE

	OffsetTarget
	isValid
	To judge if this target is assigned and it is valid to use

	
	Offset
	Get the offset value of the target

	ElevationTarget
	isValid
	To judge if this target is assigned and it is valid to use

	
	Elevation
	Get the elevation value of the target

	SurfaceTarget
	isValid
	To judge if this target is assigned and it is valid to use
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