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Description 

This course was developed to teach students fundamental use of GEOPAK, MicroStation, 
and the FDOT CADD standard resources and applications for Traffic Plans and Signalization 
design based on a typical traffic plans design workflow to produce and present Traffic Plans and 
Signalization design required for Electronic Delivery. 

Topics Covered 

• General topics on Signalization Plans and File Creation 
• Exploring the FDOT2008 desktop folder 
• Create File/Project tool for creating base files for a project 
• FDOT20XX Traffic Plans Menu bar
• Levels and Level Filters 
• Text Styles 
• Annotation Scale 
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• Creating a Summary of Pay Items 
• Signalization Tools 
• Quantities and Reports 
• Sheet Navigator/Sheet Labeling Tools 
• Plotting Tools 
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• FDOT Basic GEOPAK Road (CE-11-0099) 
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1 SIGNALS PLANS 
OBJECTIVE 

This chapter is divided into three sections: 

1. CADD Standards & File Creation 

This section contains: 

• General discussion on Signalization Plans and File Creation. 

• Exploring the FDOT2008 folder on your desktop. 

• Using the FDOT Create File/Project tool to create the base files for a project. 

2. Traffic Plans Menu 

This section discusses setting up the FDOT Menu to add the Traffic Plans menu. 

3. Levels, Text and Models 

This Section discusses some new features/concepts used in MicroStation XM. 

• Levels 

• Level Filters 

• Text Styles 

• Annotation Scale 

• Models 

INTRODUCTION 
This chapter will review the Florida Department of Transportation (FDOT) FDOT2008 working 
environment including how to properly create design files that meet FDOT standards. New 
concepts and some new tools are introduced that make producing plans much more efficient. 
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GENERAL CADD STANDARDS & FILE CREATION 
GENERAL DISCUSSION 

Traffic Plan projects are normally a component of a Roadway plans package. Therefore, the 
project directory structure usually exists prior to beginning work on a Traffic Plans component. If 
this is not the case, the same directory structure and file standards that apply to Roadway apply to 
any other lead component. The FDOT CADD Production Criteria Handbook (CPCH) defines the 
naming convention used to create the different types of design files required in a project. 

The Department uses TIMS Document Management software to manage project files and to 
create the local directory structure. The FDOT Electronic Delivery (EDelivery) software is used 
to document all project files and track project information. Geopak's Project Manager creates a 
set of binary files to keep track of all the files used by GEOPAK and their purpose. The 
information tracked by GEOPAK is different from that maintained in EDelivery and TIMS. 

EXPLORING THE FDOT2008 FOLDER ON YOUR DESKTOP 
When the FDOT software was installed on your computer an FDOT2008 folder was placed on 
your desktop. This folder contains shortcuts to applications used when working on FDOT 
projects. Some of the shortcuts are for starting MicroStation and others are for working with 
Electronic Delivery. 

The figure below shows the contents of the FDOT2008 folder. 

 

 

It is recommended that you use these shortcuts to start MicroStation. Using these shortcuts will 
start your workspace environment properly which can alleviate, among other things, issues with 
using the wrong CADD standards. 
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FDOT delivers three shortcuts for starting MicroStation, they are: 

1. FDOT2008 – Uses the V8 file format and FDOT2008 CADD standards. This option requires 
existing MicroStation V7 formatted files to be converted for both file format and CADD 
standards. All new support files and programs are accessible. 

2. FDOT2002_V7 – Uses the V7 file format by forcing MicroStation to operate in V7 
Workmode. This option uses the FDOT2002 CADD standards. This option requires no 
conversion, but it does significantly reduce the capabilities of GEOPAK. 

3. FDOT2002_V8 – Uses the V8 file format with the FDOT2002 CADD standards. This option 
requires the existing MicroStation V7 formatted files to be converted to the new file format 
only. This option requires the use of old support files, (i.e. criteria files, GEOPAK support 
databases). 

You will determine based on your projects which workspace to use. In this course, you will use 
the FDOT2008 workspace exclusively. 

Note FDOT2008 does not include a metric workspace. Resource files that are required to view 
and print existing metric files are supplied for this purpose only. 

Using these shortcuts to start MicroStation, as mentioned previously, opens MicroStation 
Manager and sets the workspace but does not set the Project. The Project is set by selecting the 
drop down arrow and selecting the correct project file or (.pcf) file. The workspace remembers the 
last project worked in and will use the .pcf file the next time MicroStation is started with that 
workspace. This is important to watch as you probably work on more than one project at a time. It 
is recommended that you always use the pcf file. This supplements other tools used to produce 
your electronic delivery submittal. Discussion provided later in the course. 
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USING FDOT CREATE FILE/PROJECT TO CREATE BASE FILES 
The Create File/Project application is used to create MicroStation design files, Compbook 
Excel files and other files in accordance with FDOT standard file naming conventions.  Create 
File/Project uses an ASCII text file, called a Control File (*.ctl) to perform these task(s).  This 
application can also create projects, although Electronic Delivery is the recommended method for 
creating new projects.  Create File/Project can be accessed from both inside and outside of 
MicroStation. The advantage to using this tool to create files is that the file will always be named 
according to FDOT standards and you will always be required to select the project folder. 

The Figure below shows the Create File/Project tool. 

 
After creating the file you can immediately open it or create all of your design files and open them 
at a later time. 
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Lab Exercise: Creating the Base Files for a Project 
CREATING SIGNALIZATION FILES 

1. Open the FDOT2008 folder on your desktop.  

 
2. Double click on the CreateEdit FDOT2008 Files icon. This will open the Create 

File/Project tool. 

Note When training in FDOT offices, the user must click the Project Navigator button to allow 
the Create File/Project tool to work locally. 

3. On the top right hand side of the Create File/Project tool, select the Project Settings button. 
This will open Project Settings. 

 
4. Select Active Project. This will open Select Active Project. 
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5. Browse to the Projects folder and select 50735535201. Stop at the root folder. 

 
6. Click on the Select button. This selects the project and takes you back to the Select Active 

Project dialog. 
7. Click OK on the Select Active Project dialog. 
8. Click OK on the Project Settings dialog. This sets your active project. 

Next, load the appropriate control file. Remember the control file sets the discipline you are 
about to work in. Signalization files are part of the Roadway control file. It is important to 
know how to do this in case you are required to use a different control file in the future or if 
the standards ever change. 

9. Select the Load Control File button, located below the Project Settings button on the 
Create File/Project dialog. 

10. Browse to the FDOT2008\Disciplines folder. Depending on how your software is installed, 
the FDOT2008\Disciplines folder could be on your server or your local hard drive. 

 
11. Either double click on the Roadway.ctl file or select the Roadway.ctl file and click Open. 

This loads the control file. You are now ready to select an output folder and create a design 
file. 
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12. In the File Group category, use the drop down arrow to select Signal Design Files (DGN). 
This sets the file types to Signalization files and sets the output folder to Signals. 

 
Note This version of Create File/Project allows you to browse to a different Output Folder if 

needed. 
13. In the File Type category list, select the file Proposed Design and Signal Information. This 

selection populates the Output File and Seed File with the correct information. 

 
14. Click the Create button at the bottom of the dialog. 
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15. Click the OK button to acknowledge the file creation. 

 
Notice at the bottom of the dialog, next to the Create button, that the Open DGN button is 
now active. This allows you to open the file with this tool, which also registers and checks the 
file out in Project Navigator.  Also, notice below the Create and Open DGN buttons that 
the file name is shown. If the file Dsgnsg01 already exists in this project the application will 
increment the file name to Dsgnsg02, it will not overwrite the file. 

 

 

 

 

 

 

 

 

16. Go on to the Optional Exercise or click OK to close the Create File/Project tool. 

 

Optional Exercise: Create Additional Files 
USE SAME FILE GROUP TO CREATE ADDITIONAL DESIGN FILES 

1. Using the Create File/Project tool select the Tabulation of Quantity Sheets file. 
2. Select the Create button. 
3. Click OK to acknowledge the file creation. 
4. Repeat steps 1 thru 4 to create the Border Sheet Reference File for Plan Sheets. 
5. Click OK on the Create File/Project tool. This will close the tool. 
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Lab Exercise: Starting MicroStation through the FDOT2008 Folder 
OPENING MICROSTATION USING SHORTCUTS IN FDOT2008 FOLDER 

In this exercise, use the FDOT2008 folder located on your desktop similar to the previous 
exercise. This folder contains several shortcut icons. It is important that you review and 
understand what each icon is used for. 

1. From the FDOT2008 folder double click on the icon labeled FDOT2008. This opens the 
MicroStation Manager dialog and sets the Workspace environment. 

 
2. In MicroStation Manager, select the project 50735535201. This selection places you in the 

correct root directory. 

 
3. Navigate to the Signals folder. 
4. Select the Dsgnsg01.dgn file and click Open. You can also double click on the file to open it. 
5. Once in MicroStation notice that the FDOT Menu bar appears. Take a moment to 

familiarize yourself with this workspace. 
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TRAFFIC PLANS MENU 
ACTIVATING THE TRAFFIC PLANS MENU 

As you’ve seen in the last exercise, FDOT Menu loads when you start MicroStation through the 
FDOT delivered workspaces. FDOT Menu, by default, opens in the Standard menu; you have the 
option to configure FDOT Menu to load additional discipline menus as needed.  

 

 
 

The figure below shows the possible FDOT Menu configurations. 

 

   
 

In the top portion of the Site Menu Configuration dialog you have the option to load one or all of 
the Roadway Menu Options. For example, Traffic Plans can be loaded along with Roadway and 
Typical Sections or it can be loaded by itself.  

The Bottom portion of the dialog allows you to load the Structures, Right of Way, Utilities or 
Photogrammetry menus. These menus cannot be loaded at the same time as the Roadway menus. 
Once you have selected your menu configuration clicking the Update button loads the additional 
menus, Exit closes this dialog without making any changes. 
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Lab Exercise: Setting up FDOT Menu to Load the Traffic Plans Menu 
LOAD TRAFFIC PLANS MENU 

1. Continuing in Dsgnsg01.dgn select the Standard pull down from the far left of FDOT 
Menu. 

2. Select the first option Configuration. This opens the Configuration dialog. 

 
3. Click the option to load the Traffic Plans menu.  

Note It’s a good idea to activate the Roadway menu as well. 

 
4. Click the Update button. You should see the standard FDOT Menu with the Traffic Plans 

menu added at the end. 

 
5. Take some time to familiarize yourself to the FDOT Menu. 
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LEVELS, TEXT AND MODELS 
LEVELS 

FDOT has created 6 level libraries: Common, Survey, Right of Way, Roadway, Photogrammetry 
and Structures. There are approximately 1400 levels. The appropriate level library is loaded when 
you create or open a MicroStation file using the FDOT workspaces. The level name is a maximum 
of 18 characters and is divided into three components.  

The three components of a level name are: 

1. Level Name 
2. State  
3. View 

An example of a plan view level is (SignalHead_ep).  

1. Level Name – SignalHead 
2. State - e 
3. View - p 

The level name is obvious, it describes the element you are about to draw.  

The State options are: 

e = Existing 

p = Proposed 

d = Drafting 

The View options are: 

p = Plan 

r = Profile 

x = Cross Section 

Note Some levels do not show a State or View in their name. These levels are set by default to 
be a proposed plan view element. An example is the level (RPM1) this level is created for 
proposed RPM’s in the plan view. 

The levels symbology or color, weight and style are created ByLevel. What this means is that each 
level already has a color, weight and style associated to it. Users cannot create additional levels. 
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Level Filters 
Level filters are used to group levels together. This makes searching through the level menu much 
easier. FDOT delivers level filters for each level library. These filters are discussed later in this 
section. Level Filters do not turn levels on or off but they reduce the number of levels visible in 
the dialog box. 

Activating a level filter is very easy and can be done from several locations. On FDOT Menu, 
under the Traffic Plans menu, Signals, you can load the level filters. 

 
Next to the level name menu there is a drop down menu as seen in the figure below where you can 
load a level filter. This option is only available if you have “Active Level Filter” selected. 

 
Note By default the Level Filter is already set by the filename. 
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TEXT STYLES 
A Text Style is comprised of a group of text attributes, such as font, width, height, spacing and so 
on. Text styles take away the burden of having to set all of the individual text parameters as 
required in previous versions of MicroStation. FDOT delivers predefined text styles, which you 
should use whenever possible. The text styles delivered by FDOT are created at a scale of 1 to 1. 
This is important to remember when placing text using Annotation Scale. Annotation Scale is 
discussed in more detail later in this section. 

Text Styles Dialog Box 

 
The Text Styles dialog box shows all of the text styles that exist in the design file, and all of the 
parameter settings for each style. When you start a new file or open an existing file based on the 
fdot_v8_levels.dgnlib all of the appropriate text styles are loaded. No changes should be made to 
the delivered text styles. 

You can open the Text Styles dialog by selecting Element > Text Styles from the MicroStation 
menu. 
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Annotation Scale 
Annotation Scale associates all of the text you have placed in a model to a specific scale so if you 
need to change the scale of that model the text dynamically changes with it. The caveat is that you 
must check on the Annotation Scale lock before placing the first piece of text and continue to use 
Annotation Scale on all of the remaining text for this to function properly. 

Using Annotation Scale also removes the burden of having to calculate what text height should be 
used at a particular scale when placing text. Annotation Scale is model specific.  

It is recommended that this be set at the time the model is created and that the Annotation Scale 
lock is selected.  This can also be set in the Model Properties as seen in the figure below. 

 
Important items to remember regarding Annotation Scale 

• Model Specific 

• Annotation Lock must be on from the start 

• Can be synced up to the plot scale using FDOT Menu 

• Can be set in the model properties 

• Don’t switch between Annotation Scale on and off 
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MODELS 
Models are independent sets of design data within the same file. Every MicroStation design file 
has at least one model named Default. Models are used to consolidate files that contain data that is 
used collectively. An example is the cross section file, this one file (Rdxsrd*.dgn) has four models 
in it. 

• Pattrd – Pattern lines for cross sections 
• Rdxsrd – Cross Sections 
• Xsshrd – Cross Section Shapes 
• Rdxsrd_shg – Cross Section Sheets 

This one file with four models replaces four MicroStation design files. 

Another example of how to use a model is with your alignment file or (Algnrd*.dgn). This file is 
for displaying the Baseline of Construction. Typically, you have multiple alignment files to cover 
all of the different scales. Using the model concept you have one MicroStation (Algnrd*.dgn) file 
with several models in it (i.e. a model for each scale). 

When you create a new model you have several options to define in the model properties, these 
properties are unique to the model. The figure below shows the Create Model dialog box. 

 
There are two types of models, Design and Sheet. The Design model is the actual geometry or line 
work and the Sheet model is the sheet file or border. Models can be either 2D or 3D and you can 
reference a 3D model to a 2D design file. 

Note If you use multiple models in your files, it is important that you document their names and 
uses in your project Journals. This will give downstream users an idea as to what is in 
the file and whether it is important or not. The same goes for CADD managers who are 
reviewing QC reports, if you create temp models to work in and the model fails 
compliancy you are covered if you have this documented in your Journal, as long as this 
Model IS NOT referenced to any other design file. 
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Lab Exercise: Using the Tools (Part 1) 
REFERENCE FILES, MODELS AND PLOT SCALE 

In this exercise, you will attach reference files that have multiple models in them. This reinforces 
what was discussed earlier regarding models inside of a MicroStation file. There is more than one 
way to load the references dialog. Use what is familiar to you. 

1. Continuing with Dsgnsg01.dgn open the References dialog box. This dialog is loaded by 
clicking on the References icon on the Primary Tool Bar. 

 
2. In the References dialog select Tools > Attach. This opens the Attach Reference dialog. 
3. Navigate to the Roadway folder. 
4. Select the Algnrd01.dgn file in the roadway folder. This is the alignment file that contains the 

Baseline of Construction. 
The attachment method should be set to Interactive by default. All of the files you are 
working with in this training course are true V8 format files so you are not required to use 
Coincident World as the attachment method. 

5. Click on OK. This opens the Reference Attachment Settings dialog box. 

 
Notice the Model name defaults to the Default model. As discussed earlier in this section every 
MicroStation file has at least one model named Default, except Rdxsrd*.dgn where the default 
model has been renamed to Rdxsrd. This reference file has additional models in it to 
accommodate multiple scales. Take a moment to look at this in your dialog.  

6. In the Reference Attachment Settings dialog set the Model to Default. 
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7. Click the OK button. This attaches the reference file. 
8. In MicroStation do a Fit View. This fits the reference file to your view. 

Take a moment and zoom in close to the baseline, notice that there are no tick marks or 
stations. The default model in the (Algnrd01.dgn) file does not have ticks or stations in it. 
The stations and ticks are in another model in the same file. The reason for doing it this way is 
that on Signalization plans sometimes it’s more advantageous to only display the stations and 
ticks and not the baseline because it may be confusing if it is close to another pavement 
marking line. With this set up you can turn of the display of the reference file (Algnrd01 
model Default). 

9. Using the same process as above, attach the Model BL 100 in the Algnrd01.dgn file. 

Zoom in close to the baseline again; notice now that there are tick marks and stations. 

 
10. Attach the reference file Dsgnrd01.dgn in the roadway folder, use the default model. This 

will give us the proposed roadway features. 

Depending on the type of project you are working it may be necessary to attach the 
Topord*.dgn file and existing drainage and utility files. If there are conflicts with any of the 
existing features than that reference file should be displayed. Refer to the Plans Preparation 
Manual Volume II - Chapter 23 for further guidance. 

11. From the FDOT Menu select Actions > Set Plot Scale of File or click the Star icon. This 
opens the Set/Update Plot Scale. 

 
12. Change the Scale to 100 and click OK. This changes the active plot scale of the file from 50 

to 100.  

In previous versions of FDOT Menu -9999 was the default scale; this causes problems with 
other applications like Sheet Navigator so FDOT set the default scale to 50.  
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Lab Exercise: Using the Tools Part 1 (Cont.) 
MODELS 

You will be setting the Annotation Scale for the default model and create a new model in this 
exercise. This model is a place where you can experiment with some tools without adding junk to 
the default model. 

1. Continuing in Dsgnsg01.dgn open the Models dialog. You can open this from the Primary       
Tool bar. 

 
2. In the Models dialog, highlight the Default model. 
3. Right mouse click on the Default model and select Edit Model Properties. This opens 

Model Properties. 

 
 

4. For Annotation Scale set this to 1”=100’. 
5. Click OK. This closes the Model Properties dialog. 
6. Click Yes on the Alert dialog. Up to this point nothing is in the design file to change. 
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7. In the Models dialog select Create a new model. This opens the Create Model dialog. 
 

 
 

8. Set the Type to Design 2D. These are the default settings. 
9. In the Name, enter Class Work. This is the Model name. 
10. Description can be left blank. 
11. For Ref Logical enter Practice Work. This field, if populated, will fill in the logical name in 

the reference palette if you attach this file. This is very helpful. 
12. For Annotation Scale set this to 1”=100’.  
13. Click OK. This creates the new model and makes it the active model. 
14. Set the Plot Scale to 100. 

 
Notice now that the new Model shows up in the Models dialog. To switch between models, 
double click on the model name. The active model name will be next to the View 1 name. 

 
15. In MicroStation, turn the Annotation Scale Lock on. 
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Lab Exercise: Using the Tools (Part 2) 
LEVELS AND FILTERS 

In this exercise, you will investigate the Levels and Level Filters delivered by FDOT. The 
elements placed in this exercise are not part of the final design; they are for experimenting and 
practicing only. 

1. Continuing with Dsgnsg01.dgn in the Class Work model select from FDOT Menu Traffic 
Plans > Signals > Set Signals Level Filter.  

This sets the active level filter. As a refresher, a level filter isolates the levels you see in the 
level dialog so it is easier to navigate. The level filters are grouped by discipline and are now 
set by the filename. 

2. In the Attributes menu, select the drop down arrow next to the level names. 

 
3. Scroll down and select the level ConduitUP. This sets the active level to ConduitUP and sets 

the color, Weight and Style because all levels are set up ByLevel. 
4. In the Attributes menu, select the drop down arrow next to the level name. 
5. Scroll all the way to the top and select Filter: STANDARDS:DSGNSG. This opens the 

Recall Filter dialog. 

 
Note This is another way to load level filters. 
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6. Scroll down and select Text (fdot_v8_levels). 

 
7. Click OK. This loads Text levels filter. 
8. Take a moment to review the levels in this filter. Notice that all you see are levels associated 

to text.  

Now that the Filter is loaded, you can navigate the level drop down menu and select the level 
that is appropriate to the item you are placing. It is important to understand how useful the 
level filters are, they will save you time when going from Line work to Text and so on. 

Lab Exercise: Using the Tools (Part 3) 
ANNOTATION SCALE AND TEXT STYLES 

This is a brief introduction to placing text using the FDOT delivered Text Styles. This is 
discussed in more detail later in this course. 

1. Continuing with Dsgnsg01.dgn in the Class Work model, set the active level to TextLabel. 

 
2. From the MicroStation Main Menu select the Place Text tool. This opens the Place Text 

dialog. 
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Notice that the Annotation Scale option is active. This was part of our Model Properties you 
set in a previous exercise. Remember with Annotation Scale set you do not have to calculate 
what text height and width to use; this tool does it for you. 

Also notice that the Annotation Scale option is active. This was part of our Model Properties 
we set in a previous exercise. Remember with Annotation Scale set we do not have to 
calculate what text height and width to use; this tool does it for you. 

3. From the Text Styles drop down menu select the General Text Labels (Scale=1) style. This 
grays out the Height and Width option. 

 
4. In the Text Editor dialog enter a sample text string and place it in your design file. 

 
5. From the MicroStation Main Menu select the Display Text Attributes tool. 

 
6. Select the text you placed and notice the text attributes, the Height and Width are set to the 

correct size based on the Annotation Scale. You did not have to calculate this. 

 
7. Take a moment to familiarize yourself with the Place Text dialog and the other delivered 

Text Styles. 
8. Change the Model back to Default and select File>Save Settings. 
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2 CREATING A KEY SHEET 
CHAPTER OBJECTIVES 

The objective of this chapter is to teach you how to create a Signal Plans Key Sheet that meets 
FDOT CADD standards. 

INTRODUCTION 
Once you have completed this chapter you will be able to create a Key Sheet and all of its 
components that follow FDOT standards. The FDOT CADD standards and the Plans Preparation 
manual will be adhered to for creation of this sheet. 

GENERAL INFORMATION 
The key sheet is the first sheet in the set of construction plans. The information shown on the 
Signal plans key sheet will vary depending on if the Signal plans are a component of the Roadway 
plans or the lead component. For example, if the Signal plans are a component of the Roadway 
plans, then you do not need a location map or length of project box because this information is on 
the lead key sheet. This also applies to the Signal plans key sheet. Refer to of the Plans 
Preparation Manual Chapter 3 Volume II for more information. 

During the creation of a Key Sheet, the user is required to take the actions listed below.  

Produce the graphical portion of the sheet with these elements:  

• Place the standard border cell for a key sheet. 

• Place the project location map (only on a lead Key Sheet). 

• Place the Florida map cell for a key sheet (only on a lead Key Sheet). 

• Place the Section, Township and Range lines (only on a lead Key Sheet). 

• Begin Milepost (correct to three decimal places). 

• Place the North arrow cell for a key sheet (only on a lead Key Sheet). 

• Identify all Railroad Crossings (only on a lead Key Sheet). 

• Fill in component Plans (Only on a lead Key Sheet). 

• Index of Sheets 

• Revision Box  

Fill in the project data, including the following: 

• Financial Project ID, Number 

• Federal Funds (if applicable) 

• County Section Number, County Name and State Road Number  

• Fiscal Year 

PROJECT LOCATION MAP 
Florida county maps are available for download from FDOT’s Surveying & Mapping web page. 
http://www.dot.state.fl.us/surveyingandmapping/maps.shtm 
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These maps are available in DGN or PDF file format. Download the DGN file into the appropriate 
project directory. This file is used by another FDOT Menu tool to attach, scale and clip the map 
to your key sheet. Currently the county map DGN files are only available in MicroStation version 
7 format. In the key map sheet clipping process we will cover how to use the version 7 maps with 
a Version 8 design file. 

The Project Location Map is placed in the center of the sheet and sized so as not to interfere with 
other elements on the Key Sheet. Its purpose is to provide enough information so that the project 
location is easily understood. Township, Range, and County lines and numbers are shown to make 
the location clear.  

USING FDOT MENU TO CREATE A TRAFFIC PLANS KEY 
SHEET 

The FDOT Menu includes tools to aid in the creation of key sheets with location maps or without. 
The figure below shows all of the possible scenarios for creating a traffic plans key sheet. 

 

KEY SHEET WITHOUT MAP 
As you can see from the figure above, you have the option to create a Key Sheet with or without a 
map. If you select the option without a map example (Signalization Keysheet w/o MAP) you 
have to first create the Key Sheet design file using the Create File/Project tool or some other 
acceptable method to create the design file using the correct seed file and design file name. 
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KEY SHEET WITH A MAP 
If your project is the lead component you will need to create the Key Sheet with a map. This 
option from the FDOT Menu opens the Key Map Sheet Clip tool. This tool does not require you 
to have a Key Sheet design file already created, this tool will create it. 

 
Note This tool by default is set to create the Roadway Key Sheet even if you start the tool in 

the Signals folder. You have to set the Key Map Type and it is important that you do this 
first. 

Scale - 1”=2miles (10,560), 1”=4miles (21120) or 1”=8miles (42240) 

Key Map Type – List of disciplines for creating key sheets. As you select the component, the 
DGN File Name will dynamically change accordingly. 

Use Federal Funds – If selected this places the (FEDERAL funds) text on the Key Sheet. 

DGN File Name – Displays the working directory path and the design file name of the Key Sheet 
being created. This dynamically changes based on the Key Map Type setting. The New button 
creates a new file for the sheet cell to be placed in.  The file name will default to the next available 
file number in the standard naming convention for the key map type chosen. 

Co. Map Name – This is the county map file you download from FDOT’s Surveying and 
Mapping web site. Browse to the file in either in the Roadway discipline folder or the data folder 
in your project directory. The web site to download the files is 
www.dot.state.fl.us/surveyingandmapping/countymap.shtm . 

Clip Area – This portion of the dialog is for setting the clip limits of the map. You can either key 
in the coordinates, or dynamically select them with the Define Clip Area button. 

Define Clip Area - This opens the selected county map so that you can graphically select the area 
to be clipped.  A square will be attached to your cursor.  The size of the square is defined by the 
Scale or Size.  Place the square around the area to be clipped and enter a data point.  The Clip Key 
Map button will become active. 

Clip Key Map – This will clip the map, place the sheet cell, open the file, set the plot scale 
according to the scale selected, and then launch Sheet Navigator. 

Note If a Key Sheet is created in the roadway directory by error make sure to delete it to avoid 
problems with electronic delivery. 
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FLORIDA MAP 
The Florida map is a cell you can place from the FDOT Menu. The Florida Map cell is to be 
located in the upper right hand corner of the key sheet. This map is only needed on the key sheets 
without a location map. Refer to the Plans Preparation Manual Volume II Chapter 23.2 for more 
detail. 

 
The insertion point is the upper right hand corner of the border and the cell scale is based on the 
plot scale. A leader line and text label pointing at the general location of the project are also 
required. 

 

  



Creating a Key Sheet - Using FDOT Menu to Create a Traffic Plans Key Sheet Chapter 2 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 2-5 

INDEX OF PLANS 
The Index of Plans is used to describe what sheets and corresponding sheet numbers are in the set 
of plans. This option on the FDOT Menu opens a text editor with a pre-defined index. This text 
file is editable and can be placed using the text editor. 

 
The next figure shows the Signal plans index text file opened in the text editor.  

 
The height and width of the index text, when placed on the Key Sheet, is generally set to 369.6, 
which is the default text size for a Key Sheet of a scale of 1” = 1 Mile. Though the Key Map 
Clipping tool sets the text height and width values, you may desire to check the program for 
accuracy or modify these values based on the scale of your Key Sheet.  

For Example, if your Key Sheet is a scale of 1” = 2 Miles, you would multiply 369.6 x 2 to get 
739.2. Another way to look at this is to take the text size of 369.6 and divide it by 5280, getting 
369.6 / 5280 = 0.07, which is the desired text height for a 1 to 1 scale. Take 0.07 x 10560 = 739.2, 
where 10560 is 2 miles. 

Under the Tools menu there is an option to Import text, which is how this text is placed in your 
design file. Notice the note in the body of the text file explaining the insertion point. The 
importance of using this tool, whenever updates or changes are made, is to keep your files 
consistent. 
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NORTH ARROW AND SCALE 
The North Arrow and Bar Scale are automatically placed on key sheets with a location map using 
the Key Map Sheet Clip tool covered earlier in this section. If you created a key sheet by some 
other means or deleted the North Arrow from you key sheet, this is the tool for you. Simply select 
the scale and place the arrow. 

 

 
 

COMPONENTS OF CONTRACT PLAN SET 
The Components of Contract Plan Set is a list of all disciplines that are a component to the lead 
project. The order of the component plans is: 

1. Roadway 
2. Signing and Pavement Marking 
3. Signalization 
4. Intelligent Transportation Systems (ITS) 
5. Lighting 
6. Landscape 
7. Architectural 
8. Structures 

If your project includes Signals, Signing and Pavement Markings or other component sheets as 
part of the Roadway Plans and those sheets are numbered consecutively within the Roadway Plans 
then these are not to be shown as components of the contract plans set. 

The next figure shows the FDOT Menu tool to aid in the production of the Components of 
Contract Plan Set. 
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This tool functions just like the Index of Plans. A text file is opened for editing to meet your 
project requirements. The text size for this file is set up to read the plot scale of the active design 
file. You do not need to edit the text height and width as long as the plot scale is set correctly in 
your active file. 

 
This file is set up for the lead key sheet in your set of plans. If you create a Signals Key Sheet 
without a map you will not use this file because there are no components hence there is no 
“COMPONENTS OF CONTRACT PLANS SET” option on the key sheet. 
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STRUNG PROJECTS NOTE 
Projects that are independently prepared but are let in the same construction contract shall have the 
additional Financial Project IDs noted on the right side of the key sheet just below the “Plans 
Prepared By” block. This is a cell that can be placed from the FDOT Menu. This tool reads the 
plot scale for text size. 

 

 
The FPID numbers in this note are part of a data field; do not drop the cell to edit the text. 
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RANGE AND TOWNSHIP MAP LABEL 

The Township and Range are used to better describe the area of the project. On the FDOT Menu 
there is a tool to help place these labels. 

 
The Township and Range labels are cells with data fields in them, again do not drop the cell to 
edit the text. The cells are placed based on the plot scale. The next figure shows the Township and 
Range cells placed from the FDOT Menu. 
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SHEET NAVIGATOR 
Sheet Navigator is a tool developed for FDOT to aid in the proper identification of plan sheets in 
a construction set of plans. Sheet Navigator will tag each sheet with information pertinent to the 
electronic delivery process. Sheet Navigator can also Auto Number and renumber sheets in a set 
of plans. 

 
It is important to remember not to put sheet borders in design files that are not going to be part of 
your plan set. Sheet Navigator along with the electronic delivery indexer will look for all files that 
have sheet borders in them and will tag them as sheets. If you absolutely have to put a sheet border 
in a file that is not part of the plan set than check the Obsolete option in this dialog so that indexer 
will not pick the file up as a sheet file. 

Note We will cover this tool in great detail later in this course guide in clip plan sheets. 
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Lab Exercise: Creating a Key Sheet With a Location Map (Part 1) 
CREATE THE KEY SHEET 

1. Open Dsgnsg01.dgn in the Signals folder. 
2. From the FDOT Menu, select Traffic Plans > Keysheets > Keysheet With Map. This 

opens the Key Map Sheet Clip dialog. 

 
3. Set the top portion of the dialog as follows: 

• Scale – 1”=2miles 

• Key Map Type – Signal 

• Check to Use Federal Funding 

4. The next figure shows how the dialog should look up to this point. Notice the file name is set 
and there is a new item for Ref File Name.  
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5. Click the New button next to the DGN File Name. This will open the Key Map Sheet File 
dialog with the file name filled in. 

 
This dialog allows you to enter a different file name and select a different folder. 

6. Click the OK button. This will create the Key Sheet File however, it is an empty file. 
7. Click the Browse button next to Co. Map Name. This is where you select the full county map 

MicroStation file downloaded from the Survey and Mapping web site. 
8. Navigate to the data folder in the project. The location where the county map is stored in will 

vary. The data folder is not necessarily the folder you will find this file in at your office. 
9. Select the cm_volusia1.dgn file and click OK.  
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10. This will populate the Co Map Name field in the Key Map Sheet Clip dialog. 
 

 
 

11. Click the Define Clip Area button.  

This opens an information dialog asking you to Upgrade the file to V8 or open read only and 
keep as V7. This happens because the county maps are still in V7 format. For this exercise, 
you will open the file as Read Only. In the future, these county maps will be converted to V8 
and you will not receive this warning. (MicroStation v8 and MicroStation v8 XM Edition 
use the same file format.) 

 
12. Select Open read-only (Keep as V7 format) and click OK. This opens the county map 

design file where you will position the clip border around the area to be clipped. 
13. In MicroStation, pan to an area where the clip border will have maximum coverage. This area 

is not important for this exercise; it is just a general location. 

You can use any of the MicroStation zoom or pan tools you need to move around the file. 

14. Issue a data point to place the clip border. 

If you don’t like the clip area you picked you can click the Define Clip Area button to place a 
different clip boundary. 

15. Click the Clip Key Map button. This will process for a moment and open the key sheet. 
Sheet Navigator will also open requiring user input. 

16. Close Sheet Navigator. We will come back to this. 
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Lab Exercise: Creating a Key Sheet With a Location Map (Part 2) 
SHEET NAVIGATOR 

1. Continuing in Keyssg01.dgn, the plot scale should be set automatically to 10560. This is 
equal to a 1”=2mile scale. 

Note It is very important to set the plot scale before completing Sheet Navigator: the Digital 
Signature Note is dependent on the scale. 

2. In Sheet Navigator, fill in the Sheet Number with T-1. 
3. For the Financial Project ID 1, click inside the blank filed. This will populate the field with 

the correct Financial Project ID. 
4. For the County, select the drop down arrow and navigate to Volusia County. 
5. For the Road Number, type in 415. Do not include SR in the field; it is part of the sheet file. 
6. For the Digital Signature Note, select the drop down and choose Standard. 
7. Click the Save button. This will tag the file with all of the pertinent information for creating 

the electronic delivery index and also populates the fields in the key sheet. 

 
8. Click the X in the upper right-hand corner to close Sheet Navigator. 
9. Take a moment to review the key sheet. 
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Lab Exercise: Creating a Key Sheet With a Location Map (Part 3) 
ADD INDEX OF SHEETS 

1. Continuing in Keyssg01.dgn, zoom in around the text “INDEX OF SIGNAL PLANS”. This 
is on the left hand side of the sheet. 

2. From the FDOT Menu, select Traffic Plans > Keysheets > Index of Plans > Signalization. 

 
3. On the Alert dialog, click OK. This is a warning for organizations that use a document 

management system such as TIMS or ProjectWise. 
 

 
 

4. Change the TX=, TW= and LS= to 739.2. This sets the text for a 1”=2 mile scale. 

 
5. Click the Save File icon.  
6. In the Text Editor, click Tools > Import Text. 
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7. Read the status bar in MicroStation, this provides information for the next step required. 

 

 
8. Snap to the origin of the text label SHEET. This will line up the text properly. 

 
9. Issue a data point to place the text. 
10. Close the Text Editor. 

Lab Exercise: Creating a Key Sheet With a Location Map (Part 4) 
ADD THE RANGE AND TOWNSHIP LABELS 

1. Continuing in Keyssg01.dgn, zoom in around location map in the center of the sheet. 
2. From the FDOT Menu, select Traffic Plans > Keysheets > Range Map Label. This 

attaches the Range cell at the active plot scale. 
3. Locate where you want to place the label and issue a data point to place the Range cell.  

This cell contains data fields so it is not necessary to drop it, use the edit data field tool to edit the 
label. 

4. From the FDOT Menu, select Traffic Plans > Keysheets > Township Map Label.  
5. Locate where you want to place the label and issue a data point to place the Township label. 

The next figure shows what the map with labels would look like. These labels come with the 
default text built into them, you will have to change this based on your project. 

 



Creating a Key Sheet - Sheet Navigator Chapter 2 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 2-17 

Lab Exercise: Creating a Key Sheet With a Location Map (Part 5) 
PLACING PROJECT LOCATION LABEL 

In this exercise we will draw a leader line with arrow pointing at the general location of the 
project on the Florida map then the note “LOCATION OF PROJECT” will be added. This 
exercise will require you to use some concepts covered earlier in the course. 

1. Continuing in Keyssg01.dgn, zoom to the Florida Map area of the key sheet. 

 
2. Set the MicroStation level to Leaderline_dp. Use the drafting filter to make this easier. 
3. Place a line starting from a point near the label DELAND on the map. The leader line will be 

a two piece line or smart line. 
4. Draw the second part of the leader line horizontal. The length needs to be long enough to hold 

the text “LOCATION OF PROJECT’. The length can be adjusted after the text is placed. 
5. From FDOT Menu select Traffic Plans > Arrows and Barscales. 
6. Select the Place Terminator Arrows tool on the Place Arrows and BarScales XM Edition 

tool bar.  (Terminator icon.) 

 
7. Set the Terminator to ArrTermPrEnd located in the rdwyeng.cel library. This terminator is 

a personal preference, use whichever arrow meets your needs. 
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8. Select the leader line and accept the line to place the arrow. Select near the end of the line. 
9. Set the MicroStation level to TextLabel.  
10. On the MicroStation Main Tool Palette (Classic), select Place Text. 
11. Set the Text Style to General Text Label. 
12. Check on the Height and Width and set them to 739.20. (.07 x 10560). 
13. In the Text Editor, key in LOCATION OF PROJECT. 
14. Place the text above the leader line. 
15. Adjust the length of the leader line if needed. 
16. The next figure shows the label and leader line pointing at the project location. 
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Optional Exercise: County Number 
PLACE COUNTY NUMBER NEXT TO COUNTY NAME 

In this exercise you will use the Fill in Single Enter_Data Field tool to place the county number 
next to the county name. The county number is made up of five numbers, the first two numbers 
are the county and the next three numbers represent the section of the road being worked on. This 
county number can be found on the straight line diagrams. 

1. Continuing in Keyssg01.dgn, zoom to the top center of the key sheet next to the text 
“VOLUSIA COUNTY”. 

 
2. From the MicroStation Main Tool Palette (Classic), select the Fill in Single Enter_Data 

Field tool. 
3. Issue a data point in between the parenthesis. A box will appear inside of the parenthesis, this 

lets you know you got the data field. 

 
4. In the Text Editor dialog, type in the county number 79120. 
5. Issue a data point in the view or click Enter. This will fill in the data field with the county 

number. 
6. Right mouse click to reset/cancel the command. 
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3 SUMMARY OF PAY ITEMS 
CHAPTER OBJECTIVES 

The objective of this chapter is to teach you how to create the Summary of Pay Items sheet. 

INTRODUCTION 
The Summary of Pay Items sheet is generated from data outputted from Trns*Port PES. In 
Trns*Port, there are two different outputs produced for pay item summaries: the Project Summary 
of Pay Items and the Proposal Summary of Pay Items. Use the appropriate report, based on the 
project’s phase.  

For early phase reviews (up to Phase III, or until the proposal has been created), the designer must 
use the Project Summary of Pay Items Report (the proposal report is not available during this 
phase of a project). If a designer anticipates the simultaneous release of multiple projects, he 
should print each project’s Summary of Pay Items for review. These reports are printed on 
standard 8.5" by 11" paper. A Project’s Summary of Pay Items sheet does not have to be in CADD 
sheet format for phase review submittals. 

For later phase reviews (Phase III or after the proposal has been created), the designer uses the 
Proposal Summary of Pay Items Report. After the designer submits the report from the designer 
interface menu, the output is sent to the CADD FTP site, ftp.dot.state.fl.us/outgoing/ces/, normally 
within 5-10 minutes. The output is transferred to a MicroStation graphics design file and placed 
on a standard formatted plan sheet via a program available in the Florida Department of 
Transportation (FDOT) Engineering/CADD Systems Software. The quantities listed in the plans 
must be kept current with the quantities in Trns*Port. Any revisions to the quantities in 
TRNS*PORT must be transferred and update in the graphics design file. The TRNS*PORT 
Quantities are used to prepare the bid documents and the quantities listed in the plans must 
match.  

When the Signal Plans are a component of the Roadway plans, the Summary of Pay Items Sheet is 
part of the Roadway plan set and is not included as part of the Signal Plans.  

The CADD version of the Summary of Pay Items Sheet is created by a program, Trns*Port 
Quantities option that is available on the FDOT Menu > Roadway submenu. This tool transfers 
the PES Output file and imports it into a design file and places it on a plan sheet.  
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GENERAL INFORMATION 
The Trns*Port Quantities tool gives you the option to place a border sheet file into the design file 
or to only import the PES text file so that you do not override the border and its settings. The next 
figure shows how to access the tool. 

 
The next figure shows the Trns*Port Quantities tool loaded from the FDOT Menu. The dialog is 
broken into two parts; the top portion of the dialog defines the sheet information and search paths. 
The bottom part of the dialog defines the label for the title block on the sheet border. 

 
DGN File Name – This is the path and name of the design file that the PES data will be placed 
into. It is not necessary to key-in the filename only the sequence number, (i.e. key in cessrd.dgn). 
The first sheet is placed at 10000, 10000 and the rest are stacked one above the other. Click 
Browse to navigate to the location of the file in your project directory if this was created 
previously or click New to create the file from the TRNS*port application dialog. 
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Input File Name - The name of the PES data input file, for example: p723423.dat. It doesn't 
matter where the PES data file is located as long as it is accessible by the file list box. This file 
may also be a text file, for example: 50735535201.txt. Click Browse to navigate to the location of 
the file in your project directory. 

FTP Site and FTP Path - After the designer submits the report from the designer interface menu, 
the output is sent to the CADD FTP site, ftp.dot.state.fl.us/outgoing/ces/, normally within 5-10 
minutes. 

Number of Cells - This is read from the PES data input file and is set when it is created. If the cell 
'SBCES’ cannot be found, a warning comes up prompting you to attach the correct cell library. 

Label Sheet - If these fields are filled in, the program places the sheet number, the title, and the 
project number in the appropriate fields on the sheet cell when it is placed. The Label Sheet 
toggle will disable the Label Sheet portion of the FDOT TRNS*port tool.  The labeling then can 
be completed by the Sheet Navigator application. 

 

Lab Exercise: Loading the FDOT Menu > Roadway Submenu 
IN THIS EXERCISE YOU WILL ATTACH THE ROADWAY SUBMENU TO THE FDOT MENU. 

17. If you closed MicroStation, open Keyssg01.dgn. 
18. From the FDOT Menu, open the FDOT Menu Configuration tool.  
19. Add Roadway and TrafficPlans to the menu options. 

 
20. Click Update. 
21. Click OK to make the configuration changes. 

Notice now that there is a Roadway menu on the FDOT Menu. 

 
The reason for attaching the Roadway Submenu to the FDOT Menu is because there are certain 
tools that are stored under the Roadway Submenu only. The next exercise uses one of those tools.  
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Lab Exercise: Transferring PES Data to Plan Sheet 
CREATE SUMMARY OF PAY ITEMS SHEET 

In this exercise you will create a new design file and import the Trns*Port text all at one time. 
FDOT delivers a tool to automate this process called Trns*Port. This tool can be started from any 
open MicroStation file. 

1. Continuing in Keyssg01.dgn, from the FDOT Menu, select Roadway > Sheets > Trnsport 
Quantities. This opens the Trns*Port tool. 

 
2. Select New in the DGN File field. This opens CES DGN dialog.  

 
3. For the file name, change it from Cessrd01 to Cesssg01.dgn. 
4. Click OK. This fills in the DGN File name in the Transport Data File dialog. 
5. For the Input File Select Browse. This opens Trns*Port Data File. 
6. Browse to the data folder in the project. 
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7. Select the 50735535201-3.txt file.  

 
8. Click OK in the Transport Data File dialog. This fills in the Input File name in the FDOT 

TRNS*port dialog and populates the Number of Cells needed. 
9. Fill in the Road Number with SR 415. 
10. Select Volusia as the County. 
11. Leave Financial Number blank. Sheet Navigator will populate this. 
12. For the Sheet Title, leave the default text. Sheet Navigator will change the case to all upper if 

necessary. 
13. Set the discipline to Signal. This will set the Sheet Number Prefix to T-. 
14. Set the Number to 2. This will number the sheet T-2. 

 
15. Click Load Summary of Pay Items. This will load the CES text file and place a border in the 

file. 
16. Close the FDOT TRNS*port dialog. 
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Lab Exercise: Update Sheet with Sheet Navigator 
ADD DIGITAL SIGNATURE NOTE AND UPDATE LABELS 

1. Continuing in Cesssg01.dgn, from the FDOT Menu launch Sheet Navigator. 

 
2. Notice the fields that are populated, also notice that all of the fields are upper case. Sheet 

Navigator by default places all text as uppercase that is why you left the text in the Transport 
tool lower case, this tool will fix it. It would have been a waste of time to retype the Sheet 
Description text in the Transport tool. 

3. For the Financial Project ID 1, click inside the blank field. This will populate the Project ID 
with the correct number. 

4. Set the Digital Signature Note to Standard. 
5. Click Save. This updates the sheet border. 
6. Close Sheet Navigator. 
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4 SIGNALS TOOLS 
CHAPTER OBJECTIVES 

The objective of this chapter is to teach you how to use Design and Computation (D&C) 
Manager, the FDOT Menu and other GEOPAK tools to create proposed Signal features.  

INTRODUCTION 
The Signal Tools section introduces several applications that help the user in the creation of 
Signals plans.  

As explained in Chapter One of this course material, you will create a new file, dsgnsg01.dgn, in 
which the Signals proposed design elements will be drawn. In addition, you must reference the 
proposed roadway design file, dsgnrd01.dgn, existing topographic file topord01.dgn, existing 
utilities utexrd01.dgn, existing drainage drexrd01.dgn, existing and proposed right-of-way files, 
and any additional files containing the existing features along the project.  

After the above is done, you are ready to clip the sheets. To aid in this task, you have two options 
available, the Traffic Plans submenu Clipping program, commonly known as the FDOT clipping, 
and the GEOPAK’s Sheet Clipping program. 

The next step is to draw/place the proposed Signal features in accordance with FDOT CADD 
Standards. The Traffic Plans submenu provides tools with the active settings (Level and 
Symbology) used to create the Signal features. There are additional tools available to help in the 
efficient placement of Signal poles and Controller Cabinets: D&C Manager and the GEOPAK 
Draw Cell group by Feature tool. 

Refer to chapter 24 in the Plans Preparation Manual, Volume II, for more detail on developing 
the Signalization plans. Refer to the Design Standards indexes for design criteria. 

The Labeling of the plan sheet items has been made easier with the use of GEOPAK’s Plan 
Labeler, which allows you to create styles for the placement of repetitive labels. 

To assure that you are adhering to the Traffic Plans CADD Standards, the Traffic Plans submenu 
provides an easy way to check and fix symbology to match the CADD standards. 

Finally, you must compute the pay items used and populate the Tabulation of Quantities Sheet. 
GEOPAK’s D &C Manager can calculate and report every “each” and “linear” item. D &C 
Manager generates a report that can be polished in Microsoft Excel, which can then be imported 
into the MicroStation Tabulation of Quantities design file. 
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CLIPPING SIGNAL PLAN SHEETS 
Clipping Signal Plan Sheets is different than clipping Roadway or Signing and Pavement Marking 
Sheets. Unlike SAPM plans there may only be one Signal Plan sheet. The user will use GEOPAK 
to layout and clip the sheet(s). The scale should not be smaller than 1” = 50’. 

If a Motif file is used, this should be set up prior to starting the clipping process. A Motif file is 
basically a template MicroStation file with all of the reference files attached that the user wants 
attached to each plan sheet. There is an option to use the active file when clipping. 

TO START THE PLAN SHEET LAYOUT TOOL 
1. From MicroStation, click Applications > MicroStation Civil Extension or Road > Plans 

Preparation > Plan/Profile Sheet Composition  
<OR> from the Road tool box, click the Plan/Profile Sheet Composition button. 

 
2. Once activated the Plan Sheet Layout dialog opens as shown next. 
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SHEET LIBRARY 
The Plan Sheet Layout tool uses an attached library that controls what sheet types are available. 
The Plan Sheet Library or “psl” files are located in the FDOT2008\geopak\dat_files folder. The 
Plan Sheet Library is accessed from the Plan Sheet Layout pull down menu option:            
File >Sheet Library.   

• Selecting Attach opens the Attach Sheet Library dialog as shown below. 

 
FDOT delivers these files ready to use, they cover the most common of the sheet configurations 
you will use. By default the rdplan.psl library is attached. You can look at the header of the 
dialog box to see which library is currently attached. 

• Selecting Edit opens the Sheet Layout dialog as shown below. 

 
The most important parameters in Sheet Layout: Sheet Library dialog are the following:  

Cell Library – Make sure the correct cell library is attached. 

Sheet Cell – This is the name of the cell representing the border. 

Sheet Cell Placement – Select how the Sheet Cell, Border, is to be placed. Either Place the sheet 
cell in each file or place it once in a border reference file.  
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Sheet Library items 
There are some settings in the sheet library that the user may need to adjust to make the plan 
sheets look the way they want. For example, if after the sheets are clipped and you notice that the 
offset for the left edge of the border to the clip limit is too small this can be adjusted in the library 
and the sheets re-cut. 

The next figure shows the Offset from Cell Origin as 0.200. This is the default as delivered from 
FDOT. When the sheets are clipped you will notice that the space from the left edge of the border 
to where the clip sheet starts is too small. 

 
The next image shows the top panel with the Offset from cell origin set at 0.200. Changing this 
value to 0.800 will shift the clip area over to a much better looking condition. 

 
The following figure shows the results after changing the Offset from Cell Origin. 
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SHEET LAYOUT SETTINGS 
The Sheet Layout Settings dialog is available from the Plan Sheet Layout pull down menu 
option:  Settings > Plan Sheet Layout. This dialog instructs the sheet clipping application to cut 
sheets a certain way. For example: do you want the clipping to go from Left to Right, is there a lot 
of elevation relief on the project, if so than set the stair stepping ON and how do you want the 
sheet view attributes set up, use the current design file or a Motif  file. 

 
A Motif file is nothing more than a MicroStation design file with reference files attached and level 
symbology set up the way you want the plan sheets to look when clipped. FDOT has established a 
standard design file name MTPLSG01.dgn. Once the Motif file is created the user would attach 
the appropriate reference files and turn on or off the levels to make the file look the way the user 
wants the plan sheets to look. The user can also set up any level symbology that is required. 

SHEET COMPOSITION 

Sheet Composition  controls how the limits of the sheets are handled. The options are: 

1. By Begin Station/Overlap 
2. By Station Range: Inside Out 
3. By Station Range: Outside In 
4. By Station Range: Radial  
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The Station Range is a factor of the Clipping Scale. Look in the PPM, Volume 2, Chapter 10, for 
the values to be used in the Station Range. These values are filled in based on the scale entered, 
but may need to be adjusted to fix areas in sharp curves where portions of the design files are 
missed.  

These four options are covered in great detail in the Basic GEOPAK for Roadway Designers 
training guide. In this training course you will use the option By Station Range Radial. 

By Station Range Radial  
With this option the Horizontal distance is used to trim the Station Range. The Maximum 
Drawing Area, Horizontal and Station Range are inter-related. The resultant clipping shapes are 
not rectangular; instead the Vertical edges are oriented perpendicular to the alignment, which 
results in rectangular shapes along tangent sections and more of a trapezoidal shape along curved 
sections. Adjusting the Station Range will alleviate the pie shaped wedges along curves. 

 
The critical value in this option is the Station Range. This should be set based on the standards 
delivered in the PPM. For example, for 100 scale sheets the Station Range should be set to 1400. 
This is the maximum value and may be decreased to handle alignments with unique conditions 
like sharp curves or intersections. 

Horizontal is used for the clipping limits at the ends of the sheet. If the user adjusts the 
Horizontal distance the Station Range will dynamically change by the Horizontal distance times 
two. 

Vertical sets an additional clip limit from the defined sheet width. In the figure above, the red 
dashed rectangle represents the Maximum Drawing Area. Entering a value other than zero will 
reduce the clip limit by this amount.  

The sheet layout process is a multiple step process because of the items mentioned earlier, curves 
and intersections. There are three ways to approach this: 

1. Layout all clip sheets from begin project to end project then adjust the sheets at the 
intersections and around curves to clean up the pie shaped wedges. 

2. Layout single sheets at all of the intersections then run the remaining clip sheets up to the 
intersections and after the intersections. It is good practice to try to center intersections on the 
plan sheets if possible. 

3. Get the clipped sheets from the Roadway group and rename them to signals sheets. As long as 
the scales are the same this option works fine. 
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SHEET LAYOUT 

The Sheet Layout  is used to define the Ports and alignments and station range to run the 
layout along. 

 
Job – This is the gpk. If Project Manager is used, this will be filled in automatically. If Project 
manager is not used you will have to select it using the magnifying glass icon. 

Multiple Sheets – The user is clipping more than one sheet. 

Single Sheet – The user is clipping only one sheet. 

Port – In a Plan/Profile scenario Port 1 would be the Plan view and Port 2 would be the Profile. 
For Plans that are Double Stacked with two plan views both Port 1 and 2 would be Plan. 

Type – This is either the Plan or Profile area. In a scenario like Signalization Plans there will only 
be a Plan port. 

Dependency – This instructs the Port to either be dependent on an Alignment or another port. 

Alignment – This is a GEOPAK chain that the sheets are clipped along. 

Offset – This allows the user to set the clip borders at an offset from the Alignment. 

Motif File – This shows whether a motif file is used and if so what the name is. 

Double-clicking on one of the Plan ports in the Layout Settings tool opens the Plan Port Data 
dialog as seen below. This is where modifications are made to set up the Layout Settings dialog. 

 
Begin and End Station – This defines where the first sheet starts and the last sheet ends. The user 
can either key in the values or use the Select icons to dynamically pick the stations. It is highly 
recommended that you select and even station or snap to an even tick mark for the begin station so 
that the sheets will all fall on even stations. 

Extend – This allows the user to start the first sheet at a defined distance prior to the Begin 
Station. This is good for leaving space to General Notes or if you anticipate additional design that 
may occur before the Begin Station.  This can be used to account for that. The same applies for the 
End Station. 

Layout Sheets – This button will show the user the number of sheets needed based on the Begin 
and End Stations. Clicking this button will draw the clip borders into the active design file. 
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SHEET NUMBER MANAGER 

Sheet Number Manager  provides a method for applying sheet and sequence numbers to the 
clip borders. The main window contains a list of the sheet borders contained in the file. In the case 
of dual clip borders for a single sheet, i.e. Plan/Profile sheets, the borders are grouped together and 
only listed once in this window. Select a line in the window and click the up and down arrow 
buttons to move the Sheet in the sequence order. The next two buttons allow for the manual 
editing of sequence and sheet numbers. The ID button is used to graphically select a sheet to 
modify. Select the Highlight Clipping Shape check box or Window Center Clipping Shape if 
applicable.  

Keep in mind that this is the MicroStation design file name for the sheet not the actual sheet 
number that is placed in the title block. Knowing this, the user should always run Sheet Number 
Manager and add a Prefix of ‘0’ to the sheets so when the sheets are clipped the file names will be, 
as an example: Plansg01.dgn not Plansg1.dgn. This will make organizing and managing the files 
in explorer much easier. 
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MODIFY SHEETS 

The Modify Sheets  allows the clip sheet borders to be adjusted prior to actually clipping the 
sheets. The Sheet Modify command opens Plan Sheet Layout: Modify, which operates in two 
modes, Slide Sheets or Modify Drawing Area, represented by the two buttons in the upper left 
corner. The following figure shows the Slide Sheets mode.  

Slide Sheets is used to move the clip borders along the alignment. Type a specific station in the 
box and choose the Left Station, Center Station, or Right Station to apply the new station. Left 
Station, Center Station, or Right Station refers to the portion of the clip border that is located at 
that station. Another option is to change the Sheet Chord Offset of the border to allow the 
movement of the sheet parallel to the alignment in either direction for a given distance. 
Additional Rotation can also be applied. This angle is measured from the left station and is in 
reference to the alignment. Perform any of these three actions dynamically with the Dynamic 
buttons to the right of the respective function.  

 
Modify Drawing Area changes the composition of the borders. Type the appropriate dimensions 
in the Drawing Shown, Horizontal, and Vertical boxes, and then select Left Station, Center 
Station, or Right Station from the Hold To list.  

 
In either mode, select which sheet is being modified from the Shape list, or click the Identify 
button to do so graphically. Select the Slide Preceding Sheets check box and/or the Slide 
Following Sheets check box to indicate if the sheets preceding and following the modified sheet 
are to be slid to compensate for the changes made to the current sheet border. To make any 
changes effective, click the Apply button. 

  



Chapter 4 Signals Tools- Clipping Signal Plan Sheets 

4-10 ©2009 FDOT FDOT Traffic Plans Course - Signalization 

CLIP SHEETS 

The Clip Sheets  actually clips the plan sheets based on all of the previous settings. 

 
The Output File section allows the user to specify where sheet files are created and what to name 
them.  

Directory – Select the path where the new sheet files are to be placed.  

Sheet Name Prefix – Type the name of the sheet file. Type only the first part of the file name; the 
software supplies a numerical suffix that corresponds with the sheet number. For example, if 
PLANSG is entered as the prefix, as the sheets are clipped the files are named PLANSG01.DGN, 
PLANSG02.DGN, PLANSG03.DGN, etc.  

Rotate Reference or Rotate View – Rotate Reference is used when stacking more than one sheet 
per file and Rotate View is used when only one sheet per file is used.  

Sheets per File – Type the number of sheets to be created in each design files. 

Sheet Range Begin and End - Select the range of sheets to be created from the clip borders. 

The Labels and Annotations section allows the user to enter a Sheet Title and Project Number, 
as well as Match Line text when applicable. The user cannot enter this information if the 
annotation information is not set up in the Sheet Library. Typically the user would not use this 
section to label the sheets. 

Note If this section is grayed out that is because of the Sheet Annotation settings in the 
attached library are toggled off as seen in the next figure. 

  
Process Sheets – This button when pressed starts the sheet clipping process. 
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Lab Exercise: Create Plan Sheet Border and Clip File  
CREATE THE BORDER REFERENCE FILE 

In this exercise the user will create the Plan Sheet Border if it has not already been created. 

1. Open the FDOT2008 folder on the desk top. 
2. Start the Create File/Project tool. Use the icon for 2008 files. 
3. In the Create File/Project tool, set the File Type to Signal Design Files (DGN). 
4. Select Border Sheet Plan. This will create the file Bdplsg01.dgn and place it in the Signals 

folder. 
5. Click Create. 
6. Click OK to acknowledge the file creation. 
7. In Create File/Project tool, select Clip Borders. This file is used by the GEOPAK Sheet 

Clipping tool. 
8. Click Create. 
9. Click OK to acknowledge the file creation. 
10. Click OK on the Create file/Project dialog to close it. 
11. Start MicroStation and open the Border previously created, BDPLSG01.dgn. 
12. Set the Plot Scale to 1.0. No need to place a sheet border at this time, the sheet clipping 

process will place the border sheet cell. 

Lab Exercise: Clip Sheets 
ATTACH REFERENCE FILES 

In this exercise the user will attach all necessary reference files to the clip file. 

Open Clipsg01.dgn in the Signals folder. 
Open the Reference dialog. 
Attach these files from the Roadway folder: 

• Algnrd01 – Model Default 

• Algnrd01 – Model BL50 

• Dsgnrd01 – Model Default 

Attach this file from the Signing folder 

• Dsgnsp01 – Model Default 

Attach this file from the Signals folder 

• Dsgnsg01 – Model Default. 

Zoom in near station 620+00. This is the same intersection worked on in previous exercises. 
Rotate the view by 2 points using two station tick marks and selecting from left to right. This 

aligns the baseline horizontal to the view. 
Save Settings. 
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LOAD PLAN/PROFILE SHEET COMPOSITION TOOL 
1. Continuing in Clipsp01.dgn start select Plan/Profile Sheet Composition from the GEOPAK 

Road tools palette or from the Applications > GEOPAK Road > Plans 
Preparation>Plan/Profile Sheet Composition pull down. 

 
2. Select the SR415.prj file located in the Roadway folder.  This opens Plan Sheet Layout. 

 
SHEET SETTINGS 

1. In Plan Sheet Layout, select the sheet type PlanSingle. This is done by selecting the drop 
down menu on the right hand side of the dialog. 

2. Set the Scale to 50.00. This is next to the sheet type. 

 
3. In Plan Sheet Layout, select File > Sheet Library > Edit. This opens Sheet Library. 

 
4. In the Sheet Cell Placement portion of the dialog, select Place Sheet Cell Once in a 

Reference File. Use the magnifying glass icon to browse to the border sheet created earlier. 
5. Close Sheet Library by clicking on the X in the upper right-hand corner. 
6. Click Yes to save changes made to the library. 
7. In Plan Sheet Layout, select Settings > Sheet Layout. This opens Sheet Layout Settings. 

 
8. Set Sheet Layout Progression to Left to Right (Standard). 
9. Set Profile Stair Stepping to Off. 
10. Set Sheet View Attributes to Use Current Design File. 
11. Click OK. 
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SHEET COMPOSITION 

1. Open Sheet Composition . This can also be loaded from the Tools menu. 

 
2. Set the method to By Station Range: Radial. 
3. Set the Station Range to 750.00. This can be adjusted after the clip border is placed. 
4. Close Sheet Composition. 

 

LAYOUT SHEETS 

1. Click the Layout Sheets icon  or select from the Tools menu. 
2. The Job number should be set to 415. If you do not use Project Manager you will have to 

browse and select the gpk. 
3. Set the method to Single Sheet. The options are Single or Multiple. 
4. Double-click on Port 1. This opens Plan Port Data. 

 
5. Set the Chain to BLCONST. 
6. Set the Offset to 0.00. 
7. Click OK. 
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8. Set the Begin Station to 618+80. The End Station will default to 626+30; this is 750’ as set 
in the Sheet Composition dialog. 

 
9. Click the Layout 1 Sheet button. This will draw the clip shape into the design file. 
10. Close Layout Settings. 

 

MODIFY SHEET 
In this part of the exercise the user will adjust the horizontal and vertical clip limits from a full 
plan sheet to an area that just covers the intersection. 

1. Click the Modify Sheets button . 

 

2. On the top-left corner, click Modify Drawing Area  . 
3. Under Lateral Dimension, set Hold To Left Station. 
4. For Drawing Shown, enter 240.0. This sets the Horizontal to 255.0. 
5. Set the Vertical to 100.0. 
6. Click Apply. 
7. Close Plan Sheet Layout. 
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SHEET NUMBER MANAGER 
This process will place a 0 in the design file name so that it reads as Plansg01.dgn and not 
Plansg1.dgn. 

1. Click the Sheet Number Manager button . This opens Sheet Number Manager. 

 
2. Select the sheet.  

3. On the right-hand side of the dialog click the Edit Sheet Number button  . This opens 
Edit Sheet Number. 

 
4. Toggle on Add Prefix. 
5. Enter a 0 for the Prefix. 
6. Click OK. This will change the sheet number to 01. 
7. At the bottom of Sheet Number Manager, toggle on Window Center Clipping Shape. 
8. Select Sheet 01. This will zoom and center on sheet 1. This is very useful when there are 

multiple sheets. 
9. Close Sheet Number Manager. 
10. Click Yes to Save Sheet Number Changes. 
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CLIP SHEETS 

1. Click the Clip Sheets button . This opens Clip Sheets. 

 
2. For the Directory, use the magnifying glass to browse to the project Signals folder. 
3. For Sheet Name Prefix enter Plansg. The full file name will appear in to the right of the 

prefix space. 
4. For Orientation select Rotate View. The options are Rotate View or Rotate Reference. This 

is a personal preference. 
5. Set the Sheets per File to 1. 
6. Set the Model to Active. The Sheet Range is ok as is. 

Note The sheet range settings allow the user to pick a range of sheets to clip in case you do 
not want to clip all of the sheets at this time. This is useful as a check to make sure all of 
the settings are the way you want them before clipping a mass number of sheets. 
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7. Labels and Annotations, this will be grayed out if the options are turned off in the sheet 

library. If they are active, it is not necessary to fill them in as you will use Sheet Navigator 
to populate the title block.  

8. Click Process Sheets. This will start the sheet clipping process. 
9. Close Clip Sheets. 
10. Open Plansg01.dgn in the Signals folder. 
11. Take a moment to review the sheet and reference files and level settings. If the settings are not 

the way you want them, go into the clip file and fix them and re-clip the sheet. 
12. Close Plan Sheet Layout. 
13. Click Yes to save settings if you utilized Project Manager for this Lab. 
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Lab Exercise: North Arrow 
PLACE NORTH ARROW 

Now that there is a clip border it is easy to know where to place the North Arrow so that it falls 
within the plan sheet clip limits. It is very important that the user set the view to the setting 
Unrotated before placing the North Arrow. 

1. Open Dsgnsg01.dgn in the Signals folder. 
2. Zoom to station 620+00. 
3. Attach the reference file Clipsg01.dgn from the Signals folder. 
4. From the MicroStation view commands, select Rotate View. 
5. Set the Rotate View to Unrotated. 

 
6. From FDOT Menu, select Traffic Plans > Arrows-Barscales. 

 
7. Select the Place North Arrow icon at the far left of the dialog box that appears. 

 
8. Place the North Arrow near the upper-right corner of the clip limits. 
9. Right -click to Cancel the command. 

 

LABEL NORTH ARROW WITH THE SCALE 

 
1. From FDOT Menu, select Traffic Plans > Arrows-Barscales > Label North Arrow with 

Scale. 
2. Pick the North Arrow just placed. 
3. Issue a data point to place the label. 
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Lab Exercise: Border Sheet Title Block 
FILL IN TITLE BLOCK USING SHEET NAVIGATOR 

1. Open Bdplsg01.dgn in the Signals folder. 
2. From FDOT Menu, select Utils > Label Sheets (Sheet Navigator). 
3. Leave the Sheet Number field blank, this will be covered later using the Auto Numbering 

process. 
4. For the Financial Project 1, pick inside the blank field, this will automatically populate. 
5. Set the County to Volusia. 
6. For the Road Numb enter SR 415. 
7. Set the Digital Signature Note to Standard. 

 
8. Click Save Sheet. This tags the sheet. 
9. Close Sheet Navigator. 

Note The Sheet Description will be populated in the Plan Sheet. 
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Lab Exercise: Adjust Sheet Border  and Title Block 
SLIDE BORDER REFERENCE FILE AND FILL IN TITLE BLOCK 

In this exercise the user will shift the border to position the intersection on the right side of the 
plan sheet. The user will also fill in the title block using Sheet Navigator. 

1. Open Plansg01.dgn in the Signals folder. 
2. Open the reference file palette. 
3. Select the Border reference file, Bdplsg01.dgn. 
4. In the References dialog select Tools > Move. 
5. Move the border reference file so that the intersection is located on the right side of the sheet. 

Hint Use AccuDraw to assist in moving the border. 
6. In MicroStation, select File > Save Settings. 
7. From FDOT Menu, select Actions > Label Sheets (Sheet Navigator). 
8. In Sheet Navigator in the Sheet Description field, enter SIGNALIZATION PLAN. 

 
9. Click Save.  
10. Close Sheet Navigator. 
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Lab Exercise: Annotation Scale 
SET ANNOTATION SCALE IN PLAN SHEET 

In this exercise the user will set the Annotation Scale for the default model to 1”=50’. Setting the 
Annotation Scale will make placing text easier. 

1. Continuing in Plansg01.dgn, open the Models dialog. 
2. In the Models dialog, select Edit Model Properties. 

 
3. Set the Annotation Scale to 1”=50”. 

 
4. Click OK in Model Properties. 
5. Click Yes on the Alert dialog. 

 

 
 

6. Close the Models dialog. 
7. In MicroStation, turn on the Annotation Scale lock. 
8. In MicroStation, save the settings. 
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Lab Exercise: Signal Head Detail 
PLACE SIGNAL HEAD DETAILS 

In this exercise the user will use the Signal Cell Webpage to place the Signal Head Detail. 

1. Continuing in Plansg01.dgn, zoom to the left side of the plan sheet. 
2. From FDOT Menu, select Traffic Plans > Signals > Signal Cells Webpage. 
3. Scroll down and select the cell 3 Section 1 Way Horizontal. 

 
4. Place the Cell near the top left -corner of the plans sheet. 
5. Right Click to Cancel. 
6. From FDOT Menu, select Traffic Plans > Signals > Signal Cells Webpage. 
7. Scroll down and select the cell 5 Section 1 Way Thru-Left Horizontal. 

 
8. Place the Cell next to the first cell. 
9. Right Click to Cancel. 
10. The Assembly text and Pay item Number Box contain data fields which can be edited using 

the Edit Data Fields tool in MicroStation. 
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PLACE DETAIL TEXT 
In this exercise the user will place the description text “SIGNAL HEAD DETAIL” below the two 
signal heads placed in the previous exercise. This note is bigger than normal text so the user will 
have to temporarily turn off Annotation Scale to set the text height manually. 

 
1. Continuing in Plansg01.dgn select Place Text from the MicroStation Main Classic tool 

palette. 
2. Set the Text Style to General Text Label.  This will set the MicroStation level and Text 

Style. 
3. Turn off Annotation Scale by clicking on the Annotation Scale button next to the lock for 

Text Height and Width. 

 
4. Check on the Height and Width. 
5. Set the Height and Width to 5.0. This would be 0.1 x 50 = 5.0. 
6. In the Text Editor type in SIGNAL HEAD DETAIL. 
7. Place the text below the two signal heads. 
8. Right click to Cancel the command. 

Note When the user selects another text style the Annotation Scale will be turned back on. 
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Lab Exercise: Controller Timing Chart and Loop Detector Chart 
PLACE CONTROLLER TIMING CHART 

This exercise is to help familiarize the user with the Signals Cell webpage.  

1. Continuing in Plansg01.dgn zoom to the bottom left side of the plan sheet. 
2. From FDOT Menu, select Traffic Plans > Signals > Signal Cells Webpage. 
3. Scroll down and pick the cell Timing Chart Controller 8 Movements. 

 
4. Place the cell in the design file. 
5. Repeat the previous steps to place the Loop Detector Chart Standard. 

 
6. Both of these cells have data fields built into them to aid the user in populating the data. 
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Lab Exercise: Mast Arm Assemblies Sheet 
CREATE MAST ARM ASSEMBLIES SHEET 

In this exercise the user will create the Mast Arm Assemblies sheet and place the standard notes 
and table. 

1. Using the Create Edit File/Project tool from FDOT Menu, create the Mast Arm Detail 
and Tables sheet. 

 
2. Open the Mast Arm Detail sheet by clicking the Open DGN button after creating the file. 
3. Set the Plot Scale to 50. This will be the default scale after creating the file. 
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4. From FDOT Menu, select Traffic Plans > Signals > Mast Arm Tabulation Sheet > Place 
Sheet Mast Arm Design Table. 

 
5. Place the sheet cell in the design file. 
6. Right-click to Cancel the command. 
7. Using Sheet Navigator, fill in the title block. Do not place the sheet number. 

 
8. Click Save 
9. Close Sheet Navigator. 
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FILL IN TABLE 
The table in this sheet has a excel spread sheet that can be opened from FDOT Menu, edited and 
then placed in the MicroStation file. 

1. From FDOT Menu, select Traffic Plans > Signals > Mast Arm Tabulation Sheet > Edit 
and Place Data. 

 
 

2. Click the Edit Input  icon to open the appropriate Excel sheet named SHMAT3.xls. 
3. In Excel, enter the appropriate data and save the file.   

(Do not close the Excel.  It must remain open to perform the rest of the Lab.) 

 

4. From Edit Excel Summary Box dialog, select Place Text  icon. 
5. Snap to the end of the first horizontal line under the label STRUCTURE ID NUMBERS. 

 
6. Issue a data point to place the text. 
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Lab Exercise: Mast Arm Tabulation Detail Sheet 
CREATE NEW FILE 

1. Using the Create Edit File/Project tool from FDOT Menu, create the Pole Tabulation and 
Details for all Types. 

 
2. Open the PLDTSG01.dgn file. 
3. Set the Plot Scale to 50. 
4. From FDOT Menu, select Traffic Plans > Signals > Mast Arm Tabulation Sheet > Place Mast 

Arm Sheet 1. 
5. Issue a data point in the file to place the sheet. 
6. Right-click to Cancel the command. 
7. Using Sheet Navigator, fill in the title block. Do not place the sheet number. 

  



Signals Tools - Clipping Signal Plan Sheets Chapter 4 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 4-29 

FILL IN TABLE 
The table in this sheet, just like the previous sheet, has an excel spread sheet that can be opened 
from FDOT Menu, edited and then placed in the MicroStation file. 

1. From FDOT Menu, select Traffic Plans > Signals > Mast Arm Tabulation Sheet > Edit 
and Place Data.  Be sure to select the Excel file from below the Place MastArm Sheet 1. 
See figure below. 

2. Click the Edit Input  icon to open the appropriate Excel sheet named SHMAT1.xls. 
 

 
3. In Excel, enter the appropriate data and save the file. 

 

4. From Edit Excel Summary Box dialog, select Place Text  icon. 
5. Snap to the end of the first horizontal line under the label ID NUMBER. 

 
6. Issue a data point to place the data. 
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STRAIN POLE SCHEDULE SHEET 
Creating the Strain Pole Schedule sheet follows the same process used in the last two exercises. 
The user would create second Pldtsg02.dgn file then from FDOT Menu select the Strain Pole 
Schedule Sheet for placement. As with the Mast Arm sheet the Strain Pole Schedule Sheet has an 
excel spread sheet that can be edited and imported into the MicroStation file. The Place Text 
option in this menu item sets the MicroStation level and also sets the text style to Summary 
Table. 

 

 
 

EXPLORING DESIGN AND COMPUTATION MANAGER 
The Design and Computation Manager or D&C Manager uses a proprietary database that is 
provided by FDOT. When the FDOT software is installed, the latest Design and Computation 
Manager database (DDB) is placed either on your server or on your local hard drive. For new 
projects, it is recommended that you copy the latest DDB file from the FDOT installation folder 
into your project SYMB folder and rename it to the eleven digit FIN number.   

For the 50735535201 project used as the example in this manual, the fdot2008.ddb is renamed to 
50735535201.ddb. This allows you to modify the database for specific parameters, and protect it 
from being overwritten by any future maintenance updates. The latest FDOT .ddb file is in the 
\FDOT2008\geopak\databases\ folder.  The naming format is fdot####.ddb where #### is the 
year of the .ddb file.  

Once D&C Manager is opened during a design session it should not be closed, just minimize the 
dialog. This tool loads slowly because of the number of items in the database. It is highly 
recommended that every user that works on projects becomes very familiar with D&C Manger. 
D&C Manager should be the standard tool used by everyone whether they are drawing simple 
lines or designing major interchanges. Many other applications and processes rely on the features 
that D&C places on elements, if these features are not found then drawing cross sections, for 
example, would be nearly impossible. 
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This database has been set up specifically by FDOT to create elements with the correct level 
symbology according to FDOT CADD Standards. The .ddb file is set up with discipline folders 
called categories. Inside of each category are items.  

• Categories - The basic component of the hierarchical tree is the Category, which is 
represented by a folder icon. The fdot2008.ddb database categories are divided by discipline. 
The figure above shows the Categories with a description relative to their discipline.  Inside 
these Categories you have either subcategories or items. Items are represented by one of three 
icons as described below.  

•  Items - The other database component is the item. An item could be a drafting item, a 
compute item or a default item. Items contain specific functions related to defined element 
symbology or quantity calculations. Items are represented by one of three icons: 

 Default Icon -These items are used to set drafting standards for MicroStation 
commands or 3PC routine.  

 Drafting Standards Icon - These items are used to set drafting standards for 
MicroStation commands or to draw COGO elements with annotation. 

  Calculator Icon - These items are used to set drafting standards for MicroStation 
commands or to draw COGO elements. The graphics can be tagged with a pay item attribute 
for additional stratification of features when running computations. Computation parameters 
are defined for these items. 

DESIGN AND COMPUTATION MANAGER MENU BUTTONS 
D&C Manager has a toolbar to quickly access different modes. The function of each button is 
summarized below.  

 

 Switch to Toolbox Mode. D&C Manager is set up to work in two different modes, as a 
dialog box or a toolbox. This button activates the toolbox mode. This toolbox can be resized and 
docked. To change the display back to the whole dialog box, click the Switch to Dialog Mode 
button. The Place Influence check box is at the left end of the toolbox.  
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 Identify Item. The Identify Item button is used to identify the D&C Manager item to a 
selected MicroStation element previously drawn by the D&C Manager or elements drawn with 
Graphical COGO and the SMD file. If the item you ID does not match an item in the active 
database, a message appears in the status bar saying: No matching database item. This is a very 
useful tool for new users learning the hierarchy of the database. 

 Display.  The Display button filters the display of MicroStation elements in the design file 
so only the selected features are displayed, highlighted or hidden. This button expands D&C 
Manager to show a collection bin. This collection bin is for controlling the display of multiple 
items at one time. To add items to the collection bin, double-click the item. This tool also opens a 
second tool box with four buttons as seen in the figure below. 

 
From left to right the buttons are: Normal Display, Highlight Selection, Hide Selection and 
Display Only Selection. We will cover all of these in the exercises. 

 Design. The Design button is used to plot COGO and MicroStation elements into 
MicroStation with the defined symbology, GEOPAK Attributes and/or GEOPAK Adhoc 
Attributes by use of Draw Plan and Profile dialog or in conjunction with MicroStation 
commands when Place Influence is toggled on. 

 

 Set. The Set button is used to set the symbology of previously drawn MicroStation graphic 
elements in accordance with the parameters of a selected item in the database. This is the tool you 
use if an element needs to be fixed to meet CADD standards. 
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 Compute. The Compute button is used for tabulating quantities of items that have been 
placed as a Pay Item by use of the Design or Set mode or have been drawn in MicroStation and 
they match the search criteria of the ddb file. This tool also expands D&C Manager to show the 
collection bin; this allows you to process multiple pay items at one time. A second toolbox 
containing the computation results is also opened. Computing is covered later in this course. 

  

 Shapes. The Shapes button uses plan view MicroStation graphics that defines an enclosed 
area to create a filled shape for computing area quantities.  

 Pavement Marking. This mode provides additional options for placing pavement striping 
and markings. This tool adds four additional tools to D&C Manager as shown in the figure below.  

 
The four tools from left to right are:   

• Striping 

• Separation 

• Chevron Diverge 

• Chevron Merge 

 Preference. This expands the toolbar to include four additional buttons to configure D&C 
Manager. These tools are also accessible from the Edit menu. 
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DESIGN SETTINGS 
There are some settings that need to be addressed before using D&C Manager to draw or 
compute items. These are the Design Settings loaded from the Settings>Design menu in D&C 
Manager. 

 

Element Connectivity 
Maximum GAP Tolerance – If the distance between two specified elements in a MicroStation 
file is smaller than the Max Gap Tolerance, the software assumes the two elements intersect and 
act accordingly. If the distance is larger than the Max Gap Tolerance, GEOPAK assumes the two 
elements do not connect. 

Deduction tolerance – The Deduction Tolerance is utilized in the Compute mode. For example, 
if the pay item is specified for a curb line, and for each manhole (drawn in as a cell), there is a 
deduction of six feet. The origin of the cell does not have to be on the curb line, but must be within 
the deduction tolerance in order for the cell to be recognized and the deduction to be made. 

Custom Line Style Creation 
Custom Line Style Creation – The Custom Line Style Scale Factor utilized during the Draw 
Plan & Profile dialog. Note this scale is only for custom line styles. Text and other labeling are 
controlled by the Label Scale on the Draw Plan & Profile dialog. 

Cell Creation 
Cell Creation – Plot Scale is utilized as a ratio with the Creation Scale within the setup of D&C 
Manager. If the Cell Creation Scale is 10 and the designer wants the cell twice as large as a cell 
placed with D&C Manager, utilize 20 as the Drawing Scale. 

If a drawing scale is entered all subsequent cells that are placed from the D&C Manager are scaled 
accordingly if the item is set to use creation scale. When the user places a cell with place influence 
on, GEOPAK utilizes the drawing scale setting to compute an X & Y scale for use in the 
MicroStation place cell dialog. Why do this? Otherwise, the user has to key- the X & Y scale in 
the place cell dialog whenever you change the item to be placed in D&C Manager. This also 
allows you to use a metric ddb with English cells by using a different creation scale. 

Influence Graphic Cell Level Symbology – When active, GEOPAK utilizes the symbology 
within the D&C Manager, ignoring the element symbology defined in the cell. 
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DESIGN MODE 
Design Mode is the default mode when the D&C Manager is opened. Design Mode is used for 
the following functions:  

• Set Drafting Standards by use of the Place Influence command for the placement of 
MicroStation elements using MicroStation commands. 

• Plot COGO elements into the design file according to the drafting standards set by 
the item’s defined parameters. 

• Place Adhoc Attributes on an element. 

Whether an item is placed in the file by generic MicroStation commands or plotted from the 
COGO database, the items can be placed as pay items for future tabulation. The following 
sections will detail the procedure to set drafting standards for MicroStation commands and for the 
plotting of COGO elements. 

By selecting Place Influence, you can use MicroStation commands to place elements utilizing 
the element attributes established for the currently selected item in the GEOPAK D&C Manager 
database. With some items, a GEOPAK attribute is placed with the element for calculating 
quantities.  

 
When Place influence is selected the MicroStation level symbology is set. Any MicroStation 
command to draw a line, copy a line or place a cell is set to this symbology. 

 
When the user is finished placing the elements for a selected item it is important to remember to 
turn off Place Influence. 

It cannot be stressed enough how important it is that all users working on projects become familiar 
with D&C Manager and use this tool for everything they do. D&C Manager should be the first 
tool opened when MicroStation is started and the last tool closed when the work day is done. 
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ADHOC ATTRIBUTES 
An Adhoc Attribute is additional information about a particular element. Look at it as just 
another property for the MicroStation element. Example, a line has this fundamental data 
associated to it: 

• Level 

• Color 

• Weight 

• Style 

By placing an Adhoc on the line you are giving that line additional information. That information 
could be a chain name, cross slope, profile name, thickness, etc. It is almost limitless as to what 
can be associated to an element with Adhocs. These Adhocs can be used by other applications 
downstream to generate quantities, draw cross sections or many other tasks. 

AdHoc Attributes are comprised of three types of information that must be defined:  

1. Name  
2. Type 
3. Value  

The Name is an identifying term used when GEOPAK is searching for a specific Adhoc 
Attribute.  

The Type identifies the nature of the information, and can be set to various options: Numeric, 
String, Unit, Quantity, and Remarks.  

The Value is the actual information to be used by GEOPAK, and is determined by the Type. For 
example, if the Type is set to Numeric then the Value must be a number.  

DRAWING SIGNAL POLES 
Generating the proposed Signal design is the responsibility of the engineer. Currently FDOT is 
developing a signalization program that will aid in the drawing of the signal poles regardless if it 
is a mast Arm or Strain Pole. The program prompts the user to select an Arm type and it will tag 
that Mast Arm with AdHocs to be used during quantity computation. 

There are a couple of ways to approach drawing the Signal poles into MicroStation, the user 
could use D&C Manager in conjunction with other GEOPAK tools to draw the signal poles at 
the specified location or the user could use the signal program to draw the poles.  

DRAWING OTHER FEATURES 
Pull boxes, Conduit and Loop Detectors are also important parts of the Signal plans. In this course 
the user will learn how to place these elements using D&C Manager. The user will also learn how 
to attach an AdHoc attribute on the signal poles for use in generating automated quantities. 
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DRAW CELL BY FEATURE 
One of the options the user has to draw the signal elements is the Draw Cell by Feature tool in 
GEOPAK. This tool is best suited for placing one cell at a time like a Mast Arm foundation or 
Loop Assembly.  

The Draw Cell by Feature tool can be loaded from the MicroStation pull down menu 
Applications > Road > Plans Preparation > Draw Cell by Feature.  

This tool can also be loaded from the Road Tools palette. 

 
The Draw Cell by Feature tool is very user friendly and requires little explanation. 

 
Note This tool is not available in MicroStation Civil Extensions and FDOT has not 

completed their internal equivalent Draw Cell application.  You will need to deactivate 
MicroStation Civil Extensions and load Bentley Civil from the Applications pull 
down menu. 
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DRAW CELL GROUP BY FEATURE 
Another option the user has to draw the light poles is the Draw Cell Group by Feature tool in 
GEOPAK. This tool works well when placing multiple cells at one time. 

Note When using the Draw Cell Group by Feature and/or Draw Cell by Feature 
tools, always ensure to load the correct GEOPAK Database (*.ddb) as the tool will 
'reset' the Database to the *.ddb specified in the resource file every time the tool is 
closed and reopened.  This GEOPAK Database (*.ddb) may not be the database 
intended for use with your active project. 

The Draw Cell Group by Feature tool can be loaded from the MicroStation pull down menu 
Applications > Road > Plans Preparation > Draw Cell Group by Feature.  

This tool can also be loaded from the Road Tools palette. 

 

Feature Group 
Defines the D&C Manager item to use which in turn selects the cell to be placed and the Offset 
from the selected element to place the item. 

 
Based on the items that are checked you can place up to three different cells with this tool. The 
Magnifying glass next to each item allows the user to browse to D&C Manager and select the 
appropriate item which will attach the cell to be drawn. The Offset is the distance off of the 
selected DGN Element or Chain when drawing the cell.  
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Location  
Defines whether you use a DGN element or Chain, Begin and End stations and Spacing. 

 
Element – This is either a GEOPAK Chain or DGN element. This functions just like the Draw 
Striping tool. The Begin and End fields will be populated with the appropriate data based on the 
element selected. They can be modified using the buttons or by keying in the value. 

Buffer Distance – This is for setting where to start the first cell and end the last cell.  

Spacing – There are several options available to set the spacing between the cells, they are: 

1. Increment – This is a set value between cells. 
2. Even – Evenly spaces the cells at a specified spacing, the buffer distances are ignored. 
3. Max Spacing – The location of the beginning and ending cell are determined, then a 

sufficient number of cells are placed in between, so that the distance between them is no more 
than the specified Max Spacing. 

4. Once – Only one set or cell is placed. The ending buffer distance is ghosted. 
5. Each Vertex – The origin of the cell is placed at each vertex of the selected element. The 

Begin and End and buffer distances are ghosted. 
6. End Points – The origin of the cell is placed at each end point of the selected element. The 

Begin and End and buffer distances are ghosted. 

Angle – If set to Absolute the angle is based on 0 degrees as horizontal. If set to Relative the cell 
is placed relative to the element selected. 

Justification - The justification can be based on the center cell (only option if only one row is 
placed), the upstream or downstream cell.  Only those toggled on in the Feature Group are 
available for setting Justification. 

Note This tool is not available in MicroStation Civil Extensions and FDOT has not completed 
their internal equivalent Draw Cell application.  You will need to deactivate MicroStation 
Civil Extensions and load Bentley Civil from the Applications pull down menu. 
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REVIEW D&C SIGNALS ITEM 
Before placing the Signals items it is important to understand how they are set up. The ddb file 
that FDOT delivers will have cells assigned to the Signal items to assist in the production of plan 
elements. These items may also have scales and rotations that need to be addressed when placing 
them. Knowing how the item is set up prior to placing it will alleviate having to experiment, delete 
and redraw. One advantage to using D&C Manager to draw the mast arms and other Signal 
elements is that the elements can be automatically quantified. The figure below shows the Mast 
Arm item in D&C Manager. 

 
 

 

Selecting and then right-clicking on an item 
opens a menu that allows the user to review how 
an item will work when placed with D&C 
Manager. 

The next figure shows a Mast Arm item in the 
review dialog. The top portion of the Review 
Dialog shows information about the selected item 
such as pay item number and Cell Name. The 
bottom portion describes what actions will be 
taken when the user double-clicks on this item in 
D&C Manager. In the Design field notice the 
string of commands that takes place when this 
item is selected for placement. One of the 
important items the user needs to be aware of is 
when this item is placed it requires 2 points to set 
the rotation and the active scale is set to 1. 
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Lab Exercise: Placing Signal Poles using D&C Manager 
In this exercise the user will place a Mast Arm Signal Pole at a specified station and offset. 

LOAD DDB AND SELECT MAST ARM ITEM 
1. Continuing in Dsgnsg01.dgn attach the following reference files: 

• Dsgnrd01.dgn from the roadway folder. 

• Algnrd01.dgn from the roadway folder, attach the BL 50 model. 

• Dsgnsp01.dgn from the signing folder. 

 
2. Zoom to near station 620+00. This is near the end of the project. 
3. Turn off the Pavement Marking text levels to clean up the area around the intersection. 
4. Open D&C Manager, if closed. 
5. From D&C Manager click File > Open and navigate to the project symb folder. 
6. Select 50735535201.ddb. This is the project ddb file copied from the FDOT2008 folder and 

renamed. 
7. Click OK to load the ddb file. 

START DRAW CELL BY FEATURE 
1. From the Road Tools palette click on the Draw Cell By Feature tool. 

       This opens Draw Cell by Feature. 

 
2. To set the Feature, click on the magnifying glass icon. This opens Select Design & 

Computation Payitem. Make sure the correct ddb file is loaded. 
3. Navigate to and double-click on the Signalization category. 
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4. Double-click on the category Mast Arm Assemblies > Furnish & Install > 150 w/ Signal 
Backplate > Single Arm. 

 
5. Double-click on the item 064931102 Single Arm without Luminaire (D3). 

 
6. Set the Placement to On Element. The other option is Point. 
7. Set the Angle to 270 and Relative. This is based on how the cell was created. 
8. Set the Element to Chain.  If necessary, set the GEOPAK Job to the 415 gpk file. 
9. From the drop down menu, select BLCONST. 
10. Check on Station and key in 619+35. 
11. Check on Offset and key in 51.00. 
12. Click the Draw button and move the cursor to the left side of the baseline and issue a data 

point. 
13. Right-click to Reset the command. 
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PLACING MAST ARM 
Placing the Mast Arm on the Signal Pole can be placed by using the Signal Cells web page from 
FDOT Menu or directly from the Cell Library in MicroStation. The Arm is not drawn with D&C 
Manager however the item for the Pole will tell the user which cell to use. Example, the Signal 
Pole placed in the previous exercise used the Item 064931102 Single Arm without Luminaire 
(D3), the (D3) indicates that the arm should be Mast Arm Type D3. The user can now go to the 
Signal Cell Web page and select the cell to be attached to the Pole. 

The next figure shows the Signal Cells web page loaded from FDOT Menu. Also notice the 
descriptions of the cells under the picture. For more information regarding Mast Arm types and 
Pole types refer to the Design Standards Index 17743. 

 

 

Lab Exercise: Place Arm on Pole 
PLACE ARM FROM SIGNAL CELLS WEB PAGE 

In this exercise the user will place the Mast Arm Type D3 on the pole placed in the previous 
exercise. 

1. Continuing in the Dsgnsg01.dgn file, zoom in near the Signal Pole just placed. 
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2. From FDOT Menu, select Traffic Plans > Signals > Signal Poles/MastArms Webpage. 
This opens the Signal Cells web page. 

 
3. Scroll down and select the Cell Mast Arm Type D3. This will make the active cell 

MastArmD3 in MicroStation. 
4. In MicroStation, select the Place Active Cell tool. This is just to verify the settings. 

 
5. Set the Active Angle to 270. This should be set as we just used the Draw Cell by Feature 

tool and set the Angle there. 
6. Set the Scale to 1 for both the X and Y. 
7. Snap to the middle of the face plate of the Signal Pole. See cross hairs in figure below. 

 
8. Issue a data point to place the cell. 
9. Right-click to Cancel the command. 
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PLACE SIGNAL HEAD 
Much like the Mast Arm, the Signal Head can be placed using Signal Cell web page or the 
MicroStation Cell Library. Another option the user has is D&C Manager. The advantage to 
using D&C Manager is the ability to quantify the items automatically. Depending on the version 
of the ddb file you are using it may be necessary to edit the item for the signal head in the ddb to 
place the correct cell at the correct scale. 

The figure below shows the Signal head item in D&C Manager. The user needs to modify the 
Cell Name from Sig3_1 to SignlHd. The Set Scale option also needs to be changed to Use Active 
Scale. Finally at the bottom of the dialog in the Key in Commands section the user needs to edit 
the Cell name again and remove the AS=1 key in. Once these changes are made and saved to the 
ddb, the user can place this item and later quantify them. Notice in the Design field the value 
Active Angle PT2 this tells the user that the cell rotation will be set by picking 2 points in the 
design file. 
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Lab Exercise: Place Signal Head 
In this exercise the user will place a Signal Head on the Mast Arm using D&C Manager. 

PLACE SIGNAL HEAD 5 SECTION 1 WAY 
1. Continuing in Dsgnsg01.dgn, zoom out so the entire intersection is in the view.  
2. Open D&C Manager if it is closed. 
3. In D&C Manager, navigate to Signalization > Traffic Signals > Furnish & Install. 
4. Double-click on item 0650 51511 Traffic Signal, 5 Section Cluster – 1 way, Standard. 
5. Set the rotation angle of the cell by picking 2 points in the design file, use the nearest snap 

and snap to the Mast Arm. 
6. Position the cell so that it is centered on the opposing turn lane and against the mast arm. 

Using AccuDraw will make this process easier. 
7. Issue a data point to place the cell. 
8. Right-click to Cancel the command. 
9. Zoom in on the Signal Head and move the head so it is touching the Mast Arm. 
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PLACE SIGNAL HEAD 3 SECTION 1 WAY 
1. In D&C Manager, navigate to Signalization > Traffic Signals > Furnish & Install. 
2. Double-click on item 0650 51311 Traffic Signal, 3 Section – 1 way, Standard. 
3. Set the rotation angle of the cell by picking 2 points in the design file. 
4. Position the cell so that it is centered on the opposing through lanes and against the mast arm. 

Use the 6” White lane line as a reference. 

 
5. Issue a data point to place the cell. 
6. Right-click to Cancel the command. 
7. Zoom in on the Signal Head and move the head so it is touching the Mast Arm. 
8. Turn off Place Influence in D&C Manager. 

PLACE SIGNAL ARROW AND NUMBER 
In this part of the exercise the user will complete the Signal Head by adding a arrow pointing 
towards the lane the signal is servicing and also place a signal number. The next figure shows the 
finished product. 

 
1. From FDOT Menu, select Traffic Plans > Signals > Set Signals level Filter. 
2. In MicroStation, set the active level to SignalHead. 
3. Using the MicroStation Place Line tool, draw a line 12’ long from the Signal Head toward 

the middle of the intersection. Use AccuDraw to expedite this process. Next, the user will 
place the arrow head. 

 
4. From FDOT Menu, select Traffic Plans > Signals > Signal Heads. This opens the Signal 

Heads toolbox. 
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5. From the Signal Heads toolbox, select the Signal Head Arrow cell. 

 
6. In MicroStation, select Place Active Cell and set the Active Angle to 0. 

 
7. Set the X and Y Scale to 50.0. 
8. Snap to the end point of the line drawn at the Signal Head. 
9. Issue a data point to place the Arrow Head. 

 
10. Right-click to Cancel the command. 
11. Using Power Selector, select the line and arrow head. 
12. Copy the line and arrow head from this Signal Head to the second Signal Head. 
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PLACE SIGNAL NUMBER 
1. From the Signal Heads toolbox, select the Signal Head No. Plan view cell. 

 
2. In MicroStation, select Place Active Cell and set the Active Angle to 0. 

 
3. Set the X and Y Scale to 50.0. 
4. Position the cursor in front of the arrow head on the first Signal Head and issue a data point. 
5. Using the MicroStation Fill In Single Enter_Data Field, click inside the Signal Head 

Number box. 
6. Type in the number 5. 
7. Data point in the view to accept this value. 
8. Right-click to Cancel the command. 
9. Copy the Signal Head Number to the other Signal Head and edit the number to be 2. 
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LOOP ASSEMBLIES 
The loops, like the signal heads, can be placed with MicroStation tools, FDOT Menu or D&C 
Manager. The advantage to using D&C Manager is the ability to tag the item with intelligence 
and automate quantities. The Figure below shows the Loop Assembly for a Type F loop. Review 
the Key in Commands before placing the Loop to understand what actions are taken during 
placement, for example this item requires a 2 point rotation to align the loop with the lane it is 
being placed in.  

 

Lab Exercise: Place Loop Assemblies 
In this exercise the user will continue working in the same intersection and place the Loop 
Detectors, using D&C Manager, that correspond to the Signal Heads placed in the previous 
exercise. Refer to Design Standard index 17781 for additional design criteria for Loop 
Assemblies. The figure below shows the Loop placed 2’ behind the stop bar centered in the turn 
lane. 
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PLACE LOOP TYPE F 
1. Continuing in Dsgnsg01.dgn zoom in near station 621+00. 
2. Activate AccuDraw if it is turned off. 
3. Open D&C Manager and navigate to Signalization > Loop Assemblies > Furnish & 

install. 

 
4. Double-click on item 0660 2106 Loop Assembly (Type F) (20’). This will prompt the user to 

set the active rotation angle using 2 points. 
5. For point 1 snap to the end point of the 6” white lane line nearest the stop bar and issue a data 

point. 
6. For point 2 snap to the same 6” white lane line up station and issue a data point. After this 

point is selected the Loop cell will be attached to the cursor. 

 
Note If the wrong rotation was picked, right click to cancel the command then go back to D&C 

Manager and double-click on the item again to restart the command. 

7. Snap to the 6” White Lane line at the stop bar. 
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8. Push the letter O on the keyboard. This sets the AccuDraw Origin at the end of the line. Next 
the user will establish the center of the lane. 

9. Move the cursor down towards the center of the turn lane and push the Enter key. This locks 
the axis of AccuDraw. 

10. Type in the number 6. This is half of a 12’ lane. 
11. Push the letter O on the keyboard. This sets the AccuDraw Origin in the center of the turn 

lane. 

 
12. Move the cursor to the right and type in the number 2. This moves the Loop exactly 2’ from 

the stop bar. 

 
13. Issue a data point to place the Loop. 
14. Right click to Cancel the command. 
15. In D&C Manager turn off Place Influence. 
16. Using the MicroStation Fill In Single Enter_Data Field click inside the Loop. 
17. Type in the number 5. 
18. Issue a data point in the view to accept the value. 
19. Right click to Cancel the command. 
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PLACE LOOP TYPE A 
In this part of the exercise the user will use the same process as in the last exercise to place the 
Type A loop. The figure below shows the finished product. 

 
1. Continuing in Dsgnsg01.dgn activate AccuDraw if it is turned off. 
2. In D&C Manager double-click on item 0660 2101 Loop Assembly (Type A). This will 

prompt the user to set the active rotation angle using 2 points. 
3. For point 1 snap to the end point of the 6” white lane line nearest the stop bar and issue a data 

point. 
4. For point 2 snap to the same 6” white lane line up station and issue a data point. After this 

point is selected the Loop cell will be attached to the cursor 
5. Snap to the 6” White Lane line at the stop bar. 
6. Push the letter O on the keyboard. This sets the AccuDraw Origin at the end of the line. Next 

the user will establish the center of the lane. 
7. Move the cursor up towards the center of the through lane and push the Enter key. This locks 

the axis of AccuDraw. 
8. Type in the number 6. This is half of a 12’ lane. 
9. Push the letter O on the keyboard. This sets the AccuDraw Origin in the center of the 

through lane. 
10. Move the cursor to the right and type in the number 2. This moves the Loop exactly 2’ from 

the stop bar. 
11. Issue a data point to place the Loop. 
12. Right click to Cancel the command. 
13. In D&C Manager turn off Place Influence. 
14. Using the MicroStation Fill In Single Enter_Data Field click inside the Loop. 
15. Type in the number 2. 
16. Issue a data point in the view to accept the value. 
17. Right click to Cancel the command. 
18. Copy this Loop using AccuDraw up 12’ to the next through lane. The figure below shows the 

three Loops placed in the design file. 
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PULL BOXES 
The Pull Box item in D&C Manager works much like the Loop Assemblies in that the user is 
required to define 2 points to set the rotation angle. As with any item being placed with D&C 
Manager it is good practice to review the item to better understand how the item is placed. If the 
user places the Pull Boxes using the Signals Tool Box, those Pull Boxes will need to be Set using 
D&C Manager in order to automate quantities. 

 

Lab Exercise: Place Pull Box 
In this exercise the user will use D&C Manager in conjunction with Draw Cell by Feature tool 

to place several pull boxes around the intersection. By using D&C Manager, the user will be able 
to generate automated quantities. The figure below shows the Pull Boxes drawn in Plan view. 
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PLACE PULL BOX 
1. Continuing in dsgnsg01.dgn, zoom in near the North West quadrant of the intersection. This 

is above where the Loops were just drawn. 
2. Open D&C Manager if it is closed. Make sure the correct ddb file is loaded. 
3. From the Road tools palette open the Draw Cell by Feature tool. 
4. To set the Feature click on the magnifying glass icon. This opens Select Design & 

Computation Payitem. Make sure the correct ddb file is loaded. 
5. Navigate to Signalization > Pull and Junction Boxes. 
6. Double-click on Item 0635 1 11 Pull box (Furnish & Install). This loads the item into the 

Draw Cell by Feature tool. 
7. In Draw Cell by Feature click the drop down menu and 

select the item 0635 1 11 Pull box (Furnish & Install). 
8. Set the Placement to By Point. 
9. Click the Draw button. The Pull Box cell will be attached 

to the cursor. 
10. Place the Pull Box behind the curb & gutter line in front 

of the sidewalk line. 

 
11. Place a second Pull Box to the right of the first Pull Box. 

 
12. Using the same process as above, place the 4 remaining Pull Boxes as shown in the figure 

below. 

Note Set the Angle to 40.0 in the Draw Cell by Feature tool before drawing the remaining pull 
boxes. 
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Lab Exercise: Place Controller Assembly 
In this exercise the user will use the Signals toolbox or the signals Web Page in conjunction with 
D&C Manager to place a Base Mounted Controller. The figure below shows the general location 
of the Controller. 
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PLACE CONTROLLER ASSEMBLY 
1. Continuing in Dsgnsg01.dgn, zoom to the opposite side of the intersection of the Mast Arm 

placed earlier or the South East quadrant. 
2. Open D&C Manager if it is closed; make sure the correct ddb file is loaded. 
3. In D&C Manager, navigate to Signalization > Controllers and Cabinets > Actuated Solid 

State > Furnish & Install. 
4. Select item 0670 5110 Actuated Solid State (NEMA). 

5. Activate the Design mode  if it closed.  
6. Check on Place Influence. This sets the MicroStation symbology plus it will place the 

GEOPAK attributes on the Controller cell. 
7. From FDOT Menu, open the Signal Controllers toolbox. 

 
8. From the Signal Controllers toolbox, select the Proposed Base Mounted Controller. This 

is the first tool on the palette. 

 
9. Place the Controller behind the back of sidewalk. 
10. Right-click to Cancel the command, 
11. Turn off Place Influence. 
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Lab Exercise: Draw Loop Lead In wire 
In this exercise the user will draw the Loop Lead-In wire from the end of the Loop Detectors to 
the Pull Box. The lead-In is paid for under the Loop Detector so the user will draw this line using 
the MicroStation Place Line command, no D&C item is used. The figure below shows the Loop 
Lead-In drawn from Loop Detectors to the Pull Box. 

 
DRAW LOOP LEAD-IN 

1. Zoom in near the Loop Detectors placed earlier. 
2. Set the Signals Level Filter.  

 
3. In MicroStation, set the Level to LoopLI.  
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4. From the MicroStation Main Classic tool palette, select Construct Line at Active Angle. 

 
5. Set the Method to From Point. 
6. Set the Active Angle to 145.0. 
7. Check on the Length and enter 3.0. 

 
8. Snap to the end of the Loop Detector near the Stop Bar as seen in the next figure. 

 
9. Issue a data point to accept the location. 
10. Move the cursor towards the Stop Bar and issue a second Data Point. The next figure shows 

the Lead-In connected to the Loop Detector. 

 
11. Repeat this process on the remaining two Loop Detectors. 

Next, the user will draw the Loop Lead-In that connects the Loop Detectors to the Pull Box. 
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12. Using the Place Line command, draw a line from Loop L-5 parallel to the Stop Bar to a point 
past the last Loop L-2, then into the first Pull Box as shown in the next figure. 

 
The location of the Pull Boxes will be dependent on each individual project. The placement of 
Loops, types of Loops used and Loop Lead-In wire placement may vary from district to district, 
consult with the district traffic engineers regarding these issues. 
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DESIGN SETTINGS 
The custom line styles used to draw the Conduit lines can be adjusted so that the line style 
displays graphically pleasing. At times it may be necessary to adjust the line style scale to get the 
symbols built into the line style to display properly. 

To adjust the line style scale in D&C Manager the user would go to Settings > Design this opens 
the Design Settings dialog. 

 
In the center of the Design Settings dialog is the item for Custom Line Style Creation. This 
setting controls how a line style is displayed when drawn with D&C Manager. The user should 
check on the Scale Factor and set the scale. In most cases the Plot Scale will work but in some it 
may be necessary to adjust this value as with the Conduit on a 50 scale plan sheet, a scale of 20.0 
gives a better representation of the Conduit line style. Changing this value will not affect the 
quantities; however, it is very important that the user communicate any changes to all design 
squad members for consistency. 

The Figure below shows the same conduit line drawn using two different Scale Factors. 
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Lab Exercise: Place Conduit 
In this exercise the user will draw conduit from Pull Box to Pull Box and then to the Controller 
Cabinet. This exercise will use two different types of Conduit, Underground and Under Pavement. 
The next figure shows the two types of conduit drawn in Plan view. 

 
PLACE CONDUIT UNDERGROUND 

1. Continuing in Dsgnsg01.dgn, zoom in near the Pull Boxes placed next to the Loops in the 
North West quadrant. 

2. Open D&C Manager, if closed. Make sure the correct ddb file is loaded. 
3. From D&C Manager, select Settings > Design. This opens Design Settings. 
4. Check on Scale Factor. 
5. Enter the value 20.0. 
6. Close the Design Settings dialog. 
7. In D&C Manager, navigate to Signalization > Conduit > Furnish & Install. 
8. Select item 0630 1 12 Conduit (Underground). 
9. In D&C Manager, start the Design mode. 
10. Check on Place Influence. This will set the MicroStation level symbology. 
11. Using the MicroStation Place Line tool, draw a line from one Pull Box to the next Pull Box. 

See figure below. 
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PLACE CONDUIT UNDER PAVEMENT 
1. In D&C Manager, select item 0630 1 13 Conduit (Under Pavement). 
2. Using the MicroStation Place Line tool, draw a line from one Pull Box to the next Pull Box 

under the road; see the next figure. 

 
3. Complete the conduit from the Pull Box to the Controller Cabinet across the road. This is also 

an Under Pavement conduit. 
4. Zoom to the area near the Signal Pole. 
5. Switch the D&C Manager item back to 0630 1 12 Conduit (Underground). 
6. Draw a line from the Signal Pole to the Pull Box. 

 
7. Turn off Place Influence. 
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PLACING TEXT LABELS 
There are several different types of notes and labels that are placed on Signal Plans that are not 
used in other components. For example the Pole location label and the Pay Item number box. 
These labels are part of FDOT Menu and can be placed from the Cell Web Pages or the Signals 
toolboxes. The user should use which ever method they are most comfortable with. 

To place the Pole Location label from the Cell Webpage go to FDOT Menu and select Traffic 
Plans > Signals > Signal Cells Webpage. 

 
Once the Webpage is loaded, scroll down and find the correct cell and click on the picture. This 
makes that cell the active cell in MicroStation which can now be placed in the general location of 
the Signal Pole.  

The Pole Location cell has data fields built into it. It is not necessary to drop the cell to edit the 
label, use the Fill in Single Enter_Data Field tool. 

 
To place the Pole Location label from the Signals toolboxes, from FDOT Menu, select Traffic 
Plans > Signals > Signal Text. 
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Just like from the Cell Webpage, this tool makes the selected cell the active cell in MicroStation 
and is ready for user input for placement. 

Similar to the Pole Location label is the Pay Item Number box, this cell can be placed from either 
of the tools previously mentioned. This cell also contains data fields for easy editing. 

 
This cell is placed in the general location of the item it is refereeing to and a leader line is draw 
from the Pay Item box to the item. Next to the pay Item Number box the user will add a piece of 
text with the quantity and unit as shown below.  

 
The quantity, if it is a linear element, can be calculated and placed with GEOPAK Plan Labeler. 
This will be covered later in this chapter. 
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Lab Exercise: Place Pay Item Number Box 
In this exercise the user will place the Pay Item Number Box then add a leader line and arrow 
head. 

PLACE PAY ITEM NUMBER BOX 
1. Open Dsgnsg01.dgn in the Signals folder. 
2. Open Project Manager. 
3. Zoom to the North West quadrant of the intersection near the first two pull boxes placed 

earlier. 
4. Open the Signal Text toolbox from FDOT Menu.  
5. From the Signal Text toolbox select the Pay Item Box cell. 

 
6. Place the cell near the Underground conduit line. 
7. Right-click to cancel the place cell command. 
8. Using the Fill in Single Enter_Data Field tool add the text 630-1-12. 

 
DRAW LEADER LINE AND PLACE ARROW HEAD 

        The next figure shows the completed exercise. 

 
 

1. In MicroStation set the active level to Leaderline_dp. 

 
2. Use the MicroStation Place Line to draw the leader line from the bottom left corner of the 

Pay Item Number Box to the Underground conduit line. Use the Nearest snap. 
3. Right-click to cancel the Place Line command. 
4. From FDOT Menu, select Traffic Plans > Arrows and Barscales. 
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5. Select the Place Terminator Arrows icon at the far right of the dialog box that appears. (Last 
icon.) 

 
6. From the Terminator dialog select ArrTermPnt. 

 
7. Click Place terminator. 
8. Pick the leader line drawn earlier, pick close to the end nearest the conduit line. 
9. Close the Terminator dialog box. 
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PLAN LABELING 
GEOPAK delivers a tool, Plan View Labeler, to aid in the placement of plan labels. These labels 
can be simple callouts or complex blocks of text with stations and offsets built into them. It is 
possible to create custom labels for those pieces of text that are placed repeatedly into a style file 
similar to a library. FDOT delivers style files with custom labels already created.  

Labels created with labeler can be synced with D&C Manager for level symbology. This resolves 
issues with inconsistency between users. Labels can also be created at a scale of 1 to 1 so that they 
will work on any scale sheet.  

Labels can be created with leader lines and arrow heads as part of the custom label. The arrow 
heads can be terminators delivered by FDOT or the standard arrows built into the labeler. Again 
this makes for very consistent plan labeling if all users use the same labels. 

Plan View Labeler can be launched from the Road Tools palette.  

 
<Or>  Select from the MicroStation drop down menu Applications > GEOPAK ROAD >  Plans 
Preparation >  Plan View Labeling. 

The general work flow of the Labeler is:  

• Open Labeler. 

• Open a Style File or .lsf. 

• Select a custom label. 

• Create a custom label. 
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 The Label Feature buttons on the Text tab are discussed below. 

 

  Select GEOPAK or MS Element – Prompts the user to select the GEOPAK or 
MicroStation element. From this selection the user can retrieve the geometry and place that 
information in MicroStation. 

 Data Point Location – Prompts the user to snap to or issue a data point in the design file. 
Usually used when placing station and offsets. 

 2 GPK Point Line - Works with visualized points from COGO. When the points are 
selected, a display line is drawn between the points and a circle is placed at the midpoint. The 
bearing of that line is displayed and can be placed in MicroStation.  

 3 GPK Point Arc - Works with visualized points from COGO representing the P.C. and 
P.T. of the curve. When the points are selected, a display curve is drawn and the user is prompted 
to enter the chord direction point, which is identified dynamically. Now any element of the curve’s 
geometry can be displayed or placed in MicroStation.  
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Lab Exercise: Create a Custom Text Label 
In this exercise the user will create a custom label for the Conduit length that is placed next to the 
Pay Item Number box as shown in the figure below. 

 
OPEN PROJECT LSF FILE 

1. Open Dsgnsg01.dgn in the Signals folder. 
2. Zoom to station 621+00. Near the underground conduit line drawn earlier. 
3. Rotate the view by 2 point; use the station tick marks 620+00 and 621+00 as the 2 points. 
4. Open Plan View Labeler. Either from the Road Tools palette or from the Applications menu. 

 
5. Open the Styles tab. Next the user will open the lsf file located in the project symb folder. 
6. From Plan View Labeler select Style Files > Open. 
7. Navigate to the project symb folder and select fdotlabels.lsf. 

 
8. Select the fdotlabels.lsf file and click Open. This loads the lsf file in the project folder. 
9. In the Styles tab double-click on the Traffic Plans category. This expands the category and 

shows the standard labels delivered by FDOT. 
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SET THE PARAMETERS 
1. Continuing in Plan View Labeler, select the Scale pull down menu; then, select Change 

Scale. This opens Scale Style. 

 
2. Set the New Scale to 1.00. This allows the user to create a custom label that can be used at 

any scale. 
3. Click OK. 
4. Open the Params tab. This is where the user will set the text size and symbology. 
5. Click on the Paddle Lock icon to lock it. 
6. Set the text Height to 0.07. The Width automatically matches the height. 
7. Set the Justification to Left Center. Click on the nodes to adjust this. 
8. Set the Font to 48. 
9. Set the Level to TextLabel. 
10. Set the Color and Weight to ByLevel. 

 
11. Open the Shape tab. 

12. Select the first option which is No Shape . 
13. Open the Leader tab. 

14. Set the Leader Type to NO leader . 

 

ROTATE TAB 
1. Open the Rotate tab. 
2. Set the Current Angle to 0.00. This is not critical at this point as the user can change this as 

the labels are being placed. Setting this now will make the preview look better. 
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TEXT TAB 
1. Open the Text tab. 
2. Make sure the Job No. is set to 415. Using Project Manager will ensure this. 
3. Set the Chain to BLCONST. Use the drop down menu. 
4. At the bottom of the dialog under Label Feature, select the first icon, Select GEOPAK or 

MS Element . 
5. Pick the Underground conduit line. 
6. Set the Computed text option to Length. 
7. Set the number of decimal places to 0. 
8. Double-click on the word Length. This pushes the length over to the text field. 

 
9. Click the Space button. This is located under the Key In field. 
10. Type in LF. 
11. In Plan View Labeler, select the Scale pull down menu; then, select Change Scale. 

 
12. Set the Scale to 50.0. 
13. Click OK. 
14. In Plan View Labeler, click Place Label. 
15. Place the label next to the Pay Item Number Box. 
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SAVE LABEL 
1. Continuing in Plan View Labeler open the Styles tab. 

 
2. Make sure the Traffic Plans category is selected. 
3. Click New Style. 
4. Enter the new Style Name Line Length 

 
5. Set the Style Scale to 1.0. 
6. Click OK. 
7. Click the Styles Files pull down menu and select Save. 
8. Close Plan View Labeler. 

        The Length in this style will dynamically change as different lines are selected. 

Note This tool is available in MicroStation Civil Extensions  
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5 QUANTITIES AND REPORTS 
CHAPTER OBJECTIVES 

In this chapter the following topics will be covered: 

• Import Project Properties from Trns*port 

• Generate quantities and export to Quantity Manager 

• Generate CSV file in Quantity Manager 

• Export Quantities for Trns*port 

• Place quantities on Tabulation of Quantities Sheet 

INTRODUCTION 
This section covers applications used to produce quantities and then place the quantities on a plan 
sheet or computation book. Being able to produce quantities based on your design elements should 
be your ultimate goal.  Team work is crucial to achieving this goal, if everyone in the design squad 
is not following the same procedures as it applies to CADD standards, producing automated 
quantities will be much more difficult. 

GENERATE QUANTITIES 
Quantities are generated from the elements designed and drawn in MicroStation using Design 
and Computation (D&C) Manager. All of the elements drawn in the previous exercises are now 
able to be automatically quantified because D&C Manager was used to draw the elements. 

D&C Manager has the ability to generate individual sheet quantities or the entire projects 
quantities at one time. D&C Manager can export to a CSV file that can be imported into the 
Tabulation of Quantities file or it can export to a data base that can then be opened with Quantity 
Manager.  

Quantity Manager is a standalone program that can organize and manipulate the data created by 
D&C Manager and quantities generated manually then create reports which can be used to 
produce an electronic comp book. Quantity Manager can also export the quantities to Trns*Port, 
which takes away the need to have a user to manually enter all of the project pay items. This task 
alone can save hours over the lifespan of a project, not to mention removing the possibility of 
human error. Also, Quantity Manager can export to a CSV file which can then be used to create 
the Tabulation of Quantities sheet. 

Signal Plans quantities are considered sheet quantities, which means there is a Tabulation of 
Quantities sheet in the plan set that breaks down the quantities per sheet. 

Note When calculating quantities with D&C Manager, Locate must be OFF in all attached 
Reference files.  Otherwise, GEOPAK will crash. 
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QUANTITIES TO TRNS*PORT WORKFLOW 
1. Generate quantities using D&C Manager then export to a database file. 
2. Export the project properties xml file from Trns*Port. This can be done any time after the 

notice to proceed has been executed. 
3. Open the project in Quantity Manager, this is the database file, usually in Access database 

format (mdb). 
4. Import the project properties into Quantity Manager; this is the xml file from Trns*Port. 
5. Create a funding rule in Quantity Manager, this is really the item category. Example 0500 is 

the category for Signal plans. This funding rule associates the items in Quantity Manager to 
a category in Trns*Port. 

6. Apply the funding rule to the appropriate items. 
7. Export the Quantities from Quantity Manager to a format Trns*Port can read. This is an 

xml file also. Name it using the 11 digit FIN number .xml. 
8. Upload the quantities to Trns*Port. This alleviates the need for a user to manually enter pay 

items and quantities. 
9. Export the quantities from Quantity Manager into a .csv file to be used on the Tabulation of 

Quantities Sheet. 

D&C MANAGER QUANTITIES 

  
D&C Manager expands to add a list box at the bottom of the dialog, when the Compute option is 
selected. This is the collection bin, where the user adds the items from D&C Manager to be 
quantified. To load the items into the collection bin you double click on the item. To clear the 
collection bin, right click in the collection bin area and select clear collection. Once all of the 
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items are added to the collection bin they can be saved for future use. To save a collection, right 
click in the collection bin area and select Save Collection. Save the file to the project.  

The following figure shows the collection bin populated with items ready for quantity calculation. 
The items will not be in numerical order when loaded into the collection bin; they are displayed in 
the order that they are added.  

 
To open and organize the collection:  

1. In D&C Manager, go to Favorites > Organize Favorites. This opens My Favorites. 

 
2. In My Favorites, click Open. 
3. Browse to the folder where you saved the collection and select the file. The collection file will 

have a .col extension. 
4. Use the Up and Down buttons to organize the items. 
5. Click Save As to save the changes. 

Note The items can also be organized in the output from D&C Manager or in Quantity 
Manager prior to going onto sheets. 
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REVIEW ITEMS PRIOR TO COMPUTING QUANTITIES 
Prior to computing any quantities it is important to review the items that are about to be computed. 

D&C Manager Display tool will aid in this task. To activate the Display tool, click on the  
icon. 

 

 Normal Display – the items of interest change back to their original element symbology. 

 Highlight Selection – the desired elements are displayed in the current MicroStation 
highlight color, while any other elements remain unchanged. 

 Hide Selection – the desired items are not displayed in the view, however all other elements 
are displayed. This is the reverse of the Display Only Selection tool. 

 Display Only Selection – only the items in the collection box appear, while the rest are not 
displayed in the view. 

Using the Highlight Selection the user would zoom in close to the project elements and make sure 
that whatever is placed in the collection bin for computing quantities highlights. 

Note Always set the option back to Normal Display before closing the tool. 

COMPUTING QUANTITIES 
Plan Quantity Computation opens when the Compute is selected.  

 
The Job is the GEOPAK gpk file, if the user is using Project Manager than this will be set. 

Extents field a list of options for limiting the area and elements included in the quantity 
calculations. The following figure shows the options available.  
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• Active Design File – All elements in the Active Design File are candidates for computation. 
• View – Only the selected items that are displayed in MicroStation view one are computed.  If 

the view includes area outside of the Range, the Range will override. 
• Fence – A MicroStation fence must be placed, and all specified graphical features which 

satisfy both the fence and the Range will be tabulated. The Fence mode is sensitive to the 
MicroStation Inside, Overlap and Clip modes.  

• Boundary Element – A previously drawn closed shape is used to determine quantities. 
 When selected, the user is prompted to select the closed shape.   This mode is sensitive to the 
MicroStation Inside, Overlap and Clip modes. 

• Station Range – A Baseline Reference (chain or dgn) must be defined for this option.  The 
range fields default to the extent of the chain.  The user can key in a station or by clicking 
Begin or End Station icons graphically define the station range.  Perpendicular projections to 
the station(s) define the extent of the computations. This option is not ideal for sheet 
quantities. 

• Sheet Range – Sheets placed with the Plan Profile Sheet Composition tool can be utilized. 
Select the option which displays the sheet range. This option will work in our scenario. 

• Selection Set – A MicroStation selection set of the candidate compute elements must be 
created prior to computing. 

• Boundary Selection Set – A MicroStation selection set of the Boundary (not the actual 
candidate compute elements) must be created prior to computing. This option will work in our 
scenario. When this option is used it uses the element ID number in Quantity Manager to 
organize the data for each individual sheet. 

Baseline Reference allows the user to define a Chain or DGN element for offsets and station 
values for reports. In addition the Range, if set, is measured from the selected Chain or DGN 
element to search for candidate items. Setting the Baseline Reference to None limits the type of 
output that can be generated as no station / offset values can be computed. 

When using Sheet Range or Boundary Elements it is not necessary to toggle on Begin and End 
Station limits. 

Highlight During Computation toggle, when checked, highlights all MicroStation elements 
selected for computation in the selected color. 

Compute Quantities starts the computation process and when completed opens the Computation 
Results dialog box. 



Chapter 5 Quantities and Reports- Generate Quantities 

5-6 ©2009 FDOT FDOT Traffic Plans Course - Signalization 

 
It is imperative to fix any errors or omissions in the results before going any further.  

Export Format sets the type of output the user wants to generate from the reported quantities. 
There are several formats to choose from. 

• Comp Book – A more detailed ASCII report that lists not only quantity summaries, but also 
geometric properties such as plan view coordinates and station/offsets for located elements. 

• Item report – Quantities Summary listing pay items, descriptions, units and total quantities 
for located elements. File is in ASCII format. 

• Item Table – Contains the same information as the Item Report, but formatted in tabular 
form. 

• DBMS – Very detailed information including calculated and rounded quantities, geometric 
properties, pay item numbers, descriptions, station / offset values, etc. The format is the 
selected database (i.e., Microsoft Access, Oracle, SQL Server, and dbase is set in the 
Compute Settings tool). This option is required when taking the quantities into Quantity 
Manager.  

• CSV By Item –Summary listing pay items, descriptions, units and total quantities for located 
elements. Format is CSV (coma separated values). 

• CSV By Element – A more detailed report that lists not only quantity summaries, but also 
geometric properties such as plan view coordinates and station/offsets for located elements. 
Format is CSV (coma separated values). 

• Table – User defined table column properties.  A column for designating the appropriate 
symbol is also included, as well as AdHoc attribute data. This option is used to generate 
legends such as for landscape plans.  

Next to the Export Format is a field for entering the file name of the output file, using the 
magnifying glass allows you to browse to a specific folder. 

When exporting the quantities there are two options to choose from, Create or Append. This will 
place the quantities into a new file or append them to a previously created file. 

Run and Groupings are only used for the DBMS export format to Quantity Manager. The Run 
is a user key in and any logical description, like Signal Plans or Preliminary, can be used. This 
description will be passed to Quantity Manager.  There is a list of several default Groupings 
included in the drop down menu, however, you are only concerned with typing in 0500 for 
Signalization. This is the recommended Grouping when exporting to Quantity Manager, as this 
is the only grouping that can be passed to Trns*Port. 

Export commences the output file process and creates the quantity file. In this training you will be 
exporting to DBMS which will create an MDB file that can then be opened with Quantity 
Manager. 
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Lab Exercise: Create and Save a Collection of Favorites 
CREATE COLLECTION OF ITEMS 

In this part of the exercise you will create a collection of items used to generate quantities and save 
the collection as a favorite to be used with future processes. 

1. If closed, open Dsgnsg01.dgn in the signals folder. 
2. Open D&C Manager. 
3. Zoom in near Sta 620+00. 
4. Click on the Compute icon in D&C Manager. This is the calculator icon. 
5. If there are items in the collection bin of D&C Manager, right-click in the collection area and 

select Clear Collection. 

Next, you will use the ID tool in D&C Manager to identify and add pavement marking items 
to the collection. Once all of the items are identified you will save the collection. 

6. Click the ID icon in D&C Manager. 
7. Pick one of the Mast Arm Pole and accept it. This will take you to the item 064931102 

Single Arm without Luminaire (D3). 

 
8. Right-click on the item and select Add to Collection. This will place the item in the 

collection bin. 
9. Click the ID icon and pick the Conduit lines and accept it. Make sure to get both 

Underground and under Pavement lines. 
10. Right-click on the item and select Add to Collection. 
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11. Repeat this process to add the Pull Boxes, Loop Detectors and Controller Cabinet. Make 
sure to get the two types of Loop Detectors, A and F. 

 
12. Right-click in the collection bin and select Save Collection As. This opens Save Collection to 

a file. The location will default to the working directory. 

 
13. Enter a file name for the collection, example: Signals or Signalization. The extension .col 

will be added automatically. 

 
14. Click OK. 



Quantities and Reports - Generate Quantities Chapter 5 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 5-9 

ORGANIZE THE COLLECTION 
Organizing the collection is only to make it easier on the designer when working with a group of 
items as they will now be in numerical order. Organizing the collection will have no impact on 
creating the Tabulation of Quantities Sheet; this is organized in Quantity Manager. 

1. In D&C Manager, select Favorites > Organize Favorites. This opens My Favorites. 

 
2. In My Favorites, click Open. 
3. Navigate to the Signals folder and select Signalization.col. This loads the D&C items into 

My Favorites. 
4. Using the Up and Down buttons, put the items in numerical order from lowest to highest. 

 
5. Click Save As. 
6. Select the Signalization file and click OK to overwrite it. 
7. Click OK on the Alert dialog warning you that the file already exists. 
8. Close My Favorites. 
9. Right-click in the collection bin and select Open a Collection. 
10. Select the Signalization collection in the Signals folder. 
11. Click OK to open the file. This will load the items in the collection in numerical order. 

Note The collection is also loaded in the Favorites pull down menu as seen in the next figure. 
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Lab Exercise: Review the Quantity Items 
USE THE DISPLAY TOOL TO REVIEW ITEMS 

1. Continuing in Dsgnsg01.dgn, click the Display tool on D&C Manager. 

 
2. On the Display tool, click the Highlight icon. This will highlight all of the items in the 

collection. 
3. Take a moment to review the design file and experiment with the other display options. 
4. Set the display option to Normal. 
5. Close the Display tool. 

Lab Exercise: Generate Quantities and Export to Quantity Manager 
COMPUTE QUANTITIES 

1. Continuing in Dsgnsg01.dgn reference in the Clipsg01.dgn file from the Signals folder. 
2. On D&C Manager, click the Compute icon. This opens Plan Quantity Computation. 
3. The Job number is 415. This will be 

set if you use Project Manager. 
4. Set the Extents to Boundary 

Element. 
5. Set to method Inside. 
6. Pick the Identify Boundary Shape 

icon   . 
7. Select the clip shape. 
8. Set the Baseline Reference to Chain. 
9. Pick the Chain BLCONST. 
10. Toggle on Range. 
11. Set the Range value to 300.00. This is how far from the chain the software will look for items 

to compute. 
12. Toggle on Highlight During Computation. 
13. Click Compute Quantities. This opens Computation Results. 
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EXPORT QUANTITIES TO DBMS FOR QUANTITY MANAGER 
1. Set the Export Format to DBMS. This is the required format for Quantity Manager. 
2. Using the Magnifying Glass icon browse to the Signals folder. 

 
3. Enter a file name, I recommend using the fin number. The MDB file extension will be added 

automatically. 
4. Click OK. 
5. Set Computation Results to Create. The options are Create or Append. 
6. For Run, enter Signal Plans. 
7. For Groupings, select type in 0500. This option must be selected. 

 
8. Click Export. This creates the MDB file. 

 
9. Close Computation Results. Next, open Windows Explorer and make sure the file was 

created. 
10. From FDOT Menu, select Standards > Explore Current Working Directory. 
11. You should see the MDB file in the Signals folder. 
12. Close Windows Explorer. 
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QUANTITY MANAGER 
As mentioned earlier in the training guide, Quantity Manager is a standalone program that 
organizes and manages the quantities generated from D&C Manager. Quantity Manager can also 
be used to enter non graphic quantities such as Mobilization. Once the information is loaded into 
Quantity Manager the user can then export the data from Quantity Manager into a spread sheet 
that can then be placed in CAD on the Tabulation of Quantities sheet. Quantity Manager also 
creates the Computation Book and can export the quantities to an xml file to be uploaded into 
Trns*Port. 

Quantity Manager can be loaded from the Road tools palette or from the MicroStation pull 
down menu option:  Applications. 

 

QUANTITY MANAGER WORKFLOW 
1. Open Quantity Manager. 
2. Open the Project created by D&C Manager. This is the MDB file created in D&C Manager. 
3. Import the Project Properties xml file. This is created in Trns*Port then exported to an xml 

file. 
4. Create Funding Rules for all of the categories in the project. 
5. Apply the funding rules to appropriate items. 
6. Export quantities to xml file to be loaded into Trns*Port. 
7. Create csv file, using delivered styles from FDOT, to be used to create Tabulation of 

Quantities sheet. 
8. If creating a Comp Book, create pdf files using delivered styles from FDOT. 

Note FDOT offers a full training course on Quantity Manager that most users have 
already attended. In this training guide the user will only use some basic functions of 
Quantity Manager. 
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Lab exercise: Import Project Properties from Trns*Port 
OPEN QUANTITY MANAGER AND IMPORT PROJECT PROPERTIES 

1. Open Dsgnsg01.dgn. Quantity Manger can be opened in any design file. 

2. From the Road tools palette, select Quantity Manager. The  icon is located under the 
Project Manager icon in the same menu as D&C Manager.  

 
3. In Quantity Manager, select Project > Open. This opens Connect to Database. 

 
4. Set the Database to MS Access 2000 from the drop down menu. 
5. For the File, click the magnifying glass icon. 

 
6. Browse to the Signals folder and select the project mdb file. In this exercise select 

50735535201.mdb. This is the file created in D&C Manager. 

Note If your discipline is part of the Roadway set of plans you will be required to make sure 
that all of your MicroStation elements are drawn with D&C Manger and check the 
quantities but not create a database. The Roadway user will typically create one project 
database of all quantities. In this example the Signal plans are stand alone. 

7. Click Open. This takes you back to Connect To Database. 
8. Click Connect. This loads the project database into Quantity Manager. 
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LOAD PROJECT PROPERTIES FROM TRNS*PORT 
1. Continuing in Quantity Manager, select Project > Properties.  

This opens Project Properties. 

 
2. In Project Properties, select Project > Import aecXML.  

 
3. Browse to the Signals folder and select 50735535201.xml. This is the file exported from 

Trns*Port. 
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4. Click Open. This loads the project properties. As seen in the following figure, notice that the 
General Information is now filled in. 

 
5. For the Location Information, pick the drop down menu and select the chain BLCONST. 

This will populate the Begin and End Station. 
6. For the Begin Mile Post, enter 0.000. 
7. For End Mile Post, enter 2.407. 
8. For Midpoint Coordinates, set Latitude to 28 28 50. Put a space between values. 
9. Set Longitude to 81 18 7. Put a space between values. 

The Midpoint Coordinates can be provided to the user by the Surveyor on the project. They 
refer to a point on the Centerline about mid way along the project. 

10. Click Import. This loads the Project Properties into Quantity Manager and marries them 
with the project database, the MDB file. 

Note Unless something in Trns*Port changes that affects the project properties you will not 
have to reload the project properties xml file for this database. 
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Lab Exercise: Create Funding Rule and Apply to items 
CREATE FUNDING RULE 

In this part of the exercise the user will create a funding rule for the Signals category, 0500. The 
funding rule in this example is not about money but rather it is used to associate pay items to a 
category. 

1. Open Quantity Manager if it is closed. 
2. In Quantity Manager, select Edit > Funding > Rule. This opens Funding Properties. 

 

3. At the bottom of the dialog click the New Funding Rule icon . This creates a new rule 
under the Funding portion of the dialog with the name New Funding Rule 1.  

4. Click on New Funding Rule 1. This populates the Name and Description fields with default 
settings, these will have to be changed. 

5. Change the Name to 0500. This is the Category number for Signal Plans. 
6. Change the Description to Signals. The Description MUST contain at a minimum one word 

that matches the description in Trns*Port. 
7. Click Update. 
8. On the Warning dialog, click Yes.  

 
 
 

This opens an Information dialog. 
 
 

9. On the Information dialog, click OK. This adds the new 
funding rule to the project. 

 
10. Close Funding Properties.  
11. Next, the user will apply the new funding rule to all items that applies to this category. 
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APPLY FUNDING RULE 
1. Continuing in Quantity Manager, in the left-hand pane select the tab Payitem Table. This 

displays all of the pay items for the project. 
2. Select the first item then using the Shift key on the keyboard select the last item in the table. 

This will display all of the items and quantities in the right hand pane. 
3. Select Edit > Select all. This selects all of the items in the database. 

Note Only do this if all of the items in the database are the same category. 
4. In the right-hand pane, right-mouse click and select Apply Funding Rule. 

 
5. In Apply Funding Rule, select the Funding Rule 0500. This is the funding rule created 

earlier. 

 
6. Click Apply. This will apply the 0500 category to all of the selected items. It may take several 

seconds to process. 
7. Take a moment to review the items by navigating the tabs in the bottom pane.  
8. In the top-right pane, select item 0635 1 11 Pull Box. 
9. Select the Funding Rules tab; notice the category number. 
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Lab Exercise: Export Quantities for Trns*Port 
EXPORT QUANTITIES FOR TRNS*PORT 

1. In Quantity Manager in the left-hand pane, select the tab Payitem Table. 
2. Select the first item then using the Shift key on the keyboard select the last item in the table. 
3. Select Project > Export > Export. This opens the Export dialog. 
4. Set the Export Style to aecXML + Funding. Use the drop down menu to select this. 
5. Toggle on Rename Trns*port Grouping As: and type in 0500. This is set to Design 

Estimate by default. 

 
 

6. For Document File Name, click the 
magnifying glass icon and browse to the 
Signals folder. 

7. Enter a new file name for the Trns*Port 
xml.   
For this example, use QMtoTrnsPort. 
This name is not important; you must 
remember it for the upload process. 
 

Note Do not overwrite the xml file that is in the Signals folder, this is the project properties xml 
file. You may need this to import into Quantity Manager if errors are found. 

8. Click Open. This loads the file name into the Export dialog. 
9. Click Export.  
10. Click OK on the Information dialog. 

 

 

 

Note If all of the information in the Project Properties is not filled in, the user will receive a 
warning stating that some information is missing. 

11. Click Cancel on the Export dialog to close it. Do not close Quantity Manager. 

This data is now ready to be imported back into Trns*Port using the Designer Interface. The 
Designer Interface can be opened from the State Specifications and Estimates Office web page. 
The link below: 
http://www2.dot.state.fl.us/specificationsestimates/Estimates/BasisofEstimates/BOEManual/BOE
Online.aspx  will take the user to this page. 

  



Quantities and Reports - Quantity Manager Chapter 5 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 5-19 

Lab Exercise: Generate CSV file in Quantity Manager 
In this exercise the user will create a csv output file from Quantity Manager. This csv file will 
then be converted to SBTBSG.xls which FDOT Menu can open and import into the Tabulation of 
Quantities Sheet. 

Note It may be necessary to update the lab computers with the latest versions of the reports 
for the exercise to work correctly. 

CREATE CSV FILE 
1. In Quantity Manager, select Tools > Reports > Create. This opens Create Report. 

 
2. From Report Style, select the drop down arrow and pick FDOT Pay Item Summary By 

Sheet report (CSV). 
3. For the Report File name, click the magnifying glass icon and browse to the Signals folder. 
4. Enter a file name, for this example use SBTBSG; the csv extension will be added 

automatically. 

 
5. Click Open. 
6. On the Create Report dialog, click Create. This opens the csv file in Excel. Do not close 

Excel. 
7. Click Cancel on the Create Report dialog. 
8. Close Quantity Manager. 
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SAVE CSV FILE TO XLS FORMAT AND SORT THE DATA 
1. In Excel, select File > Save As. 

 
2. For the Save as type, select Excel 97-2003 Workbook (*.xls). 
3. Click Save. 
4. Select the data in Excel. Select the data from Name column to Total column. 

 
Hint All “X”s must be UPPERCASE or the report will not import correctly into MicroStation. 

5. Select Sort and Sort A to Z. 

 
6. Click Save. Do not close Excel. 

This process of converting the csv file to an xls file is only so the FDOT Menu tool to edit 
and import the Excel data works properly. 

7. Next, the user will create the Tabulation of Quantities Sheet and import the excel data created 
in Quantity Manager. 
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 Lab Exercise: Create Tabulation Of Quantities Sheet 
CREATE TABULATION OF QUANTITY SHEET FROM FDOT MENU 

1. Open Dsgnsg01.dgn in the Signals folder. 
2. From FDOT Menu, select Traffic plans > Signals > Create/Edit File. 

 
Note Loading the Create File/Project tool form the Signals menu will automatically load the 

correct Control File and File Group. 
3. Using Create File/Project, create the Tabulation Of Quantity Sheet. This file goes in the 

Signals folder. 
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4. Click the Open button to open the Tabqsg01.dgn file. 
5. Accept the Plot Scale of 50.  
6. From FDOT Menu, select Traffic plans > Signals > Tabulation of Quantities Sheet > 

Place Sheet, Edit and Place Excel Data. 

 
7. This opens the Edit Excel Summary Box application with the Tabulation of Quantities 

(Signalization) sheet selected. 

 

8. Click the Place Sheet icon  to place the Signalization Tabulation of Quantities sheet. 
9. Issue a data point to place the sheet file. 
10. Reset to cancel the command. 
11. Perform a Fit View. 

 
PLACE EXCEL DATA 

1. Continuing in Tabqsg01.dgn, zoom in around the upper-left corner of the sheet near the text 
PAY ITEM NO. 

2. Click the Place Text icon  to place the Signalization Tabulation of Quantities data. 

Note If the user closed the Excel file the Edit Input icon  would need to be clicked first, 
this will open the Excel file. 

3. Snap to the end of the first horizontal line under the text PAY ITEM NO. 
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4. Issue a Data Point to accept the location. 
5. Review the data. 
6. Using Power Selector, select the Totals from the last plan sheet column and move to the 

correct column in the sheet file. This will be fixed in future release of the csv style files from 
FDOT. 

There is a Single Enter Data Field for the Sheet Number text above the Plan/Final columns; 
this can be edited using the MicroStation Fill In Single Enter Data Field tool. 

 
7. Run Sheet Navigator to fill in the title block and add the Digital Signature Note. Do no 

place the Sheet Number yet. 

 
8. Close Sheet Navigator. 
9. Close Excel. 
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6 SHEET NAVIGATOR 
CHAPTER OBJECTIVES 

In this chapter the following topics will be covered: 

• Overview of Sheet Navigator 

• Sheet Navigator Work Flow 

• Auto Numbering and Renumbering 

• Edit Multiple Sheets 

INTRODUCTION 
This section covers the application Sheet Navigator, which is used to label and tag sheets for 
electronic delivery. Its functions include entering of sheet title block information, auto 
numbering of sheets, renumbering sheets and performing Multiple Edits on sheets. Using this 
tool will greatly reduce the time needed to number sheets in a set of plans or even renumber 
sheets after sheets have been added or removed from the set which is a common occurrence over 
the life span of a project.  

OVERVIEW 

 
Sheet Navigator is one of the single most important tools in preparing a project for Electronic 
Delivery. Sheet Navigator has the ability to Auto Number sheets, Number single or multiple 
sheets and Re-Number sheets. Sheet Navigator can also tag a sheet as Obsolete so that 
Electronic Delivery indexer does not pick up the sheet and index it. This allows the user to 
create exhibits or temporary sheets in the project without the worry of Electronic Delivery 
including them in the plans package. Sheet Navigator can also perform multiple sheet edits at 
one time such as adding the Road Number or the Digital Signature Note to multiple sheets.  

Sheet Navigator creates an index named Sheetinfo.xml located in either the root project folder 
or in the component folder depending on how the user creates the index. This index is crucial to 
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Sheet Navigator functioning properly when working in the Auto Numbering, Renumbering or 
Multi Sheet Edit mode. 

Sheet Navigator is used to: 

1. Tag sheets for Electronic Delivery 
2. Number Sheets 
3. Label Sheet Title Blocks 
4. Auto Number sheets 
5. Renumber Sheets 
6. Apply Revision text 

 

SHEET NAVIGATOR WORKFLOW 
1. Create Sheet files using GEOPAK or FDOT Menu. 

Note The Border can be in the active file or a reference file. 
2. Open a Sheet file in MicroStation. 
3. From FDOT Menu, start Sheet Navigator. 
4. Populate fields in Sheet Navigator. 
5. Add Digital Signature note. 
6. Save data to sheet file. 

 

SHEET EDIT TAB 
The Sheet Edit tab is used for populating the standard title block information. 

 
  



Sheet Navigator - Overview Chapter 6 

FDOT Traffic Plans Course - Signalization ©2009 FDOT 6-3 

Sheets – This shows the number of sheets in the active file and also the sheet number if they 
have been numbered. Sheets show as Undefined if they have not been numbered. 

Sheet Number – This is the actual sheet number example T-3. 

Financial Project ID 1 – Eleven digit FIN number. This is automatically populated by clicking 
in the field. You must select a project configuration file when opening MicroStation for this to 
work. 

County 1 – If the project spans two counties this is for the first county. From the drop down 
menu select the county. 

Road Number – This is the State Road number of the project alignment. 

Financial Project ID 2 – For strung projects this is for the second project FIN number. 

County 2 – This is for the second county name if your project spans two counties. 

Sheet Description – Example, Tabulation of Quantities. 

Project Description – This is used on Structural sheet borders and provides a brief description 
of the project. 

Sheet Type – This is filled in automatically and is triggered by text in the sheet cell. 01-Plan 
Sheet is the default sheet type if none of the standard text strings are found. Refer to FDOT 
Menu for more information on this tool. 

Revision – Shows what revision if any the selected sheet has applied to it. 

Allow Plot – Controls whether the sheet will be converted to a PostScript image when using 
FDOT’s Electronic Delivery Software. 

Obsolete – Toggled on will make the selected sheets obsolete or inactive which means the 
electronic delivery software ignore these files.  

Component Override – Allows the user to assign a sheet to a different discipline other than the 
default discipline.  The default discipline is the discipline in which the MicroStation file resides. 

Sheet Component – Describes what is the plan set component of the selected sheet based on the 
sheet number. Example: T-4 would be component Signals where 5 would be the Primary 
component. 

Digital Signature Note – From the drop down menu the users selects the type of electronic 
Delivery Signature to place in the file. This cell uses the plot scale of the file. 

Add Engineering Record Cell – Places the Engineer of Record cell in the file. 

View Engineering Record Text – Reads the data in the Engineer of Record cell and displays it. 

View Boundary Coordinates – Displays the coordinates of the sheet boundary. 

Reload All – Closes and re-opens Sheet Navigator. If changes have been made to Sheet 
Navigator the user will be warned to save the changes or cancel. 

Refresh Sheet – Refreshes Sheet Navigator and MicroStation. If changes have been made to 
Sheet Navigator the user will be warned to save the changes or cancel. 

Save Sheet – Saves changes and updates the MicroStation file. 

Save All – Saves changes to all sheets and updates the MicroStation files. 
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NAVIGATOR TAB 
The Navigator tab is used for the Auto Numbering, Renumbering and Editing of multiple sheets 
at one time.  

 

AUTO NUMBERING AND RENUMBERING 
This is a multi step process where you will need to first auto number the sheets then renumber 
those sheets because the auto numbering process uses arbitrary numbers based on the file name.  

Example: Keyssg01.dgn is already numbered T-0001, when Auto Numbering is started Plansg01 
is auto numbered T-0001.  

This process can save the users a lot of time on large projects and it takes the tedious operation 
of having to open every sheet file and run Sheet Navigator manually. If a project has to be 
renumbered because of adding or removing sheets, Sheet Navigator automates the entire 
process. 

AUTO NUMBERING OR RENUMBERING WORKFLOW 
1. Create a Sheet Navigator index file named sheetinfo.xml. This can either be a project 

index or component index. 

 
Selecting Project will create an index file that covers all disciplines in the project; this is the 
option to use if you are the Prime and need to number all of the sheets on the project. 
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Selecting Component is used when you are only concerned with a specific discipline. The 
discipline name will default to the working directory that Sheet Navigator was started in. 

Note It is very important that the Sheetinfo.xml is always current. If there is any doubt as to how 
up to date this file is always create a new Sheetinfo.xml. It only takes a short amount of time to 
create this file and it hurts nothing to overwrite the existing file. 

2. Open the sheetinfo.xml file. 
3. Start the numbering process. 
4. Select the process to run: Auto Number, Renumber or Edit Sheets. 

 
5. Finish and apply changes. 
6. Cancel & Exit Process allows the user to stop the process without making any changes just 

in case an error was made. 
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Lab Exercise: Auto numbering and Renumbering 
AUTO NUMBER THEN RENUMBER SHEETS 

1. Open dsgnsg01.dgn. This exercise can be completed from any design file. 
2. From FDOT Menu, select Actions > Label Sheets (Sheet Navigator).  

This opens Sheet Navigator. 

 

 
 

3. In Sheet Navigator, select the Navigator Tab. 
4. In the Navigator tab, select File > New. This opens Create New Index. 
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5. Select the Component option.  
6. Click the Build Index button. This creates sheetinfo.xml in the Signals folder. All other 

discipline folders are ignored. 
7. MicroStation will close and the CADmanage (CM.Batch) process will run. 

 
 

8. Select Renumbering/Multi-Edit > Start process. This adds several options to the dialog. 
9. Click OK on the Warning dialog. This is message that prompts the user to ensure that the 

Index is current. 
 

 
Note Several options have been added to the Sheet Navigator dialog. 

10. Select Renumbering/Multi-Edit > Auto Numbering > Auto Numbering Mode. The user 
could also use the check box at the bottom of the dialog to activate this option. 
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Note The following figure shows all of the sheets, some are numbered and others are tagged 
as undefined. Undefined means these sheets have not been numbered. When auto 
numbering is run, plansg01 will be numbered T-0001. 

 
11. Notice the toggle is On next to Sheet Order / Auto Number at the bottom of the dialog. 
12. Click Auto Number.  
13. Click OK on the Auto Number Sheets dialog. This is just information about the logic used 

to number sheets. 

 
Note If the undefined sheets are not numbered correctly, you will need to renumber these 

sheets.  If the sheets are numbered correctly you can skip to step 17. 
14. Click in the grey column before the Sheet Set Ordering column and drag across the four 

auto numbered sheets. 

15. Click the Sequence Sheets  button at the bottom of the dialog.  
This opens Sequence Sheets. 

16. Set Starting Sequence Number to 3. This changes Plansg01 from T-0002 to T-0004 and 
increments the other selected sheets by the same number. 

 
17. Click OK. Notice the Sheet numbers have now been changed.  
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18. Next you need to save the changes and update the design files. 

 
19. Click Renumbering/Multi-Edit > Finish and Apply Changes.  

 
20. Toggle on Yes to Update all sheet number references. 
21. Click Apply Renumbering on the Finish and Apply Renumbering dialog to apply 

changes. This will open the MicroStation files and add the sheet numbers to the sheets. 
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22. Notice in the figure below that the sheets are now numbered sequentially. This was 
accomplished with never entering any of the design files, totally automated. This is a huge 
time saver on large projects. 

Note Sheet Navigator can also be used to open files in the index by double clicking on the file. 

 
23. Double-click on sheet T-0004 to open plansg01.dgn.  
24. Set Sheet Navigator to the Sheet Edit tab. Notice that the design file has been edited to 

have a sheet number.  
25. Set Sheet Navigator to the Navigator tab. If there are sheets that do not have a Road 

Number, you will use this tool to add the Road Number to multiple sheets in the next 
exercise. 

 

 
 
26. Close Sheet Navigator. 
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Optional Lab Exercise: Use Multi-Edit To Add Road Number 
This exercise was created for the user to see how Sheet Navigator can be used to edit other 
sheet information other than the sheet number.  The example in this exercise is if there were 
sheets that were missing the State Road Number in the title block. The user can simply substitute 
the discipline and file names in this exercise with whatever discipline the user is working on in 
the office. 

ADD SR 415 TO ALL SHEET FILES 
1. Open Dsgnsg01.dgn. This exercise can be completed from any design file. 
2. From FDOT Menu, open Sheet Navigator. 
3. In Sheet Navigator, select File > New.  

 
In this exercise the user could have selected Open Component Index as we just closed Sheet 
Navigator and know that it is current. In the real world these files will be accessed by several 
users so it is always a good idea to re-create the Index.  

4. In Create New Index, select Component.  
5. Click OK to overwrite the existing Index file. 

Note As the index is being created you can view the process in the CM.Batch dialog as 
shown next. 

 
Note When the CM.Batch process is complete, Sheet Navigator will open showing the 

Component index. 
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6. Select Renumbering/Multi-Edit > Start process. 

 
7. Click OK on the Warning dialog. 

 
8. Click on sheet T-0005 and drag down across sheet T-0006. This selects the two sheets 

missing the Road Number. You must click and drag over the box on the far left side next to 
the Sheet number where the black arrow is shown. You can also use the Ctrl and Shift keys 
to select files. 

9. Select Renumbering/Multi-Edit > Edit Sheets. This opens Renumbering – Edit Sheets. 

 
10. Toggle on Road Number. This activates the Road Number field in the dialog. 
11. Key in SR 415 in the Road Number field. 
12. Click Apply. 
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13. Click OK on the Warning dialog. 

 
14. Click Renumbering/Multi-Edit > Finish and Apply Changes. 
15. Click Apply Renumbering on the Finish and Apply Renumbering dialog to apply 

changes. This will start the editing process. When finished Sheet Navigator will reload and 
show the completed index. 

 
16. Double-click on Sheet T-0005 and review the change. 
17. Close Sheet Navigator. 
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7 PLOTTING TOOLS 
CHAPTER OBJECTIVES 

In this chapter the following topics will be covered: 

• Plotting In MicroStation 

• Plot to PDF 

• Save Configuration file 

INTRODUCTION 
This section covers the basics of plotting from within MicroStation. FDOT delivers a number of 
plot drivers that can be used to plot hard copy paper plots or electronic post script or pdf files.  The 
plot drivers control how MicroStation displays the graphics on paper or in an electronic file.  

Users can produce plots several different ways through MicroStation. Each district office may 
have its own set of plotting procedures and plot drivers, contact the CADD manager if there are 
any questions regarding plotting. The intention of this chapter is to explain two plotting options, 
Plotting through MicroStation and plotting to a PDF file. 

FDOT delivers a document in the FDOT2008\RESOURCES\plot\ directory that better explains all 
of the delivered plot drivers. Review this document before plotting as there is important 
information that may be helpful. 

PLOTTING IN MICROSTATION 
The Plot dialog can be opened from the tool bar in MicroStation or from the MicroStation menu 
option File > Print. This will open the Print dialog as shown below. Depending on your 
office/site standards, the Print dialog opens with a standard plot driver. This is a Workspace 
Configuration setting and should be set by the CADD Manager.  
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In this course guide, you will be using the fdotprinter.pltcfg for plotting to a device. 
Fdotprinter.pltdfg, as described in the help document, is a copy of the Bentley printer.pltcfg 
driver with weights and styles set to FDOT standards. 

Note Many of the old file formats (PLT, INI, SPC) have changed in MicroStation XM. The 
old formats can be used in XM, but any files created using the new formats in XM will not 
be backwards compatible. 

MicroStation's print engine required many changes for the V8 XM Edition to ensure 
compatibility with this edition's reworked graphics display subsystem. In addition, there are a 
number of other upgrades to printing functionality.  

We will discuss what is new with plotting in MicroStation XM and will see how to edit the new 
printer drivers and pen tables later in this chapter. 

FILE MENU  
The File menu contains options for setting up the plots, previewing the plot, selecting and editing 
a plot driver, and reloading the driver after editing. 

 
The format of the printer drivers has changed to XML and they now have the extension PLTCFG. 
MicroStation XM will continue to support many of the old PLT files but Bentley encourages 
users to convert their existing drivers because they will drop support of the PLT format at some 
point in the future. FDOT has converted all of the drivers normally provided and include only the 
PLTCFG version in the FDOT2008 Software Suite. 

Edit Printer Driver Configuration 
Since MicroStation XM supports both PLT and PLTCFG files the Print dialog was enhanced to 
recognize which type of printer driver is currently attached and it opens the appropriate editor 
when you select Edit Printer Driver Configuration from the File menu. PLT files will open in 
Notepad, just as they did in the past and PLTCFG files will open in a new editor that is included in 
MicroStation XM. 
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• General Tab 

A new user interface is provided for creating and editing the new PLTCFG printer driver 
configuration files. The new tab based interface with drop‐downs to define optional setting will 
reduce the chance of typos. The General tab displays the file name and type of driver that is 
currently being edited. It also provides a notes area where the user can provide a description of the 
driver and any important instructions for it use. This is equivalent to the comments that were 
common in the top of many of the old PLT files. 

 
• Base Properties Tab 

The Base Properties tab is divided into several categories. This is where most changes will be 
made when customizing a driver. The dialog is resizable and each category can be expanded or 
minimized individually. 

When editing a printer driver, keep in mind that, many of these settings control the default values 
that will appear in the Print dialog. When a driver is configured properly the end user should not 
be required to make adjustments in their normal plotting process. 
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• Paper Sizes Tab 

The Paper Sizes tab allows you to define the page size and layout for each paper size that will be 
available when using the selected driver. For the sheet to default to the correct scale in the Print 
dialog the paper size must be properly defined. 

In MicroStation V8 the size record was equal to the size of the plot border: 
size=(10.600,16.500)/num=11/off=(0.20,0.29)/name=17x11 

In MicroStation XM the “Size” will equal the paper size which is 11 X 17 and the margins are 
used to adjust the printable area to match the size of the plot borders which are 10.6 x 16.5. 

 
• Color Maps Tab 

The Color Maps tab allows you to define the color to be printed for each color in the design file. 
Typically FDOT drivers are configured for black and white printing with only color 20 defined as 
a grayscale color. 
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• Weight Maps Tab 

The Weight Maps tab is used to define the thickness each line weight will be printed at. These 
settings may need to be adjusted, depending on hardware, to get a quality print that can be 
reproduced or copied well. 

 
• Line Styles Tab 

The Line Styles tab is used to define the way each of the standard MicroStation line styles will be 
printed. These styles have been customized in each of the FDOT printer drivers. 
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• Font Maps Tab 

The Font Maps tab allows replacement of MicroStation fonts with Windows fonts when printed. 

 
• Programs Tab 

The Programs tab allows run a program either before or after the print is processed. 
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CONFIGURATION MENU 
The Configuration menu contains options for Opening and Saving Configuration files. 
Configuration files are used to store settings that allow users to easily recreate plots. 

 
Example: You have your plot dialog set up with all of the settings needed to produce a paper plot 
that looks like it is supposed to; you save this by clicking Configuration > Save. This creates an 
.ini file that can be loaded the next time the user needs to plot a sheet. All of the settings will be 
exactly the same. 

SETTINGS MENU 
The Settings menu contains options for setting the Units (inches, feet, mm, cm, dm, m), Update 
from View, Print Attributes (like level symbology and whether or not to plot the print border along 
with several other attributes), Raster Options, 3D Plotting (ghosted) and Preferences.  

 
Note A new Print Preferences dialog was added enhancing the capabilities in a more user 

friendly layout. 

PEN TABLE 
The PenTable menu is for Creating, Attaching and Editing Pen Tables. Pen Tables can be used to 
do several things during the plot process. FDOT delivers one Pen Table that fills in the fields at 
the bottom of the plots with the file name, date and user name. This file can be modified to 
perform other functions but understand that any modifications made will affect all users if the Pen 
Table is located on the server.  
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PRINT ICONS 

 - Submits the print  

  - Opens a Print Preview window 

 - Maximizes the plot to fit the printable area 

 - Opens the Print Attributes dialog 

 - Updates the print preview to match the design file 

 

GENERAL SETTINGS 
The General Settings area is where you select the plot area and which view to plot from. It also 
shows which if any pen table is loaded, how many copies to plot and the color status.  

 
Rasterized option was added in MicroStation XM.  This option should only be used for rendering 
or transparencies because it generates larger plot files and is a considerably slower process.  When 
this option is selected MicroStation will convert both raster and vector data into a single raster 
image and send it to the printer. 

Note The Rasterized toggle option is not for printing files. 
 

PRINTER AND PAPER SIZE 
The Printer and Paper Size section is for selecting whether to use a Windows Printer or a 
Bentley Driver. Clicking on the magnifying glass allows you to browse and load a plot driver. 
Clicking the Windows icon lets you configure the windows printer. You can also select the paper 
size and whether or not to plot as Landscape or Portrait. The Full Sheet toggle, when on will 
maximize the print size to the selected paper size as seen in the figure below. 

 
The figure below shows the same plot area with Full Sheet cleared. 
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PRINT SCALE AND POSITION 
Print Scale and Position is where you fill in an exact plot scale. Typically, how this works is you 
place a fence around the plot border of the design file; this will calculate a scale and display it in 
this portion of the dialog as seen below. Next, you round this odd number up to the actual scale. In 
the example shown below the actual print scale is 100.00. 

 
Note This is one of the settings that can be saved into the settings file so when loaded for 

each plot the scale will always be set to the correct scale. 
 

You have the ability to adjust the X Origin and Y Origin print position. These values change the 
position on the print on the paper. 

CONVERTING PLT FILES TO PLTCFG 
The PLTCFG files are XML files so just changing the extension will not convert the files. You 
must select an existing PLTCFG file to begin because if a PLT file is active in the Print dialog 
Notepad will be opened when you select Edit Printer Driver instead of the new PLTCFG editor. 

Steps to Convert PLT to PLTCFG: 

14. Start MicroStation using the FDOT2008 icon and open a file with a sheet border. 
15. Fence the sheet border. 
16.  Select File > Print from the MicroStation menu to open the Print dialog. 
17. Select the Bentley driver option and click on the Select Printer Driver Configuration Fill 

button to select a driver. 
18. Navigate to the \FDOT2008\RESOURCES\plot directory and select any PLTCFG file to 

edit. 
19. With a PLTCFG file active in the Print dialog select File > Edit Printer Driver 

Configuration from the Print dialog menu.  
The new Printer Driver Configuration editor will open. 

20. From the Printer Driver Configuration editor, select File > Open. 
21.  Navigate to the PLT file to be converted and click on the Open button. 

Notice that the PLT file was opened read only. PLT files opened in this editor can only be 
opened with read access. To modify the file you will need to save it as a PLTCFG file which 
will convert it to an XML file instead of the ASCII text format used for PLT files. 

22. Select File > Save As from the menu and save the file as a .pltcfg format. 
23. Adjust Paper sizes. Now that the printer driver has been converted to the new format you will 

need to adjust the paper sizes as shown earlier. 
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PEN TABLE ENHANCEMENTS  
ELEMENT SELECTION CRITERIA 

 
Wildcards can be used to select levels by entering the expression in the Level regular expression 
field and Tags have been added to the list of element types available. 

ELEMENT OUTPUT ACTIONS 

 

Pen Table Transparency 
Pen table transparency is supported for any printer driver capable of printing in rasterized mode. If 
pen table transparency is used when printing in non‐rasterized mode, the transparency values do 
not have any effect. 

Pen Table Priority 
Pen table priority does not have any effect for printing 3D files. Priority is implemented for 
printing 3D files through Z depth, using hardware acceleration when possible, so the pen table is 
no longer required to make multiple passes through the element list. This permits some actions 
that were not possible with the 2004 Edition, such as assigning different priorities to individual 
components of a shared cell. 
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PEN TABLE - OPTIONS  

 
You can set up a pen table to apply more than one section to an element. If Match multiple 
element sections is on in the Pen Table - Options dialog box, the sections will be selected and 
applied in descending order, starting at the top of the list and working downwards. 

If this setting is off (the default), once a section has been selected by its input criteria and its 
output actions applied, pen table processing on that element stops. In the V8 XM Edition the 
Element symbology comparison mode setting in the Pen Table - Options dialog box affects only 
the manner in which the input criteria treats level symbology. There are two modes from which to 
choose: 

• As stored in element header — the element header symbology is matched against the 
input criteria.  

• As displayed in view — the view symbology is matched against the input criteria. 

PEN TABLE EDIT 
The following are the steps that will modify the standard FDOT pen table (FDOT.tbl) so that all 
of the elements in a referenced file will be plotted as if they were all color 20.  

1. To edit the Pen Table select PenTable > Edit from the menu. This will open the 
Modify Pen Table.  

2. Make a copy of the standard FDOT pen table by selecting File > Save As from the 
menu and give it a logical name. 

3. Select the last item in the Processing Order field and then select Edit > Insert New 
Section Below. 

4. The Insert Section dialog will appear prompting you for a Name. Enter a logical name.  

5. Click OK to continue. 

Note Make sure the new item is selected in the Processing Order field and then select all of 
the items in the Type field as shown below. The easiest way to do this is to click on any 
one of the items and the hit Ctrl + A on the keyboard. If you only wanted to gray scale a 
certain type of element like a shape then you would only select the appropriate items in 
the Type field. 

6. Click the Files button to define the references to be processed.  

7. The Identify Files dialog will appear. In the bottom field enter the logical name of the 
reference to apply the resymbolization to or part of the name and wildcards for files with 
multiple sheets. 
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Note When specifying a logical name for a reference in the pen table, you can enter the 
complete logical name, or you can enter an expression pattern consisting of one or more 
wild cards. The following table identifies the wild cards that you can use for matching 
logical names.  

Wild Card Used to  
(.) Match any character. Serves as a single�character wild card.  

(*) Match zero or more occurrences of the preceding character. Used in combination with any 
character or with the single character wild card (.). Automatically includes the root word. 

(+) Match one or more occurrences of the preceding character. Used in combination with any 
character or with the single character wild card (.). Automatically excludes the root word. 

8. Click Add.  

9. Add any other logical names to process and then click OK to return to the Modify Pen 
Table dialog. 

10. From the Modify Pen Table dialog box, click on the Element Output Actions tab. 

11. Select the Color checkbox and set the color to 20 as shown below. 

12. Select File > Save from the menu to save the changes. 

13. Close the Modify Pen Table dialog. 

14. Select File > Reload Printer Driver Configuration. 

 

Lab Exercise: Create a PDF Plot File 
PLOT TO A PDF FILE 

1. Open Plansg01.dgn in the Signals folder. 
2. Place a fence on the sheets plot border. This is the red shape around the outside of the border. 
3. Click on the Print icon or select File > Print from the MicroStation menu Bar.  

This opens the Print dialog and sets a default plot driver. 
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4. In the Print dialog, select File > Select Bentley Driver.  
This opens Select Printer Driver Files. 

 
5. Browse to FDOT2008\RESOURCES\plot and select fdotpdf.pltcfg. 
6. Click OK. This loads the fdotpdf plot driver and changes the settings in the print dialog. 

Note This plot driver automatically loads the fdot.tbl pen table; look at the dialog in the 
General Settings area.  

 
7. Set the Paper Size to 17 x 11. This is the default setting in the plot driver. 
8. Set the Print Scale to 50.00. 
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9. Click the Print Attributes icon  or select Settings > Print Attributes.  
This opens Print Attributes. 

 
10. Toggle off Constructions. This turns off the red plot border. 

Note It is also recommended to toggle off the Print Border and Fence Boundary options.  
11. Click OK.  

12. Click the Print icon . This opens Save Print As. 

Note The default location for the plot files is the eng_data folder under the discipline folder as 
shown below. 

 
13. Click OK. This accepts the default file name and location and creates the pdf file 
14. From FDOT Menu, select Standard > Explore Current Working Directory.  
15. Browse to the eng_data folder. 
16. Double-click on Plansg01.pdf. This will open the plot file for review. 
17. Close the pdf file. 
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SAVE THE PRINT SETTINGS 
Now that you have all of the print settings set the way you want them, it would be a good idea to 
save these settings for future use and also for other users to use so that you get consistent output. 

1. In the Print dialog, select Configuration > Save. This opens Save Print INI File As. 

 
2. In Save Print INI File As, type in Signals-PDF. The file name will default to the 

MicroStation file name. 

 
3. Click OK. This saves the settings to an ini file that can be used in subsequent plot jobs. 
4. In the Print dialog, select a different plot driver. File > Select Bentley Driver. Select 

fdotprinter.pltcfg for this example. Notice how all of the plot settings have changed. 
5. In the Print dialog open the Configuration file you just saved, Configuration > Open. 
6. In the Signals folder select Signals-PDF.ini. 
7. Click OK. This will set all of the plot preferences the way you saved them for the pdf plot. 
8. Close the Print dialog. 
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