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FDOT CROSS SECTIONS 

CE-11-0134 

Description 

This course instructs on basic and advanced GEOPAK skills to teach Advanced GEOPAK users on the 

features supported in the Florida Department of Transportation (FDOT) criteria to generate roadway cross 

sections.   

The objective of the course is to develop roadway cross sections using the FDOT criteria for MicroStation 

and GEOPAK to meet FDOT standards as defined in the Plans Preparation Manual, Computer Aided 

Drafting & Design (CADD) Manual, and the CADD Production Criteria Handbook (CPCH).  

Topics Covered  

This course includes, but is not limited to the following:  

 Design and Computation (D&C) Manager  Typical Section Generator

 GEOPAK Project Manager  Superelevation Shapes

 3PC Adhoc Attribute Manager  FDOT Criteria

Prerequisites 

To get the most from this course the user should have a basic understanding of CADD using MicroStation, 

a basic understanding of GEOPAK concepts and a solid understanding of the engineering necessary to 

design a roadway.  

This course does not teach CAD drafting or engineering design. GEOPAK is simply a tool to facilitate the 

engineering design process.  The following courses and some manual drafting or related CADD product 

experience is recommended: 

 MicroStation 

o FDOT MicroStation Essentials Part I  CE-11-0114 

o FDOT MicroStation Essentials Part II  CE-11-0115 

 GEOPAK 

o FDOT Basic GEOPAK for Roadway Designers  CE-11-0099 

o FDOT Advanced for GEOPAK Roadway Designers CE-11-0101 

 Engineering /  Design 

o Solid understanding of road design process 

 

Duration:  16 Hours    

Professional Credit Hours:  16 PDHs 
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1 INTRODUCTION 

OBJECTIVES 
This course is designed to give users hands-on instruction through the process of manipulating adhoc 

attributes and Criteria variables when creating cross sections using MicroStation V8i (Selects Series 2) 
and Bentley GEOPAK Suite – V8i (Selects Series 2).  These versions are important.  Many functions 

required for the Criteria to work correctly are not present in earlier versions.  The students will create cross 

section components using the Criteria developed for Florida Department of Transportation (FDOT) 

(Version 2010.00.00). 

FDOT CRITERIA 
All the cross section components are contained in one file, RDXSRD01.dgn.  The fdotseedxs.dgn file is set 

up with models.  The models included are Rdxsrd (cross sections), Xsshrd (shapes), Pattrd (pattern lines), 

and Rdxsrd_shg (sheets). Separate files are recommended for each run of cross sections, i.e. mainline, side 

streets, etc. 

The FDOT Criteria looks for elements contained in the design files to determine what cross section 

elements to draw.  It also gathers adhoc attribute values attached to those elements found in the plan view 

to define how it is to draw those elements/features in cross section view.  When elements are not present in 

the design files, then the Criteria does not draw those elements into cross section view.  This makes it very 

important to use the Design & Computation (D&C) Manager.  It has been designed to set the correct 

symbology for the many design files used with the FDOT software.  Therefore, the Criteria look for the 

design elements based on the D&C Manager items (often referred to as ddb features).  Along with the 

attribute tags the D&C Manager places, it also places pre-defined adhoc attributes on the necessary 

elements for the Criteria to read and use accordingly.  It is highly recommended to read the Help 

documentation which clearly explains what the Criteria is looking for on the elements and how to set those 

elements correctly. 

The Help documentation for the FDOT Criteria is in html format for easy navigation.  In addition to the 

Description button on the Typical Section dialog, it can also be accessed from the FDOT Menu and from 

within the D&C Manager. 

Five typicals are provided with the FDOT Criteria.  They are Existing Features, Proposed Features, 

DrawROW, and the two existing cross slope report typicals.   

 The Existing Features typical will draw the existing base under the existing features present 

in the topo file.  This includes the existing pavement, shoulders, curb, sidewalk, driveways, 

miscellaneous pavement and guardrail.  It also includes the use of a “GEOPAK Lines” file.  

This approach allows the users to “clean up” their topo files to run with the Criteria without 

modifying the original file from survey.   

 The Proposed Features typical encompasses divided or undivided roadways, medians, 

milling, overlay, widening, new pavement, paved shoulders, curb  and/or gutter, sidewalks, 

ditches/special ditches, berms, driveways, special profiles, tapering features, miscellaneous 

asphalt, guardrail, walls, etc all in the same typical.   

 The DrawROW typical draws and labels the right of way elements found in the RWDTRD file 

along with fence and wetland limits.   

 The existing slope report typicals, Und_ExSlope and Div_ExSlope, locate the existing edges 

of pavement from the TOPORD file and extracts the existing ground elevation from the cross 

sections.  The Criteria generate a csv file with the existing elevation and slope information. 
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WARNINGS / HELPFUL HINTS 

 GEOPAK does not recognize models when searching DGN files. (i.e. Pattern lines, Design Files) Make 

sure to be in the correct model before executing drawing commands. 

 There must be an even number of existing edges of pavement for the existing features Criteria to function 

correctly.   

 When running cross sections, there will be a pause when it loads the define DGN elements.  This is due to 

GEOPAK loading the ddb file in the background. 

 Read the Help documentation!! 

PRE-REQUISITES 
This course is designed for the more advanced Computer Aided Design and Drafting (CADD) user.  It has 

been created with the emphasis on manipulating design elements, adhocs, and variables in order to produce 

the cross sections with the desired results.  With this in mind, several steps to creating cross sections have 

already been processed and are provided for this class.  These steps are: 

1. Creating the cross section file (RDXSRD01.dgn). 

2. Creating a project within GEOPAK‟s Project Manager. 

3. Setting up the working alignment. 

4. Creating the Pattern Lines and Existing Ground Cross Sections. 

5. Creating Profiles. 

6. Creating Superelevation Shapes. 

ADDITIONAL INFORMATION 

For more information on the GEOPAK tools used in the process of creating cross sections, please go to one 

of the following links.  They contain training documentation as well as data sets. 

http://www.dot.state.fl.us/ecso/downloads/documentation/MicroStationEssentials/MSEssentials.shtm 

 

http://www.dot.state.fl.us/ecso/downloads/documentation/MicroStationEssentials/MSEssentialsPartII.shtm 

 
http://www.dot.state.fl.us/ecso/downloads/documentation/BasicGEOPAKforRWDesigners/BasicGEOPAKforRWDesi

gners.shtm 

 

http://www.dot.state.fl.us/ecso/downloads/documentation/AdvancedGEOPAKforRWDesigners/Advanced

GEOPAKforRWDesigners.shtm 

 

http://www.flugsite.com/Presentations.cfm 

 

http://www.dot.state.fl.us/ecso/downloads/presentations/default.shtm 

 

  

http://www.dot.state.fl.us/ecso/downloads/documentation/MicroStationEssentials/MSEssentials.shtm
http://www.dot.state.fl.us/ecso/downloads/documentation/MicroStationEssentials/MSEssentialsPartII.shtm
http://www.dot.state.fl.us/ecso/downloads/documentation/BasicGEOPAKforRWDesigners/BasicGEOPAKforRWDesigners.shtm
http://www.dot.state.fl.us/ecso/downloads/documentation/BasicGEOPAKforRWDesigners/BasicGEOPAKforRWDesigners.shtm
http://www.dot.state.fl.us/ecso/downloads/documentation/AdvancedGEOPAKforRWDesigners/AdvancedGEOPAKforRWDesigners.shtm
http://www.dot.state.fl.us/ecso/downloads/documentation/AdvancedGEOPAKforRWDesigners/AdvancedGEOPAKforRWDesigners.shtm
http://www.flugsite.com/Presentations.cfm
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DOCUMENT STYLE  

Style conventions used throughout the course guide are shown in the following table. 

Item Convention Example 

Menu names 

and 
Commands 

Bold, names separated 

with > symbol 

 File > Open 

 File > Compress > Design 

Software Name 

and  

Dialog box 

Title 

Arial 

 GEOPAK does not recognize models. 

 Set up the Proposed Cross Section Run - 
Exfeat dialog as shown below. 

Dialog box 

Actions 

Bold 

 

 Click the Apply button. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include box. 

 In the Segment Type list, click Lines. 

Dialog box 

Field Names 
Italic 

 Key in Hemfield Road in the Alignment Name 

field. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include field. 

 In the Segment Type list, click Lines. 

Key-ins Bold 
 Key in Hemfield Road in the Alignment Name 

field. 

File names Italic 

 Open the file Working Graphics.dgn in the  

 C:\Bentley Training\GEOPAK 101\Project 

Setup\Practice\ Working Graphics.dgn 

File paths 
Non italic 

 

 C:\Bentley Training\GEOPAK 101\Project 

Setup\Practice\ folder. 

New Terms or 

Emphasis 

Italic 

 

 The Template Library contains templates, which 

represent typical sections of the proposed roadway. 
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2 EXISTING FEATURES 

OBJECTIVES 

 Identify supported Existing Features 

 Existing Features Typical – Set up and Variables 

 Proper Use of the GKLNRD file 

EXISTING FEATURES 

FDOT has provided two typicals to draw existing features on cross sections, Existing_Features and 

DrawROW.  The Existing_Features typical will extend existing ground lines to the extent of the cross 

section cell and draw the base for the existing pavement, shoulders, curbs, sidewalks, driveways, traffic 

separators and miscellaneous asphalt as well as draw the existing guardrail.  The DrawROW typical draws 

and labels existing R/W, wetlands and fence on the cross sections.  It also draws and labels proposed R/W 

and fence. 

REDEFINABLE VARIABLES 
The Existing Features Criteria uses Redefinable Variables to set options that can be controlled by the 

designer for the entire cross section run or through varying station ranges.  These variables control search 

distances, base thicknesses, the option to extend the existing ground to the limits of the cross section cell 

(pattern line), and whether to turn different features on and off.  Included in these variables is the option to 

generate an error report.  For more detailed information on the Redefinable Variables available see the 

Cross Section Criteria Help files. 

Existing Features Redefinable Variables Summary 

Redefinable Variable Default 
Setting 

Options 

_d_ExistPavtThick 8/12 Setting to zero (0) will not draw. 

_d_ExistMiscPavtThick 4/12 Setting to zero (0) will not draw. 

_d_ExistShoulderThick 6/12 Setting to zero (0) will not draw. 

_d_ExistCurbThick 8/12 Setting to zero (0) will not draw. 

_d_ExistSidewalkThick 4/12 Setting to zero (0) will not draw. 

_d_SidewalkSearchDistance 10 Any positive number will change the search distance. 

_d_ExistTrafficSeparatorThick 8/12 Setting to zero (0) will not draw. 

_d_CurbSearchDistance 3 Any positive number will change the search distance. 

_d_ShoulderSearchDistance 15 Any positive number will change the search distance. 
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Redefinable Variable Default 
Setting 

Options 

_s_EFTTL Y (Yes) Y (Yes) – Will draw Existing Feature Labels. 

N (No) – Will not draw Existing Feature Labels. 

_s_ExtendExGrdLT N (No) N (No) – No Existing Ground Line Extension 

H (Horizontal) – Extend Existing Ground Horizontally 

12 – Any positive number continues the Existing 
Ground at its current slope.  The Value of the 
number represents the sample width for computing 
the slope. 

 _s_ExtendExGrdRT N (No) N (No) – No Existing Ground Line Extension 

H (Horizontal) – Extend Existing Ground Horizontally 

12 – Any positive number continues the Existing 
Ground at its current slope.  The Value of the 
number represents the sample width for computing 
the slope. 

 
_d_eeopSearchDistance 24 

 

Any positive number will change the search distance. 

_d_MiscPavtSearchDistance 12 Any positive number will change the search distance. 

_s_ Error_File N (No) Y (Yes) – Generates a report of Stations with error 
messages and possible resolutions. 

N (No) – Will not generate the error report. 

_s_ Error_Filename 1 1 – Uses the default filename, Exfeat_Error_File.csv. 

2 – Triggers a prompt for a filename when the 
Criteria runs. 

_d_DrivewaySearchDistance 50 Any positive number will change the search distance. 

_d_DrivewayThick 6/12 Setting to zero (0) will not draw. 

_s_EGR Y (Yes) Y (Yes) – Draws guardrail cell onto the cross section 
when the Criteria encounters existing guardrail line. 

N (No) – Will not draw the guardrail cell. 

Note:  Uses the level name to determine the correct 
cell to use (left or right). 

 

  



EXISTING FEATURES - Redefinable Variables Chapter 2 

FDOT Cross Sections ©2011 FDOT  2-3 

Exercise 2.1 Existing Features Criteria with Redefinable Variables 

In this exercise the Existing Features typical will be used to draw the existing base on the cross sections.  

Redefinable variables will be modified to turn on the option to generate the Error report. 

1. Open the file C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model Rdxsrd using the 

FDOT2010 MicroStation icon. 

2. Open Road Project by going to Applications > GEOPAK > ROAD > Project Manager. 

3. Select the Project 74185215201 and click OK. 

 

4. On the Project Users dialog, select Student from the list box and click OK. 
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5. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

 

6. Select the run ExFeat . Click OK.   

 

Note When working in Project Manager, always create a new run.  Do NOT simply rename the Untitled run.  
When creating a new run, the program copies the untitled run to generate the new run.  If this run gets 
corrupted, there is not a fresh run to use to generate the new run. 
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7. Select the Redefinable Variables category from the list.  

 

8. From the Variable list box, select _s_ Error_File and click Edit.  

Note Double clicking on the variable will also open the Redefinable Variable Editor.  
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9. On the Redefinable Variable Editor dialog change the N to a Y and click Save.  

 

10. From the File Menu, select File > Save Settings and then File > Run. 

11. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below.  

 

12. The cross sections will run.  When done, click Exit. 

13. Using the Cross Section Navigator, review the sections.  Note that the sections did not run correctly.  

Many of the sections have the error “Irregular Pavement Found”.   
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14. On the FDOT Menu select Standards > Explore Current Working Directory.  

 

15. From Explorer, open the Error Report file, Exfeat_Error_File.csv.  Review the file.  It contains the 

station, error message, and a notation to use the GKLNRD file and the TOPO Overrides to correct the 

errors found during the cross section run.  

 

16. Close Excel. 

17. Close Cross Section Navigator. 

18. Close the Proposed Cross Sections – Exfeat dialog box.  When prompted, click Yes to save 

settings to the cross section run. 
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GKLNRD FILE 

The Existing_Features Criteria searches the topo file to locate the plan view elements defining the limits 

of the existing features.  It also searches an optional supplemental design file, GKLNRD, referred to as the 

“GEOPAK Lines file”, for those same elements.  This supplemental file is designed to be used in 

conjunction with the topo file in instances when the topo file is not entirely correct.  Sometimes the topo 

file elements are not coded with the correct features or do not have the correct level symbology for the 

Criteria to locate.  In these instances, the correct elements are drawn into the supplemental file for the 

Criteria resulting in correct cross sections without modifying the topo file received from survey. 

Once a feature has been identified from the TOPORD and/or GKLNRD file, the Criteria will try to 

determine which element that it should be connecting to.  These elements are called closing components.  

Many of the features have multiple closing components.  If the Criteria cannot find the closing component, 

an error message will be drawn on the cross section at the point where the feature crosses the existing 

ground line.  If there is an odd number of existing edges of pavement found in the files the Criteria will 

draw the error message, “IRREGULAR PAVEMENT FOUND” across the top of the cross section.  The 

Criteria will try to draw what it can, however, without the pavement edges defined correctly many features 

will not be drawn. 

When errors are encountered, the next step is to take a look at the TOPORD file.  In many cases, an 

element will be found that was not coded correctly.  Sometimes, the pattern line will cross one of the 

feature elements and won‟t find a second element to tie it to, i.e. side roads.  Some instances will require 

extra elements drawn into the GKLNRD file in order for the Criteria to resolve correctly, even though the 

TOPORD elements have been coded correctly.  The Criteria includes the option to label existing features 

with the redefinable variable _s_EFTTL.  The option is useful in determining what features the Criteria 

finds in the topo file, as well as the GKLNRD file.  The labels include the type of feature, i.e. existing 

pavement or shoulder, and in which file the feature was found.  Depending on the feature and the error 

message given, different corrective measures can be taken to get the cross sections to run. The designer has 

the ability to add the missing line work and/or override specific TOPO elements using the GKLNRD file.  

Elements found in the GKLNRD file will be considered the correct feature and will override any elements 

found in the topo file.   

The following table lists some common errors encountered and corrective measures that can be applied. 

Error Corrective Measure 

Pavement crown of the roadway has 
been coded as existing edge of 
pavement 

Copy the incorrect existing edge of pavement line into the 
GKLNRD file and change the level symbology to the 
PavtCrown_ep, TopoMisc_ep, or LaneLine_ep. 

Incorrect level symbology in the 
TOPORD, i.e. edge of shoulder that 
has been coded edge of pavement or 
vice versa, etc. 

Copy the incorrect element into the GKLNRD file and change 
the level symbology 

Patten line only crosses 1 element, 
i.e. at a side road or driveway that 
extends beyond the limits of the 
pattern line 

Draw a line crossing the pattern line with the corresponding 
symbology where the designer would like to see the base 
close.  Note: Do NOT draw the element at the exact end of 
the pattern line.  This can cause errors. 

Draws base under undesired location, 
i.e. a concrete slab or parking area 

Copy the elements into the GKLNRD file and change the 
symbology of the element to TopoMisc_ep.  Drawing an 
element using this level over any element from the TOPORD 
will negate that element from the TOPORD file.  

All the sidewalk was drawn using the 
Back of Sidewalk symbology 

Copy the element that should be coded Front of Sidewalk into 
the GKLNRD file and change the level to SidewalkFront_ep. 
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The Criteria searches for and will override elements for the following features.  

 Existing Edge of Pavement 

 Traffic Separators 

 Existing Edge of Shoulder 

 Curb 

 Sidewalk 

 Driveway 

 Miscellaneous Asphalt 

 Guardrail 

For more information, please see the TOPO Elements Overrides HTML Help file.  This help file contains 

several tables listing the overrides for each topo element. These elements are to be placed in the GKLNRD 

file coincident to the topo element they will override. By placing the override element in GKLNRD file the 

elements in the TOPORD file will be ignored and not utilized by the Existing Features Criteria.   

  There are a few important notes to remember:  

 Do NOT copy ALL of the elements from the topo file into the GKLNRD file.  Only the individual 
elements that are needed to correct the topo file to achieve the correct cross section features should 
be copied or drawn into this file. 

 The GKLNRD file is NOT supported in the proposed features Criteria. 

Exercise 2.2 Using the GKLNRD file 

In this exercise, the GKLNRD file will be used to correct the existing features drawn on the cross 

sections.  These corrections will include correcting the symbology for a lane line which was incorrectly 

drawn as an edge of pavement, adding elements that did not cross the pattern lines, and “turning off” 

base under a section of embankment that was drawn incorrectly as edge of pavement. 

1. Open the GEOPAK lines file C:\e\projects\74185215201\roadway\GKLNRD01.dgn. 

2. Using MicroStation’s Copy Element tool, copy the edge of pavement line located at the center of the 

travel lanes on the left side of the roadway in the TOPORD file into the current design file.   
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3. Using the Change Attribute tool, change the element level to LaneLine_ep. 

 

Note If the Existing Features were run using just the topo file, the 5 edges of pavement found would result in 
the warning “Irregular Pavement Found”.  By drawing this line into the GKLNRD file as a lane line, the 
Criteria will now find 4 edges of pavement and be able to draw the existing base. 

4. Open the D&C Manager. 

5. Navigate to Topography \ AP. 

6. Zoom into the area of the cross over. 

7. With Place Influence turned On, place a short line segment crossing the pattern line on the inside 

edges of the roadway on top of the existing lane lines.  (These are on the pattern lines just before and 

after the cross over as indicated in the picture below.) 
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8. In the D&C Manager, navigate to Topography \ DWYE.  With Place Influence still turned ON, draw 

a line across the pattern line at the back of the driveways as shown below. 

 

9. Uncheck Place Influence. 

10. Zoom in to the ditch area on the right side of the roadway at the same station. 

11. Using the Change Attribute tool, toggle ON Make Copy to copy the 2 concrete pavement elements 

into the current file changing the level to TopoMisc_ep. 

 

12. Close the GKLNRD01.dgn file. 
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Exercise 2.3 Existing Features 

In this exercise, the user will run the previous run of the cross sections, see Exercise 2.1, with the 

GKLNRD file and compare the results.   

1. Open the file C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model Rdxsrd. 

2. Open Road Project by going to Applications > GEOPAK > ROAD > Project Manager. 

Note If the cross section run from Exercise 2.1 is still open, skip to step 6. 

3. Select the project 74185215201 and click OK. 

4. Select the user Student and click OK. 

5. Open the previous Run from Exercise 2.1, ExFeat. Proposed Cross Sections - ExFeat opens.  

6. On the Redefinable Variables section, double click on the variable _s_EFTTL.  Modify the value to 

^N^. Click Save. 

   

Note It is recommended to leave this variable set to Y (Yes) until the errors are corrected.  The labels are 
useful in determining what features the Criteria is finding in the topo and GKLNRD files.  Once the 
sections are running correctly, turn this feature off by modifying the variable to N (No). 

7. Select all the elements and Delete.  

Note The existing ground, elevation text, R/W labels, wetland limit labels and cross section cells are locked. 

8. On the Proposed Cross Sections - ExFeat dialog, select File > Save Settings. 

9. Select File > Run.  Proposed Cross Section opens. 
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10. On the Proposed Cross Section dialog, select the Output option To Log File, check the option 

Disable View Update and click Apply. 

 

11. Once the cross sections complete, review the sections using the Cross Section Navigator.   

12. Close Cross Section Navigator. 

13. Close the Proposed Cross Sections – Exfeat dialog box.  When prompted, click Yes to save 

settings to the cross section run. 

14. Select all the elements and then select Edit > Lock.  

15. Exit MicroStation. 
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3 PROPOSED FEATURES 

OBJECTIVES 

 Identify Proposed Roadway Features 

 Identify Basic Requirements for the Proposed Features Criteria 

 Identify the methods to control the proposed cross section features. 

PROPOSED FEATURES 

The FDOT Criteria is designed to run all cross sections (existing, divided or undivided, mill and resurface, 

new pavement or both, widening, etc.) through the Typical Section Generator.  It uses proposed 

pavement shapes to draw the sections. The shapes need to cover the full width of the proposed travel lanes. 

When adding shape clusters to the proposed cross section run, they need to be added from left to right. The 

Typical Section Generator is set up for the typical to be applied one time to the left roadway. The typical 

generates both the left and right side slopes for each shape cluster eliminating the need to reapply the 

typical to the right roadway.  

The FDOT Criteria supports various design options based on redefinable variables and plan graphics.  It is 

important to know what these options are during the design stage of the project to save time and effort 

when it comes time to create the proposed cross sections.  It is recommended that the D&C Manager be 

used during the design process to insure that any adhoc attributes required by the Criteria are attached to 

the elements.  Remember that if a feature does not exist, the variables for those features will not be used.  It 

is not necessary to modify the related variables to 0. 

Exercise 3.1 Identify the Roadway Features 

This exercise is a group activity.   

1. Identify the roadway “Features” depicted in the cross section. 

 

2. What other “Features” might be included in a cross section? 

The FDOT Criteria supports many design features required on divided and undivided roadways.  Supported 

pavement options include widening, milling, reconstruction, and new construction.  The roadway shoulder 

features supported are paved shoulders, curb and gutter, sidewalk, “urban” ditches, driveways, 

miscellaneous asphalt, guardrail, and shoulder barrier walls.   The slopes include ditches, barrier walls, 

gravity walls, special ditches, berms, and R/W or wetland limit constrained slopes.  The Criteria also 

supports median features which include paved/unpaved shoulders, curb and gutter, ditches, miscellaneous 

asphalt, guardrail and median barrier walls.   
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Exercise 3.2 Proposed Cross Sections “Out of the Box” 

Students will run proposed cross sections without modifying any variables or making any changes to the 

graphic elements found in the DSGNRD file. 

1. Open the file C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model Rdxsrd. 

2. Open Road Project by selecting Applications > GEOPAK > ROAD > Project Manager. 

3. Select the project 74185215201 and click OK. 

4. Select the user Student and click OK. 

5. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

 

6. Select the run PrFeat.  Click OK. 

7. Verify the Tolerance is set to 0.01 from the default setting of 0.1. 

8. Select File > Save Settings and then File > Run. 

9. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below. 

 

10. The cross sections will run.  When done, click Exit. 

11. Using the Cross Section Navigator, review the sections. 

12. Close Cross Section Navigator. 

CONTROLLING PROPOSED CROSS SECTION FEATURES 
The FDOT Criteria is designed with many variables set with default values that control what features are 

drawn into the cross section and how these features are drawn.  These variables can be modified by the 

designer through multiple methods, redefinable variables, plan graphic “trigger” elements, and adhoc 

attributes attached to the graphic elements.  Using a combination of these options a user can control the 

output of the cross section run. 



 

FDOT Cross Sections ©2011 FDOT  4-1 

4 REDEFINABLE VARIABLES 

OBJECTIVES 

 Define Redefinable Variables and What They Control. 

PROPOSE FEATURES REDEFINABLE VARIABLES 

Redefinable variables are populated into the Proposed Cross Section run when a Typical is applied 

through the Typical Section Generator.  These variables are designed to be used as typical settings over 

the length of the project.  They may be modified for the entire run or with the use of additional “If/Then” 

statements to cover specific station ranges of sections.  For more information on the Redefinable variables 

used in the Criteria, please see the Cross Section Criteria Help documentation. 

 

Note It is important to note that a redefinable variable will be overwritten by any plan graphic elements and/or 
adhoc attributes found on plan graphic elements designed to control the same feature as the 
redefinable variable.   

Proposed Features Redefinable Variables Summary 

Variable Name Default 

Setting 

Description 

_s_DDSTextFileName SodSlope.csv File name for the comma separated value (csv) file 

generated to report and calculate areas for slopes that 

are steeper than 1:3.  

_d_PavementThickness 4.5/12 Thickness in feet for the proposed pavement layer. 

_d_BaseThickness 0/12 Thickness in feet for the proposed base layer. 
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Variable Name Default 

Setting 

Description 

_d_CrossOverDitchWidth 5 Width in feet of the pavement ditch in a cross over 

where the extended pavement forms a ditch. 

_s_ExtendBaseUnderCurb N Set to Yes or No to have the Criteria draw the base 

extended under the proposed curb. 

_d_Base_Ext_Width 0/12 Width in feet of how far to extend the base under the 

proposed curb. 

_d_CurbSearchDistance 3 Distance in feet to search for the face of curb from the 

proposed edge of pavement or paved shoulder. 

_d_CurbBufferDistance 1 Distance in feet to draw a slope behind the proposed 

curb before breaking to front slope 1.  This buffer is 

ignored when there is sidewalk present behind the 

curb.  The Criteria will use the utility slope instead. 

_d_CurbBufferSlope -6 The slope in percent format of the drawn curb buffer.  

Do NOT include the percent sign. 

_d_UtilitySlope 2 The slope in percent format for the utility strip drawn 

between the back of curb and the front of sidewalk.  

Do NOT include the percent sign. 

_d_SidewalkSlope 2 The slope in percent format for the proposed 

sidewalk.  Do NOT include the percent sign. 

_d_SidewalkThickness 4/12 Thickness in feet of the proposed sidewalk. 

_d_SidewalkBufferDistance 2 Distance in feet to continue the sidewalk slope behind 

the sidewalk before breaking to front slope 1. 

_d_OutsideShoulderSearchDistance 10 Distance in feet to search for a paved shoulder line 

from the edge of pavement. 

_d_NormalOutsideShoulderSlope -6 Normal shoulder slope in percent format when not in 

super elevation.  Do NOT include the percent sign. 

_d_OutsideShoulderWidth 8 Width in feet of the total outside shoulder.  This 

includes the paved and unpaved shoulders. 

_d_OutsideShoulderThickness 3/12 Thickness in feet of the paved shoulder pavement 

layer. 

_d_ShoulderBaseThickness 4/12 Thickness in feet of the paved shoulder base layer. 

_d_MaxRollOver 7 The maximum algebraic difference between the 

pavement slope and the shoulder slope. 

_d_MedianShoulderSearchDistance 10 Distance in feet to search for a paved shoulder line 

from the edge of pavement in the median. 

_d_NormalMedianShoulderSlope -6 Normal median shoulder slope in percent format when 

not in super elevation.  Do NOT include the percent 

sign. 

_d_MedianShoulderWidth 4 Width in feet of the total median shoulder.  This 

includes the paved and unpaved shoulders. 

_d_MedianShoulderThickness 6/12 Thickness in feet of the median paved shoulder. 

 

 

  



REDEFINABLE VARIABLES - Propose Features Redefinable Variables Chapter 4 

FDOT Cross Sections ©2011 FDOT  4-3 

Variable Name Default 

Setting 

Description 

_d_FrontSlope_1_Slope_Left(Right) -1:6 Slope in rise:run format of Front Slope 1.  This slope 

is NOT part of the ditch variables.  It is intended for 

clear zone.  Do NOT zero out this variable if this 

feature is not to be drawn.  Turn this feature off by 

setting _d_FrontSlope_1_WidthLeft(Right) to 0.  

_d_FrontSlope_1_Width_Left(Right) 10 Width in feet of Front Slope 1.  This slope is NOT 

part of the ditch variables.  It is intended for clear 

zone.  Setting the value of this variable to 0 will turn 

this feature off. 

*_d_FrontSlope_2A_Slope_Left(Right) -1:4 Slope in rise:run format for Front Slope 2A.  This is 

the front slope for the outside ditch.  Do NOT zero out 

this variable if the feature is not to be drawn. 

*_d_FrontSlope_2A_Max_Ht_Left(Right) 5 This is the maximum depth of the ditch in which the 

FrontSlope2A will be used. 

*_d_FrontSlope_2B_Slope_Left(Right) -1:3 Slope in rise:run format for Front Slope 2B.  Do NOT 

zero out this variable if the feature is not to be drawn. 

*_d_FrontSlope_2B_Max_Ht_Left(Right) 10 This is the maximum depth of the ditch in which the 

FrontSlope2B will be used.  FrontSlope2B will start 

from the max depth of 2A. 

*_d_FrontSlope_2C_Slope_Left(Right) -1:2 Slope in rise:run format for Front Slope 2C.  Do NOT 

zero out this variable if the feature is not to be drawn. 

*_d_FrontSlope_2C_Max_Ht_Left(Right) 20 This is the maximum depth of the ditch in which the 

FrontSlope2C will be used.  FrontSlope2Cwill start 

from the max depth of 2B. 

*_d_FrontSlope_2D_Slope_Left(Right) -1:1 Slope in rise:run format for Front Slope 2D.  Do NOT 

zero out this variable if the feature is not to be drawn. 

*_d_FrontSlope_2D_Max_Ht_Left(Right) 100 This is the maximum depth of the ditch in which the 

FrontSlope2D will be used.  FrontSlope2D will start 

from the max depth of 2C. 

_d_DitchWidth_Left(Right) 4 Width in feet of the outside ditch bottom. 

_d_DitchBackslope_Left(Right) 1:3 Slope in rise:run format for the back slope of the 

ditch.  Do NOT zero out this variable if this feature is 

not to be drawn. 

_d_StandardDitchDepth_Left(Right) 4 Depth in feet of the outside ditch. 

_s_RightofWayConstrainedSlope_Left 

(Right) 

No Tells the Criteria whether or not to consider the ROW 

when tying in the back slope of the ditch to existing 

ground.  If set to Yes, the Criteria will analyze the tie 

point and adjust the slope of the back slope such that 

the ditch ties to existing ground before the ROW.  If 

set to Adj, the Criteria will adjust the ditch bottom 

width to tie to existing ground before the ROW and 

then the back slope if adjusting the ditch bottom width 

does not work.  The default of No will ignore the 

ROW location and tie to ground using the ditch 

variable settings. 
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Variable Name Default 

Setting 

Description 

_d_ROW_Buffer_Width 0 Distance in feet to tie inside of the ROW if the 

variable 

_s_RightofWayConstrainedSlope_Left(Right) has 

been set to Yes or Adj. 

_s_WetlandConstrainedSlope_Left(Right) No Tells the Criteria whether or not to consider the 

Wetland Limits when tying in the back slope of the 

ditch to existing ground.  If set to Yes, the Criteria 

will analyze the tie point and adjust the slope of the 

back slope such that the ditch ties to existing ground 

before the Wetland Limit.  If set to Adj, the Criteria 

will adjust the ditch bottom width to tie to existing 

ground before the Wetland Limit and then the back 

slope if adjusting the ditch bottom width does not 

work.  The default of No will ignore the Wetland 

Limit location and tie to ground using the ditch 

variable settings. 

_d_Wetland_Buffer_Width 0 Distance in feet to tie inside of the Wetland Limits if 

the variable _s_WetlandConstrainedSlope_Left(Right) 

has been set to Yes or Adj. 

_s_ForcedSlopeLeft(Right) No Tells the Criteria whether or not to force the slope to 

existing ground ignoring the ditch variables.  The 

forced slope begins at the bottom of Front Slope 1. 

_s_ForcedSlopeLeft(Right)Value 1:2 Slope value in rise:run format to use to force the slope 

to tie to existing ground.  Will only be used if the 

corresponding variable _s_ForcedSlopeLeft(Right) is 

set to Yes.  Do NOT zero out this variable if this 

feature is not to be drawn. 

_d_FeatherDistance_Outside_Left(Right) 0 Distance in feet for the Criteria to tie to existing 

ground beyond the outside shoulder of the roadway.  

Setting this value to any positive number will turn this 

feature on.  The slope will vary. 

_d_MatchLineChainSearchDistance 50 Distance in feet from the outside edge of pavement to 

search for a match line.  This feature will draw the 

sections at normal slopes until it encounters the match 

line in plan view.  At the match line offset, the 

Criteria will draw straight up or down to tie to 

existing ground. 

* The Front Slope 2 variables work together to provide “stair stepping” of the ditch front slopes.  They work in 

conjunction with the Standard Ditch Depth variables.  The Max Height variables run consecutive from the previous 

Max Height variable.  I.e. For a ditch depth value of 30 feet, Front Slope 2A continues from 0 to 5 feet, Front Slope 

2B continues from 5 to 10 feet, Front Slope 2C continues from 10 to 20 feet, and Front Slope 2D continues from 20 

to 30 feet.  If the ditch depth is set to less than the Max Height of Front Slope 2A, then only the slope value from 

Front Slope 2A will be used.  The other variables do NOT need to be set to 0 so that they will not be used.  They can 

be left at the default values.   

Note Do NOT eliminate slope features by setting the slope variable values to 0.  This will result in errors 
within the Criteria.  Set the corresponding depth, width, or height variable to 0. 
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MODIFYING REDEFINABLE VARIABLES 
Double clicking on one of the variables in the proposed cross section run dialog, or selecting the variable in 

the list and clicking Edit will open the Redefinable Variables Editor dialog. 

  

From this editor, the value may be modified for the entire run by typing in the new value and clicking Save.  

To maintain the value of the variable, but modify over a station range, the If/Then statement may be copied 

and pasted creating a new defining If/Then statement.  See below for an example. 

  

Note Care should be taken in the order in which the station ranges are defined in the list of If/Then 
statements.  The Criteria will read all of the statements and reset the value of the variable if the If/Then 
statement is true.  In some cases, this may set the value incorrectly when encountering overlapping 
station ranges.  
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Exercise 4.1 Modifying Redefinable Variables 

In this exercise, students will modify the redefinable variables for the cross section run. 

1. Open the file C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model Rdxsrd. 

Note If the cross section run from Exercise 3.2 is still open, skip to step 7. 

2. Open Road Project by going to Applications > GEOPAK > ROAD > Project Manager. 

3. Select the Project 74185215201 and click OK. 

4. Select the User Student and click OK. 

5. Click on the Proposed Cross Sections button.  

6. Select the PrFeat Run on the Select Run dialog and click OK.  (This is the same run used in Exercise 

3.2.)  Proposed Cross Sections – PrFeat opens. 

7. Select the Redefinable Variables category. 

8. Scroll down the list of variables and select _d_FrontSlope_1_Width_Left.  Click on the Edit button. 
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9. On the Redefinable Variables Editor, modify the entry as shown below. 

 

10. Click Save. 

11. Select the variable _s_ForcedSlopeLeft. Edit the variable value to Yes and then click Save. 

12. Select all the elements and Delete. 

Note The existing ground, elevation text, R/W labels, wetland limit labels and cross section cells are locked. 

13. From the File Menu, select File > Save Settings. 

14. From the File Menu, select File > Run.  Proposed Cross Section opens. 

15. On the Proposed Cross Section dialog, select the Output option To Log File, check the option 

Disable View Update and click Apply. 

16. The cross sections will run.  When done, click Exit. 

17. Using the Cross Section Navigator, review the sections. 
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Exercise 4.2 Right of Way Applications 

In this exercise, students will modify the Right of Way and Wetland Limit redefinable variables to have the 

Criteria consider the location of these features when tying the back slope of the ditch to existing ground. 

1. On the Proposed Cross Sections – PrFeat dialog, select the Redefinable Variables category. 

2. Scroll down the list of variables and select _s_RightofWayConstrainedSlope_Right.  Double click 

on the variable or click on the Edit button. 

   

3. Modify the variable value to Yes.  Click Save. 
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4. Select the variable _s_WetlandsConstrainedSlope_Left.  Double click on the variable or click on the 

Edit button. 

 

5. Modify the variable value to Adj.  Click Save. 

 

6. Select the variable _s_ForcedSlopeLeft.  Double click on the variable or click on the Edit button. 
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7. Modify the variable values as shown below.  Click Save. 

 

8. Repeat steps 6 – 7 for the variable _s_ForcedSlopeRight. 

9. Select all the elements and Delete. 

Note The existing ground, elevation text, R/W labels, wetland limit labels and cross section cells are locked. 

10. From the File Menu, select File > Save Settings. 

11. From the File Menu, select File > Run. 

12. On the Proposed Cross Section dialog, select the Output option To Log File, check the option 

Disable View Update and click Apply. 

13. When sections are done running, click Exit. 

14. Using the Cross Section Navigator, review the cross sections. 

 



 

FDOT Cross Sections ©2011 FDOT  5-1 

5 PLAN GRAPHICS   

OBJECTIVES 

 Define Plan Graphic elements and What They Control. 

 Define Adhoc Attributes and What They Control. 

PLAN GRAPHIC ELEMENTS OVERVIEW 
Plan graphics are elements drawn into the design file that, when found by the Criteria, tell the Criteria what 

to draw on cross sections.  Some of these elements are required for design such as the proposed edge of 

pavement, curb and gutter, sidewalk, etc.  Other elements are added to the design file strictly for the 

Criteria in order to control the cross section features.  These elements are set up to be non-plottable.  These 

elements include special ditch lines, median lines, berm lines, and graphic override lines. 

Plan graphic elements are searched for using Define_DGN variables.  The D&C Manager is used by the 

Criteria to define these variables.  It is important to use the D&C Manager to draw the elements into the 

design.  When searching for plan graphic elements, the Criteria is looking for elements that cross the 

pattern lines.  They also must be placed in the area of the design file that the Criteria will be able to locate 

them.  Simply placing a line into the file does not guarantee that it will be found by the Criteria.  For 

example, a special ditch line needs to be placed outside the limits of the shoulder of the roadway where the 

ditch would be constructed.  (This includes paved and unpaved shoulder.)  

Finding the plan graphic elements in plan view will tell the Criteria which cross section features to draw.  

Additionally, some elements also have adhoc attributes which will tell the Criteria how to draw the 

features.  Adhoc attributes used by the Criteria to define the necessary variables are set up in the D&C 
Manager. It is important to understand that only the adhocs defined by the delivered FDOT2010.ddb file 

will be recognized by the FDOT Criteria.  New adhocs may not be introduced onto an element and then be 

expected to be read by the Criteria. 

Some adhoc attributes have default values of none or 999.  The Criteria considers these values to be 

undefined.  If these values are changed so that they are recognized by the Criteria, then change them.  

However, if the feature is removed from the project or the value needs to be reset so that it does not draw in 

the cross sections any longer, change these values back to none or 999.  Setting the values to 0 will result in 

errors. 

Note The values shown in the adhoc box within D&C Manager do NOT represent the adhocs attached to 
an existing element.  They may be modified to add to new elements drawn or set onto existing 
elements.  To view the adhoc attributes on the elements, use GEOPAK or FDOT’s Adhoc 
Attribute Manager. 

Plan Graphic Elements Summary 

Feature Associated 

Adhocs? 

Plan/Trigger? Design File 

Back of Sidewalk Yes Plan/Trigger DSGNRD 

Front of Sidewalk No Plan DSGNRD 

Driveway Yes Plan/Trigger DSGNRD 

Edge of Pavement Yes Plan DSGNRD 

Existing Ground No Plan RDXSRD 
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Feature Associated 

Adhocs? 

Plan/Trigger? Design File 

Existing R/W No Plan RWDTRD 

Proposed R/W No Plan RWDTRD 

Wetland Limits No Plan TOPORD 

Milling Limits Yes Plan DSGNRD 

Median Line Yes Trigger DSGNRD 

Miscellaneous Asphalt Yes Plan DSGNRD 

Guardrail No Plan DSGNRD 

Proposed Traffic Separators Yes Plan DSGNRD 

 Curb and/or Gutter (All types) No Trigger DSGNRD 

Paved Shoulder Yes Plan DSGNRD 

Side Road Tie Down Lines Yes Plan DSGNRD 

Match lines No Plan DSGNRD 

Curb and Gutter Wall No Plan DSGNRD 

Shoulder Barrier Wall (Cant. or L) Yes Plan DSGNRD 

Shoulder Barrier Wall (Retaining) No Plan DSGNRD 

Gravity Wall No Plan DSGNRD 

Median Barrier Walls Yes Plan DSGNRD 

Edge of Front Slope 1 No Trigger DSGNRD 

Special Ditch Lines Yes Trigger DSGNRD 

Berm Lines Yes Trigger DSGNRD 

Front Slope 1 Slope Override Yes Trigger DSGNRD 

Front Slope 1 Width Override Yes Trigger DSGNRD 

Front Slope 2 Slope Override Yes Trigger DSGNRD 

Ditch Width Override Yes Trigger DSGNRD 

Back Slope Override Yes Trigger DSGNRD 

Ditch Depth Override Yes Trigger DSGNRD 

Force Slope Override Yes Trigger DSGNRD 

Feather Distance Override Yes Trigger DSGNRD 

 

For a detailed list of the graphic elements the Criteria searches for, consult the FDOT Criteria Help files.  

They may be accessed through the FDOT Menu under Roadway > FDOT2010 Criteria Help Files, in the 

D&C Manager on the Adhoc Attributes dialog by clicking on the “?” icon, or by clicking on the 

Description button on the Typical Sections dialog. 

 It is recommended to extend elements beyond the limits of the pattern lines, at least 2 times 

tolerance, when they are to be used by the cross section Criteria.  This also applies to superelevation 

shape and pattern line creation.  There are issues with GEOPAK processing elements that intersect 

with one another exactly.  Undesirable results can occur.  
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PAVEMENT GRAPHICS (TRAVEL LANES) 
The intent of the work to be done on the project is communicated to the Criteria through the milling limit 

lines and proposed edges of pavement.  Milling and overlay will only be drawn on the cross sections when 

the Criteria finds the milling limit lines in the design file.  Likewise, the proposed edges of pavement 

represent the full depth pavement construction on the project.  Full depth pavement can be found as 

widening, new construction, or reconstruction. 

MILLING AND RESURFACING 

Milling and Resurfacing is one of the more complex features of the Criteria.  Milling Limit lines are 

required to be drawn into the design file for this operation to be reflected on the cross sections.  The D&C 
Manager item location is Roadway Design > Plan Features > MillLimit.  This item has been set up with 

several adhocs that will tell the Criteria how to process the milling and overlay layers of the cross sections. 

 

The first consideration is the Design Method.  Simply put, this adhoc defines the milling control point for 

the cross sections.  Four options are available, M, L, R, and C.   

If the Design Method is set to M (minimum overlay), the Criteria will analyze the existing pavement area 

and the cross slope of the roadway to determine the point on the section where the minimum amount of 

overlay will be required for construction.  By default, it will project the cross slope back to the pgl location 

and write the elevation out to an input file which can then be used to store a profile into COGO.  The 

minimum overlay profile can then be used to develop a proposed profile for the roadway.  The new 

proposed profile can then be used to control the cross sections by setting the profile name to the Overlay 

Profile adhoc.  This process is optional and provided in the Criteria as an aid for designers. Using the 

option M will also trigger the Criteria to draw the milling as Match Existing, which will trace the existing 

ground.  This results in a constant depth of milling. 

Setting the Design Method to L (left), R (right), or C (chain) tells the Criteria that the milling control point 

needs to be fixed to the location indicated.  The Criteria will hold the proposed top of pavement to the 

existing ground elevation.  Using one of these options will trigger the Criteria to use the cross slope of the 

shapes to draw the milling, resulting in variable depth milling.  The top of the proposed pavement can be 

raised or lowered from the existing ground elevation using the adhoc Overlay Profile.  If the stationing of 

the profile defined on the Overlay Profile adhoc does NOT match the baseline stationing of the cross 

section, the adhoc Prof Sta Ref Chain must also be defined. 
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There are two methods used to draw the Overlay and Widening, ME (match existing) and CC or SC (crown 

or slope correction).  The ME method traces the existing ground line while the CC or SC methods will use 

the slopes on the shapes.  These methods can be set for the overlay using the adhoc Overlay Type (CC ME) 

The method used for widening is set using the adhoc Widening Slope (SC ME).  When the option for the 

widening is set to ME, the adhocs, Sample Offset Distance and Sample Width, are used to calculate the 

existing cross slope of the roadway.  From the edge of the existing pavement, the Criteria will move over 

the Sample Offset Distance toward the pavement and then locate the existing ground.  Then it will move 

again, in the same direction toward the pavement, the distance defined by Sample Width and locate the 

existing ground.  The elevations at these 2 locations are used to calculate a cross slope.  This cross slope is 

used to draw any widening encountered on that side of the cross section.   

 

The Criteria reads the adhocs from the milling limit lines from left to right as it processes the elements that 

cross the pattern line.  The adhocs found on the first milling limit line that it encounters will set the values 

for the milling variables to be used for that cross section or until the Criteria encounters a median line.  

Once a median line is found, the Criteria will search for the next milling limit line to reset the milling adhoc 

values.  The only exception to this is the Milling Depth.  The milling depth is reset each time a milling limit 

line is found.  The value defined will be applied to the pavement to the right of the milling limit line.  The 

value defined on the last milling line is not used since that element designates the end of the milling area. 
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PROPOSED EDGE OF PAVEMENT (NEW CONSTRUCTION & WIDENING) 

Use of the proposed of edge of pavement lines triggers the Criteria to draw full depth pavement.  The D&C 
Manager item location is Roadway Design > Plan Features > EOP. 

 

The adhocs have been set to give the Criteria the pavement design for the proposed pavement utilizing the 

adhocs Pavement Thickness and Base Thickness.  If the base is to be shown constructed under the curb, the 

adhoc Extend Base Under Curb can be set to „Y‟ and the Base Extension Width for the distance the base 

extends beyond the back of curb set.  These values are measured in feet. 

The adhoc Widen_Side is used to tell the Criteria which side of the pavement that the widening is extending 

from.  This prevents the Criteria from drawing the pavement in the wrong location.  See the example shown 

below. 

 

There may be situations on a project where the edge of pavement needs to be controlled by a profile.  In 

these cases, the profile can be set using the EOP_Widening_Profile adhoc.  The Criteria will use the cross 

slope defined by the shapes to the limits of shape and then vary the slope from the shape to the profile 

elevation at the horizontal location of the edge of pavement line drawn in the design file.  The 

Widening_Profile_Chain should only be set when the profile stationing does NOT match the baseline 

stationing of the cross sections.  
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SIDE ROAD TIE DOWNS 

Side Road Tie Downs are elements drawn in the design file which designate to the Criteria where to tie the 

pavement operation to the existing ground/pavement.  The D&C Manager item location is Roadway 

Design > Plan Features > SRTD.  There are not any shoulder or slope features beyond this element.  The 

Criteria will use the cross slopes of the shapes where the shapes are drawn and then tie from the elevation 

at the outside edge of the shape to the existing ground elevation at the side road tie down location.  The 

slope of this tie will vary and cannot be controlled through the use of the side road profile.  If desired, the 

“profile” of the side road can be reproduced through a series of proposed edge of pavement lines drawn in 

the design with profiles set on the adhoc EOP_Widening_Profile and the corresponding chains set to the 

adhoc Widening_Profile_Chain.  A simple profile composed of 2 VPI‟s of the same elevation can be 

created to represent the side road elevations at key offsets to force the Criteria to draw the pavement at side 

road cross sections to better resemble the profile of the side road.  See example below. 

 

 

Exercise 5.1 Pavement Applications 

In this exercise, the students will review and modify the milling limit lines in the DSGNRD file to control 

the milling behavior of the cross sections and add a side road tie down line. 

1. Open the MicroStation design file C:\e\projects\74185215201\roadway\DSGNRD01.dgn. 

2. Open the Adhoc Attribute Manager.  It can be accessed through Applications > GEOPAK > ROAD 

> 3PC Adhoc Attribute Manager, through the Road toolbox, <OR>  

from the Road Project Manager Task List. 
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3. Click the Identify Element icon and then click on one of the Milling Limit lines.   

 Turn off the display for the TOPORD reference along with all the levels, except: ShldrPaved, 

EOP, and MillingLimits.  This will make selecting the desired elements easier. 

 

4. Review the list of adhocs on the Milling Limit line. 

 

5. Create a MicroStation Selection Set of the all the Milling Limit lines on the left roadway. 
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6. In the Adhoc Attribute Manager, click within the Design Method adhoc Value field and modify to C. 

 

7. Click on File > Preferences. Preferences dialog opens. 

 

8.   Set the Set Mode to Replace. 

 

9. Close the Preferences dialog. 
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10. In the Adhoc Attribute Manager, click on the Set Attributes icon. 

 

11. An Alert box will appear asking “Are you sure?” to set the attributes for a Selection Set. Click Yes. 

 

12. Click on the Identify Element  icon.  The elements from the selection set are dropped from the 

selection set and appear in the Adhoc Attribute Manager list box.  Use the Previous Element and 

Next Element icons to toggle through the elements to verify that the adhocs were modified. 

 

Note When there is a selection set brought into the dialog box, the tool is in a “review” mode.  Using the Set 
Attributes button will not have any affect. 
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13. Click on the Identify Element icon. (This will clear the adhoc list box.)  Select a Milling Limit line 

from the right roadway.  

14. In the Adhoc Attribute Manager, highlight Design Method in the list box.  Right click over the line 

and select Copy to Display Filter. 

 

15. Click on the Highlight Selection button to see the highlighted elements that match the query.  Switch 

back to Normal Display.  

 

16. Click on the Add Elements to Selection Set button to place the highlighted elements in a 

MicroStation selection set. 
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17. In the Adhoc Attribute Manager, click within the Design Method adhoc Value field and modify to R. 

 

18. In the Adhoc Attribute Manager, click on the Set Attributes icon. 

 

19. An Alert box will appear asking “Are you sure?” to setting the attributes for a Selection Set. Click 

Yes. 
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20. Click on the Identify Element icon.  The elements from the selection set are dropped from the 

selection set and appear in the Adhoc Attribute Manager list box.  Use the Previous Element and 

Next Element icons to toggle through the elements to verify that the adhocs were modified. 

 

21. Close the AdHoc Attribute Manager. 

22. Open the D&C Manager and navigate to the side road tie down item, Roadway Design > Plan 

Features > SRTD. 

23. Turn on Place Influence. 

24. Zoom into the area of the side road And place a line crossing the side road to indicate a location to tie 

into the existing pavement. 

 

25. Turn off Place Influence. 

26. Open the cross section file, C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model RDXSRD. 

Note If the cross section run from Exercise 4.1 is still open, skip to step 31. 

27. Open Road Project by selecting Applications > GEOPAK > ROAD > Project Manager. 

28. Select the project 74185215201 and click OK. 

29. Select the user Student and click OK. 
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30. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

 

31. Select the run PrFeat.  Click OK. 

32. Select all the elements in the file and delete. 

33. Select File > Save Settings and then select File > Run. 

34. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below. 

 

35. The cross sections will run.  When done, click Exit. 

36. Using the Cross Section Navigator, review the sections. 

37. Close Cross Section Navigator.  
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SHOULDERS  

Shoulders, in this context, consist of the area from the edge of pavement to the top of Front Slope 1.  

Shoulder treatments can consist of paved shoulders, curb & gutter, utility strips, sidewalks, urban ditches, 

driveways, and may include miscellaneous asphalt, guardrail and/or walls.  Through various plan graphics 

and adhoc attributes, the shoulder features are defined for the Criteria.  

PAVED SHOULDERS 

Paved shoulder lines drawn into the design file triggers the Criteria to include paved shoulders on the cross 

sections.  The D&C Manager item location is Roadway Design > Plan Features > PSHLDR.  The exact 

location of the elements in the design file is used by the Criteria.  If a paved shoulder line is not drawn and 

curb and gutter is not found, the Criteria will draw unpaved shoulder on the cross sections using the settings 

from the redefinable variables.  

 

The Shoulder Thickness and Shoulder Base Thick adhocs are used to provide the pavement design 

information to the Criteria.  If the shoulder base needs to extend beyond the asphalt layer, the Shoulder 

Base Ext adhoc can be set to any positive number representing the distance, in feet, that the Criteria should 

extend the base layer. 

Adhocs are also provided to help control the unpaved shoulder.  The unpaved shoulder width and slope 

may be controlled through the adhocs Unpaved Shoulder Width and Unpaved Shoulder Slope.  Typically, 

the slope would follow the paved shoulder slope.  If the design requires this to be a different slope, change 

the value from 999 to the desired slope.  A value of 999 is interpreted as undefined by the Criteria and 

ignored. 

The paved shoulder slope is, by default, controlled through the Criteria to follow the standard shoulder 

slopes as defined in the Plans Preparation Manual, Chapter 2 using the cross slope of the shape.  If the 

design intent of the shoulders should not follow the standard shoulder cross slope, the shoulder slope can be 

controlled using the adhocs Paved Shld Begin Slope and Paved Shld End Slope.  These adhocs, when set to 

a value other than 999, will override the standard.  They can also be used to taper the shoulder slope by 

setting the begin and end adhocs to different values.  The transition is calculated over the entire length of 

the paved shoulder line making the location and length of the element drawn important.  As an example, 

the paved shoulder may be constructed on a project that will later be widened.  The shoulder slope needs to 

match the cross slope of the roadway, including through superelevated sections.  The paved shoulder line 

can be drawn to match the transitions of the super elevation with the corresponding begin and end slopes 

defined on the adhocs.   

CURB & GUTTER 

Curb and gutter is drawn on the cross sections when the face of curb element is found in the design file.  

The D&C Manager item location is Roadway Design > Plan Features > Curb & Gutter, Curb, Gutter.  

The Criteria supports Type A, B, D, E, F, RA, Drop Curb, Valley Gutter and Shoulder Gutter.  It is 
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searched for from the edge of pavement or shoulder.  The exact location of the face of curb does not matter.  

It acts as a trigger for the Criteria.  If it is found within the search distance defined by the re-definable 

variable, _d_CurbSearchDistance, the curb will be drawn according to the specifications shown in the 

FDOT Design Standards.  When using shoulder gutter, make sure the curb search distance is not set to a 

value which will find the curb from the edge of pavement.  The curb will be drawn but not the paved 

shoulder.  In the case of a driveway, the Criteria will automatically draw the curb as drop curb, eliminating 

the need to break the lines in the design file.   

Valley gutter has adhocs to provide the designer the ability to control the gutter elevation through a profile.  

If a special gutter profile is required, set the profile name to the Profile Name adhoc.  The chain name is not 

required unless the profile stationing does NOT match the baseline stationing of the cross sections. 

 

BACK OF SIDEWALK 

The back of sidewalk line when drawn in the design file will trigger the Criteria to draw sidewalk.  The 

D&C Manager item location is Roadway Design > Plan Features > BSW.  The exact location is used by 

the Criteria.  In addition to the sidewalk, there are adhocs on the back of sidewalk line that will trigger 

other features to be drawn. 

 

The sidewalk attributes are defined by adhocs on the back of sidewalk line.  These adhocs will override the 

redefinable variables for the sidewalk.  The sidewalk thickness, cross slope, buffer width, buffer slope and 

utility slope can all be defined through the adhocs.  The back of sidewalk profile, if created, can also be set 

to the adhoc Sidewalk Back Profile to control the elevation at that back of sidewalk.  The adhoc Sidewalk 

PGL Chain is only required if the stationing of the back of sidewalk profile does NOT match the baseline 

stationing of the cross sections. 

An “Urban Ditch” is a ditch that is between the curb/shoulder and the sidewalk.  It can be triggered to be 

drawn using the adhoc Urban Ditch Y or N.  The adhocs with names that begin with „UD‟ control how the 

ditch is drawn.  Care should be taken with these values to insure the ditch will fit in the area before the 

sidewalk.  Special ditch profiles are not supported for the urban ditches. 
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Handrail may also be triggered using the adhoc Handrail Y or N.  When set to „Y‟ the Criteria will draw 

handrail at the back of sidewalk.  The sidewalk base is drawn according the FDOT Design Standards with 

the extra concrete under the handrail.  The type of handrail drawn is controlled through the adhoc Handrail 

Type P or B.  Set the adhoc to P to draw pedestrian handrail or B to draw bicycle handrail. 

FRONT OF SIDEWALK 

The front of sidewalk line is used to define the width of the sidewalk.  The D&C Manager item location is 

Roadway Design > Plan Features > FSW.  The exact location of this element is used by the Criteria.  If it 

is not located in the design file, the Criteria will try to tie the sidewalk to the back of curb. 

DRIVEWAYS 

Driveways will be drawn in the cross section when a driveway line is drawn into the design file.  The D&C 
Manager item location is Roadway Design > Plan Features > DWY.  This line is searched for from the 

edge of pavement.  It is only searched for once, therefore it is important that this line be located at the back 

of the driveway where it is to tie to existing ground.  If more than one driveway line is used to depict the 

driveway for the plans, make sure to turn off Place Influence in the D&C Manager for all lines except the 

back tie in line so that the Criteria will not find the additional lines in the file.   

Note The Remove Data tool can be used to remove the GEOPAK attribute tags from the undesired 
design elements.  It can be accessed through the FDOT Menu under Actions > GEOPAK VBA 

Utilities > Remove GEOPAK Atrributes and Adhocs. 
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The Criteria provides 3 “pads” that can be controlled through the attached adhocs to draw the driveway in 

the cross section.  Depending on the type of driveway, defined by the adhoc DrivewayOrigin, these pads 

will start at either the back of curb (DrivewayOrigin set to C for curb) or at the outside edge of the paved 

shoulder (DrivewayOrigin set to S for shoulder).  For pads 1 and 2, the depth, width, and slope values can 

be controlled by setting the appropriate value to the corresponding adhoc.  The back of each of these pads 

can also be controlled by a profile or offset.  In order to use the profile, the profile name needs to be set to 

the adhoc DWPad*Profile.  If the profile stationing does NOT match the baseline stationing, then the 

DWPad*PGLChain must be set to the appropriate chain name.  When using the PGL chain stationing, the 

adhoc Use PGL*Station must also be set to „Y‟. Setting the adhoc UsePGL*Offset to „Y‟ tells the Criteria 

to use the PGL chain to set the horizontal location for the back of the pad.  Pad 3 runs from the back of pad 

2 to the existing ground at the horizontal location defined by the driveway line found in the design file.  

The slope of this pad will vary.  The driveway can be made to tie to the existing ground before reaching the 

back of the driveway by setting the adhoc BackEntBufferWidth to a positive value.  This value is measured 

in feet.  The Criteria will finish the driveway from the start of the buffer to the back of the driveway by 

tracing the existing ground. 

When drawing the driveway, the Criteria will also draw what would be a normal section on a non-plotting 

level.  This is intended as an aid for designers.  If there is a ditch section, a pipe would need to be 

constructed under the driveway.  The additional drawing of a normal section helps the designer to locate 

the pipe as well as provide some guidance setting the flow line elevations. 

MISCELLANEOUS ASPHALT & GUARDRAIL 

Miscellaneous asphalt will be drawn on the cross sections outside the edge of pavement when found in the 

design file.  The D&C Manager item location is Roadway Design > Plan Features > MiscAsph. 

 

The adhoc thickness sets the depth of the miscellaneous asphalt drawn on the cross sections.  There are 2 

different applications for the miscellaneous asphalt.  In the first scenario, there is a separation between the 

roadway pavement and the miscellaneous pavement.  In this case, the adhoc Separation should be set to 

„Yes‟.  Two miscellaneous asphalt lines are required to define the area of the miscellaneous asphalt.  If the 

miscellaneous asphalt should be constructed from the edge of the roadway pavement without the a 

separation, the adhoc should be set to „No‟.  Only one miscellaneous asphalt line would be required at the 

outside edge of the miscellaneous asphalt area. 
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In many situations, guardrail is accompanied by the miscellaneous asphalt.  The two features do not have to 

both exist in order to be drawn.  The Criteria will draw whichever features that it finds in the design file, 

whether it is guardrail, or miscellaneous asphalt, or both.  The D&C Manager item location for the 

guardrail is Roadway Design > Plan Features > Guardrail > Guardrail.  All the guardrail types will be 

represented on the cross sections as a cell, either left, right, or double faced. 

Exercise 5.2 Shoulder Applications 

In this exercise, the students will modify the back of sidewalk line to add handrail and add guardrail with 

miscellaneous asphalt to the median.  

1. Open the MicroStation design file C:\e\projects\74185215201\roadway\DSGNRD01.dgn. 

2. Zoom in to right side of the roadway at the pattern line at station 1398+00. 

3. Using the MicroStation tool Break Element by Point, break the back of sidewalk line to create a 

separate back of sidewalk line matching the limits of the handrail. 

 

4. Open the Adhoc Attribute Manager.  It can be accessed through Applications > GEOPAK > ROAD 

> 3PC Adhoc Attribute Manager, through the Road toolbox, OR from the Road Project Manager 
Task List. 

5. Click on the Identify Element button and then select the 

back of sidewalk line crossing the pattern line with the 

handrail. 
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6. Modify the adhoc Handrail Y or N value to Y. 

 

7. Click on the Set Attributes button and then left click on the back of sidewalk line. 

 

8. Left click again to accept the selection. 

9. Zoom into the median area at station 1395+00. 

10. Open the D&C Manager and navigate to Roadway Design > Plan Features > Guardrail > 

Guardrail and select the item 0536  1  1 Roadway (Left). 
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11. With Place Influence turned on, copy the paved shoulder line into the median 3.0 feet. 

12. Navigate to Roadway Design > Plan Features > MiscAsph. 

13. Set the adhoc attributes as shown below. 

 

14. Copy the gurardrail line 3.0‟ to the left and 1.5‟ to the right of the guardrail. 

15. Turn off Place Influence. 

16. Open the cross section file, C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model RDXSRD. 

Note If the cross section run from Exercise 5.1 is still open, skip to step 18. 

16. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

17. Select the run PrFeat.  Click OK. 

18. Select all the elements in the file and delete. 

19. Select File > Save Settings and then File > Run. 

20. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below. 

 

21. The cross sections will run.  When done, click Exit. 

22. Using the Cross Section Navigator, review the sections. 

23. Close Cross Section Navigator. 
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SLOPES 

Slopes include all the areas outside the shoulders of the roadway.  Roadway features may include sloped 

area for clear zone, roadside ditches, berms, gravity walls, or a simple forced slope to the existing ground. 

EDGE OF FRONT SLOPE 1 

Front Slope 1 is a sloped area located between the shoulder and the roadside ditch.  The intent of this 

feature is to provide recoverable terrain, clear zone, for vehicles when they run off the road.  The slope and 

width of this area is defined in the Plans Preparation Manual, Chapter 2.  Front Slope 1 is controlled 

through redefinable variables, Plan Graphic Overrides and the EFS1 graphic element drawn into the design 

file.  The D&C Manager item location is Roadway Design > Plan Features > EFS1. When this line is 

found, the Front Slope 1 Width redefinable variable is ignored and the slope is drawn to the intersection of 

the element found in the design file.  

SPECIAL DITCHES 

There are times when a special ditch profile is developed for the roadside ditch in order to insure capacity 

for drainage.  One way to specify a special ditch profile is to assign them to the special ditch Define 

variables.  They may also be added to a Special Ditch line in the design file.  The D&C Manager item 

location is Roadway Design > Plan Features > SpDitch. 

 

The profile name for the special ditch is assigned to the adhoc Profile_Name.  If the stationing of the 

special ditch profile does NOT match the baseline stationing of the cross sections, then the adhoc 

Ditch_Chain needs to be assigned the correct chain name for the stationing of the profile.  This chain is 

used for stationing purposes only.  The Criteria will get the correct profile elevation and continue Front 

Slope 2 at the slope defined by the redefinable variable for Front Slope 2 until it reaches the proposed 

profile elevation.  If it is desired to have the element in the design file control the horizontal location of the 

bottom of Front Slope 2, then the adhoc Use_Plan_Graphic needs to set to „Yes‟.  Setting this to „Yes‟ will 

override the Front Slope 2 slope making it vary. 
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BERMS 

Berms are special features on the roadway that can only be triggered from a special Plan Graphic Override 

element drawn in the design file.  The D&C Manager item location is Roadway Design > Plan Features 

> Slopes Plan Graphic Overrides > Berm.  They are designed to drawn off the back slope of the roadside 

ditch and will draw another ditch behind the berm. 

 

 

The Criteria for the berm will extend the back slope for the roadway ditch using the value given for the 

adhoc Ditch Backslope Width.  Then it will draw the top of the berm using the Berm Width adhoc followed 

by another ditch before tying to existing ground.  The berm ditch is controlled through adhocs as shown in 

the picture above.  They work the same as the corresponding redefinable variables for the roadway ditch.  

The ditch backslope width can also be controlled through the use of a profile.  Set the name of the profile to 

the adhoc Top Berm Profile.  If the stationing of the berm profile does NOT match the baseline stationing, 

the adhoc Top Berm PGL Chain will need to be set with the appropriate chain.  The adhoc 

UseTopPGLStation must also be set „Y‟.  Setting the adhoc UseTopPGLOffset to „Y‟ will use the PGL 

chain defined by Top Berm PGL Chain to control the horizontal location to apply the profile.  This option 

will override the back slope value for the roadway ditch.  
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Similarly, the berm ditch bottom elevation can also be controlled through the use of a profile. Set the 

profile name to the adhoc Berm Ditch Profile.  If the stationing does NOT match the baseline stationing, 

use the adhoc Berm Ditch PGL Chain.  To use the stationing of this chain, set the adhoc 

UseDitchPGLStation to „Y‟.  Set the adhoc UseDitchPGLOffset to use the PGL chain to control the 

horizontal location for the profile elevation to be applied. 

If the berm ditch is not desired, the adhoc values for the ditch must be modified.  Set the Berm Front Slope 

1 Width value to 0.  Then modify the Berm Standard Ditch Depth to a very small value, i.e. 0.1.  In this 

way the berm ditch elevation will remain above ground.  When a ditch bottom elevation is above the 

existing ground elevation, the Criteria will extend the slope of Front Slope 2 until it ties to existing ground. 

Note In order for the berm to be drawn by the Criteria, a roadway ditch must be valid.  If the roadway ditch is 
above the existing ground elevation, a special ditch line must exist to provide a special ditch profile 
elevation for the roadway ditch to be drawn.  Otherwise, the Criteria will extend the front slope until it 
ties to existing ground eliminating both the roadway ditch and berm. 

PLAN GRAPHIC OVERRIDES 

Plan graphic overrides were added to the Criteria to give the designer more control, graphically, over how 

the roadside slopes of the cross sections are drawn.  The D&C Manager item location is Roadway Design 

> Plan Features > Slopes Plan Graphic Overrides.  These graphics act as triggers for the Criteria. They 

must be located in the area of the slopes beyond the shoulders (paved and unpaved) in order to be found by 

the Criteria. 

Each of the override lines has 2 functions.  The first function is to override the corresponding redefinable 

variable with a different value.  Some of these represent slopes, widths, or depths.  Others will trigger 

features on and/or off with their values.  The second function is to provide the option to taper the related 

feature across multiple cross sections.  Each of the elements has 2 adhocs defining the beginning and end 

value for the element.  The Criteria uses the length of the element and the distance along the element to the 

pattern line intersection to calculate the value for the given station.  See the graphic below for an example. 

 

Note Elements drawn should not start and/or stop at the exact intersection with the pattern lines.  This can 
cause incorrect results running the cross section Criteria.  Extend the elements a minimum of 2 times 
tolerance, 0.02, beyond the pattern lines. 

It is also important that the elements are NOT drawn outside the limits of the cross section baseline.  
The software uses the baseline stationing to reference the element and determine where the current 
station relates to the overall length of the element to calculate values for tapering. 
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Front Slope 1 Slope 

This element when found in the design file will override 

the redefinable variables _d_FrontSlope_1_Slope_Left 

or _d_FrontSlope_1_Slope_Right depending on the side 

slope in which it is drawn. 

 

 

 

Front Slope 1 Width 

This element when found in the design file will override 

the redefinable variables _d_FrontSlope_1_Width_Left 

or _d_FrontSlope_1_Width_Right depending on the side 

slope in which it is drawn. 

 

 

 

Front Slope 2 Slope 

This element when found in the design file will override 

the redefinable variables _d_FrontSlope_2_Slope_Left 

or _d_FrontSlope_2_Slope_Right depending on the side 

slope in which it is drawn. 

 

 

 

Ditch Width 

This element when found in the design file will override 

the redefinable variables _d_DitchWidth_Left or 

_d_DitchWidth_Right depending on the side slope in 

which it is drawn. 

 

 

 

Ditch Back Slope 

This element when found in the design file will override 

the redefinable variables _d_DitchBackSlope_Left or 

_d_DitchBackSlope_Right depending on the side slope 

in which it is drawn. 
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Ditch Depth 

This element when found in the design file will override the 

redefinable variables _d_StandardDitchDepth_Left or 

_d_StandardDitchDepth_Right depending on the side slope 

in which it is drawn. 

 

 

 

Forced Slope 

This element when found in the design file will override 

the re-definable variables _d_ForcedSlopeLeft 

and_d_ForcedSlopeLeftValue or _d_ForcedSlopeRight and 

_d_ForcedSlopeRightValue depending on the side slope in 

which it is drawn.  There is also an Adhoc named 

UseGraphic Y or N. This adhoc, when set to „Y‟, will 

override the slope values and draw the tie down to the 

horizontal location of the graphic element resulting in 

variable slopes. 

 

Feather Distance 

This element when found in the design file will override the 

redefinable variables _d_FeatherDistance_Outside_Left or 

_d_FeatherDistance_Outside_Left depending on the side 

slope in which it is drawn. 

 

 

MATCH LINES 

Match lines, when found in the design file, tell the Criteria to stop drawing and tie straight up or down to 

the existing ground.  The D&C Manager item location is Roadway Design > Plan Features > ML. 
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Exercise 5.3 Slopes Applications 

In this exercise, the students will add the graphic element into the DSGNRD file to control the location of 

the edge of front slope 1 and add the Plan Graphic Override line D1W to taper the right roadway ditch 

width. 

1. Open the MicroStation design file C:\e\projects\74185215201\roadway\DSGNRD01.dgn. 

2. Open the D&C Manager and navigate to the item Roadway Design > Plan Features > EFS1. 

 

3. On the EFS1 Edge of Front Slope 1 dialog, click on the check box to turn on Place Influence. 

4. Using the MicroStation Move/Copy Parallel command, copy the right outside Paved Shoulder line 

10‟ to the right from Station 1384+90 to Station 1390+10. 

5. Navigate to the item Roadway Design > Plan Features > Slopes Plan Graphic Overrides > D1W. 

6. Modify the adhocs as shown below. 

 

7. Place a line in the area of the ditch on the right side of the roadway from Station 1389+00 to 1391+00. 

Note Make sure to extend the line past the pattern lines.  A distance of 2 times tolerance, 0.02, is 
recommended. 

8. Turn off Place Influence. 

9. Open the cross section file, C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model RDXSRD. 

Note If the cross section run from Exercise 5.2 is still open, skip to step 12. 

10. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

11. Select the run PrFeat.  Click OK. 
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38. Select the Redefinable Variables category. 

12. Scroll down the list of variables and select _s_ForcedSlopeRight.  Click on the Edit button. 

13. Modify the value as shown below.  Click Save. 

 

14. Select all the elements in the file and delete. 

15. Select File > Save Settings and then select File > Run. 

16. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below. 

 

17. The cross sections will run.  When done, click Exit. 

18. Using the Cross Section Navigator, review the sections. 

19. Close Cross Section Navigator. 
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MEDIANS 
The median encompasses the area between shape clusters.  This includes the crossovers, traffic separators, 

ditches, and filled sections between curb and gutter.  The median is designated by the use of a Median line.  

MEDIAN LINE 

When found in the design file, the median line tells the Criteria that the neighboring shape clusters need to 

be connected.  The D&C Manager item location is Roadway Design > Plan Features > MedLn.  The 

median line MUST exist for ALL divided roadway sections.  The exact location of this line is not 

important.  It acts as a trigger for the Criteria to treat the side slope differently.  The element simply needs 

to be placed in the design file somewhere in the middle of the median beyond the work to be done on each 

side of the median. 

 

The adhoc Median_Type tells the Criteria how to draw the median.  There are 8 median types: 

 Type „0‟ Designates that NO work is to be done beyond the pavement.  This median line type 

can be used in the median or on the outside shoulders. 
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 Type „1‟ Designates a ditch with fixed slopes and a fixed depth is to be drawn in the median.  

The ditch bottom width will vary to fit the ditch within the limits of the median. 

 

 Type „2‟ Designates a ditch with fixed slopes and ditch width is to be drawn in the median.  The 

ditch depth will vary to fit the ditch within the limits of the median. 

 

 Type „3‟ Designates a ditch with fixed depth and width is to be drawn in the median.  The slopes 

will vary to fit the ditch within the limits of the median. 

 

 Type „4‟ Designates a “V” bottom ditch. 
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 Type „5‟ Designates a filled median with 4% slopes.  This median type is intended for use in 

urban sections with curb and gutter. 

 

 Type „6‟ Designates that a traffic separator (Type I or IV Option 1, or Type II or V) is to be 

drawn in the median.  These traffic separator options “cut” the pavement with no asphalt or base 

beneath them. 

 

 Type „7‟ Designates a cross over where the pavement is to be extended to meet in the middle.  

This median type is also to be used when a traffic separator Type I or IV Option 2 is to be drawn 

in the cross section.  This is so that the asphalt and base are carried under the traffic separator. 

 

If the section is rural with shoulders, paved and/or unpaved, the Criteria will use the shoulder adhocs to 

define the feature attributes such as the shoulder slope, width (both left and right independently) and the 

shoulder depth.  The shoulder depth will be overridden by the adhocs on the paved shoulder line. 

If the median type selected is one of the options for a ditch (Types 1 – 4), then the adhocs for the ditch 

variables will be used to define the slope, width, and ditch depth.  The option to control the median ditch 

depth with a profile is not supported.  The option to pave the ditch can be turned on with the adhoc 

PavedMedianDitch.  The options to set the paved ditch width and the depth of the concrete can be defined 

with the adhocs PavedMedianDitchWidth and PavedMedianDitchDepth respectively. 

The Criteria also has the option to tie to existing ground instead of drawing a ditch, similar to the outside 

roadway ditch.  By setting the adhocs FeatherDistMedianLeft and FeatherDistMedianRight, the Criteria 

will tie the section to existing ground from the outside edge of shoulder.  This will result in varying tie 

down slopes.  The Forced Slope option is not supported in the median. 
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TRAFFIC SEPARATORS 

Traffic separators will be drawn in the cross section when the Criteria encounters traffic separator lines in 

the design file.  The D&C Manager item location is Roadway Design > Plan Features > Concrete 

Traffic Separators.  The exact location of the traffic separator lines is reflected on the cross sections. 

 

The type of traffic separator to draw is conveyed to the Criteria by the D&C Manager item used to draw 

the traffic separator.  The option for the traffic separator, for types I and IV, are defined for the Criteria by 

the adhoc Option.  Option 1 traffic separators cut or break the pavement while Option 2 traffic separators 

are constructed on top of the pavement. (See Standard Index 302 for more details 

The type of traffic separator to be constructed will determine not only how the traffic separator is defined in 

plan view, but also the median line, since the traffic separator is considered a median feature The exact 

location of these elements is reflected in the cross sections. For Option 1 traffic separators, a median line 

needs to be drawn down the middle of the traffic separator (exact location is not important) with the 

Median_Type adhoc set to 6 for Traffic Separators. Turn lane superelevation shapes are not required, unless 

the cross slope of the turn lane is different from the main line shape cross slope, nor are additional proposed 

edge of pavement lines. The Criteria considers the traffic separator elements as proposed edges of 

pavement and will widen from a milling limit line or edge of pavement to the traffic separator line using the 

slope from the superelevation shapes or as defined by the milling widening adhocs. If widening is to be 

drawn and additional proposed edge of pavement lines are NOT drawn, the widening will be drawn using 

the values from the redefinable variables. 

 

If the traffic separator is a Type I or IV, Option 2, the traffic separator should be drawn into plan view 

using the appropriate D&C Manager item with the adhoc Option set to 2. The exact location is reflected in 

the cross section. A median line needs to be drawn anywhere in the turn lane area between the two shape 

clusters. The adhoc Median_Type should be set to 7 for a cross over to trigger the Criteria to draw the base 

and asphalt layers under the traffic separator. 
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For dual traffic separators, if Option 2 traffic separators are to be drawn, both traffic separators should be 

drawn in plan view and the type 7 median line drawn in the turn lane between the traffic separators. 

Nothing further is required. 

 

However, for dual Option 1 traffic separators, both traffic separators should be drawn with a type 6 median 

line drawn down the center of each traffic separator. In addition, since Option 1 traffic separators break the 

asphalt, a shape will be required in the turn lane area between the traffic separators, to define the elevation 

and cross slope of the pavement. These additional shapes are only required where the pattern line crosses 2 

Option 1 traffic separators.  
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Note Note, since these shapes do not touch any other shape, these shapes are considered a separate 
shape cluster and must have a different tie in order to differentiate from the other shape clusters. If the 
turn lane shape parameters match the mainline shape clusters, an error will occur when running the 
cross sections. 

 

 

Exercise 5.4 Median Applications 

In this exercise, the students will modify the median line in the urban section to a type 5 for the filled 

median at 4% slopes. 

1. Open the MicroStation design file C:\e\projects\74185215201\roadway\DSGNRD01.dgn. 

2. Open the Adhoc Attribute Manager. 

3. Zoom into the urban section of the project, from station 1398+00 to station 1403+00. 

4. Click on the Identify Element button and then select the median line. 
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5. Modify the adhoc Median_Type value to 5. 

 

6. Click on the Set Attributes button and then left click on the median line. 

 

7. Left click again to accept the selection. 

8. Open the cross section file, C:\e\projects\74185215201\roadway\RDXSRD01.dgn; model RDXSRD. 

Note If the cross section run from Exercise 5.3 is still open, skip to step 11. 

9. On the Road Project dialog, select Proposed Cross Sections.  The Run dialog will open. 

10. Select the run PrFeat.  Click OK. 

11. Select all the elements in the file and delete. 
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12. Select File > Save Settings and then select File > Run. 

13. On the Proposed Cross Section dialog, set the Output option To Log File and then click Apply as 

shown below. 

 

14. The cross sections will run.  When done, click Exit. 

15. Using the Cross Section Navigator, review the sections. 

16. Close Cross Section Navigator. 

Note By placing all of the desired median lines into a MicroStation selection set all of the elements can be 
set at one time. 

 

WALLS 
Various walls are supported by the Criteria.  These walls include the smaller retaining walls, median barrier 

walls, and gravity walls.  The large MSE walls are not supported by the Criteria. 

CONCRETE BARRIER WALLS 

The D&C Manager item location is Roadway Design > Plan Features > Concrete Barrier Wall.  All the 

walls under this category are supported except the Box Culverts.   
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Some of the concrete barrier walls include adhocs with additional information used to draw the wall.  The 

footer widths are intentionally set to a default of 0.  These widths should be determined by the 

designer/structures engineer. 

 

 

The Rigid – Shoulder wall has adhocs for the footer width and the wall type.  The available options are C, 

cantilever, and L, L wall. 

 

GRAVITY WALLS 

Gravity walls can be located in the D&C Manager under Roadway Design > Plan Features > Concrete 

Gravity Wall.   Note that the adhoc attributes set up for the gravity walls are for quantity purposes ONLY.  

The Criteria does not use these adhocs. 

Note Once a gravity wall is found and drawn in the cross section, the Criteria considers the section complete 
and will not look for a draw any other features beyond the gravity wall. 


	FDOT Cross Section Criteria V8i_CoverPages
	STATE OF FLORIDA
	DEPARTMENT OF TRANSPORTATION
	FDOT CROSS SECTIONS
	Course Guide
	ENGINEERING / CADD SYSTEMS OFFICE
	FDOT CROSS SECTIONS
	ENGINEERING / CADD SYSTEMS OFFICE
	FDOT CROSS SECTIONS
	CE-11-0134
	Description
	Topics Covered
	Duration:  16 Hours
	Professional Credit Hours:  16 PDHs
	Copyright © 2011 by Florida Department of Transportation

	FDOT Cross Section Criteria V8i_Publish2.pdf
	1 INTRODUCTION
	Objectives
	FDOT Criteria
	Warnings / Helpful Hints
	Pre-requisites
	Additional Information
	Document Style

	2 EXISTING FEATURES
	Objectives
	Existing Features
	Redefinable Variables
	Exercise 2.1 Existing Features Criteria with Redefinable Variables

	GKLNRD File
	Exercise 2.2 Using the GKLNRD file
	Exercise 2.3 Existing Features


	3 PROPOSED FEATURES
	Objectives
	Proposed Features
	Exercise 3.1 Identify the Roadway Features
	Exercise 3.2 Proposed Cross Sections “Out of the Box”

	Controlling Proposed Cross Section Features

	4 REDEFINABLE VARIABLES
	Objectives
	Propose Features Redefinable Variables
	Modifying Redefinable Variables
	Exercise 4.1 Modifying Redefinable Variables
	Exercise 4.2 Right of Way Applications


	5 PLAN GRAPHICS
	Objectives
	Plan Graphic Elements Overview
	Pavement Graphics (Travel Lanes)
	Milling and Resurfacing
	Proposed Edge of Pavement (New Construction & Widening)
	Side Road Tie Downs
	Exercise 5.1 Pavement Applications


	Shoulders
	Paved Shoulders
	Curb & Gutter
	Back of Sidewalk
	Front of Sidewalk
	Driveways
	Miscellaneous Asphalt & Guardrail
	Exercise 5.2 Shoulder Applications


	Slopes
	Edge of Front Slope 1
	Special Ditches
	Berms
	Plan Graphic Overrides
	Match Lines
	Exercise 5.3 Slopes Applications


	Medians
	Median Line
	Traffic Separators
	Exercise 1.1
	Exercise 1.1
	Exercise 5.4 Median Applications


	Walls
	Concrete Barrier Walls
	Gravity Walls




