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FDOT CORRIDOR MODELING 
CE-11-0135 

Description 

This course is an introduction to GEOPAK Road Corridor Modeling and builds on the 
basic and advanced Florida Department of Transportation (FDOT) GEOPAK for 
Roadway Designers course skills by teaching users Corridor Modeling features and 
working with FDOT components and templates. 

Topics Covered  

This course includes, but is not limited to the following:  

         FDOT Template Library overview          End Condition exceptions
         Point Name and Component Name Conventions          Superelevation Proposed Cross Section
         Point Constraints          Cross Section Labeling
         Template creation and editing tools          Earthwork
         Roadway Designer          Cross Section Reports
         Station Ranges          Cross Section Sheets
         Parametric Value Settings          Displaying Surface Model
         Alignment and Point Controls on Templates          Drive Thru.

Prerequisites   

To get the most from this course the user should have a basic understanding of Computer 
Aided Design and Drafting (CADD) using MicroStation, a basic understanding of 
GEOPAK concepts and a solid understanding of the engineering necessary to design a 
roadway.  

This course does not teach CAD drafting or engineering design. GEOPAK is simply a 
tool to facilitate the engineering design process.  The following courses and some manual 
drafting or related CADD product experience is recommended: 

 MicroStation 

o FDOT MicroStation Essentials Part I  CE-11-0114 
o FDOT MicroStation Essentials Part II  CE-11-0115 

 GEOPAK 

o FDOT Basic GEOPAK for Roadway Designers  CE-11-0099 
o FDOT Advanced for GEOPAK Roadway Designers CE-11-0101 

 Engineering /  Design 

o Solid understanding of road design process 

 Review Topics 

o DTM Tools 
o Draw Profile Tool 
o Proposed Profile and Active chain control Profiles 
o Drawing and Computation (D&C) Manager 

Duration:  24 Hours    

Professional Credit Hours:  24 PDHs 
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All rights reserved.  For information about this and other CADD training courses, publications, videos, and Frequently Asked 
Questions, visit the Engineering/CADD Systems Office of the Florida Department of Transportation on the world-wide web at 
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1 INTRODUCTION  

This course was developed to introduce GEOPAK and MicroStation users to the V8i SELECTseries2 

Corridor Modeling tools for design and development on Florida Department of Transportation (FDOT) 
projects.  The curriculum  includes the following: software overview, general workflow, FDOT Template 

Library overview, Create Template dialog, Point Name and Component Name Conventions, Point 

Constraints, Roadway Designer dialog, Station Ranges, Parametric Value Settings, Alignment and Point 

Controls on Templates, End Condition exceptions, Superelevation design commands, Overlay/Stripping 

components, Proposed Cross Sections, Cross Section Labeling, three dimensional (3D) Corridor design 

models, and Drive Roadway commands.  

COURSE OBJECTIVES 
Students will expand their knowledge of basic and advanced GEOPAK skills by introducing them to 

GEOPAK Road, Corridor Modeling.  At successful completion they will have learned how … 

 

 To use the Corridor Modeling tools to design a roadway utilizing the FDOT delivered Template 

Library of standard components and templates 

 To incorporate 2 dimensional (2D) design graphics in Corridor Modeling by importing the 

elements for use as design model control lines 

 To apply varying typical section conditions along the project, including;  

o  variable medians,  

o special ditches,  

o handrail checks,  

o gravity wall placement,  

o slope conditions,  

o left and right turns, etc.  

 To apply the Superelevation wizard along a corridor.  

 To provide ‘real-time” cross section view updates, and design checks along the project before 

cross sections are created in MicroStation.  

 To create and display 3D models for better designing and visualization 

 To use the milling overbuild and overlay components on a project corridor.  

 To apply vertical adjustments along existing alignments on resurfacing projects. Including vertical 

alignment generator based on user defined overbuild, milling and overlay, standards. 

 Corridor Modeling techniques are used for developing driveways and intersection, etc.  

This course has 24 Professional Development Hours (PDHs) associated with it. 

EXPECTATIONS 

WHAT THIS COURSE PROVIDES 

This course provides an introduction to template and component creation, template constraints, applying 

template on corridors and several point controls methods. This course provides a standard workflow for 

designing a project with the Corridor Modeling tools. 

This course does not provide a description of every GEOPAK command. However, the online GEOPAK 

command reference help is referenced throughout the document.  Instruction for advanced template design 

and constraints are not specifically covered.  However, the more advanced design exercises in chapters 6-

11 provide ample instructions to advanced template techniques. 
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DOCUMENT STYLE  
Style conventions used throughout the course guide are shown in the following table. 

Item Convention Example 
Menu names 
and 
commands 

Bold, names 
separated with 
> symbol 

 File > Open 

 File > Compress > Design 

dialog box 
actions 

Bold 

 
 Click the Apply button. 

 Click the Graphic Select button to the right of the 
Horizontal Alignment Include box. 

 In the Segment Type list, click Lines. 

dialog box 
field names 

Italic 
 Key in Hemfield Road in the Alignment Name field. 

 Click the Graphic Select button to the right of the 
Horizontal Alignment Include field. 

 In the Segment Type list, click Lines. 

Key-ins Bold 
 Key in Hemfield Road in the Alignment Name field. 

File names Italic 
 Open the file Working Graphics.dgn in the  

 C:\Bentley Training\GEOPAK 101\Project 
Setup\Practice\ folder. 

File paths Non italic 

 
 Open the file Working Graphics.dgn in the 

 C:\Bentley Training\GEOPAK 101\Project 
Setup\Practice\ folder. 

New terms or 
emphasis 

Italic 

 
 The Template Library contains templates, which 

represent typical sections of the proposed roadway. 
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FILE TYPES 
The GEOPAK road design process uses several different file types. All GEOPAK data is stored in external 

files. The CAD file is used to view a graphical representation of the design data, but the graphic files do not 

store the GEOPAK data. Deleting the CAD graphics does not affect the GEOPAK data. For example, if 

the graphics that represent existing ground surface contours are deleted, the GEOPAK existing ground 

surface file is not modified. 

Below is a brief description of the major file types used in GEOPAK. 

File Type   Description 

Project Manager .prj A binary file created to store project information when a 
new project is created. 

Surface .tin A binary file, also known as a digital terrain model (DTM), 
that stores features made up of random points, breaklines, 
and boundary data along with triangulated surface model. 
The features and the triangles together represent an 
existing ground surface. 

Surface DAT .dat A binary (or ASCII) file containing string and point 
information, that is used for digital terrain model 
construction. 

Geometry Project  .gpk A binary file (job###.gpk) created when starting a 
coordinate geometry (COGO) session for the first time or 
created through Project Manager, that stores geometric 
data including points, lines, curves, spirals, parcels, chains, 
and profiles. The file may be appended to during the design 
process. Multiple users can access this file at the same time.  
Only one file should be created for each project. The "###" 
is the only variable in this filename. It represents a job 
number (1 to 3 alphanumeric characters) unique to a project 
and is user defined upon creation. 

Template Library  .itl Stores templates and template components. Different 
components can be assembled to build templates, which 
define the typical sections of a roadway. Only one Template 
Library file may be open for editing at a given time. 

Roadway 
Designer 

.ird Stores information defining the parameters of a roadway 
design. These roadway design parameters are defined using 
a tool called the Roadway Designer. The Roadway 

Designer is used for corridor management, assigning 
template drops, creating Superelevation, reviewing the 
design, defining template transitioning, and creating design 
surfaces. Only one Roadway Design file may be open for 
editing at a given time. 

Corridor Modeling .rdp Stores the Roadway Design Preferences from the settings in 
the main Corridor Modeling dialog. 

Corridor Modeling 
Surface  

.dtm Store the digital terrain model (DTM) made up of random 
points, breaklines, boundary and subsurface features along 
with triangulated surface model. 
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ADDITIONAL INFORMATION 
The FDOT CADD Software Suite provides help files to explain how the GEOPAK Corridor Modeling 

tools can be used in conjunction with the FDOT workspace. 

Webinar training recordings are available on many of the subjects covered in this manual on the 

Engineering\CADD Systems Office (ECSO) website at: 

 http://www.dot.state.fl.us/ecso/downloads/clips/default.shtm 

COURSE SUPPORTING FILES 
The exercises for each module are independent of one another and can be used without having to complete 

the exercises in previous modules. Most exercises use Project Manager. When the project file is loaded, 

all other supporting files such as surfaces, geometry databases, etc. are loaded. All files used in this course 

are located in the C:\FDOT Training Material\FDOT Corridor Modeling\ folder. The exercise files are 

organized into separate compressed zip files for each module.. 

  

http://www.dot.state.fl.us/ecso/downloads/clips/default.shtm
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2 OVERVIEW  

WORKFLOW 
Before the Corridor Modeling tools can be discuss in any great detail, it is best to understand how they fit 

in the overall GEOPAK Road Project Manager workflow. The diagram below gives a general idea of where 

Corridor Modeling fits.  The workflow outlined in green shaded area is basically replicated with the 

Corridor Modeling application.  Corridor Modeling is not intended to replace the entire process, only 

provide another alternative set of tools to design the proposed roadway.  The Corridor Modeling diagram 

outlined below the Traditional Project Manager diagram shows the various dialogs and processes within the 

application environment.  All of the processes are covered in detail within the various chapter exercises to 

follow. Corridor Modeling files and results will directly integrate with all the other outside processes 

shown in the Project Manager diagram and vice versa. 
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ACCESSING CORRIDOR MODELING 
The Corridor Modeling tools delivered with GEOPAK are located under the MicroStation menu option:  

Applications > GEOPAK > ROAD > Corridor Modeling.  <OR>  

Access Corridor Modeling by clicking the Corridor Modeling icon on the GEOPAK ROAD tools pallet. 

 

 

The Corridor Modeling dialog is the interface environment for several functions.  

a) Project Identifier 

b) Tree View Setting Window 

c) Menu Options 

d) Tool Buttons  

When the Corridor Modeling dialog is loaded for the first time, a sub folder named rddbs is created within 

the active project directory structure. This folder contains files that will be used by Roadway Designer. 
This sub folder should NOT be deleted. The rddbs folder is created in the working directory of the active 

DGN file. Three files are located in this folder: 

 cmjob791.alg - created and re-created every time geometry or plan graphics are imported 

 cmjob791.xml - created when geometry from the .gpk is imported from to the Corridor Modeling 

dialog 

 plangraphics.txt - created when exiting Corridor Modeling dialog after plan graphics have been 

imported. 
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PROJECT IDENTIFIER 
The Project Identifier selects the GEOPAK coordinate geometry Job file by entering a Job number or 

clicking the magnifying glass to access available (.gpk) files. 

 

TREE VIEW SETTING WINDOW  
These options are where the Project specific settings are defined and Project information can be imported. 

The dialog will change based on the selected option in the tree list to reveal parameters and preferences to 

be defined for the project and saved. The preferences and imported information can then be saved in a 

preference (.rdp) file and recalled for future use. 

PREFERENCES 

 Station Lock - Applicable only when the first station specified on the horizontal alignment is an 

odd-numbered station (for example, 2+38). When Increment is selected, and the first station is 

odd-numbered, the software performs the command action at odd-numbered stations only (for 

example, 2+38, 2+88, 3+38). When Even is selected, the software performs the command action 

to the first station and then forces all subsequent actions to even-numbered stations. For example, 

if the first station is 2+38 and the station interval is defined as 50, the software performs the 

command action at stations 2+38, 2+50, 3+00, etc. 

 Slope Readout - Designates a particular format for expressing slope from the Slope combo box. 

 Horizontal/Vertical Chord Height - Process of automatically adding shots to the DTM input (.dat) 

file by interpolating new shots from the linear and curved sections of the data. 

 Template Library - Specifies the .itl file for the project. Select a file or use one of the 

automatically selected files. This field is populated by the configuration variable 

(GPK_RD_Template_Library), if set. If it is not set, this field is populated by the ./bin/default.itl. 

 DTM files Path: - Specifies the save location for surfaces, .dtm files, created and imported for the 

project. This field is populated by selecting the magnifier and choosing the directory path for the 

preference variable.   Note: Roadway designer may not work properly if this is not set to the 

project roadway folder.  
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DTM 

Imports selected DTM or TIN file(s). If you import a TIN file, it is converted to a .dtm file. Used to select 

and import the existing surface(s) (DTM/TIN) and/or other target surfaces. 

   

GEOMETRY 

The Geometry imports various types of Geometry data (Chains, Profiles, etc.) from the selected .gpk file 

and generates an .alg file based on the information you provide. 

When you select a row in the list box and click Import, the geometry is updated in the .alg file with the 

selected Chain, Profile, and Drafting Standard information. The .alg file is put in the rddbs sub-directory.  

If a list box entry is red, that indicates the entry has been deleted since the last update. 

If a list box entry is blue, that indicates the entry has been changed since the last update.  
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PLAN GRAPHICS 

The Plan Graphics option on the Corridor Modeling dialog is used to store plan view graphical elements in 

the Roadway Designer alignment file (.alg). Roadway Designer does not work with plan view graphics 

directly The elements must be imported as alignments in the Roadway Designer alignment file (.alg). The 

alignments can then be used by Roadway Designer to handle pavement transitions, widening, etc. 

DIALOG OPTIONS 

 Search Criteria - There are three options to choose from that can be selected to search for plan 

graphics. 

o Symbology – by MicroStation Level, color, style, weight, etc.. 

o Feature – by Design & Computation Manager feature. 

o Selection Set – MicroStation Selection Set. 

 Chain - An existing chain stored in the Coordinate Geometry file (.gpk) that will be used to search 

for the plan graphics that will be stored as alignments in the Roadway Designer alignment file 

(.alg). 

 Side - Select either “L” or “R” to instruct the software as to which side of the selected chain you 

would like to use in the search. 

 Begin and End Offsets - A search distance from the selected chain used to search for plan 

elements. 

 Display - Once the search criteria has been specified and added to the collection box, this option is 

used to display the plan elements that will be stored. 

 New Chain Name - Specifies the new chain name to be stored in the Roadway Designer 
alignment file (.alg). (NOTE: these chains are NOT converted/stored in the (.gpk))  

 Drafting Standard - Symbology that will be assigned to the new chain. 

 Import - Stores the new chain or any added graphical elements into the Roadway Designer 
alignment file (.alg) and makes Roadway Designer aware of the new chain/ element(s). 

 Add Search Criteria to List - Adds specified search criteria to the collection box. 

 Modify Search Criteria of Selected Row - Modifies the selected row of search criteria in the 

collection box. 

 Delete Search Criteria of Selected Row - Deletes the selected row of search criteria in the 

collection box. 

Note The Drafting Standards labeled “XS_*” should not be used when importing Plan Graphics 
from the design file and to display imported Alignments from the .alg file. 
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ALG VIEWER 

Used to display, un-display and delete the imported geometry and plan graphics alignments.  

 

 

MENU BAR  

 

FILE MENU 

 Load, Save, Save As or Exit - After the Corridor Modeling dialog is populated according to the 

specific project information and the information is imported, it is recommended to save the 

Corridor Modeling preferences to the active design file working directory.  The file will be saved 

with a (.rdp) extension.  

 

TOOLS MENU 

 Export Profile to GPK - Opens the Export Profile to GPK dialog, which allows the designer to 

save/export vertical adjustment profiles created from the OverLay Tools in Roadway Designer 
out of an ALG file to a gpk file. 

 Draw Roadway from Template - Opens the Create 2D Graphics dialog, which allows the 

designer to create 2D graphics from a specified template in a Template Library file. 
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COMMAND REFERENCE & HELP 

All of the Dialog Parameter fields are described in the Help files. To view this information, select 

Applications > GEOPAK > ROAD > Help and then select the Command Reference folder and then 
Corridor Modeling. The F1 keyboard button does not work for the Help files in GEOPAK Corridor 
Modeling. 

 

 

<OR> Access help from the FDOT Menu Option: Roadway > FDOT Corridor Modeling Help files. 
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TOOL BUTTONS  

  

 

OPEN CREATE TEMPLATE:   

Open Create Template opens the Create Template dialog.  After the specific project information has been 

imported, a model of the proposed roadway design is generated by assembling project 

components/templates and applying them to a corridor using the Roadway Designer.  

Components, Templates and End Conditions are created, edited and stored in the Template Library File 

which has an *.itl extension. 

The Standard Road or Project Specific Template Library can be shared, however, the Template Library is 

recommended to be read-only when shared.  It’s recommended to create a project specific Template 

Library by copying the Standard Road Template Library to the project directory symb folder which allows 

the designer to modify the Template Library to meet the specific needs of the project. 

Templates can be copied from a Standard Template Library to a Project Specific Template Library using 

Tools > Template Library Organizer in the Create Template Tool. 

OPEN ROADWAY DESIGNER:   

Open Roadway Designer opens the Roadway Designer dialog.  Templates are designed and subsequently 

utilized to create a proposed model of the roadway. This is accomplished using the Roadway Designer 
tool. In the Roadway Designer, templates are assigned to specific station ranges along a selected corridor.  

The Roadway Designer, via the Edit Transition tool, connects the points of the template drops, forming a 

model of the roadway, which is made into a surface model. The connected template points form 

longitudinal break line features in the surface model. 

The Roadway Designer is where Superelevation is created and/or applied to the design.  The Roadway 
Designer tool requires the following preferences be set up prior to accessing the tool: 

GPK file select (job number) 

DDB  

DTM  

Geometry 

Plan Graphics 

The Roadway Designer data is saved in the Roadway Design file which has an (.ird) extension. 

The Roadway Designer tool has three window viewing areas. They represent the plan, profile, and cross 

section views of the design. 

DRIVE ROADWAY:   

Drive Roadway opens the Drive Roadway dialog. The Drive Roadway tool allows the designer to view the 

path a driver would take along a roadway. It also generates a 3D line string along the path which might be 

used to control camera position along the roadway. 
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DRAW CROSS SECTION FROM SURFACES:   

Draw Cross Section from Surfaces opens the Draw Cross Sections dialog.  Designers will recognize this 

as the tool used for cutting existing ground cross sections from a TIN file.  The Draw Cross Sections from 

Surfaces tool is used to draw both the existing ground surface and proposed Roadway surfaces on the cross 

sections. 

Support for a DTM created by Roadway Designer is a new feature of the tool. All template components 

are included in the proposed cross sections created from a Roadway Designer DTM. 

 

CROSS SECTION LABELING:   

Cross Section Labeling opens the Cross Section Labeler dialog.  The Cross Section Labeler tool is 

provided for batch labeling the different components of the cross sections in a corridor set.  The Cross 

Section Labeler has several label types that can be saved in a label preference file .xlp.  Labels can be 

defined for Slopes, Elev/Off, Station, Text Notes or a Dimension or text between two points. Each of the 

labels can have customized attributes styles which can also be saved in an xml file.  
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3 NEW CORRIDOR MODELING 
PROJECTS 

This chapter provides the user with an introduction and exercises on the Corridor Modeling dialog. When 

starting a new project in Corridor Modeling, there are a few simple procedures to do first in order to get 

your Corridor Modeling design going.  

LOADING ACTIVE GEOPAK PROJECT FILES 
The Roadway Designer part of Corridor Modeling uses GEOPAK chains to define the direction and 

path of the roadway. These chains or alignments will need to be established in a GEOPAK project before a 

Corridor Modeling design can begin. The (.gpk) file(s) can then be associated and saved with the Corridor 
Modeling project.  

Note There are NO alignment tools, either horizontal, or vertical in the Corridor Modeling 
dialogs. 

PROJECT PREFERENCE SETTINGS 
Corridor Modeling is a front end dialog that will allow the user to set up project specific preferences. 

Symbology features, geometry information, and the existing surface will also be imported from the tool that 

Roadway Designer will utilize when creating a roadway design model. The preferences and imported 

information can then be saved in a preference (.rdp) file. 

The preferences are project specific dialog settings that can be stored with a Corridor Modeling project. 

These settings are stored in a (.rdp) file for the Corridor Modeling project at the working directory.   

 Station Lock - Applicable only when the first station specified on the horizontal alignment is an 

odd-numbered station (for example, 2+38). When Increment is selected, and the first station is 

odd-numbered, the software performs the command action at odd-numbered stations only (for 

example, 2+38, 2+88, 3+38). When Even is selected, the software performs the command action 

to the first station and then forces all subsequent actions to even-numbered stations. For example, 

if the first station is 2+38 and the station interval is defined as 50, the software performs the 

command action at stations 2+38, 2+50, 3+00, etc. 

 Slope Readout - Designates a particular format for expressing slope from the Slope combo box. 

 Horizontal/Vertical Chord Height - Process of automatically adding shots to the DTM input (.dat) 

file by interpolating new shots from the linear and curved sections of the data. 

 Template Library - Specifies the .itl file for the project. You can select a file or use one of the 

automatically selected files. This field is populated by the configuration variable 

(GPK_RD_Template_Library) if set. If it is not set, this field is populated by the ./bin/default.itl. 
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There are detailed descriptions for each of the fields represented in the GEOPAK Corridor Modeling 

Command References. 

 

 

Note Also, from FDOTSS2 Menu select Roadway then FDOTSS2 Corridor 
Modeling Help Files to get further information links on project preferences for 
Corridor Modeling. 

 

EXISTING TIN MODELS 
In a Corridor Modeling project, the design model is generated and tied to the existing ground.  The 

existing ground needs to be represented in a digital terrain model format.  The Corridor Modeling dialog 

will allow for both file formats: GEOPAK TIN or DTM. The Corridor Modeling dialog also allows 

multiple TIN/DTM files to be associated with a project and saved in the (.rdp).  This would be useful if a 

project survey was stored in several different files.  

GEOMETRY  
Imports various types of geometry data from the selected .gpk file and generates an .alg file based on the 

information you provide.  When you select a row in the list box and click Import, the geometry is updated 

in the .alg file with the selected Chain, Profile, and Drafting Standard information.  The .alg file is put in 

the rddbs sub-directory.  

 If a list box entry is red, that indicates the entry has been deleted since the last update. 

 If a list box entry is blue, that indicates the entry has been changed since the last update. 
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EXERCISE OVERVIEW 
3.1 Load Active GEOPAK Project .prj &.gpk Files  

3.2 Change the Project Preference Settings  

3.3  Import an Existing TIN Model 

3.4 Add / Import GEOPAK Chains to Alignments 

Note For Importing MicroStation Elements See Chapter 4, Importing Plan Graphics to 
Alignments 

Exercise 3.1 Load Active GEOPAK Project .prj & .gpk files. 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The design file has the proposed design drawn in 

MicroStation for the project according to FDOT Engineering CADD standards.  Other project reference 

files are attached to the file and not displayed for the existing topo, utilities and right of way.   

Before beginning this Chapters exercises remove or rename the c:\e\projects\22807915201 folder if it 

exists, and then extract the 22807915201(3).zip file to C:\e\projects.  

1. Open the FDOT folder on the desktop and click on the FDOT icon.  

2. Select the DSGNRD01.dgn file in the c:\e\projects\22807915201\roadway\ folder in the FDOTSS2 

workspace in MicroStation. 

3. From the MicroStation pull down menu select Applications > GEOPAK > Activate GEOPAK 

 

4. Open up GEOPAK Project Manager from the MicroStation menu option:  

Applications > GEOPAK > Road > Project Manager to insure the project .prj and .gpk files are 

loaded and active.  
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5. Collapse the Road Project dialog 

6. From the GEOPAK Road Tools toolbox, open the Corridor Modeling dialog. 

 

7. From Corridor Modeling, click the Magnifier icon next to the Job: field, confirm the Project 

Identifier  job791.gpk file is selected and click OK. 

 

8. Select File > Save As to create a new project Corridor Modeling Preference file, SR817.rdp. 
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Exercise 3.2 Change the Project Preference Settings 

The next step when starting a new Corridor Modeling project is to set the Project preferences and save 

them off to a file for future loading. In this exercise, the Corridor Modeling Preferences are set for the 

Station Lock, Slope Readout, Horizontal and Vertical Chord Heights.  Once a new preference file is saved, 

the setting can be loaded together for future session from the File > Load menu option on the Corridor 
Modeling dialog. 

1. From Corridor Modeling, select the Preferences item in the tree view list.  

2. Set the Station Lock, Slope Readout, Horizontal, Chord Height, and Vertical Cord Height as shown 

below: 

 

3. For help on these parameters preference settings see the Corridor Modeling Help files by selecting 

from the MicroStation menu option Applications > GEOPAK > ROAD > Help and then 

navigating to the folder Road > Command Reference > Corridor Modeling. 

   

4. Read each of the Command References in the online help to answer the following questions: 

a. In the Section Horizontal Chord Height, what does the parameter affect? 

b. In the Section Vertical Chord Height, what does the parameter affect? 

c. In the DDB Section, where is the FDOTSS2 xin file?  Note that the DDB item is not present 

in the tree view list.   

d. In the ALG Viewer, what types of elements are used to display alignments? 

5. Close the online help.  
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6. Set the DTM Files Path as shown below. 

 

7. From the Corridor Modeling menu, select File > Save to save the project Preference file. Click OK 

on the Information dialog.  

 

Exercise 3.3 Import an Existing TIN Model 

In this exercise the existing digital terrain model for the project is identified and then imported into the 

Corridor Modeling environment. The DTM can be in either TIN or DTM format, however if TIN it is 

converted to a DTM file. The existing project TIN file is used by Corridor Modeling as the base surface or 

target to tie the new project model. The name and location of this file is saved with preference file  

1. From Corridor Modeling, select the category DTM in the tree listing (a) to set the existing TIN 

model.  

2. Click the Magnifier icon  next to the TIN field, navigate to the project roadway folder. 

3. Select the site.tin file for the project and then click Open.  

4. Click the Add Tin icon  to list and display the path in the TIN/DTM files list.  

5. Highlight the added site.tin file and click the Import button to import the file. Click OK on the 

Information Alert dialog.  
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6. Select File > Save the project Corridor Modeling preference file, SR817.rdp  

Note The Corridor Modeling dialog should remain open until finished with the design 
session. It will be accessed periodically by future commands in other steps. If it is 
inadvertently closed, it will take a several seconds to close and then the following Alert 
dialog will appear.  If the preferences have already been saved, Click No to close the 
session.    

 

Note Closing the Corridor Modeling dialog will also close the Create Template dialog, if 
it is open, without prompting to save the changes to the Template library.  However, the 
Roadway Designer dialog will remain open, if the Corridor Modeling dialog is 
closed.  

Exercise 3.4 Add / Import GEOPAK Chains to Alignments 

In this exercise, several Coordinate Geometry chains and profiles from the project (.gpk) file are identified 

and imported to create an alignment file.  This (.alg) file is created and put in the (rddbs) folder of the 

project roadway sub-folder.  The alignments are the longitudinal features the templates follow in the 

Roadway Designer.  The Corridor Modeling application is a legacy Inroads application that ran on (.alg) 

alignment files for horizontal and vertical control; thus the need to convert or import the (.gpk) chains and 

profiles to (.alg) format. 

1. Open Corridor Modeling, if closed, and select the Geometry category in the tree view list.  

2. Set Chain: by selecting BL817 from the drop down list. 

3. Set Profile(s) by selecting EXGROUND from the list window.  

4. Set Drafting Standard: by selecting Centerline – CL Existing from the dropdown list. 

5. Click the Add icon . Alignment will appear in the display window.  

6. Repeat the procedure for the PGL-LT and PGL-RT.  

CHAIN PROFILE DRAFTING STANDARD 

BL817 EXGROUND Centerline – CL Existing 

PGL-LT PGL-LT Baseline Station TIC Large 

PGL-RT PGL-RT Baseline Station TIC Large 
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7. The results should match the image below. 

 

8. Click the Import button to import the geometry from the .gpk file to the .alg file. The following 

Information box will display to confirm import. 

 

Note: Once the alignments have been associated with the Corridor Modeling project, there is a smart 

update feature that runs with the Corridor Modeling application that creates notification when changes 

have been made to the GEOPAK project file.  When such alignment changes have been identified, 

they simply need to be re-imported to have an effect on the Corridor Modeling design.  

9. From the Corridor Modeling menu, select File > Save to save the project preference file. 
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4 IMPORTING PLAN GRAPHICS TO 
ALIGNMENTS 

PLAN GRAPHICS 
The Plan Graphics option on the Corridor Modeling dialog is used to store plan view graphical elements in 

the Roadway Designer alignment file (.alg). Roadway Designer does not work directly with plan view 

graphics like criteria elements.  First these elements must be stored as alignments in the Roadway 
Designer alignment file (.alg). The alignments can then be used by Roadway Designer to handle 

pavement transitions, widening, etc.  If the elements in the design file change, an Information dialog 

appears and the elements should be imported again.  

DIALOG OPTIONS 

 

 Search Criteria - There are three options to select from that can be selected to search for plan 

graphics. 

o Symbology -  Searches for the Plan Graphic by Level, color, style, weight, etc. of the plan 

graphics. 

o Feature - Searches for the Plan Graphic using Design & Computation Manager feature. 

o Selection Set – Uses a  MicroStation Selection Set to set the Plan Graphic. 

 Chain - An existing chain stored in the Coordinate Geometry file (.gpk) that will be used to search 

for the plan graphics that will be stored as alignments in the Roadway Designer alignment file 

(.alg). 

 New Chain Name - Specifies the new chain (alignment) name to be stored in the Roadway 
Designer alignment file (.alg). 
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 Drafting Standard - Symbology that will be assigned to the new chain (alignment) when 

displayed with the ALS Viewer. These have been imported from the DDB to match FDOT CADD 

Standards. 

 Display - Once the search criteria has been specified and added to the list box, this option is used 

to highlight the plan elements that will be stored. 

 Side - Select either “L” or “R” to instruct the software as to which side of the selected chain you 

would like to use in the search. 

 Begin / End Offsets - A search distance from the selected chain used to search for plan elements. 

 Filter Tolerances – Both horizontal and variance filter tolerances are considered together for each 

pair of graphical segments. The middle point is deleted if both segment lengths are less than the 

horizontal filter tolerance while the projected distance between the mid-point and the chord 

between the two end points is less than the variance tolerance. A value of 0 for both tolerances 

disables them. 

 Import – Stores the new chain or any added graphical elements into the Roadway Designer 
alignment file (.alg) and makes Roadway Designer aware of the new chain/ element(s). 

  Add Search Criteria to List - Adds the specified search criteria to the collection box. 

  Modify Search Criteria of Selected Row - Modifies the selected row of search criteria in 

the collection box. 

  Delete Search Criteria of Selected Row - Deletes the selected row of search criteria in the 

collection box. 

 

EXERCISE OVERVIEW 
4.1 Add / Import Plan Graphics to Alignments  

4.2 ALG Viewer  

4.3 Understanding Smart Update  

Exercise 4.1 Add / Import Plan Graphics to Alignments 

In this exercise 2D MicroStation elements drawn for the proposed roadway design will be selected and 

imported to create alignments. These alignments are imported from graphics and stored in the (.alg) file 

along with the imported Coordinate Geometry. The alignments are used for style constraints defined in 

the FDOT templates. Roadway Designer will follow the 2D proposed design (i.e. EOP, edge of 

pavement) to handle pavement transitions, adding lanes, traffic separator display, wall display, etc. and 

much more.  

1. Optional, extract the 22807915201(4).zip file in the c:\e\projects directory. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22807915201\roadway\ folder in the FDOTSS2 

workspace in MicroStation.  

3. From the GEOPAK Road Tools toolbox, open the Corridor Modeling dialog, select the GPK job 

number 791.  
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4. Select File > Load to load the project file SR817.rdp.  

 

The search criteria for the Import Alignment command works off of a defined chain as stored in the 

COGO database.  It has the ability to find graphical alignment features in the design file. However, this 

command can only be defined left or right from the defined chain.  Therefore, it is necessary to create 

an offset chain to the defined centerline out a distance beyond the right or left side and search for 

elements twice the distance in the other direction. For example, create an offset chain 500 feet right 

and define the offset search 1000 feet left.   

 

5. From the Road Project dialog, select Coordinate Geometry to create an offset alignment. 

 

Note If necessary, Delete the Import Alignment and elements from GPK file, #500, 501 & 502 
Points and #500 & 501 Curves. 
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6. From the Coordinate Geometry menu, select Element > Chain > Store > Offset Chain. 

  

7. Using the settings shown below, store an offset chain, IMPORT, 500 feet right from the baseline of 

survey. 

 .  

8. Select Store Chain button and then close the Store Offset Chain Dialog. Close the Coordinate 
Geometry dialog. Select No to save an input file.  

9. From the Corridor Modeling dialog, select Geometry, and then Add and Import the offset chain 

utilizing the Baseline – Station TIC Large drafting standard. 

 

10. Select File > Save to save the project preferences. 
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11. Select Plan Graphics to switch the dialog for importing of the necessary alignments for the Corridor 
Modeling project. Begin by adding the edge of pavement graphics. First set the Search Criteria to 

Symbology.  

 

Note There are 3 ways to import graphics in the Corridor Modeling dialog: by Symbology, 
by Feature and by Selection Set.  The method described in the exercise is by 
Symbology.  The symbology search window starts from a chain offset 500 feet right of 
centerline, “Import” chain and ends left 1000 feet of the “Import” chain. This method will 
find all features Bylevel one direction from a defined chain.  

12. Click the  icon to the right of the Symbology option to open the Element Symbology 
dialog. Check the Lv Names box, and uncheck each of the others.  

Note If necessary, hit the reset button to clear all of the fields and start over.  

 

13. From Element Symbology, select Match and follow the MicroStation prompts at the bottom left 

corner to Identify an EOP element, click again to Accept/Reject the element. The Lv Name EOP 

should appear in the dialog.  
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14. Close Element Symbology by clicking on the X in the upper right corner. Move your cursor over 

the  icon to verify the search symbology setting.  

 

15. From Corridor Modeling, complete the dialog entry by following these steps: 

a. Select the offset Chain: IMPORT from the available chains in the dropdown list.   

b. Key-in a New Chain Name, EOP.   

c. Define the appropriate Drafting Standard from the list, Pavement- Proposed. 

d. Set the Begin Offset: to 0 and End Offset: to 1000. 

e. Set the Side option Side L from the list. 

f. Set the Filter Tolerances for the Horizontal and Variances to 10 and .1 respectfully. 

g. Click the Add Search Criteria to the List icon  to enter the settings into the dialog 
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16. Repeat Steps 11-16 to include each of the following plan features: 

Lv Name Chain New Chain Name Drafting Standard 

SidewalkBack IMPORT SWB Sidewalk -Back Proposed 

SidewalkFront IMPORT SWF Sidewalk -Front Proposed 

CurbBack IMPORT CURBBACK Curb - Back Proposed 

EOP IMPORT EOP Pavement Proposed 

TrafSeparator IMPORT TS Traffic Separator Proposed 

 

17. See Note below to continue… 

*RWLine_ep IMPORT ROW_EX ROW Existing 

 

Note *The Existing Right of Way (ROW) lines are stored in the reference file RWDTRD01.dgn 
file in the project rwmap folder.  The reference file should be “activated” prior to selecting 
the element with the Match button on the Element Symbology dialog. Continue with the 
following steps.  

18. Hold a right click over a Right of Way line and click Activate. This will make the Reference file the 

active file.  Or from the References dialog, right click on the RWDTRD01 file and click Activate. 
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19. Click on the Match button and add the RWLine_ep to the search criteria list.  

 

*RWLine_ep IMPORT ROW_EX ROW Existing 

20. Click the Add Search Criteria to the List icon  to enter the settings into the dialog. When finished 

right click again in the design file and click Deactivate Default to return to the original file.  

 

21. The new chains can be imported all at once or one at a time.  From Corridor Modeling, select the 

chain(s) to be imported by simply checking the box in the Store column under the Search Criteria 

display, and then click the Import button.  When you have succeeded, an Information window will 

display to confirm action. Click OK. 
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Note It is likely that an Information dialog similar to the one below will display, indicating 
drafting problems with the MicroStation elements.  

 

Note If this dialog appears, click OK and a list of drafting problems will appear. These must be 
resolved with MicroStation edit element commands in order to store the alignments in 
the Corridor Modeling project. 

 

22. Select on each row and the error location will be centered to the view.  Use MicroStation to resolve 

each of the list items and click the Import button again. 

23. Select File >Save to save the Corridor Modeling project imported Plan Graphics. 

Exercise 4.2 ALG Viewer 

In this exercise using the Corridor Modeling dialog, the alignments created with Import Geometry and 

Import Plan Graphics exercise will be displayed in a new design file model. First a new model will be 

created from MicroStation.  This exercise will help provide a basic understanding of the ALG Viewer 
dialog option and the alignment database that Corridor Modeling uses in the Create Template and 

Roadway Designer dialogs. 

1. From the MicroStation menu, select File > Models. The Models dialog displays.   

 

2. Select the Create a new model icon.  The Create Model dialog displays.  
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3. Select Type: Design from Seed. Leave Seed Model: fdotseed2d.dgn, Default.  Key-in the Name:  

ALG Viewer.  Uncheck the Cell Properties:  Can be placed as a cell.  Check the Create a View 

Group box.  Click OK. 

   

4. The Active View Group display in the lower left corner of the MicroStation dialog should change to 

the ALG Viewer View Group. Also, there should be an empty view. Close the Models dialog.  

5. On the Corridor Modeling dialog, change the focus on the tree view to ALG Viewer.  Select all of the 

entries and click the Display Selected Rows icon .   

 

6. Click the Fit View icon on the MicroStation window.  

7. In the Display column of each row a check symbol should have appeared. Uncheck each of the rows 

to un-display each of the alignments. <OR> Use selection sets and choose the Un-display Selected 

Rows icon . 

Note The delete selected rows  icon will remove the imported alignments from the ALG 
file. This is NOT required for this exercise.  
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Exercise 4.3 Understanding Smart Update 

In this exercise MicroStation elements are modified to indicate a change to the previously imported 2D 

design elements. This will make the ALG file out of sync with the elements. When you re-enter the 

Corridor Modeling environment, an Information dialog will display. This dialog is referred to as a Smart 

Update and the graphics or geometry should be re-imported. 

1. Continue working in the DSGNRD01.dgn file.  Change the view group back to the Default Views 

group. Change the viewing area to the portion of the BL817 between Stations 76 and 78.  

2. Select the MicroStation command Modify Element. 

3. Move the line EOP elements that intersect in the driveway. 

 

4. Close Corridor Modeling. Click No to save settings.  

5. Reopen the Corridor Modeling dialog.  The following Information dialog displays. Click OK. 

 

Note This is referred to as the Smart Update feature in Corridor Modeling.  It is an alert to the 
user that the Geometry file or the MicroStation graphics have changed.  

6. Select the Plan Graphics option on the tree view of the Corridor Modeling dialog. The EOP row in 

the import list is now the color blue.  
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7. Slide the row display to the right to view the Store column and check only the box for the EOP on 

the import list. Click the Import button to re-import the plan graphics.  

 

8. An Information dialog should display. Click OK. 

 

9. Select File Save to save the SR817.rdp file.  
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5 CREATING NEW PROJECT 
TEMPLATES 

TEMPLATES BASICS  

 Templates are typical sections of the proposed roadway 

 Templates are stored in the Template Library File (.itl) 

After the proposed project plans have been created, a 3D model of the proposed roadway design is 

generated by assembling project plan graphics to cross sections along the proposed centerline of the 

alignment.  Templates are the cross section views that are used to create the proposed 3D model.  

Individual templates are created and stored in the Template Library file, which has the file extension.itl.  

The Template Library can be shared by many people needing the template standards, but the Template 

Library must be read-only when it is being shared. Usually a project specific Template Library is created 

for each project and the appropriate templates are copied to that library so they can be modified to meet the 

specific needs of the project. 

PROJECT TEMPLATE LIBRARIES 
The first time a project is started in Corridor Modeling, a new project Template Library should be created.  

This (.itl) file will contain the templates used for the design of the corridor. These templates can be created, 

customized and saved specific to the project.  This procedure provides a measure of Quality 

Assurance/Quality Control (QA/QC) on a project if the project (.itl) is managed properly. To begin with, 

the FDOT workspace is delivered with a plethora of standard components and templates which can be used 

to start off a project (i.e. FDOTSS2.itl). In the future, it may be deemed prudent to start with templates 

from previous projects. This can also be accommodated provided standard naming conventions and 

procedures are followed and documented when creating the templates.  

APPLYING TEMPLATES 

 Templates create a model of the proposed roadway 

 Accomplished using the Roadway Designer 

 Template points generate longitudinal break line features in the model 

Templates are used to create a proposed model of the roadway. This is accomplished using the Roadway 
Designer tool. In the Roadway Designer, templates are assigned to specific stations along the mainline 

alignment at a specific interval, which are called template drops.  

The Roadway Designer connects the points of the template drops, forming a model of the roadway, 

which is made into a surface model. The connected template points form longitudinal break line features in 

the surface model. 
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TEMPLATES – SURFACE MODELS 

 Top template points create a triangulated surface.  

 Points below the surface are “Exclude from Triangulation” points. 

 All Subsurface Points lower than the triangulated surface are “Exclude from Triangulation” 

points in the proposed surface. The sub-surfaces will appear, if desired, in the proposed cross 

sections as “components.” Components are used to generate the sub-surface line work on the 

GEOPAK cross sections, allowing proposed earthworks to be processed.  

If required for a specialized workflow, individual template layers (including sub-surfaces) can be 

triangulated. This process is not a common workflow and is not discussed in this course. 

CREATE TEMPLATE DIALOG 
The Create Template dialog is accessed from the Corridor Modeling dialog. To create or edit a Template 

Library, click the Open Create Template icon on the Corridor Modeling dialog. This opens the Create 
Template dialog.  

  

The Create Template dialog is the primary place where templates are created and edited. This is also 

where templates are copied from a standard Template Library to a project Template Library using Tools > 

Template Library Organizer. 
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TEMPLATE LIBRARY 

 User Definable Folder Structure 

 Create Templates, Components and End Conditions 

 Right-click Functions 

 Copy and Paste, and Drag and Drop 

 Red-colored Box Indicates Current Template 

 Drag and Drop Components to Current Template Window 

On the left side of the dialog, you will find the Template Library area, which contains a Windows-like 

folder structure. The root folder is the name and location of the Template Library that is currently open. 

Only one Template Library may be open at a time. 

To navigate the folder structure, double-click the folders you want to open or close. Inside any folder you 

can create and organize your templates and subfolders. The organization of the folder structure is user 

definable. The folder structure also supports common Windows functions, such as drag and drop, cut and 

paste, etc. 

Most commonly-used commands can be accessed by right clicking on the folders and templates. If you 

double click a template, it becomes the Current Template and is signified by a red box around the Template 

icon. The Current Template is also identified in the Current Template area next to the Template Library 

area. To assemble or edit a template, it must be the Current Template. 

CURRENT TEMPLATE WINDOW 

 Templates Assembled and Edited 

 Right-click To Create Components 

 Double-click To Edit Points and Components 

 View Commands Bottom of Window 

In the center of the Create Template dialog is the main graph for creating templates. The graph is called 

the Current Template window. The Current Template window uses its own graphics engine and is not a 

MicroStation View. 

The scale of the graph is dynamic and changes as you zoom in and out. The center point of the Current 

Template window is marked by the dynamic origin, which is a magenta-colored box. The dynamic origin is 

used as a reference point and can be moved to any location in the graph. 

At the bottom of the graph there are numerous view commands, which are similar to MicroStation View 

commands. There are two buttons that look like the MicroStation View Previous and View Next 

commands, however, they are used to undo and redo template creation operations. If your mouse has a 

scroll wheel, it can be used to pan and zoom. The CTRL-Z keyboard hotkey will undo your last edit or 

creation. 

In the graph area you can right-click to access commands and you can double-click elements in the graph 

for editing purposes. 
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TEMPLATE PREVIEW WINDOW 

 Previews Templates and Components 

 Works on Non-current Templates 

 Placement Point Location Denoted by a Cyan-colored Box 

 Click Point to Move Placement Point Location 

 Drag and Drop from Preview Area to Current Template Window 

Under the Template Library area is the Preview area. When you highlight (single click) a template, the 

template is displayed in the Preview area. 

You can use the Preview to assemble templates from their parts or components. This is accomplished using 

drag and drop functions. 

The cyan-colored box in the Preview represents the insertion point for any drag and drop operation. You 

can change the insertion point location by clicking the desired insertion point on the preview. 

DYNAMIC SETTINGS 

 Tools > Dynamic Settings Command 

 Precision Input Template Points 

 XY= Absolute Coordinates 

 HS= Horizontal Delta Distance and Slope from Last Point Placed 

 DL= Key-in Delta Coordinates from Last Point Placed 

The Dynamic Settings dialog is used for precision input of the template components and to assign point 

names and styles when creating components. 

It also serves as a compass for the location of your cursor with respect to the dynamic origin. The dynamic 

origin can be moved using Set Dynamic Origin, located at the bottom of the Dynamic Settings dialog. 

The Dynamic Settings dialog is accessed by selecting the menu option Tools > Dynamic Settings or using 

the View Control icons located below the Current Template window. 

The Key-in pull-down specifies the type of key-in to be performed. 

XY = key-in absolute coordinates 

DL = key-in delta coordinates from last point placed (defaults to the dynamic origin if it 

is the first point of a component) 

HS = key-in horizontal delta distance and slope from last point placed 

VS = key-in vertical delta distance and slope from last point placed 

OL = key-in delta coordinates from dynamic origin 

OS = key-in horizontal delta distance and slope from dynamic origin 
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COMPONENTS 

 Components are Parts of the Template 

 Curb and Gutter, Median Barrier, Pavement Layers, Cut and Fill, etc. 

 Simply Drag and Drop Components Together to Create a Complete Template 

 When Two Points Coincide, Heavy White Plus Sign Appears 

 Existing Connection Point Name Override Dropped Point Name 

Components are logical parts of a template. Portions of the template that are separated into components are 

normally based on tabulation considerations. Examples of components include curb and gutter, median 

barrier, pavement layers, cut and fill slopes, and ditches. 

Components are normally kept in a separate folder in the Template Library and are used to assemble 

complete templates. Drag and drop the components to the Current Template window to create a complete 

template. When connecting two components, the connecting point will change to a white colored plus sign 

prior to placing the component. This is the indication that the points coincide. When the components are 

connected together, using drag and drop from the Template Library folders, any coincident component 

points will use the point names of the previously placed component. Template point names can be edited 

anytime during the creation process. 

Components are normally created with point names that are not specific to being on the left or right side of 

the roadway. When they are used to create completed templates, prefixes and suffixes to the template 

points can be automatically added during component placement. Prefixes and suffixes are controlled using 

Tools > Options in the Create Template dialog and can be set and cleared in the Dynamic Settings 
dialog during placement using the Apply Affixes check box. 

MERGING COMPONENTS 

 Right-click between the components to merge 

 Select the Merge Components command 

When combining two components of a pavement section together, two separate components are produced 

with a vertical segment dividing them. To remove the vertical segment, position the cursor over the vertical 

segment and right-click. Then select Merge Components. 

BASIC TEMPLATE CREATION WORKFLOW 
1. Open Template - Open an existing Template Library by specifying the Template Library in the Create 

Roadway preferences. 

2. Create New Template  - Click the Open Create Template icon. This brings up the Create Template 

dialog. 

3. “Drag and Drop” Template Components - Navigate to the appropriate folder where the components are 

stored in the Template Library folder structure and drag and drop the components to the Current Template 

window. 

4. Name New Template - Navigate to the appropriate folder in the Template Library folder structure and 

select File > New > Template. Name the new template. 

5. Merge Components - If necessary, right-click on the vertical segment between two components and click 

Merge Components. 

6. Verify Point Names - Set the Display Point Names radio button in the Display area of the Create 
Template dialog. Review the point names. Editing the point names, if needed, by double-clicking on the 

points in the Current Template window. 

7. Save the Template Library 
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EXERCISE OVERVIEW 
5.1 Creating a New Project Template Library  

5.2 Creating Project Folders in Template Library 

5.3 Using the Template Library Organizer  

5.4 Naming Project Templates 

5.5 Creating A Basic Template 

Exercise 5.1 Creating a New Project Template Library 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the 

project. The Corridor Modeling dialog is loaded and the project preferences are loaded from the previous 

exercises. The Create Template dialog is opened and a new Template Library file will be created for the 

project. The new Template Library for the project will be created in the project symb folder. This new 

project Template Library will be the container for all the components and templates used to develop the 

corridor design models for the project design. Once the new project Template Library is created, the 

Corridor Modeling Preferences will be updated and saved in the Roadway Designer preference file 

(.rdp). 

1. Optional, extract the 22807915201(5).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22807915201\roadway\ folder in the FDOTSS2 

workspace in MicroStation. 

3. Open up GEOPAK Project Manager to ensure the project .prj and .gpk files are loaded and active.  

 

4. From the GEOPAK Road Tools toolbox, click the Corridor Modeling icon. 
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5. From the Corridor Modeling dialog, select File > Load, select SR817.rdp from the project 

preferences list and click Open. 

6. Click the Magnifier icon  next to the Job: field box and make sure the active job791gpk is 

located correctly.  

 

7. Click the Open Create Template icon to create a new project Template Library. 

  

8. From the Create Template dialog, select File > New > Template Library. Navigate to the project 
symb folder, C:\e\projects\2280795201\symb\. 

9. Key-in the new template library name, SR817. Select Save.  

  

10. Close the Create Template dialog. 



Chapter 5 ____________________________ CREATING NEW PROJECT TEMPLATES - Creating a New Project Template Library 

5-8 ©2014 FDOT  FDOT Corridor Modeling 

11. From the Corridor Modeling dialog, set the new project Template Library under the category 

Preferences in the tree listing.  

  

12. Click the Magnifier icon  next to the Template Library field, navigate to the project symb folder 

C:\e\projects\2280795201\symb\, select the newly created SR817.itl file for the project, and then click 

Open.  

 

13. From Corridor Modeling, select File > Save the project Corridor Modeling preference file, 

SR817.rdp. Select Yes to replace the file or OK to dismiss the Information dialog. 
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Exercise 5.2 Creating Project Folders in the Template Library 

In this exercise 2 new folders will be created within the Template Library. One is for project template 

components and one is for full templates. The project components folder will contain parts of the full 

template and will be obtained from the FDOTSS2 Template Library. The project templates folder will 

contain the constructed templates for the corridor. The project templates in the exercises to follow will be 

named and saved in stages or phases in order to track the progress of the design. This method is also 

recommended to provide a backup and/or history for potential trouble shooting along the way. 

1. Click the Open Create Template icon to open the Create Template dialog. 

 

2. From the Create Template menu, select File > New > Folder to create a new folder in the project 

Template Library. Rename the folder SR817 Templates. Click on the root folder and repeat steps to 

create folder named SR817 Components. 

 

 

3. Select File > Save to save the project Template Library .itl file. To verify: look at the prompt location 

in the lower left corner of the Create Template dialog.  
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Exercise 5.3 Using the Template Library Organizer 

In this exercise the Create Template dialog is used to open the Template Library Organizer from the 

Tools menu option. The Template Library Organizer is used to obtain various components and templates 

from other Template Libraries and Roadway Designer files.  For the exercises to follow, the FDOTSS2 

Template Library contains a basic Typical Section and all of the components that will be used for the 

project design. 

1. Select Tools > Template Library Organizer.  

 

2. From the Template Library Organizer dialog, click the Ellipses icon next to the OK button. The 

Open Template Library window displays. 

  

3. From Open Template Library, navigate to the CM WORKSHOP folder and select the 

FDOTCM_TRAINING.itl Template Library file. 

  

Note Templates can be obtained from Roadway Designer files also. For example, if an old 
project would be a good start for the current project or if a change was made to a 
template in Roadway Designer and should be saved to the current project library. 

4. Set the Files of type list to Template Libraries (*.itl), select the FDOTCM_TRAINING.itl file and 

then click Open. The Template Library Organizer dialog will display with the .itl file listed in the 

right Available In: window. 
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5. From the Template Library Organizer, navigate to the FDOT folder Typical 

Sections\Proposed\Urban/SubUrban\4 Lane Divided Arterial(45 MPH or Less)\ to find the 

standard Typical Section for the project. Select the PPM EXHIBIT TYP-5 to preview the template 

in the Preview window below the directory view.  

 

6. Drag and drop templates and components from the right side to the left side ONTO THE SR817 

Components folder for the project.  

7. Collect the following items from the FDOTSS2 Template Library and drag them to the SR817 

Components folder. 

FDOTSS2 Folder Item Name 

Component\Pavement\Travel Lanes 12’ Travel Lane Right 

Component \Pavement\Travel Lanes\Base Base 12’, 2% Right 

Component \Pavement\Travel Lanes\Base Extension Pavement Base Extension Outside Right 

Component\Shoulder\Outside\Paved 5’Paved Shoulder 

Component\Shoulder\Outside\Base Shoulder Base Outside 6% 

Component\Shoulder\Outside\Paved Unpaved Shoulder 

Components\Barriers & Retaining Walls Gravity Wall 

Component\Shoulder\Outside\Paved 5’Paved Shoulder 

End condition\Cut & Fill FDOT Standard Cut & Fill 

End condition\Cut & Fill\Parts 6:1 FILL to 5’ 

End condition\Cut & Fill\Parts 6:1 CUT’ 
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8. Click OK to return to the Create Template dialog and click Yes to the “Save data to file…”. The 

FDOT Standard Items are now saved in the project Template Library.  

 

Exercise 5.4 Naming Project Templates 

In this exercise using the Create Template dialog the Typical Section obtained from the FDOTSS2 

Template Library is copied and renamed in the project Template Library template folder. The Create 
Template dialog has functionality similar to Window Explorer to help manage templates for each project.  

A consistent project template naming convention will be valuable as the template design progresses in the 

exercises and on a project.  For the exercises to follow as the template changes it will be copied and 

renamed adding an “_1, _2, _3,…” to keep previous template versions saved in the project Template 

Library. 

1. In the SR817 Components folder, Right click on the EXHIBIT TYP - 5 template, and click Copy.  

 

2. Right click on the SR817 Templates folder and click Paste.   

3. Right click on the copied EXHIBIT TYP – 5 template and click Rename. Change the name of the 

template to SR817.  

4.  Right click on the SR817 template and click Set Active. A small red box will indicate the active 

template. 

 

5. Select File > Save to save the project Template Library.  
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Exercise 5.5 Creating a Basic Template  

In this exercise using the Create Template dialog a Basic Template will be created within the project 

Template Library.   This exercise will help provide a basic understanding of the basic template creation 

methods from the FDOTSS2 library components types, connection points, constraints, targets, etc. 

1. Right click on the SR817 Templates folder and select New Template.  

 

2.  Right click on the New Template1 and select Rename. Change the name to Basic Template, press 

enter to store the name 

3. Right click again on the Basic Template and click Set Active 

  

4. Before adding components, open a preference file that will add a prefix to the point names. Select the 

Tools > Options from the Create Template menu to launch the Template Options dialog.   
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5. Click the Preferences button and then select the FDOT list item. Click Load and Close the 

Preferences dialog. Click OK to close the Template Options dialog.  

 

6.  Select the Tools > Dynamic Settings from the Create Template menu. This provides a toolbox like 

dialog for placing components.  

 

Note The X and Y Step value 0.1000 functions similar to a grid lock in MicroStation when 
placing the components  

7. Drag the 12’ Travel Lane component to the small magenta square in large view. 
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8. Drag and drop the Base 12’, 2% component and connect it to the bottom side of the pavement 

component in the template. The cursor will turn white when it is lock on the location.  

 

9. Add the shoulder components, 5’Paved Shoulder, Shoulder Base and Pavement Base Extension.   
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10. Add the 6:1 Cutand  6:1 FILL to 5 Components’.  Uncheck the Display Point Names Option and 

select the Fit View Icon.  

 

11. Click Edit Undo several times back to the start of the exercise (i.e.  a blank template).  

Note Use the icons at the bottom of the view:   

12. Repeat the steps with the Mirror option checked when dragging components. Right Click while 

dragging to get the dialog.  

 

13. The completed template should look similar to the image below.  

 

Note To change the default properties of the delivered components use the Point Properties 
Dialog 
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14. To Change the pavement width to 11 feet, double click on the right top edge of pavement and the 

Point Properties dialog will display. Change the Constraint 1 Horizontal Value to 11.0.  

Note Use the Tab Key to enter data, NOT the Enter key  

  

15. Click Apply to see the new changes to the Basic Template. Close the Point Properties dialog. 

16. Repeat this procedure to change the roadway pavement width on the left side.  

17. Save the Template Library, select File > Save from the Create Template drop down menus.  

18. Close the Create Template dialog. 
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6 FDOT STANDARD LIBRARY 
COMPONENTS 

APPLYING FDOT STANDARD LIBRARY COMPONENTS  

 Roadway Designer Basics 

 Switches, Display Rules 

 Parametric Constraint Values  

 Assigning Style Constraint and Ranges to Points 

 Assigning Point Controls to Alignments, (i.e.  PGL, Special Ditch Profiles, etc.) 

 End Conditions 

ROADWAY DESIGNER BASICS  
After the templates are created, they are applied using the Roadway Designer. The Roadway Designer 
combines alignments, surfaces, and templates to create a model of the proposed roadway. It is also where 

Superelevation is created and applied to the design. 

The Roadway Designer tool is accessed from the Corridor Modeling dialog.  

 

Roadway Designer requires certain preferences be set up prior to accessing the tool. These preferences 

(DDB, Plan Graphics, and Geometry, DTM) are stored in the .rdp file. (Roadway Designer Preferences). 

This file will be stored in the working directory and should not be deleted. To load the preference file select 

File > Load from the pull down menu on the Corridor Modeler dialog then select the appropriate preference 

file. 

The data you input into Roadway Designer is saved in the Roadway Design file, which has the extension 

.ird. 

ROADWAY DESIGNER DIALOG 

The Roadway Designer dialog has three different window viewing areas in Normal Mode. They represent 

the plan, profile, and cross section views of the design. 

These views use their own graphics engine, like the Create Template dialog, and are not MicroStation 

views. The views show only what is related to the design, not what is displayed in the MicroStation design 

file. The content of each window is controlled by the active Corridor selection and Active Surface settings. 
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The Roadway Designer dialog is resizable. Each window in the Roadway Designer can be resized. 

 

PLAN VIEW WINDOW 

 Shows template locations 

 Shows Corridor’s centerline alignment, cut-fill lines, and original ground surface perimeter 

 Shows civil design data, not CAD graphics 

 Links to data 

 Shows station position 

 Mouse over tips 

 View controls 

The Plan View window is located in the upper left corner of the Roadway Designer dialog. Although it 

looks like a MicroStation view, it does not display the graphics in the MicroStation design file. Not 

having the MicroStation graphics displayed allows you to focus on the design data only. 

The location of the templates is displayed with respect to the corridor alignment and original ground 

surface, which are shown as short brown lines. The Plan window is linked to the other windows in 

Roadway Designer via station positioning of the design. The station position is shown as the longer 

yellow line.  

Other graphics in this window include the corridor centerline, original ground surface perimeter, and cut-

fill lines. Other graphic indicators appear in the window. Mouse-over tips are available and view controls 

are located on the bottom of all of the Roadway Designer’s view windows. 
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PROFILE VIEW WINDOW 

 Shows original surface and Corridor’s vertical alignment 

 Shows civil design data, not CAD graphics 

 Links to data 

 Mouse over tips 

 Shows station position 

 Dynamic scale 

The Profile View window is located in the lower left hand corner of the Roadway Designer dialog. It 

does not show MicroStation graphics. 

It displays the Original ground surface line and the corridor’s vertical alignment. It is also linked to the 

station position of the design and that location is shown as a heavy vertical yellow line.  The scale of the 

Profile View window is dynamic based on the zoom controls. 

CROSS SECTION VIEW WINDOW 

 Shows original ground surface and proposed design 

 Shows civil design data, not CAD graphics 

 Right-click functions 

 Mouse over tips 

 Links to data 

 Dynamic Scale 

The Cross Section View window is located on the right side of the Roadway Designer dialog. It does not 

show MicroStation graphics.  It displays the Active Surface line, (typically, existing ground) and the 

templates as they are applied to the design. This window will be a primary area for reviewing the design. 

Additional display settings can be applied by right-clicking on the window. The scale of the Cross Section 

View window is dynamic based on the zoom controls. Located directly below the Cross Section view 

window is an area that displays the current station being displayed and several buttons that allow you to 

step through the design, based on stationing. 

ROADWAY DESIGNER FUNDAMENTALS 

 Corridor Management command specifies horizontal and vertical alignments 

 Template Drops command specifies template location and Template 0,0 point tracks on the 

Corridor’s horizontal and vertical alignment 

 Create Surface command creates a DTM of the proposed roadway design model and surface 

contains template components 

CORRIDOR MANAGEMENT COMMAND 

A Corridor is a design section of roadway defined by the station limits of the mainline horizontal and 

vertical alignment. A corridor is created by using Corridor > Corridor Management. 

To create a Corridor, name the Corridor, select a horizontal and vertical alignment and optionally set the 

station limits of the project. A single roadway design file (.ird) can store all the corridors of a project. The 

.ird file is single user access only. 

The next step is to assign templates to the corridor. This is accomplished using Corridor > Template 

Drops. 
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TEMPLATE DROP COMMAND 

Template Drops are used to assign previously created templates to specific stations in the corridor. The   

XY = 0,0 point on the template tracks on the corridor’s horizontal and vertical alignment to form the 

proposed roadway. 

To create template drops, select the appropriate template from the Template Library, the station where the 

template is applied, and the modeling interval. The final result is a station and template list. 

CREATE SURFACE COMMAND 

Create Surface combines the corridor and template drops data to create a surface model of the proposed 

roadway design. This creates a surface consisting of the top surface of the roadway design and the sub-

grade components, which are ‘Exclude from Triangulation’ points and children of the top surface. 

Components can be displayed in cross sections and used for volume calculations. 

BASIC ROADWAY DESIGNER WORKFLOW 
1. Open Geometry, original ground DTM, and preferences 

2. Select Roadway Designer 

3. Load Template Library 

4. Create new roadway design 

5. Create new corridor 

6. Assign template drops 

7. Create surfaces 

8. Save roadway design results 

EXERCISE OVERVIEW 
6.1 Roadway Designer Basics  

 Manage Corridors 

 Template Drops  

 Tools Options 

 Component Quantities 

 Create Surface 

6.2 Switches, Display Rules  

6.3 Parametric Constraint Values  

6.4 Assign Style Constraints & Ranges to Points 

6.5 End Conditions 

6.6 PGL Handles and Test Point Controls in Create Template 

6.7 Assign Point Controls to Alignments  
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Exercise 6.1 Roadway Designer Basics 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the 

project. The Corridor Modeling dialog is loaded and the project preferences are loaded from the previous 

exercises. The following Roadway Designer tasks will be completed: 

 A new corridor for the project is created using the Manage Corridors dialog.   

 The Template Drops dialog is used to select a Template for the Corridor.   

 Roadway Designer options dialog is used to set display options, report options and critical 

stations to included or exclude for processing.  

 The Component Quantities dialog is opened to view corridor estimates on cost and materials. 

 The Create Surface dialog is opened to create a proposed DTM and 3D MicroStation mesh model. 

 Manage Corridors 

1. Optional, extract the 22807915201(6).zip file in the c:\e\projects folder. 

2. Open FDOTSS2 in the file c:\e\projects\22807915201\roadway\DSGNRD01.dgn 

3. Open up GEOPAK Project Manager to insure the project .prj and .gpk files are loaded and active.  

 

4. From the GEOPAK Road Tools toolbox, open the Corridor Modeling dialog. 

5. From the Corridor Modeling dialog, Select File > Load, select SR817.rdp from the project 

preferences list and then click Open.  

6. From the Corridor Modeling dialog, click on the Open Roadway Designer icon. 
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7. From the Roadway Designer dialog, select Corridor > Corridor Management. 

 

8. Name the corridor SR817 and enter the dialog information with the following information.  

 

9. From the Manage Corridors dialog, click Add to add the corridor to the Corridors: list box, then 

Close Manage Corridors dialog. 
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 Template Drops 

1. From the Roadway Designer dialog, select Corridor > Template Drops to open the Template 
Drops dialog. 

 

2. In the Template Drops dialog, change the Interval to 20.  

 

3. In the Library Templates: area of the dialog, browse to the folder named SR817 Templates and 

select the template named SR817. Click Add  
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4. Close the Template Drops dialog. The Roadway Designer now displays graphics in the 3 views. 

 

5. To view other sections along the corridor; Use the cross section navigation gadget tools <or> drag 

the yellow line in the plan or profile view.  

6. From the Roadway Designer dialog, select File > Save . Enter SR817 in the File Name field. 

Choose Save.  
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 Tools Options 

1. Select Tools > Options <OR> click the Options icon. The Roadway Designer Options dialog 

displays.   

 

2. From the Roadway Designer Options dialog, check only the Horizontal Cardinal Points and 

Reference Graphics boxes and uncheck all others.  

or  

3. From the Roadway Designer Options dialog, click the Preferences button. 

  

4. From the Preferences dialog, click the FDOT line and choose Load. Close the Preferences 

dialog.  
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SWITCHES, DISPLAY RULES  
One of the more sophisticated features of template design in Corridor Modeling is the ability to add 

display rules on template components.  Display rules are used to turn on or off components based on logical 

statements. If a rule or statement is TRUE the component is on. If the rule is FALSE the component is off.  

The rules are compared against physical attribute of template at each defined interval location along the 

corridor, (i.e. If the distance between two points is the value one, then a component will be displayed.  If 

the distance is not one, then the component will not be displayed). 

Display rules follow IF, THEN logic and can be joined by ‘AND’ and ‘OR’ to create multiple conditions 

for a rule to be TRUE.  This allows designers the ability to create very flexible and accommodating 

templates. Using display rules on templates reduces the need to place several template drops along a 

corridor when a different template conditions are needed.  

Switches are essentially point constraint values, labels, or parametric constraints, which make display rules 

TRUE or FALSE  

The FDOT Template Library includes many provided switches on the delivered templates.  These can be 

used at the discretion of the designer.  They may be used as provided or as an example for other project 

specific conditions.  By and large, display rules are project design specific and will be addressed in later 

chapter exercises. 

Some of the conditions where display rules and switches have been provided on the delivered templates 

include the following: 

 Curb Types 

 Curb Base  

 Traffic Separator Types 

 Median Types, Flat vs. Crowned 

 Shoulder Gutter  

 Ditch Pavement 

 Guard Rail 

Exercise 6.2 Switches, Display Rules  

In this exercise the Create Template dialog is used to edit point properties for Curb Base and Curb Type 

label values for the project template. Depending on the label value, different components on the template 

become active for display. Therefore, they act like “switches. Values for the switches are defined in the 

display rules for the template. In order to view which value is used to display which component, the 

Display Rules dialog is opened for review.  The Typical Sections delivered in the FDOTSS2 Template 

Library were created to be very flexible and accommodating for a variety of situations and project 

requirements. Rather than use the delivered “switch” display conditions, the project specific template 

conditions are defined in this exercise. 

1. In Roadway Designer dialog, change to the Create Template dialog by clicking on the Open 

Template Library icon.  
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2. From the Create Template dialog,. Make the SR817 Template active if it is not by double clicking 

on the name in the list.  

 

3. From the Create Template dialog, set the Display settings to Components, check Display Point 

Names and uncheck Display all Components. 
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4. To switch on the curb base for display, find the template points LT_CURB_BASE _SWITCH and 

RT_CURB_BASE _SWITCH with the Library tab active. Double click on each point and change 

the Horizontal Constraint Value to 1.  

 

  

5. Click Apply and Close.  Once the Value has been set for each point the Curb Base is now displayed 

in the Template. 
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6. To change the outside curb type, find the template points LT_OUT_CURB_SWITCH and 

RT_OUT_CURB_SWITCH with the Library tab active. Double click on the point and change the 

Horizontal Constraint Value to 1.   

7. Click Apply and Close.  The curb will now display a Type E curb.  

8. Click the undo Icon to return to the delivered Type F curb display. 

To pre-determine what switch settings will display 

9.  Open the Component Properties dialog, double click on the line of any component to OR right 

click on the line of any component and click the Edit Component option from the list.   

 

10. On the Component Properties dialog, click the Edit button next to the Display Rules field.  The 

Component Display Conditional Expression dialog will display. The bottom half of the dialog is a 

Template Display Rules listing all rules for the template.  

Note The Value column indicates what the number is associated with each available 
component name, (i.e.  2 for Shoulder Gutter SG, 3 for Drop Curb, etc.).  EDITING THE 
DISPLAY RULES IS AN ADVANCED TOPIC TO BE ADDRESSED IN ANOTHER 
CHAPTER. 

 

11. Click OK to exit the dialog. Close the Component Properties dialog.  Click File Save to save the 

work from this exercise.  

Note There is another way to view the display rules for the template which will be described in 
general in the next section regarding Parametric Constraints.  
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PARAMETRIC CONSTRAINT VALUES 

 

 Used to override Constraint Values 

 Named as Labels in the Point Properties dialog 

 Override values set in the Tools > Parametric Constraints dialog 

 Easily adjusts pavement thickness 

Parametric Constraints are used to override constraint values. For example, a template created with a 2 inch 

layer of asphalt, but the design calls for 3 inches.  The 2 inches is a vertical constraint value that can be 

overridden to 3 inches using parametric constraints. To create parametric constraints, first Edit the template 

points and key-in a name in the Labels field that you want to assign to a specific constraint value. For 

pavement thickness, it would be the vertical constraint of the bottom layer points. In the Roadway 
Designer dialog, use Tools > Parametric Constraints to assign overriding values to the labeled points OR 

set project specific values in the Create Template dialog to override the preset values delivered in the 

FDOT Template Library.  

Exercise 6.3 Parametric Constraints Values  

In this exercise the Create Template dialog is used to edit the default parametric value in the Parametric 

Constraints folder of the Active project template. The pavement and base thickness will be changed for 

both sides of the template. Changing the value in the dialog will change the vertical constraint distance for 

each point with that label assign to it. This is an efficient way to change multiple point constraint values in 

one step on a project template. 

1. Continue working on the SR817 Template from the last exercise active.  
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2. Select the Active Template tab under the Template Library tree 

list to make it active.  Collapse the tree list folder if necessary. The 

dialog should display as follows: 

Note This is also where the Display Rules for the template can 
be reviewed and edited in reference to the previous 
section.  

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Open the Parametric Constraints folder to display the list for the active template.  

Note Notice at the bottom of the list the LtCurbBaseSwitch.  This is one of the switches that 
were changed in the previous exercise. They could have been changed here as well.  

4. To change the pavement thickness for the left roadway: Right click on the EOP_PvtThickLt item and 

click Edit.  

5. Change the Default Value from -0.25 feet to -4/12 feet, or 

from 3 inches to 4 inches. Use the Tab key to enter the 

information and Click OK. 

 

 

6. Repeat for the right roadway.  

7. To change the base thickness for the left roadway, Right click on the EOP_Base ThickLt item and 

click Edit.  

8. Change the Default Value from -0.833 feet to -1 feet or 

from 10 inches to 12 inches. Click OK. 

 

 

9. Repeat for the right roadway.   

Note Notice that the curb base thickness changes along with the pavement base. This is 
because of predefined relationships developed in the FDOT Template Library 
components. 

10. Select the Library Tab again on the Create Template dialog and select File > Save. Select File > 

Save to exit the Create Template Dialog. 
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ASSIGNING STYLE CONSTRAINT & RANGES 

   

 Template Point Controls 

 Used to override the normal locations of Template Points 

 Uses include lane widening, ramp and intersection design, and separate grade line control of a 

single corridor. 

Template point controls are used to override the normal horizontal and vertical locations of template points 

during the modeling process. Design examples include lane widening, ramp and intersection design, 

Superelevation, and divided highways with separate grade lines. These overrides are accomplished by 

assigning template point names to alignments. The assigned template points will follow the alignments 

using horizontal and/or vertical controls within a specified station range. Surface features can also be used 

to control template points. 

In the previous chapter Importing Plan Graphics the following MicroStation lines were imported as 

Corridor Modeling alignments which can be used for template points: 

Lv Name Chain New Chain Name Drafting Standard 

Sidewalk Back IMPORT SWB Sidewalk -Back Proposed 

Sidewalk Front IMPORT SWF Sidewalk -Front Proposed 

EOP IMPORT EOP Pavement Proposed 

Traf Separator IMPORT TS Traffic Separator Proposed 

    

Exercise 6.4 Assign Style Constraint & Ranges to Points  

In this exercise the Create Template dialog is used to edit point properties of specific points. A Style 

Constraint is selected and a Range value is assigned to the points in the project template that will need to 

follow the imported graphic alignments. This will cause the template to vary the segment lengths in 

Roadway Designer to reflect the project design requirements for the locations of the template points. The 

FDOTSS2 Template Library has been designed and delivered with default Style Constraint and Range 

value setting for several other template points, (i.e. edge of pavements, front and back of curbs, front and 

back of sidewalks and traffic separator, etc…).  This exercise changes the inside and outside edge of 

pavement Style Constraint and Range values to follow the Milling Limits along the proposed project as 

defined in the 2D graphics. 

1. Continue working with the SR817 Template from the last exercise active.  

2. Select the Library tab under the Template Library tree list.  
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3. Right click on the top outside edge of pavement point of the left roadway, LT_PVT_EOP_OUT and 

select the Edit Point option from the list, <OR> double click on the point.  The Point Properties 

dialog will display with the Style Constraint list field and check box located at the bottom.  

  

4. Check the Style Constraint box and verify the list item is Pavement Proposed.  Click Apply and 

Close 

The Style Constraint applies an override from the current template location. Instead the template will 

look a range from 0 to 50 feet left of the defined template point location for the Milling Limits to set 

the horizontal location of the template point.  

Note When the template is processed in Roadway Designer, if the alignment style 
alignment, (i.e. Pavement Proposed) is not found, then the point location will default to 
the horizontal location defined in the template.  

5. Right click on the top outside edge of pavement of the right roadway, RT_PVT_EOP_OUT and 

select the Edit Point option from the list, <OR>  double click on the point. Verify the Style 

Constraint. 

 

6. Select File > Save to save the changes to the Template library.   
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END CONDITIONS 
End condition components are used to form the template transition slopes to the existing ground. End 

condition templates in the FDOT Template library have multiple end conditions components.  All have 

standard slope condition tests developed to meet FDOT design standard criteria. 

COMPONENT PROPERTIES  

The component properties for End Conditions have an additional area for End Condition Properties. These 

properties list the Target Type and Priority for processing end condition components 

TARGET TYPE  

This property determines what the end condition will try to intercept. The Target Type affects the way the 

side slope is constructed. Feature XYZ, Alignment XYZ, and Style XYZ will override the slope constraint 

and use whatever slope is necessary to tie to the target location. All other Target Types observe the slope 

constraint to locate the point.  

Additional drop down menus are displayed below the Target Type. These are used to list the target of the 

type specified in the Target Type. The information required for each Target Type is:  

 Surface – Set to Active (which will tie to whatever surface is active) or to a specific surface. 

Surface is the most common Target Type and used by most FDOT standard side slopes.  

 Elevation – Enter the target elevation in the Vertical Offset field. This can be useful for setting 

elevations of benches, for example.  

 Feature XY, Feature Elevation, and Feature XYZ – Identify a surface (Active can be used) and the 

Feature Name that you want to seek. For example, you may need to tie into an existing curb or an 

existing ditch feature.  

 Alignment XY, Alignment Elevation, and Alignment XYZ – All must have a horizontal alignment 

specified. Alignment Elevation and Alignment XYZ also need the Vertical Alignment identified. 

For example, Alignment Elevation can be used to tie a special ditch into the elevation of a vertical 

alignment.  

 Style XY, Style Elevation, and Style XYZ – Specify a Style. These targets work just like the 

previous Feature and Alignment targets, except the side slope looks for a Style used in the active 

surface or geometry project instead of a specific feature or alignment listed by name. For example, 

if you want to tie into an existing curb, but the curb is made up of multiple features, you can tie 

into the style for the curb and the side slope finds the first occurrence at each template drop.  

Note The most often used Target Type is Surface. 

PRIORITY:  

This property determines the order in which end condition components are processed. The processing order 

is from the lowest numbered priority to the highest. The flattest slopes are set to the lowest numbered 

priority so that they are processed first. If you do not set the priorities ahead of time, they can be set when 

the end conditions are tested.  
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POINT PROPERTIES  

For points that are part of an end condition, four additional check boxes for End Condition Properties are 

added to the Point Properties.  

 Check for Interception - If on, the point checks for an interception of the target between the 

previous point and this one. In general, turn this option on for the last point in a cut or fill 

definition. An example of where it would be turned off is for the fore slope of a ditch that has a 

flat bottom.  

 Place Point at Interception - When on, the point will be constructed where it contacts the target. 

When off, the point is constructed as defined by its constraints. Turn on this option in most cases 

when Check for Interception is on.  

 End Condition is Infinite – When on, the point will extend past its defined width in order to 

contact its target. When off the point must reach its target within its defined width in order to be 

constructed. This option is used for the steepest cut and fill slope defined in the template. Since it 

is off for shallower side slopes, they will not extend beyond their constrained horizontal distance.  

 Do Not Construct – When on, the point will be solved for as normal, but will not be used when 

creating the component. 

Exercise 6.5 End Conditions 

In this exercise the Create Template dialog is used to add end condition components to the project 

template. The typical sections delivered in the FDOTSS2 Template Library were designed and delivered 

without end condition components. However, individual end condition component groups are available in 

the End Conditions folder.   In order to tie the project template to the imported DTM existing surface the 

end condition component copied from the FDOTSS2 Template Library is added to the project template.  

Also in this exercise, the Test button on the Create Template dialog is used to open the Test End 
Conditions dialog.  

1. From the Create Template dialog: Uncheck the Display Point names 

2. Right click the template SR817 and click Copy. On the folder, SR817 Templates, click Paste and 

right click to Rename the template, SR817_1.  Double click or right click and click Set Active.   

3. From the Tools menu option on the Create Template dialog, click on the Dynamic Settings option. 

Check on the Apply Affixes box on the Dynamic Settings Toolbox.  
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4. Open the SR817 Components folder and select the FDOT Standard Cut & Fill item in the list. Drag 

the end condition components near the right side of the template. While dragging, use the right mouse 

click and click Mirror before placing to apply to both sides of the template. When the joining points 

are near the template point will turn white. This is a template snap feature. Click on the last right 

point on the template. 

   

5. Click the Fit icon. 

  

  



FDOT STANDARD LIBRARY COMPONENTS - End Conditions ______________________________________________ Chapter 6 

FDOT Corridor Modeling  ©2014 FDOT  6-21 

6. When the drag operation is complete the template should look like the one below.  

 

Note To recover from a misplaced drag, use the Undo icon below the template window OR 
delete the template and start with a new copy of the previous edited template.  

7. Select File >Save to save the changes to the Template Library.  

8. Click the Test button in the Create Template dialog to open the Test End Conditions dialog. 

 

9. Select the <Active> Surface in the Available Targets list and then click Draw. This will place a 

white line using the default surface slope in the dialog.  
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10. Move the mouse cursor up and down vertically to observe the End Condition Solutions based on the 

location of existing surface.   

  

Note For a complete Reference Command List, click the Help button to review the 
documented functionality. 

11. Click Close to exit the Test End Conditions dialog.   

12. Select File > Save to save the changes to the project template library, SR817.itl 
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Exercise 6.6 PGL Handles and Test Point Controls in Create Template  

In this exercise the Create Template dialog is used to test components component relationships on the 

project template. The typical sections delivered in the FDOTSS2 Template Library were designed and 

delivered with null points labeled as PGL Handles. 

Also in this exercise, the Test Point Controls command in the Create Template dialog is introduced to 

assist the designer in testing the component relationships as point controls move the template in roadway 

designer. 

NULL POINT HANDLES 

The FDOTSS2 templates have handle points built in to assist in the designer in areas that get full of details.  

By placing “NULL POINTS” outside of busy areas, other points can be constrained to the points to act as 

handles for testing purposes. To fully constrain the roadway to the null points, follow the procedure as 

follows below: 

1. Zoom into the median area of the template. 

2. Locate the null points above the left and right PGL points on the template. Turn on the point names 

briefly. They are labeled LT_PGL_HANDLE and RT_PGL_HANDLE. 

3. Right click on the left roadway inside edge of pavement point BELOW the LT_PGL_HANDLE 

handle and select Add Constraint > Vertical. 

 

4. A prompt appears to select the parent point. The prompt is in the lower left corner of the Create 

Template dialog.   
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5. Select the LT_PGL_HANDLE point, the Add Vertical Constraint dialog opens to set the offset 

distance. Leave the Offset value -5.0000, Click OK.  The pavement point will change from yellow to 

red.  

  

6. Repeat for the procedure right roadway inside edge of pavement point and set the vertical constraint 

RT_PGL_HANDLE.  

 

 

TEST POINT CONTROLS  

In the Create Template dialog there are two ways to test movement of components in relationship to one 

another. The first way is with the Move Point command. The second is the Test Pont Controls command. 

Both of the commands can be found when right clicking over a template point.  The Move Point command 

will only appear when a point is yellow or green (i.e. not fully constrained).  

1. Right click on the LT_PGL_HANDLE and select Delete Horizontal Constraint.  

2. Right click on the LT_PGL_HANDLE again and select the Move Point command  

3. Move the cursor up and down to test template roadway movement when the PGL of the left roadway 

varies from the right roadway.   Notice the median slopes will change from crowned to straight slope.  

4. RIGHT CLICK AGAIN TO END/CANCEL.  Select Edit Undo to add the Horizontal Constraint 

back to the LT_PGL_HANDLE.  
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5. Right click on the outside edge of pavement point LT_PVT_EOP_OUT, select the Test Point 

Controls > Test All command. 

 

6. Move the edge of pavement in all directions to test the template roadway movement, notice how each 

of the components change with movement both horizontally and vertically.  

7. RIGHT CLICK AGAIN TO END/CANCEL 

8. Close the Create Template dialog. Choose Yes to save your changes.  
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ASSIGNING POINT CONTROLS TO ALIGNMENTS  

f

 

POINT CONTROL COMMAND 

 Set horizontal and/or vertical controls 

 Control template points based on horizontal and vertical alignments 

 Automatically overrides existing template point constraints 

BASIC WORKFLOW 

 Create alignments used for horizontal and/or vertical controls 

 Assign template points to the control alignments 

 Controlling stations based on corridor alignment stationing 

 Click Process All and review the design 

Point Controls are used to assign horizontal and/or vertical controls to any template point. Point controls 

are added to the design after the corridor is created and the template drops are assigned to the corridor. 

Point controls are specified by the corridor’s alignment stationing, and not by the stationing on the 

controlling alignment. Point controls automatically override all template point constraints on the point 

being controlled. Constraints on all other points will be obeyed. 
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Exercise 6.7 Assign Point Controls to Alignments  

In this exercise the Roadway Designer dialog is used to add Point Controls to the template define on the 

corridor. Point controls will add more project design controls to the template points along the corridor 

alignment.  For the project in the exercises, a left and right profile grade chain was designed with 

GEOPAK Coordinate Geometry and imported as alignments. The template points corresponding to these 

profile grade alignment controls are added and displayed in the Point Controls dialog. Roadway 
Designer will now re-construct the project template with the point controls alignment controls at the 

defined interval and critical points along the corridor.   Also in this exercise a temporary dimension line, in 

Roadway Designer only, is placed to see how the left PGL and right PGL vary in elevation along the 

corridor. 

1. From the Corridor Modeling dialog, open the Roadway Designer dialog. 

2. From the Roadway Designer menu, select File > Open and then select the project SR817.ird file. 

3. Select Corridor > Template Drops and select the Current Template Drops entry  

4. Select the newest version of the template SR817_1 and click on the Change button. Close the 

Template Drops dialog.  

 

5. Change the Stations in the cross section view. Notice how the pavement widths change for each of 

the roadways.  This is because they are now following the Style Milling from the imported graphics.  

6. Select Corridor > Point Controls.  The Point Controls dialog displays. See image below. 

7. Enter PGL_LT for the Control Description 

8. Select the LT_PVT_EOP_IN template point name to control. 

9. Select the Mode option Both to control the point both horizontally and vertically.  
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10. Leave the Control Type: option on Alignment. 

11. Select the PGL-LT for the Horizontal Alignment  and PGL-LT for the Vertical Alignment  

12. Leave the corridor’s default Station Limits and Offsets values.  

13. Click Add to store the new PGL_LT point control on the list. 

 

14. Repeat these steps to create another point control description PGL_RT for the RT_PVT_EOP_IN 

template point, using the PGL-RT for Horizontal and Vertical Alignments point control.  

15. Click Add to store the new PGL_RT point control on the list. 

 

16. Close out of the Points Control dialog. 
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17. Notice in the Cross Section View there are new magenta squares added to the view where the point 

controls were added.  

18. Use the Station control buttons to step through the cross section. 

 

19. To validate the Point control changes, right click on the Cross Section window and click Place 

Temporary Dimension Line  

 

20. At the prompt place a Dimension Line between the PGL_LT and PGL_RT. 

 

21. Change the Stations to see that the slope between the PGL point controls varies. This is because the 

profile grade lines are different for each side of the roadway.  

22. Select File > Save to save the changes to the SR817.ird. 

Note Depending on the station, the slope value will differ. 
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 Component Quantities 

1. From the Roadway Designer dialog cross section view, use the Station toggle buttons at the bottom 

of the view to change the location of the template along the alignment.  Notice the graphics displayed 

in the plan and profile windows. Click on the Process All button.  

 

2. From the Roadway Designer dialog, select Tools  > Component Quantities to display the dialog 

as shown below. 

 

3. Click the Proceed to End button. 

 

Note Notice how the component quantities update bases on the station along the corridor.  

4. Select the Report button on the Component Quantities dialog.  The Bentley Civil Report browser 

window displays.   
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5. Select the Evaluation folder and select the Roadway Designer Component Quantities .xls. The 

Roadway Designer Component Quantities Report displays in the window.  

 

6. From the browser menu, select File > Save As.  The Save As dialog opens.  

7. Enter the File Name SR817 and change the Save as Type to XLS File (*.xls). 

 

8. Click the Save button to create a Cost Estimate in Microsoft Excel format. 

9. Close the Bentley Civil Report browser window. 

10. Close the Component Quantities window.  
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 Create Surface 

In Roadway Designer, the Create Surface command will create a 3D Mesh Model. LEAVE Roadway 

Designer dialog open for this exercise. However, the dialog may need to be minimized. 

1. Select the FDOTSS2 menu option: Actions > Create/Edit File and to create a 3D MicroStation file 

AMGMRD01.dgn (Automated Machine Guidance Model (3D)).   

 

2. Complete the Create File/Project dialog as shown below.  If the Project field is not set to the current 

exercise project, select the Project Settings button and click on the Select Active Project button.  
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3. Click the Create button and then click Open File.  The newly created MicroStation file will open. 

4. Click OK to close the Create File/Project dialog. 

5. Set Plot Scale to 50. Click OK. 

6. From the Roadway Designer menu, select Corridor > Create Surface <OR> click the  icon, 

enter the Name: SR817 and then complete the dialog as shown.  

 

7. Click Apply to create the surface.  Depending on the settings in the Tools Options dialog this 

process may take several seconds.  

8. Close the Create Surface dialog and the mesh model elements are drawn into MicroStation file. Fit 

View to see the corridor results. It may be necessary to move the Roadway Designer and Corridor 
Modeling dialogs away from the view area.  

9. From the Corridor Modeling dialog, click the Drive Roadway tool icon and set the Drive 
Roadway dialog options as shown below.  
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10. Select Run, click the Escape key to pause the Drive Roadway command. 

11. When completed, change the MicroStation View Display Style from Wireframe to Smooth. 

 

12. Change the Light setting to the brightest. 

 

13. From the Drive Roadway dialog, click Run..  

14. Repeat with other View Display Style changes, such as, Frames per second and or Speed.  

15. Close the Drive Roadway dialog. 
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16. From the Roadway Designer dialog, select File > Save.  

 

17. Close the Roadway Designer dialog.  

Note To return to a top view in MicroStation, click the View Rotation icon, click Top, and 
then Fit View.  

 

18. Change the View Display Style back to Wireframe and select the MicroStation menu option File > 

Save Settings to save the current view. 

Note To create animations using the MicroStation animation tools refer to the white paper 
delivered in the c:\FDOTSS2\GEOPAK\corridor\help folder entitled, “MS drive thru 
animation preview”.  This is the preferred method for presenting more controllable 
“Drive Thru” conditions once the 3D design model has been finalized.  
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7 SUPERELEVATION  

Superelevation rotates pavement cross slopes through a curve so that vehicles can maintain stability at the 

design speed. The Superelevation Commands compute the necessary Superelevation rate, determine how 

the road will transition from normal crown to full Superelevation and calculates the station locations of 

these transitions for each curve in the corridor. The Create Superelevation Wizard is used to establish 

Superelevation for the roadway. The Table option automates creating the initial Superelevation point 

controls and control lines based on the FDOT Design Standard criteria.  

MENU OPTIONS 
The Superelevation Menu is located on the Roadway Designer dialog and includes the following 

Commands: 

 Create Superelevation Wizard - Used to step through the process of entering Superelevation 

criteria. There are three available methods to input the data: AASHTO, Fixed Length or Table. 

FDOT uses the Table method. After running the wizard, Superelevation control lines are 

automatically created and assigned to template points (through Point Controls) to determine how 

the points (edges, lanes, etc.) will rotate in Superelevation. 

 Create Single Control Line - An alternate method of setting up Superelevation criteria by 

manually creating Superelevation control lines, which controls the cross slope of template points 

in Superelevation. This is also useful when the cross slope of the roadway is not truly in 

Superelevation, such as matching the vertical grade of the main roadway for an approach road (i.e. 

On ramp). 

 Apply Shoulder Rollover Lock - Special Superelevation control lines and point controls are 

assigned to shoulder points, which determine how shoulders will rotate in Superelevation. FDOT 

uses multiple rollover locks on shoulders for 10% maximum Superelevation rates as defined in the 

Design Standards. 

 Import Superelevation from ASCII - Allows you to import an ASCII Superelevation file (pipe 

delimited format) to create Superelevation control lines. This file is generated and saved from the 

Roadway Designer Superelevation Report. 

 Import Superelevation from INP File - Allows you to import, from GEOPAK Shape Maker, 

Superelevation data from an alignment created in previous versions.  This creates Superelevation 

control lines matching the previous super table. 

 Superelevation Report - Generates an XML report of the superelevated points and/or their 

corresponding control lines. 
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SUPERELEVATION DISPLAY MODE 
When Display Mode is changed to Superelevation, the Roadway Designer dialog is then updated with 4 

new views:  

 Plan View - this is color filled by slope values, the end condition slopes are omitted, 

 Cross Section View – this is color coded by slope value and Superelevation points are labeled, 

 Profile View  – this displays a profile for each template point , 

 Superelevation View – this displays the Superelevation control lines in relation to the crown point, 

the zero line. 

 

Note The Superelevation Table Wizard (FDOT’s preferred method of setting up 
Superelevation criteria) is explained below. For information on other methods or the 
concept of Superelevation in general, refer to Superelevation Overview in the Reference 
Information Help file.  

TABLE WIZARD 
The Superelevation Wizard steps through the process of entering Superelevation values. These values 

include selecting the appropriate FDOT Superelevation rate table.  

FDOT uses the Table method to calculate Superelevation rates. This method complies with AASHTO 

guidelines and incorporates FDOT’s Superelevation standards by utilizing custom Superelevation tables 

located in the FDOT workspace. The FDOT Superelevation tables specify maximum Superelevation rates, 

along with spiral transition lengths, for a range of curve radii. The tables are text files, which can be opened 

in Notepad or any word processor. They are categorized by a maximum Superelevation rate and a design 

speed. For example, a table named 05_50.sup contains FDOT standard values for curves at a 5% maximum 

Superelevation rate at a 50 mph design speed.  

For more information on Superelevation rate tables, see Superelevation Rate Table (.sup) Descriptions in 

the Online Reference Information Help.  
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Additional Superelevation criteria set via the Wizard includes:  

 pivot point location (centerline, inside edge),  

 range point locations (to designate the fully superelevated portion of the template),  

 station range for different design criteria and  

 the number of lanes to be superelevated. 

The illustration below shows an example of pivot and range point locations for a template cross slope as it 

rotates through Superelevation. In this example, the template pivots about the crown points (the PGL lines) 

and the range points (left and right edge of pavement) define the range of points that will rotate to full 

super. The Wizard stores this information in Superelevation Sections. In addition to the pavement rotation, 

the shoulder appears to rotate along with pavement. The Sections are a set of super values applied to a 

station range along the corridor. If the design speed changes at any point along the corridor, end one section 

and start another.  
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SUPERELEVATION WIZARD RESULTS  

The wizard automatically creates:  

 Superelevation control lines for each point super elevated on the template  

 Vertical point controls for these points.  

 Color-coded plan display that varies by cross-slopes for the components within the template 

backbone. 

 Color-coded view cross section display of the template backbone along with the cross slope 

annotations.  

The profile display shows color-coded grade lines for all points on the template backbone. Right-click to 

control which template points are displayed (i.e. the left and right edges of roadway).  The Superelevation 

diagram shows the control lines along the corridor.  

The control lines in the Superelevation diagram view are the graphical representations of cross slope over a 

station range (stationing or length along the x-axis and cross slope on the y-axis).  A horizontal line 

represents a constant cross slope along a station range, whereas a sloped line represents a linear change in 

cross slope along a station range.  An infinite number of control lines can be assigned to an infinite number 

of points in a corridor.  The control lines can be created to control any change in cross slope between two 

points in the template (i.e. sidewalk, gutters, etc.) The control lines are colored in the diagram for visual 

clarification only. Unlike the plan, profile and cross section views, the line colors do not correlate to any 

Superelevation values.  

The Wizard automatically creates the vertical point controls that correspond to each Superelevation point 

control line. Open the Point Controls dialog to review the vertical point controls created by the 

Superelevation Wizard. The Wizard also calculates Superelevation rates for each curve on the horizontal 

alignment and stores these in the geometry project (ALG file). The Superelevation section definitions (the 

point controls and control line information) are stored in the IRD file. 

EXERCISE OVERVIEW 
7.1 Calculating the Initial Superelevation  

7.2 Controlling Superelevation Displays 

7.3 Editing Superelevation  

7.4 Moving Superelevation Control Points 

7.5 Editing Curve Set Stations 

7.6 Superelevation Reports and Save to ASCII file 

7.7 Removing Superelevation and Import Superelevation from ASCII 
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Exercise 7.1 Calculating the Initial Superelevation 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the 

project.. The Create Superelevation Table Wizard is opened from the Superelevation pull down menu on 

the Roadway Designer dialog. The project corridor has one curve along the alignment that requires 

Superelevation based on the design speed for the facility.  The Superelevation wizard will calculate the 

required cross slopes and transition station locations based on the curve table chosen from the available 

FDOT Superelevation curve tables. The Point controls needed to rotate the pavement slopes for the 

corridor through the curve are also created. 

1. Optional, extract the 22807915201(7).zip file in the c:\e\projects folder. 

2. In the Corridor Modeling dialog, load the project preferences SR817.rdp from the previous 

exercises.  

3. Open Roadway Designer dialog and open the Roadway Designer project settings (SR817.ird) 

file. 

4. From the Roadway Designer dialog, open the Table Wizard dialog by selecting Superelevation > 

Create Superelevation Wizard > Table….  

 

5. From the Table Wizard dialog, select the desired super Table, 10_50.sup located in the 

C:\FDOTSS2\GEOPAK\corridor\tables folder. This file corresponds to the curve table for a HIGH 

SPEED RURAL Facility (10% E Max) with a design speed of 50 MPH. 

6. Continue to enter information into the Table Wizard dialog as shown below. 

 

Note If the curves need different design speeds or maximum super rates (i.e. different tables), 
highlight the curves to load from this table.  



Chapter 7 _________________________________________________ SUPERELEVATION - Calculating the Initial Superelevation 

7-6 ©2014 FDOT  FDOT Corridor Modeling 

7. Click Load Values From Table. The rate values are read from the table and updated for the 

horizontal curve set listed in the dialog box or highlighted.  

8. Click Next and then click the ADD button on the Superelevation Section Definitions pane. This 

displays the Add Super Elevation Section dialog. 

 

9. From the Add Superelevation Section dialog, select the Crown Point, Left Range Point and 

Right Range Point, using the drop down lists <OR> the Target buttons as shown below.  

 

Note The Range Points are the template points at edges of the template section to be rotated 
in the superelevated portion of the alignment. . 

10. Select Four for the Number of Lanes: 

11. Key-in 1 for Runoff Length Multiplication Factor.  

Note This is typically used only when there are more than four lanes.  

12. Set the Begin Station limit to 73+00. 

Note Station limits are used to define Superelevation section criteria limits. If Superelevation 
design criteria changes (such as different pivot points, range points or different number of 
lanes), then create a new section to specify the different criteria. However, using multiple 
tables along the alignment does not require multiple sections.  

13. Click OK.  
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14. Click Add to create another Superelevation Section, right rdwy, repeating steps 6 through 10 to add 

the right rdwy section.  

 

15. The completed Superelevation Section Definitions dialog should look as follows: 

 

16. Click Next on Superelevation Section Definitions dialog to display the Superelevation Controls 

dialog. 

Note This box lists point controls that are created automatically by the Wizard. The point 
controls determine the vertical location (by defining a cross slope) of template points 
(those at and inside the range points) while rotating in Superelevation. Use the Edit 
button to make changes in the control lines as needed. Use the Delete button to remove 
unnecessary point controls. 

17. Click Finish to complete Superelevation Wizard. The Superelevation Wizard creates 

Superelevation control lines and uses point controls to assign them to the template points within the 

Superelevation range. 
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18. Open the Point controls dialog, click Corridor > Point Controls from the Roadway Designer 
Dialog menu. 

 

Note Notice the new point controls corresponding to each control line on the Superelevation 
diagram. The Superelevation control lines are displayed on the Superelevation diagram 
view in Roadway Designer. The control lines represent the percent cross slope (vertical 
axis) at each station (horizontal axis) for each point that is superelevated in the super 
range.  

19. Select Tools options to be sure that only the Horizontal Cardinal Points are checked on and the close 

the Roadway Designer Options dialog.  

 

20. Click Process All.  
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21. To see the Superelevation results, change the cross section view Stations through the curved part of 

the project.    

 

 

22. Select File > Save from the Roadway Designer dialog. Superelevation control is saved in the .ird 

file for the project.  
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Exercise 7.2 Controlling Superelevation Displays 

In this exercise the Roadway Designer dialog Display Mode is changed to Superelevation.  The 

Roadway Designer dialog is then updated with 4 new views:  

 A plan view - this is color filled by slope values, the end condition slopes are omitted, 

 A cross section view – this is color coded by slope value and Superelevation points are labeled, 

 A profile view and – this displays a profile for each template point , 

 A Superelevation view – this displays the Superelevation control lines in relation to the crown 

point, the zero line. 

Also in this exercise, the profile display list will be changed to only include the 4 edge of pavement lines.  

This exercise is to review Superelevation design layout. 

1. From the Roadway Designer dialog, select the Display Mode: Superelevation radio button to 

view the Superelevation diagram. 

 

To set which profile lines are displayed in the Superelevation diagram, Right-click in the Superelevation profile 

view to open the Profile Display List dialog and click Superelevation Display List. 
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2. From the Displayed Profile List dialog, click None to clear and then select only the following 

control lines to be displayed:  

a. Left inside edge pavement, LT_PVT_EOP_IN 

b. Left outside edge of pavement, LT_PVT_EOP_OUT 

c. Right inside of pavement, RT_PVT_EOP_IN 

d. Right outside of pavement, RT_PVT_EOP_OUT 

 

Note Press the Ctrl keys and select multiple profile lines to display. 

3. Click Apply. The Superelevation profile diagram is updated with the only the selected control line 

displayed. 

 

4. To edit the Superelevation Criteria, such as, a point’s cross slope or max super rate, the normal 

crown, runoff or full super locations, etc., use one of the following methods:  

a. Edit Superelevation Point Properties (via dialog box settings).  

b. Graphically Move Superelevation Points (using dynamic settings).  

c. Edit Curve Set Stations (in table format).  

Note Exercises 7.3 – 7.5 explore each of these methods. 
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Exercise 7.3 Editing Superelevation 

In this exercise the Superelevation control line points will be edited using the Superelevation Point 
Properties dialog. The Station and Cross Slope can be changed in this dialog. If the Superelevation wizard 

calculations need to be overridden they can be calculated by another method and entered here in a manual 

mode. 

1. From the Roadway Designer dialog, select the Display Mode: Superelevation radio button to 

view the Superelevation diagram. 

2. Right click on the beginning point of the transition in the Superelevation diagram and then click Edit 

Point. The Superelevation Point Properties dialog displays. 

 

3. Change the Station value to an even station, i.e. 96+56 and then click Apply.  

4. Close the Superelevation Point Properties dialog.  
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Exercise 7.4 Moving Superelevation Control Points 

In this exercise the Superelevation control line points will be moved using the Dynamic Settings dialog. 

The Station and Cross Slope can be changed in this dialog. If the Superelevation wizard calculations need 

to be overridden they can be calculated by another method and entered here in a manual mode. 

1. From the Roadway Designer dialog, select the Display Mode: Superelevation radio button to 

view the Superelevation diagram. 

2. Right-click on the next point on the superelevation transition control line and click Move Point. The 
Dynamics Settings dialog displays.  

3. Move the cursor to dynamically change the location of the point.  OR… 

 

4. In the x+xx,x% field, enter the nearest whole or even station and cross slope to move the point.  

Note Use the syntax <Station, Cross Slope> when keying in the Dynamic Settings box. 
Express the cross slope as either a % or decimal (334+25,5% or 334+25,.05).  
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Exercise 7.5 Editing Curve Set Stations 

In this exercise the Superelevation control line points will be edited using the Edit Curve Set Station 

dialog. The Station and Cross Slope information can be changed in this dialog. If the Superelevation wizard 

calculations need to be overridden they can be calculated by another method and entered here in a manual 

mode. This method would be used if there were curve sets that calculated overlapping Superelevation 

stations. This often happens on reverse curve alignments with little distance between curve points of 

successive curves. 

1. From the Roadway Designer dialog, select Display Mode: Superelevation radio button to view 

the Superelevation diagram.  

2. Right-click in the superelevation diagram control line view and then click Edit Curve Set Stations. 

The Superelevation Control Curve Set Station Edit dialog displays. 

 

3. Use the Curve Set controls to select the desired curve and verify the desired Section Name is correct 

from the drop down menu.  

4. Click Show Curve Set Information to display curve data in the lower right corner of the dialog box. 

5. Add or Remove Data for other curves within the super section from the list by using the buttons to 

the right of the data area.  

6. Modify Stations and Cross Slopes in white cells by changing the data entries.  

7. Press the Tab key to move to the next editable field.  

8. Edit Reverse Crown stations by toggling off the Constrained check box. If the Constrained check 

box is toggled back on, the station will revert back to its original value. 

Note Changing previously constrained stations may result in kinks in the control line.  

9. Click Apply to accept the changes.  

10. Click Undo to discard any changes, if desired.  
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Exercise 7.6 Superelevation Reports and Save to ASCII  

In this exercise the Superelevation control line points can be saved using the Roadway Designer 

Superelevation Report dialog. The Superelevation sections and ranges can be saved entirely along with the 

control points in the Point Controls dialog in an ASCII file.  This file can then be edited and re-loaded if 

something changes on the template or if the method of Superelevation changes.  

1. Open Windows Explorer and navigate to the C:\ProgramFiles\CommonFiles\Bentley 

Shared\RoadwayDesign\XMLData\Superelevation directory. To save the Superelevation for the left 

rdwy, edit the SuperelevationASCIIImport.xsl file and change the leftRangePointName to 

LT_PVT_EOP_OUT.  Change the rightRangePointName to LT_PVT_EOP_IN. 

 

2. From the Roadway Designer menu click Superelevation > Report. The Roadway Designer 
Superelevation Report dialog  will appear. Complete the Superelevation Report dialog as shown 

in order to save the superelevation data for the left roadway. Click Apply 

 

Note When the Specified Interval is greater than the corridor length, the ASCII Import report 
will only contain the Superelevation key stations.  
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3. By default the Superelevation Data Report will be displayed in the Bentley Civil Report Browser 
dialog.  

 

4. Select the SuperelevationASCIIImport.xsl file in the folder list on the left side of the dialog.  The 

display window in the browser should update as shown.  
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5. To save the Bentley Civil Report Browser data to a file, select File > Save As and key-in the File 

name :  left rdwy as shown. Click Save. 

 

6. Repeat the steps as necessary in this exercise to save an ASCII file for the right roadway 

Superelevation control.  

Note When saving the text files for divided roadways, it is necessary to fill in the last column of 
data matching the second column.  

  

Note The files can now be used by the Roadway Designer .> Superelevation .> Import 
Superelevation from ASCII command.  
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Exercise 7.7 Removing Superelevation 

In this exercise the Superelevation control line points can be deleted using the Superelevation Display List 
dialog. The Superelevation sections and ranges can be deleted entirely along with the control points in the 

Point Controls dialog.  This is the method for removing Superelevation point control lines if something 

changes on the template or if the method of Superelevation changes.  

1. Right-click in the Superelevation diagram control line view and select Superelevation Display List...  

2. To delete just one control line, select the associated point controls from the Available Superelevations 

list and then click Delete. 

Note You can press the Ctrl key and select multiple point controls to delete more than one 
control line.  

 

3. To delete all control lines for a Superelevation section, select the section from the Superelevation 

Section list (all point controls should highlight) and then click Delete. Click Apply and Close. 

4. Once both the left rdwy and right rdwy Superelevation Sections have been deleted, select from the 

Roadway Designer dialog Superelevation > Import Superelevation from ASCII to restore them.  

5. Complete the Import ASCII dialog as shown and click Apply.  

 

6. Complete the dialog again to import right rdwy.txt file. Click Cancel on the Import ASCII dialog.  

Save the .ird file. Select File > Save on the Roadway Designer dialog. 
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8 BUILDING VARIABLE CONDITIONS 

INTRODUCTION  
This chapter provides step by step details on how to apply the variable conditions with FDOT Standard 

Library Components along a project corridor. The course project has many design requirements of which 

are common on many projects.  

Among them are:  

 Left Turn Lanes Added in the Median  

 Right Turn Added on Outside  

 Intersection Crossover Pavements 

 Grass Medians 

 Traffic Separators 

 Varying Sidewalks 

 Retaining Walls 

Traditionally the changing median conditions along the corridor would require multiple template drops and 

template changes to design the corridor.  This method will allow for a single template to handle any median 

conditions that is encountered.   

 

EXERCISE OVERVIEW 
8.1 Using the Variable Median PPM Exhibit templates as delivered in the 

FDOTSS2 workspace 

8.2 Applying Superelevation to inside widening 

8.3 Varying Sidewalks  

8.4 Walls and Checking for R/W  
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Exercise 8.1  Using the PPM Exhibit templates with Variable Median 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK 

using the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded 

for the project. The Corridor Modeling dialog is loaded and the project preferences are loaded from 

the previous exercises. The Create Template dialog is opened to begin building a variable median 

into the project templates.   

Note This FDOTSS2.itl file has PPM Exhibit Templates with variable medians included. The 
median can vary with the following conditions 

 Curb Median with or without Left Turns  

 Shoulder Median with or without Left Turns 

 Crossovers at intersections 

 Traffic Separators with Left Turns 

Note . The next few steps will describe the templates available and the how to make them 
work for this project.  

 

1. Optional, extract the 22807915201(8).zip file in the c:\e\projects directory. 

2. Open FDOTSS2 in a project design file, i.e. c:\e\projects\DSGNRD01.dgn. Load the GEOPAK 

Road Project Manager and collapse the dialog. Open Corridor Modeling and load the SR817.rdp 

file.  

3. From the Corridor Modeling dialog, click the Open Create Template icon. The project Template 

Library will display in the Create Template dialog. 

4. Select Tools>Template Library Organizer. 

   

5. On the Available In side of the Template Organizer dialog, select the Browse Button.  
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6. Navigate to the FDOTSS2/GEOPAK/Corridor folder and select the FDOTSS2.itl file. 

  

7. Copy the entire Median Conditions folder AND the Typical Sections/Urban/Suburban Variable 

Median Offsets/4 Lane Divided Arterial (45 MPH or Less) PPM EXHIBIT TYP-5 template to the 

SR817.itl template library 

 

8. Choose OK to exit the Template Library Organizer dialog and choose Yes to save the changes the 

SR817.itl file.  
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9. Open Median Conditions folder and Set Active the Curb Median template 

 

Note The five things to know about these median condition templates are as 

a. The line at the top is an end condition search line that targets alignments that have been 
imported. I.E CurbBack 

b. Each of the components are turned on ONLY if the target is found. This is by the Parent/Child 
relationship of the Template components 

c. The LT and RT PGL Handles control the overall width of the median and can be modified to fit 
any project 

d. The LT and RT PVT Handles control the amount of pavement inside widening from the PGL 
lines 

e. Each of the Handles have style constraints to located the imported alignments and the 
horizontal range will need to be modified to fit the project 

10. Copy the PPM EXHIBIT TYP-5 template to the SR817 Templates folder and rename it to 

SR817_2. This template was built to include each of the median conditions found on a typical divided 

roadway.  

  

11. Right-click and click Set Active on the SR817_2 template. 
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 To modify the Template to match the project PGL Lines  

The left and right PGL lines on this project are -18 and 10 feet offset from the Baseline. Therefore, 

the template PGL Handles will be moved to accommodate the median width.  Adding an additional 2 

feet to the offset width will allow for the Back of Curb lines to match the imported graphics.  

1. Right-click on the LT_PGL_HANDLE point and select Edit Point. 

 
2. Change the Horizontal Constraint Value to -20 on the Point Properties dialog.  Also, uncheck the 

Style Constraint. Click Apply and Close.  

 

  



Chapter 8 _____________________ BUILDING VARIABLE CONDITIONS - Using the PPM Exhibit templates with Variable Median 

8-6 ©2014 FDOT  FDOT Corridor Modeling 

3. Right-click on the RT_PGL_HANDLE point and select Edit Point. 

 
 

4. Change the Horizontal Constraint Value to 12  on the Point Properties dialog. . Also, uncheck the 

Style Constraint  Click Apply and Close. 
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 To redefine the  Style Constraints ranges for the variable median Template  

The EOP, and Traffic Separator points on the templates need to follow the imported graphics for this 

project.  Since, the overall median with is 6 feet wider than that in the PPM Exhibit the style 

constraint range will be modified on the LT and RT PVT_HANDLE points on the template.  

5. Right click on the LT_PVT_HANDLE point of the template and choose edit point.  

  

6. In the Point Properties dialog, Edit the style constraint value and change it from 18 to 25. This will 

allow for the left inside EOP to move across two lanes for the target style.  
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7. Right click on the RT_PVT_EOP_IN point of the template and choose edit point. 

  

8. In the Point Properties dialog, Edit the style constraint value and change it from -18 to -25. This will 

allow for the right inside EOP to move across two lanes for the target style.  

   

 

9. Save the changes to the SR817_4 template and close the Create Template Dialog.  
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 To apply the variable median template to the previous SR817 corridor in Roadway 
Designer there are four steps:  1.) Change the template in the Template Drops dialog 
and 2.) Add the Parametric Constraint to connect all the median conditions. 3.) Modify 
the point controls in Point Controls dialog.   

10. Open Roadway Designer and then choose Corridor >Template Drops. A. Select the Current 

Template Drops entry in the list, B. Select the SR817_2 Template in the Library Templates List., and 

C. Select the Change. Button. Close the template Drops dialog. 

  

11. On the Roadway Designer dialog, choose Tools Parametric Constraints. Select the OffsetVert 

Constraint Label and set the values to 0. Choose Add then Close the dialog 
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12. Continue in Roadway Designer and then choose Corridor >Point Controls. . Modify the Point 

Name of the PGL_LT from LT_PVT_EOP_IN to LT_PGL_IN.  

 

13. Continue in Roadway Designer and then choose Corridor >Point Controls. . Modify the Point Name 

of the PGL_RT from RT_PVT_EOP_IN to RT_PGL_IN.  
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14. Continue in Point Controls. . Change the Reference Point of the Superelevation for 

LT_PVT_EOP_OUT to LT_PGL_IN.  Choose Change to apply the modification. 

 

15. Continue in Point Controls. . Change the Reference Point of the Superelevation for 

RT_PVT_EOP_OUT to RT_PGL_IN. Choose Change to apply the modification 

16. Close the dialog and choose File Save to update the SR817.ird file in Roadway Designer. 
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Exercise 8.2 Applying Superelevation to Inside Widening 

In this exercise the Create Template dialog is used to change the Constraint2 type from Slope to Vector 

Offset on the inside widening components. This will cause the inside widening pavement to maintain the 

same slope as the main roadway pavement; therefore in effect, applying Superelevation by a constrained 

relationship.  

1.  In the Roadway Designer dialog, change the Station value to 102+00.  Notice how the inside 

widening slope is not super elevated.  This can be accomplished with vector offset constraints in the 

Template.  

 

2. Click the Open Template Library icon on the Roadway Designer dialog.  
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3. In the Create Template dialog, select the Active Template tab and choose the 

RT_PVT_CURB_EOP_IN point or the edge of pavement on the inside curb and choose Edit Point.  

 

4. Change the Constraint Type from Slope to Vector Offset and modify the dialog to follow the 

pavement slope between the PGL_IN and PVT_EOP_OUT. Set the Constraint Label to OffsetVert. 

Click Apply  

 

5. Repeat for the RT_PVT_CURB_EOP_IN, TS_LT_TP, and TS_RT_TP points.  

6. Save and Close the Template Library. 

7. Open the Template Drops dialog and select the Current Templates Drops entry, Choose  the 

Synchronize with Library button.  
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8. Close the Template Drops dialog. The inside widening now is following the Superelevation slopes. 
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Exercise 8.3 Varying Sidewalks 

In this exercise the Create Template dialog is used to add end condition components to the project 

template to locate the back of sidewalk alignment. In this project design, the sidewalk will only be 

constructed in specific areas on the project, a SW_Display end condition is used as a parent component to 

the components outside the curb.  Also, in this exercise a Normal Fill component will be added to the back 

of curb, similar to the force slope in criteria. A display rule is added to this component containing the 

“NOT SW_Display” definition.  Therefore, the Normal Fill component will not display if the back of 

sidewalk alignment is present. 

1. Open the Create Template dialog, right click and copy the SR817_2 template to the SR817 

Templates folder. Set Active the new template and rename the template SR817_3.  

2. Right click in the template view and select Add New Component > End Condition 

 

3. Select the Toggle On/Off Dynamic Settings icon and be sure that the Apply Affixes is on. Key-in 

the Point Name SW_Begin.  

  

4. Key-in the Component Name, Select the Target Type and Style, Right click in the view and check on 

the Mirror option. 
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5. Enter a point at the xy= 30, 7 location.  

a. Check the End Condition is Infinite box on the Dynamic Settings dialog.  

b. Change the point name to SW_End on the Dynamic Settings dialog  

c. Enter another point at the xy= 40, 7 location. 

d. Right click and select Finish 

Note Two new End Conditions will appear on the template.  

 

 Next create two new Display rules, LT_SW_Display and RT_SW_Display.  

1. Right click on one of the new components and select Edit Component. Choose the Edit button on 

the Component Properties dialog.  

2. Click Add button on the Component Display Conditional Expressions Dialog.  

3. Create a new Display Rule as shown below.  Repeat these steps for the other new component.  

   

 

4. Click OK to add the new Template Display Rule to the list.  

5. Click OK to close the Component Display Conditional Expressions dialog. 

6. Click Apply and Close to close the Component Properties dialog 
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 Create a Parent relationship to the End condition SW_Display component on each 
component outside of the curb.  

1. Add the FDOT Standard Cut &Fill end conditions to each side of the SR817_3 template with Apply 

Affixes checked on in the Dynamic Settings Box.  

 

2. Right click on each of the components outside of the curb and select Edit Component. 
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3. Set the Parent Component relationship to the SW_Display End Condition Component for each 

component outside of the curb.  

<OR> … Create a chain relationship to one another with the first related to the SW_Display End 

Condition Component.  

 

<OR> … Another method is to change to the Active Template Tab and drag each of the components 

under the SW_Display component.  

4. Edit the Front of Sidewalk point RT_SW_FRONT_TOP_OUT change the Horizontal Constraint to 

.1  and set the Horizontal Range  +25. Repeat for the LT_SW_FRONT_TOP_OUT point, use -25. 

5. Edit the Back of Sidewalk point RT_SW_BACK_TOP_OUT, set the Horizontal Range +25. Repeat 

for the LT_SW_BACK_TOP_OUT point, use -25. 

6. Click on each of new SW_End points to display the Point Properties dialog. Click on the Do Not 

Construct box.  

 To add a Normal Fill End Condition when the sidewalk is not present: 

1.  Right click in the view and select 

Add New Component > End 

Condition 

 

 

 

2. Enter Normal Fill for the Current Component dialog Name, set the Target Type: to  Surface, set 

the Style: to XS- Ditch Slopes 

 

3. Start the new component on the right top back of curb point, RT_CURB_BACK_OUT, click on the 

first point.  

 While in the command to create a component, use the Right Click again to check to see if the Mirror or 
Reflect setting is on. Use the escape key to leave as is.  
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4. In the Dynamic Settings dialog,  

a. Check the End Condition is Infinite box 

b. Enter NORMAL_FILL for the Point Name:,  

c. Set the Point Style to Text-Miscellaneous,  

d. Check the Apply Affixes,  

e. Set the exact key-in field to hs=.1,-.1667.  

f. Click the Enter key while the cursor is in the key-in field to store the second point.  

g. Right click again and choose Finish.  

    

5. Double click on the new component, the Edit Component dialog displays. Check the Use Name 

Override Box and key-in RT_FILL, click the Apply button. DO NOT close the dialog.  
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6. Click the Edit button next to the Display Rules: field, the Display Rule Conditional Expression 

dialog will display. From the list, select the RT_SW_Display rule.  Click the NOT button and then 

the Selected Rule button  

 

7. Click OK on the Display Rule Conditional Expression dialog. Click Apply and OK on the 

Component Properties dialog.   

8. The component will not display unless the Display All Components box is check ON in the Create 
Template dialog. 
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9. Save the template and repeat these steps for the Normal fill on the Left side of the template.  

 

 

10. Save the changes to the Template library.  
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Exercise 8.4 Walls and Checking for R/W 

In this exercise the Create Template dialog is used to add Gravity Wall components to the project 

template. In this project design, if the R/W is too close to construct a normal fill slope within the Right of 

Way, a wall will be included. In the FDOTSS2 Template Library there is a normal gravity wall component 

that will be added as an end condition to the template. The only change to the Gravity Wall end condition is 

the priority number. 

1. Zoom in to the End Condition area on the right side of the SR817_3 template.   

 

2. Open the SR817 Components folder and drag the Gravity Wall component over to the Buffer Out 

point, RT_BUFFER_OUT. While in dragging, right click and select the Reflect option to flip the 

components for the Right side of the template.  
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3. Right click on the top of the Gravity Wall component and select Edit Component.  Select the Wall 

Height/TIN component.  

\ 

4. Change the Priority to 36 and Add the RT_SW_Display component as the Parent Component 

 

5. Click the Apply button.  

6. Close the Component Properties dialog. Save the Template. 

  



Chapter 8 __________________________________________ BUILDING VARIABLE CONDITIONS - Walls and Checking for R/W 

8-24 ©2014 FDOT  FDOT Corridor Modeling 

 To check for the existing Right of Way distance 

1. Right click in the Template view and select New Component > End Condition. Open the Dynamic 
Setting dialog and check on the Apply Affixes.  

2. Create an End Condition that targets the AlignmentXY for the ROW_EX . Place the first point, 

ROW_BEGIN at xy=40,4. Press Enter. 

 

3.  Place the second point, ROW_END at xy=100,4.  Press Enter. 
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4. Edit each the right side Cut/Fill component end points, (8 Total) and change the Horizontal 

Constraint to the ROW condition ending point, RT_ROW_END. Use -2 for a 2 foot buffer distance.   

Note Verify on the 2:1Fill and 2:1Cut Slope Components that the “End Condition is Infinite” 
is NOT checked. 

 

5. Edit each the left side Cut/Fill component end points, (8 Total) and change the Horizontal Constraint 

to the ROW condition ending point, LT_ROW_END. Use +2 for a 2 foot buffer distance. 
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6. Use the Test window to verify the results of the Right of Way condition check on the cut/fill end 

conditions.  

 

7. Select and Edit the RT_ROW_END and LT_ROW_END points, check the Do Not Construct box. 

Click Apply and Close 

 

8. Save the template. 



 

FDOT Corridor Modeling  ©2014 FDOT  9-1 

9 WIDENING, MILLLING & 
RESURFACING 

INTRODUCTIONS 
Florida’s Design Criteria for Resurfacing, Restoration and Rehabilitation (RRR) of Streets and Highways is 

outlined in the Plans Preparation Manual, Volume 1, and chapter 25. In general, some of the types of work 

for RRR projects are defined as follows: 

 Mill and resurface only, EOP to EOP, no other improvements 

 Resurface with trench widening (Roadway only) 

 Resurface adding turn lanes (spot improvements) 

 Resurface adding paved shoulders 

 Combination of above 

 Resurface with access management improvements 

 Add paved shoulders only 

 Intersection improvements 

 Correct horizontal and/or vertical alignment 

 ADA compliance 

 Approaches to structures 

 RRR with Right of Way acquisition 

Improvements other than resurfacing, restoration or rehabilitation which can be considered include: 

 Improve side slopes; slope flattening/stabilizing. 

 Correct shoulder drop-off. 

 Pave shoulders. 

 Improve pavement cross slope. 

 Improve pavement drainage. 

 Provide or upgrade sidewalks, transit stops and bikeways. 

 Provide or upgrade curb cuts, ramps and other disability access features. 

 Reconstruct or close driveways to comply with Access Management standards. 

The GEOPAK Corridor Modeling application has tools built in to assist in the design of RRR projects.  

Specifically, in the Create Template dialog, there are special components that can be added for milling, 

overbuild and resurfacing.  Also, in Roadway Designer, there are cross slope correction and vertical 

alignment adjustment tools available to achieve the optimum rehabilitation design.  

In this chapter exercise, the templates created from previous exercises will be modified to include the 

widening for turn lanes, radii, bus turn outs, etc.  The template will also be changed to reflect the milling, 

overbuild and overlay for the existing pavement along the corridor. Simple vertical adjustment criteria will 

be applied to the project based on a maximum milling depth.   
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EXERCISE OVERVIEW 
9.1 Modify Design Template with Inserted Points 

9.2 Differentiate Widening from Resurfacing 

9.3 Assign Parent Components & Delete Base Components  

9.4 Adding Milling, Overbuild & Overlay Components  

9.5 Apply Template to Corridor 

9.6 Vertical Adjustments Settings 

WIDENING, MILLING & RESURFACING 
The project in this course manual is a typical RRR project. It includes several of types of work described 

above. Including: 

 Mill and resurface only, EOP to EOP 

 Adding/widening pavement for turn lanes (spot improvements) 

 Intersection improvements (Radii improvements, new traffic separator) 

 Improved pavement cross slope 

 Provide or upgrade sidewalks, transit stops and bikeways 

The design file has well defined line work designating the milling limits and widening limits along the 

project. These limits will be targeted on the template to automate the design and development of cross 

sections. The templates will be designed with widening, milling, overbuild, and resurfacing. 

Exercise 9.1 Modify Design Template with Inserted Points 

The first step will be to add the widening targets to the project SR817 template.  The template will be 

modified to allow for simultaneous milling and widening targets as shown in the diagrams below.  

 To accommodate widening for the outside lanes and inside lanes in a Curb Median with Widening 

condition, there are three points to be inserted at 4 different locations: 

LOCATION Left Outside Left Inside Right Inside Right Outside 

Top LT_ML_OUT LT_ML_IN RT_ML_IN RT_ML_OUT 

Middle LT_ML_BOT_OUT LT_ML_BOT_IN RT_ML_BOT_IN RT_ML_BOT_OUT 

Bottom LT_ML_BASE_BOT_OUT LT_ML_BASE_BOT_IN RT_ML_BASE_BOT_IN RT_ML_BASE_BOT_OUT 
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 To accommodate widening for the inside lanes when a traffic separator is present, there are three 

points to be inserted at 2 different locations.  They are: 

LOCATION Left Inside Right Inside 

Top LT_ML_IN1 RT_ML_IN1 

Middle LT_ML_BOT_IN1 RT_ML_BOT_IN1 

Bottom LT_ML_BASE_BOT_IN1 RT_ML_BASE_BOT_IN1 

 

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the project. 

The Corridor Modeling dialog is loaded and the project preferences are loaded from the previous 

exercises. The Create Template dialog is opened and the completed template from chapter 8 is copied and 

renamed.  
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The template will have new points inserted on the components to accommodate widening on the inside and 

outside of the milling limits for each roadway. Also, the style constraints defined in the earlier chapters will 

be changed to target Pavement-Proposed alignments and the new points will target the Milling Limits. 

Since components cannot be inserted on templates, this step is included prior to creating new components. 

1. Open the FDOTSS2 MicroStation workspace in the c:\e\projects\2280795201\roadway folder in the 

DSGNRD01.dgn file.  

2. Click the GEOPAK Project Manager  icon and select the sr817.prj Road Project.  

3. Open the Corridor Modeling dialog box by clicking on the  icon <OR> from the MicroStation 
menu option: Applications > GEOPAK > ROAD > Corridor Modeling. 

 

4. From the Corridor Modeling dialog, select File  > Load. A browser window will appear in the 

current working design file directory.  

5. Select the SR817.rdp preference file to load. 

6. Open the Create Template dialog by clicking on the Create Template icon.  

 

7. From the tree view right click on the SR817_4_RD Template and click Copy.   

8. Right click on the folder, click Paste and then rename the template SR817_5. 

9. Right click on the SR817_5 template and select Set Active.  

10. Click on the Active Template tab and uncheck the Display All Components box in the Display area 

of the Create Template dialog. 

  



WIDENING, MILLLING & RESURFACING - Modify Design Template with Inserted Points _________________________ Chapter 9 

FDOT Corridor Modeling  ©2014 FDOT  9-5 

 To turn off the display of Components in the Active Template tab of the Create 
Template dialog 

1. Expand the Components folder, right click each of the “TS_” components in the list and click 

Displayed.  This will toggle off the each of the Traffic Separator components displayed in the view.  

 

2. Also, right click on the RT_XOverPvt and toggle off the display of the Crossover Median. Since the 

RT_XOverPvt is the parent of the LT_XOverPvt, both sides toggle off together. 

 <OR> right click on the LT_XOverPvt and toggle off the display of the Crossover Median on the left 

side. 

 

 To add the widening targets for the left inside roadway 

1. Zoom into the left side of the template and right click on the LT_CURB_TP_IN point, click Edit.   

 

2. In the Point Properties dialog, change the Parent 1: Horizontal Constraint to be applied from the 

Lt_PVT_EOP_IN point and change the Value to 1.0.  
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3. Also, change the Style Constraint feature list selection from Milling Limits to Pavement – 

Proposed, click Apply to save the changes and then Close the Point Properties dialog.  

 

4. Select File > Save to save the changes to the Template Library.  

5. Toggle on the Dynamic Settings dialog and check the Apply Affixes box.  

 

 Bookmark INSERT POINT  

1. Right click on the LT_CurbInWidenPvt component next to the LT_CURB_TP_IN point and click 

Insert point.  
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2. Float a point in between the LT_PVT_EOP_IN and the LT_CURB_TP_IN points. Use a data point 

to insert a point, right click and then right click again and select Finish to store the point. 

 

Note There is a problem with the software that appears in the Active Template tab of the 
create template dialog; all the components re-display after an inserted point. 

3. Right click on the new inserted point and click Edit Point.  

4. From the Point Properties dialog, change the name to LT_ML_IN and set the following:  

Point Name  LT_ML_IN  

Check Use Feature Name Override LT_ML_IN  

Constraint 1 Slope LT_PVT_EOP_IN 2.0% 

Constraint 2 Horizontal LT_PVT_EOP_IN 0.90 

Style Constraint  Milling Limits  

Label  none  

Range Horizontal 35  

5. Right click on the LT_CURB_TP_IN point and click Edit Point.  From the Point Properties 

dialog, change the Constraint to target the new LT_ML_IN point.  The values should be: 

Point Name  LT_CURB_TP_IN  

Check Use Feature Name Override LT_CURB_TP_IN  

Constraint 1 Slope LT_PVT_EOP_IN  2.0% 

Constraint 2 Horizontal LT_ML_IN 0.10 

Style Constraint  Pavement – Proposed  

Label  none  

Range Horizontal 35  
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6. Click Apply and Close the Point Properties dialog. Save the Template Library. 

7. Next insert another point directly below the inserted milling point, right click on the component and 

click Insert point. When the Component Selection dialog appears, click the 

LT_CurbInWidenPvt.  

  

8. Place the point, right click and click Finish.  

9. Right click on the point and click Edit Point to open the Point Properties dialog.  Change the 

dialog as follows: 

Point Name  LT_ML_BOT_IN  

Check Use Feature Name Override LT_ML_BOT_IN  

Constraint 1 Horizontal LT_ML_IN 0.0 

Constraint 2 Horizontal LT_ML_IN -0.5 

Style Constraint    

Label  EOP_PVT ThickLt  

10. Click Apply and Close the dialog to save the changes. Save the Template Library 
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11. Next insert another point directly below the inserted LT_ML_BOT_IN point, right click on the 

component and click Insert point. When the Component Selection dialog displays, click the 

LT_CurbInWidenPvtBase.  

  

12. Place the point, right click and click Finish.   

13. Right click on the point and click Edit Point to open the Point Properties dialog.  Change the dialog 

as follows: 

Point Name  LT_ML_BASE_BOT_IN  

Check Use Feature Name Override LT_ML_BASE_BOT_IN  

Constraint 1 Horizontal LT_ML_BOT_IN 0.0 

Constraint 2 Horizontal LT_ML_BOT_IN -1.0 

Style Constraint    

Label  EOP_Base ThickLt  

14. Click Apply and Close the dialog to save the changes. Save the Template Library. 

15. The results should resemble the image below. 
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16. REPEAT this procedure for the milling targets on the left outside roadway, right inside roadway and 

the right outside roadway.  Use the Point Name Convention from below and save the Template 

Library after each point is added.  Follow the steps outlined above.  

 Go back to the bookmark Insert Point.  

Use the following guidelines: 

a. Change each of the existing outside and inside points to target the widening Style Constraint, 

Pavement-Proposed.  

b. Insert each point on the correct component nearest the curb or traffic separator location. 

c. Construct each new TOP point to be a Horizontal constraint and Vertical constraint from 

the PVT_EOP _IN (PGL control point) and to target the Milling Limits Style Constraint. 

Use the same range value as the widening points.  

d. Change each of the existing TOP outside and inside points to be a Horizontal constraint and 

Vertical constraint from the new ML point, Horizontal = (+/-)0.10, slope = Vector 

Offset(inside), (+/-) 2.0%(outside). 

e. Include the Label for each of the Middle and Bottom points. 

f. Save the Template Library after each point is added. 

Location Left Outside Left Inside Right Inside Right Outside 

Top LT_ML_OUT LT_ML_IN RT_ML_IN RT_ML_OUT 

Middle LT_ML_BOT_OUT LT_ML_BOT_IN RT_ML_BOT_IN RT_ML_BOT_OUT 

Bottom LT_ML_BASE_BOT_OUT LT_ML_BASE_BOT_IN RT_ML_BASE_BOT_IN RT_ML_BASE_BOT_OUT 

17. For the new points at the Traffic Separator use the table below: 

LOCATION Left Inside Right Inside 

Top LT_ML_IN1 RT_ML_IN1 

Middle LT_ML_BOT_IN1 RT_ML_BOT_IN1 

Bottom LT_ML_BASE_BOT_IN1 RT_ML_BASE_BOT_IN1 

18. Save the Template Library. 
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Exercise 9.2 Differentiate Widening from Resurfacing 

In this exercise the template will have new components added and constrained to the points created in the 

prior exercise. The components will accommodate widening on the inside and outside of the milling limits 

for each roadway. Since components cannot be inserted on templates, this step is included prior to deleting 

the older components.  

1. From the tree view, right click on the SR817_5 Template and click Copy.   

2. Right click on the SR817 Template folder, click Paste and then rename the template SR817_6. 

3. Right click on the SR817_6 template and select Set Active.  

4. From the Create Template dialog, select Tools > Options and set the Template Options dialog as 

shown in the image below. Click OK to close the dialog.  

 

5. Zoom into the inside widening area of the left roadway.  

6. Right click on the template window and select ADD New Component > Constrained. 

 



Chapter 9 _____________________________ WIDENING, MILLLING & RESURFACING - Differentiate Widening from Resurfacing 

9-12 ©2014 FDOT  FDOT Corridor Modeling 

7. In the Name: field, key in LT_TSInWidenPvt1 and from the Style: list, select XS - Proposed 

Ground Line,  

 

8. Right click in the view and check Closed Shape. If already checked hit the Escape (Esc) Key. 

 

9. Select the four points shown below that define the widening pavement, right click and click Finish.  

  

10. Right click on the template window and select ADD New Component > Constrained.  

11. In the Name field key in LT_TSInWidenBase1 

12. From the Style pull down list, select the XS - Proposed Base Line.  
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13. Select the four points shown below that define the widening base, right click and click Finish.  

 

14. Save the Template Library. 

15. Zoom into the outside widening area of the left roadway.  

16. Save the Template Library. 

17. Repeat the ADD New Component > Constrained procedure for the each of the components listed in 

the table below. Use the following naming convention for the new components: 

 Left Outside Left Inside Right Inside Right Outside 

Outside Widening 

at Curb 

LT_CurbOutWidenPvt 

LT_CurbOutWidenBase 

  RT_CurbOutWidenPvt 

RT_CurbOutWidenBase 

Inside Widening at 

Curb 

 LT_CurbInWidenPvt1 

LT_CurbInWidenBase1 

RT_CurbInWidenPvt1 

RT_CurbInWidenBase1 

 

Inside Widening at 

Traffic Separator 

 LT_TSInWidenPvt1 

LT_TSInWidenBase1 

RT_TSInWidenPvt1 

RT_TSInWidenBase1 

 

Note Use the undo and Redo icons to make corrections while editing templates.  

 

18. Save the Template Library. 
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Exercise 9.3 Assign Parent Components, Delete Base Components  

In this exercise the new widening template components will be associated with other template components 

using Parent Component Properties. This step is necessary for the new components to inherit the variable 

template display rules created in the previous chapter for this project. The un-needed base components will 

then be deleted for both roadways.  

1. From the tree view right click on the SR817_6 Template and click Copy.   

2. Right click on the Template folder, click Paste and then rename the template SR817_7. 

3. Right click on the SR817_7 template and select Set Active.  

4. Right click on the LT_CurbBaseOutside component, select Edit Component. Change the 

Components Properties dialog to have the Parent Component as the LT_CurbTypeF. 

 

5.  Right click on the RT_CurbBaseOutside component, select Edit Component. Change the 

Components Properties dialog to have the Parent Component as the RT_CurbTypeF. 
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6. Assign the TS_Display as the Parent Component to the new widening Pavement and Base 

components for each side of the Traffic Separator. 

 

7. Assign the LT_CurbTypeE1 as the Parent Component to the new left side widening Pavement and 

Base components.  

 

8.  Assign the RT_CurbTypeE1 as the Parent Component to the new right side widening Pavement 

and Base components 
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9. Reassign the LT_CurbBaseInside in the Component Properties dialog to have the Parent 

Component as the LT_CurbTypeE1. 

 

10. Reassign the RT_CurbBaseIn in the Component Properties dialog to have the Parent Component 

as the RT_CurbTypeE1. 
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 Delete the Base Components 

1. Zoom into the left roadway. 

2. Right click on the base component, LT_PavementBase2%Outside, and select Delete Component. 

  

 

3. Delete the base components for both the Curb Median and Traffic Separator inside widening on the 

left roadway:  LT_CurbInWidenPvtBase, LT_TSInWidenPvtBase 

4. Delete the main base component and the inside widening base components on the right roadway: 

RT_PavementBase2%Outside, RT_CurbInWidenPvtBase, RT_TSInWidenPvtBase 

5. Delete the base components for the crossover median pavement: LT_XOverPvtBase, 

RT_XOverPvtBase 

Note When these step are completed, the only base components remaining will be for the 
curbs and the new pavement widening components. 
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Exercise 9.4 Adding Milling, Overbuild and & Overlay Components 

In this exercise the template will have new milling, overbuild and overlay components added. Standard 

resurfacing components are located in the FDOTSS2 template library. These components will be added in 

place of the pavement and base components and will accommodate milling and overbuild between the 

inside and outside of the milling limits for each roadway.   

1. From the Create Template dialog select Tools >Template Library Organizer 

2. For the Available In: folder on the right side, navigate to the  

C:\FDOTSS2\GEOPAK\corridor\FDOTSS2.itl folder and click Open.  

3. In the Template Library Organizer dialog , open the FDOT templates folder and navigate to the 

Cross Slope Correction folder shown below:  

 

4. Drag the 12’ Resurfacing 1 1/2” Depth CSC template over to the project template library and place 

it in the SR817 Components folder.  

5. Also drag the Resurfacing Shoulder CSC  template over to the project template library and place it 

in the SR817 Components folder 

6. Click OK to close the Template Library Organizer dialog. Click Yes to save the data.  

7. Double click on the 12’ Resurfacing- 1 1/2” Depth CSC template to display it in the main view.  
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8. Right click on the bottom side of the shape and select Edit Component. The Component Selection 

dialog will open.  

 

Note This template is a composite of 3 required components for Resurfacing: Milling, 
Overbuild, and Overlay.   

9. Press the Esc key to release the Component Selection dialog. 

 To illustrate how these components work together: 

The Basic Template created in the previous exercise will be modified with the resurfacing components.  

1. Make a copy of the Basic Template and rename the template Cross Slope Correction.  

2. Set Active the Cross Slope Correction template  

3. Drag the 12’ Resurfacing- 1 1/2” Depth CSC template with the Mirror option checked, onto the 

Cross Slope Correction template at the center point. 

4. Drag the Resurfacing Shoulder CSC template with the Mirror option checked, onto the Cross 

Slope Correction template at the shoulder point. 

5. Delete the pavement, base, and shoulder component copied from the Basic Template  The Cross 

Slope Correction template should look as follows  
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6. Click the Test button to open the Test End Conditions dialog.  

7. Click on the Draw button in the Test End Conditions dialog to view how the resurfacing 

components are constructed based on where the exiting surface is located.  The light blue is the 

required milling, yellow is the required overbuild and gray is the overlay. Some of the colors overlap.  

 

8. Time permitted; repeat this exercise with the resurfacing components from the Match Existing 

folder.  

 

 To add the Resurfacing components to the SR817 Project Template 

1. Locate the MILL_EVAL_CP point, right click and select Delete Point.   

2. Copy and Paste 12’ Resurfacing- 1 1/2” Depth CSC template to the SR817 Components folder. 

Rename the template with the prefix “Inside “and the individual components with the prefix 

“InsidePavement” instead of “Pavement”.  

   

 

3. In the SR817 Templates folder, Copy and Paste the SR817_6 to a new template and Rename the 

template SR817_7.  

4. Right click on the SR817_7 Template and click Set Active. 
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5. Toggle On the Dynamic Settings dialog, Apply Affixes should be checked.  

6. Zoom into the left roadway, Display Point Names should be checked to view the LT_PVT_EOP_IN 

point.   

7. Drag the 12’ Resurfacing- 1 1/2” Depth CSC template onto the view and Right click on the 

template window and select Reflect. Place the template on the LT_PVT_EOP_IN point.  

 

8. Zoom out enough to view the left side of the added components. Right click on the 

LT_PVT_OLAY_OUT point and select Delete Horizontal Constraint. 

9. Right click on the LT_PVT_OLAY_OUT point again and select Add Constraint > Horizontal. At 

the prompt choose the LT_ML_OUT point of the template.  Change the Offset on the Add 
Horizontal Constraint dialog to 0.00 and choose OK.  

 

10. Right click on the   LT_ML_OUT point and select Merge Points, Delete the 

LT_PVT_OLAY_OUT point.  
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11. Right click on the LT_Pavement2%Outside component and select Delete Component.  

 

12. Repeat the procedure and add the Resurfacing Components on the left side widening. Use the 

Inside Resurfacing- 1 1/2” Depth CSC template. 
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13. Edit the Component Properties for the 3 inside widening resurfacing components and add the 

TS_Display as the Parent Component. This step will associate the inside resurfacing with Traffic 

Separator display condition. The three components to edit are:  

a. LT_InsidePavementOverlay 

b. LT_InsidePavementOverbuild 

c. LT_InsidePavementMilling 

 

14. Repeat the procedure and add the Resurfacing Components on the right roadway. Use the 12’ 

Resurfacing- 1 1/2” Depth CSC template. Remember to Merge Points and Delete Component. 

 

15. Repeat the procedure and add the Resurfacing Components on the right side widening segment. Use 

the Inside 12' Resurfacing- 1 1/2” Depth CSC template.  Remember to Merge Points and Delete 

Component. 
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16. Edit the Component Properties for the 3 inside widening resurfacing components and add the 

TS_Display as the Parent Component. This step will associate the inside resurfacing with Traffic 

Separator display condition. The three components to edit are:  

a. RT_InsidePavementOverlay 

b. RT_InsidePavementOverbuild 

c. RT_InsidePavementMilling 

 

Note The template should now look as shown below.  
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17. Repeat the procedure and add the Resurfacing Components on the Crossover Median.  

 Use the Inside 12' Resurfacing- 1 1/2” Depth CSC template.  

 Drag the new resurfacing components approximately 1 foot above the final Crossover Median and drop 
them first. Make sure to use care to drop the right side, right of the 0 line, to ensure the RT_ affixes are 
applied.  

 

18. Use the Active Template tab to turn off components. Open the Components folder and right click on 

the component name in the list and uncheck the Displayed. 

 

19. Uncheck all the traffic separator and curb types. Then move the components into place 

 

20. Remember to Merge Points and Delete Component. Leave the PVT-CROWN, LT_PVT_EOP_IN 

and RT_PVT_EOP_IN points. 
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21. Edit the Component Properties for the Milling Crossover segments and add CrossoverMedian 

AND NOT TS_Display as the Display Rule. There are a total of 6 components that need this rule:  

a. LT_InsidePavementOverlay1 

b. LT_InsidePavementOverbuild1 

c. LT_InsidePavementMilling1 

d. RT_InsidePavementOverlay1 

e. RT_InsidePavementOverbuild1 

f. RT_InsidePavementMilling1 

  

22. Save the template.  

23. Repeat the procedure and add the resurfacing components for the inside curb median widening 

components.  Use the Inside 12' Resurfacing- 1 1/2” Depth CSC template.  

 Use the Inside 12' Resurfacing- 1 1/2” Depth CSC template.  

 Drag the new resurfacing components approximately 1 foot above the Inside Curb Median and drop them 
first.  Make sure to use care to drop the right side, right of the 0 line, to ensure the RT_ affixes are applied.  
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24. Use the Active Template tab to turn off components. Right click on the Components folder in the list 

and uncheck the Displayed check.  Then Right click on the RT_CurbTypeE component in the list and 

check the Displayed check 

   

Note This will display only the all Curb Median With Widening Components established from 
parent relationships in the previous exercises  

 

25. Right click on the top end points and  move the components into place using the edit point properties. 
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26. Add the RT_CurbTypeE1 as the Parent Component for the right side resurfacing components.   

 

27. Add the LT_CurbTypeE1 as the Parent Component for the left side resurfacing components  

  

28. Toggle back to the Library tab and fit the template view.  The template should look as follows. 

 

29. Save the Template Library 

30. Use the Test button to check the display conditions. 

31. Remember to move the move the ML_IN and ML_IN1 points back to .05 inside of the 

EOP_PVT_IN points.  
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Exercise 9.5 Apply Template to Corridor  

1. Open the Roadway Designer dialog and select File > Open the SR817.ird file to load the project 

Mainline Corridor design. 

2. From the Corridor drop down list, select SR817.   

3. Click the Template Drops icon  to open Template Drops dialog.  

4. Select the Current Template Drops entry and change the template entry to the SR817_7 Template, 

click Change to save the entry and then close the dialog.  
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5. DELETE Super Section Ranges and ADD NEW Section Range Definitions as shown in the 

diagrams below. 

    

6. To validate or test the template widening along the corridor, from the Roadway Designer dialog, 

select Corridor > Display References.  The Display References dialog displays.  

7. From the Alignment list, select the EOP item, check on the Display as Right of Way box and then 

click the Add button.   

8. From the Alignment list, select the ML item, check on the Display as Right of Way box and then click 

the Add button. Close the dialog. 
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9. From the Roadway Designer Options dialog, click the Options icon , check on the Reference 

Graphics box in the Display area and then click OK. 

  

10. Use the Cross Section view to step through the stations on the corridor.  Use the mouse hover tool to 

see the name of the Reference Graphic lines.  
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 If the template is not working properly:  

1. From the Roadway Designer dialog, click the shortcut  icon, to open the Create Template 

dialog. Make changes to the template as necessary.  

a. The style constraint ranges may need to be changed when the curb and traffic median cross 

itself.  

b. Insert points on the widening pavement at the bottom of the overlay layer. Use Add Full 

Constraint and then Merge Points and Delete the inserted point. This will associate the bottom 

of the overlay with the widening pavement.  

c. Check the Component Properties dialog for all added components in this exercise for the 

same Name and Name Override .   

d. Check the Point Properties dialog for all added component points in this exercise for the 

same Name and Name Override. 

 

2. Click OK to save the changes, select File > Save to save the Template Library and then click Close 

to exit the Create Template dialog. 

3. From the Roadway Designer dialog, open the Template Drops dialog and select the Current 

Template Drops entry. Notice the Template name is red which indicates that the Template Library 

version of the template has been changed.  

4. Click the Synchronize with Library button and close the dialog.  
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VERTICAL ADJUSTMENTS 

Exercise 9.6 Vertical Adjustments Settings 

1. If Exercises 9.1-9.5 were skipped to learn the Vertical adjustments, extract the 22807915201(10).zip 

file in the c:\e\projects folder 

2. From the Roadway Designer dialog, change the Display Mode in the bottom right side to Overlay. 

An additional view will display similar to Superelevation Display Mode and the Overlay Tools pull 

down will be enabled. 

 

 

Note Each of the dialogs listed in the Overlay Tools list has a Help button to link to the 
Reference Information for that dialog. 
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3. Open the Roadway Design Options dialog, check only the Horizontal Cardinal Points in the 

Include Critical Sections area and then click OK. 

4. Click the Process All button.  

Note Allow this process to complete. It may take several minutes.  

5. Prior to creating a Vertical Adjustment, review the cross sections to evaluate how the Milling and 

Overbuild have been applied to the project based on the current template settings and vertical 

alignment design.  

6. From the Roadway Designer dialog, select the Tools > Milling Report option.  

 

Note In order to generate a report of the milling surface area, place a check in the Stripping 
Component box on each of the milling component in the template.  Save the Template 
Library and Resynchronize the Template Library with the Template Drops list.  

7. A Milling Report by Station will be generated. This an xml format file using the format file delivered 

with GEOPAK Corridor Modeling. 
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8. Record the final Planar Area for this run.  

 

9. From Roadway Designer dialog, select the Overlay Tools > Vertical Adjustment Setting.   

10. Set the Backbone to 2/12 <OR> .1667. 

11. Check the Maximum Milling box and set to 2/12 <OR> .1667. 

12. Set the Template Range to Left Point to LT_ML_OUT and the Right Point to RT_ML_OUT.   

13. Change the Station Range to begin at 73+00. 

  

14. Click OK and then click the Process All button. 
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15. Wait then review the cross section.  

16. From the Roadway Designer dialog, select the Tools > Milling Report option again and compare 

the final area result.  

 

17. Select Tools > Approximate Component Quantities to get a report of the computed quantities.  
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18. From the Component Properties dialog, edit the Template again and change the Milling 

Component depth to 2/12 <OR> .1667 for each of the Milling Components in the template.  

 

19. Click Apply and Close.  

20. Save the Template Library and Resynchronize the Template Library with the Template Drops list.  

21. In the Vertical Overlay Adjustment Setting dialog, select the Use Minimum Milling option and 

reset the Start Station value to 73+00.  

  

22. Click OK and then click Process All.  
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23. Wait and then review the cross section.  

24. From the Roadway Designer dialog, select the Tools > Milling Report option again and compare 

the final results.  
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10 CROSS SECTIONS & LABELING 

INTRODUCTION 
Historically, proposed cross sections were created using criteria after the existing ground sections were cut 

from a TIN file utilizing the Draw Cross Sections from Surfaces tool. The Corridor Modeling method does 

not automatically draw the proposed cross sections into a MicroStation design file like the criteria method. 

The Draw Cross Sections from Surfaces tool is used to draw both the existing ground surface and proposed 

cross sections into the MicroStation graphics file at the same time. This tool is an enhanced version of the 

tool included previously in GEOPAK. 

A new feature of the tool is support for a DTM created by Roadway Designer. Proposed cross sections 

created from a Roadway Designer DTM include all template components (pavement layers, shoulders, 

sidewalk, tie slopes, etc.), thus eliminating the need to select by features from the FDOT ddb file.  

ACCESSING THE DIALOG 
The dialog is invoked via the GEOPAK Road Tools or menus as always but for convenience it can also 

be invoked by clicking the Draw Cross Sections from Surfaces icon on the Corridor Modeling dialog. The 

tool works exactly the same no matter where it is accessed from. 

PREREQUISITES 
The prerequisites to generate cross-sections utilizing digital terrain modeling are: 

GEOPAK coordinate geometry database wherein the horizontal and vertical alignments are stored. 

Binary GEOPAK TIN file or a DTM created with Roadway Designer. 

Each surface to be drawn must be added to the list box. This is accomplished by using the action / edit 

buttons on the right side of the dialog. Each surface draws a cross section line or line string. When the list 

box is populated, clicking Draw in the upper right corner commences the processing. 

The generation of existing ground cross sections must be invoked from within the MicroStation design file 

wherein the sections are to be drawn. GEOPAK does not create this MicroStation design file. 

CROSS SECTION SYMBOLOGY 
Existing ground symbology is controlled from “By Level Symbology” or “By Feature”. 

Proposed cross section symbology is controlled by Roadway Designer. The same symbology that is used 

in Roadway Designer to display the design template will also be used to draw the proposed cross 

sections. Symbology must be set in the Draw Cross Sections from Surfaces dialog but that setting will 

be ignored when the cross sections are processed. 

Cross Section point symbology is controlled by the active MicroStation settings when the cross sections 

are processed. 

The Pattern Lines Even-Increment distance for cutting cross sections needs to match, or be evenly divisible 

by, the Corridor Interval that is set for the Template Drops in Roadway Designer. If these settings do not 

match then the cross sections that are cut will be an interpolation and could affect the earthwork. 
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EXERCISE OVERVIEW 
10.1 Create Surface DTM & TIN 

10.2 Review Pattern Lines & Existing Cross Sections 

10.3 Review Pattern Lines 

10.4 Reviewing Cross Sections 

10.5 Draw Proposed Roadway Cross Sections    

10.6 Label Cross Sections  

10.7 Cross Section Sheet Layout with Earthwork  

Exercise 10.1 Create Surface DTM & TIN 

In this exercise the proposed roadway design file, RDXSRD02.dgm, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the project. 

The Corridor Modeling dialog is loaded and the project preferences are loaded from the previous 

exercises. Roadway Designer is opened and the project designer (.ird) file is loaded.  The Create 
Surface dialog is loaded and the proposed DTM is created.   

1. Optional, extract the 22807915201(10).zip file in the c:\e\projects folder. 

2. Open the FDOTSS2 MicroStation workspace in the cross sections project design file 

c:\e\projects\22807915201\roadway\ RDXSRD02.dgn. 

3. From the MicroStation menu, open the Corridor Modeling dialog by selecting Applications > 

ROAD > 3D Tools > Corridor Modeling. 

4. Select Job Number job791.gpk.  
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5. Load preference file SR817.rdp. 

 

6. Click on the Open Roadway Designer icon to launch the Roadway Designer dialog.  

7. From the Roadway Designer dialog, select File > Open and select the SR817.ird file. Click the 

Open button. 

 

8. From the Roadway Designer dialog, select Corridor > Create Surface and the Create Surface 

dialog will display.  
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9. In the Create Surface dialog, key-in SR817 in the Name: field and ONLY check the Empty Design 

Surface and Horizontal Curves boxes. 

  

10. Click the Apply button. This will execute the command to create a new .tin and .dtm file in the 

project roadway folder.   

11. When the dialog finishes processing, close the Create Surface dialog. Close the Roadway 
Designer dialog.  

12. Close the Corridor Modeling dialog and then click No to Save Setting.  
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Exercise 10.2 Review Pattern Lines & Existing Cross Sections 

 Reviewing Pattern Lines 

In this exercise, the user will review the pattern lines locations for the cross sections. 

1. In the design file c:\e\projects\22807915201\roadway\RDXSRD02.dgn. 

 Change the active model to Pattrd. Attach as reference files, DSGNRD01.dgn and ALGNRD01.dgn to 
the model. 

 

2. Access Project Manager.  The Road Project dialog should appear since we “remembered” the 

project and user in a previous exercise. 

3. From Road Project, click the Draw Pattern button.  

 

4. Select the XSPATT run and click OK in the Run dialog. The Draw Pattern Lines dialog displays. 

5. Review the settings in the each of the fields. 

 The Dialog information is populated automatically by the Working Alignment Definition. 

  

6. Close the Draw Pattern Lines dialog.  

7. Click Yes when prompted to Save Settings. 

8. Minimize the Road Project dialog and fit the contents of the view.  
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 Reviewing Cross Sections 

In this exercise, the Cross Section Navigator tool will be used to review the existing cross sections. 

1. In the design file RDXSRD02.dgn, change the Active Model to Rdxsrd. Minimize the Road Project 
dialog. 

 

2. From the Road toolbox, click the Cross Section Navigator icon. 

 

<Or>  From  the MicroStation menu, select GEOPAK > ROAD > Cross sections > Navigator 
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3. The Cross Section Navigator displays. 

 
 

4. Use the navigation buttons to browse through the cross sections. 

 

<OR> Use the Station List pull down to access any particular station. 

 

5. Close Cross Section Navigator.  

Exercise 10.3 Review Existing Utilities on Cross Sections 

For this exercise, existing utilities have been pre-drawn onto the cross sections using the Draw Ancillary 
Features application. For instructions on drawing existing utilities on cross section, see the FDOT 

Advanced GEOPAK for Roadway Designers Course Guide, chapter 3. 

1. Review the cross sections and utilities using Cross Section Navigator. 
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Exercise 10.4 Loading Existing Features on Cross Sections  

For this exercise, existing cross section features have been pre-drawn onto the cross sections using the 

Typical Section Generator, a tool which allows users to automatically access and setup the appropriate 

criteria for our cross sections. For instructions on drawing existing features on cross section, see the FDOT 

Advanced GEOPAK for Roadway Designers Course Guide, chapter 6. 

1. Review the cross sections and note the existing features drawn on the cross sections.  

 

Exercise 10.5 Draw Proposed Roadway Cross Sections 

In this exercise, the proposed roadway cross sections can be generated by two methods.  

1. Method 1: 

a.  From Road Project dialog, select the Existing Ground Cross Sections button.  

 

b. Select XSGROUND in the Select Run dialog and click OK. 
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c. The Draw Cross Sections dialog displays. 

  

 The XS Cells tab portion of the dialog is already filled out by the Working Alignment Definition. 

d. Continue to the Both Methods Label  <OR> 

2. Method 2: 

a. Click the Draw Cross Sections from Surfaces icon on the Corridor Modeling dialog. 

 

b. Select XSGROUND in the Select Run dialog and click OK.  

 The XS Cells tab portion of the dialog is already filled out by the Working Alignment Definition. 
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3. Both Methods 

a. Select the Surfaces tab  

 The Surfaces tab portion of the dialog is already filled out for the Existing Ground Surface by the Working 
Alignment Definition. 

 

 Add Proposed Surface 

1. Under Details Section: Toggle the Tin file: button to DTM File.  Click on the magnifier icon and 

select SR817.dtm. 

2. Under Display Settings:  Set the list to By Level Symbology. 

Note The symbology for the proposed sections is controlled by the component styles defined 
in the XIN file. 

3. Click the Add Surface button.   

Note The template point names that are displayed in Roadway Designer will be plotted on 
each cross section. The symbology of these points is controlled by the active 
MicroStation settings.  

  



CROSS SECTIONS & LABELING - Draw Proposed Roadway Cross Sections__________________________________ Chapter 10 

FDOT Corridor Modeling  ©2014 FDOT  10-11 

4. Select File > Save As to save the Draw Cross Sections Preferences, name the file SR817. 

 

5. To save the information to the Working Alignment Definition, from the Road Project dialog click 

the Define button and set the Proposed Finish Grade option in the tree view as follows and click OK.  

 

Note In order to control the size and level display of the component point name display 

6. Set the Active Level to Scratch1_dp 

7. Set the Active Text size to .05, from the MicroStation Key-in: TX=.05. 
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8. Set the Active Text Scale to 1, from the MicroStation Key-in: AS=1. 

 

9. To Process Cross Sections, click the Draw button on the Draw Cross Sections dialog. 

10. Click the Delete All Existing Elements and Redraw on the Update Option dialog. Click Apply.  

 

11. Close the Draw Cross Sections dialog and click Yes to save the Setting. . 
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CROSS SECTION LABELING  

 Slopes 

 Elevations 

 Offsets 

A cross section labeling tool is provided in Corridor Modeling for labeling the different components of the 

template. Historically, this was accomplished with criteria. The cross section point labels that are plotted 

from Roadway Designer when the cross sections are generated are used in the labeling process. 

To label the slope of a component both end of the component must be identified. If a negative sign is 

desired in the label, identify the piece of text with the highest elevation first. 

To label an elevation and/or offset, only one piece of text needs to be selected. 

ACCESSING THE DIALOG 

The dialog is invoked by clicking the Cross Section Labeling icon on the Corridor Modeling dialog. 

 

 

 General Tab - This is where the Job Number, Chain Name, and Station range are entered. There is 

also a “Draw Labels” button that is used to draw the labels after the remainder of the dialog is 

populated with the desired labels. 

 Slope Label Tab - A “Start Point” and “End Point” is selected by clicking the ID button next to the 

respective field then identifying the desired piece of text. Click the Symbology button and enter 

the desired symbology for the label. Also toggle on the required “Slope Text Format” (there are 

several formats available). 

Once the information is entered it must be added to the list box though the Action / Edit buttons 

on the right side of the dialog. Add as many slope labels to the list box as needed. 
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 Elev/Off Label Tab - To label an elevation and/or offset click the ID button next to the point field 

then select the respective text associated with the location desired for the label. Set the “Elevation” 

option and/or the “Offset” option. Click the Symbology button and enter the desired symbology 

for the label. The “Slope Text Format” option is unavailable. 

Once the information is entered it must be added to the list box. This is accomplished via the 

Action / Edit buttons on the right side of the dialog. Add as many elevation and/or offset labels to 

the list box as needed. 

 Draw Labels - Once all the labels have been entered into the dialog, select the “General” tab then 

click the “Draw Labels” button. The labels are drawn on each cross section. 

 Preference File - The dialog settings can be saved in a preference file (.xpl) that can be recalled 

for use on other cross section files. 

Exercise 10.6 Label Cross Sections 

In this exercise the proposed roadway Cross Sections labels will be created and drawn on the Cross 

Sections in the design file, RDXSRD02. The Cross Section Labeling dialog is launched from the 

Corridor Modeling dialog.  The labels are defined from the point names drawn on the proposed roadway 

elements and stored in a preference file for the project. The point names are plotted when the proposed 

cross sections are plotted. They are drawn on the active level with the active text and active scale settings.   

1. Open the FDOTSS2 MicroStation workspace in the cross sections project design file 

c:\e\projects\22807915201\roadway\RDXSRD02.dgn. 

2. From the MicroStation menu, open Corridor Modeling dialog by selecting Applications > ROAD 

> 3D Tools > Corridor Modeling. 

3. Select Job Number job791.gpk.  
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4. Load preference file SR817.rdp  

 

 

5. Click the Cross Section Labeling icon on the Corridor Modeling dialog. 

 

6. Set the General tab: 

a. Select Job Number job791.gpk. 

b. Select Chain BL817. 

c. Change the Begin Station to 73+00. 
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7. Set the Slope Label tab: 

a. Click the ID button for the Start Point. 

b. Select the right inside pavement point text labeled RT_PVT_EOP_IN 

c. Click the ID button for the End Point. 

d. Select the right outside pavement point text labeled RT_PVT_EOP_OUT. 

e. Select the Symbology button then enter the desired symbology. 

f. From the Slope Label Attributes dialog, 

set the Level to TextXSSlopePvt_dp and 

Slope Text Format Option to 0.00%. 

 

 

 

g. Close the Slope Label Attributes dialog. 

h. Click the Add button. 

 

i. Repeat for the left pavement segments. 

j. Repeat the slope label steps for the cut/fill slopes on both sides. 

k. Set the Slope Text Format option to RUN:1. 

l. Save to a new preference file SR817. 
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8. Set the Elev/Off Label tab: 

a. Set the Elevation check box. 

b. Use the ID button to identify the text that represents the PGL of the right roadway, 

RT_PVT_EOP_IN. 

c. Click the Symbology button then enter the desired symbology. 

d. Close the Label Attributes dialog. 

e. Click the Add to List button. 

f. Repeat steps 1 to 5 for the cut/fill tide down points on both sides of the roadway. 

g. Save the preference file SR817. 

9. Select the General tab. 

a. Click the Draw Labels button. 

 

b. Review the labels. 

c. If there are additions or modifications to be made to the labels after the Draw Labels 

command is executed, use the MicroStation Select by Attribute dialog. Execute the levels 

for TextXS* and delete the elements.  

 

d. Re-Draw Labels as necessary.  
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Exercise 10.7 Earthwork Quantities 

In this exercise basic cut and fill earthwork will be processed for proposed cross sections. 

1. Open the design file c:\e\projects\228079115201\roadway\RDXSRD01.dgn.  

2. Access Project Manager. 

3. From Road Project, click the Earthwork button.  

 

4. Create a new run BL817. Select the BL817 run and click the OK button. The Earthwork dialog 

opens. 

 

5. Select XS DGN File. All of the information is populated by the Working Alignment. 

 

  



CROSS SECTIONS & LABELING - Earthwork Quantities __________________________________________________ Chapter 10 

FDOT Corridor Modeling  ©2014 FDOT  10-19 

6. Select Soil Types. 

 

7. Leave the Class set to Existing Ground. Key in the name Earth for the Soil Type. 

 

8. Enable the Use Working Alignment check box. 

 

  



Chapter 10 __________________________________________________ CROSS SECTIONS & LABELING - Earthwork Quantities 

10-20 ©2014 FDOT  FDOT Corridor Modeling 

9. Click the Add button to add Existing Ground to the Soil Type Items list box as shown. 

 

10. Change the class to Proposed Finish Grade, uncheck the Use Working Alignment Definition 

option, and check only the Lv Names option as shown. 
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11. Click the Select Levels button to the right of the Lv Names field. 

 

12. In the Level Name Search Filter dialog that appears, select the following level names: 

AsphaltMilling_px 

 Base_px 

 CandG_px 

 CandGBase_px 

 Driveway_px 

 DrivewayBase_px 

 Overlay1_px 

 Overbuild_px 

 ShldrUnpaved_px 

 Sidewalk_px 

 SidewalkBase_px 

 Slopes_px 

 TrafSeparator_px 

 TrafSeparatorBase_px 

 XSBaseTop_px 

 XSGrdLine_px 

13. Click OK. 
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14. Click the Add button to add Proposed Finish Grade to the Soil Type Items list box.   

15. Select Earthwork Shapes. 

 

Note The use of Draw Earthwork Shapes is optional. If it is desired to see the shapes place a 

check mark appropriately. When creating the cross section sheets, the shapes 

come also, so fill will have to be turned off under View Attributes. 

16. Enable the check box to Draw Earthwork Shapes. 

17. Enable the check box to Stratify Shape Color.      

 

18. Access the Set Feature dialog and set the symbology for the Earthwork Shapes as shown in the 

following figure. 

 

19. Click OK to close the Set Feature dialog. 
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20. Select Output Format. 

 

21. Set the End Area Decimal Places to 2. 

 

22. Select Centroid Adjustment and enable the check box.  
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23. Select Sheet Quantity. 

 

24. Enable the check box to Write Sheet Quantities File.     

25. Key in earth.txt in the ASCII File field.     

 

26. Click Add to add the Column 1 earthwork to the list box.   

 

27. Leave the Column set to 1 but change the EW Operation to Subgrade Exc. 
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28. Click Add to add the Subgrade Exc to the existing Column 1 earthwork. 

 

29. Change the EW Operation to Subsoil Exc.  

   

30. Click Add to add the Subsoil Exc to the existing Column 1 earthwork. 

 

31. Change the Column to 2. 

32. Set the Earthwork Operation to Common Exc. 

33. Set the Quantity Type to Unadjusted Volumes. 
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34. Click Add to add the Column 2 earthwork to the list box.  

 

35. Leave the Column set to 2 and change the Earthwork Operation to Subgrade Exc. 

36. Click Add to add the Subgrade Exc to the existing Column 2 earthworks. 

 

37. Leave the Column set to 2 and change the Earthwork Operation to Subsoil Exc. 

38. Click Add to add the Subsoil Exc to the existing Column 2 Earthworks. 

 

39. Change Column to 3. 

40. Change the EW Operation to Fill. 
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41. Click Add to add the Column 3 earthwork to the list box.     

 

42. Change the Column to 4. 

43. Set the EW Operation to Fill. 

44. Click Add to add the Column 4 earthworks to the list box.      

 

45. Select Files > Save Settings. 

46. Select Files > Run. 

47. Set the option To Log File and key in a log file name of earth.log. 

 

48. Click Apply to process the earthwork. 

49. When processing is complete, click Exit.     
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50. Close the Earthwork dialog. When prompted to Save Settings click Yes 

51. From the /roadway directory, review the file earth.log.    

 

52. From the /roadway directory, review earth.txt.   
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Exercise 10.8 Cross Section Sheet Layout with Earthwork  

In this exercise,  the cross sections are referenced onto sheets with the earthwork quantities. 

1. Open the design file c:\e\projects\228079115201\roadway\RDXSRD01.dgn. 

2. Change the active model to Rdxsrd_shg. 

 

3. Access Project Manager. 

4. From Road Project, click the Cross Sections Sheets button.  

 

5. Create a new run named BL817 and select the BL817 run and click OK. 

6. The Cross Section Sheet Composition dialog. 

Note When accessing the Cross Section Sheet Composition dialog for the first time and until a 
sheet DGN file is defined, the user will get the following Alert dialog. You will have to 
click OK 4 times to dismiss this dialog. 
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7. Select the sheet XSSHEET20_10EW Rt. 
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8. Select Sheet DGN file.  

 

9. Enable the check box for Detach Existing Sheets before Processing. 

 

10. Select or key-in RDXSRD02.dgn as the Sheet DGN file name. 

 

11. Select Earthwork Quantity Labels. 
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12. Select or key in the file name earth.txt for the Earthwork Quantity file. 

 

13. Select File > Save Settings.   

14. Click the Layout Sheets button. The cross sections will attach as reference files and be drawn on the 

sheets. 

 

 

15. Close the Cross Section Sheet Composition dialog. When prompted to Save Settings, click Yes. 

16. Review the sheets. 

 

 Modifying Cross Section Sheet Layout 

In this exercise, the user will save the Sheet Library to our project directory and then modify our sheet 

layout preferences. 

1. Access the previously created Cross Section Sheet run. 

2. Select File > Sheet Library > Save As. 
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3. Save the file in your \roadway directory using the name BL817.xssl as shown. 

 

4. The dialog will automatically update and begin to use the newly created BL817.xssl sheet library.  

 

5. Select Sheet Stack Orientation and change the Number of Sheets per Column to 5. 
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6. Select Station Labels and change the Station Label Y Offset to 10.  

 

7. Select Elevation Labels and change the Elevation Increment (mu) to 5. 

 

8. Select File > Sheet > Update. 

9. Select File > Sheet Library > Save. 

10. Click the Layout Sheets button. The cross sections will be laid out on the sheets. 

 

11. Close the Cross Section Sheet Composition dialog. When prompted to Save Settings, click Yes. 

12. Review the sheets.  

13. Exit MicroStation. 
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11 INTERSECTION DESIGN STEPS 

INTRODUCTION 
GEOPAK Corridor Modeling can be used to model proposed at grade intersections along a project.  This 

basic approach for intersection design, as documented, can be used on similar intersections with skew, 

orientation or number of lanes.  Some of the types include three-leg (T or Y), four-leg, multi-leg or 

circular. 

To begin, a mainline corridor for the project should be determined with consideration given to the cross 

roads intercepting or joining the mainline at or along the edge of pavement.  The approach to the design is 

to first design the mainline corridor through the intersection from left edge of pavement to right edge of 

pavement.  Next the crossroad baseline, profile and typical section design needs to have been defined.  

Below is a list of Corridor Modeling prerequisites to begin an intersection design 

 The mainline chain stored in the gpk file and then imported an alignment in Corridor Modeling 

with its corresponding profile grade line(s) 

 The mainline Corridor Modeling corridor design template and Roadway Designer files 

 The crossroad chain stored in the gpk file and then imported as an alignment in Corridor 
Modeling with its corresponding profile grade line.  

  The basic typical cross road section. 

Note Consideration should be given to whether the cross road profile in the intersections 
should match at the mainline profile grade line(s) or at the edge of pavement or some 
other location. For further information please refer to the Florida Intersection Design 
Guide located at:   

Note   http://www.dot.state.fl.us/officeofdesign/publications/.  

EXERCISE OVERVIEW 
11.1 Create an Intersection Design Corridor 

11.2 Create Quadrant Chain & Profile Alignments  

11.3 Create Vertical Tangents 

11.4 Importing Quadrant Chains & Profiles  

11.5 Create the Quadrant Templates 

11.6 Design Quadrant Alignments 

11.7 Create the Intersection Model 

 

INTERSECTION DESIGN MODELING 
For the class exercise, an at grade 4 legged intersection will be designed with the Corridor Modeling tools. 

This intersection is located at the crossing of Peter Road and SR817, Baseline Station 74+71.  

  

http://www.dot.state.fl.us/officeofdesign/publications/
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Exercise 11.1 Create an Intersection Design Corridor  

In this exercise the proposed roadway design file, DSGNRD01.dgn, will be opened with GEOPAK using 

the FDOT workspace and Project configuration. The GEOPAK Project Manager is loaded for the 

project. The Corridor Modeling dialog is loaded and the project preferences are loaded from the previous 

exercises. The Cross Road chain and profile are added to the imported geometry as alignments.  The 

Roadway Designer is opened and the project designer (.ird) file is loaded.  The Manage Corridors 

dialog is used to create a new mainline corridor with Station limits of the intersection to be modeled. Open 

the FDOTSS2 MicroStation workspace in the project roadway folder in the DSGNRD01.dgn file.  

1. Optional, extract the 22807915201(11).zip file in the c:\e\projects folder. 

2. Open the Corridor Modeling dialog by clicking on the  icon <OR> from the MicroStation 

menu, select Applications > GEOPAK > ROAD > Corridor Modeling. 

 

3. From the Corridor Modeling dialog, select File > Load. A browser window will appear in the 

current working design file directory. Select the SR817.rdp preference file to load. 

4. From the Corridor Modeling dialog, select Geometry from the tree list to display the Chains and 

Profiles that have been imported into the Corridor Modeling Alignments .alg file in the rddbs 

folder.  

5. Select the Chain Peter and the Profile Peter_PG from the list and then click the Add Chain to List 

icon to include it with those shown in the dialog below.  

  

6. Click the Import button and select File > Save to save the changes to the SR817.rdp file.   
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7. Open the Roadway Designer dialog, select File > Open, and then select the SR817.ird file to load 

the project mainline corridor design.   

Note Intersection designs are complex regions along a corridor and are best designed 
separate from the mainline. It is recommended to define the limits of the intersection and 
then design the intersection on separate mainline corridor. Once the intersection design 
is complete the corridors can be processed together.  

8. In the Roadway Designer dialog, select Corridor > Corridor Management to open the Manage 
Corridors dialog <OR> click the first icon under the menu list.  

9. Select the Mainline Corridor from the list and then check the Station box.  

10. Enter the intersection station limits and click Copy as shown below.  

 

11. Enter the New Name for the corridor as SR817_Peter, and click OK. The point control alignments 

for the left and right PGL lines will be copied. The templates drops list will also be copied.  

12. Close the Manage Corridors dialog. 
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13. Change the corridor drop 

down list to the new 

corridor for the 

intersection.  

 

 

 

 

 

 

 

 

 

 

 

 

 

14. From the Roadway Designer dialog, select Corridor > Template Drops to open the Template 
Drops dialog and select the entry in the Current Templates Drops.  

15. Change the Interval to 20 master 

units or feet, and then click Change. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16. Close the Template Drops dialog.   

17. Select File > Save to save the SR817.ird Roadway Designer file changes for the intersection 

project. 

18. Close the Roadway Designer dialog. 
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QUADRANT CHAIN & PROFILE ALIGNMENTS 

Exercise 11.2 Create Quadrant Chain & Profile Alignments 

In this exercise quadrant alignments and profiles will be created or loaded along each of the corner radius 

curves.  

1. From the MicroStation menu, select Applications > GEOPAK > ROAD > Geometry > Design 

Multicenter Curve <OR> from the Road Palette COGO button pullout.  

 

2. The Multicenter Curve Tool dialog will display. 
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3. From the Multicenter Curve tool settings, click the box next to the Store to GPK File label. 

 

4. In the Alignment section of the dialog, select the magnifier icon next to the Job: label and select the 

job791.gpk file when the Job Number dialog is launched.  

 

5. Double click on the field next to the By Level Symbology label to launch the Set Feature dialog. 

Change the Level to CLConst_dp. 
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6. To create radii chain PETER_NE and profile PETER_NE_PG for the NE quadrants, complete the 

dialog with the information shown in the images to follow.  
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7. Click the Apply button and move the cursor to the NE_quadrant of the intersection. The radius for 

the quadrant is constructed as temporary viewing graphics. Click a data point in the view to accept 

and store the new alignment definitions. 

 

8. When the Alert dialog opens.  Click Yes to redefine the chain and profile.  
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9. Close the Multicenter Curve tool settings. 

Note This table can be used with the Multicenter Curve Too to create each of the quadrant 
alignments for this intersection.  The dialog will create one alignment at a time. On the 
Vertical Tab, Use Pavement slope (2%) FOR EACH THE ENTRY GRADE AND EXIT 
GRADE. 

New Chain 
Start 

Sta. 
New Profile 

Entry 

Chain 

Entry 

Profile 

Exit 

Chain 

Exit 

Profile 

Entry 

Width 
Radius 

Exit 

Width 

Entry 

Grade 

Elev 

Exit 

Grad 

Eleve 

PETER_NE 1+00 PETER_NE_PG PETER 

PETER_PG 

PGL-RT 

PGL_RT 

44.092 40 36.62 4.46 5.45 

PETER_NW 1+00 PETER_NW_PG PETER 

PETER_PG  

PGL-LT 

PGL_LT 

47.26 40 49.415 5.50 5.49 

PETER_SW 1+00 PETER_SW_PG PETER 

PETER_PG  

PGL-LT 

PGL_LT 

52.5 50 37.61 5.38 5.54 

PETER_SE 1+00 PETER_SE_PG PETER 

PETER_PG  

PGL-RT 

PGL_RT 

45.235 50 47.548 4.45 5.31 

Note At some intersections the edge of pavement at the radius point will have a different 
station along the centerline on each side of the intersection cross road.  It is important to 
begin the quadrant alignments at the same cross road centerline location on each leg the 
intersection. This can be done by adding begin tangents segments to the quadrant 
alignments with the GOPAK COGO store graphics command. 
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 To Add /Create Tangent segments to the quadrant alignments  

1. Using the MicroStation Match Element command select the PETER_NE alignment stored 

previously.  The active ByLevel element should change to CLConst_dp. 

 

2.  Use Place Line to create a line from the alignment beginning to the intersection cross road limits.  

 

3. When this line is added to the alignment, the Begin Station will be changed to reflect the length of 

the line. Select the MicroStation Measure Length command to determine the exact length of the line 

placed. 
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4. Subtract the length from 100. This is the new Begin Station for the alignment. Use the table below to 

record the measured Segment Length and Begin Station calculations. 

QUAD Beginning 

POINT # 

Segment Length Begin Station 

PETER NE 100 18.50 0+81.4971 

PETER NW 200 21.86 0+78.17 

PETER SW 300 21.97 0+78.03 

PETER SE 400 1.025 0+98.98 

Note When using the Store Graphics command, turn off all the other elements levels near the 
elements to be stored.   Be sure that the COGO Redefine button is checked in order to 
overwrite the alignment with the new segment added. 

5. From the Road Project dialog click the Coordinate Geometry button to add the tangent segments 

to the quadrant alignment.  <OR> Select Applications > Road > Geometry > Coordinate 

Geometry. 
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6. The Coordinate Geometry dialog opens, check Redefine.  Close the Coordinate Geometry 

dialog. Minimize the Road Project dialog.  

 

7. Select Applications > Road > Geometry > Store Graphics. The Store Graphics dialog opens.  

 

8. From the Store Graphics dialog, select the Job file job791.gpk. Complete the dialog as shown.  
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9. Click on the ID Element and select first the tangent element and then the radius element. Once they 

are both highlighted, data point away from the graphics to accept. The Store button will become 

active. Click the Store button.  

 

10. An Alert dialog will open regarding the redefining of the alignment PETER_NE.  Select OK. 

 

11. Close the Store Graphics dialog 

Note The Multicenter Curve tool will generate a profile for the radius portion of the quadrant 
alignments. However, another segment will need to be added to match the Existing 
Ground Line and to match the Begin Station of the tangent segment added.  This is also 
necessary to verify the profile grade elevation of the curve at its tie into the mainline. 
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Exercise 11.3 Create Vertical Tangent 

 In this exercise a new Vertical Tangent will be added to the PETER_NE_PG profile created by the 

Multicenter curve Tool 

1. From the MicroStation Menu, select File > Open and select the DSPFRD01.dgn file.  

2. Select the Applications > GEOPAK > ROAD > Plans Preparation > Draw Profiles to display the 

quadrant profiles.. 

 

3. The Draw Profile dialog will display. 
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4. Select the Surfaces tab and follow the steps in the diagram below:  

a. From the Chain dropdown, select the quadrant alignment, i.e. PETER_NE.  

 

b. Click the Draw Profile Cell Control icon.  The Profile Cell Control dialog displays. 

c. Select the Active Chain, PETER_NE, and then click Add.  

 

d. Place a data point in the MicroStation file to add the profile grid axes.  
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5. From the Draw Profile dialog, select Feature: EPGL_50_5, browse for the site.tin, Method: 

Triangles, and then click the Add icon to add the proposed profile to the Profile Cell. 

 

6. Toggle to the COGO tab, select the Profile: PETER_NE_PG, select Feature: PPGL_50_5C and 

then click the Add icon. 

 

7. Close the Draw Profile and the Profile Cell Control dialogs.  
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8. From the Road Project dialog, select the Vertical Alignment button  

 

<OR> From the MicroStation menu, select Applications > GEOPAK > ROAD > Geometry > 

Layout profiles (VPI Based) <OR> select option 8 from the COGO tool palette. 
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9. Select the PETER_NE Chain, click the Identify Cell button and select the axis of the profile cell. 

Data point again to accept the profile cell.  

10. Key-in the Operator Code jd. 

 

11. Click the OK button to open the Profile Generator dialog.  

12. From the Profile Generator dialog, select File > Load Profile, select the Profile PETER_NE_PG, 

and then click OK.  This is the profile created by the Multicenter Curve tool and stored in the .gpk 

file.  
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13. In the Profile Generator dialog locate the section for the VPI  1, click the <<Insert button to add a 

VPI to the beginning of the profile, click the Dynamic button, and then key-in the beginning Station 

of the existing profile.  

 

14. Accept the snap to store the point to the profile. Click the Next button on the lower right corner of the 

dialog and change the Speed Setting to 15 and the L Value to 10.0.   

15. Click the Next button until the last VPI information can be viewed. Verify that the elevation is the 

same as the elevation calculated for the mainline PGL station and offset, in the exercise above.  

16. Select File > Save Profile. The change to the profile has been saved to the .gpk file.  

 

17. Close the Profile Generator dialog.  
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Exercise 11.4 Importing Quadrant Chains & Profiles 

In the next Steps the Quadrant Chains and Profiles will be added Imported for Corridor Modeling 

1. Open the DSGNRD01.dgn design file and open the Corridor Modeling dialog.  The smart update 

feature will display the Information dialog. 

 

2. Select the Geometry option on the tree list. Select the PETER_NE alignment from the Chain 

dropdown list and the PETER_NE_PG profile on the Profiles list. Click the Add icon to add it to 

the list. 

   

3. Click the Import button to include the quadrant alignment in the .alg file for the Corridor Modeling 

project.   

4. Repeat this for each of the quadrant Chains and Profiles. 

 .  

5. From the Corridor Modeling dialog, select File > Save to save the changes to the .rdp file.  
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QUADRANT TEMPLATES 

Exercise 11.5 Create the Quadrant Templates 

In this exercise the Create Template dialog will be used to create templates for the quadrant corridors. 

Using a copy of the project Typical Section template, components are deleted leaving only one half of the 

template on one side of the centerline.  The remaining pavement segment is changed to a small segment.  

The template origin is then changed to the edge of pavement line. This will allow for the pavement to 

stretch or warp itself around the corridor connecting with the crossroad and mainline edge of pavement. 

1. From the Corridor Modeling dialog, open the Create Templates dialog.  

 

 

2. From the tree list right click on the EXHIBIT TYP-5 Template and click Copy. 

3. Right click on the SR817 Templates folder and click Paste.  

4. Open the folder and rename the template INT_LT.  

5. Right click on the INT_LT Template and click Set Active.   
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6. Change the tab to Active Template, open the Display Rule folder, set the CurbBaseLt Displayed 

Value to 1.00 and then click OK. 

 

7. Change back to the Library Tab, right click in the Grid View and click Delete Components. 

 

8. Drag the cursor across each of the components right of the Left Pavement components.  There may be 

points to be deleted. Right click on each of the points and click Delete Point.  
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9. The remaining template will display as follows.  

 

10. Right click on the Outside Edge of Pavement Point and click Edit Point, the Point Properties dialog 

displays. Change the Type: Constraint 1 to None and Constraint 2 to None and uncheck the Style 

Constraint box.  

 

11. Click Apply and close the Point Properties dialog. 
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12. Right click on the Inside Edge of Pavement Point and click Edit Point. The Point Properties dialog 

will display. Change the following:  

Constraint 1 Horizontal 

Parent 1 LT PVT_EOP_OUT 

Value 0.1 

  

Constraint 2 Slope 

Parent 1 LT PVT_EOP_OUT 

Value 2.00% 

 

13. Click Apply and close the Point Properties dialog.   

14. Zoom in on the Outside Edge of Pavement in the Create Template dialog, right click on the 

Outside Edge of Pavement Point and then click Change Template Origin.  
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15. The template display will update outside of the limits. Click on the Fit View Icon.  

 

16. Edit the point properties for the Sidewalk: SW_FRONT_TOP and SW_BACK_TOP. 

17. Verify that the Horizontal Style Constraints are checked and the Horizontal Range Distance is set 

to +/- 25 feet. 
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18. Change the SW_FRONT_TOP Sidewalk Point Horizontal Distance to +/- 0.1 feet.  

 

19. Select File > Save to save the template to the project Template Library.  

20. Repeat the procedure for INT_RT <OR>  

21. To create the right side template, select File > New in the Create Template dialog. Name the 

template INT_RT.  

22. Right click on the INT_RT Template and click Set Active. 

23. Select Tools > Dynamic Settings to open the Dynamic Settings 

dialog, set the X and Y Step to 0.1 and then check the Apply 

Affixes box. 

 

 

 

 

 

24. Drag the INT_LT Template onto the window and right click and select Reflect to drop the template 

on the 0,0 origin point.  

Note The drag operation with Apply Affixes will copy the point names and component names 
from the original template AND append “RT_ “  to the beginning of each.  This results in 
RT_LT_ex_ex name format.  To avoid this use the delete components method described 
above.  

 

25. Select File > Save to save the project Template Library and close the Create Template dialog.  
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DESIGN THE QUADRANT ALIGNMENTS 

Exercise 11.6 Design the Quadrant Corridors 

In this exercise the Roadway Designer dialog will be used to create the corridor names for each of the 

quadrant alignments. The Template Drops dialog opened in Roadway Template will be used to add 

templates definitions to each of the quadrant corridors.  The Point Controls dialog. 

1. Open the Roadway Designer dialog, select File > Open and select SR817.ird. 

2. Open the Manage Corridors dialog by clicking the icon  <OR> select Corridor > Corridor 

Management. 

3. Key-in a New Name for the quadrant corridor, i.e. Peter_NW. Complete the dialog as shown below 

and click the Add button.  

 

4. Repeat this procedure for each of the Quadrant Alignments.   
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5. Close the Manage Corridors dialog  

6. In the Roadway Designer dialog, change the Corridor drop down list to a Quadrant Corridor, i.e. 

Peter_NE.  

 

7. Open the Template Drops dialog and select the INT_RT template, change the Interval setting to .5, 

click Add and then close the Template Drops dialog.  
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8. Click the Point Controls icon  <OR> from the Roadway Designer dialog, select Corridor > 

Point Controls. The Point Controls dialog displays for the Quadrant Alignment Corridor.  

9. From the Point drop down list, select the hanging top edge of pavement, *LT_LT_PVT_EOP_IN 

point depending on how the template was created previously. 

 

10.   Complete the dialog as shown below and then click Add. 

 

11. In order to complete the quadrant Corridor Modeling, the Transition Point Control Stations need to 

be determined. This can be accomplished with the Corridor Modeling smart target icons.  
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12. Hover over the Stop field of the Station Limits target icon. 

 

13. A tool tip appears “Hold down the CTRL key to select station from the drawing file”  

14. Follow the tip and pick the location in MicroStation where the radius point line intersects with the 

mainline edge of pavement. See the example below. 

 

15. Change the Control Type to Corridor Point and complete the dialog as shown below to add the 

remaining control for the template on the corridor. Close the Point Controls dialog.  Click File > 

Save the save to SR817.ird Roadway Designer project. 
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16. Select a different quadrant corridor and repeat this procedure for each quadrant. Use the tables below 

to complete the settings for each quadrant.  

Corridor Template 

Drop 

Control 

Descr. 

Point H Align V Align 

Peter_NE INT_RT Peter_CL LT_LT_PVT_EOP_IN Peter Peter_PG 

Peter_NW INT_LT Peter_CL LT_PVT_EOP_IN Peter Peter_PG 

Peter_SW INT_RT Peter_CL LT_LT_PVT_EOP_IN Peter Peter_PG 

Peter_SE INT_LT Peter_CL LT_PVT_EOP_IN Peter Peter_PG 

 

Corridor Control Descr Start Sta Point Corridor Corridor Point 

Peter_NE SR817_RT_EOP 1+16.33 LT_LT_PVT_EOP_IN SR817_Peter RT_PVT_EOP_OUT 

Peter_NW SR817_LT_EOP 1+18.71 LT_PVT_EOP_IN SR817_Peter LT_PVT_EOP_OUT 

Peter_SW SR817_LT_EOP 1+20.82 LT_LT_PVT_EOP_IN SR817_Peter LT_PVT_EOP_OUT 

Peter_SE SR817_RT_EOP 1+25.86 LT_PVT_EOP_IN SR817_Peter RT_PVT_EOP_OUT 

17. From the Roadway Designer dialog, select File > Save to save the SR817.ird Roadway Designer 
project. 
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INTERSECTION MODEL 

Exercise 11.7 Create the Intersection Model 

In this exercise the intersection composite surface model will be created from the Create Surface dialog.  

A DTM and TIN file will be saved to the project Roadway folder or in the Path defined by the TIN/DTM 

files field on the Corridor Modeling dialog. Also, a 3D corridor mesh model will be drawn in the 

MicroStation file. The DTM file will be used to create Cross Sections for the intersection. 

1. In MicroStation, open the 3D file, c:\e\projects\22807915201\roadway\AMGMRD01.dgn. 

2. Open the Roadway Designer dialog and select File > Load the SR817.ird file, 

3. Change the Corridor label to SR817_Peter. 
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4.  Click the Create Surfaces icon  <OR> select Corridor > Create Surfaces. The Create 
Surface dialog displays. Enter the Nam:; Peter_INT and complete the dialog as shown below.  

  

5. Click on the Clipping options and check to see that Clip All is the default in the clipping option.  If 

not, double click on the line to change. Click on the OK to close the dialog.  

 

6. Click Apply to start the processing.  

Note ALERT !  THIS PROCESS MAY TAKE AWHILE.  

7. When complete, click Close on the Create Surface dialog. Close the Roadway Designer dialog 

and click to Save the changes to the SR817.ird file.   

8. Use MicroStation Fit View to view the intersection model. 
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9. Change the view rotation to Right Isometric.  

  

  

Mesh Model 

 

Smooth Shaded
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