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1 DIGITAL TERRAIN MODEL TOOLS 

OBJECTIVES 
The objectives of this session are: 

• Overview of Digital Terrain Model (DTM) tools 

• Extracting an Existing TIN File 

• Checking and Displaying a TIN File 

• Correcting for Voids 

• Updating the Working Alignment 

OVERVIEW 
Digital Terrain Models (DTM) are generated from a wide range of data sources including MicroStation 
elements, survey data, GEOPAK cross sections and GeoGraphics project data. An Extract utility is 
included to facilitate the retrieval and formatting of MicroStation graphical elements, classified as 
contours, random points, break lines, voids, islands and boundary points. GEOPAK offers a multitude of 
tools for creating, editing and performing tasks using DTM’s.  DTM’s utilize Data Points and break lines 
in order to generate a computer model of the ground.   

The surveyor generally supplies the designer with a 3D MicroStation file that contains a DTM consisting 
of a network of graphic triangles. The designer processes the contents of the DTM file using the tools 
supplied by GEOPAK to extract information and create a .DAT file. A .DAT file is a data file that contains 
the information used for triangulation. It is an intermediate file and compiles the information extracted to 
use as points to triangulate with, thus creating a Triangulated Irregular Network (TIN) file.  Many 
GEOPAK tools throughout the design process use a .TIN file.  

ACCESSING DTM TOOL 
The user accesses all DTM tools from the DTM toolbox. From the DTM toolbox, the user has the option to 
open the individual tools using the toolbox icons or to open a menu bar that contains the commands 
organized by function.  
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• From the Project Manager Road Project dialog, click the Existing Ground icon. 

 

• From the MicroStation menu, select Applications > Road > DTM Tools  

• From the Road Tools toolbox, select DTM Tools. 

 

ACCESSING DTM MENU BAR 
The DTM menu bar contains all the tools GEOPAK has available for working with DTMs; organized on 
menus by their general function. The user will find all DTM menu bar tools on the DTM toolbox, but new 
users usually find it easier to remember where the tools are located when using the menu bar. 

• On the DTM toolbox, click the DTM Menu icon. 
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DTM TOOLS FOR ROADWAY DESIGNERS 
In general, roadway designers use only a few of the GEOPAK DTM tools. Their use is normally limited to 
extracting data from a 3D design file and building a TIN model for use with GEOPAK’s other tools. This 
manual only covers those tools commonly used by roadway designers. For more information on DTM tools 
not covered in this manual, see the help files delivered with GEOPAK. 

EXTRACT GRAPHICS 
Extract Graphics gathers data from the 3D design file provided with the survey of the project. This design 
file, normally provided to the designer in the form of a graphical triangle file, can also be in several other 
formats. Extract Graphics can mine the needed data from any of the various types of files. The product of 
Extract Graphics is a DAT file. The DAT file simply contains XYZ coordinates of the data contained in 
the 3D design file. 

From the DTM menu, select Extract > Graphics.  

ACCESSING EXTRACT GRAPHICS 

 

File Name 

OVERVIEW OF EXTRACT GRAPHICS 

Specifies the name of the DAT file created or appended. 

File Type Two options are available:  Binary and ASCII.  

Binary These files have a smaller file size than an ASCII file, containing the same data, but 
cannot be read or modified by the user.  

ASCII These files contain the data in a format read or modified in any text editor. The benefit of 
an ASCII file is that the user can check for and correct any errors in the data. 
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File Open Specifies the method used for accessing the DAT file.  

Create This generates a new file with a specified file name. Create also overwrites existing files 
with the same File Name, which prompts a warning that the file exists and gives the user 
an opportunity to choose to overwrite or not.  

Append   This adds the data to an existing DAT file. 

Feature Specifies the type of feature used in the field. The 3D MicroStation design file 
represents these features. The DAT file is created based on these features. 

 Spots   are points that have no functional relationship to any other point. Random survey 
shots in open terrain would be an example of random spots. Point elements such as cells, 
circles, and text strings are typical MicroStation elements used to define spot elevations. 
Lines, line strings, and other longitudinal elements are equally valid. GEOPAK creates a 
spot elevation for each vertex of each longitudinal element. 

 

Breaks This designates linear features such as edges of pavement, ditch bottoms, ridges, etc. 
Any longitudinal element defines as a break line. GEOPAK automatically segments 
circular arcs in a manner consistent with the arc radius. When selected the dialog 
changes to include a Stroking icon, which will access the DTM Stroking Options dialog. 

 

 

Stroking This is a process of automatically adding new shots to the DTM input file by 
interpolating new shots from the linear and curves sections of the data. This dialog 
allows you to control the spacing of these new shots in both a linear and curve mode. 

Boundary These are constrains the external boundary of the triangulated model. Triangles are not 
created outside the boundary polygon. In addition, any point data outside the boundary 
polygon will be ignored. A boundary polygon must start and finish with the same point. 
In addition, the boundary polygon must be continuous within the data file. 

Contours Special feature intended for use if the source MicroStation elements represent digitized 
or otherwise created contours. Use of this feature insures the integrity of the contour 
strata in the subsequent DTM. Processing of a DTM with contours classified as spot 
elevations invariably results in a DTM that, if subsequently contoured, will not match the 
original extracted contours.  When selected the dialog changes to include a Stroking icon 
as described above. 

 

Void These areas are closed shapes to demarcate areas of missing data or obscure areas. No 
point or break data located within the void area is utilized and no triangles are created 
inside the void areas. The Void coordinates are included in the triangulation and void 
lines between successive void coordinates insert as drape lines on the TIN surface. 
Therefore, they do not change the slope or elevations of the TIN surface. 



DIGITAL TERRAIN MODEL TOOLS -DTM Tools for Roadway Designers ______________________________________ Chapter 1 

FDOT GEOPAK for Roadway Designers - Advanced  ©2011 FDOT 1-5 

Island Used to place triangulated data within a void, i.e., islands in the middle of rivers, lakes, 
etc. 

Graphic 
Triangles 

Extracting as triangles maintains the sides of each triangle in addition to the vertices. 
Using spots utilizes the vertices, but not the triangle sides. By survey at (FDOT), survey 
commonly provides Graphic Triangles to design and used to create the DAT file. 

Drape 
Void 

In the drape void, the void coordinates are not included in the triangulation. Voids are 
inserted post triangulation. The void coordinates and lines drape on the TIN surface. 
Even though a user must provide an elevation for the Drape Void vertices, the user 
elevations changes to the elevation of the TIN surface at the XY Drape Void coordinate 
position. 

Break 
Void 

A void utilizes the elevations of each vertex, while the void lines between successive 
void coordinates insert as break lines. Therefore, break voids change the slope and 
elevations of the TIN surface. 

Mode The Extraction mode determines XYZ data directly from the coordinate values of three-
dimensional MicroStation elements. The Interpolation mode, by contrast, derives XYZ 
data by locating spot elevations on longitudinal MicroStation elements and 
interpolating. Hence, the Interpolation mode applies to both two-dimensional as well as 
three-dimensional MicroStation files as long as a Z-coordinate reading can be 
ascertained from the spot elevations. 

Search 
Criteria 

The Search Criteria specifies the symbology and attributes of the elements to gather data. 

Match This determines the Search Criteria by selecting elements from the design file. 

Display This highlights all elements matching the Search Criteria. Display visually verifies the 
defining of all intended elements in the Search Criteria. 

Reset This clears all definitions in Search Criteria. 

Extract Extract specifies the limits of the design file that are to be processed. Complex Chain 
will extract data from a specified complex chain. Selection Set will extract data from a 
group of elements contained in a selection set. Fence processes all elements contained in 
a MicroStation fence. View 1 through View 8 will process all elements displayed in the 
selected view. 

Apply This commences the extraction process. Completely fill out the dialog and make sure 
that the View, Fence or Selection Set is set prior to selecting Apply. 
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BUILD TRIANGLES  
Build Triangles uses the DAT file to create a binary file containing the TIN model.  

• From the DTM menu, select Build > Build Triangles.  

ACCESSING BUILD TRIANGLES 

 

Data File 

OVERVIEW OF BUILD TRIANGLES 

Specifies the DAT file used to create the TIN file. 

TIN File Specifies the name of the TIN file created. 

Dissolve Option Dissolve Option eliminates the long, thin triangles along the edge of the TIN model, 
resulting from the triangulation process. These triangles are a by-product that is not 
indicative of the actual terrain.  

None Does not apply any dissolving to the model and leaves these extra triangles.  

Sliver Selection applies a formula to remove some of the extra triangles.  

Side Selection eliminates any triangles, which has a side longer than a user specified 
length. This option, in effect, makes each side of a triangle a break line and will not 
triangulate across any triangle side thus retaining the integrity of the original triangle 
file. 

Process   Process begins the triangulation process. When processing is complete, a message 
displays in the MicroStation status bar. 

The recommended Dissolve Option is Side. This creates a more accurate duplication of the existing TIN 
with the fewest extraneous triangles. Using this method, no leg of an existing triangle crosses with a new 
triangle, insuring the integrity of the new TIN. Florida Department of Transportation (FDOT) provides 
a tool accessible from the FDOT2008 Menu called Find Longest Side that scans the existing triangles in 
the DTM design file and calculates the length of the longest triangle side. The Side Dissolve Option uses 
this length. The exercises cover this in detail. 
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LOAD DTM FEATURES  
Load DTM Features is used to display the contents of the TIN model or DAT file. Load DTM Features is 
useful for checking the accuracy of the TIN model by overlaying it on the actual graphical triangles 
delivered with the survey. 

• From the DTM menu bar, select Load > Load DTM Features.  

ACCESSING LOAD DTM FEATURES 

 

File 

OVERVIEW OF LOAD DTM FEATURES 

 

Open Will open a previously saved Load DTM Features preference file (*.lpf). 

Save Select to save the dialog settings into a preference file (*.lpf). If a preference file has 
already been loaded then using the Save option will automatically update the current 
preference file. If one is not currently in use then a prompt will display for a name to use 
when saving the preference file. 

Save As This option will save the dialog settings into a preference file (*.lpf), similar to the Save 
option. However, this option will always prompt the user for a file name. 

Load File Allows selection of three different types of file sources; TIN, Data or Lattice as well as 
the source data file name.  

TIN The option will allow the selection or input of a binary tin file. 

Data The option will allow the selection of a DTM Input file. This file is a binary or ASCII 
format. 

Lattice The option will allow the selection of a binary lattice file. A Lattice file is a gridded 
mesh created from the binary tin file. 
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Display 
Preferences 

 

Load This determines which portion of the DTM to load. For Fence, loads the portion of the 
DTM located within a fence (always overlap) placed in MicroStation. For View, loads 
the portion of the DTM within the MicroStation view window. Extent draws features 
for an entire model. 

Display  
Only 

If checked, elements are not drawn into the MicroStation file and disappear when an 
update or view control command is issued. If this box is not checked, elements are 
drawn into the file at the specified element symbology. 

Graphic 
Group 

If checked, the elements comprising the DTM are loaded into the design file as a 
Graphic Group for easy manipulation and/or deletion. 

DTM 
Feature 

Symbology           
List Box 

As the Load File option is selected, the list box changes dynamically to display 
supported features.   

Each feature has element symbology options (Level, Color, Weight and Style) and a 
display mode (on/off).  As each feature highlights, its element symbology displays in 
the window directly below the list box.   

Note the Display column indicating whether the display is ON or OFF.   

The symbology changes by editing the fields below the list box.  Double clicking a 
feature will toggle that feature on or off.  A right mouse click over a feature opens a 
pop-up menu with options to turn the selected feature on or off or turn all features on or 
off.   

Four light bulbs, right of the List Box, control display on/off toggle.  

 The bright bulb (top) activates the display for all features, regardless of their 
current display status.  

 The darker bulb (second from top) deactivates the display for all features 
regardless of their current display status.  

 and  The bottom two bulbs, activate and deactivate the selected feature 
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WORKING ALIGNMENT AND PORT VIEWER    

WORKING ALIGNMENT    
Within GEOPAK’S Project Manager, the intent of a working alignment is to allow the designer to 
organize a project and to access project information without repetitive typing of the required information. 
Job numbers, chains, stationing, file names; practically all the information defined within the working 
alignment environment is “remembered” by GEOPAK then recalled as needed for the various Project 
Manager procedures.  

On a simple project, the designer may only want to define one working alignment. However, on a more 
complicated project, an unlimited number of working alignments can be defined. The designer can easily 
change from one working alignment to another by simply selecting the desired alignment from the Select 
Working Alignment dialog. 

The working alignment updates through Project Manager. The FDOT Basic GEOPAK for Roadway 
Designers course covers Project Manager. The setup for Project Manager for this course is in 
accordance with recommendations listed in the Basic GEOPAK course. This is just a suggested setup and 
may vary per FDOT District requirements.  Check with your District CADD Manager or your Project 
Manager for any specific requirements in naming convention for the Project Manager. 

• From the Road Project dialog, click the  icon. 

CREATING OR SELECTING A WORKING ALIGNMENT 

    

Run 

OVERVIEW OF SELECT WORKING ALIGNMENT 

 

New Create a new working alignment definition. 

Copy Project - Copy a Working Alignment from another project. User will be prompted to 
select the desired project name, the user name from within that project and then to select 
the Working Alignment name from that project. 

User - Copy a Working Alignment from within the same project but from a different user 
name. 

Run - Copy a Working Alignment from the same project and user name. 

Modify Modify the Working Alignment name and/or description. 

Delete Delete a Working Alignment. 
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OK Selecting a Working Alignment name from the dialog and clicking OK makes the selected 
Working Alignment active. 

Cancel Exit the dialog without making any changes. 

• From the Road Project dialog, click the  icon.   

DEFINING A WORKING ALIGNMENT 

• Plan View Settings 

 

Design File Design file where the plan view graphics are located. This can be 
keyed-in or selected using the File icon. 

Chain Alignment name for the Working Alignment being defined. 

• Plan View > Pattern Settings – By Station 

Patterns define the locations of the cross sections by two options: By Station and By Design File. 

 

By Station When selected, the dialog changes to allow users to define the patterns 
by station limits and increments. 

Horizontal 
Scale 

Entry made for Horizontal scale of the cross sections. 
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Vertical Scale Entry made for Vertical scale of the cross sections. 

Begin Station Entry made for Beginning station of the cross sections. 

End Station Entry made for Ending Station of the cross sections. 

Increment/Even Increment spaces the cross sections at the same increment apart from one 
another, regardless of the stationing of the alignment. In the case of an 
alignment with station equations, this could result in cross sections not 
necessarily falling on even stations. If Even is used, then even stations 
are maintained even if this results in the spacing of the sections being 
irregular. 

Left Offset Field specifies the left extent of the cross sections. 

Right Offset Field specifies the right extent of the cross sections. 

• Plan View > Pattern Settings – By Design File 

 

By Design 
File 

When selected, the dialog changes to allow the user to define the patterns 
using graphical elements in a design file. 

Horizontal 
Scale 

Entry made for Horizontal scale of the cross sections. 

Vertical 
Scale 

Entry made for Vertical scale of the cross sections. 

Design File Design file where the graphical patterns are located. This can be keyed-in or 
selected using the File icon. 

Search 
Criteria 

Patterns defined using any combination of graphical symbologies (i.e. Level 
Names, colors, weights, etc.), either keyed into the individual fields or 
selected from lists using the icons. No definition enabled or specified means 
ALL pertinent values for that particular item are taken into account. For 
example, if no color specified, then ALL colors (0-255) are part of the 
search symbology. 
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Match Clicking this icon and identifying a graphical element will harvest the 
symbology of the element into the dialog.  

Display Clicking this icon will highlight all elements in the design file that match the 
symbology in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 

Placement The symbology entered in the fields above is used only when searching for 
patterns. When a dialog is placing/drawing patterns, it will use the 
symbology defined here. You can access the symbology selection dialog 
shown below by double-clicking on the sample graphic. 

 

• Plan View  > Shapes Settings  

Shapes allow the user to specify the super-elevation shapes for the Working Alignment by 
two options: By Search Criteria and All in DGN. 

 

By Search 
Criteria 

When selected, the dialog changes to allow the user to specify the graphical 
symbology of the shapes as well as the design file where they are located. 

Design File Design file where the super-elevation shapes are located. This can be keyed-
in or selected using the File icon. 

Search 
Criteria 

Define the shapes using any combination of graphical symbologies (i.e. 
Level Names, colors, weights, etc.), keying into the individual fields or 
selecting from lists using the icons.  If not enabling or specifying a specific 
item (e.g. color), then ALL pertinent values for that particular item will be 
taken into account. For example, if the color has no specification, then ALL 
colors (0-255) apply as part of the search symbology. 
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Match Clicking this icon and identifying a graphical element will harvest the 
symbology of the element into the dialog.  

Display Clicking this icon will highlight all elements in the design file that match the 
symbology in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 

 

All in DGN When selected, the dialog changes to allow the user to specify the design 
file where the shapes are located. Graphical symbology is not considered 
in this case and ALL of the shapes located in the design file will be found. 

Design File This specifies the design file where the superelevation shapes are located. 
This can be keyed-in or selected using the File icon. 

• Profile View Settings 

 

Design File Design file where the profile is drawn, keyed in or selected using the File 
icon. 

Existing 
Profile 

Name of the Existing profile, keyed in or selected from the geometry 
database using the Select icon. 

Proposed 
Profile 

Name of the Proposed profile name, keyed in or selected from the 
geometry database using the Select icon. 
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• Profile View > Location Settings  

This setting is the location of the profile within the design file, based on a reference station 
and elevation as well as a coordinate location. 

 

Horizontal Scale Enter horizontal scale of the profile. 

Vertical Scale Enter vertical scale of the profile. 

Station Equation  

Gaps This option specifies that the profile make graphical allowances for 
gaps in the profile. 

No Gaps This option specifies that the profile does not make graphical 
allowances for gaps in the profile. 

DP Station Reference station of the profile, that occurs at the DP location. 

DP Elevation Reference elevation of the profile, that occurs at the DP location. 

DP X X  Coordinate of the Reference Data Point of the profile. 

DP Y Y  Coordinate of the Reference Data Point of the profile. 

By DP Clicking this icon and then selecting a location in the design file 
will automatically harvest the coordinates of the Data Point and 
fill in the DP X and DP Y fields. 

Profile Cell  

     Draw Cell          
at X,Y 

Clicking this icon and then identifying a location in the design file 
with a Data Point will draw a profile cell at that location using the 
information from the dialog. 

Identify Cell Clicking this icon and then identifying an existing profile cell in 
the design file will fill out the dialog using the information from 
the profile cell. 
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• Cross Section View Settings 

 

XS DGN File Design file where the cross sections are located, keyed in or selected using 
the File icon. 

If GEOPAK cross section cells are present in the selected file, the Chain and Station ranges 
populate automatically.  This is the only way to populate these fields. 

• Cross Section View > Existing Ground Settings  

This setting allows the user to specify the search and placement symbologies of the existing 
ground lines. The ground lines can be defined using any combination of graphical 
symbologies (i.e. Level Names, colors, weights, etc.), keyed into the individual fields or 
selected from lists using the icons. 

 

Match Clicking this icon and identifying a graphical element will harvest the 
symbology of the element into the dialog.  

Display Clicking this icon will highlight all elements in the design file that match the 
symbology in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 

If no specifications for specific items (e.g. color), then ALL pertinent values for that particular 
item are taken into account. For example, if the color not enabled, then ALL colors (0-255) are 
used as part of the search symbology. 
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• Cross Section View > Proposed Finish Grade Settings  

This setting allows the user to specify the search symbology for the proposed finish grade 
elements. Define the proposed finish grade elements using any combination of graphical 
symbologies (i.e. Level Names, colors, weights, etc.), keyed into the individual fields or 
selected from lists using the icons. 

 

If a specific item (e.g. color) is not enabled and specified, then ALL pertinent values for that 
particular item will be taken into account. For example, if the color is not enabled, then ALL 
colors (0-255) will be used as part of the search symbology. 

Match Clicking this icon and identifying a graphical element will harvest the 
symbology of the element into the dialog.  

Display Clicking this icon will highlight all elements in the design file that match the 
symbology in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 

• DTM Settings 

 

Existing Ground TIN File name for Existing Ground DTM, keyed in or selected 
using the File icon. 

Portview TIN Any other TIN files encompassing the same area as the 
Existing Ground TIN. 
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Portview Horizontal 
Scale 

This is a required entry, if specifying a Portview TIN.  

 

Portview Vertical Scale See definition of Portview Horizontal Scale above. 

Horizontal drawn at true coordinates, while the vertical scale drawn distorted; therefore, the ratio 
of the scales, rather than the actual value, that is important. 

PORT VIEWER 
The Port Viewer is a tool that enables the user to view and manipulate different aspects of a road design 
simultaneously, even though they are located in different design files. These different aspects include: 

• Plan View 

• Profile View 

• Cross Section View 

When invoking the Port Viewer, the following views open and the corresponding files activate: 

• View 6 - Plan view 

• View 7 – Profile 

• View 8 - Cross Section or Digital Terrain Model 

Only one view is your “active” view, meaning that the elements in this view are available for modification 
and deletion. The other views attach as references files, so the elements in those files can only be viewed, 
not manipulated. However, with the touch of a icon the Port Viewer can make any of the views active. 

As a pre-requisite to invoking the Port Viewer, there must be a Working Alignment defined. 

• From the Road Project dialog, click the  icon.  

ACCESSING PORT VIEWER 
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View Menu 

OVERVIEW OF PORT VIEWER 

Allows the user to either fit the different views or make them active. 

Fit Plan View (6) - Fit the Plan View (MicroStation View 6) 

Profile View (7) - Fit the Profile View (MicroStation View 7) 

XS View (8) - Fit the Cross Section View (MicroStation View 8) 

All - Fit all of the above views (6, 7 and 8) 

Active Plan View (6) - Make the Plan View (6) the active view. 

Profile View (7) - Make the Profile View (7) the active view. 

XS View (8) - Make the Cross Section View (8) the active view. 

Options Menu This menu allows users to access the Display Options dialog. 

 
Plan Station - When enabled, the pattern line displays on the screen in the plan view. 

Offset Circle – When enabled, a circle of the size designated in the Offset Circle Size 
displays at the station and offset location specified in the Port Viewer dialog. 

Offset Circle Size – Setting that designates the size of the Offset Circle. 

Auto Center Window - When activated, the Station and Offset specified in the Port 
viewer dialog centers in the Plan View window. 

Profile Elevation – When enabled, a horizontal line (using the Marker Display element 
symbology) is displayed on the Profile View at the Elevation specified in the Port 
Viewer. 

Station – When enabled, a vertical line (using the Marker Display element 
symbology) is displayed on the Profile view at the Station specified at the top of the 
Port Viewer dialog. 

Auto Center Window - When enabled, the Station and Elevation specified in the Port 
viewer dialog centers in the Profile window. 

XS Elevation – When enabled, a horizontal line (using the Marker Display element 
symbology) displays in the XS View at the Elevation displayed in the Port Viewer. 

Offset – When enabled, a vertical line (using the Marker Display element symbology) 
displays in the XS view at the offset specified in the Port Viewer dialog 

DTM Left – Setting that designates the horizontal distance from the specified 
alignment, defining the left limits of the cross section or DTM display line, similar to 
a cross section pattern line. 
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DTM Right - Setting that designates the horizontal distance from the specified 
alignment, defining the right limits of the cross section or DTM display line, similar 
to a cross section pattern line. 

Show Stations  
Only at XS cell 

This toggle affects the movement of the dynamics in the plan view. With the option 
toggled off, the cross hair display moves along with your mouse. However, When 
toggled on, the cross hair only stops at a cross section location. 

Marker Display   The Marker Display allows the user to specify the color, style and weight of the 
horizontal and vertical display lines. 

Dynamic to  
Cursor 

Sensitivity 

Determines how close the MicroStation cursor must get to the Data Point cross 
hairs (dynamic cursor) before they begin to follow the MicroStation cursor 
dynamically in the Set mode. This is to prevent the cross hairs from jumping over to 
the MicroStation cursor until it is within a certain distance from them. This distance 
is set as a percentage of the diagonal size of a given view. 

Apply This saves the changes. 

Station This setting reflects the current station of the dynamic cursor in each view. This 
station can be “locked” using the toggle. 

XS DTM /         
XS Station 

When utilizing the XS Station option, the XS View displays the actual cross sections 
from the specified cross section file. When the XS DTM option is selected, a cross 
section generated "on the fly" from the specified DTM is displayed. 

<<   <   >   >> 

 

These icons allow the user to scroll forward and backward through the cross sections. 
Upon selection of each icon, all views are dynamically changed to reflect the 
displayed cross section. In addition, the display lines in the plan view and profile 
view also dynamically move. 

Off. The field reflects the current offset of the dynamic cursor in each view. This offset 
can be “locked” using the toggle. 

Elev. The field reflects the current elevation of the dynamic cursor in each view. This 
elevation can be “locked” using the toggle. 

Active  

Plan View Option makes the plan view the active view. 

Profile View Option makes the profile view the active view. 

XS View Option makes the XS view the active view. 

Set When clicked, Set commences dynamic movement of the cursor. The designer can 
move to any unlocked station, elevation, or offset and watch all display lines move 
simultaneously. Pressing reset discontinues the dynamics, while a Data Point on the 
screen suspends the dynamics. 

DP When selected, any generic MicroStation command utilizes the current 
station/offset/ elevation position as a Data Point. The user utilizes the DP icon any 
time during the viewing. 
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Exercise 1.1 Accessing Project Manager 
In this exercise, the user will access Project Manager. For this class, there is an assumption made, that the 
user has the basic knowledge of how to set up Project Manager. The initial project setup has already been 
prepared using the following parameters: 

• Project Name:  sr817.prj.  

• Project User: J Doe 

• Operator Code: JD 

• GPK Name:  job791.gpk 

Double-click on the self-extracting zip file C:\Chapter1_Exercises.exe and click the Unzip icon at 
the prompt. This will extract and setup the files needed for this exercise. 

1. Open the design file C:/e/Projects/22807915201/roadway/GDTMRD01.dgn.  

2. Select Applications > Road > Project Manager.  

 

3. Select the Project sr817.prj and click OK. 
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4. Select the User: J Doe and click OK. 

 

5. Enable the Remember options for both Project and User. 

  

6. Enable the Auto Sink option. 
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Exercise 1.2 Extracting Graphics 
In this exercise, the user will extract graphical triangles as a prelude to creating our DTM. 

1. From the Road Project dialog, click Existing Ground. Select Run dialog opens to create a new run. 

 

 

2. Select the menu option Run > New.  New Run Name dialog opens. 

3. Create a new Run Name: SR817 with the Description shown below and click OK. 

 

4. In the Select Run dialog, highlight SR817 run and click OK. 
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5. On the DTM toolbox, click the DTM Menu icon.  

 

 

6. On the DTM menu bar, select Extract > Graphics.  

 

7. Key-in the File Name: site.dat. 

This will already be in the File Name field if this is the first time this dialog has been accessed. 

8. Set the File Type to Binary.  

9. Set the File Open to Create. 

10. Set the Feature to Graphic Triangle. 

11. Set the Mode to Extraction.  

 



Chapter 1 _____________________________________ DIGITAL TERRAIN MODEL TOOLS - Working Alignment and Port Viewer 

1-24 ©2011 FDOT  FDOT GEOPAK for Roadway Designers - Advanced 

12. Under Search Criteria, enable the Lv Name check box. 

13. Click Match.  

14. In the design file, select one of the triangles.  

Note All of the triangles will highlight and remain highlighted until an update view or other view control 
command is issued. 

15. Data Point again in the design file to accept the selected triangle. DTMTriangles_ep appears in the 
Lv Names box under Search Criteria. 

 

16. Set the Extract mode to View 1. 

17. In MicroStation, fit the view to make sure the entire contents of the file display in View 1. 

18. Click Apply. When processing completes, Extract view 1 complete displays in the MicroStation status 
bar. 

19. Close the dialog box.  An Alert displays, prompting to Save Extract Parameteres Settings? 

 

20. Click Yes and the dialog closes. 
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Exercise 1.3 Building Triangles 
In this exercise, the user will build the DTM from the previously created DAT file. 

1. From the FDOT Menu select Actions > Miscellaneous > Calculate Longest Triangle. This VBA 
automatically calculates the longest triangle side in the design file and launches GEOPAK’s Build 
Trianges tool.  The Build Triangles tool’s Dissolve Option automatically sets to “side” and the longest 
triangle side length is automatically input into the Side Length field. 

 

2. In the Data File field, key-in site.dat. 

 

Note If unsure of the Data File name, click on the magnifying glass icon and browse  to the file.  Generally, 
anywhere  magnifying glass icon displays, it will open a file browser. 

3. In the TIN File field, key-in site.tin.  

 

4. In Build Triangles, click Process. The TIN file creates and ‘Build Triangles Completed’ appears in the 
MicroStation message center. 

5. Close Build Triangles dialog. Click Yes when prompted to Save Settings. 
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Exercise 1.4 Loading DTM Features 
In this exercise, the user will display the DTM graphically. 

1. On the DTM menu bar, select Load > DTM Features. Load DTM Features dialog opens. 

 

2. Set the Load File type to TIN, then key-in site.tin. 

3. In the Display Preferences area, set the Load option to For View.  

4. Enable the Display Only check box. 

5. Double-click the Display column on the Triangles row. The display of the triangles changes to ON. 

 

Note Since the triangles are going to be plotted Display Only, the level or symbology is not important at this 
time.  Setting a color that contrasts with the original triangles will be beneficial in identifying the new 
triangles and checking for accuracy by seeing all the existing triangles overlain by the new triangles. 

6. Click Load. 

7. Zoom In to the MicroStation view to have the individual triangles clearly displayed. The loaded 
DTM features disappear, because Display Only was selected. 

8. Click Load. The contents of the DTM display. Visually confirm that the DTM triangles exactly 
overlay the MicroStation elements. 

9. Close Load DTM Features dialog. Click Yes when prompted to Save Settings. 
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Exercise 1.5 Delineating and Processing a Void 
After viewing the DTM created in the previous exercise, note that there are additional triangles plotted in 
the DTM.  An area that once had no triangles, called Void, now has triangles. The triangles placed in the 
Void are interpolated and do not present an accurate representation of the Void area. In this exercise, the 
user will modify the DTM to rectify this situation. 

1. In MicroStation, select Utilities > Saved Views.  Saved Views dialog opens. 

 

2. Double-click on the saved view VOID and enter a Data Point. This will zoom to the Void area in the 
design file. 

3. Dismiss the Saved Views dialog. 

4. From the DTM menu bar, select Extract > Graphics. Extract Graphics dialog opens. 

 

5. From the Extract Graphics dialog, set File Open to Append. 

6. Set the Feature to Void. 

7. Click Reset to clear all previously defined search criteria. 

Note If the Extract Graphics dialog displays previous Search Criteria, clicking the Reset icon will clear 
this information. If not done, then new Search Criteria appends to the previous search symbology. 

8. Turn off the level DTMTriangles_ep, so only the Void 
shape displays. 

9. Click Match. 

10. In the design file, select the shape that defines the Void 
area. 

11. Data Point again in the design file to accept the shape. 
Default appears in the Lv Name box under Search 
Criteria. 

12. Set the Extract mode to View 1. 

13. Click Apply. When processing is complete, Extract view 
1 complete displays in the MicroStation status bar. 

14. Close the Extract Graphics dialog. Click Yes, when 
prompted to Save Settings. 
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15. On the DTM menu bar, select Build > Triangles. Build Triangles dialog opens and should already be 
filled out correctly from a previous exercise. 

 

16. Click Process. Since the user previously used TIN File name, an alert prompts to overwrite the 
existing TIN file 

 

17. Click OK. The tin file creates and ‘Build Triangles Completed’ appears in the MicroStation message 
center. 

18. Close Build Triangles dialog. Click Yes when prompted to Save Settings. 

19. On the DTM menu bar, select Load > DTM Feature. The Load DTM Features dialog loads and 
should be filled out correctly from the previous exercise. 
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20. With the view still set around the shape, click Load. The contents of the DTM display. Note that the 
triangles no longer cross through the Void. 

 

 

21. Close the Load DTM Features dialog. Click Yes when prompted to Save Settings. 

22. Close the DTM menu bar.  

23. Close the DTM toolbox.  
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Exercise 1.6 Updating the Working Alignment 
In this exercise, the user will update the Working Alignment with the appropriate DTM information. 

1. Access Project Manager. 

Note Since you “remembered” the Project and User in a previous exercise, the Road Project dialog 
should appear. 

2. Click Define. Working Alignment Definitions opens. 

 

3. In the list box, click DTM, which shows the DTM options. 

 

4. For the Existing Ground TIN field, click File and select C:\e\Projects\22807915201\roadway\site.tin. 
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5. Do the same for the Portview TIN field. 

  

6. Key-in 1 for both the Portview Horizontal Scale and the Portview Vertical Scale. 

  

7. Click OK to save and update the Working Alignment. 

8. Exit MicroStation. 
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2 EXISTING GROUND PROFILES 

OBJECTIVES 
• Cutting an Existing Ground Profile 

• Plotting Profiles 

• Updating Working Alignment 

DRAW PROFILE TOOL 
The Draw Profile tool enables the user to draw several profiles simultaneously from a variety of data 
sources.  If the data source is a TIN file, Draw Profile facilitates storing the resultant profile within the 
coordinate geometry database. 

ACCESSING THE DRAW PROFILE TOOL 
• From MicroStation menu, select Applications > ROAD >Plans Preparation > Draw 

Profiles 

<OR> 

• From the Road toolbox, click the Draw Profiles icon. 
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ACTIVATING THE DRAW PROFILE TOOL 
As can be seen above, the majority of the dialog options are inactive. To activate these options, the user 
must place a GEOPAK Profile cell in the design file. If a profile cell already exists in the design file, 
GEOPAK will recognize it. GEOPAK offers several options to place a profile cell, but for this class we 
will use the method provided by the Draw Profile dialog. 

 

Job Number Required to identify the coordinate geometry database wherein the chain for 
generating the profiles is stored. 

Chain This is required to reference a horizontal alignment to the profile. Compute any 
subsequent settings of station ranges and left/right offsets relative to this alignment. 
The Chain may be entered here or entered as the Active Chain as shown in 
Figure 2-5 in the Profile Cell Control. It will then display here. 

Profile Cell 
Control  The current profile cells lists along with associated station, elevation, etc. 

Update Profile 
 Option updates any previously drawn Profile. 

Label Scale
  

Option utilized when using the By Feature Display Settings option.  The specified 
Label Scale compares to the scale within the Design and Computation Manager 
Item and proportioned. This option is only utilized if the text setting within the D&C 
Feature is set to scale, not fixed. 
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PROFILE CELL CONTROL DIALOG 

 

Profile Cell Control is comprised of two main parts: 

Active Chain Chain used when generating the selected profile cell. The example in the preceding 
figure shows one profile cell in the current design file that is associated to Chain 
BL817. The user may enter the Active Chain here, or if entered as Chain in the Draw 
Profile options shown in Figure 2-3, that entry automatically displays here. 

MicroStation 
File, Station, 
etc. 

This list box gives information about all the Profile Cells that are relative to the 
Active Chain. Three action icons are located on the right side of the dialog box. 
Notice in the preceding figure that one profile cell is in the Active Design file. The A 
indicates active file. The Solid circle next to the A indicates which profile cell is 
selected.  

The following figure shows an additional profile cell drawn in a reference file, 
referenced to the active file. 
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The Place Profile Cell tool enables the user to place the profile required as a prerequisite to any profile 
creation. Note the profile cell may be placed by many other applications in GEOPAK as well (e.g. D&C 
Manager, Vertical Alignment Generator, Active Chain Control, Project Manager Working Alignment, Plan 
/ Profile Sheets, etc.) 

PLACING A PROFILE CELL 

• On the right side of the Profile Cell Control dialog box, Click the Place Profile Cell 
icon. Place Profile Cell opens. 

       

Station Defines the corresponding station of the reference Data Point and will be the 
origin of the profile cell. The beginning station of the specified chain is the 
default. 

Elevation This defines the corresponding elevation of the reference Data Point. It should be 
an even value to correspond to a major profile grid and should be lower in 
elevation than the lowest elevation of the profile. 

Horizontal/Vertical 
Scales 

This sets the scale, establishing a vertical exaggeration of the profile. 

Gaps/No Gaps This specifies whether the Profile Cell contains a gap. Setting this option to Gap 
will allow a profile that has a “gapped” station equation to draw the profile with 
the corresponding gap shown. 

Cell Range This defines the height of the Profile Cell above and below the reference Data 
Point. These values are in true length (without taking into account horizontal and 
vertical scales). The Top and Bottom Delta values of the profile cell must be set 
large enough such that all elements of the profile fall completely within the cell 
limits. For example, all profile elements must be between a horizontal line drawn 
at the top of the cell and one drawn at the bottom of the cell.  

The profile cell itself will be reviewed in one of the exercises. 
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If you have multiple profile cells in a design file, you can only have one “Active” at a time. Any operations 
that are applied use this active profile cell. To activate a profile cell, you can double-click on the desired 
profile cell in the Profile Cell Control dialog or highlight the desired cell and use the icon as shown. 

ACTIVATING A PROFILE CELL  

 

The dialog delineates the active profile cell  by the filled circle as shown in Figure 2-9 above. 

DRAW PROFILE MENU COMMANDS 

 

File Allow the user to save the dialog settings to a resource file. This file can then be loaded later 
to populate the settings of the dialog. The default file extension is .prd. This file can 
remember more dialog settings than the standard resource files. If the .rsc files are deleted 
from the GEOPAK \bin folder, all of the information in Draw Profile is lost. However if a 
file with all of the settings is saved in another location, then that file can be loaded and the 
information is restored. 

Load Load a previously saved .prd file. 

Append Append to the .prd file that is currently opened by the dialog. 

Save Save the contents of the dialog into a .prd file. If a .prd file is currently loaded, it will be re-
saved. 

Save As Allows the selection and saving of a new .prd file. 

Exit Exit the dialog. 
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Edit These commands operate on the rows in the list box.  The list box is the area in the 
middle of Draw Profile dialog in either the Surfaces tab or COGO tab. 

Cut Rows This removes a row from the list box into the buffer. If this row does not pass back 
into the list box, the information deletes from the list box and no longer displays. 

Copy Rows This copies a row from the list box into the buffer.  Use this command if several rows 
have similar information. Rather than manually entering every line into the list box, 
copy and paste a line, and then modify. 

Paste Rows This pastes a row from the buffer into the list box for subsequent editing. 

 

Update Options The check to the left of the options indicates the active options. Only one option 
activates at any given time. Therefore, if an option is selected the previous active 
option is deactivated. 

Delete Existing 
Elements and Redraw   

When this option is active, it deletes any profiles previously drawn with this and new 
ground lines are drawn. 

Delete Non-Modified 
Elements and Redraw 

When this option is active, it deletes any profiles previously drawn and manually 
modified and new ground lines drawn. 

Draw on Top of 
Existing 

When this option is active, any previously drawn profiles are ignored and a new set is 
drawn, resulting in two profiles. 

Query When active, it prompts the user each selection of the Modify Line or the Remove 
Surface icons. Update Option opens, as shown in the following figure.  This 
allows the user to specify the application of changes. 
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SURFACES TAB 
Defines the surface utilized for drawing profiles. A single processing supports multiple surfaces drawn 
from a variety of sources.  Source data includes GEOPAK .tin files, Site Models, or Site Objects.  The list 
box using the action / edit icons on the right side of the list box must include each surface to be drawn.  
Each surface draws a cross section line string or lines.  When adding a line to the list box, the profile is 
drawn. Below describes the icons along the right side of the Surfaces list box. 

 

Add Surface 
Settings  Adds to the list box the profile information based on the Details, Display 

Settings, Station Limits, Filter Tolerances and Offsets settings. 

Modify Line 
  Modifies selected Profile 

Remove Surface 
   Deletes selected Profile 

Store Surface in 
COGO  Opens Store Profile dialog to store the selected Profile into COGO 
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Details  

 

Tin File Allows you to browse and select a.tin file. 

Method  As shown in the following figure, there are five methods. 

Triangles - Use this method if a .tin file is selected. 

Break Lines - Use this method if utilizing a GEOPAK Site component. 

POT - Creates a profile with VPIs at every location where a POT occurs in the 
referenced chain. 

Increment - Creates a profile where the user specifies the incremental distance 
between successive VPI points on the existing ground profile where the first VPI 
point is coincident with the Beginning Station. 

Even - Specifies the incremental distance between successive VPI points on the 
existing ground profile where the user rounds to the next highest even station 
from the Beginning Station of the first VPI point. For example, if the Beginning 
Station is 10+15 and the Even value is 25, the VPIs would be generated at 10+25, 
10+50, etc. 

Display Settings Specifies the element symbology of the profile elements generated, using By 
Level Symbology or By Feature.   The figure below illustrates how the 
symbology displays and what the symbology settings are. 

 

 By Level Symbology - Double-clicking the black box to the right of the setting 
opens GEOPAK Set Feature dialog, specifying the symbology.  
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 By Feature - With this setting, the user selects an item from the current Design 
and Computation Manager.  Click the Paintbrush icon to open the Select 
Design & Computation Payitem, and then select the appropriate Payitem.  
This method is preferred because it assures compliancy to CADD standards. This 
method also attaches the GEOPAK Feature Code defined in the Design & 
Computation Manager. 

   

 

Filter 
Tolerances 

 

Each pair of profile segments considers both Horizontal and Variance filter 
tolerances together.  If both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord 
between the two end points is less than the  

Variance tolerance, deletes the middle point. 
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Station Limits When selecting the chain at the top of Draw Profile dialog, the Begin and End 
stations fill in automatically.  The user may use these limits --or-- type the station 
limits in the Begin and/or End boxes <OR> click the Begin or End Set Station 
icon and graphically ID the station range. To use anything other than the default 
station, the user must enable the Begin and/or the End Station Limits toggles, 
based on the situation. 

  

 

Offsets Vertical or Horizontal Offsets may be specified in terms of master units (i.e., 
feet).  The Horizontal Offset is the distance offset from the chain.  Once the 
horizontal location for the profile is determined, the data source, or in the case of 
this course, the TIN file is utilized to determine the profile along the horizontal 
offset.  Any Vertical Offset applies after the profile is generated from the source 
data. 

 

Void The Void Plot Parameters specify the element symbology of the existing ground 
lines generated, which are located within a void in the model. Double-click the 
symbology box and Set Feature opens.  
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COGO TAB  
The COGO tab displays profiles that are stored in the .gpk, such as a profile that was stored with other 
tools or via an input file.  As long as the profile is in COGO, it displays with this tool. This tool works very 
much like the Draw Plan & Profile tool in Design and Computation Manager.  In the future, this 
will be the only method to display profiles. 

 

 

Details  

Profile  This is a list of the profiles currently stored in the .gpk. 

t 

Vertical Offset Option allows the user to display the profile at a defined offset left or right of the 
horizontal chain assigned to the profile.  

 



Chapter 2 ______________________________________________________ EXISTING GROUND PROFILES - Draw Profile Tool 

2-12 ©2011 FDOT    FDOT GEOPAK for Roadway Designers - Advanced 

Station Limits Same as those described for the Surfaces tab. 

Display Settings Same as those described for the Surfaces tab. 

Custom Line Style – If setting the Display Settings to By Feature, the Custom 
Line Style is available, because some items in Design and Computation 
Manager use custom line styles. This check box applies the correct scale factor as 
they are drawn. 

 
Options - The Options portion of Draw Profile has the same options as those 
found on Draw Plan and Profile within Design and Computation Manager. In 
the above figure, the user selects General. When using Display Settings set to By 
Feature, the Design and Computation Manager will dictate which boxes 
will be checked or unchecked. 
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THE PROJECTION TAB 
The Projection tab should be used when the chain / profile to be drawn is different from the chain / profile 
used to create the profile cell.  

The list box must include each projected profile drawn, using the action / edit icons on the right side of the 
list box. When adding a line to the list box, the profile is drawn. Enabling Draw in the list box deletes or 
redraws the profile. 

 

This class will not be using this tool because there is only one alignment in the class project. 
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Exercise 2.1 Creating Existing Ground Profile  
In this exercise, the user will process and draw our existing ground profile. 

1. Double-click on the self-extracting zip file C:\Chapter2_Exercises.exe and click the Unzip icon at the 
prompt. This will extract and setup the files needed for this exercise. 

2. Open the design file C:\e\Projects\22807915201\roadway\DSPFRD01.dgn. 
3. Open Project Manager. The Road Project dialog will appear. Sink this dialog. 

4. From the Road toolbox, click the Draw Profile icon. Draw Profile opens. 

   

5. From Draw Profile dialog, select BL817 from the Chain pull-down. 
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6. Click the Dialog Profile Cell Control icon.  

 

7. Profile Cell Control dialog opens. 

 

8. Click the Place Profile Cell icon on the right side of the dialog box. 

 

9. Place Profile Cell dialog opens. 
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10. In Place Profile Cell dialog, complete the information as shown in the figure shown below:  

 

The Profile Cell attaches dynamically to your cursor. Place the Profile Cell in the design file near the 
referenced plan view similar to that shown in the figure shown below: 

 

Note Although the profile cell can be placed anywhere in the design file, we have placed it near the 
referenced plan view so that an exercise in chapter 4 which utilizes the profile design file and 
dsgnrd01.dgn file will be easier to manipulate. This will be explained later. 

11. When the profile cell places in the design file, the Place Profile Cell dialog closes.  Profile Cell 
Control dialog box refreshes to show active profile cell information. 

 

12. Close Profile Cell Control dialog. 

13. From Draw Profile, select the Surfaces tab.  
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14. Click the Browse Tin File icon to select C:\e\projects\22807915201\roadway\site.tin. 

 

15. Select Triangles as the Method for extraction. 

16. Set the Display Options to By Feature. 

 

17. Click the Browse Feature icon. 

 

Note Due to the size of the Select Design & Computation Payitem database, there will be a delay while 
the database opens. 

18. Select Design & Computation Payitem dialog opens. 
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19. In Select Design & Computation Payitem dialog, navigate to: 

Roadway Design / ProfileFeatures / RoadwayDesignProfiles / ProfileGradeLine(Existing) / EPGL_50_5 

 

20. With EPGL_50_5 highlighted in Select Design & Computation Payitem dialog, click OK. 
The Feature sets to the selected item’s symbology, and Select Design & Computation Payitem 
dialog closes. 

Note Due to the Project Manager Autosink option being enabled, when the Select Design and 
Computation Payitem dialog closes the Road Project dialog will come back up from its minimized state. 
Although this is an inconvenience, you will have to sink it again. 

21. On Draw Profile dialog, click the Add Surface Settings icon. 

 

22. The profile adds to the list box and drawn into the design file. 
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23. Click the Store Surface in COGO icon. 

 

24. Store Profile dialog opens. 

 

25. From the Store Profile dialog, enter the information as shown above and click Apply.  The profile is 
stored in the GPK file (COGO). 

26. Close Store Profile dialog.  
27. Disable the Draw toggle in the list box to disable (delete) the display of the existing ground profile. 

 

28. Select the COGO tab. 
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29. For Profile, select Profile EXGROUND. 

 

30. Enable the By Feature option under Display Settings and then select the same feature used previously 
to plot the profile. 

 

31. Enter 50 for the Label Scale and click the Add COGO Profile Settings icon.  

 

32. The profile adds to the list box and drawn into the MicroStation design file. 

 

33. Close Draw Profile. 
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Exercise 2.2 Display Existing Ground Profile in COGO 
In this exercise, the user will display the profile in COGO and review the information.  

1. Access Project Manager. 

2. From Road Project dialog, click the Coordinate Geometry icon. Coordinate Geometry 
opens. 

 

3. From Coordinate Geometry menu, select Tools > Navigator. Navigator dialog opens. 

   

4. From Navigator dialog, select Profile from the Element pulldown. 
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5. Select EXGROUND and then click the Print/Describe Element icon. 

 

6. Close the Navigator dialog. 

7. In Coordinate Geometry dialog, the stations and elevations of each VPI used to store the profile 
appear in the display window. 

 

8. Close Coordinate Geometry dialog.  

9. An Alert dialog opens prompting to save the session. Click No. 

 

Note If you click the Yes icon, a prompt displays to enter a file name to create an input file listing the 
commands that were just used in COGO. In this case, Print Profile EXGROUND was the only 
COGO command used.  
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Exercise 2.3  Updating the Working Alignment 
In this exercise, the user will update the Working Alignment in Project Manager. 

1. From Road Project dialog, click .  Working Alignment Definition dialog opens. 

2. From Working Alignment Definition dialog, select the category Profile View. 

 

3. Click File and select the Design File:  
DSPFRD01.dgn. 

  

 

 

 

4. Click Select beside the Existing Profile field. 
The Profile Selection dialog opens. 

 

 

 

 

5. Select the profile EXGROUND and click OK. 
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6. From Working Alignment Definition dialog, select the catagory Location. 

 

7. Click the Identify Cell icon. 

8. Select and accept the profile cell drawn in DSPFRD01.dgn.  The profile cell information appears in 
Working Alignment Definition dialog. 

 

Note Your coordinates may be different from those shown in the dialog image above. 

9. Click OK. Working Alignment Definition dialog updates and closes. 

10. Exit MicroStation. 
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3 EXISTING CROSS SECTIONS 

OBJECTIVES 
• Drawing Pattern Lines 

• Drawing Existing Ground Cross Sections 

• Drawing Existing Utilities on Cross Sections 

• Update Working Alignment 

WORKFLOW 
Plotting of Existing Cross Sections begins by determining where the cross sections cut. Pattern lines are 
drawn into a 2D plan-view design file, one pattern line for each desired cross section.  FDOT provides a 
cross section seed file, FDOTSEEDXS.DGN. This seed file has four (4) models, one of which is Pattrd 
(Pattern Lines) which stores the pattern lines. From these pattern lines, locations of the existing cross 
sections are determined and then the existing ground cross sections created. The user draws Existing 
Features, such as base and utilities with the existing ground line plotted. 

PATTERN LINES 
Pattern lines are simply a line drawn in MicroStation that determines the location and width of the cross 
section. There are three ways to draw Pattern lines:  

• Draw Pattern Lines,  

• Draw Pattern Lines from XS, 

• Use the MicroStation Draw Line tool.  

DRAW PATTERN LINES FROM XS 
The Draw Pattern Lines from XS tool is the most common option used to recreate the pattern lines, if for 
some reason, the original pattern line data was lost after creating the cross sections, or if importing the 
cross sections from another program (e.g. CAiCE). 

DRAW PATTERN LINES 
The user utilizes Draw Pattern Lines to place pattern lines in a cross section design file (using the pattern 
line model) prior to cutting existing ground cross sections.  
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ACCESSING DRAW PATTERN LINES 

• From the Road Project dialog, click , and then click on OK from the 
Select Run dialog.  

 

• From MicroStation, select Applications > Road > Cross Sections > Draw Patterns by 
Station Range. 

• From the Road toolbox, click Draw Patterns by Station Range.  
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OVERVIEW OF DRAW PATTERN LINES  
Draw Pattern Lines should be opened with Project Manager open.  This is the only way to access the 
Select Run dialog, which allows the user to create a new run and thus be able to save settings for future 
reference and or reuse.  

The dialog divides into three main sections:  

• The project specific information at the top of the dialog contains the job number and the 
Chain Name. The Chain Name must be previously stored within the Coordinate Geometry 
database.  

• The location of the pattern lines information in the middle section of the dialog gathers the 
information for the using stations and offsets. If the alignment has station equations, regions 
may also be included.  GEOPAK will compute the stations based on a specified chain and 
display the value in the corresponding station field.  

• The how to information in the bottom section of the dialog includes directions on how to 
place the pattern lines from spacing requirements to symbology. 

Job This specifies the GPK file used. 

Chain This specifies the chain representing the alignment used for the cross sections. 

Beginning  

Left Offset This specifies the start of the first pattern line relative to the centerline. 

Station  This specifies the location of the first station.  Clicking the DP icon to the right of each 
station gives the designer the option to graphically select the station by placing a Data 
Point on the screen. Therefore, it is handy to have the alignment and plan view design 
files referenced to the pattern model of the cross section file. 

Right Offset This specifies the end of the first pattern line relative to the centerline. 

Ending  

Left Offset This specifies the start of the last pattern line relative to the centerline. 

Station  This specifies the location of the last station.  Clicking the DP icon to the right of each 
station gives the designer the option to select graphically the station by placing a Data 
Point on the screen. Therefore, it is handy to have the alignment and plan view design 
files referenced to the pattern model of the cross section file. 

Right Offset This specifies the end of the last pattern line relative to the centerline. 

 Positive offsets extend from the centerline in the directions indicated by the offset box 
(i.e. Left Offset (+) or Right Offset (+).  If entering a negative offset  into the Left Offset (+) 
field, the pattern will actually start on the right side of the centerline. So, if a pattern line is set 
at -10 for the Left Offset (+) and 150 for the Right Offset (+), a pattern line 140 ft. long is 
created starting at 10 ft to the right of the centerline 

If the Beginning offsets are wider than the Ending offsets, GEOPAK incrementally shortens 
the width of each pattern line until it reaches the end pattern line. 
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Spacing This defines the spacing of the pattern lines and supports several options.  

 

Increment When drawn, Patterns are at the specified interval when added to the beginning station. 

Even Patterns are placed at even stations based on value in the key-in field, but are not based 
on the beginning station. 

Once When drawn, only one pattern displays based on the station in the beginning station 
field and utilizing the offset in the beginning area. The ending station area ghosts for 
this option. 

Control Points 
Horizontal 

When drawn, Patterns displays at each horizontal critical point. 

Control Points 
Vertical 

 

When drawn, Patterns displays at the beginning (VPC) and ending station (VPT) for 
each vertical curve. In addition, a pattern is drawn at the high or low point on each 
vertical curve. 

Superelevation 
Transitions 

 

This scans current design file and reference files for superelevation shapes created with 
the specified chain. This draws a pattern line at the beginning and end of each 
superelevation shape, including the beginning and ending station fields in the dialog 
box. 

Skew Angle This allows for skewing the angle of the pattern line by a specified angle and places 
normal pattern lines perpendicular to the referenced chain. 

Level 
Symbology 

This reflects symbology of the pattern lines that are to be drawn. 

Draw Pattern 
Lines 

This draws the pattern lines in the design file. 
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EXISTING GROUND CROSS SECTIONS 
Once pattern lines determine the locations of the cross sections, the user utilizes Draw Cross Section to 
plot the Existing Ground Cross Sections into the cross section design file’s Rdxsrd model. The Draw 
Cross Section, using the Surfaces tab, draws existing ground lines or other surface lines (within a 2D 
MicroStation design file) utilizing a GEOPAK binary DTM file (TIN file). To generate existing cross-
sections utilizing digital terrain modeling, there must be a .gpk file containing the horizontal alignment 
chain, a TIN file, and, with plotting of cross sections by DGN, there must be pattern lines.  

ACCESSING DRAW CROSS SECTIONS 

• From the Road Project dialog, click the  icon, and then click on OK in the 
Select Run dialog.   

 

• From MicroStation, select Applications > Road > Cross Sections > Draw Cross Sections 
from Surfaces  

• From the Road toolbox, click the Draw Cross Sections from Surfaces icon, 

   



Chapter 3______________________________ EXISTING CROSS SECTIONS - Existing Ground Cross Sections 

3-6  ©2011 FDOT  FDOT GEOPAK for Roadway Designers - Advanced 

OVERVIEW OF DRAW CROSS SECTIONS 
The preferred method to open Draw Cross Sections is via Project Manager and Road Project. When 
using the Road Project, the majority of the information displays at the time Draw Cross Sections opens. 
This information automatically pulls from the Working Alignment Definition. 

File The file options are utilized to "remember" more dialog settings than the dialog 
resource file. The default extension is .xsd. 

Load This loads a previously saved settings file. 

Save This saves the dialog into an existing settings file. 

Save As  This saves the dialog settings into a new settings file. 

Exit This closes the dialog. 

Edit Several options are available to assist the user in manipulating the information in 
the dialog:  Not all of these options are available for the XS Cells tab. 

Cut Rows This cuts a row from the list box into the buffer. Unless the line is pasted back 
into the list box, the information is deleted from the list box and is no longer 
displayed.  Not available for XS Cells tab. 

Copy Rows This copies a row from the list box into the buffer. Utilize if several rows have 
similar information. Copy, paste, and then modify s line, rather than manually 
entering every line into the list box. Not available for XS Cells tab. 

Paste Rows This pastes a row from the buffer into the list box for subsequent editing.  Not 
available for XS Cells tab. 

Save Dialog  
Settings 

This stores the current dialog box settings to the resource file. 

Restore Saved 
Settings  

This populates the dialog box with settings from the previous session via the 
resource file. If the resource file has been deleted, the settings cannot be 
restored. 

Clear Surface     
List 

This removes all rows from within the list box. 

Update Options The Update Options turns off/on by each selection of the option. The check to 
the left of the option indicates the option is active. Only one option may be 
active at any given time, therefore, if selecting an option, the previous active 
option is de-activated.  

 

Delete Existing 
Elements and 

Redraw 

Any existing ground lines previously drawn with Draw Cross Sections are 
deleted and new ground lines are drawn. 
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Delete Non 
Modified Elements 

and Redraw 

Only existing ground lines previously drawn with this tool AND not modified 
are deleted and new ground lines are drawn. Any ground lines previously drawn 
with this tool and modified are left intact. 

Draw on Top of 
Existing 

Ignores any previously drawn ground lines and a new set is drawn, resulting in 
two sets of ground lines. 

Query When activated, a prompt opens each selection of Draw. The user must select 
one of the three options and click the Apply icon to begin processing. Clicking 
the Cancel icon closes the dialog box with no further processing. 

Job Number This is a requirement to identify the coordinate geometry database wherein the 
chain for generating the cross sections is stored. 

Chain This is a requirement to reference an alignment within each cross section. The 
subsequent specifications of station ranges and computes left/right offsets 
relative to this baseline when pattern by station is utilized. If pattern by design is 
utilized, the intersection of each pattern line with the baseline determines the 
station of the cross section. 

DP Origin When checked, a prompt displays requiring a Data Point for the location in the 
file to begin cross section placement. 

 Select the Draw icon after all information on the Draws Cross Sections dialog has been 
reviewed and set as desired.  It draws the cross sections into the active model of the 
current design file. 

XS CELLS TAB 
When generating existing ground cross sections, the user must indicate where each cross section is to be 
drawn.  In addition, the cross section width, the chain utilized for the cross sections, as well as, how far 
apart cross sections are drawn must all be dictated to GEOPAK. Draw Cross Sections supports three 
methods of identifying this information: By Station, By DGN File and In Existing Only. 
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Pattern 

 

 

By Station These are parameters, which indicate where each cross section is located. This method 
consists of only key-in fields and no graphical representation. The begin and end 
station for the specified chain is displayed by default and may be manually changed. 

 
Begin Station - The station of the first cross section 

End Station - The station of the last cross section 

Spacing - Determines the spacing, Even or Increment, of the cross sections.  

Left Offset - Length of the cross section to the left side of the baseline. 

Right Offset

By DGN File 

 - Length of the cross section to the right side of the baseline. 

This defines the parameters graphically in the pattern model of a cross section design 
file. Each line or line string (pattern line) represents the generation location of a cross 
section. 

 
The information shown in the above figure is populated automatically via the Working 
Alignment Definition. The following instructions apply only if  there are no working 
alignment defined. 

Design File - Specifies the design file where the pattern lines are located. Click on the 
magnifying glass to the right of the Design File box and navigate to the desired cross 
section design file with the Pattrd Model containing the pattern lines. 
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Levels - Specifies the level that the pattern lines are drawn on. There are three options 
to select a level:  

• Activate levels by clicking the box to the left of Levels. Then, type in the 
name of the level <OR> 

• Click on the icon   to the right of the Levels and select the level from a 
list  <OR> 

• Click on the Match icon and click on a pattern line in the design file, then 
click again to accept it. The level will then fill in automatically.  

Using the FDOT Standards, only the level name is required, since the  Colors, Styles 
and Weights should be set at ByLevel. 

Color - Specifies the color of the pattern lines. The selection process is the same as 
that for levels. 

Styles - Specifies the line style of the pattern lines. The selection process is the same 
as that for levels. 

Weights - Specifies the weight of the pattern lines. The selection process is the same 
as that for levels. 

Match - Sets the symbology of the pattern lines by clicking on an existing pattern line. 

Reset - Resets the symbology settings. 

Display - Highlights all pattern lines that meet the specified symbology. 

In Existing 
Only   

Determines the location and width of the cross section based on cross section cells that 
already exist in the active file. 

 
Scale

 

 - Horizontal/Vertical determines the Horizontal and Vertical scale of the cross 
section. 

Spacing

 

 - Horizontal/Vertical determines the Horizontal, and Vertical spacing of the 
cross section cells. Number of XS by Column determines the Number of XS by 
Column.  This specifies how many cross sections will be placed in each column in the 
design file. Normally the defaults are sufficient. 
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SURFACES TAB 
The Surfaces tab defines the surfaces that constitute the existing cross section. Multiple surfaces can be 
used; each surface is represented in the cross section by a separate line or line string. When first opened, 
there is generally a slight delay as data is loaded before the dialog becomes active. 

 

The majority of the information shown in the above figure populates automatically via the Working 
Alignment Definition. The user enters or manually sets some of the following information. 

Surfaces List 
Box 

Displays the surfaces used to create the cross sections. The following icons are to the 
right of the list box: Add Surface, Modify Surface Settings, or Remove Surface. 

Details This specifies the surface and settings for each surface used to draw the cross sections. 

TIN File This specifies the TIN file for the surface. 

Method  This specifies the type of data contained in the TIN file. The two options are Triangles 
and Breaklines. 

Type This specifies the element type of the cross section ground line. The two options are Line 
and Line String. 

Display 
Settings 

This specifies the display symbology of the cross section elements. The two options are: 

By Level 
Symbology 

This requires the user to define the level, color, weight, and line style of the cross section 
elements. 

By Feature This allows the user to select a feature from the Design and Computation 
Manager database to determine the properties of the cross section elements. 

Filter The user considers both Horizontal and Variance filter tolerances together for each pair 
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Tolerances of cross section segments.  If both segment lengths are less than the Horizontal filter 
tolerance AND the projected distance between the mid-point and the chord between the 
two end points is less than the Variance tolerance, the middle point is deleted. 

Text Settings This specifies if user places an Elevation at the centerline of the cross section and the 
text settings of the elevation text.  If the Elevation Toggle is checked and the user double 
clicks the element symbology box to the right of Elevation, the following dialog appears. 

 

Void Determines if voids in the DTM are plotted on the cross sections and the symbology used 
to represent void areas. 
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EXISTING UTILITIES ON CROSS SECTIONS 
The placement of existing underground utilities onto cross section sheets has been simplified by the use of 
an interactive dialog called Draw Ancillary Features. This dialog interacts with a selected utility design 
file that contains elements with the correct symbology or features that represent various types of utilities. It 
will search for specific utilities, measure the horizontal distance from a controlling baseline and plot a user 
defined symbol or cell at a specified depth of cover, based on a tin file. If the existing underground utility 
design file contained chains and related profiles for those chains, then exact elevations could be plotted. 

ACCESSING DRAW ANCILLARY FEATURES 
From MicroStation, select Applications > Road > Cross Sections >Draw Ancillary Features. 

<OR> 

From the Road toolbox, click the Draw Ancillary Features icon. 

 

   

OVERVIEW OF DRAW ANCILLARY FEATURES 

File  

Load This loads a previously saved settings file (.afd). 

Save This saves the dialog settings into an existing setting file (.afd). 

Save As This saves the dialog settings into a new settings file (.afd). 

Exit This closes the dialog. 
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Update Options 

Delete Existing 
Elements and  

Redraw 

Any existing ancillary features previously drawn with Draw Ancillary Features 
are deleted and ancillary features are drawn. 

Delete Non   
Modified 

Elements and  
Redraw 

Only existing ancillary features previously drawn with this tool AND not 
modified are deleted and new ancillary features are drawn. Any ancillary features 
previously drawn with this tool and modified are left intact. 

Draw on                
Top of Existing   

Any previously drawn ancillary features are ignored and a new set is drawn, 
resulting in two sets of ancillary features. 

Query When activated, the user is prompted each time Draw is clicked. The user must 
select one of the three options and click the Apply icon to begin processing. 
Clicking the Cancel icon closes the dialog box with no further processing.  

At the time of this writing, the Edit Option does not function. This option has been 
added as a placeholder for future enhancements. 

Job Required to identify the coordinate geometry database where the chain for 
generating the desired offsets of the utility is stored. 

Chain Alignment used to generate the cross section or profile cell.  

The subsequent specifications of station ranges and left/right offsets are computed 
relative to this chain when pattern by station is utilized.  

If pattern by design is utilized, the intersection of each pattern line with the 
baseline determines the station of the cross section.  

View Defines the type of view that the utilities will be plotted to; Profile or Cross 
Section.  

Label Scale Utilized when the By Feature Display settings option is utilized. The specified 
Label Scale is compared to the scale within the D&C Item and the text is adjusted 
based on the ratio between these two scales. Note this option is only used if the 
text setting in the D&C Manager is set to scale, not fixed. 

Station Range When the Chain field at the top of the dialog is populated, its beginning and 
ending station are displayed in the Station Range group box. The defaults may be 
utilized if the entire profile is drawn. However, manually entering stations or 
clicking Set Station and graphically identifying a location are supported. In the 
case of cross sections, the stations are determined by the pattern lines and the 
correct stations are not necessarily displayed. 

Draw The Draw button should be selected after all information on the Draws 
Ancillary Features dialog has been reviewed and set as desired. It draws 
the ancillary features into the active model of the current design file. 
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List Box    Each ancillary feature to be drawn must be added to the list box. The action icons 
on the right side of the dialog accomplishes this.  Required information is the 
element type, elevation and display settings. 

 

Add                     
Element Set     Adds the ancillar y information to the list box. 

Modify                
Element Set    Modifies the currently selected ancillary item in the list box. 

Delete             
Element Set      Deletes the currently selected ancillary item in the list box.  

Draw 
 Disables/Enables the drawing of selected ancillary item in the list 

box. 

Intersecting 
Elements 

The Intersecting Elements section of the dialog is where the user defines how the 
horizontal (offset) and vertical (elevation) parameters for the ancillary feature will 
be computed. 

 

Horizontal 
Parameters 

A variety of data sources exists to define the horizontal location of the desired 
ancillary feature. 

 
Chain 

 

- COGO chain stored in the GPK file defined at the top of the dialog. The 
location of the chain is used to determine the horizontal location of the ancillary 
feature. 
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Survey Chain

 

 - Survey chain stored in the GPK file defined at the top of the 
dialog. The location of the chain is used to determine the horizontal location of the 
ancillary feature. 

Level Symbology 

 

- Scans the specified design file for any element specified 
symbology.  If it crosses the profile or cross section cell, the location of the 
element is used to determine the horizontal location of the ancillary feature. 

The tool defines the symbology to use for locating the ancillary feature. 

Feature

 

 - Scans the specified design filefor any element matching the specified 
D&C feature symbology.  If it crosses the profile or cross section cell, the location 
of the element is used to determine the horizontal location of the ancillary feature. 

Vertical      
Parameters 

A variety of data sources exist to define the vertical location of the desired 
ancillary feature.  The data source selected for the horizontal parameters, affects 
the data sources available for the vertical location. 

Cogo Profile

 

 - If Chain was selected for the horizontal parameters, the 
elevation can be determined from a specified Cogo Profile if it exists.  

If no Cogo Profile exists or if the user wishes to create a different 
elevation, you can enable the Extract toggle and select one of the three sources 
for the elevation. 
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Survey Chain

 

 - If Survey Chain was selected for the horizontal parameters, the 
elevation can be determined from the specified Survey Chain.  The elevation in 
the survey chain can be overridden by enabling the Extract Elevation toggle and 
selecting one of three sources for the elevation. 

  If Level Symbology or Feature is selected to define the horizontal 
parameters, the Extract Elevation toggle must be enabled to set the elevation. 

 Extract Elevation

o TIN Elevation will be determined from the tin file at the horizontal 
location of the ancillary feature.  

 - Enable this toggle and then select on of the following data 
sources: 

 
o Level Symbology Scans the limits of the profile or cross section 

cell and uses any element of the specified symbology. The elevation is 
then determined from this element at the horizontal location of the 
ancillary feature. 

 
o Feature  Scans the limits of the profile or cross section cell and 

uses any element of the specified D&C feature symbology. The elevation 
is then determined from this element at the horizontal location of the 
ancillary feature. 

 
o Adhoc Attribute  Although this is listed as an option, there is no 

way to define it so it should not be used. 

Vertical Offset

Display Settings 

 This offset applies to the elevation after it is determined from 
one of the sources detailed above.   

These are three options supported for displaying the ancillary features. 

Cell 

 
Cell Name - Cell drawn to represent the ancillary feature.  

Symbology - Activating this toggle and specifying the symbology will override the   
graphical symbology of the given cell. 
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Scale - Scale used for cell placement. 

Apply Vertical Exaggeration - Activating this toggle and setting the scale will 
distort the cell. 

Justification

Symbol 

 - A variety of standard justifications are supported. 

 
Symbol  - Set the desired symbol from a standard pictorial list.  

Symbology - Specifying the symbology will set the graphical symbology of the 
symbol. 

Justification - A variety of standard justifications are supported. 

Width – This is symbol width. If no height is given, then this value is default for 
both the height and the width. 

Height

Text 

 - Enable the toggle and specify the height of the symbol. Setting a value 
different from the width will result in distortion of the symbol. 

 

 
Sample 

 

 - Double-clicking on the sample 
graphic will access the Text Symbology 
dialog. This dialog allows the user to set the 
symbology of the text placed as well as any 
desired offsets. 

 

Angle - Text rotates by setting the angle. 

Label 

  - Clicking this icon will display 
several intrinsic variables than can be used in the creation of the label. Brackets {} 
must encompass these intrinsic variables (e.g. Station, Offset, Elevation, etc.). 

- Any desired text string to insert and 
use.  
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Exercise 3.1 Drawing Pattern Lines  
In this exercise, the user will draw our pattern lines to define the locations of our existing ground cross 
sections. 

1. Double-click on the self-extracting zip file C:\Chapter3_Exercises.exe and click the Unzip icon at 
the prompt. This will extract and setup the files needed for this exercise. 

2. Open the design file C:/E/Projects/22807915201/roadway/RDXSRD01.DGN. 

 The active model is already set to Pattrd. In addition, the files DSGNRD01.dgn and ALGNRD01.dgn are 
already referenced to the model. 

 

3. Access Project Manager.  The Road Project dialog should appear since we “remembered” the 
project and user in a previous exercise. 

4. From Road Project, click the  icon.  

5. From the Select Run menu, select Run > New. 

 

6. From the New Run Name dialog, key-in the Run Name, XSPATT, and Description, and click OK. 
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7. In the Select Run dialog, select the run XSPATT and then click OK.  

 

8. The Draw Pattern dialog opens. 

 

 The Job and Chain automatically fill by the Working Alignment. 
9. Key-in a Beginning Station of 76+00 and an Ending Station of 120+00. 

10. Key-in a value of 200 for both Left and Right Offsets. 

11. Set the spacing option to Even and key-in 100 for the spacing. 

 

12. Double-click in the Level Symbology box.  
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13. GEOPAK Set Feature opens. 

 

14. On GEOPAK Set Feature, select PatternLines1_dp in the Level list.  

Note The Levels list alphabetically. Type the first letter of the level you are looking for, in this case the letter 
‘P’. This will move you to the first level starting with the letter P.  

15. In the Color list, select ByLevel.  

16. In the Style list, select ByLevel. 

17. In the Weight list, select ByLevel. 

18. Click OK. The changes save and GEOPAK Set Feature closes. 

19. On Draw Pattern Lines dialog, click the Draw Pattern Lines icon to draw the pattern lines into the 
design file. 

 

20. Close Draw Pattern Lines. Click Yes when prompted to Save Settings. 
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Exercise 3.2 UPDATING Working Alignment 
In this exercise, the user will update the Working Alignment with our pattern information. 

1. From Road Project, click the Define icon. Working Alignment Definition dialog opens. 

2. From Working Alignment Definition dialog, select the category Pattern.  

 

3. Click By Station and change the option to By Design File.  

 

4. The dialog changes to display the By Design File options. 

 

5. For Horizontal Scale, key-in 20. 

6. For Vertical Scale, key-in 10. 
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7. For Design File, select C:\e\Projects\22807915201\roadway\RDXSRD01.DGN. 

 

8. Enable the toggle for Lv Names. 

 

9. Click on the Match icon. 

10. In the design file, Data Point on a pattern line, and then Data Point again to accept. The Lv Names 
field populates with the name level name PatternLines1_dp. 

 

11. Right-click on the Placement Symbology box and select By Element. 

 

12. In the design file, select a pattern line then Data Point again to accept. The Placement Symbology 
dialog will populate with the correct pattern symbology. 

 

13. From Working Alignment Definition dialog, click OK to save and close. Working Alignment 
Definition dialog closes. 
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Exercise 3.3 Drawing Existing Ground Cross Sections 
In this exercise, the user will cut existing ground cross sections. 

1. In the design file RDXSRD01.dgn, change the Active Model to Rdxsrd. 

 

2. On the Road Project, click the Existing Ground Cross Sections icon.  

 

3. On the Select Run menu, select Run > New. 

 

4. Key-in the Name XSGROUND and a Description in the New Run Name dialog and click OK. 
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5. Select XSGROUND in the Select Run dialog and click OK. 

 

6. The Draw Cross Sections dialog opens. 

 

 The XS Cells tab of the dialog fills out by the Working Alignment Definition. 
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7. On Draw Cross Sections dialog, select the Surfaces tab to access the surface definition portion of the 
dialog. 

 

 The information from the Working Alignment Definition has populated the Surfaces Tab with the settings 
known up to this point. 

8. Under Display Settings, select By Feature.  

 

9. Click the Browse Feature icon . Select Design & Computation Payitem dialog opens. 

10. In Select Design & Computation Payitem dialog, select the Feature CSEGL and click OK. 
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11. On the Draw Cross Sections dialog, the symbology changes to that of the selected feature. 

 

12. Right-click on the By Feature symbology box, as shown below and then select Copy. 

 

13. Enable the Void symbology toggle. 

 

14. Right-click on the Void symbology box and select Paste.  

 

15. The Void symbology will change to be the same as the Existing Ground symbology. 

 

16. Change the Type to Line String. 
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17. Enable the Elevation toggle. 

 

18. Double-click in the Text box.   

 

19. GEOPAK Set Feature dialog opens. 

 

20. Set the Elevation Text Features to match those in the next figure, and then click OK.  
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21. GEOPAK Set Feature dialog closes. 

22. Click the Modify Surface icon. 

 

23. The Surface settings update in the list box. 

 

24. On Draw Cross Sections dialog, click the Draw icon to process the existing sections. 

25. Close the Draw Cross Sections dialog. Click Yes when prompted to Save Settings. 

26. From the MicroStation menu, select Edit > Select All. 

27. From the MicroStation menu, select Edit > Lock. 

28. From the MicroStation menu, select File > Save Settings. 
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Exercise 3.4 Reviewing Cross Sections  
In this exercise, the user reviews our existing ground cross sections using the Cross Section Navigator. 

1. Sink the Road Project dialog. 

2. From the Road toolbox, click the Cross Section Navigator icon. 

 

3. Cross Section Navigator opens. 

 

4. Use the navigation icons to browse through the cross sections. 

 

5. Use the Station List dropdown to access any particular station. 

 

6. Close Cross Section Navigator. 
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7. From the FDOT Menu, select Actions > GEOPAK VBA Utilities > Review Cross Sections in 
Animation.  The VBA Cross Section Movie dialog opens. 

 

8. Click the Play Forward icon to browse through the sections automatically. 

 

9. Change the Frame Rate to 8 and then click the Play Reverse icon. 

 

10. Close the VBA Cross Section Movie dialog. 
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Exercise 3.5 Exercise 3.5 UPDATING Working Alignment  
In this exercise, the user will update the Working Alignment with the cross section information. 

1. Access Project Manager. 

2. From Road Project, click the Define icon to access the Working Alignment Definition dialog. 

3. Select the category Cross Section View. 

 

4. Click the File icon and select the design file:   
C:\E\Projects\22807915201\roadway\RDXSRD01.dgn.  

5. The Chain, Begin Station and End Station will populate automatically. 
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6. Select the item Existing Ground. 

 

7. Enable the toggles for Lv Names and Types. 

 

 

 

 

 

8. Click the Match icon.  

9. Place a Data Point on an existing ground line element from one of the cross sections.  

10. Place another Data Point to accept. The symbologies are 
populated. 

 

 

 

 

 

11. Right-click in the Placement symbology box and select By 
Element. 

 

 

12. Place a Data Point on an existing ground element from 
one of the cross sections. 

13. Place another Data Point to accept. The Placement symbology updates. 

 

14. On Working Alignment Definition dialog, click OK. Working Alignment Definition dialog closes. 
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Exercise 3.6 Drawing Existing Utilities on Cross Sections 
In this exercise, the user will draw existing utilities onto the cross sections using the Draw Ancillary 
Features application. 

1. Open MicroStation design file C:\E\Projects\22807915201\utils\UTEXRD01.dgn. 

2. Sink the Road Project dialog. 

3. From Road tools, click the Draw Ancillary Features icon. 

 

4. Draw Ancillary Features dialog opens. 
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5. Select Chain BL817. 

 

6. Under Intersecting Element, select the Level Symbology. 

 

7. Click the Intersecting Element Symbology icon. 

 

8. The Intersecting Element Symbology dialog opens. 
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9. Fill out the dialog as shown below: 

 

10. Close the Intersecting Element Symbology dialog. 

11. Type in or select the design file C:\e\Projects\22807915201\utils\UTEXRD01.dgn. 

 

12. Enable the toggle for Extract Elevation. 

 

13. Type in or select the TIN file C:\E\Projects\22807915201\roadway\site.tin.  

 

14. Key-in a Vertical Offset of -2.00 

 

15. Set Display Settings to Cell. 

 

16. Under Display Settings, key-in the cell name XPIPE. 

17. Key-in 2 for Scale. 

18. Set Justification to Center Top. 
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19. Enable the Apply Vertical Exaggeration toggle. 

 

20. Enable the Cell Symbology toggle. 

 

21. Double-click on the Cell Symbology graphic to open the Cell Symbology dialog. Set as shown below 
and Click OK. 

 

22. Click on the Add Element Set icon to add the utility to the list box. 

 

23. Set the Display Settings to Text. 

 

24. Double-click on the Text Symbology box. 
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25. The Text Symbology dialog opens. 

 

 

 

 

 

 

 

 

 

 

26. Fill out the dialog as shown in the figure and click OK. 

 

 

 

 

 

 

 

 

 

 

27. In the Label box, key-in a 
label for the utility (e.g. 
Water). 

 

 

 

28. Click the Add Element Set 
icon to add the utility to the 
list box. 

 

 

 

29. Repeat steps 6 through 24 for each of the following utilities, using the specified vertical offset for each.  

Note There are a couple of things to remember:  First, make sure that when you set the symbology for each 
subsequent utility that you clear out the existing symbology in the dialog by using the Reset icon. If you 
do not do this then you may end up appending additional symbology instead of replacing what is 
already in the dialog. Second, as you add each additional utility do not forget that each utility requires 
two entries in the list box: 1 entry to be displayed with a cell and a 2nd entry to be displayed with a text 
string. 
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30. For Buried Telephone, use a Vertical Offset = -4.00. 

 

31. For Sanitary Sewer, use a Vertical Offset = -6.00. 

 

32. For Buried Cable TV, use a Vertical Offset = -2.00. 

 

33. For Buried Conduit, use a Vertical Offset = -3.00. 
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34. For Buried Gas, use a Vertical Offset = -5.00. 

 

35. Without closing Draw Ancillary Features, open the design file:  

c:\E\Projects\22807915201\roadway\RDXSRD01.dgn. 

36. Change the View option to Cross Section. 

 

37. From the Draw Ancillary Features menu, select File > Save.  The Save afd File As dialog opens. 
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38. Key-in the File Name BL817UTILS.afd and click OK. 

39. From the completed Draw Ancillary Features dialog, click the Draw icon to process the utilities and 
draw them into the cross section file. 

 

40. Toggle on the Delete Existing Elements and Redraw in the Update Option dialog and click Apply. 

 

41. Close Draw Ancillary Features dialog. 

42. Review the cross sections and utilities using Cross Section Navigator. 

43. From the MicroStation menu, select Edit > Select All. 

44. From the MicroStation menu, select Edit > Lock. 

45. Exit MicroStation. 
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4 PROPOSED PROFILE & ACTIVE 
CHAIN CONTROL 

OBJECTIVES 
• Visualization of the Profile Through COGO  

• Draw the Vertical Alignment to FDOT Standards Using the Draw Profile Tool.  

• Update the Working Alignment.  

• Overview of Active Chain Control 

• Set Up of Active Chain Control 

 

This chapter discusses creating a vertical alignment (profile). The users will create a proposed profile with 
Layout Profile (VPI Based), which opens the Profile Generator. The setup and use of GEOPAK Active 
Chain Control enables the user to manage plan, profile, and cross section views simultaneously. It also 
allows usage of MicroStation tools to place elements in any view based on the Curvilinear Coordinates 
settings. In this chapter, the following topics are covered:  

Creation of a vertical alignment (profile) by duplicating a portion of the proposed profile PGL-RT using 
Key-ins is covered. This profile will be re-created using the existing ground profile cell as an anchor.   This 
will be done using Layout Profile (VPI Based) also known as Profile Generator. 
The attachment of the correct K Value file (kvl) is detailed. This profile, as did the original, will not have 
any vertical curves because the back and ahead grades for each VPI is less than the maximum required 
algebraic difference for grade at the specified design speed.  

Creation of a vertical alignment (profile) using the Profile Generator’s Dynamic option creating grades 
and VPIs by dynamic graphical manipulation. Creation of the profile starts at the first point of the 
previously created existing ground line profile. The VPIs place dynamically and the grades graphically 
manipulated so that vertical curves based on design speed and K Values are required. The user manipulates 
vertical curves for lengths that are appropriate for placement in a plan set and corrected for any overlap, 
using Profile Generator tools.  Preferences will be set based on desired rounding of grades and lengths. 
Preference settings primarily affect the use of the Dynamic option.  
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PROFILE GENERATOR  
The Profile Generator is a tool used to graphically create, manipulate and store proposed profiles or modify 
existing profiles.  Profile generates and modifies under the control of an interactive dialog box.  The user 
can choose to key-in stations and elevations and/or use dynamic graphical manipulation to insert or modify 
VPIs with the click of a mouse. 

FDOT provides K-value tables for establishing the stopping sight distance for crest and sag curves. Once 
the user enters design speed, the profile generator reads the K-value table and draws a vertical curve at the 
maximum K-value settings applicable to the speed selected. The user modifies vertical curve length 
manually by entering a length to round to an even number. 

ACCESSING PROFILE GENERATOR 

From the Road Project dialog, click the  icon  

<OR> 

From MicroStation, select Applications > ROAD >Geometry > Layout Profiles (VPI Based)  

<OR> 

From the Road tool box, click the Vertical Alignment icon.  
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SETTINGS DIALOG 
The purpose of the Settings dialog is to identify the area in the design file where you will be working. 
Unlike an alignment that has coordinates and a specific location in a design file, a profile has no specific 
location and can be placed anywhere in the design file. This dialog gives the software the necessary 
information to identify the profile location. 

Accessing Profile Generator (using any of the options mentioned above), opens a Settings dialog.  

 

Job This specifies the COGO database (.gpk) to be used to store or access a given profile 
name. 

Operator Code A two-character designation that identifies the operator/user (typically this would be 
the user’s initials). When any input or output files are stored this user designation is 
added to the name of the file. 

PGL Chain This specifies the alignment name that is associated with the profile. 

Location and Scales  

Horizontal           
Scale 

This specifies the Horizontal Scale of the plotted profile. 

Vertical              
Scale 

This specifies the Vertical Scale of the plotted profile. 

Reference           
Station 

This is the Beginning Station of the plotted profile, but not necessarily the beginning 
station of the profile. This reference station is used in conjunction with the reference 
elevation as a reference point when working with the profile. 

Reference       
Elevation 

A given elevation that is combined with the reference station to be used by the 
software as a reference point when working with the profile. 

X The X coordinate of the Reference Station/Reference Elevation location. This 
coordinate can either be keyed-in or set by the DP icon. 
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Y The Y coordinate of the Reference Station/Reference Elevation location.  This 
coordinate can either be keyed-in or set by the DP icon. 

DP icon This icon can be used to set the X and Y coordinates of the reference point. 

Profile Cell  

Draw Cell                 
at X,Y 

Plots a profile cell at the location given by the X and Y coordinates using the 
information in the Settings Dialog. This tags the profile cell with all of the above 
information for easy access by other dialogs in the future.   

Identify Cell This allows the user to select a previously plotted Profile Cell. All of the information 
is then Clicked up from this Profile Cell and used to populate the Settings dialog. 

OK Accepts and closes the Settings dialog, which then opens the Profile Generator 
dialog. 

Cancel This closes the Settings dialog without accessing Profile Generator. 

PROFILE GENERATOR MENUS 
Selecting the OK icon on the Settings dialog opens the Profile Generator dialog. The Profile Generator 
has two menus detailed below:  File and Tools. 
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PROFILE GENERATOR FILE MENU  
Preferences Preferences permits the specification of rounding parameters.  On Preferences, 

elevations, vertical curve lengths and VPI to VPI distances round to two decimal places, 
while grades round to one ten thousandth of a percent. The following figure shows the 
preferences that are acceptable to FDOT. 

 

Elevation Increment, Length Increment, and Grade Increment  - Defined in Preferences and affect 
dynamic operations while designing profiles. 

Curves 

 

Maintain Curve K Value - fixes the K value so that length is allowed to change based 
upon the fixed k value. 

Maintain Curve Length

Hold Vertical Curve - Check box works with Maintain Curve K Value and Maintain Curve Length 
to lock Vertical Curve information during VPI modifications.  If not selected, the vertical 
curve is allowed to respond to changes in the forward and back grades, length, and speed. 

 - fixes the length value and allows the k value to be adjusted 

Window Center Current VPI - Check box keeps the active VPI centered in the window during VPI 
modifications. 

Profile Cell Settings This opens the Settings dialog previously discussed. 

K Value Table Establish this once and rarely changed.  K Values for Stopping Sight Distance 
defines the stopping sight distance K-values for crest and sag conditions at various user 
specified design speeds. FDOT provides a K Value table located in the 
FDOT2008\GEOPAK\bin folder.   There are two files to choose from based on your 
project: 

FDOT_NonInterstate.kvl  - for freeway (non-interstate) roadways 

FDOT_Interstates.kvl

 

  - for interstate roadways 
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For definitions of the following terms, refer to the Glossary of Terms in the PPM 
Volume I chapter 2. 

 
Load Profile Loads previously stored profile selected from profiles that are located inside the .gpk 

file.   

 

Save Profile Stores a new profile or updates a previously stored profile under the same name in the 
.gpk file. Redefine must be ON-+ in COGO to update profiles.  

 

Save Profile As Stores the profile under a different name.   
 

Clear Profile Erases the information that currently displays in the Profile Generator along with the 
temporary graphics that are displayed in the MicroStation file. 

 

Draw Profile Changes the temporary graphics displaying the profile into permanent graphics using 
the active level symbology.  Typically, the user utilizes Profile Generator to display 
the profile with temporary graphics depicting your current level symbology.  The 
closing of Profile Generator erases the temporary graphics.     

 

 Exit Closes Profile Generator. 
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PROFILE GENERATOR TOOLS MENU 
The Tools menu has the following commands. 

Issue Data Point Enables the user to type in stations and elevations and issue a MicroStation Data Point 
that can be part of a place line, place cell or any other generic MicroStation operation.  
For example, a cell representing the low member or bridge beam could be placed with 
this tool.  

 

Critical Points Vertical curves define in terms of one or two critical points.  As can be ascertained from 
Critical Points in the following figure, the user may define the station and elevations for 
the critical points either by key-in or by placing a Data Point in the MicroStation file. If 
mathematically solvable, the vertical curve is drawn and the speed and K-value options 
adjust to the appropriate design speed. 

 

Best Fit There are three options for Best Fit:   
 Line, Parabola and Profile. 

 

 

 

Line This option fits a line between the candidate elements.  The resultant line data is 
displayed in the dialog and the line is drawn onto the profile cell.  
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Parabola This option fits a vertical curve between the candidate elements.  The resultant 
curve data displays in the dialog and the curve is drawn onto the profile cell. 

 

The fields below apply to both the line and parabola options: 

Display Only - Elements display only and not drawn into the MicroStation file when this 
toggle is on. 

Use Fence - The best fit line is drawn using only the elements within the fence when this 
toggle is on.   

Line/Parabola Data - The line data displays here. 

Identify Element

Profile This option fits a profile comprised of tangent lines and vertical curves between the 
candidate elements based on the constraints in the Design Parameters.   As there is no 
symbology option, the active symbology is used.   Use Fence and Identify Element 
operate as described above. 

  - This allows the user to identify elements used dynamically. 
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CALCULATING THE VERTICAL CURVE LENGTH 
The formula for calculating the Vertical curve length is L=KA where 

L= Minimum Length 

K= Constant based on design speed (look at the tables Volume I Chapter 2 in PPM) 

A= Algebraic Difference in Grades (percent) 

For this example, our road is an Arterial, the design speed is 60mph and we are designing a sag curve. 

K = 136 based on table in PPM Volume I Chapter 2. 

 

Back grade into sag curve is (-) 2.200% and grade ahead is (+) 1.200% 

The Algebraic Difference is 2.200 + 1.200 = 3.400 so A = 3.4  

Back to the formula: 

L=KA so L=136 x 3.4 or L = 462.4 

L = 462.4 is the minimum vertical curve length. 

The following figure shows the same results as above, except that the Profile Generator does the 
calculations. The Back Grade, Forward Grade and selected Design Speed were entered, and the Length and 
K value were calculated using the default.kvl table. 
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The following figure shows an example of a Crest vertical curve calculated by GEOPAK using the .kvl 
tables. Refer to the charts in the PPM to find that the calculations for Length and K Value meet the same 
design criteria as FDOT. 

 

 

ENTERING VPIS 
A vertical alignment can be stored in two ways: either manually input the stations and elevations or 
dynamically choose them. 

  

Station  This is the Station of a VPI. The icon on the right of box locks in the station. 

Elevation This is the Elevation for the previously entered Station.  The icon on right of box locks 
in the elevation. 
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Parameter Options: 

Off This allows full, unencumbered dynamics. GEOPAK attempts to round the associated 
parameter to the increment set in Preferences, but there is no guarantee. 

Inc Ensures that the designated profile parameter rounds in accordance with the increment 
defined in Preferences. 

Lock Forces all dynamic operations to maintain the designated profile parameter.  

Profile Generator provides Profile Parameter Option icons for the Back Grade, the 
Current VPI Station, the Current VPI Elevation and the Forward Grade.  There is no 
option icon for grade lengths because the current VPI station dictates grade lengths. See 
the following figure. 

 
Of the four Profile Parameter Option icons circled in the preceding figure, the 
following combinations are the only ones allowed: 

One can be Locked with the other three Off. 

One can be Locked, one can be set to Inc (increment) & the other two Off. 

Two can be set to Inc and the other two Off. 

Dynamic This allows the user to click on the profile, which populates the Station and Elevation 
boxes. When these ground rules are not satisfied, setting one Profile Parameter Option 
icon automatically and appropriately adjusts any conflicting Profile Parameter Option 
icon.   

For example, if the Station box is Locked and the user attempts to lock the Elevation 
box, the option icon for the Station box is unlocked and returned to the OFF setting. 

ACTIVE CHAIN CONTROL 
Active Chain Control enables the user to manage plan, profile and cross section views simultaneously. It 
also allows usage of MicroStation tools to place elements in any view based on the curvilinear coordinate 
settings.  Active Chain Control requires that the files representing the various views be referenced (i.e., 
plan, cross section and profile) before utilizing the tool.  
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ACCESSING ACTIVE CHAIN CONTROL 
From MicroStation, select Applications > GEOPAK Road > Active Chain Control  

--or--  

From the Road toolbox, click the Active Chain Control 
icon.   

 

 

 

 

Job Defines the GPK file to be used. 

Chain Defines the chain that is associated with the component views to be used with Active 
Chain Control. 

 

id  Used to graphically select the chain. 

Curvilinear Coordinates  Opens Curvilinear Coordinates dialog, which enables the user to 
enter precise curvilinear coordinates relative to the active chain. 

 

 

S This is the Station along the active chain. If the lock is on, the pointer follows a 
perpendicular line to the chain in plan views, and a vertical line in profile views. 

Ext. This is the Extension to the station along the active chain. A negative value means that 
the extension is before the beginning of the chain. A positive value means that the 
extension is after the end of the chain. 

O Offset from the active chain. If the lock is on, the pointer follows a parallel line to the 
chain in plan views. 
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Z Use this box to enter elevation. If the lock is on, the pointer follows a horizontal line in 
Profile views. 

DS Delta station from the previous Data Point or tentative point. If the lock is on, the pointer 
follows a perpendicular to the chain in plan views, and a vertical line in Profile views. 

DO Delta offset from the previous Data Point or tentative point. If the lock is on, the pointer 
follows a parallel to the chain in plan views. 

DZ Use this box to enter delta elevation from the previous Data Point or tentative point. If 
the lock is on, the pointer follows a horizontal line in Profile views. 

Permanent Lock    When selected, coordinate locks remain active, even after a Data Point 
is clicked. 

Apply Click to send a Data Point to the input queue. Entering a Data Point by a click in a view 
has the same effect.  

Tip   Use the check box(es) at the left of one or more boxes to lock the value of the 
associated box(es). 

Profile Cell Status icon  Displays the status of the profile component view.  If the Profile Cell 
Status icon is dimmed, a profile cell is not present in the active or reference files. If 
Profile Cell Status is colored, then there is a profile cell present.  

 

If you right-click the Profile Cell Status icon, a menu appears with the commands 
Place Profile Cell and Profile Cell Control. See Chapter 2 for descriptions of these 
commands.  

 

Cross Section Cell Status  Displays the status of the cross section component view. If dimming 
Cross Section Cell Status, no Cross Section cell is present in the active or reference 
files. If Cross Section Cell Status is colored, a cross section cell is present.  

 

Fit View  These icons correspond to the MicroStation view windows. Each icon can be defined 
to: Plan, Profile, or Cross Section.  

     

If you right-click a Fit View icon, a menu appears with a selection of component views 
controlled by that icon. 
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Exercise 4.1 Storing the Vertical Alignment with Key-Ins  
In this exercise, the user will design your proposed profile based on information in a provided table.  

1. Double-click on the self-extracting zip file C:\Chapter4_Exercises.exe and click the Unzip icon at the 
prompt. This will extract and setup the files needed for this exercise. 

2. Open the design file C:\e\Projects\22807915201\roadway\DSPFRD01.dgn. 

3. Access Project Manager. From Road Project, click the  icon.  

4. Settings dialog opens. The information in the dialog 
automatically fills based on the Working Alignment 
definition. 

 

 

 

 

 

 

 

 

5. From Settings, click the OK icon. Profile Generator dialog opens. 

 

6. From the Profile Generator menu, select File > K Value Table.  
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7. K Values opens. 

 

Note These values match the PPM chart in Volume I, Chapter 2, for a Sag or Crest curve. 

8. Confirm that the K Values are the FDOTNonInterstate.kvl, and then click OK. K Values closes and 
the table attaches to Profile Generator. 

9. In Profile Generator dialog, key-in 54+80 for the Station and click the Enter key. 

10. In Profile Generator dialog, key-in 10.63 for the Elevation and click the Enter key. 

 

11.   Click the Insert>> (insert after) icon. 

 

12. The dialog changes to allow the entrance of another VPI. 
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13. Using the information in the following table, enter VPI 2 through VPI 6. 

 This table represents only a portion of the profile PGL-RT that is used in the actual project. It does not 
cover the entire length of the project because of time limitations. 

Table of VPI Numbers 

VPI Number Station Elevation 
2 62+50.00 8.23 
3 73+26.00 6.07 
4 74+71.58 6.36 
5 75+65.00 6.12 
6 78+50.00 6.75 

 

14. Click the Prev icon or the scroll bar along the bottom of the dialog to center VPI 2 in the dialog. 

 

 

15. For VPI 2, select a Speed of 45. Note that the K value changes, that an L value for Length of Vertical 
Curve is calculated and the three stations and elevations are calculated. 

 

16. Repeat the previous step for VPI 3 through VPI 5. 

17. In Profile Generator, select File > Clear Profile. Profile 
Generator re-initializes to its original state.  

 

 

 

 

Note Selecting File > Clear Profile will not delete a stored profile from the GPK 
file. It only clears the current VPI information from Profile Generator to 
allow creation of another profile or allow a saved profile to be loaded. 
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Exercise 4.2 Storing the Vertical Alignment Dynamically 
In this exercise, the user will create a profile with limited key-ins using dynamic graphic manipulation to 
place VPIs and set grade lengths and percent of grade. The user will create Vertical Curves based on K 
Values, Design Speed, Stopping Sight Distance and Algebraic Difference in grades. 

Note In this exercise, the student will be placing VPIs graphically. As such, each student’s profile will be 
different and will not exactly match the instructors profile or the examples that follow.  

1. From the Profile Generator menu, select File > Preferences.  

 

2. Preferences dialog opens. 

 

3. From Preferences, enable the toggle for Window Center Current VPI. Note the default Elevation 
Increment, Length Increment and Grade Increment settings. Click OK to close Preferences. 

 

4. Zoom into the beginning of the existing ground profile. 
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5. From Profile Generator, click the  icon. Profile Generator is now in dynamic mode 
and the cursor has changed to a circle with cross hairs. 

6. Move the cursor around within the profile cell and note that as the cursor moves, the Station and 
Elevation values change dynamically. 

7. Snap to the beginning of the existing profile to establish the first VPI of the proposed profile.  

8. Data Point a second time in the design file to accept. The information for VPI 1 populates and 
dynamic control releases. 

 

9. From Profile Generator, click the  icon. 

10. Click the Dynamic icon, placing the cursor back in dynamic mode for the next VPI selection. 
Note While in Dynamic mode, the use of any MicroStation View commands such as Zoom In, Zoom Out 

or Fit View will release Dynamic mode. After using any of these commands, the user must click 
Dynamic again to return to the Dynamic mode. 

11. Place another VPI by Data Point several hundred feet from the previous VPI. 

 

12. Repeat Steps 6-8 to continue establishing VPIs to the end of the existing ground profile.  



PROPOSED PROFILE & ACTIVE CHAIN CONTROL - Active Chain Control __________________________ Chapter 4 

FDOT GEOPAK for Roadway Designers - Advanced  ©2011 FDOT 4-19 

13. Use the Prev and Next icons to center different VPIs in the dialog. Note that MicroStation centers the 
graphical VPI in the view. This is the results of setting Preferences to Window Center Current VPI.  

 

14. Center the VPI 2 in the dialog. 

 

15. Select Symmetrical Vertical Curve. 

  

16. Select 45 from the Speed pull down. 
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17. Observe the L:, K:, and SSD: calculations based on Speed of 45. 

 

Note Even though a short vertical curve is calculated for each VPI, according to the PPM Volume 1, Chapter 
2, Table: Maximum Change in Grade Without Vertical Curves, for a Design Speed of 45 mph, there can 
be a maximum change in grade in percent of 0.70 before a vertical curve is necessary. The original 
profile PGL-RT for the project that went to construction did not use vertical curves because the change 
in grade at all VPIs was less than 0.70%. 

18. For each VPI, set the speed to 45. Observe the Vertical Curve lengths. For the short Vertical Curves, 
check the algebraic difference in grade (see note above) to verify if a Vertical Curve is necessary. If no 
Vertical Curve is necessary set L: to 0. 

 

19. Find a VPI that requires a Vertical Curve.  Round up the Vertical Curve Length to an even length, as 
shown below.  

 

Note When rounding the Vertical Curve length always round up, not down. Rounding down will lower the 
design speed. 
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20. Select File > Save Profile As. Save Profile As opens. 

    

21. From Save Profile As, key-in CLASS as the Profile name and key-in class791.inp as the Input 
File name for a COGO input file. Click the OK icon to close the dialog and save the profile. 

 

22. Depending on the state of the profile, one of two different messages displays at this point. If the profile 
has no overlapping or out-of-range vertical curves, then it will be stored into the Coordinate Geometry 
database and the following message displays. 

 

However, if the profile does have overlapping or out-of-range vertical curves, then it will NOT be 
stored into the Coordinate Geometry database and the following message displays. 

 

  



Chapter 4________________________ PROPOSED PROFILE & ACTIVE CHAIN CONTROL - Active Chain Control 

4-22  ©2011 FDOT  FDOT GEOPAK for Roadway Designers - Advanced 

23. These overlapping or out of range vertical curve problems will be denoted on the dialog. 

 

24. If any problems are noted, correct the problems by modifying the appropriate VPI and save again. 

25. Close the Profile Generator.   

26. Answer No when prompted to Save the Profile. 

27. Answer Yes when prompted to Save Vertical Alignment Settings. 
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Exercise 4.3 Displaying the Vertical Alignment in COGO 
In this exercise, the user will display the proposed profile geometry in COGO and review the data. 

1. From Road Project, click the  icon.  

 

2. Select Tools > Navigator --or-- click the Navigator icon    on the Coordinate Geometry 
dialog. 

 

3. In the Navigator dialog, set the Element to Profile. 
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4. Select the profile CLASS from the list of profile names. 

 

 

 

 

 

 

 

 

 

5. Click the Print/Describe icon.  

 

 

 

 

 

 

 

 

 

6. The profile information appears in the display window of the Coordinate Geometry dialog. 
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7. Close Navigator dialog. 

8. From Coordinate Geometry, select File > Input File Utility. Input File Utility opens. 

   

 

9. From Input File Utility, select Output, then type class in Output File box. 

 

10. Click the Apply icon to create the output file. 
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11. This process creates an output ASCII file in the Roadway folder with the name CLASS791.ojd, where  

CLASS is the name entered in the Output File field,  

791 is the .gpk name, 

.ojd is Output and operator code.  

The user opens and prints this file with any text editor. Review the following sample output file.. 

 

12. Close Input File Utility dialog. 

13. Close Coordinate Geometry dialog. 

14. Click No when prompted to Save Settings. 
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Exercise 4.4 Drawing the Vertical Alignment  
In this exercise, the user will draw the proposed profile using the Draw Profile tool. 

1. Sink the Road Project dialog. 

2. From the Road toolbox, click the Draw Profile icon.  

   

 This dialog does not populate from the working alignment definition. 

3. Select Update Options > Query. 

 

 

4. Select the COGO tab. 
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5. On the COGO tab, select Class from the Profile Name list. 

 

6. Leave the Vertical Offset set to 0. 

 

7. Leave the Station Limits to the default begin and end station values of the profile. 

 

8. Under Display Settings, click the Browse Feature icon.  

9. From Select Design & Computation Payitem, navigate to the item PPGL_50_5 and click the 
OK icon. 
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10. Click the Add COGO Profile Settings icon. 

 

11. The profile CLASS adds to the list box and drawn into the design file. 

 

12. Zoom in on the profile and review the information. The profile information displays as shown below. 

 

Note Arrowheads do not place along the leader lines for the Vertical Curves.  The user must place these by 
hand. However, the Roadway > Place Arrows and Barscales utility in the FDOT Menu is available to 
use. 
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Exercise 4.5 Modifying Display Options and Re-Drawing the Profile  
In this exercise, the user will modify the display options and re-draw the profile. 

1. Under Options, select VC.  

 

2. Enable the K Value toggle. 

 

 When a changing any of the settings, an asterisk appears next to the word Details as a reminder to the 
user that a change has been made. 

 

3. Click the Modify COGO Profile Settings icon.  

 

 

4. On Update Option, enable the toggle for Delete all Existing Elements and Redraw. 

 

5. Click the Apply icon. The proposed profile is deleted and redrawn. 

  



PROPOSED PROFILE & ACTIVE CHAIN CONTROL - Active Chain Control __________________________ Chapter 4 

FDOT GEOPAK for Roadway Designers - Advanced  ©2011 FDOT 4-31 

6. In the drawing, zoom in on one of the vertical curves and review the K Value. 

 

7. On Draw Profile, select File > Save.  Save Profile File dialog opens. 

8. Key-in a file name of CLASS and then click the OK icon.  

 

Note The file automatically is given a .prd extension. 

9. Close Draw Profile. 
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Exercise 4.6 Entering Working Alignment Information 
In this exercise, the user will update the Working Alignment to include the Proposed PGL you just created. 

1. Access Project Manager. 

2. From Road Project, click the  icon.  Working Alignment Definition dialog opens. 

3. Select the category Profile View. Working Alignment Definition options change, as shown below. 

 

4. Click the Select icon next to Proposed Profile. 

 

5. Profile Selection dialog opens.  

6. Select the profile CLASS and then click OK. 

 

 

 

 

 

 

 

7. From Working Alignment Definition, click OK to save settings and close the dialog. 
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Exercise 4.7 ACTIVE Chain Control 
In this exercise, the user will learn how to use Active Chain Control. 

1. Sink the Road Project dialog. 

2. From the Road toolbox, click the Active Chain Control 
icon. 

 

 

 

 

 

3. Active Chain Control dialog opens. 

 

4. Attach RDXSRD01.dgn as a reference file. When attaching RDXSRD01.dgn, be sure to attach the 
RDXSRD model. 

 

5. Open Views 1, 2 and 3. 

6. From the MicroStation menu, select Window > Tile to tile the windows. 

7. Select BL817 in the Chain list. 

 

 

 

 

8. Right-click the Fit View 1 icon and then select Plan. View 1 is set 
to the Plan View. 

 

 

9. Right-click the Fit View 2 icon and then select Profile. View 2 is 
set to the Profile View. 
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10. Right-click the Fit View 3 icon and then select Cross Section. 
View 3 is set to the Cross Section View. 

 

 

 

11. Right click the Fit View 3 icon again. Select Cross Section 
Navigate.  

 

12. XS Navigate opens. 

 

13. Click the Curvilinear Coordinates icon. 

 

14. The Curvilinear Coordinates dialog opens. 

 

15. Practice moving the mouse in View 1 (Plan View) and notice how the mouse tracks accordingly in the 
View 2 (Profile View).  Notice how the Curvilinear Coordinates dialog updates the Station and 
Offset values as the mouse moves. 

16. Practice moving the mouse in View 2 (Profile View) and notice how the mouse tracks accordingly in 
the View 1 (Plan View).  Notice how the Curvilinear Coordinates dialog updates the Station, Offset 
and Elevation (Z) values as the mouse moves. 

17. Use the Cross Section Navigator to browse through the cross sections in View 3. 

18. Close Active Chain Control dialog and all related dialogs. 

19. Exit MicroStation. 
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5 SUPERELEVATION SHAPES 

OBJECTIVES 
• Detail Superelevation Tools 

• Build Superelevation Shapes using Automated Superelevation 

• Analyze Shapes 

WORKFLOW 
GEOPAK supports many options for the definition of pavement on proposed sections. They range from a 
single slope specification tied to a baseline/profile to complicated, multiple roadway sections, each having 
its own superelevation transitions. 

Some roadway projects are very basic where no superelevation transitions are required, meaning the 
roadway slope for all pavement can be specified as a single value. In this case, the slope is defined during 
the proposed cross section processing and no additional superelevation work is required. This is done 
running Cross Sections in shapeless mode. 

There will be cases of defining superelevation when roadways are constant widths without tapers such as 
turn lanes, acceleration and deceleration lanes. In these cases, the automated superelevation can be used, 
based on a user defined design speed and taking into consideration the geometry of the roadway. An ASCII 
format file of the superelevation data can be created and reviewed. The engineer can override the computed 
values where necessary and then GEOPAK draws pavement representations as complex shapes into a 
MicroStation 2D design file. 

Another option is the definition of superelevation when roadways are not constant widths. This would be 
when there is acceleration and deceleration lanes, turn lanes and gore areas.  In this case, graphic elements 
within a MicroStation 2D design file are utilized to create complex shapes, which define the 
superelevation transitions. 

Any combination of these tools can be utilized with a project or even with a single roadway. The shapeless 
mode is good for rural applications, low volume city streets and frontage roads, while the automated 
method quickly generates automated shapes for more complex roadways. Any area that cannot be defined 
using the automated method can be supplemented by the graphical method. 
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SUPERELEVATION SHAPE MANAGER TOOLS 

ACCESSING SUPERELEVATION SHAPE MANAGER TOOLS 
From the MicroStation menu: select Applications > ROAD > Cross Sections > Superelevation Shape 
Manager Tools. 

<OR> 

From Road tools, select the Shape Manager. 

    

There are several applications available from the Superelevation Shape Manager Tools palette. Each of 
these tools serves a different purpose, giving the user the ability to not only create and modify 
superelevation shapes, but also to obtain information from these shapes once created.  This course covers 
each tool and the purpose it serves. 

AUTOMATED SUPERELEVATION 
Click the Automated Superelevation icon. 

<OR>  

From Road Project, click the  icon.  
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AUTOMATED SUPERELEVATION - PREFERENCES 

 

A rich set of preferences is available which gives the user complete control over every aspect of the 
standardization of the superelevation design process. AASHTO Method 5 is available as a default, along 
with the ability to employ user-defined lookup tables both for e (superelevation rate) and for runoff length. 
There can be user-defined equations entered to compute these values. A thorough set of options is available 
for resolving the superelevation conflicts of Reverse Curves, Compound Curves, Broken Back Curves, and 
Short Curves. 

The user can access the Preferences dialog through the Automated Superelevation dialog by selecting 
File > Preferences. 

The dialog consists of a simple menu bar containing File utilities, four shortcut icons (also for File utilities) 
and nine tabs. Upon selection of each tab, the dialog dynamically changes to reflect the selection. The small 
left and right arrows to the right of the tabs scroll to display the tabs. Each press of one of the arrows moves 
the tabs one position. 

The left-to-right progression of the tabs matches closely with the order of processing which GEOPAK goes 
through when computing superelevation. Therefore, the following discussion of the Superelevation 
Computation Process presents the detailed descriptions of the various items under each tab. 

FDOT has two predefined preference files available to their users – one for rural conditions and one for 
urban projects.  Select the appropriate file per project.  For a typical project, the users need to modify the 
preferences based on project conditions.  If so, copy the appropriate SEP file to the project directory and 
modify as needed.  Outlined below, is each tab and typical adjustments that the user makes for each type of 
project. 
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E TAB 

The first step in the process is the computation of e for each curve.  Regardless of the manner of 
computation, e computation is based on the curvature of each curve and the Design Speed. 

E Method Identifies the method GEOPAK will use to compute e.  The available methods are 
Radius Table, AASHTO Method 5, and Equation. 

Table Name This contains the name of the CSV file in which to find the tables when Methodology 
is AASHTO Method 5 or Radius Table.  Generally, do not include a path in the file 
name since Environmental variables control these and/or user control in the 
Superelevation Computation dialog.  If specified along with the .csv file name, it uses 
that path regardless of other methods of setting the path such as Environmental 
Variables. If Methodology is Equation, the text field is the location where the equation 
is entered.  Pressing the Files icon ( ) opens the dialog, wherein the desired file may 
be selected.  Pressing the Edit icon ( ) opens the editor specified in the 
environmental variable GPK_SUPER_EDITOR which should normally be set to Excel 
or some type of spreadsheet application. 

Speed 
Interpolation 

Specifies how GEOPAK is to interpolate between Design Speed columns, if the user 
selects a Design Speed not found in the table.  Speed Interpolation applies to both the 
AASHTO Method 5 table and Radius Table for e computation. 

Radius 
Interpolation 

Specifies how GEOPAK is to interpolate between Radius Rows if the given Radius 
does not have a corresponding row with an exact match in the table. This applies only 
to Radius Table option. For rural conditions, the default is fine.  For urban, the Radius 
Interpolation should be set to Conservative entry. 

E Rounding 
Increment 

Controls rounding and applies to e regardless of how computed.  This is simply 
rounding to the nearest number evenly divisible by the rounding increment.  For 
example, if e rounding was set to 0.25, and e, as computed from a table, comes out to 
be 3.789, the value rounds to 3.75, which is evenly divisible by 0.25.  Set a value of 
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0.00 to disable the rounding of e. 

 

RUNOFF LENGTH TAB 

The second step in the process of computing Superelevation transitions is the computation of Unadjusted 
Length, which is the Runoff Length as if the roadway had two lanes only.  (Adjusted Length is the true 
Runoff Length, adjusted for the true roadway width.)  In all methods of computation of Unadjusted Length, 
the computation is based on the rounded e value for each curve. 

If one or both sides of a curve (ahead and/or back) have a spiral, then no length computations need to be 
made for the part with a spiral, since the length of transition is dictated by the length of the spiral.  Within 
the Spiral Distribution group box, the user has the option to determine how spiral lengths match to 
Superelevation Transition lengths. 

If the option is set to Spiral Length = Runoff Length, the Runoff Length is the same as the spiral length.  
Runoff begins with the TS or CS and ends at the SC or the ST.  Tangent Runout falls on the adjacent 
tangent, outside of the spiral.  If the option is set to Spiral Length = Runoff Length + Tangent Runout, 
Runoff and Tangent Runout lengths are set such that the Total Transition Length equals the spiral length, 
and the Tangent Runout falls on the spiral. 

The remainder of the items on the Runoff Length tab has to do with Unadjusted Length computation for 
circular curves in which either the back, ahead, or both sides of the curve are not spirals.  

Runoff Length 
Method  

Determines which method GEOPAK will use to compute the Unadjusted Length.  
The supported methods are e Table, Relative Gradient Table, and Equation, each of 
which is detailed following the explanation of the dialog items.  All methods for 
computation of Length use e and Design Speed as the primary inputs. 

Table Name This contains the name of the CSV file in which to find the tables when Methodology 
is AASHTO Method 5 or Radius Table.  Generally, do not include a in the file name 
since these are Controlled by Environmental variables and/or user control in the 
Superelevation Computation dialog.  If specified along with the .csv file name, it 
uses that path regardless of other methods of setting the path such as Environmental 
Variables. If Methodology is Equation, the text field is the location where the 
equation is entered.  Pressing the Files icon ( ) opens the dialog, wherein the 
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desired file may be selected.  Pressing the Edit icon ( ) opens the editor specified 
in the environmental variable GPK_SUPER_EDITOR which should normally be set 
to Excel or some type of spreadsheet application. 

Speed 
Interpolation 

Specifies how to interpolate between Design Speed columns, if the user selects a 
Design Speed not found in the table.  Speed Interpolation is applicable to e Table and 
Relative Gradient Table for AASHTO Method 5 and e Table. 

E Interpolation Specifies how to interpolate between e Rows if the given e value does not have a 
corresponding row in the table.  e Interpolation applies only to e Table. 

Width Basis Determines how to compute Unadjusted Length if the inside lane has a width 
differing from the Nominal Lane Width.   

As an example, consider a Typical Section with four lanes and no median.  The 
inside two lanes are ten feet wide and the outside two lanes are fourteen feet wide, 
while the Nominal Lane Width is twelve feet. 

 • If set Nominal Lane Width, and the value read from the table (or equation) is 
35, no change needed to that value.   

• If set Actual Lane Width, and the value read from the table (or equation) is 
35, the value multiplies by 12 over 10, resulting in an Unadjusted Length of 
42. 

 For rural projects, the default values do not need modification.  For urban projects, 
the Nominal Lane Width need setting for each project. 

Consider Half 
Lane If Width 
< 

It is common that five or seven lane roadway sections have the crown point in the 
center o the middle lane.  In order to model this correctly, two lanes must represent 
the middle lane, each being half the true lane width. 

Several options, which adjust the runoff length, must have an accurate count of the 
number of lanes.  By modeling a five-lane section with six lanes, this count is not 
correct. 

This situation is resolved by specifying a width below which a lane counts as a half 
lane.  In this way, the five lane section modeled by four full lanes and two half lanes 
is correctly considered by GEOPAK to have five lanes. 

As an example, if the center turn lane of a roadway were 16 feet wide, the left and 
right halves of the center turn lane would each be 8 feet.   

If the Consider Half Lane if Width < text field were set to 8 (or 9 or any number 
greater than or equal to 8), those two lanes would be considered together as one lane 
for the purpose of counting lanes in preparation for making the Runoff Length 
Adjustment. 

Length 
Rounding 
Increment 

Controls rounding and applies regardless of how computation is done for Unadjusted 
Runoff Length.  It is rounding to the nearest number evenly divisible by the rounding 
increment.  If the rounding increment is set to 1.000000, the Unadjusted Runoff 
Length rounds to the nearest whole number. 
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TANGENT RUNOUT TAB 

Tangent Runout Distance The distance from a Cross Slope of Normal Crown to a Cross Slope of 
zero as shown below: 

 

Three methods are available to compute:  

Relative Gradient   The Tangent Runout Distance is computed as the result of applying the 
Relative Gradient of the Runoff to the Tangent Runout.   

If rounding takes place, the length change caused by the rounding is applied evenly to 
both Runoff and Tangent Runout such that the Relative Gradient remains the same over 
both portions of the transition. 

Fixed Distance  A text field reveals to the right that contains the numeric value for the distance.  
With this option, Tangent Runout Length is set to a certain distance without regard to the 
Relative Gradient of the Runoff.   This will cause a discontinuity in the Relative Gradient 
at the zero slope point.  

If rounding takes place, the length change applies entirely to the Runoff portion so that 
the Tangent Runout distance remains unchanged. 

Equation A text field reveals to input the equation for calculation. Intrinsic variables are 
available to assist in developing the needed equation. 

After the Tangent Runout has been computed (regardless of the method), Total Length 
Rounding is applied if specified as something other than zero in the Total Length 
Rounding Increment text field. 

If rounding takes place, the length change applies entirely to the Runoff portion so that 
the Tangent Runout distance remains unchanged. 
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ADJUST FACTORS TAB 

Base Adjust Factor 
On 

Total Number of Lanes (default option)    The multilane adjust factor is determined 
by the total number of lanes across the entire roadway. 

Number of Lanes Rotated   Compliant to AASHTO 2001 Standards. The 
multilane adjust factor is determined by number of lanes being rotated on one side of 
each roadbed. 

Multilane Runoff 
Length Adjust 
Factors 

On the left side of each text field is a toggle. For a given lane number:  

• If the toggle is off, Non-Adjustment Factor adjustment is used.  

• If the toggle is on, the Adjustment Factor in the text field is used. 

Length Adjustment is a modification of the two-lane length (unadjusted length) 
according to the true width of the roadway.  

• If Adjustment Factor is used, the length adjusts by applying a multiplier 
according to the number of lanes.  

• If Non-Adjustment Factor is used, the length adjusts by dividing the total 
roadway width by the Nominal Lane Width without consideration of the 
number of lanes. 
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DISTRIBUTION TAB 

After computing the Adjusted Lengths for non-spiraled ends of circular curves, the transition is distributed 
over the curve and its adjacent tangents and stationing is computed relative to the PC and PT.  The amount 
of the transition that falls on the tangent is termed Percent on Tangent.  Options are provided to base that 
percentage on Total Length or on Runoff Length. 

Distribute Over This controls whether GEOPAK applies the % on Tangent value to Runoff Length 
or Total Transition Length. 

 • Runoff Length Only   The distribution percentage is applied to the Runoff 
Length.   

• Tangent Runout + Runoff Length  The distribution percentage 
applies to the Total Transition Length. 

% On Tangent Determines the percentage of the distribution which is to be located on the tangent 
leading up to (or trailing) the curve. 

• For rural roadways, 80% on tangent is desired, but can be as little as 50% 
if necessary.  For rural divided roads, the low side can be set to either 
Match High Side Full Super Station or Distribution. 

• For urban roadways, 80% on tangent is desired, but can be as little as 50% 
if necessary.  For urban divided roads, it is desirable to set the low side to 
Match High Side Full Super Station. 
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ROTATION TAB 

Transition Profile The Elevation Transition has options for Linear or Parabolic. 

Parabolic The Transition ID option on the Superelevation Computation dialog is available. 

Linear   The Transition ID on the Computation dialog is not available and all transitions 
must be linear. 

Outside Lane 
Rotation 

Two options: Rotate to Match Inside Lanes and Independent Rotation. 

Independent Rotation All transition stations begin and end at the same station, regardless of Normal 
Cross Slope.  If the Typical Section has Broken Back Normal Crown, this means 
that the cross slope remains broken throughout the transition until achieving Full 
Super, at which point the cross slope is continuous. 

Rotate to Match 
Inside Lanes 

If the Typical Section has Broken Back Normal Crown, the lanes of lesser cross 
slope do not begin transitioning until the lanes with greater cross slope come up to 
match.  In other words, as soon as possible within the transition, the cross slope is 
unbroken. 

Axis of Rotation Only applies to two lane roadways.  The two options are Rotate About Centerline 
and Rotate About Inside Edge. 

Rotate About 
Centerline (left icon) 

The rotation point is at the grade point as illustrated by the icon. 

Rotate About Inside 
Edge (right icon) 

The rotation point is at the edge of pavement.  For curves to the right, the rotation 
point is at the right edge of pavement.  For curves to the left, it is on the left edge of 
pavement. 

Note For FDOT projects, the defaults on the Rotation tab are desirable. 
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Superelevation Transition Conflicts occur when the stationing of the superelevation transitions of two 
adjacent curves overlap, or when the fully superelevated station range on one curve is too short.  When 
curve conflicts occur, GEOPAK attempts to resolve them by adjusting relative gradients, distribution 
percentages or e values, depending on the applicable preferences.  FEOPAK uses the remaining tabs in the 
Superelevation Preferences dialog to set parameters and use in resolving these conflicts.   

SUPERELEVATION TRANSITION CONFLICT RESOLUTION 

Before writing the autoshape input file, GEOPAK scans the filler line stationing created by prior processes 
in the superelevation flowchart for four types of conflicts:   

Reverse Curve conflict This occurs when two adjacent curves that deflect in opposite directions have 
transitions that overlap, or which have a short section of full Normal Crown between 
them. 

Broken Back conflict This occurs when two adjacent curves that deflect in the same direction have 
transitions that overlap, or which have a short section of full Normal Crown between 
them.  The parameters for handling this conflict are found on the Compound Curves tab. 

Compound Curve conflict This happens when two curves deflecting in the same direction have no 
intermediate tangent, resulting in a PCC shared between them. 

Short Curve This involves only one curve.  It would be a case in which the length of the fully 
superelevated segment of the curve is too short. 

It sometimes happens that two superelevation conflicts may happen on the same or adjacent curves.  
Therefore, when double conflicts occur, GEOPAK prioritizes them as which takes precedence, as follows: 

• Reverse Curves 

• Broken Back Curves 

• Compound Curves 

• Short Curves 

This means, for example, that if there is a choice to be made as to whether to fix the Reverse Curve 
situation or the Broken Back Curve, Reverse Curves are fixed.   
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REVERSE CURVES TAB 

A Reverse Curves conflict occurs when two adjacent curves that deflect in opposite directions have 
superelevation transitions that overlap or are in close proximity.  Two levels of conflict are defined for 
Reverse Curves:  Critical and Supercritical.  The determining factors for defining a conflict as Critical or 
Supercritical are both based on the Length of Normal Crown existing between the two transitions.   

Overlapping transitions may have a negative Length of Normal Crown. 

The distinction, then, between Critical and Supercritical, has to do with handling of the conflict.  If the 
conflict is Critical, adjustments are made so that the Minimum Normal Crown Length is maintained.  If the 
conflict is Supercritical, the transitions of the two curves are merged and Normal Crown never occurs 
between the conflicting curves.   

When GEOPAK checks for this conflict, it first checks to see if the Length of Normal Crown violates the 
Supercritical threshold.  If it does not, GEOPAK then checks the Critical threshold.  This means that if the 
value for Maintain Minimum Length is less than or equal to Supercritical Length, no conflict would ever be 
handled as Critical.   

Either value may be negative, although this is ill advised for Maintain Minimum Length. 
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COMPOUND CURVES TAB 

The Compound Curves Tab contains settings for two types of conflicts in which two adjacent curves 
deflect in the same direction.  “Compound Curves” are when two curves deflect in the same direction and 
have no intermediate tangent section, but instead share a common station, the PCC.  “Broken Back Curves” 
occur when two curves deflect in the same direction and have an intermediate tangent section that is short 
enough that the superelevation transitions of the two curves overlap or nearly overlap. 

Compound 
Curves 

 

Determine 
Transition 

Length 

The length of the transition is determined by one of the options detailed listed below: 

By Averaging Both Relative Gradients - The Relative Gradients of the two conflicting transitions 
are averaged to result in the new Relative Gradient and Transition Length.  The End Full Super 
Station of the first curve and Begin Full Super Station of the second curve are determined by 
positioning the transition according to the Length Distribution At PCC option. 

By Using Relative Gradient of Sharper Curve - The Relative Gradient of the sharper of the two 
curves (as it is before adjustment) is the Relative Gradient used to determine the Transition 
Length.  The End Full Super Station of the first curve and Begin Full Super Station of the second 
curve are determined by positioning the transition according to the Length Distribution At PCC 
option. 

By Using Relative Gradient Of Flatter Curve  - The Relative Gradient of the flatter of the 
two curves (as it is before adjustment) is the Relative Gradient used to determine the Transition 
Length.  The End Full Super Station of the first curve and Begin Full Super Station of the second 
curve are determined by positioning the transition according to the Length Distribution At PCC 
option. 

By Using Unadjusted FS Station To FS Station

Length 
Distribution      

at PCC 

 - The End Full Super Station of the first curve and 
the Begin Full Super Station of the second curve are unchanged from their values before 
adjustment.  The Transition Length and Relative Gradient are set from the original Full Super 
stations.  The Length Distribution At PCC option is not considered. 

The first three options described above involve the adjustment of the Full Super Stations of the two 
curves.  These three options allow the placement of the transition with respect to the PCC to be 
controlled via, Length Distribution at PCC which has five options. 
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 Evenly - option causes the transition length to be half on the first curve and half on the second 
curve.  

By Degree Of Curvature, By Radius, and By e - split the ratio of distribution on each curve 
according to the ratio of degrees of curvature, radius, or e or each curve.   

By Percentage On Sharper Curve

Broken Back 
Curves 

 - allows control of the distribution by entering a percentage to be 
applied regardless of the ratios of various attributes of each curve. 

This occurs when two curves that are adjacent within a chain and deflect in the same direction 
have superelevation transitions that overlap or are in close proximity.  There are two levels of 
conflict defined for Broken Back Curves:  Maintain Minimum Normal Crown, and Maintain 
Minimum Reverse Crown. 

 

SHORT CURVES TAB 

The Short Curve conflict occurs when the length of the fully superelevated portion of the curve is shorter 
than the desired minimum.  This is not a conflict between two adjacent curves as the other conflict types, 
but is instead an undesirable situation occurring on a single curve.   

The following depicts a better understanding: 

 



Chapter 6 _________________________________________________ SUPERELEVATION SHAPES - Automated Superelevation 

5-16 ©2011 FDOT FDOT GEOPAK for Roadway Designers - Advanced 

If a curve is in the Short Curve state, there are three supported methods of Treatment, as detailed below. 

Truncate e The End Normal Crown Stations and Relative Gradients of the two 
transitions of the curve hold constant.  The e-value reduces sufficiently so 
that the new Full Super Length equals Maintain Minimum Length. 

Slide Transitions, Hold 
Relative Gradient 

The Normal Crown and Full Super stations of both transitions of the curve 
move outward from the PI of the curve by the same amount such that the 
Relative Gradient does not change and the Full Super Length equals 
Maintain Minimum Length. 

Change Full Super 
Stations, Change 
Relative Gradient 

The Full Super stations moved outward from the PI of the curve by the 
same amount such that the Full Super Length equals Maintain Minimum 
Length.  The Normal Crown stations do not change.  Therefore, the Relative 
Gradients become steeper. 

• Broken Back Curves – Avoid if possible.  If an engineer runs into this situation, FDOT does not have 
standards in place.  It is the engineer’s responsibility to calculate the correct values and choose the 
correct options for the preference tab for compound curves. 

GENERAL SUPERELEVATION CONSIDERATIONS 

• Allow Sufficient Length of Tangent between Reverse Curves for adequate superelevation transition. 
This suitable tangent length should be determined as follows: 

o 80% of the transition for each curve should be located on the tangent. 
o The suitable tangent length is equal to or greater than the sum of the two 80% distances. 
o Where alignment constraints dictate a less than desirable tangent length between curves, there 

is an allowable adjustment of the 80/20 superelevation transition treatment (where up to 50% 
of the transition may be placed on the curve). 

• Compound Curves - Avoid if possible.  When they are necessary, the radius of the flatter curve should 
not be more than 50% greater than the sharper curve. 

• Small Deflection Angles - should lengthen curves to avoid the appearance of a kink.  (Curves should be 
at least 500 ft. long for a central angle of 5° and the minimum increased 100 ft. for each 1° decrease in 
the central angle (900 ft. for a 1° central angle).  (PPM Section 2.8.1.1) 

• Rule of thumb: Use the largest radius for the curve as is possible. 
• Superelevation Transition is 80/20 (tangent/curve), but up to 50% of the transition can be on the curve 

in special situations. 
• Minimum Length of Transition (for emax=0.10) is 100’ per PPM Table 2.9.3. 
• Minimum Length of Transition (for emax=0.05) is 50’ for design speed under 40 mph and 75’ for 

design speed of 40 mph or greater per PPM Table 2.9.4. 
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AUTOMATED SUPERELEVATION - DIALOG 

 

Job Specifies the GPK file used. 

Chain Specifies the baseline chain dictating the horizontal geometry for which superelevation 
transitions are calculated. This chain, also called the Shape Cluster Baseline in the Auto 
Shape input file. 

Begin Station Populated with the default beginning of the chain. For just part of a chain, the user can 
manually change this station. 

End Station Populated with the default ending of the chain. For just part of a chain, the user can 
manually change this station. 

Design Speed Sets the Design Speed used either in the tables or in equations for e and length 
computations. 

Transition ID GEOPAK defaults to a linear interpolation for its transitions. However, the software 
also provides the options for an unlimited number of parabolic transitions. GEOPAK 
will ghost this option, if no other Transition IDs are setup in the preferences. 

Preference File   Identifies the Preference File used for computation. The various Preferences Files which 
are available in the combo box are determined by what files have the .sep file extension 
in the Preference Files Path on the User Directories dialog.   FDOT delivers two 
preference files: 
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Facility Determines whether the roadway cross section is to be divided or undivided. This option 
determines the following:  

• Whether or not the values Profile, Tie (Offset or PGL), and/or the Tie or PGL 
values may be different. If they are different, then it generates two shape 
clusters, which usually is required for a median.  

• Which Preference used as found on the Distribution tab of the Preferences 
dialog, discussed, later in this chapter. 

e Selection Sets the maximum superelevation rate for the calculation. This is set by the preference 
file. 

L Selection Sets the Lane selection option for the calculation. The allowable lane selection options 
are pre-determined by the preference file. 

  

Left/Right Tabs This contains data pertaining to each lane within each roadway. If the Facility is 
undivided, then the left tab is for the left lane(s) while the right tab is for the right 
lane(s), resulting in the creation of one (1) shape cluster. If there is a divided Facility, 
then the right tab is for the entire right roadway, while the left tab is for the left 
roadway, resulting in the creation of two (2) shape clusters.  

Profile  GEOPAK profile defined as the Shape Cluster Profile in the Auto Shape input file. 

Tie: Offset Horizontal distance from the Chain to the Profile. 

 

Tie: PGL The horizontal chain associated with the profile. 

 

%Slope  Sets the cross slope of each shape in normal crown in percent format. A negative sign 
denotes the roadway going downward, while emanating away from the PGL. A Normal 
Crown section of 2.0% therefore, entered as –2.0. 

Offsets This defines the dimension of the shape (usually a lane) by two offset distances from the 
baseline. This does not support Tapers. Offset distances are negative if measured to the 
left. Each lane must have the same offset on the left as the left adjacent lane and must 
have the same offset on the right as the right adjacent lane (no gaps in offsets). 
Computation may not proceed if this condition is not met. There should be one row in 
each of the list boxes for each lane of the typical section. Lane offset values are entered in 
terms of master units. 

Dependent This identifies whether the shape of the lane is dependent on the profile or 
independent of the profile. One dependent shape, based on the profile, is required for 
each cluster. Other shapes drawn, not based on the profile, but on adjoining lanes, are 
independent. For example, turn lanes drawn abutting next to the mainline roadway, so 
they are independent. However, a lane based on the profile for its initial elevation, such 
as one of the through lanes, is profile dependent. 



SUPERELEVATION SHAPES - Automated Superelevation _________________________________________________ Chapter 6 

FDOT GEOPAK for Roadway Designers - Advanced  ©2011 FDOT 5-19 

New Lane   Adds a new lane to the list box, then key-in the desired values in the edit 
fields 

Delete Lane     Deletes the highlighted lane from the list box. 

Quick Entry     Enables the user to populate the shape cluster list boxes quickly while 
entering the data using engineering terminology. 

 

After entering the information on this dialog and clicking OK, the number of lanes and 
their corresponding offsets entered automatically into the shape cluster boxes.  

If the user enters an odd number of lanes (such as five), they put the center lane: half on 
the left tab and half on the right tab. If the Half Lane Width item (on the Runoff Length 
tab of the Preferences dialog) is set properly, those two narrow lanes count as one for the 
purposes of computing Runoff Lengths.  

Rectify Lanes   Eliminates any gaps or overlaps between lanes, ensuring that one lane 
starts where the other lane ends. For example, if one lane is set to 0 and 12, while the next 
lane is set to 10 and 24, there is an overlap between 10 and 12. Clicking Rectify Lanes 
will leave the 0 to 12 lane intact, and change the second lane to 12 and 26, maintaining 
the width of the second lane but eliminating the overlap. 

Create Input File Select an ASCII file wherein GEOPAK creates the autoshape input file. It is not 
necessary to include the extension, as GEOPAK will add .inp to the field. 

Generate Superelevation Transitions Processes the superelevation calculations to generate the shape 
input file. 
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SUPERELEVATION AUTOSHAPE BUILDER 
The Superelevation Autoshape Builder tool processes a previously created shapes input file. 

 

 

 

Autoshape Input File Name of the input file to be processed.  The browse icon is available to navigate 
to the desired file. 

Display Only When active, the superelevation shapes display, but not drawn into, the design file as 
permanent elements. The shapes will disappear when the view updates. 

Override Input File Level Symbology When active, the user has the ability to override the 
symbology of the shapes that is specified in the input file. 

Draw Superevelation Shapes Processes the shape input file and draws or displays shape into the 
active design file. 
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SUPERELEVATION SHAPE MAKER 
Superelevation Shape Maker gives the user the ability to create superelevation shapes manually. 
To do this, the user must supply the information to build the shapes. This includes not only the 
elements that make up the extents of the shape’s limits, but also information such as slopes, baseline, 
profiles, etc. 

 

 

Job Number Coordinate geometry database number, wherein superelevation chains and profiles are 
stored. The user can enter the Job Number manually or identified by pressing the Select 
icon. 

Tolerance In order to create a shape, the elements that represent the edges of pavement must be 
coincident. This is where tolerance comes into play. If the elements are not coincident 
perfectly, then building the shape may fail. If this happens, a larger tolerance may be 
used. 

Shape Parameters 

Baseline  A chain used to describe the proposed alignment of the superelevation shape.  

Profile  Profile used to describe the vertical geometry of the superelevation shape 
utilizing the stationing of the baseline defined. 

Tie/PGL Chain   When this option is set to Tie, then a constant offset distance is given and 
applied to the Baseline to define a Profile Grade Line (PGL). A negative tie means the 
profile offsets to the left of the proposed alignment. A positive tie offsets to the right of 
the alignment relative to the direction of the stationing.  
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Setting the option to PGL chain, initiates a selection of an alignment, that defines the 
PGL. This is optional and only used when the offset distance from the Baseline to the 
Profile is not constant. 

 

Class Dependent/Independent option identifies whether the shape is dependent on the profile or 
not. A good rule of thumb is one dependent shape per shape cluster. 

Transition ID Dictates the type of transition utilized by the software, either linear or parabolic. 
The software utilized linear interpolation, if the Trans ID is blank or 0. The transition 
table is utilized when the transition ID is greater than 0. Note the Trans ID reflects the 
number from the xs.td file. 

Symbology Sets the graphical symbology of the superelevation shape. 

Slope Label Sets the text symbology and characteristics of the slope labels drawn with the 
superelevation shape. 

Identify Shape Fills out the dialog using the parameters of the selected shape. 

Filler Lines The filler lines are the “ends” of the shape (i.e. where the shape begins and where the 
shape ends). There are 3 options with which to define these extents. When selecting 
each option, the dialog will change to reflect required information for that option. 

 

By DP Data Points define the Beginning and Ending Extents of the shape. If the transition 
toggle is disabled, then both ends of the shape will use the given slope. If enabled, the 
user will have to input a second slope. 

 

By Line The beginning and ending extents of the shape are defined by identifying a MicroStation 
line. If the transition toggle is disabled, then both ends of the shape will use the given 
slope. If enabled, the user will have to input a second slope. 

 

By Station The beginning and ending extents of the shape are defined by giving a station. 
The user identifies the station with a key-in or by a Data Point in the design file. If the 
transition toggle is disabled, then both ends of the shape will use the given slope. If 
enabled, the user will have to input a second slope. 
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Element Selection  There are three options used to select the elements that make up the edges of the 
proposed shape. 

Manual  The user must manually identify each element that comprises the sides of the 
proposed shape. 

 

Semi-Automatic  The user can identify a single element, and then upon subsequent Data 
Points the software will attempt to connect the elements and “walk” around the shape 
edges. If the software comes to a fork then the user can use the “right-click” mouse icon 
to choose different options. 

 

Automatic The user identifies a single point in the interior of the shape and the software 
attempts to automatically figure out the sides and creates the shape.  Radius defines the 
size of the circle displayed at each element end point used to create the shape.  These 
circles are for display purposes only and will disappear once refreshing the view. 

 

ID Element Used in conjunction with the above Element Selection methods to identify the sides of 
the proposed shape. 

Draw Draws the shape into the design file. 
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SHAPE ANALYST 
The Shape Analyst tool is extremely useful, as it provides information on any point within or outside a 
superelevation shape. This tool supports all superelevation shapes, including those with non-linear 
(parabolic) transitions, non-zero ties and PGL chains.  

While most of the dialog is displayed information, some user input is required, and detailed in the list 
below. 

 

 

Job Number Coordinate geometry database number, wherein superelevation chains and profiles are 
stored. The user enters the Job Number manually or identifies by pressing the Select 
icon. 

Display Only When active, the flow arrow and text are displayed, and not drawn into the 
MicroStation design file. Therefore, they are lost after refreshing the screen. When not 
active, all text and elements place in the MicroStation file. 

Cross Section When not activate and issuing a Data Point, the elevation of the Data Point and a flow 
arrow display as depicted below. The preference settings determine the arrow size, text 
and orientation. 

 

When activate, a line is placed through the Data Point, perpendicular to the shaped 
cluster baseline. In addition to the elevation and flow arrow placed at the Data Point, 
elevations display where the cross section line intersects any superelevation shape of the 
same cluster. 



SUPERELEVATION SHAPES - Shape Analyst ___________________________________________________________ Chapter 6 

FDOT GEOPAK for Roadway Designers - Advanced  ©2011 FDOT 5-25 

Elevation Information 

Chain  Shape cluster baseline utilized to create the shape. GEOPAK also determines this, when 
the Data Point is issued. 

Profile  Shape cluster profile. Note this is a display only field, populated by GEOPAK when 
issuing the Data Point and the intersecting shapes are determined. 

Station / Offset    When using the By Station / Offset icon at the bottom of the dialog, the user can 
make an entry into these fields manually. In other options, GEOPAK automatically 
populates the fields by projecting the Data Point onto the specified chain, and calculating 
the station and corresponding offset. 

Extrapolate Fixed Slope   Another option supported in the Shape Analyst tool is the extrapolation of a 
fixed slope. The user utilizes this option when the Data Point, dynamic point or station 
/ offset is outside of the shape. When activate, it extrapolates the given slope from the 
last known slope (i.e. the last shape). When not activate, the Data Point projectes back 
to the shape's chain, then the elevations at the edges of the shape are displayed and the 
slope of the outside shape is projected to the Data Point. 

 

Detailed below are three supported options to define the desired point. The icons are located at 
the bottom of the dialog. 

 

By Station/Offset The Station / Offset is projected back onto the shape cluster baseline and the elevation of 
the projected point is displayed. This option can be manual entry only and requires no 
Data Point on the screen. 

DP   A Data Point within a superelevation shape whose X, Y coordinates are utilized to 
compute station / offset from the specified shape cluster baseline, which is subsequently 
utilized in conjunction with the shape to compute the various slopes and elevations.  
After clicking DP, the user can place numerous Data Points. It is not necessary to click 
DP again. Each corresponding station / offset displays along with the associated output 
information. 

Dynamic This icon activates the dynamic mode. As the cursor moves across the screen, any 
momentary pause places the elevation and flow arrow in the MicroStation file, 
computes, and displays the analysis information. 
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User Preferences Set by clicking on User > Preferences. 
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SHAPE PROFILER 
The Shape Profiler tool provides profile information based on a GEOPAK superelevation shape. This tool 
supports all GEOPAK superelevation shapes, including those with non-linear (parabolic) transitions, non-
zero ties and PGL chains.  

 

 

 

Job Number Coordinate geometry database number, wherein superelevation chains and profiles are 
stored. The user can enter the Job Number manually or identified by pressing the Select 
icon. 

Display Only When active, the flow arrow and text are displayed, and not drawn into the 
MicroStation design file. Therefore, they are lost when refreshing the screen. When not 
active, all text and elements are placed in the MicroStation file. 

Graphic Grade   Currently the only option supported. The elevations are drawn graphically based on the 
user-defined parameters. 

The next group of fields relates to the superelevation shape. For this tool, only one 
shape may be utilized at any one time. The fields are detailed below:  

 

Chain Shape cluster baseline utilized to create the shape. The chain is selected from the list of 
all chains stored in the current coordinate geometry database. 
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Identify Shape Press the icon, then select and accept the shape utilized for the grade computations.  
This populates the chain, From Station and To Station setting from the Shape Properties. 

From Station/To Station  After defining the shape, the software populates the station fields with 
the stations of the filler lines (i.e. the ends of the shapes). If there is no need of the 
graphic grade for the entire shape, the DP icons can define a partial shape. Press the DP 
icon, then place a Data Point inside the shape. The station is automatically adjusted to 
reflect the Data Point. 

Three options are supported to define the distance between the graphic grade points.  

 

Even Specifies the incremental distance between successive Graphic Grade points where the 
first Graphic Grade point is rounded to the next highest even station from the From 
Station. For example, if the From Station is 100+15 and the Even value is 25, the Graphic 
Grade points would be generated at 100+25, 100+50, etc., divisible by the even value. 

Increment Creates Graphic Grade points where the user specifies the incremental distance 
between successive Graphic Grade points where the first Graphic Grade point is 
coincident with the From Station and defines subsequent points adding Increment to the 
From Station. 

Intersect  Creates Graphic Grade points at every location where the selected element 
intersects the superelevation shape. 

Elevation Along:   Two options are provided to specify where the graphic grade elevations are created.   

Element  If the Complex Chain toggle is active, the user may select a string of elements. 
If the toggle is off, the user may select a single element. GEOPAK calculates the 
elevations along the edge of the selected elements at the specified increment. The element 
can be located inside, along or outside the shape. If the element is outside of the shape, 
then the slope of the shape extrapolates to the element’s location. 

 

Shape  The elevations are drawn around the shape at the specified interval from the 
filler lines. If the shape has a 0% slope in the shape, it is labeled based on the User 
Preferences.  This option is not available with the Intersect option in the previous filed. 
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User > Preferences  Preferences may be set.  
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SHAPE EDITOR 
The user utilizes the Shape Editor tool to modify the slope and station attributes of an existing 
superelevation shape.  

 

 

Job All shapes have attributes: baselines, profiles and optional PGL chains. These geometric 
elements are stored in the specified job number. 

Identify Shape  Click this icon, then click on a shape and accept the shape by clicking again off the 
shape.  This will fill in the From and To Station Information including % of Slope. 

Tolerance In modifying a Superelevation Shape Filler Line, adjacent shapes must be located and 
processed to ensure that the common filler line adjusts on both shapes.  Due to the 
limitation of graphical precision, these shapes may not share a precise, coincident filler 
line.  The tolerance is used to search and process shapes when the filler line is relocated. 

From / To Station  When the shape is identified, the slope information will be populated in the 
dialog.  At that point, the user can modify the information by either key-in or 
dynamically, then press Apply to make the changes to the superelevation shape. 
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SHAPE SELECTOR 
The user utilizes the Shape Selector tool to either highlight or select shapes based on one of the shape’s 
parameters (e.g. Slope, Baseline Name, Profile Name, etc.).  

 

       

Job All shapes have attribute: baselines, profiles and optional PGL chains. These geometric 
elements are stored in the specified job number. 

Process 

View All shapes highlight or select in the current view that match the filter.  Eight views are 
available. 

Fence A MicroStation the user must place a fence prior to clicking Hilite or Select. Regardless 
of which Fence option is utilized (i.e., Inside, Clip, Void, etc), the shapes which match 
the filter and part or all of the shape is within the confines of the fence are highlighted or 
selected. 

 

Filter 

Baseline   A chain associated with the superelevation shape (i.e., shape cluster baseline defined 
when the shape was created). 

Profile Profile associated with the superelevation shape (i.e., shape cluster profile defined when 
the shape was created). 

PGL Chain   PGL Chain associated with the superelevation shape (i.e., shape cluster PGL 
Chain defined when creating the shape). 

Class  There are two supported options: dependent or independent. 

Transition ID  Used in parabolic tapers and its associated parabolic parameters.  
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Transition Type There are two transition types are supported: non-transition (where the cross 
slope of the shape is consistent) and transition (where the cross slope is different at the 
ends or specified stations of the shape.  

Tie Horizontal distance between the baseline and the profile grade line. If the baseline and 
profile grade line are coincident, the tie is zero. 

From Slope   Slope in percent format of the superelevation shape at the lower stationing. 

To Slope   Slope in percent format of the superelevation shape at the higher stationing. 

Delta Slope   Algebraic difference in percent format between the From Slope and To Slope. 

Delta Slope/L   Algebraic difference in slope between the From Slope and To Slope divided by 
the length of the shape. This is an indicator of the rate at which the cross slope is 
changing. This parameter relates closely to the relative gradient of the transition. 

All This refers to all shapes. Note there are no user input requirements for this option. 

Filter Operators A variety of supported operands detailed below. The Option chosen determines the 
available operands. 

 

Greater Than (>)   Only available with certain options. 

Greater Than or Equal To (>=)   Only available with certain options. 

Less Than (<)   Only available with certain options. 

Less Than or Equal To (<=) Only available with certain options. 

Equal To (=)   Only available with certain options. 

Not Equal To (! =)  Only available with certain options. 

Hilite When clicking the Hilite icon, all shapes fulfilling the query highlight in the design file. 

Select When clicking the Select icon, all shapes fulfilling the query place into a MicroStation 
selection set. 
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SHAPE PROPERTIES  
The Shape Properties tool provides a variety of shape and slope information. In addition, the user can 
modify this shape information on individual shapes or selections of shapes. 

 

 

Job All shapes are attributed with baselines, profiles and optional PGL chains. These 
geometric elements are stored in the specified job number. 

Shape Parameters 

Baseline  Shape cluster baseline utilized to create the shape. 

Profile  Shape cluster profile utilized to create the shape. 

PGL Chain Shape cluster PGL chain used to create the shape. 

Transition ID Utilized in parabolic transitions only and defines the transitions. 

Tie  Shape Cluster Tie used to create the shape. 

Class  There are two options supported: Dependent and Independent. 

From Slope The cross slope (in percent) at the lowest station value end of the shape. 

To Slope  The cross slope (in percent) at the highest station value end of the shape. 

ID Populates the highlighted shape parameters with the attributes of a particular shape. 
Click ID, then select and accept a superelevation shape. GEOPAK populates every field 
where a toggle is activated. 

Set Sets individual superelevation shapes with a set of desired parameters. Activate the 
desired parameters and populate the associated fields with the desired values. Then click 
Set Entire Selection, an alert appears to confirm the changes. Selecting Yes changes the 
shape attributes. 

Set Entire Selection   Sets multiple superelevation shapes in a MicroStation selection set with a set of 
desired parameters. Activate the desired parameters and populate the associated fields 
with the desired values. Then click Set Entire Selection, select and accept the 
superelevation shape to be changed. 
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SHAPE TO DTM 
The Shape to DTM tool reads GEOPAK superelevation shapes and creates a DAT file suitable for use in 
the Build Triangles tool in the DTM tool frame. 

 

 

Job All shapes have attributes: baselines, profiles and optional PGL chains. These geometric 
elements are stored in the specified job number. 

Chain Shape cluster baseline utilized to create the shape. 

From Station Lower stationing used as the limits of the DAT file. Enter station or Click DP icon         
(       ) and graphically select. 

To Station Upper stationing used as the limits of the DAT file.  Enter station or Click DP icon           
(       ) and graphically select. 

Increment/Even  The interval of points used for the data file. When Increment is used, the value added to 
the From Station iteratively until the To Station is reached.   If the From Station is 
10+10 and the value is 25, Increment values are 10+10, 10+35, 10+60, etc. When Even 
is utilized, the points are taken at even values within the station range.   If the From 
Station is 10+10 and the value is 25, Even values are 10+25, 10+50, 10+75, etc. 

Plot Elevation Text When enabled, text is placed at each point included within the data file. 

Create DTM Data File When enabled, it creates a DTM Data File. If the file already exists, then it 
appends to the file. 

Data File Name of data file created or appended. 

Mode The options are to Create a new file or Utilize a previously created file, in which case, 
the data created in this procedure is appended to the original data.  If you select Create 
mode and the data file you named already exists, an Alert dialog will appear asking to 
overwrite the existing file.  Select OK or Cancel. 

Decimal Number of decimal places used when creating the data file. 

Apply Commence the procedure. 
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Exercise 5.1 Processing Automated Superelevation 
Even though this road is now considered urban, it was originally built as a rural roadway many years ago 
using rural specifications in use at that time.  Since then, the area has developed into an urban area 
servicing more motorists than originally designed.  You will notice that if using the actual current design 
specifications of urban and a 45mph design speed, the entire project computes to be normal crown.  If this 
were a new roadway, the design would utilize normal crown; however, we are rehabbing a roadway with 
superelevation because of the past rural standards.  The designer of this project created the shapes by hand 
to better fit the existing conditions.  Subsequent exercises use original designer shaped, because they match 
the actual design. 

In this exercise, the user will use the software to calculate the superelevation transitions. 

1. Double-click on the self-extracting zip file C:\Chapter5_Exercises.exe and click the Unzip icon at the 
prompt.  

2. Open the design file C:/e/Projects/228079115201/roadway/RDXSRD01.dgn.  

3. Access the Model XSSHRD. 

 

4. Open Project Manager, and from Road Project, click the Calculate Superelevation icon.  

 

5. Create a new run and access the Automated Superelevation dialog. 
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6. Fill in the top portion of the dialog with the information as shown below: 

 

7. With the Left Tab active, select the profile PGL-LT. 

 

8. Change the Tie option to PGL Chain. 

 

9. Select the chain PGL-LT. 
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10. Click the New Lane icon. 

 

11. A new lane entry adds to the list box. 

 

12. Click the New Lane icon again to add a second lane entry to the list box. 

 

13. Click the Right Tab to change the focus of the dialog. 
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14. Select the Profile PGL-RT. 

 

15. Change the Tie option to PGL Chain. 

 

16. Select the chain PGL-RT. 

 

17. Click the New Lane icon twice to add two lane entries to the list box. 
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18. Key-in the name SHAPES.INP in the Create Input File field. 

 

19. Select File > Level Symbology. 

 

 

20. Set the Dependent Shapes symbology as shown below: 

 

21. Set the Independent Shapes symbology as shown below: 

 

22. Close the Superelevation Shape Level Symbology dialog. 
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23. Click the Generate Superelevation Transitions icon. The superelevation calculations process and the 
input file is created. The input file opens automatically in the Text Editor for review. 

 

 

Note If you get a message stating that the autoshape input file could not be written to file name “shapes.inp”, 
check the path in the Create Input File field by clicking on the Browse Autoshape Input File icon ( ) 

24. Click the Create Superelevation Shapes icon to draw the superelevation shapes into the design file. 

 

25. Close the Text Editor. 

26. Close the Automated Superelevation dialog. Click Yes when prompted to Save Settings. 

27. Review the superelevation shapes in the design file. 

Exercise 5.2 Superelevation Shape Manager Tools 
In lieu of a structured exercise, use the created shapes from Exercise 5.1 to review each of the 
Superelevation Shape Manager Tools.  At the end of this exercise, please Exit MicroStation. 
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6 PROPOSED CROSS SECTIONS 

OBJECTIVES 
• Detail Proposed Cross Sections 

• Typical Sections Overview 

• Process a Shapeless Typical to Add Existing Features 

• Process Proposed Features 

• Modify Re-definable Variables 

• Use DGN Elements and Adhocs 

OVERVIEW 
One of the most powerful and flexible features of GEOPAK is the use of criteria in generating proposed 
cross sections.  Within criteria, design conditions can be evaluated and complicated design decisions 
executed in response to these design conditions.  The flexibility of criteria allows the designer to make the 
design as basic or as complex as the project requires.  Numerous baselines can interrelate as ditches and 
medians are drawn between roadways and ramps. Sophisticated drainage details can also be drawn with 
criteria.   

Users utilize the FDOT Cross section criteria to draw cross section features outside of the mosaic of 
superelevation shapes typically representing pavement.  Operationally, the software constructs the cross 
section features derived from the mosaic of shapes first.  Then, the software constructs the remaining 
portions of the cross section through the application of criteria emanating out from the outer edges of the 
shapes. 

The FDOT Criteria by designs runs all cross sections (existing, divided or undivided, mill and resurface, 
new pavement or both, widening, etc.) through the Typical Section Generator.  FDOT delivers 5 typical 
sections. Each of these typical sections is associated with specific criteria files. By selecting a typical 
section appropriate to the project, the required criteria files are automatically applied and setup using the 
proper side slope conditions.   

Drawing proposed cross sections is the interaction with all the various components already addressed in 
this manual, with the addition of criteria. The following components are required to draw proposed cross 
sections: 

• GPK file - All referenced chains and profiles are stored. These include shape cluster baseline 
and profiles in addition to special ditch grades, retaining wall alignments, etc. A minimum of 
one alignment and one profile is required. 

• Existing Ground Cross Sections 

• Pattern Lines - If Pattern by DGN was utilized 
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• Shapes - Utilized to draw pavement features encompassing superelevation. However, if the 
project has no superelevation transitions, the user may use the shapeless method. In this case, 
the initial point is the shape cluster baseline, profile, and tie combination. Users draw all 
proposed cross section elements, including pavement with criteria.  

Note The FDOT criteria require shapes to be present for all proposed cross section runs.  Travel lane width 
shapes are the minimum. 

• Plan View Layout of Roadway Features - The FDOT2008 criteria support various design 
options based on plan graphics.  It is important to know what these options are during the 
design stage of the project to save time and effort when it comes time to create the proposed 
cross sections.  It is recommended that the Design & Computation Manager be used during 
the design process to insure that any Adhoc attributes required by the criteria are attached to 
the elements 

CONTROLLING CROSS SECTION FEATURES  
The FDOT criteria by designed have many variables set with default values that control what and how the 
cross sections are drawn.  Re-definable Variables control these features, graphic “trigger” elements, and 
Adhocs attached to these graphics.  Using a combination of these options a user can control the output of 
the cross section run. 

RE-DEFINABLE VARIABLES 
Re-definable Variables are modifiable, so they have different values over different station ranges within the 
same cross section run.  Re-definable Variables populate into the Proposed Cross Section run when a 
Typical applies through the Typical Section Generator.  These variables by designed used as typical 
settings over the length of the project.  The user can modify them for the entire run or with the use of 
additional “If/Then” statements to cover specific station ranges of sections.  It is important to note, any 
Adhocs found on plan graphic elements will overwrite the Re-definable Variables.  For a complete list of 
the Re-definable Variable used in the criteria, please see the Cross Section Criteria Help documentation.  
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Double clicking on one of the variables or selecting the variable in the list and then clicking Edit opens the 
Re-definable Variables Editor dialog. 

 

From this editor, the user can modify the value for the entire run by typing in the new value and clicking 
Save.  To maintain the value of the variable, but modify over a station range, the If statement may be 
copied and pasted with a new defining If statement.  See below for an example. 
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GRAPHIC ELEMENTS 
Graphic elements found in the DSGNRD file control many of these features.  Define_DGN Variables 
searches for these graphic elements.  The FDOT Criteria defines these variables to match the symbology 
for the feature as defined in the Design & Computation (D&C) Manager.  It is important to use the D&C 
Manager to draw the elements into the design. Most features are commonly drawn elements that a 
requirement in the design file, such as EOP, curb and sidewalk or paved shoulders.  Some features are not 
required for plans production but necessary all the same to add certain features to the cross sections.  These 
features include special ditch lines, median lines, milling limit lines, etc.   

The user should pay special attention in the placement of these lines.  They must cross the pattern lines and 
be placed in the area of the design file that the criteria will be able to locate them.  Simply placing a line 
into the file does not guarantee that the criteria will find it.  For example, the user should place a special 
ditch line outside the limits of the shoulder of the roadway where the ditch would be constructed.  (This 
includes paved and unpaved shoulder limits.) 

Graphic Element Summary 

Feature Associated 
Adhocs? 

Back of Sidewalk Yes 

Front of Sidewalk No 

Driveway Yes 

Edge of Pavement Yes 

Existing Ground No 

Existing R/W No 

Proposed R/W No 

Milling Limits Yes 

Miscellaneous Asphalt Yes 

Proposed Traffic 
Separators Yes 

Curb and/or Gutter (All 
types) No 

Paved Shoulder Yes 

Side Road Tie Down Lines Yes 

Match lines No 

Curb and Gutter Wall No 

Shoulder Barrier Wall 
(Cant. or L) Yes 

Shoulder Barrier Wall 
(Retaining) No 

Gravity Wall No 

Median Barrier Walls Yes 

Edge of Front Slope 1 No 



PROPOSED CROSS SECTIONS - Controlling Cross Section Features ________________________________________ Chapter 7 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 6-5 

Feature Associated 
Adhocs? 

Special Ditch Lines Yes 

Berm Lines Yes 

Front Slope 1 Slope 
Override Yes 

Front Slope 1 Width 
Override Yes 

Front Slope 2 Slope 
Override Yes 

Ditch Width Override Yes 

Back Slope Override Yes 

Ditch Depth Override Yes 

Force Slope Override Yes 

Feather Distance 
Override Yes 

Note For a detailed list of the graphic elements the criteria searches for, consult the FDOT Criteria Help 
files,   T accessed through the FDOT Menu option Roadway > FDOT2008 Criteria Help Files. 

ADHOC ATTRIBUTES 
Most, but not all, graphic elements needed for criteria have associated Adhoc attributes.  These Adhocs 
represent variables in the criteria.  They can represent numeric values for thicknesses, heights, widths, etc.  
They can have a text or string value that can represent a trigger (Yes or No) or the names of COGO chains 
or profiles.  It is important to understand that FDOT Criteria only recongizes the Adhocs defined by the 
delivered FDOT .ddb file.  User must not introduce New Adhocs onto an element and then be expected to 
be read by the criteria.   

Adhocs attach to elements in several ways.  The first way is through the D&C Manager using either the 
Design or Set Modes with Place Influence and Adhoc Attributes toggles on.  The values for the Adhocs 
have been set to a default and will revert back to these values each time the item is invoked.  

Note The values shown in the Adhoc box within D&C Manager do NOT represent the Adhocs attached to 
an existing element.  The user may modify them to add to new elements drawn or set on to existing 
elements.  

The user may also place them on elements using one of the Adhoc Attribute Managers (GEOPAK or 
FDOT).  These programs can gather the Adhocs for review and subsequent modification, and then set them 
back onto existing elements in the file. 

For a detailed list of the Adhoc attributes the criteria searches for, consult the FDOT Cross Section Help 
files.  They may be accessed through the FDOT Menu under Roadway > FDOT2008 Criteria Help Files 
–or—by clicking on the “?” icon on the Adhoc table that pops up with the D&C Manager. 
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ADHOC ATTRIBUTE MANAGER 
The Adhoc Attribute Manager can be accessed from the menu pull down Applications > Road > 3PC 
Adhoc Attribute Manager – or – from the Road Toolbox. 

    

 

File Menu Opens the Preferences dialog box. 
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Preferences 

Set Mode - Defines the actions of the tool.  Options include to Append (add the Adhocs 
in the list box to the selected element) and Replace (remove existing Adhocs and replace 
with Adhocs in the list box to the selected element). 

Window - Offers to options to view the active element when reviewing Adhocs on a 
selection set. When toggled on and set to Center, the active element is automatically 
centered on the screen. When Pan is selected, MicroStation pans to the selected element. 

Hilite

 

 - The active element for review is highlighted. 

Icons 

 

Attribute Display Filter Opens the Attribute Display Filter dialog box that queries the Adhocs 
attached to MicroStation elements. The user can create a selection set from the results. 

 

File - Options to Open, Save and Save As.  The filter settings are saved as .txt files that 
can be used at later time. 

Settings - Opens the Display Preferences dialog. Allows control for highlighting color 
used with the Display options. 
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 Right clicking on a highlighted row in the list box will bring up the option to Copy to 
Display Filter.  Selecting this option will copy the Adhoc information into the display 
filter using the correct format. 

    

The options at the bottom of the dialog create new conditions that can be added to the list 
using the insert icon.  The display icons above the list box provide display options for the 
elements that meet the conditions in the list box.  Those options are from left to right, 
Normal Display, Highlight Selection, Hide Selection, and Display Only Selection.  
Once listing the conditions for the selection, the Add Elements to Selection Set icon 
adds the elements to a MicroStation selection set.  

 

Identify Element Selects an element to review the Adhocs. If Adhocs are attached to the element, 
they will be populated in the list box. 

Set Attributes Sets the Adhocs contained in the list box to selected element(s). 

Adhoc Scooper Scans the file for elements with attached Adhocs and creates an output file with 
the Adhocs and associated information. 

Previous Element  With selection set identified for review, this navigates to the previous 
element. 

Next Element With selection set identified for review, this navigates to the next element. 

List Box  The list box contains the Adhocs associated with a selected element. Once 
Adhocs are in the list box, add or delete new Adhocs using the Add New Row and 
Delete Row icons on the right of the list box. Modify Adhocs by clicking on the Name, 
Type, or Value and typing or selecting the new value.  Once changes are made, the 
Adhocs can be set or attached to elements in the file. 
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Due to the additional functions built into the criteria, there are a few things to check in the design files. 

GENERAL CONSIDERATIONS 

• Make sure there is a Median Line drawn into all median sections.  This also includes 
crossovers and traffic separators.  Crossovers and traffic separators are handled by placing an 
Adhoc on the Median Line. 

• Check for any special lines that are required for special features such as special ditches, 
berms, slopes plan graphic overrides, etc. 

• Check design elements for required attribute tags or Adhocs.  If there has been a new release 
of the criteria, double check the Adhocs on the existing elements using a combination of the 
D&C Manager (has all the required Adhocs set up) and the Adhoc Attribute Manager (lists all 
the Adhocs currently set on the elements). 

If any of the design elements are not correct, the resulting cross sections will not be as expected.  The Help 
documentation can help guide the designer to achieving the desired results. 

PROPOSED CROSS SECTIONS 
Proposed Cross Sections may be accessed: 

• From Road Project, click the Proposed Cross Sections icon. 

 

• The Select Run dialog appears.  Either select an existing run or create a new run by selecting Run > New. 

 

• The Proposed Cross Sections dialog appears. 
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FILE MENU 

 

Run Process the proposed cross sections. Selecting this option will access the Proposed 
Cross Section dialog shown below. 

 

Output Selection of the To Screen option will write all output to the screen, while using the To 
Log File option will write all output to the designated log file. 

 

Pause On Each Section Selecting this check box will cause the proposed cross sections to pause 
after the first cross section is processed. The user can control the processing of each 
subsequent section by clicking the Apply icon and can abort at any time. 

Criteria Viewer Selecting this check box will access the Criteria Viewer at the beginning of the 
first cross section. This viewer allows the user to walk through the processing of the 
section while watching the criteria. 

Apply Begin the processing of the proposed cross sections. 

Save Settings Saves any changes to the run. 

Export Exports all dialog settings to a proposed cross section input file. 

Exit Exit the dialog. 
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XS DGN FILE 

 

XS DGN File The file containing the specified cross sections. When using a working alignment 
definition, the cross section design file name fills in automatically. 

Tolerance The designation of a tolerance value allows user specification of the acceptable 
gaps/overlaps between elements forming the cross sections. 

The FDOT Criteria requires the tolerance to be set to 0.01. 

PATTERN 

 

Use Working Alignment Definition  Select this box, when working with a Working Alignment 
Definition. The rest of the dialog dims and utilizes the pattern definition from the 
defined working alignment. If the check box is clear, the user defines the patterns 
manually using the options on the dialog.  
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By DGN File Allows the user to define the cross section locations by graphical lines in a design file 
called “patterns”. When selected, the dialog changes to allow the input of required 
information. 

 

Chain  Alignment used to cut the existing sections. 

Horiz/Vert. Scale   This is horizontal and vertical scale of the cross sections. 

DGN File  The name of the design file where the pattern lines reside. 

Search Criteria  Graphical symbology of the pattern lines. This symbology can be set by 
selecting from a list of available options using the icons at the right of the dialog or using 
the Match icon. 

Whenever graphical patterns are used, the software searches ALL of the models in the 
specified design file to locate the patterns. 

Match Clicking this icon and identifying a graphical element will harvest the symbology of the 
element into the dialog. 

Display Clicking this icon will highlight all elements in the design file that match the symbology 
in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 
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By Station Allows the user to define the cross section locations by specifying particular station 
values. When selected, the dialog changes to allow the input of the required information. 

 

Chain  Alignment used to cut the existing sections. 

Horiz Scale/Vert. Scale  Beginning station of the patterns. 

Begin Station The Begin Station may be typed into the field manually or populated 
dynamically using the  icon.  

End Station The End Station may be typed into the field manually or populated dynamically 
using the  icon. 

Increment/Even Uses the Begin Station and adds the value to obtain the next station value 
regardless of station equations. 

Left Offset   Specifies the left extent of the cross sections. 

Right Offset   Specifies the right extent of the cross sections. 
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EXISTING GROUND 

 

Use Working Alignment Definition   When Use Alignment Definition toggle is activated, the rest of 
the dialog is ghosted and the existing ground definition form the defined working 
alignment is utilized.  If the toggle is not activated, the required information to specify 
the existing ground must be entered manually on the dialog. 

DGN File The name of the design file where the existing ground cross sections are located.   

Search Criteria Graphical symbology of the existing ground lines.  This symbology can be set by 
selecting from a list of available options using the icons at the right of the dialog or 
using the Match icon.   

Match Clicking this icon and identifying a graphical element will harvest the symbology of the 
element into the dialog. 

Display Clicking this icon will highlight all elements in the design file that match the symbology 
in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 
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SHAPES 

 

Use Working Alignment Definition When Use Working Alignment Definition check box is 
selected, the rest of the dialog is dimmed and the shape definition from the defined 
working alignment is utilized. If the check box is clear, the required information to 
specify the shapes must be entered manually on the dialog. 

There are 3 options available with which to define shapes: 

 

All in DGN All of the shapes in the specified design file are used, regardless of symbology. 
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By Search Criteria Only shapes in the specified design file matching the defined symbology are 
used. 

 

When specifying shapes using either of the previously mentioned options, the software 
searches ALL of the models in the specified design file to locate the shapes. 

Shapeless No shapes are utilized and all cross section elements are drawn with criteria. No 
additional user input is required with this option. 
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SHAPE CLUSTERS 

 

Chain Alignment name associated with the shape. 

Tie/PGL Specifies the offset relation between the Chain and Profile. 

 

If set to Tie, then the profile is applied at given offset from the chain. 

 

If set to PGL, then the profile is applied along the given chain name selected from the 
pull down. 
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Profile Profile name associated with the shape cluster.   

Scan icon When specifying the use of shapes, the Scan icon displays, and used to populate Chain 
and Profile. 

 

   Selecting a cluster in the dialog will automatically fill in the chain/tie/profile information 
back on the Proposed Cross Sections dialog. 

   If the Shapeless option is being used, select the Chain and Profile using the dropdown list 
of available options.   

 

Add Adds the Profile Grade Line (PGL) information to the list box. 

Delete Deletes the selected PGL from the list box. 

Up Use this to move a selected PGL up in the order of the list box. 

Down Use this to move a selected PGL down in the order of the list box. 

Note It is important to add shape clusters into the list from left to right in the direction of stationing. 
Typical This icon will only enable once a PGL in the list box is selected. Clicking this icon will 

access the Typical Section Generator. 
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Note    The next section will discuss Typical Section Generator in detail. 

Thick This icon will only enable once a PGL in the list box is selected. Clicking this icon will 
access the Pavement Thickness Plot Parameters dialog. This dialog can be used to 
specify multiple pavement thicknesses and symbologies. 

    

FDOT criteria draws the pavement thicknesses. Therefore, the use of this dialog is not 
required. 
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Side Slope Conditions 

Define This icon will access the Conditions dialog to manually setup the Side Slope Conditions 
(e.g. Side Slope Left, Side Slope Right, etc.). 

 

Modify Accesses the Side Slope Modification dialog to modify the selected side slope condition.  

 

Delete Deletes the selected side slope condition from the list box. 

Up/Down Moves the selected side slope condition up/down in the list box. 

Criteria Files 

Add Clicking this icon accesses the Criteria dialog to manually select and add selected criteria 
files to the list box. 

 

Delete Deletes the selected criteria file from the list box. 

Up/Down Moves the selected criteria file up/down in the list box. 
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DEFINE DGN VARIABLES  
When using the FDOT criteria, Define dgn variables are not populated in the dialog.  . 

 

By File 

 

 

If set to All, then the defined DGN variables from all of the listed criteria files 
are displayed. If the option is set to a specific criteria file, then only those DGN 
variables defined in that particular file display.  

 

Level Symbology /  
DDB Feature 
 
 

When set to Level Symbology, the dialog changes to allow the defining of the 
DGN variable by graphical symbology (i.e. level, color, weight, etc.) 
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When set to DDB Feature, the dialog changes to allow the specification 
of a feature to define the DGN variable.   

 

DGN File Design file where the graphical element is located. 

Search Criteria When the Level Symbology option is used, define the graphical 
symbology of the DGN variable. These symbologies can be populated 
using the icons or the Match icon defined below. 

Match Clicking this icon and identifying a graphical element will harvest the 
symbology of the element into the dialog. 

Display Clicking this icon will highlight all elements in the design file that match 
the symbology in the dialog. 

Reset This icon will blank out or reset all of the symbology fields. 

Add Used to add an “undefined” DGN variable to the list box once it’s been 
manually defined using either Level Symbology or a DDB Feature. 

Modify If changes are made to a variable (i.e. symbology, dgn file name, etc.), 
this icon is used to update or modify the selected variable in the list box. 

Note Any changes made to these variables are saved within the cross section run in Project Manager. No 
changes are made to the criteria files themselves. 
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DEFINE VARIABLES 

 

By File When the By File option is set to All, all defined variables from all criteria are displayed. If 
the option is set to a specified criteria file, only the variables within the specified criteria file 
are displayed. 

 

Value When a variable in the list box is selected, the defined value of the variable will be placed in 
this box and made available for modification. 

Add Used to add an “undefined” variable to the list box once it’s been manually defined. 

Modify If changes are made to the value of a variable, this icon is used to update or modify the 
selected variable in the list box. 

Note Any changes made to these variables are saved within the cross section run in Project Manager. 
No changes are made to the criteria files themselves. 
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REDEFINABLE VARIABLES 
These are Variables whose values can be changed throughout the cross section run based on station ranges. 
There are two types of redefinable variables:  Numeric and String.  

• Numeric variables always begin with “_d_”. They can only contain a numeric value (e.g. 0, 
1.2, -3, etc.).  

• String variables always begin with an “_s_”. They can only contain a string value. Note that 
if a number is entered (e.g. 9) for a string value that this will be interpreted as the character 
“9” and not the number 9. 

 

Variable This is a list of the variables that can be redefined. 

Redefine This is the definition of the variable highlighted in the Variable list box. 

Edit To edit or change the value 
of a variable, select the 
variable in the list box and 
click this icon. This will 
access the Redefinable 
Variables Editor dialog  
(double-clicking on the 
variable will also access the 
editor). Any changes to the 
variable’s value and/or 
station ranges are made 
within this editor. 

 

Save Exits the editor and saves any changes 

Note Any changes made to these variables are saved within the cross section run in Project 
Manager. No changes are made to the criteria files themselves. 

Cancel Exit the editor without saving any changes. 
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PLOT PARAMETERS 

 

Cross Section 
Lines 

This defines the element symbology for drawing top and bottom of shaped 
pavement. This is also the default symbology for all elements drawn with 
criteria when no specification is set for symbology within the criteria. 

Text  

Line Text Selecting this check box will plot the PGL Elevations on the cross sections. 

Station Text Selecting this check box will plot the Station Text on the cross sections. 

Baseline Name 
Text 

Selecting this check box will plot the Shape Cluster Baseline name on the cross 
sections. 

Note FDOT criteria handles by design ALL of the required labeling so the text options should be unchecked 
or disabled.  The user can control each of the above text options using its associated GEOPAK Set 
Feature dialog. 
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Plot  

Pavement 
Thickness 

This indicates the depth of the shaped pavement in master units. If the shape cluster 
pavement thickness is utilized and a value greater than 0 is given, both the top and 
bottom of pavement are drawn utilizing the lines parameters. If a pavement 
thickness of zero is utilized or the check box is clear, only the top surface is drawn. 

Fill Gaps 
Between 
Clusters 

Connect two shapes or the outermost elements drawn via criteria between two 
shape clusters when the shape clusters reference the same Baseline Name. 

Transition 
Definition 

Dictates the type of superelevation transitions to be used for drawing the proposed 
cross sections. If the check box is clear, all superelevation transitions will be linear, 
regardless of the transition ID attached to the shapes when created. If the check box 
is selected, then the transitions attached to the shapes at the time of creation are 
utilized. Any shape that had no transition identification attached defaults to linear 
transition.   

Intersect 
Between 
Clusters 

When criteria between two separate shape clusters draw lines that extend past each 
other, selecting this check box will cause the two lines to be intersected and 
trimmed. 

Process 
Clusters as 

Indicated 

When selected, GEOPAK draws the sections in the specified order. If disabled the 
default is left to right.   

Remove Skewed 
Effect 

Proposed cross section elements are drawn sensitive to skew angles. Depending on 
the circumstances, the designer may not want to utilize this skew angle, so enabling 
this option removes this skew effect. 

Process Only 
Sections With 

Existing Ground 

When enabled, only cross sections that contain existing ground lines will be 
processed in the run. 

Pavement 
Shapes 

Option to draw the pavement shapes or not. Left unchecked, the top line o a shape 
cluster will not be drawn in the cross section. 

Note FDOT criteria handles by design ALL of the above scenarios so they should ALL be unchecked or 
disabled. 
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DRAINAGE 

 

Draw Drainage 
Components 

Select this check box to draw the drainage components onto the cross sections. 

Project Database This is the project database from GEOPAK Drainage. 

Drainage DGN File Design file where the drainage graphics (i.e. nodes and pipes) reside. 

TYPICAL SECTIONS  
This feature within Proposed Cross Sections was originally developed to automate (as much as possible) 
the development of cross sections for widening and resurfacing jobs, but it has been expanded to account 
for all types of construction. Typical Section Generator is a library of cells that represent typical sections. 
Each typical section is associated with a set of criteria files. It enables selection of a typical section from 
the library and sets everything up under the proper side slope conditions. 

When the typical is applied, the software reads the criteria files and all variables contained in those files are 
populated into the dialog.  
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Cell / 
Description 

The Typical Sections are a cell library where each cell in the library represents a 
different typical.  

Template  

Template 
Designed to 
Work With: 

If the selected typical section is NOT designed for divided roadways, note that the 
“Apply to Left/Right Roadway” option is not available (i.e. it’s dimmed).  

 
If the selected typical section is designed for divided roadways, note that the “Apply to 
Left/Right Roadway” option is available. In this situation, you are required to process 
the typical section twice; once for the Left Roadway and a second time for the Right 
Roadway. 

 

 The FDOT criteria control file accounts for the LT/RT side slopes.  The typical need 
only be applied once to each shape cluster. 

Description Opens the FDOT/ECSO GEOPAK Typical Sections Criteria Help Files, which 
describe what the typical sections are designed to do, under what conditions the typical 
can be run and it documents each of the variables used to control the cross sections. 

 

Range  

Apply to Whole 
Chain 

If this option is used, the typical section criteria is applied to the entire length of the 
chain. 
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Apply Process the Typical Section. This does two things: 

First, it sets up the criteria under the appropriate side slope conditions in the Proposed 
Cross Sections dialog 

 

 

 Second, it populates the variable portions of the dialog with the variables defined in the 
criteria. 
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DELIVERED TYPICAL SECTIONS 
There are five (5) delivered typical sections. Each typical section has its own detailed documentation. 

Existing 
Features 

The Existing_Features typical will extend existing ground lines to the extent of the 
cross section cell and draw the base for the existing pavement, shoulders, curbs, 
sidewalks, and traffic separators. The Existing_Features criteria search the topo 
file to locate the plan view elements defining the limits of the existing features.   
 
It also searches a supplemental design file, (GKLNRD) referred to as the 
“GEOPAK Lines file”, for those same elements.  This supplemental file is 
designed to be used in conjunction with the topo file in instances when the topo 
file is not entirely correct.  Sometimes the topo file elements are not coded with 
the correct features or do not have the correct level symbology for the criteria to 
locate.   
 
In these instances, the correct elements are drawn into the supplemental file for the 
criteria resulting in correct cross sections without modifying the topo file received 
from survey. 

There are a few important notes to remember: 

Do not copy all of the elements from the topo file into the GKLNRD file.  Only 
the individual elements that are not correct should be copied or drawn into this 
file. 

Proposed Feature Criteria does NOT support the GKLNRD file. 

Proposed 
Features 

This draws pavement shoulders, curb and gutter, medians, berms, walls or any 
combination.  This all-in-one typical is used for all instances of proposed features 
whether divided or undivided, new, rehabilitation or reconstruction. 

Slope Reports Slope Text Reports. 

Div_ExSlope This creates ASCII text file of existing pavement slopes for divided roadways. 

Und_ExSlope This creates ASCII text file of existing pavement slopes for undivided roadways. 

Draw Right 
of Way 

The DrawROW typical draws and labels existing R/W and wetlands on the cross 
sections.  It also draws and labels proposed R/W and fence. 
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Exercise 6.1 Shapeless Cross Sections - Existing Base  
In this exercise, the user will be introduced to the Typical Section Generator, a tool that allows the user 
to automatically access and setup the appropriate criteria for cross sections. 

1. Double-click on the self-extracting zip file C:\Chapter6_Exercises.exe and click the Unzip icon at the 
prompt. This will extract and setup the files needed for this exercise. 

2. Open the design file C:/e/Projects/228079115201/roadway/RDXSRD01.dgn.  

3. Access the Model RDXSRD. 

4. Access Project Manager. 

5. From Road Project, click the Proposed Cross Sections icon.  

 

6. Create a new run named EXBASE and access the dialog.  

 

7. From Proposed Cross Sections, select the category XS DGN File.  

 

8. The XS DGN File name populates automatically from the Working Alignment Definition. 

9. Change the Tolerance to 0.01. 
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10. Select the category Pattern. 

 

11. Enable the Use Working Alignment Definition toggle. 

 

12. The dialog populates with the pattern symbology information. 

13. Select the category Existing Ground. 
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14. Enable the Use Working Alignment Definition toggle. 

 

15. The dialog fills out with the appropriate existing ground information. 

16. Select  the category Shapes. 

 

17. The existing base criteria do not need superelevation shapes, so this will be a Shapeless run. 

18. Select the category Shapeless. 

 

Note Even though there are shapes defined in the Working Alignment Definition, in this case we are not 
using the Working Alignment Definition but choosing to override this by manually setting the option. 
This will in no way affect the Working Alignment Definition. 
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19. Select the category Shape Clusters. 

 

20. Click the down arrow for Chain and select BL817. 

 

 

21. Click the down arrow for Profile and select EXGROUND. 

 

22. From Proposed Cross Sections, click the Add icon to add the PGL information to the list box. 
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23. Select the PGL added in the previous step, and then click the Typical icon. Typical Sections opens. 

 

24. Select the Cell Existing_Features. 
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25. Click the Description icon to open the help files for the Existing Features typical. 

 

26. Review the documentation for the Existing Features typical. Close the Windows Internet Explorer 
window when done. 

 

27. Click Apply. Typical Sections closes. In the Proposed Cross Sections dialog, the Side Slope 
Conditions list box and Criteria Files are populated. 
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28. Select the category Define DGN Variables.  Note that there are no variables to change. 

 

29. Select the category Define Variables. No changes are required. 

 

30. Select the category Redefinable Variables.  
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Note For this exercise, we will leave these variables unchanged. We will learn how to modify these variables 
in a subsequent exercise.   If the Existing_Features labels are not desired, modify the redefinable 
variable _S_EFTTL value to ^N^. 

31. Select the category Plot Parameters. 

 

32. Double-click on the sample graphic for XS Lines to access the GEOPAK Set Feature dialog. 

 

 

33. Change the symbology as shown. 

 

Note The XS Lines symbology is used ONLY to control the symbology of the graphical lines associated with 
the superelevation shapes. The criteria will control everything else. Since we are using a shapeless run 
here this symbology will not be used. 

34. Click OK to close the GEOPAK Set Feature dialog. 
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35. Disable ALL of the Plot toggles. 

 

 

 

 

 

36. Select File > Save Settings. 

37. Select File > Run.  

 

38. Proposed Cross Section opens. 

 

 

 

 

 

39. Click Apply. Processing Display 
opens and cross sections are drawn 
into the design file (this may take a 
few minutes). 

 

40. Exit the Proposed Cross Sections dialog. Click Yes when prompted to Save Settings. 

41. Access Cross Section Navigator. 

42. Review the cross sections and note the existing features drawn on the cross sections. 

 

43. Close the Cross Section Navigator. 

44. From MicroStation, select Edit > Select All. 

45. From MicroStation, select Edit > Lock to lock the newly created elements. 
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Exercise 6.2 Proposed Features 
In this exercise, the user will find many steps that are the same as in the previous exercise. Only steps that 
are different will have explanations and screen shots. This exercise is a continuation of Exercise 6.1 and the 
assumption is that the design file is still open. 

1. From Road Project, click Proposed Cross Sections.  

2. Create a new run named XSRECON and access the Proposed Cross Sections dialog. 

3. Set the options for Tolerance, XS DGN File, Pattern and Existing Ground as was done in the 
previous exercise. 

4. Enable the Use Working Alignment Definition toggle for Shapes. 

 

5. Select the category Shape Clusters.  

6. Click the Scan icon. 

 

7. The List of Clusters dialog displays. 

 

8. Select the Left Cluster PGL in the list as shown (this information represents the Left Roadway of the 
divided section). Note that upon selection, the information fills out in the Proposed Cross Sections 
dialog. 

 



PROPOSED CROSS SECTIONS - Typical Sections _______________________________________________________ Chapter 7 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 6-41 

9. From the Proposed Cross Sections dialog, click Add to add the shape cluster to the list box. 

 

10. Repeat the previous two steps again to add the Right Roadway Shape Cluster to the list box.  

Note Always list Shape clusters from left to right in the direction of stationing. 

11. Close the List of Clusters dialog. 

12. Select the Left Roadway Shape Cluster in the list box as shown. Note the Typical icon enables. 

 

13. Click the Typical icon to access the Typical Sections dialog. 

14. Select the Cell Proposed_Features. 
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15. Click the Description icon to review the help files for this typical. 

 

16. Close the Internet Explorer window and return to the Typical Sections dialog.  Note that “Apply to 
Left Roadway/Apply to Right Roadway” is grayed out. 

17. Select Apply. 

 

18. The Proposed Cross Sections dialog fills automatically with the proper criteria files under the 
appropriate side slope conditions. 
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19. Repeat Steps 9-15 for the Right Roadway.  

20. From Proposed Cross Sections, select Define Variables. 

 

21. Select the variable RIGHT OF WAY DGN. 

22. In the Value field, key-in C:\E\Projects\22807915201\rwmap\rwdtrd01.dgn. 

Note You can cut and paste the path from Windows Explorer or click the “select a DGN” icon and browse to 
the desired file instead of typing it in. 

23. Click Modify to change the value of the variable. 

 

24. Select Plot Parameters. 

25. Set the XS Lines symbology as shown. 
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26. Disable all the Plot settings as done previously. 

 

27. Select File > Save Settings. 

28. Select File > Run and process the cross sections. 

29. When processing is complete, close the Proposed Cross Sections dialog and Click Yes when 
prompted to Save Settings. 

30. Open Cross Section Navigator and review the cross sections.  

Exercise 6.3  Modifying Redefinable Variables 
In this exercise, the user will learn how to use and modify the Redefinable Variables to control the behavior 
of our cross sections. 

1. Access Proposed Cross Sections, using the previously created run. 

2. Select Redefinable Variables. 

3. Click the Edit icon. 

 

 

 

 

 

 

 

 

4. In the Redefinable Variables Editor dialog, 
change the value of _s_ForcedSlopeLeft to “Yes”. 

 

Note This is an example of changing a string variable. 
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5. Click Save. 

6. Change the value of _s_ForcedSlopeRight to “Yes”. 

 

7. Edit the variable _d_ForcedSlopeLeftValue. 

 

8. Modify the value of _d_ForcedSlopeLeftValue as shown and Save. 

 

Note This will force the criteria to draw a slope of 1:2 for all stations less than 90+00, and then use a slope of 
1:4 for all stations greater than 90+00. 
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9. Edit the variable _d_ForcedSlopeRightValue. 

 

10. Modify the value of _d_ForcedSlopeRightValue as shown and Save. 

 

11. Select File > Save Settings. 

12. From MicroStation, select Edit > Select All. 

13. From MicroStation, select the Delete Element icon or hit the delete key to delete the previously 
plotted cross sections. 

14. Select File > Run and process the cross sections. 

15. When processing is complete, close the Proposed Cross Sections dialog and click Yes when 
prompted to Save Settings. 

16. Open Cross Section Navigator and review the cross sections.  
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Exercise 6.4 Using DGN Elements and Adhocs 
 Median Designator Lines 

In this exercise, the user will learn how to control the behavior of our criteria and cross sections by placing 
graphical elements in a design file. These graphical elements can be “tagged” with additional information 
called “Adhocs”, and are used solely for the purpose of passing information to the criteria.  

1. Open the design file DSGNRD01.dgn. 

2. Access the D&C Manager. 

3. Navigate to the item MedLn as shown in the image 
below. 

 

 

 

 

 

 

  

 

4. Enable the toggle for Place Influence and Adhoc Attributes. 

 

5. When the toggle for Adhoc Attribute enables, the MedLn Median Line for Criteria Adhoc Attributes 
dialog appears. 
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6. Change the value of the Median_Type Adhoc to 5 by placing a Data Point inside the Value field, 
change the value and then press Enter. 

 

 

7. Close the Adhoc dialog. 

 

8. Change the D&C Manager to Toolbox Mode. 

 

 

9. The Adhoc dialog may pop up again when you switch to toolbox mode. Just close it.  

10. Using the MicroStation Place Line tool, place a Median Line inside of the traffic separator starting 
near station 75+65.00 making sure the Median Type Adhoc is set to 6 for traffic separator.   

  

11.  Continue this line through to the end of the traffic separator. 

12. Start a new line in the normal median (between the curb and gutter) with the Median Type set to 5.  
This line is a trigger line and is only drawn across the pattern lines somewhere between the backs of 
curb. 
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13. Across pattern lines through median crossovers, a Median Line must be drawn with the Median Type 
set to 7 within the limits of the crossover pavement between the shape clusters. 

Note The placement of this median line and its associated Median_Type Adhoc will tell the criteria what type 
of median to build between these station values. Because this dataset shapes the crossover areas, the 
Median Line must drawn where the shapes come together.  

 Side Road Tie Down Lines 
1. From D&C Manager, navigate to and select the item SRTD as shown. 

 

2. Place Sideroad Tie Down lines at the intersection at Station 95+00 as shown in the figure below. 

 

3. Place another Sideroad Tie Down line at the intersection at Station 105+00 as shown in the figure 
below. 
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Exercise 6.5 Using the Adhoc Attribute Manager  
In this exercise, the user will check the Adhocs on the existing elements and modify Adhoc values using 
the Adhoc Attribute Manager. 

1. Open the file C:/e/projects/22807915201/roadway/dsgnrd01.dgn. 

2. Open the Adhoc Attribute Manager.  It can be accessed through Applications > ROAD > 3PC 
Adhoc Attribute Manager or through the Road Toolbox. 

 

3. Select the Identify Element icon, and then click on one of the Milling Limit lines.   

Tip   Turn off the display for the topord and utexrd references, along with all the levels 
except ShldrPaved, EOP, and MillingLimits.  This will make selecting the desired elements 
easier. 

   

4. Review the list of Adhocs on the Milling Limit line. 

5. In the Adhoc Attribute Manager, highlight Milling Depth in the list box.  Right click over the line 
and select Copy to Display Filter. 
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6. Click on the Highlight Selection icon to see the highlighted elements that match the query.  

 

7. Click on the Add Elements to Selection Set icon to place the highlighted elements in a MicroStation 
selection set. 

8. In the Adhoc Attribute Manager, double click on the value of Milling Depth and change it from 
0.160000 to a value of 0.20. 

    

9. Repeat step 8 to change Overlay Thickness 1 to 0.20 as well. 

10. Select File > Preferences. 
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11. Preferences opens.  Set the Set Mode to Replace. 

 

12. Click on the Set Attributes icon. 

 

13. An Alert displays.  Click Yes to set the new attributes to the elements. 

14. Click on the Identify Element icon.  The elements from the selection set drop from the selection set 
and appear in the Adhoc Attribute Manager list box.  Use the arrow icons to toggle through the 
elements to double check that the new Adhocs were added. 
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7 BOREHOLE NAVIGATOR 

OBJECTIVES 
• Overview of Borehole Navigator 

• Overview of Preferences 

• Import Soil Boring Data 

• Plot Soil Borings into Cross Sections 

INTRODUCTION 
The GEOPAK GeoTechnical toolset includes a wide variety of tools for the input, storage, review and 
editing of soil boring data.  The user can create subsurface TINs of the various materials for subsequent 
drawing onto cross sections or profiles.  They may draw actual borings in Plan View, placed on cross 
sections, profiles or drawn into 3D as soils columns.  GeoTechnical tools have several main functions: 

• Storage of boring data for easy review and manipulation 

• Drawing of borings onto plan view  

• Drawing of borings onto profiles 

• Drawing of borings onto cross sections 

• Drawing of borings into a 3D file 

• Generation of subsurface TINs 

The Borehole Navigator (main dialog) facilitates the manipulation of data. Users can add, modify or 
delete boreholes along with manipulation of material layers. It also supports Standard Penetration Test 
(SPT) data (although for FDOT projects, SPT uses a different application). 

ACCESSING BOREHOLE NAVIGATOR  
Access the Borehole Navigator through the MicroStation menu Applications > ROAD > Utilities > 
GeoTechnical – or – from the Road toolbox. 
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WORKFLOW 
Before populating borehole information, the user must create a borehole project file via the File > New 
option.  The default file extension for a borehole project file is .GTD.  Once created, a dialog opens that 
prompts for project specific information – the GPK file for the project and a ground tin model name. 

 

Upon creating the project, the user imports Borehole data via several methods as listed below: 

• Import from a Borelog32 file.  

• Import from CSV files. 

• Import via pre-2004 Edition ancillary input files. 

• Input one at a time via the Add Borehole tool. 

 

After one or more boreholes are stored in the project file, the user may draw them in any context – plan, 
profile, cross section or 3D.  In addition, the user may generate subsurface models on any layer. 
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BOREHOLE NAVIGATOR DIALOG 

MENU OPTIONS 

 

FILE 

New Creates a new GTD file. 

Open Opens an existing GTD file. 

Save Saves the current dialog information into the active GTD file. 

Save As Saves the current dialog information into a new GTD file. 

Import Imports data from another file format into the dialog. 

 

Borelog32 Imports data from a Borelog32 formatted file. 

Ancillary INP Imports data from an input file (used in GEOPAK V7 & earlier)  

CSV  Imports data from a CSV file format.  Three options include: 

 Borehole (.brh) - The Borehole file contains the following.  borehole_name, 
description, chain_name, station, offset, depth, water_elev_0, water_elev0_date, 
water_elev_24, water_elev_24_date, water_elev_type (0=DOC 1=strata), rok_elev, 
rok_elev_type (0=DOC 1=strata), elevation, location_point_x, location_point_y.  
NOTE: not all fields are required. The minimum information is borehole_name, 
chain_name, station / offset or location_point_x and location_point_y. 
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 Material (.mtl)

 NOTE: each line can have only one stratum; however, each borehole may have as 
many lines as needed. To accommodate some of the GPS equipment, the 
borehole_name may be set to 0. When encountered, GEOPAK utilizes the 
borehole_name from the previous line. The use of the actual borehole_name in 
multiple lines is also supported. 

 – The Material file contains the material information and supports 
the following.  Borehole_name, material_name, type_of_elev (DOC=DOC 
Strata=SE), description, doc_or_se (depth of cover or strata elevation), 
include_rock_data (Yes=1 No=0), record_percentage, required_percentage   

 SPT

 When importing a file and the borehole name already exists, an Alert message is 
displayed.  If Append is selected, the data for current borehole is maintained and 
just the fields that are being imported change. If Replace is selected, the current 
borehole in the database is deleted and the imported information is utilized. The 
option can be applied to a single borehole, or to all boreholes in the current process. 
If Cancel is selected, the Alert message closes and no changes occur, returning the 
user to the Borehole Navigator. 

 – This file contains the Standard Penetration Test data and supports the 
following.  Borehole_name, type_of_elev (DOC=DOC Strata=SE), description, 
doc_or_se (depth of cover or strata elevation), total_count, count_1, count_2, 
count_3 

Preferences Opens the GeoTechnical Preferences dialog. The GeoTechnical Preferences 
control the graphic display of the borehole data in plan, 3D, cross section, and profile 
views.  The settings may be saved (*.gtp) to serve as a standard setup for subsequent 
projects.  In larger organizations, the GeoTechnical Preference file may be set up and 
administered by a single person or group of people such as a CAD support group in the 
same manner as the existing Design & Computation Manager databases. This dialog 
will be covered in more detail later in the chapter. 

FDOT has a .GTP file, called GEOTECH2008.GTP, available for use in the 
FDOT2008\GEOPAK\bin folder.  The file contains preferences that comply with State 
CADD standards for Geotechnical drawings. 

Project Files Opens the GeoTechnical dialog where the project files (gpk and tin) are entered or can 
be modified. 

 

The checkbox is used to override manually entered elevations with the TIN elevations. 

Exit Exits the Borehole Navigator tool. 
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TOOLS 

Convert Coord to Sta/Off This tool converts borehole(s) stored with coordinates to station / 
offset, based on the user defined Chain.  

 

Convert Between Chains  This tool converts station / offset of boreholes based on the stored chain 
to the station / offset of any other defined chain. 

 

Settings Opens the Borehole Settings dialog box. 
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TOOL ICONS 

 

 Add Borehole 

 Delete Borehole 

 Modify Borehole 

 Select Borehole 

 Material Alignment 

 Interpolating Subsurface TINs from Borehole Data 

 Visualize Boreholes in Plan View 

 Visualize Boreholes in Profile View 

 Visualize Boreholes in Cross Section View 

 Visualize Boreholes in 3D 

 Closes Borehole Navigator 

 Switches to Tool Box Mode 

 

 Switches back to Dialog Mode. 
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 This is a manual tool used to add borehole data into the project. 

ADD BOREHOLE 

 

Borehole Name of the new borehole to be added. 

Type The Type determines the element symbology used to draw the borehole in plan view. 
The Types listed are a mirror of the types in the Preferences. 

Description This is an optional description for the borehole. 

Chain Name of the chain used to locate the borehole.  If a chain is not used, the X and Y 
coordinates are the only way to loctate the borehole. 

Auxiliary Chain A secondary chain that can be associated to the same borehole located off a primary 
chain.  The user must provide the chain/station/offset for the auxiliary chain location. 

Locate By Station/Offset  Locates the borehole using station/offset information. 

 –or— 

Locate By Coordinate (X&Y) Locates the borehole using X & Y coordinates. 

Station/X The Station or X value of the borehole location depending on the Locate option. 

Offset/Y  The Offset or Y value of the borehole location depending on the Locate option. 

Reference TIN Elevation  Method used to locate the existing ground elevation.  

 –or— 

User Supplied Elevation  Method used to located the existing ground elevation. 

Water Elevation Optional data that supports the 0 hour and 24 hours readings and dates.  0 hour is taken 
immediately after the boring is drilled while 24 is the reading taken 24 hours later.  
These reading can be measured as a depth of cover or strata elevation. 

mk:@MSITStore:C:\Program%20Files\BentleyXM\Documentation\geopak_geotech.chm::/2gt2/Descriptions.htm�
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Refusal Elevation  This is the optional data designating the elevation of the Refusal.  This value can 
be Strata Elevation (actual elevation of the refusal) or Depth of Cover, both in terms 
of master units. 

Material Information  Opens the Material Information dialog.  This dialog is used to add, modify or 
delete material layers associated with the boring. 

 

This dialog contains 3 sections: Material List Box, Strata Data, and Core Data 

Material List Box  Contains a list of the material layers associated with the boring.  
Includes the icons on the right side of the list box to add, modify, or deleted the selected 
material layer in the list box. 

Strata Data Settings define the boring material type. 

Material Name - Drop down list to define the material type.  This list is populated from 
the material types defined in the preferences. 

Boring Type - Defines the elevation data type.  Options are Depth of Cover or Strata 
Elevation.  The numeric field box used to assign the depth of cover or strata 
elevation. 

Description

Core Data Optional definition for the material layer. This only applies to the Rock Layers 
and not to each individual material. If the Material Name requires the information of 
Recovery % and the Rock Quality Designation %, activate the Include Core Data toggle 
and enter the percentages in the respective entry fields. These Core Data entry fields are 
only available if the toggle is activated. 

 - This is the optional description for the entered data.  Toggle on the check 
box to un-ghost the field. 

SPT Data Opens the SPT Data dialog box. This dialog box contains 2 sections:  SPT Data List 
Box and the data entry options underneath. 

SPT Data List Box Lists the SPT Data for the borehole. 

Data Entry Option The elevation can be entered as a Depth of Cover or at the actual 
Elevation (Strata Elevation). Select Depth of Cover or Strata Elevation and key-in the 
appropriate value.  Activate the Count toggles for the data. In some instances, the 3 Blow 
Counts are plotted into cross section or profile view; while other cases, only the Total 
Count is labeled. 

OK Adds the borehole information to the borehole list box. 

Cancel Closes the Add Borehole dialog without storing the borehole information. 
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 This opens the Delete Borehole dialog, which provides a list of the current boreholes to select 
from to delete.  Highlight the desired boreholes to delete from this list box and click Delete. 

DELETE BOREHOLE 

 

 This opens the Modify Borehole dialog.  The information from the Add Borehole dialog relating 
to the borehole displays.  The user can make changes to these settings and then click OK to save. 

MODIFY BOREHOLE 
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The functionality of the ID icon  is determined by the setting (ID locates the closest borehole to 
DP) in the Borehole Settings dialog. This dialog is opened by selecting Tools > Settings from the 
GeoTechnical menu bar. 

SELECT BOREHOLE 

When the ID locates the closest borehole to DP is active and a Data Point is placed on the screen, the 
navigator highlights the borehole that is closest to this selected location and displays the relevant 
information for that borehole in the navigator. 

When the ID locates the closest borehole to DP is not active and any part of a borehole or its label is 
selected and accepted, the navigator highlights the borehole in the navigator and displays the relevant 
information for that borehole. 

 After entering the boreholes in the GeoTechnical project, the user may review and modify the 
material layers of adjacent boreholes. When selected, the Material Alignment tool opens two dialogs: 

MATERIAL ALIGNMENT 

Align Material Layers Master List  The Align Material Layers Master List displays all Material 
Names in the current project. If the Material is found in more than one stratum per 
boring, numbers are appended to the Material Name, i.e., PEAT-1 and PEAT-2. The 
Average, Minimum, and Maximum Depth of Cover for each Material Name are also 
listed. The entries in this dialog are display only, and no user input is required.  

 

Align Material Layers The Align Material Layers tool is utilized to review / edit boreholes.  

 

The Material Names and TIN Name listed in the left side of the dialog. The boreholes 
list across the top and the strata elevations or depths of cover for each boring are listed. 
To move data, utilize the VCR icons on the bottom of the dialog to scroll through the 
boreholes. Note the double left arrows return to the first borehole, while the double right 
arrows advance to the last borehole. The single arrows move one borehole per each 
pressing of the arrows.  
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To move the data up or down to match strata, use the arrow keys to move the borehole 
to be changed to the center position. This can be easily viewed on the screen, as this 
borehole is displayed in blue in the dialog. Next, highlight the elevation or depth of 
cover to be moved, which turns the data red. The associated material layer is changes 
green. 

Use the blue arrows at the bottom of the dialog to move the strata data up or down, until 
it lines up with the desired Material Name. It can only be aligned with another layer of 
the same Material Name. 

 Subsurface TIN files can be created for any material name with a minimum of three boreholes with 
the specified material. 

INTERPOLATING SUBSURFACE TINS FROM BOREHOLE DATA 

 

Boundary In some cases, the user may want to demarcate the area 
of a particular material type. Examples include swamps, 
peat bogs, etc. where a distinct boundary can be 
ascertained. In this case, a boundary should be created, 
where the TIN file will not be created outside of it. This 
can be accomplished by highlighting the material from 
the Create TIN Files From Material Layers dialog, then 
clicking Boundary. 

Select Area Click this icon, then select and accept a previously drawn closed shape to demarcate the 
boundary. 

Place Area Click this icon, then place Data Points to define a closed shape to demarcate the 
boundary. 

Hilite Area Clicking this icon highlights any previously defined boundary. 

Reset Area Clicking this icon deletes any previously defined boundary. If the Boundary was placed 
with a previously defined shape, the MicroStation shape is not deleted. 

Apply Zero 
Drape Area 

When activated, the Boundary is draped onto the Ground TIN, and utilized in the 
creation of the TIN file. In this case, the material depth is zero at the location of the 
Boundary and interpolated with the borehole elevations. When not activated, the X, Y 
coordinates of the Boundary are utilized as the limits of the TIN file, but the Boundary 
elevations or Z coordinates are not utilized during interpolation.  
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Void In some cases, there may be an area within a Material 
TIN where the name type is not present. In these cases, 
the user may place a void within the Material TIN. 

 

 

 

Select Area Click this icon, then select and accept a previously drawn closed shape to demarcate the 
void. 

Place Area Click this icon, then place Data Points to define a closed shape to demarcate the void. 

Hilite Area Clicking this icon highlights any previously defined void. 

Reset Area Clicking this icon deletes any previously defined void associated with the Material TIN. 
If the Void was placed with a previously defined shape, the MicroStation shape is not 
deleted. 

Apply Zero 
Drape 
Area 

When activated, the Boundary drapes onto the Ground TIN, and utilized in the creation 
of the TIN file. In this case, the material depth is zero at the location of the Boundary 
and interpolated with the borehole elevations. When not activated, the X, Y coordinates 
of the Boundary are utilized as the limits of the TIN file, but the Boundary elevations or 
Z coordinates are not utilized during interpolation.  

Material Names All Material Names found in the current GeoTechnical project are listed in the dialog. 
If the Material is found in more than one stratum per boring, numbers are appended to 
the Material Name.  

For example, in the dialog above, PEAT was found in two stratum, so PEAT-1 and 
PEAT-2 are listed. These names are utilized as the Material TIN names with the 
extension .TIN.  

To determine that stratum of each borehole in relationship to the others, refer to the 
Material Alignment tool. A minimum of three boreholes for each material are required. 
If TIN creation is attempted without three points, an Alert message is displayed. 

TIN Types  Two are supported as detailed in the table below. 

Drape ExGr TIN   The Ground TIN and borehole elevations are utilized to create the TIN. 
The resultant TIN mirrors the Ground TIN and is adjusted for the elevation depths. 

Material TIN   The Ground TIN is not utilized, and the Material TIN is created 
exclusively from the borehole elevations. 

Modify  To change the Material TIN type, highlight the desired line, set the TIN type, then click 
Modify icon. Note the type changes in the list box. 
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 GeoTechnical Tools draws boreholes and associated text unto a plan view drawing, based on 
Preferences in the GeoTechnical Preferences. The user can select single or multiple boreholes via the list 
box. 

VISUALIZE BOREHOLES IN PLAN VIEW 

 

Highlight the borehole(s) to be drawn and set the Mapping Scale. Note multiple boreholes may be 
highlighted by using the Shift and Control keys. Then click Apply to draw. 

 The GeoTechnical Tool draws boreholes and associated text onto a profile view drawing, based on 
preferences in the GeoTechnical Preferences. The borings are drawn in the same file as the original profile 
drawing.  

VISUALIZE BOREHOLES IN PROFILE VIEW 

The user can select single or multiple boreholes via the list box.  

 

Highlight the borehole(s) to be drawn. Note multiple boreholes may be highlighted by using the Shift and 
Control keys. <Control> A highlights the entire list. 

Chain This includes all chains in the defined GPK file. At invocation of the dialog, the 
Borehole entries associated with displayed chain are listed. When another chain is 
selected from the list, the associated borehole entries are updated. 

Profile This includes all profiles in the defined GPK file.  
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Plot according to 
Offset  

The distance from the origin of the borehole column and the profile is a function of the 
offset distance from the Horizontal Centerline. The further away from the centerline the 
borehole is measured, the further away from the profile it is visualized in profile view.  

Plot according to 
Stack  

When the Plot according to Stack is set, the boreholes (at same station) are stacked 
one above another. Positive (horizontal) offsets are below the profile, while negative 
offsets are above.  

Plot according to 
Profile Depth  

When the Plot according to Profile Depth is set, the origin of the borehole column is 
placed at the profile elevation based on the borehole station. If several borings have the 
same station, the borings are stacked vertically with a fixed distance between. Positive 
(horizontal) offsets are below the profile, while negative offsets are above. The offsets 
increase moving away from the profile. 

Plot according to 
Borehole Depth  

When the Plot according to Borehole Depth is set, the origin of the borehole column 
is placed at the borehole station and borehole elevation.  

Text Wrapping  Optional Text Wrapping is supported by activating the toggle to the left of Apply Text 
Wrapping. Set the value for the number of characters per line. Any line over the 
specified number wraps to the next line. The Line Spacing is the distance between lines 
(from justification from one line to the line below.) 

Profile  The profile information is not associated with the individual borehole data, therefore 
this setting does not affect which borehole entries display in the list box. 

Define Profile Origin If the Profile toggle is activated and a profile is selected from the list, clicking 
Define Profile Origin opens the Define Profile Origin dialog. 
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Information about the selected profile from the Visualize Profile dialog is displayed at the top of the dialog 
(no modification is allowed). The Horizontal and Vertical Scale at which the profile has been previously 
plotted into graphics should be entered in the center section of the dialog, along with the Beginning and 
Ending Stations of the range that the boreholes have been stored. Select the Gap or No Gap option to 
match the setting when the profile was originally drawn.  

Locate the DP Station / Elevation, DP X and Y of the profile origin either by key-in or DP selection from 
graphics. If a profile cell was placed at the time of drawing, press the ID Cell icon and select the cell, 
which populates the dialog based on the cell settings. Press OK to return to the Visualize in Profile View 
dialog. Select single or multiple boreholes from the list box, then press the Apply icon to commence 
drawing the boreholes on profiles. 

 The GeoTechnical Tool draws boreholes and associated text onto a cross section view drawing, 
based on preferences in the GeoTechnical Preferences. Viewing of columns, materials, water table 
elevations, and SPT data, including the corresponding labels is supported. 

VISUALIZE BOREHOLES IN CROSS SECTION VIEW 

The borehole must have a ground/surface elevation which has been user defined or computed from the 
defined TIN. If no ground elevation has been given or computed, the borehole is not visualized in cross 
section view.  

 

Chain  Includes all chains which have XS Cells in the active cross section file. When the 
desired chain is selected from the list, the associated borehole entries populate the list 
box. 

Station Range   To draw borehole entries within a specified station range along the chain, enter the 
Beginning and Ending Station for the range in question. To visualize a single borehole, 
assign the Beginning and Ending station such that the borehole falls within the 
specified range. 

Projection Data  GEOPAK supports several options for projection of boreholes onto cross sections.   
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To visualize the boreholes at the nearest cross section (if they do not fall on an exact xs 
station in the xs design file), select the option to Project onto Nearest XS. This option is 
used in conjunction with the Maximum Projection Distance. This Distance sets the 
maximum distance a borehole can be radially projected onto a pattern. The Maximum 
Projection Distance option is only active if the Project onto Nearest XS is selected. 

To visualize the boreholes at the exact cross section station, utilize the Draw Only if on 
XS option. Any boreholes whose station does not match the station of a cross section cell 
is not drawn, so no projection to nearby cross sections is available with this option. Note 
the Max. Project Distance is ghosted for this option. 

Two options are supported for the elevation projection:  

 Project at Borehole Ground Elevation  The borehole column is visualized at the actual top of 
borehole elevation. This could result in the column origin being visualized above or 
below existing ground at the nearest cross section. 

 Project to XS Ground Elevation The borehole column is visualized at the elevation of the 
existing ground at the nearest projected cross section at the given offset distance. This 
would result in the column origin being visualized at the existing ground elevation. The 
cross section must have a defined existing ground line at the location of the borehole, 
which is defined by clicking Define Existing Ground.  

 

 Activate the toggles to the left of the desired parameters, then enter the values in the key-
in fields. In lieu of typing, click Select to open the pop-up dialog, wherein the parameters 
may be selected. To view any elements of the specified symbology, click Display. To 
clear out all entries in the Existing Ground Line dialog, click Reset. 

 Once all of the required information has been given, click Apply to initiate the 
visualization of the borehole entries onto the cross sections. 

Text Wrapping Optional text wrapping is supported by activating the toggle to the left of Apply Text 
Wrapping. Set the value for the number of characters per line. Any line over the 
specified number wraps to the next line. The distance between lines (from justification 
from one line to the line below it is the Line Spacing.) 

Text wrapping is only supported when the Text String option (and not Individual 
Components) is utilized. This option is set within the GeoTechnical Preferences. 

Based on the GeoTechnical Preferences settings, the borehole text may be shifted 
downward. This occurs when the text height is greater than the material height for each 
strata. Note the overlapping is between strata labels within the borehole, but does not 
take into account text from one borehole overlapping an adjacent borehole. 
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 The Visualize Boreholes in 3D is utilized to display an individual borehole column in 3 
dimensional view at the correct elevation. This tool is for visualization purposes exclusively and must be 
invoked from within a 3-D file. If the tool is invoked within a 2-D file, an Information message is 
displayed. 

VISUALIZE BOREHOLES IN 3D 

 

Single or multiple boreholes may be drawn. Simply highlight the desired boreholes, then set the desired 
symbology, i.e., Level, Weight, and Style.  

The Column Radius is the radius (in terms of master units) of the circle drawn in top view.  

BOREHOLE INFORMATION 

 

This portion of the dialog displays the list of the boreholes in the project.  As each borehole is highlighted 
in the list box, the related information is shown below the list box.  Note:  The information shown here 
cannot be modified from this part of the dialog box.  The Modify Borehole tool must be used. 
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MATERIAL INFORMATION 

 

In order to view the Material Information stored for the boreholes in the list box, the user must toggle on 
the drop down arrow.  The material information shown cannot be modified from the main dialog.  It must 
be modified with the Modify Borehole tool. 
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GEOTECHNICAL PREFERENCES 

 

The GeoTechnical Preferences control the graphic display of the borehole data in plan, 3D, cross 
section, and profile views. The settings may be saved (*.gtp) to serve as a standard setup for subsequent 
projects.   Upon selecting each option, the right side of the GeoTechnical Preferences dialog changes to 
reflect the selection. 

Note FDOT has a .GTP file available in the FDOT2010\GEOPAK\bin folder.  The file name is 
GEOTECH2010.GTP and contains preferences that comply with State CADD standards for 
Geotechnical drawings. 

FILE MENU 

 

New Creates a new preferences file. All list boxes are empty and it is required to define each 
item. For either the Open or New modes, prior to opening the new database, GEOPAK 
closes the original preferences file in an orderly manner. A dialog opens offering the 
opportunity to save any changes previously made to the original preferences or to ignore 
the changes. 

Open Opens a previously created preference file. 

Save Saves the current settings to the active preferences file. 

Save As Saves the current settings as a new preference file. 

Password The Password only restricts users from changing or adding to the preferences, however, 
they can still review each item to view the element symbology or other parameters. 

Exit Exits the Borehole Navigator dialog. 
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DESCRIPTIONS 

 

Two group boxes are supported within the Descriptions option: Borehole Types and Material Names. 
GEOPAK supports an unlimited number of Borehole Types. When the fifth entry is added, scroll bars 
automatically display for ease of viewing.  

Borehole Types The Borehole Types stored within the Descriptions Preferences are reflected throughout 
the GeoTechnical tools and can only be added within the Description Preferences.  By 
opening the Add Borehole dialog, the Borehole Types mirror what is in the Description 
dialog, enabling the users to select the desired Type from the list.  The Borehole Types 
are also utilized elsewhere within the Preferences, for example, in the Plan > Cell 
option.  Additional Borehole Types may be listed if an existing project is opened which 
has types not listed or an existing preference file with additional types has been opened. 

Material Names GEOPAK supports an unlimited number of Material Names / Numbers. To utilize a 
Material Number, activate the toggle to the left of Material Number. An optional 
Material Color can be utilized by activating the toggle to the left of Material Color 
and selecting the desired color. The color is displayed in the list box. If the Material 
Color is not activated when a Material is added, N/A is displayed in the list box. The 
color is utilized when drawing the soil strata when visualized as a column in 3D and 
when the fill option (rather than material pattern) is utilized when drawing boreholes on 
cross sections and profiles. 

Each group box supports three action icons are detailed below. 

Add 

  

To add a Borehole Type or Material Name / Number, populate the edit field at the 
bottom of the group box, then click Add.  

Modify  

  

To modify, highlight the line to be modified and GEOPAK populates the edit field. 
Change the edit field, then click Modify.  

Delete To delete a line, simply highlight the line, then click Delete. An Alert message prompts 
the user for deletion.  Click Yes deletes the Borehole Type, clicking No or Cancel 
closes the Alert message, but does not delete the type. 
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PLAN 

 

Only one option is supported on the Plan dialog, Draw Borehole in Plan View. When activated, all plan 
related options in the list box are un-ghosted, so the user can set up all preferences required to draw soils 
borings in the plan view. When not active, borings cannot be drawn in plan view. If the user attempts to 
draw plan view borings via the Navigator, an Alert message is displayed. 

In order to select the Cell / Symbol option, the Draw Borehole in Plan View toggle in the Plan option 
must be activated. This dialog reflects the Cell option for drawing. 

CELL/SYMBOL 

 

Within the dialog, all parameters required to draw the cell / symbology representing the borings in plan 
view are defined. When adding or modifying boreholes, the user selects the desired Type from the list 
within the Add Borehole dialog.  
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Drawn As: 
(Cell /  
Symbol) 

Two types are supported: Cell and Symbol. When set to Cell, the dialog reflects cell 
selection options in the Borehole Feature group box, i.e., cell library, cell name, scale, etc. 
When set to Symbol, the Borehole Feature group box changes to reflect symbol preferences, 
i.e. character, font, etc. 

Borehole Type 
(list box) 

All defined Borehole Types within the preferences are listed. New Borehole Types can be 
added, while current listings can be modified or deleted.  

Add (icon) To add a Borehole Type, populate the edit field at the bottom of the group box, then click 
Add.  

Modify (icon) To modify, highlight the line to be modified and GEOPAK populates the edit field. Change 
the edit field, then click Modify.  

Delete (icon) To delete a line, simply highlight the line, then click Delete. An Alert message prompts the 
user for deletion.  Clicking OK deletes the Borehole Type, clicking Cancel closes the Alert 
message but does not delete the type. 

  Cell  When set to Cell, the Borehole Feature group box changes to reflect cell preferences, as 
illustrated below. 

 
First, select the desired Borehole Type from the list. Types cannot be manually entered, as 
the list reflects the listings from the Descriptions option within Preferences. Next, manually 
enter the desired Cell Library or select via the File icon.  

If the library is stored on a central server and mounted by the users with various drive 
designations, do not include the path and drive. Simply include the cell library within the 
users' MS_CELLLIST.  

The Cell Library field supports the MicroStation Cell Configuration Variable whereby the 
user could express the cell Library List such as: 

MS_CELLLIST = $c:\geotechnical\test.cel 

MS_CELLLIST > $c:\geotechnical\spec.cel 

Select the desired cell by clicking Select and highlighting the cell. The cell is displayed in the 
box to the right. If the cell is manually entered and cannot be found in the cell library, a 
message is displayed in the cell display box indicating the cell is not found. Include the Scale 
used at creation, as the user specifies the Mapping Scale at time of drawing.  

Below the cell is element symbology parameters utilized when placing cells. This symbology 
overrides the parameters of the cell when created, whether a point or graphic cell. 
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Symbol 

 
First, select the desired Borehole Type from the list. Types cannot be manually entered, as 
the list reflects the listings from the Descriptions option within Preferences.  

Next, select the desired (symbol) Font from the list, then manually enter the Character. Due 
to the nature of symbol fonts, only one character is supported. The size of the symbol font is 
controlled by the Text Height and Text Width. These can be fixed or can vary with the scale 
settings on the Visualize Boreholes in Plan View dialog.  

Below the Character field are element symbology parameters: Level, Color, and Weight. 
Note there is no style, as symbol fonts are drawn solid.  

In order to select the Label option, the Draw Borehole in Plan View toggle in the Plan option must be 
activated. 

LABEL 

 

In order to place labels and un-ghost the dialog, the Place Plan Labels toggle in the upper left corner must 
be activated.  The dialog is divided into two sections:  Label Component and Delimiter.   
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Label Component  Six Components can be labeled for each boring.  To place a label, activate the 
toggle to the left of the Component.  In the sample above, three Components will be 
labeled:  Borehole Name, Station, and Offset.  When all offsets are set to zero, the 
Borehole Label Origin is located at the origin of the borehole cell or symbol. All 
Components are placed with the same symbology, specified in the right side of the 
dialog. Element symbology in addition to text parameters is supported. 

 

The Horizontal and Vertical Offsets are the distances in master units from the borehole cell or symbol 
origin. 

Delimiter The Delimiter group box contains parameters for spacing and placing an optional 
delimiter.  

 

To place a delimiter, activate the Place Delimiter toggle in the upper left corner of the 
group box. The Label Spacing Offset and Borehole Spacing Offset are the distances in 
master units. 
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PROFILE/CROSS SECTION 
Since the preferences are the same for Profile and Cross Section, they will only be covered once. 

 

The Profile and Cross Section options define the placement of borings onto profile/cross section drawings.  
To toggle must be turned on for the tool to draw boreholes into the corresponding view.  Once toggled on, 
the settings options will un-ghost.  

In order for the columns to be drawn, Place Column must be toggled on. 

COLUMN 

 

The Column settings include the symbology to be used to plot the columns and the column width. 
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In order for the column labels to be drawn, Place Column Labels must be toggled on. 

COLUMN LABEL 

 

Six Components can be labeled for each boring.  To place a label, activate the toggle to the left of the 
Component.  In the dialog above, four Components will be labeled:  Borehole Name, Station, Offset, and 
Elevation.  Define the label symbology which controls the text level, color, weight, size, justification and 
font for all active components.  The label is drawn as a graphic group for ease in manipulation in the plan 
view file. 

The individual material types may be represented with pattern cells when the columns are drawn into 
profile view. In order to draw the patterns, the Place Material Patterns toggle in the upper left corner must 
be active. 

MATERIAL PATTERN 

 

Material Pattern List Box Contains the list of material types with a pattern defined. 
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Material Pattern Contains the parameters to define the patterning of the material types. 

Name/Number Name of the Material type as defined under Descriptions 

Display Mode 2 options are available: 

Cell When using the cell option, manually enter the desired Cell Library or select via the File 
icon. Select the desired cell by clicking Select and highlighting the cell.  The cell is 
displayed in the box to the right.  If the cell is manually entered and cannot be found in 
the cell library, a message is displayed in the cell display box indicating the cell is not 
found.  Include the Scale used at creation, as the scale of the profile is utilized for plotting 
scale at time of drawing.  The element symbology at time of cell creation is utilized. 

Selection of the cell library should automatically attach this cell library to the active 
design file so that the Pattern Cells may be displayed in the preview box when selected 
from the cell library or the List Box. 

The Cell Library field supports the MicroStation Cell Configuration Variable whereby 
the user could express the cell Library List such as: 

o MS_CELLLIST = $c:\geotechnical\test.cel 

o MS_CELLLIST >  $c:\geotechnical\spec.cel 

Color First, select the desired Name / Number from the list. Next, select the Display Mode. 
An area pattern (however filled areas are not supported) or simply a solid fill Color can 
represent Materials. There is no user input as the color mirrors from the Descriptions 
dialog. 

 

In order to place material labels, the Place Material Labels toggle in the upper left corner must be active. 
The dialog is divided into two sections: label parameters and the Delimiter group box.  

MATERIAL LABEL 

 

The Label Parameters have five Components that the user can label for each material. To place a label, 
activate the toggle to the left of the Component. In the sample above, one Component has the label: 
Borehole Name. 
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Horizontal Offset   The distance in master units from the Material Label Origin. The Material Label 
Origin is located at the outer edge of the borehole column. 

Vertical Offset   The distance in master units from the lower edge of each material.  

Label Direction of Column  This determines whether the label is placed to the left or right of the column.  

Construct Label As   Feature supports two options: 

Text String   Each component is placed as single text string. The Justification 
applies to the text string and the first selected component's Horizontal and Vertical 
Offset is utilized. If this option is selected, the Component Delimiter field is un-ghosted 
and a character to separate the component labels is required. Default options include 
comma (,), semi-colon (;), slash (/), and space.  The Other option allows a custom 
character to used as the delimiter.  

Individual Components Each label component acts as individual text. Offsets and the same 
justification are applied to each text component on an individual basis. 

All Components are placed with the same symbology, specified in the right side of the 
dialog. Element symbology, in addition to text parameters, are supported.  

Delimiters The Delimiter group box contains parameters for spacing and placing an optional 
delimiter. If either of the delimiter options is utilized, GEOPAK also positions material 
text, so when the text height is greater than the material thickness, overlapping text does 
not occur. 

 To place a delimiter, activate the Place Delimiter toggle in the upper left corner of the 
group box.  

 

Symbology Defines the symbology to use when drawing the delimiter. 

Component Defines the Label Component used to anchor the delimiter. 

Label Spacing Offset Distance from the end of the delimiter line to the justification of the 
component label. (in master units).  

Material Spacing Offset Distance from the material label origin (edge of the column) to the 
beginning of the delimiter line (in master units). 

Delimiter Constraint Two options are supported: 

 Always Construct - If the Place Delimiter toggle is active and this option is selected, the 
delimiter line is drawn at the defined offsets and symbology in all situations. 

Conditionally Construct

The text justification is set in the upper part of the dialog, however the Component used to draw 
the delimiter is specified just below the Delimiter Symbology. Only the Components activated in 
the upper portion of the dialog are available within the Delimiter group box. Level, Color, 
Weight and Style are also defined within the group box, enabling the placement of the delimiter in 
unique symbology from the text.  

 - If the Place Delimiter toggle is active and this option is 
selected, the delimiter line is drawn at the defined offsets and symbology only 
when the text height is less than the material height. 
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 The 0 Hr. / 24 Hr. Water Elevation Label includes text for the Water Elevation and/or a cell or symbol 
representation. 

0 HR / 24 HR WATER ELEV. 

 

 

Draw As – Cell To place a cell, activate the Place Cell toggle at the top of the Cell group box.  Identify 
the desired cell library by pressing the File icon.  

If the library is stored on a central server and mounted by the users with various drive 
designations, do not include the path and drive. Simply include the cell library within 
the users' MS_CELLLIST.  

Select the desired cell by pressing the Select icon and highlighting the cell. The cell is 
displayed in the box to the right. If the cell is manually entered and cannot be found in 
the cell library, a message is displayed in the cell display box.  

Include the Scale used at creation, as the drawing scale utilizes the cross section scale. 
Horiz Offset and Vert Offset define where the cell is to be placed.   

To determine the default location of the cell, the beginning pointer is at the center of the 
borehole column at the water elevation plus ½ the column width (the edge of the 
column).  Below the cell are element symbology parameters. 

Draw As – Symbol First, select the desired (symbol) Font from the list, then manually enter the 
Character. Due to the nature of symbol fonts, only one character is supported.  

The size of the symbol font is controlled by the Text Height and Text Width. These can 
be fixed or can vary with the profile scale.   

Below the Character are element symbology parameters: Level, Color, and Weight. 
Note there is no style, as symbol fonts are drawn solid.  
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Label Direction  Defines whether the cell/symbol is drawn to the left or right of the column. 

Water Elevation Label  The Water Elevation Label section defines whether to label the Water Elevation 
and Date Measured and how to place the selected label, i.e. symbology, scale, and 
offsets.  

 

Refusal includes text for the Refusal and/or a cell or symbol representation. 

REFUSAL 

 

The user can draw the Refusal as a Cell or Symbol.  Label Direction controls the placement side of the 
column the cell and labeling.  Both the Cell/Symbol and the Label symbology along with offsets can be 
defined in the dialog.  The label text can be set to a fixed height and width or scaled. 
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The SPT (Standard Penetration Test) Count Label includes text and delimiter options.  

SPT LABEL 

 

The SPT Count Label may be placed either right or left of the column by selecting the Label Direction 
option in the upper right corner of the dialog.  The Horizontal Offset measures from the edge of the column. 
The Vertical Offset measures from the SPT Data elevation. 

There are two supported options for Count Format: 

 Total Count  An example of a Total Count is 10. 

 Individual Count  Examples of an Individual Count format is 10-3-6 or 10/3/6.  
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Exercise 7.1 Reviewing the GeoTechnical Preferences  
1. Open the MicroStation file C:\e\Projects\22807915201\roadway\RDXSRD01.dgn.   

2. Select the Model that contains the cross sections, RDXSRD. 

3. Select the GeoTech Tools from the Road toolbar.  The Borehole Navigator dialog opens. 

           

4. From Borehole Navigator, select File > Preferences. 

 

5. If necessary, on the Preference dialog, select File > Open and set the preference file to 
FDOT2008\GEOPAK\bin\geotech2008.gtp.    

6. Review the preference settings for Plan and Cross Sections. 

7. Close the Preferences dialog box. 

  



BOREHOLE NAVIGATOR - GeoTechnical Preferences ____________________________________________________ Chapter 7 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 7-33 

Exercise 7.2 Creating and Populating the GeoTechnical Database  
1. From Borehole Navigator, select File > New to create a borehole database. 

2. Create a file called SR817.gtd. 

 

3. After accepting the file name, a prompt will display for the Job number and Ground Tin associated 
with this project.  After selecting the files, click OK to proceed. 

 

4. Select File > Import > CSV > Borehole… to import the borehole location data.   

5. Select the file Boerholetpk.brh.  This file contains the borehole names and location information as 
well as the water elevation information.   

 

Note No material information has been imported yet.  The next step will accomplish this. 
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6. Select File > Import > CSV > Material… to import the borehole location data.   

7. Select the file material.mtl.  This file contains the borehole 
names and strata material information. 

8. Click the arrow at the bottom right corner of the Borehole 
Navigator dialog to view the Material Information for each 
borehole. 

 

 

 

 

 

 

 

 

9. Click the arrow at the bottom right corner of the Borehole 
Navigator dialog to view the Material Information for each 
borehole.  As each borehole is selected, the material information 
in the Material Information window will change. 

 

 

 

 

 

 

 

 

 

 

 

10.  Navigate through each station.  Below the Borehole Information window are various pieces of data 
pertaining to each boring.  The alignment (CHAIN) where the boring was referenced, the Type of 
boring, the Ground Elevation, a Description and the Water Table Elevation. 

11. Click File > Save to update the SR817.gtd file. 

 

  



BOREHOLE NAVIGATOR - GeoTechnical Preferences ____________________________________________________ Chapter 7 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 7-35 

Exercise 7.3 Plotting Boreholes in Cross Section  
1. Select the Visualize Boreholes in Cross Section View tool.  

 

2. Set the Chain name in the upper portion of the dialog to populate the display window with our 
borehole data. 

 

3. Set the Projection Data to the following settings : 

• Project onto Nearest XS 

• Max. Projection Distance = 50 

• Project at Borehole Ground Elev 

 

4. In the final setup step, defining the symbology for the existing ground in the drawing, Zoom into a 
cross section to identify the ground line easily. 

5. Click Define Existing Ground icon.  
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6. In Existing Ground Line, click Reset.  This will clear out any erroneous values.  

 

7. Toggle on the symbology toggles shown above.  Click Match and Data Point on the line in the 
drawing representing the existing ground.  

8. Close Existing Ground Line when finished. 

9. In Visualize Boreholes in Cross Section View, select all of the boreholes in the list by single 
clicking on a borehole, then select CTRL-A on the keyboard to select all boreholes. 

 

10. Click Apply. 

11. In the case of boreholes separated by very small distances, some manual adjustments may be necessary 
in order to view them properly. 

  



EARTHWORK - Objectives ___________________________________________________________________________ Chapter 7 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 8-37 

 

 

8 EARTHWORK 

OBJECTIVES 
• Overview Earthwork Process 
• Run Quantities for Earthwork 
• Create Earthwork Output File 

GENERAL EARTHWORK CONSIDERATIONS 
Chapter 3 of the FDOT Plans Preparation Manual (PPM) contains a detailed discussion of earthwork 
calculation methodology.  Below are two key items to note from this chapter. 

• Pay for all Cut Operations as Regular Excavation (CY) or Regular Excavation (Lump Sum). Do not 
differentiate between suitable and unsuitable. 

• Pay for all Material Excavated below the finished grading template as Subsoil Excavation. Do not 
differentiate between suitable and unsuitable. 

In general, earthwork on a highway project consists of:  

Embankment  Compacted fill material needed to construct the roadway, excluding the base and 
pavement portions of the roadway and shoulders.  

Regular Excavation  Excavation necessary for the construction of the roadway, ditches, ponds, 
channel changes, etc.  

Subsoil Excavation  Excavation, removal and disposal of any material that is unsuitable in its 
original position and that is excavated below the finished grading template.  

The most important roadway operation involving earthwork is constructing the roadbed. The roadbed is 
constructed by excavating soil from cut sections and placing soil as embankments in fill sections. In cut 
sections, the roadbed is built below the original ground - the original ground is excavated to the elevation of 
the proposed roadbed. In fill sections, the roadbed is built above the original ground - the earth fill is on an 
embankment.  

The finished grading template is defined as the finished shoulder and slope lines and bottom of the 
completed base or rigid pavement for most pavements. The Department occasionally uses stabilized bases 
and sand bituminous road mixes. For these, consider the finished grading template as the top of the finished 
base, shoulders and slopes.1 

 
1 From Section 3.1.1 of the FDOT Plans Preparation Manual 
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WORKFLOW 
GEOPAK computes earthwork average End Area Method by reading and interpreting the MicroStation 
design files containing proposed and existing ground cross sections. This approach affords you maximum 
flexibility in that it is irrelevant whether the cross section elements were created entirely by GEOPAK or 
were created or modified using generic MicroStation commands. GEOPAK can compute earthwork 
volumes from any reasonable graphical representation of a cross section. 

In order to compute earthwork, GEOPAK requires: 

• MicroStation cross section design file 

• GEOPAK coordinate geometry database file (.gpk) if the baseline used to generate the cross 
sections has station equations 

These graphical cross sections can be very simple to compute only cut/fill quantities or very complex cross 
sections including several types of unsuitable or removable materials and several fill material types. There 
is no limit to the number of existing or proposed soil types.  

GEOPAK is extremely flexible when computing earthwork, utilizing several types of excavation and fill, 
many functional classifications, numerous material types, (known as soil types), and different 
shrink/expansion factors. 

ACCESSING EARTHWORK 
• From Road Project click the Earthwork icon . 

 

XS DGN FILE 

 

XS DGN File MicroStation 2D file containing cross sections (and XS Cell) to be utilized for 
earthwork computations. This field is filled in automatically from the Working 
Alignment Definition. 

Tolerance Specify the Tolerance, if different from the default. GEOPAK utilizes the 
tolerance as the radius of a circle at the endpoint of each element. If the 
candidate intersection element passes within the circle, the software will 
consider the lines intersecting. GEOPAK supports vertical ties at the outside 
limits of construction as well as any interior locations. 
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Vertical Search 
Distance 

The earthwork component of GEOPAK calculates earthwork quantities from 
the MicroStation elements present for each cross section, independent of 
whether drawn by GEOPAK or drawn with generic MicroStation commands. 
For each cross section, GEOPAK searches for candidate cross section elements 
within a certain vertical range from the cross section cell. In order to ensure that 
each element associated with a given cross section is found, GEOPAK searches 
for and analyzes elements vertically within 250 master units above and below 
the horizontal portion of the cross section cell. Therefore, should any cross 
section include terrain relief in excess of 250 feet, the Vertical Search Distance 
must be utilized. As a rule, the vertical search distance is usually 3/4 of the user-
defined Distance Between Cross section Cells. 

Baseline Baseline utilized to create the cross section cells. This is filled in automatically 
from the Working Alignment Definition. 

Beg Station Unless filled in by the Working Alignment Definition this defaults to the lowest 
numbered station in the file. However, this can be changed if only a selected 
station range for computation is desired. Note regions must be included if 
station equations are present in the Baseline. 

End Station Unless filled in by the Working Alignment Definition this defaults to the 
highest numbered station in the file. However, this can be changed if only a 
selected station range for computation is desired. Note that regions must be 
included if station equations are present in the Baseline. 
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SOIL TYPES 
Since the earthwork calculations are based on the graphical elements of the cross sections, the user must 
specify what search criteria to use for specific classes of earthwork (e.g. what element symbology makes up 
existing ground, what element symbology comprises the proposed finish grade, etc.). This is done in the 
section under Soil Types.  

 

Class Several classes of materials are supported. All classes (with the exception of 
Excavation Limits) require a soil type and search criteria. However, as each class 
is selected, the dialog will change to allow different options.  Below are details of 
each class: 
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Existing 
Ground 

Existing ground must be specified. Its associated material type determines the soil 
type underneath the lowest substrata line. The existing ground must be contiguous 
(i.e. no gaps) between the proposed tie down points using these levels. Note these 
would be the existing ground levels used for producing slope stakes or construction 
limits and therefore, do not include any subsurface elements. 

Use Working Alignment Definition - This check box is available with the Existing 
Ground class. When this option is enabled the Search Criteria defined for Existing 
Ground in the Working Alignment will be used. 

 

 

Proposed 
Finish 
Grade 

The proposed finish grade includes the top of proposed pavement, curb and gutter, 
top of proposed topsoil, top of proposed ditches, etc. The software must be able to 
draw contiguously from the centerline to the touchdown point using these levels. 

Use Working Alignment Definition - Note that this check box is available with the 
Proposed Finish Grade class. When this option is enabled the Search Criteria defined 
for the Proposed Finish Grade in the Working Alignment will be used. 
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Existing Suitable "Existing suitable" removes only what is needed to build the proposed design. It does 
not affect whether material is re-used. 

 

 

Existing 
Unsuitable 

If the Excavation Limits are present, then GEOPAK responds to the "existing 
unsuitable" classification by removing the existing pavement material between the 
Excavation Limits, irrespective of whether the section is in cut or fill. 

If the Excavation Limits are not present, then the unsuitable material is only 
removed when it would fall within the confines of a common excavation.  
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Proposed 
Undercut 

Proposed undercuts are used to define any proposed component which is not part of 
the finished grade. This includes undercuts, proposed topsoil placement, or aggregate 
quantities. Although the proposed undercut is used to define undercuts or subcuts, it is 
important to remember that the soil type is not the material being removed, but what 
the area will be backfilled with. The material being removed is computed in the 
default excavation unless it is an existing suitable or unsuitable material. 

Common Excavation Only - In some proposed undercuts, it is desirable to include 
them as common excavation rather than subgrade excavation. To override the default 
computation methods, select this check box. 

Do Not Include In Mass Ordinate  - The mass ordinate is a running summary of your 
cut and fill balance. In some cases, it is desirable to omit some materials from the 
mass ordinate. The easiest method to accomplish this for Proposed Undercuts is to 
select this check box. 

 

 

Excavation 
Limit 

Excavation limits are short lines drawn onto cross sections to tell the software where 
to stop removing existing unsuitable material. Excavation limits are required 
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whenever existing unsuitable classifications are utilized and the removal area is not a 
closed area completely within a cut area. They have no direct correlation to proposed 
features, except that the removals normally end at the outside edge of proposed 
construction. 

There are certain rules the user must follow when placing Excavation Limits. 

They must be placed in pairs. 

They must be lines. No other element types are supported. 

They must extend to (or better yet) intersect the material to be removed and existing 
ground forming a closed area. The endpoint should not be within an area where 
earthwork quantities are needed. Extend those points well beyond any cross section 
elements. 

Multiple excavation limits are also supported. This is extremely useful in projects with 
multiple roadways where existing materials are not removed between the roadways. 

Soil Type At its most basic, this field is just a name that that user gives to the material. This 
name can be anything, as long as it doesn’t contain any spaces. For example, for the 
class Existing Ground the user could name the soil type “Dirt” or “Earth”. 

The soil type specified with the existing ground is important as it is the default 
excavation material. Similarly, the soil type specified with the proposed finish grade 
is important as it is the default fill material. 

In addition to specifying the default cut and fill materials, the soil types also play an 
important role in identifying what materials can be re-used and where they can be re-
used. If the soil types for any two functional classifications are identical, GEOPAK 
will re-use the excavation material in places where embankment is required. 

Search 
Criteria 

For each class and soil type specified, the user must specify the graphic symbology 
of the cross sections elements that will comprise that class and type. Any 
combination of graphical symbology (e.g. color, weight, level, etc.) can be used to 
distinguish these elements. These symbologies can be keyed in or selected from a list 
using the icons. 

Match Used to determine the Search Criteria by selecting elements from the design file. 

Display Highlights all elements matching the Search Criteria. Match is used to visually verify 
that the intended elements are defined in the Search Criteria. 

Reset Clears all definitions in Search Criteria. 

Multiplication 
Factors 

 

Roadway 
Excavation 

Swell/Shrinkage factor for any Roadway Excavation quantities. 

Subsoil 
Excavation 

Swell/Shrinkage factor for any excavation done below the bed of the roadway (e.g. 
unsuitable material extraction). 

Fill Swell/Shrinkage factor for fill quantities. 

Add Adds the soil type to the list box. 

Delete Deletes the selected soil type from the list box. 
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Modify Used to make changes to the selected soil type in the list box. 

EARTHWORK SHAPES 

 

Draw Earthwork 
Shapes 

When this check box is selected, the earthwork shapes are drawn with color 
fill attributes. When the Fill check box is selected on the View Attributes 
dialog, color filled complex shapes are displayed. 

Stratify Shape Color Variations in color between various cut and fill options are achieved with this 
check box selected. Utilizing the order within the Soils Type dialog, 
GEOPAK assigns (in ascending numerical order) each material type two 
colors, one for cut and one for fill. Color assignments initialize at zero. 

OUTPUT FORMAT 

 

Accumulate 
Adjusted Volume 
Column 

When selected, an additional column is added to the earthwork report, 
where the adjusted volume of each excavation and fill for each material 
is cumulatively totaled. 

Accumulate 
Unadjusted Volume 
Column 

When selected, an additional column is added to the earthwork report, 
where the unadjusted volume of each excavation and fill for each 
material is cumulatively totaled. 

Calculate Only 
Between Excavation 
Limits 

In this case, excavation limits are used to demarcate earthwork 
processing. This is extremely useful in projects where earthwork is 
staged or separate quantities for each roadway in a multiple alignment 
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are necessary. When the check box is selected, ALL earthwork 
calculations are limited to within user-defined excavation limits. 

End Area Decimal 
Places 

In normal processing, the end areas are rounded to two decimal places. 
However, the user has the option to set the decimal places to between 0 
and 4. 

Formats Three classifications of excavation volumes are listed on standard 
GEOPAK earthwork outputs: Common, Subgrade, and Subsoil. 

Common      
Excavation 

Excavation volumes that are not backfilled with an earthwork material. 
This includes the excavation required for cut sections as well as for 
pavement thickness, shoulder thickness, etc. 

Subgrade     
Excavation 

Excavation volumes that are backfilled with an earthwork material. 

Subsoil        
Excavation 

Excavation required to remove unsuitable material either 1) down to the 
bottom of the proposed template or 2) down to the bottom of the 
unsuitable material layer in cases where excavation limits are defined. 

Formats (conti) In certain design instances, the designer does not require these distinctions. 
Hence, the Output Format dialog can be utilized to combine various 
quantities as follows: 

Common Exc, Subgrade Exc, Subsoil Exc, and Fill 
Excavation (Common and Subgrade), Subsoil Exc, and Fill 
Excavation (Common and Subsoil), Subgrade Exc, and Fill 
Excavation (Subgrade and Subsoil), Common Exc, and Fill 
Excavation (all types) and Fill 

ADD/SUB VOL 
Volume adjustments can be specified at project locations where material surpluses or deficits are 
encountered outside that which can be described via the cross sections. 

 

Process 
Add/Subtract 
Volumes 

If this check box is enabled, the information in this portion of the dialog will be 
processed when the earthwork is run. 

Soil Type This pulldown option will populate automatically with the names of the materials 



Chapter 9 __________________________________________________________________ EARTHWORK - Accessing Earthwork 

8-12  ©2011 FDOT FDOT GEOPAK for Roadway Designers - Advanced  

defined earlier in the dialog under Soil Types. 

Station The station indicates the location at which volumes are added to or subtracted 
from the mass ordinates and does not necessarily have to be at a cross section 
station. However, it must be within the specified station range. 

Earthwork 
Operation 

Here the standard 4 options: Common Exc., Subgrade Exc., Subsoil Exc. and 
Fill. 

Volume This is the volume that is to be added or subtracted. Subtract volumes are 
included with a minus (-) sign in front of the quantity. The volume adjustment 
header and subsequent syntax must be repeated for each add/subtract location, 
soil type or volume quantity. For example, if there is a volume adjustment to 
the common excavation and fill volumes at a particular station, two volume 
adjustments are needed 

Add Add the Station and Volume to the list box. 

Delete Delete the selected Station and Volume from the list box. 

Modify Modify the selected Station and Volume in the list box. 

CENTROID ADJUSTMENT 
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Centroid 
Adjustment 

Earthwork volumes are calculated by averaging end areas and then multiplying 
these averaged areas by the distance between two successive cross sections as 
measured along the baseline.  The generally accepted formula used for this 
calculation is: 







 +

=
2

21 AA
LV  

If the bulk of the cross section areas are located predominantly to either the left or 
the right of the baseline, an error occurs in the volume calculations for all non-
tangential portions of the baseline. This error can be negligible or substantial 
depending on the degree of baseline curvature as well as the degree to which cross 
section areas are offset about the baseline. 

These types of errors can be optionally accounted for by enabling the Centroid 
Adjustment check box. The option invokes a procedure that adjusts volumes based 
upon the lateral offset between the centroid of cross section end areas and the 
baseline. 

Centroid adjustment is used in FDOT for cross sections on a curve to take into 
consideration the distance between the two cross sections on a curve.  As noted in 
section 3.4.3.1 of the FDOT PPM, one technique that is encouraged to aid in 
computing accurate earthwork quantities is to “Reduce the interval between cross 
sections to 25 feet or less on ramps or sharp turning roadways, or determine and 
use the centroid of the section as the length for computing volumes.” 

If this option is enabled, the resulting log file will contain a section entitled 
CENTROID SUMMARY.  An example is shown below.  The Adjusted length in 
the table below is used in lieu of the difference in the station values for ‘L’ in the 
equation mentioned previously. 
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                        C E N T R O I D      S U M M A R Y 
      Station        Centroid        Centroid        Unadjusted     Adjusted 
                     Elevation        Offset           Length        Length 
                      ( ft )          ( ft )           ( ft )        ( ft ) 
    ------------   ------------    ------------     ------------  ------------ 
    325+00.00           810.37          -19.23 
                                                         100.00         100.00 
    326+00.00           811.40          -18.79 
                                                         100.00         100.00 
    327+00.00           804.94           31.24 
                                                         100.00         100.00 
    328+00.00           805.32           38.18 
                                                         100.00         100.00 
    329+00.00           807.07           39.32 
                                                         100.00         100.00 
    330+00.00           808.00           36.45 
                                                         100.00         100.00 
    331+00.00           812.96           19.00 
                                                         100.00         100.00 
    332+00.00           814.71           15.55 
                                                         100.00         100.00 
    333+00.00           816.17            2.93 
                                                         100.00          99.88 
    334+00.00           816.76           -0.06 
                                                         100.00         101.19 
    335+00.00           818.28          -27.20 
                                                         100.00         101.79 
    336+00.00           818.57          -13.83 
                                                         100.00         102.34 
    337+00.00           815.96          -39.76 
                                                         100.00         102.70 
    338+00.00           811.60          -22.18 
                                                         100.00         100.50 
    339+00.00           810.03           -9.83 
                                                         100.00         100.00 
    340+00.00           808.47          -17.22 

SKIP AREAS 
Skip Areas enable the user to specify an area in which to not calculate earthwork volumes. Skip Areas will 
stop the earthwork calculations at the last cross section before the Skip Area station range, then proceed to 
the first section past the Skip Area station range and begin the calculation anew.  This results in separate 
quantities before and after the Skip Area.  

This option is used typically by FDOT for driveways. 
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Process Skip 
Areas 

If this check box is enabled, the information in this portion of the dialog will be 
processed when the earthwork is run. 

Begin 
Station 

Beginning station to be skipped. 

End Station Ending station to be skipped. 

Add Add the Begin and End Station to the list box. 

Delete Delete the selected Begin and End Station from the list box. 

Modify Modify the selected Begin and End Station in the list box. 

IGNORE AREAS 
Ignore Areas enable the user to specify an area in which to not calculate earthwork volumes, but treats the 
areas differently than Skip Area.  Ignore Areas treats the sections within the Ignore Area station range as 
though they do not exist.  Earthwork calculations continue through the Ignore Area using the section before 
the Ignore Area and the section after the Ignore Area and the length in between to get the End Area 
calculation and resulting volume.  This results in only one quantity being calculated. 

This option is used typically by FDOT for bridges at the toe slope stations. 

 

Process Ignore 
Areas 

If this check box is enabled, the information in this portion of the dialog will be 
processed when the earthwork is run. 

Begin Station Beginning station to be ignored. 

End Station Ending station to be ignored. 

Add Add the Begin and End Station to the list box. 

Delete Delete the selected Begin and End Station from the list box. 

Modify Modify the selected Begin and End Station in the list box. 
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SHEET QUANTITY 
Earthwork quantities can be written directly onto cross sections sheets. A two step process is required. 
First, an ASCII text file is produced when calculating earthwork volumes. This ASCII text file contains the 
area and/or volume quantities that are to be written onto the cross section sheets. Second, the GEOPAK 
sheet layout utility reads this ASCII file and places the appropriate text onto the cross section sheets. 

 

Write Sheet 
Quantities File 

If this check box is enabled, the information in this portion of the dialog will be 
processed when the earthwork is run and the sheet quantities file will be created. If 
the check box is cleared then any information in this area will be ignored. 

ASCII File The name of the sheet quantities ASCII file that will be created. This name can 
either be keyed in or selected using the Select icon. 

Decimal Places For each column, the number of decimal places must be specified. The options are 
0-6. 

 

Column Allows selection of which column (1-9) the earthwork information will be placed 
in. For each column, additional information detailed below must be entered. 
There may be multiple entries in the list box for a column. 

Soil Type: The selected material type for which quantities are to be calculated. Only those 
Soil Types defined in the Soils Types sections will be available for selection. 

Earthwork 
Operation: 

The second component must be either one of the following: Common 
Excavation, Subgrade excavation, Subsoil Excavation or Fill. 

Quantity Type: This represents the actual quantity. Options include End Area, Adjusted 
Volumes, Unadjusted Volumes and Mass Ordinate. 

+/- If several quantities are to be added, the Plus operand is default. The Plus is also 
utilized for a single quantity entry. However, it must be changed to Minus if the 
quantity is to be subtracted. 

Add Add the column information to the list box. 

Delete Delete the selected column information from the list box. 

Modify Modify the selected column information in the list box. 
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Exercise 8.1 Earthwork Quantities 
In this exercise you will process our basic cut and fill earthwork for our proposed cross sections. 

1. Double-click on the self-extracting zip file C:\Chapter8_Exercises.exe and click the Unzip icon at the 
prompt. 

2. Open the design file C:/e/Projects/228079115201/roadway/RDXSRD01.dgn.  

3. Access Project Manager. 

4. From Road Project, click the Earthwork icon.  

 

5. Create a new run BL817 and access the Earthwork dialog. 

 

6. Select XS DGN File. All of the information should fill in automatically by the Working Alignment. 
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7. Select Soil Types. 

 

8. Leave the Class set to Existing Ground. Key-in Earth for the Soil Type. 

 

9. Enable the Use Working Alignment check box. 
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10. Click the Add icon to add Existing Ground to the Soil Type Items list box as shown. 

 

11. Change the class to Proposed Finish Grade, uncheck the Use Working Alignment Definition 
option, and check only the Lv Names option as shown. 
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12. Click the Select Levels icon to the right of the Lv Names field. 

 

13. In the Level Name Search Filter dialog that appears, select the following level names: 

• AsphaltMilling_px 

• Base_px 

• CandG_px 

• CandGBase_px 

• Driveway_px 

• DrivewayBase_px 

• Overbuild1_px 

• Overbuild_px 

• ShldrUnpaved_px 

• Sidewalk_px 

• SidewalkBase_px 

• Slopes_px 

• TrafSeparator_px 

• TrafSeparatorBase_px 

• XSBaseTop_px 

• XSGrdLine_px 

14. Click OK. 

15. Click the Add icon to add Proposed Finish Grade to the Soil Type Items list box.   
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16. Select Earthwork Shapes. 

 

17. The use of Draw Earthwork Shapes is optional. If it is desired to see the shapes, place a check mark 
appropriately. When creating the cross section sheets, the shapes come also, so turn Fill off under View 
Attributes. 

18. Enable the check box to Draw Earthwork Shapes. 

19. Enable the check box to Stratify Shape Color.      

 

20. Access the Set Feature dialog and set the symbology for the Earthwork Shapes as shown in the 
following figure. 

 

21. Click OK to close the Set Feature dialog. 
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22. Select Output Format. 

 

23. Set the End Area Decimal Places to 2. 

 

24. Select Centroid Adjustment and enable the check box.  
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25. Select Sheet Quantity. 

 

26. Enable the check box to Write Sheet Quantities File.     

27. Key-in earth.txt in the ASCII File field.     

 

28. Click Add to add the Column 1 earthwork to the list box.   

 

29. Leave the Column set to 1 but change the EW Operation to Subgrade Exc. 
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30. Click Add to add the Subgrade Exc to the existing Column 1 earthwork. 

 

31. Change the EW Operation to Subsoil Exc.  

   

32. Click Add to add the Subsoil Exc to the existing Column 1 earthwork. 

 

33. Change the Column to 2. 

34. Set the Earthwork Operation to Common Exc. 

35. Set the Quantity Type to Unadjusted Volumes. 
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36. Click Add to add the Column 2 earthwork to the list box.  

 

37. Leave the Column set to 2 and change the Earthwork Operation to Subgrade Exc. 

38. Click Add to add the Subgrade Exc to the existing Column 2 earthworks. 

 

39. Leave the Column set to 2 and change the Earthwork Operation to Subsoil Exc. 

40. Click Add to add the Subsoil Exc to the existing Column 2 Earthworks. 

 

41. Change Column to 3. 

42. Change the EW Operation to Fill. 
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43. Click Add to add the Column 3 earthwork to the list box.     

 

44. Change the Column to 4. 

45. Set the EW Operation to Fill. 

46. Click Add to add the Column 4 earthworks to the list box.      

 

47. Select Files > Save Settings. 

48. Select Files > Run. 

49. Set the option To Log File and key-in a log file name of earth.log. 

 

50. Click Apply to process the earthwork. 

51. When processing is complete, click Exit.     

 

52. Close the Earthwork dialog. When prompted to Save Settings click Yes 

  



EARTHWORK - Accessing Earthworkon Reports _________________________________________________________ Chapter 9 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 8-27 

53. Review the file  \roadway\ earth.log. 

 

54. Review the file \roadway\earth.txt. 
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Exercise 8.2  Unsuitable Material with no Excavation Limits 
In this exercise, the user will add unsuitable material to our earthwork calculations. 

1. Re-enter the Earthwork dialog.   

2. Select Soil Types. 

 

3. Change the Class to Existing Unsuitable. 

4. Key-in a Soil Type name of Existing Base. 
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5. Set the Search Criteria as shown in the image below and click Add to add the Existing Unsuitable 
material to the list box. 

 

6. Leave the Class set to Existing Unsuitable and key-in a Soil Type name of Existing_Concrete. 

7. Set the Search Criteria as shown in the image below and click Add to add the 2nd Existing 
Unsuitable material to the list box. 

 

8. Select Files > Save Settings. 

9. From MicroStation, select Edit > Select All and then delete the shapes created in the previous 
earthwork run. 
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10. Select Files > Run to process the earthwork. 

 

11. When reviewing your earthwork notice that the existing unsuitable materials are now being calculated 
in addition to the standard cut and fill (earth). 

12. Close the Earthwork dialog. When prompted to Save Settings click Yes. 

13. Review the cross sections.  Take note of the earthwork shapes for the unsuitable material. Notice that 
not ALL of the existing unsuitable material is being extracted.  

 

Exercise 8.3 Unsuitable Material with Excavation Limits 
In this exercise, the user will add excavation limits which will affect our unsuitable material quantities. 

1. Re-enter the Earthwork dialog using the previously created run. 

2. Select Soil Types. 

3. Change the Class to Excavation Limit. 

4. Set the Search Criteria as shown in the image below and click Add to add the Excavation Limit to 
the list box. 

 

5. Select File > Save Settings. 

6. From MicroStation, select Edit > Select All and then delete the shapes created in the previous 
earthwork run. 

7. Select Files > Run to process the earthwork. 
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8. When complete, close the Earthwork dialog. When prompted to Save Settings click Yes. 

9. Review the cross sections.  Take note of the earthwork shapes for the unsuitable material. Notice that 
ALL of the existing unsuitable material is being extracted between the Excavation Limits. 

Exercise 8.4 Proposed Undercut  
In this exercise, the user will calculate the overbuild on the job using proposed undercut. 

1. Re-enter the Earthwork dialog. 

2. Select Soil Types. 

3. Change the Class to Proposed Undercut. 

4. Key-in a Soil Type name of Overbuild. 

5. Set the Search Criteria as shown in the image below and click Add to add the Proposed Undercut 
material to the list box. 

 

6. Select File > Save Settings. 

7. From MicroStation, select Edit > Select All and then delete the shapes created in the previous 
earthwork run. 

8. Select Files > Run to process the earthwork. 

 

9. When complete, close the Earthwork dialog. When prompted to Save Settings click Yes. 

10. Review the cross sections.  Take note of the additional overbuild quantities that have been calculated. 

11. Exit MicroStation. 
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9 CROSS SECTION SHEETS 

OBJECTIVES 
• Overview of Cross Section Sheet Layout 

• Exercise  to Layout Sheets with Quantities 

WORKFLOW 
The GEOPAK sheet layout component provides an automated tool to draw cross section data in a format 
suitable for producing hard-copy cross section construction drawings. The input includes specifying sheet 
layout parameters as well as the graphic design file where the cross sections were originally created by 
GEOPAK. The output is a MicroStation design file which references the cross sections and labels such as 
baseline, station, offsets and elevation are added. There are several advantages to using sheet input: 

• The cross sections will be sorted in numeric order for the specified baseline. In addition, a 
station range can be specified. 

• The cross sections will be spaced closer together. 

• The cross sections are placed into user specified "sheet format."  

• As the cross sections are referenced into sheets, changes in cross sections are immediately 
reflected in sheets. 

• Sheets need to be generated only once, unless more sections are added to the project or 
elements are added which go outside the referenced boundaries. 

As discussed in previous chapters, the cross section design file is split into 4 models. The sheet layout uses 
one of these 4 models (rdxsrd_shg) 

ACCESSING CROSS SECTION SHEET COMPOSITION 
• From MicroStation, select Applications > ROAD > Cross Sections > Cross Section Sheet 

Composition --or – 

• From the Road toolbox, click the Cross Section Sheet 
Composition icon --or – 

 

 

 

 

• From the Road Project dialog, click the Cross Section 
Sheets icon. 
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CROSS SECTION SHEET COMPOSITION 

 

FILE MENU 

 

Sheet Library The parameters for each sheet are defined in a Sheet Library. In order to layout or clip 
sheets, a Sheet Library must be attached to the current session. The name of the currently 
attached Sheet Library is shown in the title bar.  Sheet Libraries have an extension of xssl. 
An unlimited number of different sheets can be stored within one library. When beginning 
the sheet process, select the desired sheet layout from the attached library, which loads the 
associated parameters. 

New Create a new Sheet Library. 

Attach Attaches a sheet library. 

Save Saves the dialog settings into the currently attached Sheet Library. 

Save As Saves the dialog settings into a new Sheet Library name. 

Sheet The Sheet Name is used to populate the Active Cross Section Sheet field in the main 
dialog. 
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New Create a new sheet within the currently attached Sheet Library. 

Delete   Delete the currently selected sheet from the Sheet Library. 

Update If changes have been made to the current active sheet, this option will store the changes in 
the library. Also, you must use the option Sheet>Update before choosing another sheet in 
the library or the changes made will be lost.  This is important when making changes to 
multiple sheets in a library.   

Load V7 Input 
File 

To utilize the sheet input file from previous versions, create a New Sheet, then select Load 
V7 file and select the old sheet input file.  The fields supported in V7 are populated in the 
new sheet. 

Save Settings Saves the dialog settings. 

 When running this application from Project Manager and using the Save Settings option, 
only 4 of the dialog options are saved to the Project Manager run: 

XS DGN File 

Sheet DGN File 

Detach Toggle 

Earthwork File 

To save all of your Sheet Settings, do the following: 

Copy the Sheet Library local 

Attach the local copy 

Select File > Sheet > Update 

Select File > Sheet Library > Save 

Layout Sheets Commence processing the sheet layouts. 

Exit Exit the Cross Section Sheet application. 

XS DGN FILE 
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XS DGN File Location of original cross sections, which must include the GEOPAK XS cell.  

XS Baseline When the XS DGN file is selected, the file is searched and the baseline names of 
any XS Cells found are listed. 

Begin Station Defaults to the lowest stationed cross section associated with the selected baseline 
and can be utilized if the entire file is to be processed. If a partial processing is 
desired, simply type in the desired station. 

End Station Defaults to the highest stationed cross section associated with the selected 
baseline and can be utilized if the entire file is to be processed. If a partial 
processing is desired, simply type in the desired station. 

SHEET DGN FILE 

 

Sheet DGN 
File 

Name of the design file where GEOPAK draws the cross section sheet borders, labels, 
etc. onto sheets. Note that GEOPAK does not create this file. It must be done prior to 
processing. In addition, the working units of the Sheet design file should match the 
cross section design file. 

Horizontal 
Scale 

Horizontal Scale that the cross sections are drawn. This should be the same as the 
horizontal scale with which the cross sections were originally cut. 

Vertical Scale Vertical Scale that the cross sections are drawn. This should be the same as the vertical 
scale with which the cross sections were originally cut. 

Note If a different scale ratio is used, the elevations will be incorrectly labeled. 

Sheet 
Placement 
Point 

The sheet layout software accepts the user specification of the coordinate location in 
the sheet layout design file where the cross section data is to be drawn. These 
coordinates can either be keyed in or selected using the DP icon. 

Lower Left X (mu)   X Coordinate location of the sheet placement point. 

Lower Left Y (mu)   Y Coordinate location of the sheet placement point. 
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Detach 
Existing Sheets 
before 
Processing 

When this check box is enabled, any reference files that were attached in a previous 
run are detached and replaced with new references.  Also any elements from a 
previous run are deleted and replaced.  When this is check box is OFF, any existing 
reference files and elements from a previous run are not removed.  This will allow the 
user to add cross section sheets with different station ranges. 

Attachment There are 3 options that determine how the sheets will be placed in the Sheet DGN 
File 

All Sheets in 
Active Model 

All sheets are placed in the active model. 

One Sheet Per 
Model 

Each sheet is placed in its own model.  The models will be named XS_SHEET_sheet 
number.  Nothing is placed in the active model. This option was developed for IPLOT 
users. 

One Sheet Per 
Model  / 

Display All 

Each sheet is placed in its own model.  The models will be named XS_SHEET_sheet 
number. All sheets are attached to the active model as references. This option was 
developed for IPLOT users. 
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SHEET DIMENSIONS / CELL 

 

Sheet Dimensions  

Width Width of each sheet in plotting units.   

Height Height of each sheet in plotting units. 

Place Sheet Cell To place a sheet cell, select the check box.  

Library Name of Cell Library which contains the sheet cell.   

Name Sheet cell name. 

Scale Scale to be applied to the sheet cell.   

Place as              
Shared Cell 

Check box on if sheet cell is to be placed as a shared cell.  

FDOT does not recommend using this option. 

Sheet Offset from 
Cell Origin  

 

X Offset Horizontal offset from the cell origin to the sheet corner.   

Y Offset Vertical offset from the cell origin to the sheet corner. 

Sheet Cell Placement Determines how the sheet cells will be placed.  

Place Sheet Cell             
in XS Sheet File  

Sheet cell is placed in the sheet file, once for each sheet. 

Place Sheet Cell Once      
in a Reference File 

The sheet cell is placed in the specified reference file once, and then 
referenced for each sheet. Specify the Reference File name where the cell is 
to be drawn. 
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XS SEARCH CRITERIA 

 

XS Search Criteria specified is used to determine the size of the cross section vertical clipping area. If there 
are elements on levels (i.e. the cross section cell) that you do not want displayed on the sheets, then those 
levels need to be turned off prior to the sheeting process. 

XS Element 
Search Criteria 

Any combination of graphical symbology can be selected in order to specify the 
XS elements to be searched for.    

Match To commence matching, select the desired search parameter check box, click 
Match, then select the desired element. All elements with matching search criteria 
are also highlighted. 

Display When search parameters have been set and Display is clicked, all elements 
matching the specified search criteria are displayed. 

Reset To clear all Search parameter dialogs, click Reset. Note this does not clear each 
check box, it simply clears the specified levels, weights, etc. 

Vertical Range Occasionally during the design process, the existing ground line must be extended 
to complete the design, or the proposed elements themselves are outside the 
GEOPAK XS cell. If the relief of the cross section is large, the software may not 
recognize the extreme limits of the design. The sheet layout procedure allows for 
the limits of the cell to be moved up in order to recognize all the elements.  

Lower Limit Distance below the horizontal datum line of the XS Cell. The default value (in 
master units, i.e. feet or meters) is 250.   

Upper Limit Distance above the horizontal datum line of the XS Cell. The default value (in 
master units, i.e. feet or meters) is 250. 

Horizontal If shifting the Baseline X Offset to the left or right, there may be some elements 
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Search outside the specified sheet width that needs to be included in the search.  The 
Horizontal Search option tells to software to look outside the limits of the sheet 
width, to the specified distances, and include any elements that are in the search 
criteria.   

Left Offset Offset to the left of the vertical datum line of the XS Cell. This offset should be 
entered with a minus (-). 

Right Offset Offset to the right of the vertical datum line of the XS Cell.  

SHEET STACK ORIENTATION 

 

Sheet Stack 
Orientation 

Individual cross section sheets can be stacked either vertically or horizontally. The 
sheet stack options dictate the selection.  

Vertical Stack the sheets vertically. 

Horizontal Stack the sheets horizontally. 

Horizontal 
Spacing 

Horizontal distance between successive sheets from right edge to left edge.   

Vertical Spacing Vertical distance between successive sheets from top to bottom. 

Number of 
Sheets per 
Column 

By specifying the maximum number of sheets in the stack, the software will place 
the first row or column with the specified number, then the next sheet will be 
above the first sheet and continue creating a second row, in the case of horizontal 
stacking. In the case of vertical stacking, the second stack will be to the right of 
the first stack. This is useful for large projects to avoid the edge of the design 
plane. 

 



CROSS SECTION SHEETS - Cross Section Sheet Composition _____________________________________________ Chapter 9 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 9-9 

SHEET STACK COLUMNS 

 

Note Only one of the options on this dialog can be selected. 

Single Stack Cross sections are stacked one column per sheet.  

Baseline X Offset The distance from the left edge of the sheet to the zero offset of the cross sections. 
The baseline of the cross section cell is utilized to determine the zero offset. 

Double Stack Cross sections are stacked two columns per sheet.  

Col 2 Left Edge Offset When the cross sections are to be placed onto the sheet in a double stack mode, the 
zero offset of the first stack of cross sections is determined by the Baseline X Offset. 
The center of the second stack of cross sections is located a distance from the left 
edge of the sheet to the Col 2 Left Edge Offset.  

Triple Stack Cross sections are stacked three columns per sheet.  

Col 3 Left Edge Offset When the cross sections are to be placed onto the sheet in a triple stack mode, the 
zero offset of the first stack of cross sections is determined by the Baseline X Offset. 
The center of the second stack of cross sections is located a distance from the left 
edge of the sheet to the Col 2 Left Edge Offset. The center of the third stack of cross 
sections is located a distance from the left edge of the sheet to the Col 3 Left Edge 
Offset.  

Quadruple Stack Cross sections are stacked four columns per sheet. 

Col 4 Left Edge Offset When the cross sections are to be placed onto the sheet in a quadruple stack mode, 
the zero offset of the first stack of cross sections is determined by the Baseline X 
Offset. The center of the second stack of cross sections is located a distance from the 
left edge of the sheet to the Col 2 Left Edge Offset. The center of the third stack of 
cross sections is located a distance from the left edge of the sheet to the Col 3 Left 
Edge Offset. The center of the fourth stack of cross sections is located a distance 
from the left edge of the sheet to the Col 4 Left Edge Offset.  
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MARGINS AND SPACING 

 

Cross Section Clip 
Limits 

 

Minimum Spacing 
from Top 

Minimum space from the top (expressed in plotter units) of the sheet wherein no 
cross section data is drawn by the software. Note the space may be larger than 
the specified value in order to align the top cross section on the major grids. 

Minimum Spacing 
from Bottom 

Minimum space (expressed in plotter units) from the bottom of the sheet wherein 
no cross section data is drawn by the software. Note the space may be larger than 
the specified value in order to align the bottom cross section on the major grids. 

Left Clip Offset The sheet layout software also provides the capability to specify the horizontal 
region outside which cross section data is clipped and not included. Defined in 
terms of plotting units, this value determines the portion of the left side of the 
sheet wherein a horizontal clear space is maintained.  

Right Clip Offset Defined in terms of plotting units, this value determines the portion of the right 
side of the sheet wherein a horizontal clear space is maintained. 

Minimum Spacing 
Between Sections 

Minimum space between cross sections on the sheet expressed in plotter units 
(e.g. inches or centimeters). Note the space may be larger than the specified 
value in order to space the section above and below on major grids. 

Maximum Vertical 
Size 

Maximum vertical size for a single cross section such that any elements outside 
this limit are clipped and not included. The distance is measured downward from 
the highest point on the cross section (labels are considered) and expressed in 
plotter units.  
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STATION LABELS 

 

Label Stations Enable the check box to label stations. 

Plot Parameters Double click the Sample graphic to set plot parameters and optional Prefix / 
Suffix. 

Station Label X 
Offset 1 

Defines the distance from the left edge of the sheet to the station label. When 
the cross sections are to be placed onto the sheet in a double stack mode, the 
station label for the left-hand stack of cross sections is determined by the 
Station Horizontal Offset. The station label for the right-hand stack of cross 
sections is located a distance from the left edge of the sheet equaling the 
combined value of the Station Horizontal Offset and the Second Column 
Left Edge Offset values. 

Station Label X 
Offset 2 

If you desire to place station labels on both sides of each cross section, the 
Station Label X Offset 2 can be selected and the distance from the left edge 
of the sheet to the station label is defined. 

Station Label Y 
Offset  

Defines the minimum distance from the bottom of the given cross section to 
the location of the station label. The actual distance from the bottom of the 
cross section to the location of the station label can vary since the station label 
is always placed slightly above a major grid line. If both Station X Offsets are 
selected, the station labels are placed at the same vertical offset as the Station 
Label Y Offset may be specified only once. 
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OFFSET LABELS 

 

Label Offsets Enable the check box to label the offsets. 

Plot Parameters Double click the Sample graphic to set plot parameters and optional Prefix / 
Suffix. 

Offset Label Y Offset 1 Defines the vertical offset from the bottom of the sheet to the offset labels. In 
order to place labels, the check box must be selected. 

Offset Label Y Offset 2 This option can be selected if offset labels at both the bottom and the top of the 
sheets are desired. In order to place labels, the check box must be selected in 
addition to an offset value. 

Offset Increment (mu) Spacing between each offset label.  
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ELEVATION LABELS 

 

Label Elevations Enable the check box to label the elevations. 

Plot Parameters Double click the Sample graphic to set plot parameters and optional Prefix / 
Suffix. 

Elevation Label X 
Offset 1 

Defines the distance from the left edge of the sheet to the elevation labels. When 
the cross sections are to be placed onto the sheet in a double stack mode, the 
elevation labels for the left-hand stack of cross sections are determined by the 
elevation horizontal offset value. The elevation labels for the right-hand stack of 
cross sections are located a distance from the left edge of the sheet equaling the 
combined values of the elevation horizontal offset and second column left offset 
values.    

Elevation Label X 
Offset 2 

If elevation labels are placed on both sides of each cross section, the Horizontal 
Offset Elevation 2 can be selected and the distance from the left edge of the 
sheet to the elevation label can be defined. 

Elevation   
Increment (mu) 

Determines the incremental values for which elevations are presented. For 
example, given a cross section that ranges between elevation 28.75 and 41.54 
and given an increment = 5, the sheet layout software would draw the following 
elevation labels: 30, 35, 40. At least three elevation label text strings are drawn 
for each cross section. 

Add Top Elevation 
Label 

Selecting this check box adds another elevation label above the current labels 
placed within the elevation labels parameters. If two sets of elevations labels are 
placed (one on each side of the section), the top elevation is added to both. 

Add Bottom 
Elevation Label 

Selecting this check box adds another elevation label below the single label 
placed within the elevation labels parameters. If two sets of elevations labels are 
placed (one on each side of the section), the bottom elevation is added to both. 
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EARTHWORK QUANTITY LABELS 

 

Label 
Earthwork 
Quantities 

When the check box is selected, GEOPAK places earthwork quantities onto sheets based 
on ASCII file quantities.  

Column Data  

Item ID After the earthwork ASCII file has been defined, the Item ID reflects the number of the 
column in the ASCII file. 

X Offset For each column to be utilized in sheets, The X and Y Offsets need to be defined. The X 
Offset is oriented the same as all other sheet layout options: relative to the beginning x 
and y coordinate. 

Y Offset The Y Offset is oriented from the station vertical offset. 

Display/Sample Unique parameters may be defined for each quantity. Click on Sample to set symbology.  

Plot This check box can be enabled or disabled.  If the check box is checked (enabled), then 
the earthwork quantity will be plotted on the sheets.  If the check box is not checked 
(disabled), then the earthwork quantity will not be plotted on the sheets. 

Earthwork 
Quantity File 

File created during the earthwork processing, specifically for use with sheets.  
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SHEET LABELS 

 

Name The name given to the label. This is optional and is used more for the user’s benefit 
(i.e. it makes it easy to look at the dialog and know what label is what).  

Type There are 4 types of labels: 

 
Sheet Number When this option is selected, the user must enter the beginning sheet number in 

the Label field. This sheet number will be incremented for each subsequent sheet. 
Begin Station Beginning station of each sheet. This is calculated by the software automatically. 

End Station Ending station of each sheet. This is calculated by the software automatically. 
Custom When this option is selected, the user can enter any custom label into the Label field. 

X Offset Horizontal offset from the sheet origin. This can be keyed in or use the DP Label 
Justification Point icon to have GEOPAK automatically compute the offset oriented 
from the DP Origin. 

Y Offset Vertical offset from the sheet origin. This can be keyed in or use the DP Label 
Justification Point icon to have GEOPAK automatically compute the offset oriented from 
the DP Origin. 

 
DP Origin Used to ID the sheet origin location. 
Label Used for keying in a label when either the Sheet Number or the Custom labels are 

selected. 
Display Unique parameters may be defined for each label. Click on Sample to set symbology.   

Note When creating new labels, the program assumes that sheets have already been placed at the current 
sheet scale. It will divide the given X and Y offsets by the scale of the active sheet to populate the X 
and Y offsets in the list box.   
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DIGITAL INTERPLOT 
If Digital InterPlot is installed on the computer, then this option will be available. If the plotting software is 
not installed, then the options will be dimmed.  FDOT does not use I-Plot. 

 

Create Digital 
InterPlot Plot 
Set 

Enable this check box to create the plot set automatically as the sheets are 
generated.  

IPS File Select the name of the IPS File by clicking on Open IPS File. A Settings file can 
also be viewed. 

Sheet Type When creating an IPS file, a Sheet Type option is supported. This option is used to 
create a Digital Interplot environment variable called GPK_SHEET_TYPE on 
each plot created. This variable may be used to classify/group different types of 
sheets in a plan set. 

The sheet type combo box may be read only or read/write. It defaults to read/write 
such that a custom sheet type may be entered. To restrict it to read only, set the 
environment variable GPK_SHEET_TYPE_OPTIONS_LOCK to 1. The sheet 
type options in the list are also customizable by you via a configuration variable. 
To create the above list, the variable is set: 

GPK_SHEET_TYPE_OPTIONS = Plan;Plan and Profile;Profile;Ditch 
Profiles;Dual Plan;Dual Profile; Maintenance Of Traffic;Cross Sections;Side 
Road Cross Sections;Ditch Cross Sections. 

Open InterPlot 
Organizer 

Opens InterPlot Organizer to view the plot set. 
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Exercise 9.1 Cross Section Sheet Layout with Earthwork  
In this exercise, the user will layout our cross sections onto sheets with the earthwork quantities. 

The files for these exercises are included in the Chapter 8 exercise file that you have already unzipped. 

1. Open the design file C:/e/Projects/228079115201/roadway/RDXSRD01.dgn. 

2. Change the active model to Rdxsrd_shg. 

 

3. Access Project Manager. 

4. From Road Project, click the Cross Sections Sheets icon.  

 

5. Create a new run named BL817 and access the Cross Section Sheet Composition dialog. 

Note When accessing the Cross Section Sheet Composition dialog for the first time and until a sheet DGN 
file is defined, the user will get the following Alert dialog. You will have to click OK 4 times to dismiss 
this dialog. 
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6. Select the sheet XSSHEET20_10EW Rt. 
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7. Select Sheet DGN File. 

 

8. Enable the check box for Detach Existing Sheets before Processing. 

 

9. Select or key-in RDXSRD01.DGN as the Sheet DGN File name. 

 

10. Select Earthwork Quantity Labels. 
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11. Select or key-in the file name earth.txt for the Earthwork Quantity File. 

 

12. Select File > Save Settings.   

13. Click the Layout Sheets icon. The cross sections will attach as reference files and laid out on the 
sheets. 

 

 

14. Close the Cross Section Sheet Composition dialog. When prompted to Save Settings, click Yes. 

15. Review the sheets. 

 

Exercise 9.2 Modifying the XS Sheet Layout 
In this exercise, the user will save the Sheet Library to our project directory and then modify our sheet 
layout preferences. 

1. Access the previously created Cross Section Sheet run. 

2. Select File > Sheet Library > Save As. 

 

  



CROSS SECTION SHEETS - Cross Section Sheet Composition _____________________________________________ Chapter 9 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 9-21 

3. Save the file in your \roadway directory using the name BL817.xssl as shown. 

 

4. The dialog will automatically update and begin to use the newly created BL817.xssl sheet library.  

 

5. Select Sheet Stack Orientation and change the Number of Sheets per Column to 5. 
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6. Select Station Labels and change the Station Label Y Offset to 10. 

 

7. Select Elevation Labels and change the Elevation Increment (mu) to 5. 

 

8. Select File > Sheet > Update. 

9. Select File > Sheet Library > Save. 

10. Click the Layout Sheets icon. The cross sections will lay out on the sheets. 

 

11. Close the Cross Section Sheet Composition dialog. When prompted to Save Settings, click Yes. 

12. Review the sheets and then exit MicroStation. 
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10 CROSS SECTION REPORTS 

OBJECTIVES 
• Overview of several Cross Section Reports 

• Exercise to create an FDOT GEN file 

WORKFLOW 
The GEOPAK Cross Section Report Utility can extract many different 
reports from existing and proposed cross-sections.  For each report generated, 
the user must set the parameters of the existing and/or proposed cross 
sections.  GEOPAK also provides an option to make custom headers for each 
of the reports via the User pull down menu. 

 

 

 

 

 

ACCESSING CROSS SECTION REPORTS 
The Cross Section Reports dialog can be accessed by selecting:  

• From the MicroStation Menu by selecting: Applications > 
ROAD > Cross Sections > Reports.  

• From Road Project by clicking the Reports & XS Quantities 
icon. 

• By selecting the Cross Section Reports icon from the ROAD 
tool frame. 
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CUSTOMIZE REPORT HEADER 
From the XS Report dialog, select User > Preferences.  To activate the individual fields simply toggle on 
the box next to the desired field.  Once the user has completed the dialog box, the information will be saved 
as an .hdr file.  This allows for the creation of a separate header for each type of report.  The tolerance field 
determines the maximum gap allowed between cross section elements. 

 

CLEARING REPORT 

 

The Clearing Report is useful for obtaining clearing and grubbing quantities.  For each station, GEOPAK 
will list the clearing distance on each side of the chain and the width of any exception.  The user can obtain 
the results in the appropriate units.  Toggle boxes for Cut Slope Rounding, Additional Clearing in Cut and 
Fill, and Minimum Clearing Width are provided for increased control over the output. 

Job / Chain  At the top of the dialog, the Job number and Chain are required. 

Begin/End Station GEOPAK determines the beginning and ending station within the MicroStation 
file and they are noted below the chain and placed in the key-in areas. 
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Search Criteria   

Existing Ground Line The designer may key-in the required parameters, leaving the wide 
range of defaults where specific parameters are not needed.   

Proposed Finish Grade As with the Existing Ground Line, only enough parameters to uniquely 
identify the Proposed Finish Grade are required. 

Clearing Distance  Below the Proposed Finish Grade section are four optional features. 

Cut Slope Rounding  Since the graphical cross sections typically do not show slope 
rounding, the user can specify an additional clearing distance outside the linear slope 
stake to account for cut slope rounding.  

Additional Clearing in Cut  Horizontal distance added in a cut situation. 

Additional Clearing in Fill  Horizontal distance added in a fill situation (as determined by 
the element which ties to existing ground) 

Minimum Clearing Width   If the computed minimum clearing width is less than the 
specified value, the software will utilize the specified value. 

All values are in master units (i.e. feet or meters).  GEOPAK’s application of the Cut 
Slope Rounding, Additional Clearing in Fill and the Minimum Clearing Width can 
best be explained utilizing the following illustration. 

 

First, GEOPAK measures the vertical depth of the ditch at the tie down point.  (D in the 
illustration).  That depth is then compared to the value specified in the Cut Slope 
Rounding field in the dialog.  The computed Minimum Clearing Width in the two 
conditions is: 

o If the Cut Slope Rounding > Ditch Depth, then the computed minimum 
clearing width = the Ditch Depth (D) + Additional Clearing in Cut value. 

o If the Cut Slope Rounding < Ditch Depth, then the computed minimum 
clearing width = Cut Slope Rounding value + Additional Clearing in Cut 
value. 

Now that we have the computed Minimum Clearing Width, its value is compared to the 
Minimum Clearing Width specified in the dialog.   

o If the dialog value is more than the computed value, then the dialog value 
is utilized.   

o If the computed value is more than the dialog value, then the computed 
value is utilized.   

As seen in the illustration the minimum clearing width (W) is measured (horizontally) 
from the tie down point. 

Subtotal Stationing  Subtotals are also supported for both Even and Incremental stationing.  The 
increment is defined in the Sub Every field, while the station of the first subtotal is 
defined in the First Sub At field.  
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Except Width  When selected, the dialog depicted below is invoked. 

 

Fields are supported for Begin Station, End Station, and Exception Width.  Simply type 
in the values in the keyin fields at the bottom of the dialog and press the Add icon.  The 
information is then displayed in the list box.  

To delete a line, highlight the desired line, then press the Delete icon. 

Standard File options are supported:  Open, Save, Save As, and Exit.  Utilizing these file 
options, the user can store exception widths for recall in a subsequent session. 

Additional Distance via Station  When selected, the dialog depicted below is invoked. 

 

Fields are supported for Begin Station, End Station, and Width.  Simply type in the 
values in the keyin fields at the bottom of the dialog and press the Add icon.  The 
information is then displayed in the list box.  

To delete a line, highlight the desired line, then press the Delete icon.   

Standard File options are supported:  Open, Save and Save As.  Utilizing these file 
options, the user can store additional clearing widths by station ranges and side for recall 
in a subsequent session. 

Pause on Each XS  An option for processing sections one at a time can be utilized by activating the 
Pause on Each XS toggle at the bottom of the dialog.  When activated, GEOPAK will 
process the first section, display the cross section on the screen (within the limits of the 
cell), and display the station in the Current Station output field located at the top of the 
dialog.  The elements specified in the search criteria are also highlighted.  To continue 
to the next cross section, simply press the Apply icon on the bottom of the dialog. 

ASCII File You identify the name of the ASCII report at the bottom of the dialog.  The designer has 
the option of keying in the file name, or upon selection of the Select File icon ( ), the 
Report File dialog will appear, allowing the designer to select the desired file.  The file 
will be placed in the current directory, unless a full path is specified.  If the specified file 
name already exists, the file will be overwritten with no warning message given.   

Apply  When the dialog has been completed, simply select the Apply icon to begin the report 
generation.  



CROSS SECTION REPORTS - DTM Proposed 3D Report _________________________________________________ Chapter 10 

FDOT GEOPAK for Roadway Designers - Advanced ©2011 FDOT 10-5 

DTM PROPOSED 3D REPORT 

 

GEOPAK locates specified proposed cross section elements and existing ground, and generates an x, y, z 
file (GEOPAK .DAT file) of vertices for break lines suitable for use with GEOPAK's Digital Terrain 
Modeling.  Each cross section generates one break line. In the hierarchy, the path follows (from left to 
right) existing ground until a proposed finish element is intersected. The proposed path is followed until it 
ties back to an existing ground element.  

Job / Chain At the top of the dialog, the Job number and Chain are required.  GEOPAK determines 
the beginning and ending station within the MicroStation file and they are noted below 
the chain and placed in the key-in areas. 

Search Criteria The next two sections specify the search criteria for the Existing Ground Line and 
Proposed Finish Grade.  The designer may key-in the required parameters, leaving the 
wide range of defaults where specific parameters are not needed.      

ASCII File At the bottom of the dialog, the user specifies the name of the ASCII file to be 
generated.  The designer has the option of keying in the file name, or upon selecting the 
Select File icon ( ) which will bring up the Report File dialog, allowing the designer 
to select the desired file.  The file will be placed in the current directory, unless a full 
path is specified.  If the specified file name already exists, the file will be overwritten 
with no warning message given.   

Apply  When the dialog has been completed, simply select the Apply icon to begin the report 
generation.  
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MULTI-LINE REPORT 

 

This report is useful in creating a GEN file for use by Construction personnel or exporting templated cross 
sections to various data collector formats.   

• Begin by entering the job number, chain name and station limits.   

• Next, enter the symbology for each surface to be traced.   

• Once all the parameters have been entered, the new cross section elements may be drawn to 
the design file or the user may choose the display only option.  An ASCII text file will be 
generated.  
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PROFILE GRADE REPORT 

 

The Profile Grade Report is one of the most versatile reports available.  It prints existing ground and 
design grade elevations and low point elevations for each cross section.  Additionally, this report has the 
ability to search either for the low points or any text string that you specify and create horizontal and 
vertical alignments and store them directly into the .gpk.  Horizontal alignments created from this report 
will have no curves. 

Job / Chain At the top of the dialog, the Job number and Chain are required.  GEOPAK determines 
the beginning and ending station within the MicroStation file and they are noted below the chain and 
placed in the key-in areas.  

Search Criteria The next two sections specify the search criteria for the Existing Ground Line and 
Proposed Finish Grade.  The designer may key-in the required parameters, leaving the wide range of 
defaults where specific parameters are not needed. 

Report Options  Three reports are supported in the center of the dialog:  Criteria Elements, Search Text 
and Offset.  When selected, the dialog dynamically changes to reflect the selected 
option.   

Criteria Elements The Criteria Elements option utilizes the graphic elements to 
determine the low point on the proposed finish grade surface on the left and right side of 
the section.   

Search Text    The Search Text option utilizes text placed during the proposed cross section 
processing to generate a profile.   

Offset  The Offset option creates a profile for any given chain and horizontal offset value. 
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CRITERIA ELEMENTS   
Low Point > Store Horizontal Alignment:   The designer has the option to create a chain on 

either or both sides at the low point by simply activating the toggle to the left. 

Beginning Point Number  Must be specified as GEOPAK will create a series of POTs.  No curves 
will be fit into the chain.  An initial stationing of 0+00 will be utilized.   

Left Chain or Right Chain:  Activate the appropriate toggle to indicate which chain or, if 
both are desired, activate both toggles, then specify the name of the chain(s) to be 
generated.   

Note The chain name should conform to standard GEOPAK convention, i.e. 1-9 alpha numeric characters 
with no special characters. 

Low Point > Store Vertical Alignment:  The designer has the option to create a profile on either or 
both sides at the low point by simply activating the toggle to the left.   

Left Profile or Right Profile:   Activate the appropriate toggle to indicate which profile is 
desired next to or, if both are desired, activate both toggles, then specify the name of the 
profiles(s) to be generated.   

Note The profile names should conform to standard GEOPAK convention, i.e. 1-9 alpha numeric 
characters with no special characters.   

Stationing the profiles:   Two options (via a toggle) are available: 

Station Design Alignment  - The stationing of the Chain listed in the top of the dialog 
will be utilized as the profile stationing.  In this case, creation of the horizontal 
alignment is not necessary. 

Station Low Point Alignment

  

 - The stationing of the chain created from the Store 
Horizontal alignment will be utilized.  In this case, the Store Horizontal Alignment 
and appropriate chain toggles must be activated, and the chain name must be keyed 
into the dialog box. 
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SEARCH TEXT  

 

Text   Enter the text string located on the cross section, in this case EOP.   

Store Profile  If active, a profile named EOP1 will be generated.   

Station Design Alignment  The stationing of the chain is utilized. 

Add  Select to add the information is to the list box.  

ASCII File At the bottom of the dialog, specify the name of the ASCII file to be generated.  The 
designer has the option of keying in the file name, or upon selection of the Select File 
icon, the Files dialog is invoked, allowing the designer to select the desired file.  The 
file is placed in the current directory, unless a full path is specified. If the specified file 
name already exists, the file will be overwritten with no warning message given.  
Standard File utilities (Open, Save, Save As) are supported to save the dialog settings 
for subsequent use. 

Apply  When the dialog has been completed, simply select the icon to begin the report 
generation. 
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OFFSET 

 

Offset   Enter to be utilized for the profile.   

Store Profile  The name of the profile to be created.   

Station Design Alignment  Selection utilizes the stationing of the chain.  

 Add   Select to add the information to the list box.   

ASCII File  At the bottom of the dialog, specify the name to be generated.  The designer has the 
option of keying in the file name, or upon selection of the Select File icon ( ), the 
Report File dialog is invoked, allowing the designer to select the desired file.  The file is 
placed in the current directory, unless a full path is specified. If the specified file name 
already exists, the file will be overwritten with no warning message given. 

Apply  When the dialog has been completed, simply select the icon to begin the report 
generation.   
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SEEDING REPORT 

 

For each station, the Seeding Report provides seeding slope distances right and left.  Then GEOPAK 
computes the average slope distance on each side, and uses the results to compute seeding areas.  Optional 
subtotals can also be requested.  To invoke the report, press the Seeding push icon on the XS Reports 
dialog.     

Job / Chain At the top of the dialog, the Job number and Chain are required.  GEOPAK determines 
the beginning and ending station within the MicroStation file and they are noted below the chain and 
placed in the key-in areas. 

Search Criteria The Existing Ground Line, Proposed Finish Grade and Candidate Seeding Elements.  
The designer may key-in the required parameters, leaving the wide range of defaults where specific 
parameters are not needed.  Candidate Seeding Elements specifies the portions of the cross sections that 
will be seeded if all slope conditions are met.  

 Max Allowable Slope  This dictates to the software the maximum slope that will be included in the 
calculations.  For example, if the Maximum Allowable Slope is set to 2:1 (Run:Rise), 
then a cross section element with a slope of 1:1 will not be included in the calculations.  
Two key-in fields are provided for the values and an option icon specifies Run:Rise or 
Rise:Run.  If this option is desired, simply activate the toggle to the left of the Max 
Allowable Slope. 

Subtotal Split Slope   This feature (when activated by the toggle to the left) will split the area 
quantities based on the provided slope.  For example, if the specified Subtotal Split 
Slope is 3:1, then the area quantities will be split into areas steeper than 3:1 slope and 
areas flatter than or equal to a 3:1 slope. 

Sub Every  Subtotals are provided at the user-defined intervals defined by Sub Every keyin field.   

Increment or Even   Specifies whether the distances should be calculated along the alignment or whether 
the distances should be rounded to the even station.   
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First Sub At  Keyin field identifies the first subtotal station as well as the station from which subtotals 
are calculated. 

ByPass Segments  

 

Any combination of the four options can be activated via the toggle(s) to the left.  To 
determine whether the cross section is in Cut or Fill, the software utilizes the segment 
which ties to existing ground.  When the software encounters a condition which has 
been activated, it will ignore the specified number of segments emanating from tie down 
point and moving towards centerline.   

For example, if a cross section has five Candidate Seeding Elements segments on the 
left and is in a Cut situation at the tie down point, and utilizing the dialog above, 
GEOPAK will identify the five segments, ignore the two closest to the tie down point, 
and utilize the remaining three for computations.  If the right side of the cross section 
has six Candidate Seeding Elements and is in a Fill situation, GEOPAK will identify 
the six segments, ignore the tie down segment, and utilize the remaining five for 
computations. 

Additional Distance  

 

Any combination of the three options can be activated via the toggle(s) to the left.  To 
determine whether the cross section is in Cut or Fill, the software tests the segment that 
ties to existing ground.  When encountering an activated condition, the software will 
add  specified Horizontal Distance (in master units) to the dialog to the measured the 
distance on the cross section (or subtract from, if the value is a negative number).   
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Additional Distance via Station    Select if the additional seeding is not consistent throughout the project 
to specify Additional Distances by station range, right, left, or right and left. 

 

Key-in the desired stations, Width, and select the side option.   

Press the Add icon, which populates the list box.   

To modify a line, highlight the line, which populates the edit fields.  Make the desired 
change, and then press the Modify icon.  The list box updates to the edited data.   

To delete a line, simply highlight the line, then press the Delete icon. 

Report Decimal  The number of decimal places to be used in the report should be specified in this field.  
The options available are 0 through 6. 

Pause on Each XS  An option for processing sections one at a time.  When activated, GEOPAK will 
process the first section, display the cross section on the screen (within the limits of the 
cell), and display the station in the Current Station display field located at the top of 
the dialog.  The elements specified in the search criteria are also highlighted.  To 
continue to the next cross section, simply press the Apply icon on the bottom of the 
dialog. 

ASCII File  Specify the name of the file to be generated.  The designer has the option of keying in 
the file name, or upon selection of the Select File icon ( ), the Report File dialog will 
appear, allowing the designer to select the desired file.  The file will be placed in the 
current directory, unless a full path is specified. If the specified file name already exists, 
the file will be overwritten with no warning message given.   

Apply  When the dialog has been completed, select to begin the report generation.  
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SLOPE STAKE REPORT 

 

The slope stakes report generates offsets, elevations, as well as superelevation information.  This is a 
special format report developed for the U.S. Federal Highway Administration and is traditionally used 
extensively on FHWA construction projects.  To invoke the report, press the Slope Stake push icon on the 
XS Reports dialog.   

Job / Chain  At the top of the dialog, the Job number and Chain are required.  GEOPAK determines 
the beginning and ending station within the MicroStation file and notes below the chain and placed in the 
key-in areas. 

Search Criteria The next section specifies the search criteria for the Existing Ground Line and 
Proposed Finish Grade.  The designer may key-in the required parameters, leaving the wide range of 
defaults, not needing any specific parameters. 

Report Format    FHWA Version 1 and 2, Nebraska, and Wyoming.   

Reference Hub Cell Name   Identifies any MicroStation cells previously drawn onto the cross sections to 
indicate Reference Hubs placed in the field during the original ground survey. 

Pause on Each XS    An option for processing sections one at a time.  When activated, GEOPAK will 
process the first section, display the cross section on the screen (within the limits of the 
cell), and display the station in the Current Station display field located at the top of 
the dialog.  The elements specified in the search criteria are also highlighted.  To 
continue to the next cross section, simply press the Apply icon on the bottom of the 
dialog. 

ASCII File Specify the name of the file to be generated.  The designer has the option of keying in 
the file name, or upon selection of the Select File icon ( ), the Report File dialog will 
appear, allowing the designer to select the desired file.  The file will be placed in the 
current directory, unless a full path is specified. If the specified file name already exists, 
the file will be overwritten with no warning message given.   

Apply  When the dialog has been completed, select to begin the report generation.  
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Exercise 10.1 Create a GEN File using Multi-Line Report 
In this exercise, the user will create a GEN file of cross section data for Construction personnel. 

The files for these exercises are included in the Chapter 8 exercise file that you have already unzipped. 

1. Open the design file C:/e/Projects/228079115201/roadway/RDXSRD01.dgn.  

2. Change the active model to Rdxsrd. 

 

3. Access Project Manager. 

4. From Road Project, click the Reports & XS Quantities icon.  

 

5. Select User > Preferences from the XS Report dialog to see the Report Header dialog. 

 

6. Verify that the tolerance is set 0.1 for all cross section reports. 

7. Close the Report Header dialog. 

8. Click Multi-Line from the XS Report dialog. 

9. The Job number, Chain and Station fields should be filled out. 
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10. Click the XS Elements icon. 

11. Select the following Lv Names to define the finished grade: 

• CandG_px 

• Driveway_px 

• ShldrUnpaved_px 

• Sidewalk_px 

• Slopes_px 

12. Close the Candidate Elements dialog. 

 

13. Set the Top/Bottom combo to Top and the Primary/Secondary combo to Primary. 

14. Make sure Label is set to T.  

  

15. Add this surface to the list.  

 

16. Click the XS Elements icon again.     

17. Click Reset to clear the Lv Names field. 

18. Select the following Lv Name to define the existing grade: 

• XSGrdLine_ex 

 

19. Close the Candidate Elements dialog. 

20. Set the Top/Bottom combo to Top and the Primary/Secondary combo to Secondary. 
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21. Add this surface to the list.    

 

22. Set the Output Format to GEOPAK. 

23. Enable Pause on Each XS toggle and then click Apply to process the first section. 

24. Disable the Pause on Each XS toggle and then click Apply to process the remaining cross sections.  

25. Close the Multi-Line and XS Report dialogs. 

26. Review the GEN file with a Text Editor.  The following is a Sample output. 

 

GROUND MULTILINE DATA LINE TYPE S                                                               
XS 76+00.00 R   1      -138.60    5.35    -125.87    5.30    -118.79    5.35    -118.12    5.35 
XS 76+00.00 R   1      -116.55    5.36    -116.08    5.36    -115.42    5.37    -114.81    5.38 
XS 76+00.00 R   1      -112.66    5.41    -112.01    5.41    -107.33    5.42    -106.89    5.43 
XS 76+00.00 R   1      -100.68    5.43    -100.10    5.44     -99.23    5.45     -98.35    5.46 
XS 76+00.00 R   1       -97.04    5.47     -96.18    5.47     -79.38    5.68     -76.97    5.72 
XS 76+00.00 R   1       -74.95    5.23     -68.95    5.35     -68.44    5.35     -68.28    4.85 
XS 76+00.00 R   1       -55.95    5.32     -39.95    5.76     -28.95    5.98     -17.95    6.20 
XS 76+00.00 R   1         4.55    6.40       4.72    6.90       5.22    6.90       7.88    6.77 
XS 76+00.00 R   1         8.55    6.27      10.05    6.24      21.05    6.04      32.05    5.82 
XS 76+00.00 R   1        50.11    5.30      54.11    5.08      66.67    4.38      67.90    4.24 
XS 76+00.00 R   1        73.00    4.21      73.54    4.18      78.47    4.07      92.91    3.90 
XS 76+00.00 R   1        99.23    2.82     100.43    1.77     128.33    1.79     138.69    1.77 
XS 77+00.00 R   1      -139.87    6.21    -138.59    6.04    -132.04    5.60    -131.54    6.13 
XS 77+00.00 R   1      -114.60    5.72    -114.18    6.12    -113.52    5.98    -111.52    5.95 
XS 77+00.00 R   1      -101.09    5.98     -99.93    5.97     -99.56    5.49     -94.08    5.49 
XS 77+00.00 R   1       -78.53    5.49     -77.31    5.52     -75.95    4.84     -74.95    4.86 
XS 77+00.00 R   1       -68.45    4.98     -68.28    4.48     -66.95    4.65     -55.95    4.98 
XS 77+00.00 R   1       -28.95    5.68     -17.95    5.90       0.00    6.26       4.55    6.35 
XS 77+00.00 R   1         5.22    6.85       7.88    6.97       8.38    6.97       8.55    6.47 
XS 77+00.00 R   1        21.05    6.24      32.05    6.02      47.05    5.42      68.21    3.97 
XS 77+00.00 R   1        72.47    3.95      82.37    4.28      85.45    4.35      93.68    3.91 

XS 77+00.00 R   1        96.60    3.90      97.40    3.53      98.14    3.38      99.06    
2.27 
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